Help Center/ MapReduce Service/ Component Operation Guide (LTS)/ Using Ranger/ Ranger Troubleshooting/ Ranger Fails to Be Started During Cluster Installation
Updated on 2026-06-27 GMT+08:00

Ranger Fails to Be Started During Cluster Installation

Question

Ranger fails to start during cluster installation and the Manager process task list shows database errors like "ERROR: cannot drop sequence X_POLICY_REF_ACCESS_TYPE_SEQ". Measures should be taken to fix the issue and complete the Ranger installation.

Answer

This issue typically occurs when two RangerAmdin instances are deployed

If the installation fails, log in to MRS Manager, manually restart one RangerAdmin instance, and then restart the remaining instance.