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Actualización más reciente 2025-03-05 GMT+08:00

¿Por qué veo el mensaje de error "Incorrect app authentication information" cuando invoco a una API?

Es posible que aparezcan los siguientes errores relacionados con la información de autenticación de aplicaciones:

Incorrect app authentication information: app not found, appkey xxx

{ 
  "error_msg": "Incorrect app authentication information: app not found, appkey 0117***e5e1",    
  "error_code": "APIG.0303",    
  "request_id": "a532***5aca"
}

Causas posibles

El AppKey es incorrecto.

Solución

  1. En el panel de navegación de la consola de APIG, seleccione API Management > Credentials.
  2. Haga clic en el nombre de credencial correspondiente para ir a la página de detalles.
  3. Verifique la Key y vuelva a configurar el AppKey.

Incorrect app authentication information: verify signature fail, canonicalRequest

{    
  "error_msg": "Incorrect app authentication information: verify signature fail, canonicalRequest:GET|/test/||host:d7da***3df7.example.com|x-sdk-date:20230527T015431Z||host;x-sdk-date|e3b0c***52b855",   
  "error_code": "APIG.0303",    
  "request_id": "cb14***62dc"
}

Causas posibles

El algoritmo de firma es incorrecto, y la firma calculada por el cliente es diferente de la calculada por APIG.

Solución

Para más detalles, véase Incorrect IAM authentication information: verify aksk signature fail.

Incorrect app authentication information: signature expired

{
  "error_msg": "Incorrect app authentication information: signature expired, signature time:20230527T000431Z,server time:20230527T020608Z",
  "error_code": "APIG.0303",    
  "request_id": "fd65***b8ad"

}

Causas posibles

La diferencia entre la marca de hora del cliente x-sdk-date y el tiempo del servidor APIG supera los 15 minutos.

Solución

Compruebe si la hora del cliente es correcta.