Help Center/ Scalable File Service/ User Guide/ Troubleshooting/ Mounting a File System Fails
Updated on 2025-06-27 GMT+08:00

Mounting a File System Fails

Symptom

When a file system is mounted to servers using the mount command, message access denied is displayed.

Possible Causes

  • Cause 1: The file system has been deleted.
  • Cause 2: The server and the mounted file system are not in the same VPC.
  • Cause 3: The mount point in the mount command is incorrect.
  • Cause 4: The IP address used for accessing SFS is a virtual IP address.

Fault Diagnosis

Take troubleshooting measures based on possible causes.

Solution

  • Cause 1: The file system has been deleted.
    Log in to the management console and check whether the file system has been deleted.
    • If yes, create a file system or select an existing file system to mount. Ensure that the server and the file system reside in the same VPC.
    • If no, go to Cause 2.
  • Cause 2: The server and the mounted file system are not in the same VPC.
    Log in to the management console and check whether the server and the file system are in the same VPC.
    • If yes, go to Cause 3.
    • If no, select a file system that is in the same VPC as the server.
  • Cause 3: The mount point in the mount command is incorrect.
    1. Log in to the management console and check whether the mount point is the same as the one in the mount command.
    2. If the mount point in the mount command is incorrectly entered, correct it and run the command again.
  • Cause 4: The IP address used for accessing SFS is a virtual IP address.

    Log in to the server and run the ping command and use the server IP address to access SFS. Check whether the service is reachable. See Figure 1.

    • If yes, the network problem has been resolved. Check other possible causes.
    • If no, the network is disconnected. Use the server's private IP address and the ping command to access SFS and check whether the service is reachable.
      Figure 1 Running the ping command to access SFS