Updated on 2022-02-22 GMT+08:00

Mounting a File System Times Out

Symptom

When the mount command is executed to mount a file system to ECSs, the message timed out is displayed.

Possible Causes

  • Cause 1: The network status is not stable.
  • Cause 2: The network connection is abnormal.
  • Cause 3: The operating system of the ECS where the file system is to be mounted is Ubuntu18 or a later version.

Fault Diagnosis

After the network fault is excluded, run the mount command again.

Solution

  • Cause 1 and Cause 2: The network status is not stable or the network connection is abnormal.

    Re-mount the file system after the network issue is addressed.

    • If the patch is uninstalled successfully, no further action is required.
    • If the problem persists, see the solution for cause 3.
  • Cause 3: The operating system of the ECS where the file system is to be mounted is Ubuntu18 or a later version.
    1. Check whether the target ECS running Ubuntu18 or a later version is a private image.
      • If yes, go to 3.
      • If no, go to 2.
    2. Convert the public image ECS to a private image.
      1. To create a private image based on an existing ECS, see section "Creating an Image" in the Elastic Cloud Server User Guide
      2. Use the private image created in 2.a to create an ECS or switch the ECS to the private image created in 2.a. For details, see section "Changing the OS" in the Elastic Cloud Server User Guide.
    3. Log in to the ECS and mount the file system again.