Why Are There Garbled Characters in Event Data I Exported from WAF?
On the Events page in the WAF console, you can click Export to export event data. If you open the exported file with Excel, there will be garbled characters.
Causes
The exported event data is in CSV format. If you use Excel to open the file, there will be garbled characters. This happens when the exported CSV file is encoded in UTF-8, as Excel opens file in ANSI format.
Solutions
Method 1
- Open the CSV file with Excel in the following manner:
- Create an Excel file.
- Choose Data > Get External Data From Text.
- Select the exported CSV file and click Import. The Text Import Wizard dialog box is displayed.
- Select Delimited and click Next.
- Deselect Tab, select Comma, and click Next.
- Click OK.
- In the Import Data dialog box, click OK.
- Use a text editor such as Notepad or use WPS to open the CSV file.
Method 2
- Use the Notepad text editor to open the exported CSV file.
- Choose .
- Select ANSI for Encoding, change the file name but keep the extension .csv unchanged to avoid overwriting the original file, and click Save.
Use Excel to open the new CSV file. Generally, characters can be displayed normally.
Protection Event Logs FAQs
- Can WAF Log Protection Events?
- Can I Obtain WAF Logs Using APIs?
- How Do I Obtain Data about Block Actions?
- What Does "Mismatch" for "Protective Action" Mean in the Event List?
- How Does WAF Obtain the Real Client IP Address for a Request?
- Can WAF Logs Be Transferred to OBS?
- Can WAF Forward Logs to the Syslog Server?
- How Long Can WAF Protection Logs Be Stored?
- Can I Query Protection Events of a Batch of Specified IP Addresses at Once?
- Will WAF Record Unblocked Events?
- Why Is the Traffic Statistics on WAF Inconsistent with That on the Origin Server?
- Why Is the Number of Logs on the Dashboard Page Inconsistent with That on the Configure Logs Tab?
- Why Are There Garbled Characters in Event Data I Exported from WAF?
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