Help Center > > User Guide> MRS Manager Operation Guide> Alarm Reference> ALM-12043 DNS Resolution Duration Exceeds the Threshold

ALM-12043 DNS Resolution Duration Exceeds the Threshold

Updated at: Dec 31, 2019 GMT+08:00

Description

The system checks the DNS resolution duration every 30 seconds and compares the actual DNS resolution duration with the threshold (the default threshold is 20,000 ms). This alarm is generated when the system detects that the DNS resolution duration exceeds the threshold for several times (2 times by default) consecutively.

To change the threshold, choose System > Threshold Configuration > Device > Host > Network Status > DNS Name Resolution Duration > DNS Name Resolution Duration.

When the hit number is 1, this alarm is cleared when the DNS resolution duration is less than or equal to the threshold. When the hit number is not 1, this alarm is cleared when the DNS resolution duration is less than or equal to 90% of the threshold.

Attribute

Alarm ID

Alarm Severity

Automatically Cleared

12043

Major

Yes

Parameters

Parameter

Description

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

  • Kerberos-based secondary authentication is slow.
  • The ZooKeeper service is abnormal.
  • The node is faulty.

Possible Causes

  • The node is configured with the DNS client.
  • The node is equipped with the DNS server and the DNS server is started.

Procedure

Check whether the node is configured with the DNS client.

  1. On MRS Manager, click Alarms.
  2. Check the value of HostName in the detailed alarm information to obtain the name of the host involved in this alarm.
  3. Use PuTTY to log in to the node for which the alarm is generated as user root.
  4. Run the cat /etc/resolv.conf command to check whether the DNS client is installed.

    If information similar to the following is displayed, the DNS client is installed and started:

    namesever 10.2.3.4 
    namesever 10.2.3.4
    • If yes, go to 5.
    • If no, go to 7.

  5. Run the vi /etc/resolv.conf command to comment out the following content using the number signs (#) and save the file:

    # namesever 10.2.3.4  
    # namesever 10.2.3.4

  6. Check whether this alarm is cleared after 5 minutes.

    • If yes, no further action is required.
    • If no, go to 7.

Check whether the node is equipped with the DNS server and the DNS server is started.

  1. Run the service named status command to check whether the DNS server is installed on the node:

    If information similar to the following is displayed, the DNS server is installed and started:

    Checking for nameserver BIND  
    version: 9.6-ESV-R7-P4 
    CPUs found: 8 
    worker threads: 8 
    number of zones: 17 
    debug level: 0 
    xfers running: 0 
    xfers deferred: 0 
    soa queries in progress: 0 
    query logging is ON 
    recursive clients: 4/0/1000 
    tcp clients: 0/100 
    server is up and running
    • If yes, go to 8.
    • If no, go to 10.

  2. Run the service named stop command to stop the DNS service.
  3. Check whether this alarm is cleared after 5 minutes.

    • If yes, no further action is required.
    • If no, go to 10.

Collect fault information.

  1. On MRS Manager, choose System > Export Log.
  2. Contact the O&M personnel and send the collected log information.

Related Information

N/A

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