Help Center > > User Guide> MRS Manager Operation Guide> Alarm Reference> ALM-25000 LdapServer Service Unavailable

ALM-25000 LdapServer Service Unavailable

Updated at:Sep 08, 2020 GMT+08:00

Description

The system checks the LdapServer service status every 30 seconds. This alarm is generated when the system detects that both the active and standby LdapServer services are abnormal. It is cleared when one or both LdapServer services are normal.

Attribute

Alarm ID

Alarm Severity

Automatically Cleared

25000

Critical

Yes

Parameters

Parameter

Description

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

No operation can be performed for the KrbServer and LdapServer users in the cluster. For example, users, user groups, or roles cannot be added, deleted, or modified, and user passwords cannot be changed on MRS Manager. Authentication for existing users in the cluster is not affected.

Possible Causes

  • The node where the LdapServer service resides is faulty.
  • The LdapServer process is abnormal.

Procedure

  1. Check whether the nodes where the two SlapdServer instances of the LdapServer service reside are faulty.

    1. On MRS Manager, choose Services > LdapServer > Instance to go to the LdapServer instance page. Obtain the host name of the node where the two SlapdServer instances reside.
    2. On the Alarms page of MRS Manager, check whether alarm ALM-12006 Node Fault is generated.
      • If yes, go to 1.c.
      • If no, go to 2.a.
    3. Check whether the host name in the alarm is consistent with the host name in 1.a.
      • If yes, go to 1.d.
      • If no, go to 2.a.
    4. Rectify the fault by following the steps provided in ALM-12006 Node Fault.
    5. In the alarm list, check whether alarm ALM-25000 LdapServer Service Unavailable is cleared.
      • If yes, no further action is required.
      • If no, go to 3.

  2. Check whether the LdapServer process is in the normal state.

    1. On the Alarms page of MRS Manager, check whether alarm ALM-12007 Process Fault is generated.
      • If yes, go to 2.b.
      • If no, go to 3.
    2. Check whether the service name and host name in the alarm are consistent with those of LdapServer.
      • If yes, go to 2.c.
      • If no, go to 3.
    3. Rectify the fault by following the steps provided in ALM-12007 Process Fault.
    4. In the alarm list, check whether alarm ALM-25000 LdapServer Service Unavailable is cleared.
      • If yes, no further action is required.
      • If no, go to 3.

  3. Collect fault information.

    1. On MRS Manager, choose System > Export Log.
    2. Contact the O&M personnel and send the collected log information.

Related Information

N/A

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