Updated on 2024-01-17 GMT+08:00

ALM-44006 Presto Worker Process GC Time Exceeds the Threshold (For MRS 2.x or Earlier)

Description

The system collects GC time of the Presto Worker process every 30 seconds. This alarm is generated when the GC time exceeds the threshold (exceeds 5 seconds for three consecutive times). You can change the threshold by choosing System > Configure Alarm Threshold > Service > Presto > Worker > Presto Garbage Collection Time > Garbage Collection Time of the Worker Process on MRS Manager. This alarm is cleared when the Worker process GC time is shorter than or equal to the threshold.

Attribute

Alarm ID

Alarm Severity

Auto Clear

44006

Major

Yes

Parameter

Parameter

Description

ServiceName

Service for which the alarm is generated.

RoleName

Role for which the alarm is generated.

HostName

Host for which the alarm is generated.

Impact on the System

If the GC time of the Worker process is too long, the Worker process running performance will be affected and the Worker process will even be unavailable.

Possible Causes

The heap memory of the Worker process is overused or inappropriately allocated, causing frequent occurrence of the GC process.

Procedure

  1. Check the GC time.

    1. Go to the cluster details page and choose Alarms.
    2. Select the alarm whose Alarm ID is 44006. Then check the IP address and role name of the instance in Location.
    3. Choose Components > Presto > Instances > Worker (business IP address of the instance for which the alarm is generated) > Customize > Presto Garbage Collection Time. Click OK to view the GC time.
    4. Check whether the GC time of the Worker process is longer than 5 seconds.
      • If yes, go to 1.e.
      • If no, go to 2.
    5. Choose Components > Presto > Service Configuration, and switch Basic to All, and choose Presto > Worker Increase the value of -Xmx (maximum heap memory) in the JAVA_OPTS parameter based on the site requirements.
    6. Check whether the alarm is cleared.
      • If yes, no further action is required.
      • If no, go to 2.

  2. Collect fault information.

    1. On MRS Manager, choose System > Export Log.
    2. Contact the O&M engineers and send the collected logs.

Reference

None