Help Center > > User Guide> Managing Active Clusters> Alarm Reference> ALM-43007 Non-Heap Memory Usage of the JobHistory Process Exceeds the Threshold

ALM-43007 Non-Heap Memory Usage of the JobHistory Process Exceeds the Threshold

Updated at: Mar 31, 2020 GMT+08:00

Description

The system checks the non-heap memory usage of the JobHistory process every 30 seconds. The alarm is generated when the non-heap memory usage of the JobHistory process exceeds the threshold (90% of the maximum memory).

Attribute

Alarm ID

Alarm Severity

Automatically Cleared

43007

Major

Yes

Parameters

Parameter

Description

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

Overhigh non-heap memory usage of the JobHistory process deteriorates JobHistory running performance or even causes OOM, which results in unavailable JobHistory process.

Possible Causes

The non-heap memory of the JobHistory process is overused or inappropriately allocated.

Procedure

  1. Check non-heap memory usage.

    1. On the MRS cluster details page, click Alarms.

      For MRS 1.8.10 or earlier, log in to MRS Manager and click Alarms.

    2. Select the alarm whose Alarm ID is 43007. Then check the IP address and role name of the instance in Location.
    3. Choose Components > Spark > Instances and click the JobHistory for which the alarm is generated to enter the Instance Status page. Then choose Customize > Statistics for the non-heap memory of the JobHistory Process and click OK.
    4. Check whether the used non-heap memory of the JobHistory process reaches 90% of the maximum non-heap memory specified for JobHistory.
      • If yes, go to 1.e.
      • If no, go to 2.
    5. Choose Components > Spark > Service Configuration, and set Type to All. Choose JobHistory > Default. Increase the value of -XX:MaxMetaspaceSize in SPARK_DAEMON_JAVA_OPTS as required.
    6. Check whether the alarm is cleared.
      • If yes, no further action is required.
      • If no, go to 2.

  2. Collect fault information.

    1. On MRS Manager, choose System > Export Log.
    2. Contact the O&M personnel and send the collected log information.

Related Information

N/A

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