Help Center > > User Guide> Managing Active Clusters> Alarm Reference> ALM-14001 HDFS Disk Usage Exceeds the Threshold

ALM-14001 HDFS Disk Usage Exceeds the Threshold

Updated at: Mar 31, 2020 GMT+08:00

Description

The system checks the disk usage of the HDFS cluster every 30 seconds and compares it with the threshold. This alarm is generated when the HDFS disk usage exceeds the threshold and is cleared when the usage is less than or equal to the threshold.

Attribute

Alarm ID

Alarm Severity

Automatically Cleared

14001

Major

Yes

Parameters

Parameter

Description

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

NSName

Specifies the NameService service for which the alarm is generated.

Trigger Condition

Generates an alarm when the actual indicator value exceeds the specified threshold.

Impact on the System

The performance of writing data to HDFS is affected.

Possible Causes

The disk space configured for the HDFS cluster is insufficient.

Procedure

  1. Check the disk capacity and delete unnecessary files.

    1. On the MRS cluster details page, choose Components > HDFS. The Service Status page is displayed.

      For MRS 1.8.10 or earlier, log in to MRS Manager and choose Services > HDFS.

    2. In the Charts area, view the value of the monitoring indicator Percentage of HDFS Capacity to check whether the HDFS disk usage exceeds the threshold.
      • If yes, go to 1.c.
      • If no, go to 3.
    3. Use the client on the cluster node and run the hdfs dfsadmin -report command to check whether the value of DFS Used% is less than 100% minus the threshold.
      • If yes, go to 1.e.
      • If no, go to 3.
    4. Use the client on the cluster node and run the hdfs dfs -rm -r file or directory command to delete unnecessary files.
    5. Wait 5 minutes and check whether the alarm is cleared.
      • If yes, no further action is required.
      • If no, go to 2.a.

  2. Expand the system.

    1. Expand the disk capacity.
    2. Wait 5 minutes and check whether the alarm is cleared.
      • If yes, no further action is required.
      • If no, go to 3.

  3. Collect fault information.

    1. On MRS Manager, choose System > Export Log.
    2. Contact the O&M personnel and send the collected log information.

Related Information

N/A

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