Help Center> MapReduce Service> User Guide> Alarm Reference (Applicable to MRS 3.x)> ALM-50214 Number of Tasks Queuing in the FE Thread Pool for Task Processing Exceeds the Threshold
Updated on 2023-10-10 GMT+08:00

ALM-50214 Number of Tasks Queuing in the FE Thread Pool for Task Processing Exceeds the Threshold

Alarm Description

The system checks the number of queuing tasks in the FE thread pool for processing tasks every 30 seconds. This alarm is generated when the number of queuing tasks exceeds the threshold (10 by default). This thread pool is used by the NIO MySQL Server to process tasks.

This alarm is cleared when the system detects that the number of tasks queuing in the FE thread pool for processing tasks is less than the threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

50214

Minor

Yes

Alarm Parameters

Parameter

Description

Source

Specifies the cluster or system for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Trigger Condition

Specifies the threshold for triggering the alarm.

Impact on the System

The task execution of the entire system becomes slow and blocked.

Possible Causes

Large tasks may block the task execution of the queue.

Handling Procedure

Check the execution status of FE tasks.

  1. On FusionInsight Manager, choose Cluster > Services > Doris. Click the Chart tab, select Connection from Chart Category in the left pane, and view the FE MySQL Port Connections chart. If the number of connections is large, click Instances, select the FE instance, and click the Chart tab. Select CPU and Memory from Chart Category and view the CPU Usage of FE chart. If the CPU usage is high, check the Time field in FE audit log /var/log/Bigdata/audit/doris/fe/fe.audit.log to collect statistics on the average task duration. If the value is also high, the alarm is caused by large concurrent tasks.
  2. After connecting to Doris, run the following command to check whether the default value of queryTimeout is too large. The default value is 300 seconds.

    show variables like 'query_timeout';

    • If yes, go to 3.
    • If no, go to 4.

  3. Run the following command to shorten the timeout period based on site requirements to block the tasks that take a long time:

    set global query_timeout=xxx;

  4. Log in to FusionInsight Manager, choose O&M > Alarm > Thresholds, click the name of the desired cluster, and choose Doris > Queue > Queue Length of Query Execution Thread Pool (BE).
  5. Click the edit button next to Trigger Count, change the number based on site requirements, and click OK.
  6. Click Modify in the Operation column, change the alarm threshold based on site requirements, and click OK.
  7. Wait 10 minutes and check whether the alarm is automatically cleared.

    • If yes, no further action is required.
    • If no, go to 8.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select Doris for the target cluster.
  3. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M personnel and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.