Updated on 2024-06-19 GMT+08:00

ALM-45616 CDL Job Execution Exception

Alarm Description

The system checks whether a CDL job is normal every 60 seconds. This alarm is reported when the CDL job is abnormal. This alarm is cleared when the job is restored or stopped.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

45616

Major

Yes

Alarm Parameters

Parameter

Description

Source

Specifies the cluster for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

JobName

Specifies the job for which the alarm was generated.

Username

Specifies the username of the job for which the alarm was generated.

Impact on the System

This alarm has no impact on the system.

Possible Causes

The CDL task fails to be executed due to incorrect parameter settings or other reasons. On the Job Management page of the CDL web UI, locate the row where the job is located and click Failed/Abnormal running in the Status column to view the failure cause, or view the failure cause in the logs.

Handling Procedure

  1. Log in to FusionInsight Manager as a user who has the CDL job creation or administrator permission.
  2. Choose O&M. In the navigation pane on the left, choose Alarm > Alarms, click in the row where Alarm ID is 45616, and view the name of the job for which this alarm is generated in Location.
  3. Choose Cluster > Services > CDL and click the link next to CDLService UI to go to the CDL web UI.
  4. Locate the row where the failed job is located based on the job name obtained in 2, and click Abnormal running or Failed in the Status column.

  5. On the page that is displayed, view the error information and rectify the fault. For example, Figure 1 shows that the task running on Yarn is manually killed. For details, see trace error information, as shown in Figure 2.

    Figure 1 CDL job exception
    Figure 2 Trace error information

  6. Rectify the fault based on the error information, execute the task again, and check whether the task can be executed successfully.

    • If yes, no further action is required.
    • If no, go to 7.

Collect the fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Select CDL in the required cluster for Service.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time respectively. Then, click Download.
  4. Contact O&M personnel and provide the collected logs.

Alarm Clearance

After the job is successfully restored or stopped, the alarm is cleared if it has been reported.

Related Information

None