Updated on 2024-03-01 GMT+08:00

ALM-45585 IoTDB Service Unavailable

Alarm Description

The system checks the IoTDB service status every 300 seconds. This alarm is generated when the IoTDB service is unavailable. This alarm is cleared when the IoTDB service recovers.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

45585

Critical

Yes

Alarm Parameters

Parameter

Description

Source

Specifies the cluster for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Impact on the System

Users cannot use the IoTDB service properly.

Possible Causes

  • The KrbServer service is abnormal.
  • More than 50% of IoTDBServer instances are faulty.

Handling Procedure

Check whether the KrbServer service on which the IoTDB depends is abnormal.

  1. On FusionInsight Manager, choose O&M > Alarm > Alarms.
  2. In the alarm list, check whether ALM-25500 KrbServer Service Unavailable exists.

    • If yes, go to 3.
    • If no, go to 5.

  3. Handle the alarm by referring to "ALM-25500 KrbServer Service Unavailable."
  4. After ALM-25500 is cleared, wait a few minutes and check whether the alarm HetuServer Service Unavailable is cleared.

    • If yes, no further action is required.
    • If no, go to 5.

Check whether IoTDBServer instances are faulty.

  1. On FusionInsight Manager, choose Cluster > Name of the desired cluster > Service > IoTDB > Instance.
  2. Check whether the percentage of faulty IoTDBServer instances exceeds 50%. If yes, restart the faulty IoTDBServer instances and check whether the status is restored.

    • If yes, no further action is required.
    • If no, go to 7.

Collect the fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, select IoTDB for the target cluster, and click OK.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time respectively. Then, click Download.
  4. Contact O&M personnel and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None