Help Center/ MapReduce Service/ User Guide/ MRS Cluster O&M/ MRS Cluster Alarm Handling Reference/ ALM-45476 Number of Tablets of the KuduTServer Process Exceeds the Threshold
Updated on 2025-08-09 GMT+08:00

ALM-45476 Number of Tablets of the KuduTServer Process Exceeds the Threshold

Alarm Description

The system checks the Kudu monitoring metrics every 60 seconds. This alarm is generated when the number of tablets of the KuduTServer process exceeds the threshold.

This alarm is cleared when the number of tablets of the KuduTServer process becomes normal and the system considers that the Kudu service recovers.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

45476

Minor

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Additional Information

Trigger Condition

Specifies the threshold for triggering the alarm.

Impact on the System

If the number of tablets exceeds the threshold, the query performance of the Kudu engine deteriorates.

Possible Causes

The TServer usage is too high or the TServer load is unbalanced.

Handling Procedure

Handle the Kudu instance exception.

  1. On FusionInsight Manager, choose O&M > Alarm, and check whether alarm ALM-45476 Number of Tablets of the KuduTServer Process Exceeds the Threshold exists.

  2. Choose O&M > Alarm > Thresholds > Kudu. Locate the threshold of this alarm and check whether the number of tablets of the KuduTServer process exceeds the threshold. If yes, change the threshold.
  3. Wait for several minutes, choose O&M > Alarm, and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to Step 4.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select Kudu for the target cluster.
  3. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Send the collected fault logs to O&M personnel for help.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None