ALM-45337 Presto Worker3 Process GC Time Exceeds the Threshold
Alarm Description
The system collects the garbage collection (GC) time of the Presto worker3 process every 30 seconds. This alarm is generated when the GC time exceeds the threshold (exceeds 5 seconds for three consecutive times). This alarm is cleared when the GC time of the worker3 process is less than or equal to the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Auto Cleared |
---|---|---|
45337 |
Minor |
Yes |
Alarm Parameters
Parameter |
Description |
---|---|
ServiceName |
Specifies the service for which the alarm was generated. |
RoleName |
Specifies the role for which the alarm was generated. |
HostName |
Specifies the host for which the alarm was generated. |
Trigger Condition |
Specifies the threshold for triggering the alarm. |
Impact on the System
If the GC time of the worker3 process is too long, the worker3 process performance will be adversely affected, and the worker3 process will even become unavailable.
Possible Causes
The heap memory of the worker3 process is overused or inappropriately allocated, causing frequent occurrence of the GC process.
Handling Procedure
Check the GC duration.
- Log in to FusionInsight Manager and choose O&M > Alarm > Alarms. Locate the row that contains this alarm and view the IP address and role name of the instance in Location.
- On FusionInsight Manager, choose Cluster, click the name of the desired cluster, and choose Services > Presto. On the page that is displayed, click the Instance tab and click the Worker3 instance for which the alarm is generated to access its dashboard. In the upper right corner of the Dashboard page, click the drop-down list icon and select Customize. On the Customize Statistics page, choose Cluster Status, select Presto Garbage Collection Time, and click OK to check whether the GC time is greater than 5 seconds.
- On FusionInsight Manager, choose Cluster, click the name of the desired cluster, and choose Services > Presto. On the page that is displayed, click Configurations and All Configurations, choose Worker3 > JVM, increase the value of Xmx in the JAVA_OPTS parameter, and click Save.
- Return to the Dashboard page, click More, and select Restart Service to restart the service.
- Check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 6.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select Presto for the target cluster.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M personnel and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None
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