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ALM-45276 Abnormal RangerAdmin Status

Updated on 2024-09-23 GMT+08:00

Alarm Description

The alarm module checks the RangerAdmin service status every 60 seconds. This alarm is generated if RangerAdmin is unavailable.

This alarm is automatically cleared after the RangerAdmin service recovers.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

45276

Major

Yes

Alarm Parameters

Parameter

Description

Source

Specifies the cluster for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Role for which the alarm is generated.

HostName

Specifies the host for which the alarm was generated.

Impact on the System

If the status of a RangerAdmin is abnormal, access to the Ranger native UI is not affected. If there are two abnormal RangerAdmin instances, the Ranger native UI cannot be accessed and operations such as creating, modifying, and deleting policies are unavailable.

Possible Causes

The RangerAdmin port is not started.

Handling Procedure

Check the port process.

  1. In the alarm list on FusionInsight Manager, locate the row that contains the alarm, and click to view the name of the host for which the alarm is generated.
  2. Log in to the node where the RangerAdmin instance is located as user omm. Run the ps -ef|grep "proc_rangeradmin" | grep -v grep | awk -F ' ' '{print $2}' command to obtain pid of the RangerAdmin process, and run the netstat -anp|grep pid | grep LISTEN command to check whether the RangerAdmin process monitors port 21401 in a security cluster or port 21400 in a normal cluster.

    • If yes, go to 4.
    • If no, restart the faulty RangerAdmin instance or Ranger service and go to 3.
      NOTICE:

      During the service restart, the service is interrupted. During the instance restart, the instance is unavailable, and the task on that instance fails to be executed.

  3. In the alarm list, check whether the "Abnormal RangerAdmin Status" alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 4.

Collect the fault information.

  1. On FusionInsight Manager, choose O&M > Log > Download.
  2. Expand the Service drop-down list, and select Ranger for the target cluster.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M personnel and provide the collected logs.

Alarm Clearance

After the fault that triggers the alarm is rectified, the alarm is automatically cleared.

Related Information

None

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