Help Center > > User Guide> FusionInsight Manager Operation Guide> Alarm Reference (Applicable to MRS 3.x)> ALM-45175 Average Time for Calling OBS Metadata APIs Is Greater than the Threshold

ALM-45175 Average Time for Calling OBS Metadata APIs Is Greater than the Threshold

Updated at: Mar 25, 2021 GMT+08:00

Description

The system checks whether the average duration for calling OBS metadata APIs is greater than the threshold every 30 seconds. This alarm is generated when the number of consecutive times that the average time exceeds the specified threshold is greater than the number of smoothing times.

This alarm is automatically cleared when the average duration for calling the OBS metadata APIs is lower than the threshold.

Attribute

Alarm ID

Alarm Severity

Auto Clear

45175

Minor

Yes

Parameters

Name

Meaning

Cluster Name

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the name of the service for which the alarm is generated.

RoleName

Specifies the name of the role for which the alarm is generated.

HostName

Specifies the name of the host for which the alarm is generated.

Trigger condition

Specifies the threshold for triggering the alarm.

Impact on the System

If the average time for calling the OBS metadata APIs exceeds the threshold, the upper-layer big data computing services may be affected. To be more specific, the execution time of some computing tasks will exceed the threshold.

Possible Causes

Frame freezing occurs on the OBS server, or the network between the OBS client and the OBS server is unstable.

Procedure

Check the heap memory usage.

  1. On the FusionInsight Manager homepage, choose O&M > Alarm > Alarms > Average Time for Calling the OBS Metadata API Exceeds the Threshold. Check the IP address and role name of an instance in the Location column.
  2. Choose Cluster > Name of the desired cluster > Services > meta > Instance > meta (IP address of the instance for which the alarm is generated) to go to the instance status page. Click the drop-down list in the upper right corner of the chart area and choose Customize. In the dialog box that is displayed, select Average time of OBS interface calls from OBS Meta data Operations, and click OK. Check whether the average time of OBS metadata API calls exceeds the threshold.

    • If yes, go to 3.
    • If no, go to 5.

  3. Choose Cluster > Name of the desired cluster > O&M > Alarm > Thresholds > meta > Average Time for Calling the OBS Metadata API. Increase the threshold or smoothing times as required.
  4. Check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 5.

Collect fault information.

  1. On the FusionInsight Manager portal, choose O&M > Log > Download.
  2. In the Services area, select NodeAgent, NodeMetricAgent, OmmServer, and OmmAgent under OMS.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time respectively. Then, click Download.
  4. Contact O&M personnel and provide the collected logs.

Alarm Clearance

After the fault that triggers the alarm is rectified, the alarm is automatically cleared. Manual clearing is not required.

Reference

None

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