Help Center> MapReduce Service> User Guide> Alarm Reference (Applicable to MRS 3.x)> ALM-29013 Impalad FGC Time Exceeds the Threshold
Updated on 2024-05-07 GMT+08:00

ALM-29013 Impalad FGC Time Exceeds the Threshold

Alarm Description

The system checks the FGC time of the Impalad service every 60 seconds. This alarm is generated when the FGC time exceeds the threshold (12 seconds) for five consecutive times. This alarm is cleared when the FGC time is less than or equal to the threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

29013

Major

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Additional Information

Trigger Condition

Specifies the threshold for triggering the alarm.

Impact on the System

Data read and write are affected.

Possible Causes

The memory of the node instance is overused or the heap memory is inappropriately allocated, causing frequent occurrence of the GC process.

Handling Procedure

Check the GC time.

  1. Choose O&M > Alarm > Thresholds > Impala > Process FGCT > Process FGCT of Impalad (Impalad), and check the threshold (12s by default).

  2. Log in to FusionInsight Manager, choose O&M > Alarm > Alarms, and check whether the alarm whose Alarm ID is 29013 exists in the alarm list.

    • If yes, go to 3.
    • If no, no further action is required.

  3. On FusionInsight Manager, choose Cluster > Impala, click the Instances tab, select the Impalad instance for which the alarm is generated, then click the Chart tab, locate the Process FGCT chart, and check whether the FGC time is greater than the threshold in 1.

    • If yes, go to 4.
    • If no, go to 5.

  4. Choose O&M > Alarm > Thresholds > Impala > Process FGCT > Process FGCT of Impalad (Impalad), and change the threshold to a value less than the time obtained in 3. Then, check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 5.

Collect fault information.

  1. On FusionInsight Manager of the active or standby cluster, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select Impala for the target cluster.
  3. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M personnel and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None