Help Center> MapReduce Service> User Guide> Alarm Reference (Applicable to MRS 3.x)> ALM-25008 SlapdServer CPU Usage Exceeds the Threshold
Updated on 2023-10-10 GMT+08:00

ALM-25008 SlapdServer CPU Usage Exceeds the Threshold

Alarm Description

The system checks the CPU usage of the SlapdServer node every 30 seconds and compares the actual usage with the threshold. This alarm is generated when the SlapdServer CPU usage exceeds the threshold for multiple times (5 by default).

Its Trigger Count is configurable. If Trigger Count is set to 1, this alarm is cleared when the SlapdServer CPU usage is less than or equal to the threshold. If Trigger Count is greater than 1, this alarm is cleared when the SlapdServer CPU usage is less than or equal to 90% of the threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

25008

Critical (default threshold: 85%)

Major (default threshold: 75%)

Yes

Alarm Parameters

Parameter

Description

Source

Specifies the cluster or system for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Trigger Condition

Specifies the threshold for triggering the alarm.

Impact on the System

Processes respond slowly or do not work.

Possible Causes

  • The alarm threshold or alarm trigger count is improperly configured.
  • The CPU configuration cannot meet service requirements, and the CPU usage reaches the upper limit.

Handling Procedure

Check whether the alarm threshold or alarm trigger count is properly configured.

  1. Log in to FusionInsight Manager, choose O&M > Alarm > Thresholds, click the name of the desired cluster, choose LdapServer > Other > SlapdServer Service Total CPU Percentage, and check whether the alarm trigger count and alarm threshold are set properly.

    • If yes, go to 4.
    • If no, go to 2.

  2. Change the trigger count and alarm threshold based on the actual CPU usage, and apply the changes.
  3. Wait 2 minutes and check whether the alarm is automatically cleared.

    • If yes, no further action is required.
    • If no, go to 4.

Check whether the CPU usage reaches the upper limit.

  1. On FusionInsight Manager, choose O&M > Alarm > Alarms. In the right pane, click this alarm and obtain the host name in Location.
  2. Choose Cluster > Services > LdapServer, click the Instance tab, and click the SlapdServer instance corresponding to the host name in 4.
  3. On the dashboard of the instance, observe the real-time data of the CPU Usage of a Single SlapdServer Instance chart for about 5 minutes and check whether the CPU usage exceeds the threshold (75% by default) for multiple times.

    • If yes, go to 7.
    • If no, go to 9.

  4. Check whether the status of other SlapdServer instances is normal. For details, see 5 to 6.

    • If yes, contact the MRS cluster administrator to evaluate whether to expand the capacity of SlapdServer instances. Then, go to 8.
    • If no, repair the faulty SlapdServer instance and go to 8.

  5. Check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 9.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select LdapServer for the target cluster.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M personnel and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.