Help Center > > User Guide> FusionInsight Manager Operation Guide (Applicable to 3.x)> Alarm Reference (Applicable to MRS 3.x)> ALM-24009 Flume Server Garbage Collection (GC) Time Exceeds the Threshold

ALM-24009 Flume Server Garbage Collection (GC) Time Exceeds the Threshold

Updated at: Mar 25, 2021 GMT+08:00

Description

The system checks GC time of the Flume process every 60 seconds. The alarm is generated when GC time of the Flume process exceeds the threshold (default value: 12 seconds) for 5 consecutive times. The alarm is cleared when GC time is less than the threshold.

Attribute

Alarm ID

Alarm Severity

Automatically Cleared

24009

Major

Yes

Parameters

Name

Meaning

Source

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Trigger Condition

Specifies the threshold triggering the alarm. If the current indicator value exceeds this threshold, the alarm is generated.

Impact on the System

The Flume data transmission becomes inefficient.

Possible Causes

The heap memory of the Flume instance is overused or the heap memory is inappropriately allocated.

Procedure

Check GC time.

  1. On the FusionInsight Manager portal, choose O&M > Alarm > Alarms > Garbage Collection (GC) Time of the Flume Process Exceeds the Threshold > Location. Check the host name of the instance involved in this alarm.
  2. On the FusionInsight Manager portal, choose Cluster > Name of the desired cluster > Services > Flume > Instance. Click the instance for which the alarm is generated to go to the page for the instance, click the drop-down menu in the chart area and choose Customize >Agent > Garbage Collection (GC) Duration of Flume. Click OK.
  3. Check whether GC time of the Flume process every second exceeds the threshold (default value: 12 seconds).

    • If yes, go to 4.
    • If no, go to 6.

  4. On the FusionInsight Manager portal, choose Cluster > Name of the desired cluster > Services > Flume > Configurations. Click All Configurations, and choose Flume > System. Increase the value of -Xmx in GC_OPTS as required, and click Save. Click OK.

    If this alarm is generated, the heap memory configured for the Flume server is insufficient for data transmission. You are advised to change the heap memory to: Channel capacity x Maximum size of a single data record x Number of channels. Note that the value of xmx cannot exceed the remaining memory of the node.

  5. Restart the affected services or instances and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 6.

Collect fault information.

  1. On the FusionInsight Manager portal, choose O&M > Log > Download.
  2. Select Flume in the required cluster from the Service drop-down list.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact the O&M personnel and send the collected fault logs.

Alarm Clearing

After the fault is rectified, the system automatically clears this alarm.

Related Information

None

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