ALM-23003 Loader Task Execution Failure
Description
This alarm is generated immediately when the system detects that the Loader job fails. This alarm is cleared when the failed job is manually handled by a user. This alarm must be manually cleared.
Attribute
Alarm ID |
Alarm Severity |
Automatically Cleared |
---|---|---|
23003 |
Minor |
No |
Parameters
Name |
Meaning |
---|---|
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
JobID |
Specifies the ID of failed Loader job. |
JobName |
Specifies the failed Loader job. |
UserName |
Specifies the name of the user who submits the Loader job. |
Details |
Supplementary information for which the alarm is generated. |
Impact on the System
This is a job-level alarm for Loader. The job execution fails, and you need to view specific logs to locate the failure cause. No execution result is returned. After the fault is rectified, you need to execute the task again. No impact on the Loader service.
Possible Causes
- Task parameters are incorrectly configured.
- Exceptions occur when Yarn is executing a job.
Procedure
Check whether task parameters are incorrectly configured.
- On FusionInsight Manager, choose O&M > Alarm > Alarms and click the alarm drop-down list from the alarm list, obtain the Alarm Cause.
- If the alarm cause is "Failure to submit job", view error details in Additional Information, and go to the Loader WebUI to view the execution history of the job.
By default, the admin user does not have the permissions to manage other components. If the page cannot be opened or the displayed content is incomplete when you access the native UI of a component due to insufficient permissions, you can manually create a user with the permissions to manage that component.
- Submit the task again.
- Check whether the task executed successfully.
Check whether exceptions occur when Yarn is executing a job.
- On FusionInsight Manager, click the alarm drop-down list from the alarm list, obtain the Alarm Cause.
- Check whether the Yarn activity is executed properly in the Alarm Cause. If the alarm cause is "Yarn execution failed", the Yarn activity is abnormal.
- Submit the task again.
- Please check whether the task executed successfully.
- In the alarm list, click Clear from Operation to manually clear the alarm. No further action is required.
Collect fault information.
- On FusionInsight Manager, choose O&M > Log > Download.
- Select the following nodes in the required cluster from the Service drop-down list:
- DBService
- HDFS
- Loader
- Mapreduce
- Yarn
- ZooKeeper
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M personnel and send the collected logs.
Alarm Clearing
After the fault is rectified, the system does not automatically clear this alarm, and you need to manually clear the alarm.
Related Information
None
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot