ALM-16009 Map Number Exceeds the Threshold
Description
The system checks the number of HQL maps in every 30 seconds. This alarm is generated if the number exceeds the threshold. By default, Trigger Count is set to 3, and the threshold is 5000.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
16009 |
Major |
Yes |
Parameters
Name |
Meaning |
---|---|
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Trigger Condition |
Specifies the threshold triggering the alarm. If the current indicator value exceeds this threshold, the alarm is generated. |
Impact on the System
If the number of HQL maps executed by Hive is too large, a large number of Yarn queue resources are occupied, which may take a long time and affect other tasks running using this queue.
Possible Causes
The HQL statements are not the optimal.
Procedure
Check the number of HQL maps.
- On FusionInsight Manager portal, choose Cluster >Name of the desired cluster > Services > Hive > Resource. Check the HQL statements with the excessively large number (5000 or more) of maps in HQL Map Count.
- Locate the corresponding HQL statements, optimize them and execute them again.
- Check whether the alarm is cleared.
- If it is, no further action is required.
- If it is not, go to 4.
Collect fault information.
- On the FusionInsight Manager, choose O&M > Log > Download.
- Select Hive in the required cluster from the Service.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M personnel and send the collected logs.
Alarm Clearing
After the fault is rectified, the system automatically clears this alarm.
Related Information
None
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