Help Center > > User Guide> FusionInsight Manager Operation Guide (Applicable to 3.x)> Alarm Reference (Applicable to MRS 3.x)> ALM-13006 Znode Number or Capacity Exceeds the Threshold

ALM-13006 Znode Number or Capacity Exceeds the Threshold

Updated at: Aug 17, 2021 GMT+08:00

Description

The system periodically detects the status of secondary Znode in the ZooKeeper service data directory every four hours. This alarm is generated when the number or capacity of secondary Znodes exceeds the threshold.

Attribute

Alarm ID

Alarm Severity

Automatically Cleared

13006

Minor

Yes

Parameters

Name

Meaning

Source

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the service name for which the alarm is generated.

ServiceDirectory

Specifies the directory for which the alarm is generated.

Trigger Condition

Specifies the cause of the alarm.

Impact on the System

A large amount of data is written to the ZooKeeper data directory. As a result, ZooKeeper cannot provide normal services.

Possible Causes

A large amount of data is written to the ZooKeeper data directory. The threshold is not appropriate.

Procedure

Check whether a large amount of data is written to the directory for which the alarm is generated.

  1. On FusionInsight Manager, choose O&M > Alarm > Alarms. On the displayed interface, click the drop-down button of Znode Number or Capacity Exceeds the Threshold. Confirm the Znode for which the alarm is generated in Location Information.
  2. Log in to FusionInsight Manager, open the ZooKeeper service interface, and select Resource. In the table Used Resources (By Second-Level Znode), check whether a large amount of data is written to the top-level Znode for which the alarm is reported.

    • If it is, go to 3.
    • If it is not, go to 4.

  3. Log in to the ZooKeeper client and delete the data in the top-level Znode.
  4. Log in to FusionInsight Manager and open the ZooKeeper service interface. On the Resource page, click By Znode quantity in Used Resources (By Second-Level Znode) and click to enter Threshold Configuration of By Znode quantity. Click Modify under Operation. Increase the threshold by referringto the value of max.Znode.count by choosing Cluster > Name of the desired cluster > Services > ZooKeeper > Configurations > All Configurations > Quota.
  5. Click By capacity in Resource Usage (By Secondary Znode) and then click to enter the Threshold Settings page of By Capacity. Click Modify under Operation. Increase the threshold by referring to the value of max.data.size by choosing Cluster > Name of the desired cluster > Services > ZooKeeper > Configurations > All Configurations > Quota.
  6. Check whether the alarm is cleared.

    • If it is, no further action is required.
    • If it is not, go to 7.

Collect fault information.

  1. On the FusionInsight Manager portal, choose O&M > Log > Download.
  2. Select ZooKeeper in the required cluster from the Service.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact the O&M personnel and send the collected logs.

Alarm Clearing

After the fault is rectified, the system automatically clears this alarm.

Related Information

None

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