Updated on 2024-03-01 GMT+08:00

ALM-12067 Tomcat Resource Is Abnormal

Alarm Description

HA checks the Tomcat resources of Manager every 85 seconds. This alarm is generated when HA detects that the Tomcat resources are abnormal for two consecutive times.

This alarm is cleared when HA detects that the Tomcat resources become normal.

Resource Type of Tomcat is Single-active. Active/standby will be triggered upon resource exceptions. When this alarm is generated, the active/standby switchover is complete and new Tomcat resources have been enabled on the new active Manager. In this case, this alarm is cleared. This alarm is used to notify users of the cause of the active/standby Manager switchover.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

12067

Major

Yes

Alarm Parameters

Parameter

Description

Source

Specifies the cluster or system for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Impact on the System

  • The active/standby Manager switchover occurs.
  • The Tomcat process repeatedly restarts.

Possible Causes

  • The Tomcat directory permission is abnormal, and the Tomcat process is abnormal.

Handling Procedure

Check whether the permission on the Tomcat directory is normal.

  1. In the alarm list on FusionInsight Manager, locate the row that contains the alarm, and click to view the IP address of the host for which the alarm is generated.
  2. Log in to the alarm host as user root.
  3. Run the su - omm command to switch to user omm.
  4. Run the vi $BIGDATA_LOG_HOME/omm/oms/ha/scriptlog/tomcat.log command to check whether the Tomcat resource log contains keyword Cannot find XXX and rectify the file permission based on the keyword.
  5. After 5 minutes, check whether the alarm is automatically cleared.

    • If yes, no further action is required.
    • If no, go to 6.

Collect the fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. In the Services area, select OmmServer and Tomcat, and click OK.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M personnel and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None