Help Center> MapReduce Service> User Guide> Alarm Reference (Applicable to MRS 3.x)> ALM-12057 Metadata Not Configured with the Task to Periodically Back Up Data to a Third-Party Server
Updated on 2023-05-30 GMT+08:00

ALM-12057 Metadata Not Configured with the Task to Periodically Back Up Data to a Third-Party Server

Description

After the system is installed, it checks whether the task for periodically backing up metadata to the third-party server, and then performs the check hourly. If the task for periodically backing up metadata to a third-party server is not configured, a critical alarm is generated.

This alarm is cleared when a user creates such a backup task.

Attribute

Alarm ID

Alarm Severity

Auto Clear

12057

Major

Yes

Parameters

Name

Meaning

Source

Specifies the cluster or system for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

If metadata is not backed up to a third-party server, metadata cannot be restored if both the active and standby management nodes of the cluster are faulty and local backup data is lost.

Possible Causes

Metadata is not configured with the task to periodically back up data to a third-party server.

Procedure

  1. On the FusionInsight Manager portal choose O&M > Alarm > Alarms.
  2. In the alarm list, click in the row where the alarm is located and identify the data module from which the alarm is generated based on Additional Information.
  3. Choose O&M > Backup and Restoration > Backup Management > Create.
  4. Configure a backup task. The backup data to be configured is consistent with the data in Additional Information of the alarm.

    Back up data to a third-party server, for example, remote HDFS (RemoteHDFS), NAS (NFS/CIFS), Object Storage Service (OBS), and SFTP server (SFTP). For details, see Backing Up Data.

  5. After the backup task is created successfully, wait for two minutes and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 6.

Collect fault information

  1. On FusionInsight Manager, choose O&M > Log > Download.
  2. In the Service area, select Controller and click OK.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact the O&M personnel and send the collected log information.

Alarm Clearing

After the fault is rectified, the system automatically clears this alarm.

Related Information

None