Help Center> Enterprise Management> User Guide> Enterprise Center> FAQs> Common Issues> Why Cannot an IAM User of My Enterprise Master Account Cannot View Details About My Member Accounts?
Updated on 2023-03-07 GMT+08:00

Why Cannot an IAM User of My Enterprise Master Account Cannot View Details About My Member Accounts?

Symptom

If unified accounting management is not enabled, after an IAM user of an enterprise master account logs in to the Enterprise Center, the user cannot view details about member accounts under the master account.

Possible Causes

  • The master account has not assigned the Agent Operator role to the IAM user.
  • The master account has not assigned the BSS Administrator, BSS Operator, or BSS Finance role to the IAM user.
  • The master account does not have permissions to view details about member accounts.

Assigning the Agent Operator Role to an IAM User

  1. Log in to Huawei Cloud and click Console in the upper right corner.
  2. On the management console, hover the mouse pointer over the username in the upper right corner, and choose Identity and Access Management from the drop-down list.
  3. In the navigation pane, choose User Groups.
  4. In the user group list, click Manage Permissions in the Operation column of the row containing the user group to which the IAM user belongs.
  5. On the Permissions tab page, click Assign Permissions above the permission list.
  6. Set Scope to Global service project.
  7. Select the Agent Operator role and click OK.

Assigning the BSS Administrator, BSS Operator, or BSS Finance role to an IAM User

  1. Log in to Huawei Cloud and click Console in the upper right corner.
  2. On the management console, hover the mouse pointer over the username in the upper right corner, and choose Identity and Access Management from the drop-down list.
  3. In the navigation pane, choose User Groups.
  4. In the user group list, click Manage Permissions in the Operation column of the row containing the user group to which the IAM user belongs.
  5. On the Permissions tab page, click Assign Permissions above the permission list.
  6. Set Scope to Region-specific projects and select region-specific projects for the role to take effect.
  7. Select the BSS Administrator, BSS Operator, or BSS Finance role and click OK.

Applying for the Permissions to View Details About Member Accounts

When creating a member account or inviting an account to become a member account, you can apply for the permissions to view details about the member account.

You can also apply for the permissions to view details about an exiting member account. For details, see Changing Member Account Permissions.