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1 CEC Operation Guide

1.1 Enabling the CEC
To enable the CEC, log in to Huawei Cloud, set enterprise payment information,
and subscribe to the CEC product.

1.2 Updating Enterprise Information
On the Overview page, an enterprise customer can view the basic information,
business management information, and business processes.

1.3 Creating a Call Center Instance
On the Instance Management page, an enterprise customer can create and
manage call center instances, and subscribe to agents, chatbots, and access codes
for call center instances.

1.4 Managing Resources
On the Resource Management page, an enterprise can view and manage all
subscribed resources, such as deleting a resource.

1.5 Viewing Call Duration Statistics
On the Call Duration Statistics page, an enterprise customer can view the call
duration statistics of self-owned and Huawei access codes.

1.1 Enabling the CEC
To enable the CEC, log in to Huawei Cloud, set enterprise payment information,
and subscribe to the CEC product.

For details about the pricing for commercial use, see Price Details.

In the commercial use phase, the access codes provided for free trial expire.
Therefore, apply for number resources in advance.

Procedure

Step 1 In the navigation pane of Huawei Cloud, choose Products > Business
Applications > Cognitive Engagement Center (CEC).

Step 2 Click Buy Now.
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Step 3 Use the Huawei Cloud account and password to log in to the Huawei Cloud
official website.

Step 4 Click Go to complete to complete payment details as prompted. This step is
required for enterprises that log in to the CEC console for the first time and have
not filled in the payment information. For details about the authentication, see
Adding a Payment Method.

Step 5 On the Enable CEC Service page, select I have read and agree to CEC Usage
Agreement and Privacy Statement and click Enable.

Choose Service List > Business Applications > Cognitive Engagement
Center. The CEC console is displayed, as shown in the following figure.

Step 6 After the subscription is complete, you can view the order information by choosing
Billing > My Orders.

----End

1.2 Updating Enterprise Information
On the Overview page, an enterprise customer can view the basic information,
business management information, and business processes.
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Procedure

Step 1 Log in to Huawei Cloud.

Step 2 Choose Service List > Business Applications > Cognitive Engagement
Center.

Step 3 Click Update to modify the contact person, contact number, or email address.

----End

1.3 Creating a Call Center Instance
On the Instance Management page, an enterprise customer can create and
manage call center instances, and subscribe to agents, chatbots, and access codes
for call center instances.

Prerequisites
● An enterprise customer has applied for an access code.

For details, see 1.4.3.1 Applying for Connecting to a Self-Owned Access
Code.

● Before a tenant (call center instance) subscribes to resources, the tenant has
contacted the O&M administrator of the CEC to determine whether the new
tenant needs to be split. The O&M administrator of the CEC needs to
manually modify the configuration.

Procedure

Step 1 Log in to Huawei Cloud.

Step 2 Choose Service List > Business Applications > Cognitive Engagement
Center.

Step 3 Choose Instance Management.

Step 4 Create a call center instance.

1. Click Create Call Center Instance.
2. Select an access code from the list. If multiple access codes are selected,

specify an access code as the default outbound calling number.
An access code is used as a hotline number in a call center for taking
customer calls or displayed as a calling number at the customer side.
If no access code is available, click Click here to apply for connecting to a
self-owned access code. in the upper right corner to add a self-owned access
code. For details, see 1.4.3.1 Applying for Connecting to a Self-Owned
Access Code.

3. Click Next and set Instance Name.
4. Click Next.
5. Set agent specifications based on the following parameters:
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– Current Region: Huawei Cloud site that supports the CEC function. If
multiple sites are available, select the nearest site to reduce the network
impact on agent access.

– Billing Mode: Select Pay-Per-Use.

– Specifications: Select the agent type as prompted. The options are Basic
agent, Professional agent, and Advanced agent.

– Agent Quantity: Enter a value greater than or equal to 2. If more agent
resources are required later, you can purchase them separately later.

6. Click Next to check the billing items. Click Submit. The purchase success page
is displayed.

After the subscription is complete, you can click Here to return to the CEC console.

Step 5 (Optional) Purchase a chatbot.

To use self-service, you need to purchase a chatbot.

1. Choose Service List > Business Applications > Cognitive Engagement
Center.

2. Choose Instance Management.

3. Click More corresponding to a call center instance and choose Purchase
ChatBot.

4. Set Purchase Type and Purchase Quantity, and click Next.

5. Check the fee item details, read CEC Usage Agreement and Privacy
Statement, select I have read and agree to CEC Usage Agreement and
Privacy Statement, and click Submit. The subscription success page is
displayed. Click Here to return to the ChatBot page.

----End

Follow-up Procedure

You can view the resources that you have subscribed to on the following pages:

● Resource Management > Access Code

● Resource Management > Agent

● Resource Management > IVR

● Resource Management > TTS&ASR

1.4 Managing Resources
On the Resource Management page, an enterprise can view and manage all
subscribed resources, such as deleting a resource.

1.4.1 Deleting an Agent
You can delete a single agent.
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Procedure

Step 1 Log in to Huawei Cloud.

Step 2 Choose Service List > Business Applications > Cognitive Engagement
Center.

Step 3 Choose Resource Management > Agent.

Step 4 In the upper right corner, select a call center instance or enter a desired agent ID,
and click Query.

Step 5 Click Delete in the row that contains the agent.

Step 6 In the confirmation dialog box, click OK.

----End

1.4.2 Deleting a Chatbot
You can delete a single chatbot.

Procedure

Step 1 Log in to Huawei Cloud.

Step 2 Choose Service List > Business Applications > Cognitive Engagement
Center.

Step 3 Choose Resource Management > ChatBot.

Step 4 Select a chatbot type.

Step 5 Select a call center instance name in the upper right corner and find the chatbot
to be deleted.

Step 6 Click Delete in the row that contains the chatbot.

Step 7 In the confirmation dialog box, click OK.

----End

1.4.3 Managing Access Codes

Context

You can submit an application for adding a self-owned access code. Huawei
operations management personnel will configure the line. Generally, this operation
takes about three days. In this mode, you can retain the existing hotline number
and ensure service continuity.

1.4.3.1 Applying for Connecting to a Self-Owned Access Code

You can only apply for connecting to a self-owned access code that supports SIP.
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Prerequisites
To connect enterprise self-owned access codes that support SIP to the CEC, the
following conditions must be met:

● Device: The device supports the full SIP protocol and has a fixed public IP
address and port number.

● Network quality: The voice call quality depends on the stability of the data
network. The packet loss rate between the enterprise and the CEC must be
less than 1%, the network jitter must be less than or equal to 60 ms, and the
delay must be less than 200 ms. If the network does not meet this
requirement, the voice may be intermittent and the other party cannot hear
clearly.

● Network bandwidth: The voice media protocol used by the CEC is G.711 A, the
average traffic is 100 Kbit/s, and the uplink and downlink traffic is equal.
Bandwidth is calculated as follows: Network bandwidth = (Number of
concurrent users x 100 Kbit/s)/1024
Assume that there are 100 concurrent customers, the required bandwidth is
(100 x 100 Kbit/s)/1024, that is, 9.7 Mbps. The required uplink and downlink
bandwidth is 10 Mbit/s.

● Access code: Access codes that support SIP with signaling IP addresses and
port numbers can be connected.
– Common fixed-line phone number and 95 number: Enterprises can

submit applications themselves or Huawei helps enterprises submit
applications to carriers.

– 400 number: You can directly apply for connecting to access codes that
support SIP. For access codes that do not support SIP, contact the carrier
to configure the forwarding of calls to a SIP fixed-line phone and apply
for connecting to this self-owned access code. Common virtual numbers
and mobile numbers cannot be connected.

Context
Introduction to SIP

Session Initialization Protocol (SIP) is a multimedia communication protocol
developed by the Internet Engineering Task Force (IETF,https://www.ietf.org/). It is
a text-based application-layer control protocol and is used to establish, modify,
and release sessions of one or more participants. SIP is independent of
transmission-layer protocols, and can be carried over different transmission
protocols, such as UDP, TCP, TLS, and SCTP. SIP alone cannot complete a
multimedia call. It establishes a complete multimedia communication system with
other protocols. It must cooperate with protocols such as RTP/RTCP, SDP, MGCP,
and DNS to complete a multimedia session process.

SIP only describes how to establish, modify, or release a session but does not
describe the session contents. Therefore, SIP can carry any session contents, such
as voices, videos, and games.

SIP protocol example

The SIP protocol content varies according to the line and scenario. The following is
the SIP protocol content in a voice call successfully initiated by the CEC. You can
refer to this example to understand the SIP protocol in use.
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INVITE sip:18012345678@10.11.56.68:5060;user=phone SIP/2.0
/*Request line. It consists of Method, Request-URI, and SIP Version. The Request-URI header field 
specifies the called number 18012345678 obtained by the UAP.*/
/*SIP Header-start*/
Via: SIP/2.0/UDP 10.11.56.61:5060;branch=z9hG4bK9njqrkwmmvg6or9gnjml6hvwv;Role=3;Hpt=8e48_16
/*Message header. It is used to record the path that a request passes through, so that the response can be 
correctly returned along this path. The SIP URI carried in the Via header field identifies the host name or 
network address of the customer who initiates the request. The UAP obtains the signaling address of the 
peer end from the Via header field, for example, 10.11.56.61:5060.*/
Record-Route: <sip:10.11.56.61:5060;transport=udp;lr;Hpt=8e48_16;CxtId=4;TRC=ffffffff-ffffffff;X-
HwB2bUaCookie=2717>
/*Forcible routing. It is used to force a request to pass through a series of proxies.*/
Call-ID: isbcjiwwievb2zvydwesyf2w0dxvdzsszefd@UAP9600
/*Unique call ID. The value is a string of random characters.*/
From: <sip:02160123456@10.11.56.61;user=phone>;tag=yv20ze22-CC-57
/*Initiator of the request. The calling number can be obtained. For the first message, only the From field 
contains tag, and the To field does not contain tag.*/
To: <sip:18012345678@10.11.56.68;user=phone>
/*Recipient of the request. During registration, it specifies the public customer to be registered. During a 
session, it specifies the recipient of the request and carries the URI of the recipient. For details about the 
tag field, see the description of the From field. The To header field in an initial request may not carry tag, 
but any request or response in a session must carry tag. IP address:Port number obtained by the UAP from 
the To field is the local signaling address. The UAP obtains the original called number from the Historyinfo 
or Diversion field first. If the Historyinfo or Diversion field does not contain the required information, the 
UAP obtains the original called number from the To field.*/
CSeq: 1 INVITE
/*Sequence number of a transaction. The sequence number is incremented by 1.*/
Allow: 
INVITE,ACK,OPTIONS,BYE,CANCEL,REGISTER,INFO,PRACK,SUBSCRIBE,NOTIFY,UPDATE,MESSAGE,REFER
/*Header field. It is used to list all SIP methods supported by the UA.*/
Contact: <sip:02160123456@10.11.56.61:5060;transport=udp;Hpt=8e48_16;CxtId=4;TRC=ffffffff-ffffffff>
/*Address for subsequent direct communication with the customer. The SIP URI indicates the address for 
receiving responses.*/
Max-Forwards: 69
/*Maximum times that a request can be forwarded before it arrives at the destination. The value decreases 
by 1 each time the request is forwarded. This header field is used to prevent proxy resources from being 
continuously consumed when a loop occurs. The value ranges from 0 to 255. The recommended value is 
70.*/
Supported: 100rel
/*All SIP extension methods supported by the UAC or UAS.*/
User-Agent: Huawei UAP9600 V100R005C00
Content-Length: 236
//Length of the message body, in bytes.*/
Content-Type: application/sdp
/*Type of the message body. In this example, the type is SDP.*/
/*SIP Header-end*/

/*SIP Body-start*/
v=0
/*Protocol version. In this example, the protocol version is 0. (The protocol version used by the SDP is 0.)*/
o=- 929076 929076 IN IP4 10.11.56.61
/*The first parameter: - indicates the name of the session initiator. This parameter is optional.
The second parameter: 929076 indicates the session identifier of the calling party.
The third parameter: 929076 indicates the version of the calling party. When the session data changes, the 
version number is increased by 1.
The fourth parameter: IN indicates the network type Internet. Only this type of network is supported.
The fifth parameter: IP4 indicates the IP address type. IPv4 and IPv6 are supported.
The sixth parameter: 10.11.56.61 indicates the IP address of the session initiator, which is a signaling plane 
IP address.*/
s=SBC call
/*Name of the current session.*/
c=IN IP4 10.11.56.61
/*Connection information. The "c=" line identifies the media receiving address of the UE. If the media-level 
"c=" line also exists, the media-level "c=" line is used. This parameter is mandatory in any case.
The first parameter: IN indicates the network type Internet. Only this type of network is supported.
The second parameter: IP4 indicates the IP address type. IPv4 and IPv6 are supported.
The third parameter: 10.11.56.61 indicates the actual IP address used by multimedia streams.*/
t=0 0
/*The first parameter indicates the start time, and the second parameter indicates the stop time. The start 
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time and stop time are Network Time Protocol (NTP) time in decimal format. If the values are both 0, the 
session is persistent.*/
m=audio 59354 RTP/AVP 8 0 97
/*m=<media> <port> <transport> <fmt list>. media indicates the media type, which can be audio or video. 
Currently, audio, video, application, data, and control are defined. port indicates the media port number. 
transport indicates the transport protocol. Currently, RTP/AVP is used. fmt list indicates the format list.*/
a=rtpmap:8 PCMA/8000
a=rtpmap:0 PCMU/8000
/*rtpmap indicates the keyword, which is in the format of {PT value} {Stream name}/{Sampling rate}.*/
a=rtpmap:97 telephone-event/8000
a=ptime:20
/*Media encapsulation duration (media duration that can be encapsulated in each packet, in milliseconds). 
In this example, the duration is 20 ms.*/
a=fmtp:97 0-15
a=sendrecv
/*Media direction. In this example, the media direction is bidirectional. The media direction can be inactive, 
sendonly, recvonly, or sendrecv.*/
/*SIP Body-end*/

● SIP header is a signaling message used by the sending party to notify the
receiving party of the basic information about the call.
The signaling messages may be understood as:
Call 10.11.56.68:5060.
I'm sending you a SIP message from 10.11.56.61:5060.
The call ID is xxxx.
The call is from 10.11.56.61:5060.
I need to send the message to 10.11.56.68:5060.
This is the first Invite message sent in the call request.
If you receive the message, reply to me at 10.11.56.61:5060.
This is Huawei UAP9600 V100R005C00. You can reply to me with INVITE, ACK,
BYE, and other messages.
The signaling message contains 236 characters in the SDP format.

● The SIP body is a media message, that is, SDP. Media messages are
mandatory in SIP messages. Signaling messages only enable the sending
party and receiving party to know that they are connected. Media messages
enable both parties to know the specific content of the messages.
The media messages may be understood as:
My version is 0.
The message is sent to you through the signaling address 10.11.56.61, and the
media address is 10.11.56.61 (the server that processes the signaling may be
different from the server that processes the media). The audio media stream
port is 10002, and data is transmitted using RTP. The video media stream port
is 10004, and data is also transmitted using RTP.
Not all terminals support video media. Therefore, when a SIP message is
received, the peer end may receive only the audio media information. This is
determined based on the negotiation result.

NO TICE

Currently, the supported media transmission type is RTP/AVP, that is, the UDP
channel is used to ensure the real-time audio and video transmission. The
TCP-based RTP/SAVP media transmission type is not used.
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Common SIP request and response messages are as follows.

Table 1-1 Description of request and response messages

Request Response Scenario

INVITE 1XX Negotiation request, which is used when a
session starts. If a 1XX message from the peer
end is received, the SIP network is connected and
the session can be started.

ACK 2XX When the signaling and media negotiation or
registration is successful, the local system notifies
the peer system of the success and establishes
an RTP channel.

OPTIONS 3XX Redirection request, which is used to check
trunks or MRCP links (for example, MRCP links
used when the TTS or ASR is connected).

BYE 4XX Used when a call ends in normal cases.

CANCEL 5XX If a session is interrupted due to insufficient
resources, the two ends of the SIP session need
to forcibly release the call using the CANCEL
request.

REGISTER 6XX Used for registration.

 

NO TICE

● The CEC side uses the OPTIONS request to query the information and functions
of the called party every minute to check whether the link status is normal. The
link is considered normal and calls can be made only when the enterprise side
returns a 200ok response.

● When the PRACK request is used for renegotiation, the CEC side requires that
the 18x message (for example, 180 ringing) returned by the peer end contain
the Require:100rel field and the INVITE request sent by the peer end contain
the Supported:100rel field. Otherwise, no sound can be heard during the call.

● When the CEC side uses the UPDATE request for renegotiation, this mode is
used for a normal call with an agent. When the INVITE request is used for
renegotiation, this mode is used for the call that is connected to the intelligent
IVR or transferred through the common IVR. Some carriers do not support
renegotiation using the second INVITE request. As a result, some functions,
such as the virtual number service, are unavailable.

Introduction to the call process

The process for a customer to initiate an incoming call to the CEC is as follows:

● The customer initiates a call and sends an INVITE request to the SBC of the
CEC.
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● The CEC side returns a ringing message and a link connection success (200)
message.

● After receiving the message, the customer side returns a final response to the
INVITE request.

● The CEC side receives the reply and sends a renegotiation message to the
customer side.

● After receiving the message, the customer side returns a link connection
success (200) message.

● After the CEC returns a response to the request, the customer and agent start
a conversation.

Figure 1-1 Call process
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Business Scenario

The solution for connecting enterprise self-owned access codes that support SIP to
the CEC is as follows:

Figure 1-2 Connecting to a self-owned access code that supports SIP

Typical scenario 1

The enterprise has local access code resources and directly connects to the CEC.

Connection solution:

1. The enterprise applies for access code resources from the carrier. The resource
type can be E1, private line, or SIP.

2. After the application is successful, the enterprise needs to use the local voice
gateway to convert the non-SIP lines of the carrier to the SIP lines for the
communication with the public cloud SBC platform of the CEC. For details
about the devices, see the local device recommendation in FAQs > Product
Consulting.

3. After referring to the procedure of applying for connecting to a self-owned
access code, the enterprise sends an email to the CEC operations personnel to
apply for the signaling IP address, port number, and media port number of
the CEC, which are used to set the whitelist on the local firewall and connect
to the line.

Typical scenario 2

The enterprise applies for access codes that support SIP from the carrier, and the
carrier interconnects with Huawei.

Connection solution:

1. The enterprise applies for access code and line resources from the carrier. The
resource type can only be SIP.

2. After access codes are successfully applied for, the enterprise submits an
application to the CEC requiring Huawei to directly interconnect with the
carrier. The enterprise does not need to connect to the access codes and lines.

Procedure

Perform the following steps to add a self-owned access code.
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Step 1 Log in to Huawei Cloud.

Step 2 Choose Service List > Business Applications > Cognitive Engagement
Center.

Step 3 Choose Resource Management > Access Code.

Step 4 Click the Self-Owned Access Code tab page and click Click here to apply for
connecting to a self-owned access code. in the upper right corner. On the page
that is displayed, set the access code, signaling and media IP addresses and port
numbers, and click OK.

----End

Follow-up Procedure
You need to wait for the CEC operations personnel to configure the connection
between Huawei Cloud and the self-owned access code. After the configuration is
complete, the connection status of the access code is Completed on the Self-
Owned Access Code page. You can click Associate Call Center Instance to
associate the access code with an existing call center instance.

1.5 Viewing Call Duration Statistics
On the Call Duration Statistics page, an enterprise customer can view the call
duration statistics of self-owned and Huawei access codes.

Procedure

Step 1 Log in to Huawei Cloud.

Step 2 Choose Service List > Business Applications > Cognitive Engagement
Center.

Step 3 Choose Call Duration Statistics.

On the Call Duration Statistics page, the Huawei Access Code tab page is
displayed by default. You can click the Self-Owned Access Code or Huawei
Access Code tab to view the desired access code details.

Step 4 Set Call Center Instance, Access Code Source (mandatory), Access Code, and
Query Time Period.

Step 5 Click Query.

Step 6 Select check boxes in front of access codes and click Export to export the call
duration statistics. The following figure shows the format of the exported data.

If no access code is selected, the call duration statistics on all access codes under
the enterprise are exported by default. A maximum of 1000 records can be
exported.

----End
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2 Tenant Administrator Guide

The tenant administrator refers to the administrator of the enterprise that uses
the CEC service. During tenant space creation, the system administrator configures
skill queues and accounts based on business requirements.

2.1 Tenant Space
When you sign in to your tenant space for the first time, you need to understand
the resources allocated to the tenant space and the usage restrictions.

2.2 Configuring the Employee Center
The AICC allows you to maintain organization units (OUs) and employees of your
customer service center. Different employees can perform different function
operations by permission control.

2.3 Enabling Manual Services
After the employee information of the VDN is configured, you can configure the
service content.

2.4 Configuring a Mobile Agent
A tenant administrator can configure the mobile customer service to forward
inbound calls to specified skill queues or numbers.

2.5 Configuring Multimedia Channels
The AICC supports multiple access modes, including WeChat, web, X (Twitter),
email, WhatsApp, Facebook, LINE, and 5G RCS. Customers can access AICC
services anytime and anywhere.

2.6 Robot Management and Configuration Guide

2.7 IVR Journey Analysis

2.8 Monitoring Outbound Call Risks
When the number of outbound calls of a tenant exceeds the warning threshold in
the configured policy, a risk control record is generated. The system administrator
notifies the tenant administrator of the risk control record. The tenant
administrator can view the execution status of the risk control policy.

2.9 Managing Cases

2.10 Managing Inspections
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The AICC provides the manual and AI post-event inspection functions. This section
describes how to configure rating rules for inspectors to perform corresponding
inspections.
2.11 Managing the Notification Center
This section describes how to manage notifications in the notification center.
2.12 Managing the Customer Center
A tenant administrator or an agent can view customer information and customer
contact records, and add customer information.
2.13 Making Intelligent Outbound Calls
This section describes how to configure intelligent automatic outbound calls,
manage outbound call tasks by category (including automatic and manual
outbound call tasks), and properly plan outbound call tasks.
2.14 Managing Surveys
A survey records the survey content in the form of questions. Administrators can
configure surveys for survey statistics collection of other businesses.
2.15 Managing Intelligent Training
Intelligent training tasks can be used to periodically train and test agents through
released intelligent IVR flows to check the business skills of the agents.
2.16 Configuring the Knowledge Base
This section describes how to configure the knowledge base as a tenant
administrator for agents to reference.
2.17 Configuring Public Resources
2.18 Managing Business Fault Bypass
This section describes how to manage business fault bypass and how to handle
emergency faults to ensure normal businesses for operators.
2.19 Co-browsing
2.20 Social Media Operations
2.21 Performance Management

2.1 Tenant Space
When you sign in to your tenant space for the first time, you need to understand
the resources allocated to the tenant space and the usage restrictions.

You can use an allocated business account to sign in to the AICC.

Figure 2-1 Sign-in navigation
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Currently, sign-in using both the account password and a verification code is
supported. The verification code can be a graphic verification code, mobile phone
verification code, or email verification code. For details about the authentication
mode, see the value of Two-factor Authentication Method set by the system
administrator.

NO TE

● A verification code is valid for 1 to 5 minutes and is specified by the system parameter
Two-factor Authentication System-level Verification Code Validity Period set by the
system administrator.

● The interval for obtaining a verification code is 1 minute. If you enter a verification code
correctly but sign-in fails, you can obtain a new verification code immediately.

After you sign in to the system using a business account, the Home Page is
displayed by default. If the home page is closed, you can click Home Page from
the menu to open it.

Figure 2-2 Home Page

● Call center indicator statistics: Currently, indicator statistics are displayed only
for a tenant administrator.
– Total calls: Total number of calls in the tenant space on the current day.
– Abandon calls: Total number of lost calls in the tenant space on the

current day.
– Calls in queue: Real-time indicator, which collects statistics on the

number of queuing inbound calls in the tenant space.
– Virtual Call Center Trends of the Day: Line chart that displays the

number of inbound calls and the number of outbound calls of the VDN
on the current day.

Click  or  for the inbound or outbound
call indicator respectively to select or deselect the call indicator of the
VDN on the current day.

● Quick Entry

a. By default, the following quick menu entries are selected for a tenant
administrator: Employee, Role, Skill, Agent Management, Access Code,
Called Party, Channel Configuration, Gateway Configuration, SMS
Configuration, and Rest Reason. By default, all quick menu entries are
displayed on the home page. Click  to collapse some quick menu
entries.
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By default, the following quick menu entries are selected for an agent:
Agent Parameter, Contact Record, Operation Record, Transfer Record,
Rest Record, Agent Monitor, Recording, Task Query, Task Result, and
Review Mgmt. By default, some quick menu entries are displayed on the

home page. Click  to expand all quick menu entries.

b. Click . The page for setting quick entries is displayed.

c. Click  to quickly create a case. This quick entry is displayed only
when the Case 2.0 feature is enabled for the tenant space.

d. Set quick menu entries.

i. To deselect an unnecessary quick menu entry, click  corresponding

to the entry under Selected shortcut menu or click 
corresponding to the entry among available entries.

ii. To select a required quick menu entry, click  among available
entries. You can drag the selected quick menu entries to adjust their
display sequence.

iii. Click Save. The setting of quick menu entries is complete.
● My To Do

– Outbound Task: This tab page is displayed only when the intelligent
outbound call feature is enabled for the tenant space. Information about
all configured outbound call tasks in the tenant space is displayed.

– Message: Information about all messages left in the tenant space is
displayed.

● Help Center: The help center provides documents to guide how to quickly
configure agents and robots and use the call center.
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– : Go to the knowledge base home page. This
function is available only when the knowledge base feature is enabled for
the tenant space.

– : Go to the Huawei forum home page.

NO TICE

The help center is not supported in the OP integration environment.

● Notification Center: All notifications of the current business account are
displayed.

– : Go to the notification sending page.
– Click More. The Notification Center page is displayed.

– : A notification is not read. You can click the notification to view its
details.

You can view basic tenant space information, tenant space resources, and the
settings to be configured.

● You can choose Configuration Center > System Management > Tenant
Information to view basic tenant space information, existing resource
information, and tenant space features that can be customized.
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Figure 2-3 Basic information

Only features can be configured. Other information, including tenant and
resource information, cannot be modified. To modify the basic information
and resource information, contact Huawei operations personnel.

Home Logo: Customize the home logo. Click  to upload the home
logo, which is displayed only after the system administrator sets Whether to
allow custom home icons. to Yes in the tenant space details.
Tenant space features that can be customized include:
– Intelligent Recognition: Configure whether agents are intelligent agents.

After this feature is enabled, you can set the intelligent agent assistant
and flow code parameters for intelligent agent access.

– Mobile Agent/One-Click Bidirectional Call

▪ After the system administrator enables the mobile agent feature for
your tenant space, you can enable this feature to implement mobile
agent functions.

▪ After the system administrator enables the one-click bidirectional call
feature for your tenant space, you can enable this feature to
implement one-click bidirectional call functions.
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– Voice Notification Flag: After the system administrator enables the voice
notification feature for your tenant space, you can enable this feature to
implement voice notification functions.

– Anonymous Outbound Call Flag: After the system administrator enables
the anonymous outbound call feature for your tenant space, you can
enable this feature to implement anonymous outbound call functions.

– Breakdown Voice: You can enable this feature to play a prompt tone
when the tenant space system is faulty. For details, see 2.3.3.1
Configuring the Fault Prompt Tone.

● The most important AICC resources are agent resources. You can choose
Configuration Center > Employee Center > Agent Management to view
details about the agents in your tenant space.

Figure 2-4 Agent management

You can view the number of agents, and the agent ID and softphone number
of each agent. These resources cannot be modified.
The number of agents of a type cannot exceed the number of agents of this
type allocated by the system administrator. As a tenant space administrator,
you need to configure roles of agents, business accounts associated with
agents, skill queues of agents, and features of each agent. For details, see
2.3.1.3 Associating an Allocated Agent ID with a Business Account and
Skill Queue.

NO TE

The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

● In addition to agents, you also need to configure skill queues and called
routes for complete calls. A tenant space has a certain number of default skill
queues. You can also create skill queues as required. Your tenant space has
access codes that have been allocated during provisioning. To increase access
codes, contact Huawei O&M personnel.
After associating agents, skill queues, and access codes, you can use an
OpenEye softphone number to test call functions.

2.2 Configuring the Employee Center
The AICC allows you to maintain organization units (OUs) and employees of your
customer service center. Different employees can perform different function
operations by permission control.

Concept
You need to understand the following concepts before configuring employees.
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Figure 2-5 Employee configuration

● OU: An enterprise tenant space has a default OU. You can create an OU
under the default OU based on responsibilities. Multiple OUs can be created
under each OU. For example, you can create the customer service department
and maintenance department under an OU.

● Role: A role indicates a set of work permissions. When you assign a role to an
employee, the employee has all the permissions contained in the role. For
example, a role can be an agent, administrator, case owner, or task handler.

Function permission: Function permissions are abstracted from GUI resources
(for example, permission for using specified menus) and GUI operations (for
example, addition, deletion, modification, and query). An employee can
perform operations on a resource only when the role assigned to the
employee has the corresponding permission. Function permissions are static
resources that do not change with resource configuration data. Function
permissions include the following:

– Basic Function Permission: Permissions of a role.

– Grantable Function Permission: Permissions that can be assigned to
other roles by a role. Only the roles of the current account can be
assigned to new roles.

● Employee: Employees indicate personnel employed by an enterprise. After a
role is assigned to an employee, the employee can perform operations limited
by the role permissions on the system.

Configuration flow

You can configure personnel by referring to the following brief description.

Step 1 For details about how to create an OU, see 2.2.1 Configuring OUs. Because there
is no employee or manager information, you do not need to configure the public
role, employee, or manager for the new OU.

Step 2 The default roles Tenant environment administrator and Default Agent Role
are preset in the AICC system. If the role does not meet the actual requirements,
create a role by referring to 2.2.2 Configuring Role Permissions.

Step 3 For details about how to create an employee, see 2.2.3 Configuring Employee
Information. When creating an employee, you can select a role and OU for the
employee, but cannot configure a manager for the employee.

Step 4 Go back to 2.2.1 Configuring OUs and configure information such as the
manager and public role for the OU. The manager is the manager of all
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employees in the current OU, and the permission of the public role is granted to
all employees in the OU.

----End

2.2.1 Configuring OUs
An enterprise tenant space has a default OU. You can create OUs under the
default OU based on responsibilities.

Procedure

Step 1 Choose Configuration Center > Employee Center > Organization Unit. On the
OU management page, select the default OU.

Figure 2-6 Organization Unit

Step 2 Click  to create an OU and configure OU information.

Figure 2-7 Create OU

● OU Name: Enter a customized OU name, which is mandatory.
● Upper-Level OU: The default value is the upper-level OU to which the

selected OU belongs. The value can be changed.
● Description: Enter an OU description.
● Number of multimedia clients concurrently served by agents: The

parameter priority is as follows: agent parameter > OU parameter > tenant
parameter. If this OU parameter is set to 0, it does not take effect.
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NO TE

– Agent parameter: After a tenant administrator assigns the Maximum Number Of
Concurrent Service Customers menu permission to an agent, the agent can
change the value of Number of clients served by a session at the same time on
the Personal Center > Personalized Settings page.

– Tenant parameter: A tenant administrator can change the value of Multimedia
Sessions Concurrently Processed by Agent on the Configuration Center >
System Management > Tenant Parameter page.

● Call End Status: The options are as follows:
– Follow the tenant configuration
– Idle state
– Wrap-up state
The parameter priority is as follows: OU parameter > tenant parameter. If this
OU parameter is set to Follow the tenant configuration, it does not take
effect.

NO TE

Tenant parameter: A tenant administrator can change the value of After-Call Agent
State on the Configuration Center > System Management > Tenant Parameter
page.

Step 3 Click Save. The OU is created.

Step 4 (Optional) Configure OU information.
● Export OU information.

a. Click  to create an export task.

Figure 2-8 New export task

b. Enter the password for compressing the exported file and click OK to
create an export task.

c. Click  to view the export task list. Click download corresponding to an
export task based on Task Time to download OU information to the local
PC.

Figure 2-9 Export task view
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● Click  to disable the OU. Before disabling the OU, you need to delete all
configured employees from the OU.

CA UTION

After an OU is disabled, the OU cannot be restored. Exercise caution when
performing this operation.

● Click  to suspend the OU. After an OU is suspended, the OU or the OU
and its lower-level OUs cannot be used.

● Click  to modify basic OU information.

● Click  to resume a suspended OU.

● Click  to enable a disabled OU.

● Enter an OU name and click  to fuzzily search for OUs based on the OU
name.

Step 5 Select the new OU and configure employee, role, manager, and accessible
employee information for the OU. If there is no employee or manager
information, you do not need to configure the public role, employee, or manager
for the new OU.

1. Click the Public Role tab, click Add, and select a role from the existing roles
in the tenant space. The permission of the public role is granted to all
employees in the OU.

Figure 2-10 Select Roles

2. Click Confirm. The role information is saved successfully.
3. Click the Employee tab, click Add, and select employees for the OU.
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Figure 2-11 Add Staff

4. Click OK. The employee information is configured successfully.
5. Click the Manager tab. If no employee is available, add an employee by

referring to 2.2.3 Configuring Employee Information.
6. Click the Visit Staff tab. If no employee is available, add an employee by

referring to 2.2.3 Configuring Employee Information.
Accessible employees do not belong to the OU but are allowed to access and
use the resources of the OU.

----End

2.2.2 Configuring Role Permissions
A role indicates a set of work permissions. Menu permissions and operation
permissions can be customized for a role.

Procedure
Step 1 Choose Configuration Center > Employee Center > Role.

By default, the default roles Tenant environment administrator and Default
Agent Role are preset in the system. The default role Tenant environment
administrator cannot be deleted.

Figure 2-12 Role
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Step 2 Click  to create a role and configure role information.

Figure 2-13 Configure Role Info

● Role Name: Enter a customized role name, which is mandatory.
● Upper-Level Role: Set the parent role of the current role.
● Role Template: Select a preset role template to quickly create role

permissions. The function permissions listed in the role template are the
minimum permissions of the current role. If the sub-permissions are not
listed, the current role does not have the function permissions. For details
about function permissions, see Table 2-1 and Table 2-2.
– O&M Role: The preset function permissions of the current role are as

follows:

▪ Menu permissions: Inspection Relationships, Tenant
administrator home page, Agent Monitor, Full Screen Monitoring
Configuration, Monitor Relationship, Home, Query User, Save
Employee, Reset User Password, Canceling Configurations in
Batches, Configuring Users in Batches, Query Organization,
Modify Organization, Delete Organization, Account and Password
Rule, Query Role, Query Lock, Create Lock, Delete Lock, Skill
Queue, Agent Management, Transfer external number
configuration, Variable Management, Business Interface, Cell
Management, Stored Procedure, Resource Template, Dialog Test,
RecordHistory Management, System Configuration, Process Trace,
Process Orchestration, Gray Rule, Robot management, Auto
Testing, Operation Log, Process Inspection, Intelligent Engine
Parameter, Problem clustering task, Historical Message Review,
Entity Management, Intent Management, Domain Management,
FAQ, Knowledge gray rule, Flow Management, IVR Voice, Flow
Configuration, Process Transfer Record, View Notification, Agent
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Send Notification, Transfer Record, Sign-In Log, Contact Record,
Operation Record, Rest Record, Channel Configuration, and
Multimedia Library Management.

▪ Operation permissions: Contact Record Export, Recording
Download, Play Recording Online, Querying All Contact Records,
Query ALL Sign-In Log, Query ALL Rest Record, Query ALL
Operation Record, Query ALL Transfer Record, Sign-In Log export,
User numbers are displayed in plaintext, and Configure Agent.

– Report Role: The preset function permissions of the current role are as
follows:

▪ Menu permissions: Tenant administrator home page, VDN Traffic
Report, Skill Queue Traffic Report, Agent Summary Report, Agent
Outbound Call Report, Agent Operation Report, IVR Traffic
Report, IVR Traffic Report by AccessCode, Skill Queue Traffic
Report by AccessCode, Traffic Summary Report, VDN Traffic
Report by AccessCode, Abandoned Call in Ringing Report, Skill
Queue Monitor, Audio&Video IVR Monitor, VDN Monitor,
Incoming Call Record, Recording, Agent Monitor, Offline
Message, Full Screen Monitoring Configuration, Monitor
Relationship, Home, Query Organization, Modify Organization,
Delete Organization, Agent Management, Parameter
Configuration, View Notification, Agent Send Notification,
Transfer Record, Sign-In Log, Contact Record, Operation Record,
and Rest Record.

▪ Operation permissions: Contact Record Export, Recording
Download, Play Recording Online, Querying All Contact Records,
Quality Check, Query ALL Sign-In Log, Query ALL Rest Record,
Query ALL Operation Record, Query ALL Transfer Record, Sign-In
Log export, and User numbers are displayed in plaintext.

– Manager role: The preset function permissions of the current role are as
follows:

▪ Menu permissions: Tenant administrator home page, VDN Traffic
Report, Skill Queue Traffic Report, Agent Summary Report, Agent
Outbound Call Report, Agent Operation Report, IVR Traffic
Report, IVR Traffic Report by AccessCode, Skill Queue Traffic
Report by AccessCode, Traffic Summary Report, VDN Traffic
Report by AccessCode, Abandoned Call in Ringing Report, Skill
Queue Monitor, Audio&Video IVR Monitor, VDN Monitor,
Incoming Call Record, Recording, Agent Monitor, Offline
Message, Full Screen Monitoring Configuration, Audio and Video
Workbench, Home, Query Organization, Modify Organization,
Delete Organization, Agent Management, Parameter
Configuration, View Notification, Agent Send Notification,
Transfer Record, Sign-In Log, Contact Record, Operation Record,
Rest Record, Agent Parameters, Online Chat Workbench, and
Personalized Common Language.

▪ Operation permissions: Help-seeking, Three-Party Call, End Call,
Mute/Unmute, Internal Call, Callback, Answer, Audio/Video
switching, Two-stage Dialing, Reset Skill Queue, Transfer,
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Break/End Break, Outgoing Call, Hold/Unhold, Show Busy/Idle,
Contact Record Export, Recording Download, Play Recording
Online, Querying All Contact Records, Whisper, Send a note,
Forcible release, Queue adjustment, Forcible Set Idle, Forcible Set
Busy, Intercept, Forcible Exit, Insert, Switchover, Listen, Query ALL
Sign-In Log, Query ALL Rest Record, Query ALL Operation Record,
Query ALL Transfer Record, Sign-In Log export, User numbers are
displayed in plaintext, Local Multimedia File Sending by Agents,
Transfer pop-up parameters, and Modifying Agent Fixed-Line
Phone Number.

– Agent Role: The preset function permissions of the current role are as
follows:

▪ Menu permissions: Tenant administrator home page, Audio and
Video Workbench, Home, View Notification, Agent Send
Notification, Transfer Record, Sign-In Log, Contact Record,
Operation Record, Rest Record, Agent Parameters, Online Chat
Workbench, and Personalized Common Language.

▪ Operation permissions: Help-seeking, Three-Party Call, End Call,
Mute/Unmute, Internal Call, Callback, Answer, Audio/Video
switching, Two-stage Dialing, Reset Skill Queue, Transfer,
Break/End Break, Outgoing Call, Hold/Unhold, Show Busy/Idle,
Contact Record Export, Recording Download, Play Recording
Online, User numbers are displayed in plaintext, Local
Multimedia File Sending by Agents, Transfer pop-up parameters,
and Modifying Agent Fixed-Line Phone Number.

● Description: Enter a role description, which is optional.

Step 3 Click Save. The role is created.

Step 4 (Optional) Edit role information.

● Click  to delete role information.

● Click  to modify role information.

● Enter a role name and click  to fuzzily search for roles based on the role
name.

Step 5 Select the new role and configure its own permissions and assignable permissions.

1. Click the Own permissions or Assignable Permissions tab.
– Own permissions: Permissions of the current role.
– Assignable Permissions: Permissions that the current role can assign to

other accounts.
2. Click Add and select function permissions.

You can search for permissions. Permissions unavailable to the current role are
dimmed, and the search results are highlighted.
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Figure 2-14 Select Function Permission

Function permission status description:

– : The function permission has not been configured for the current role
and can be selected for configuration.

– : The function permission cannot be configured for the current role.

– : The function permission has been configured for the current role.
3. Click Confirm to save the configuration.

Step 6 Assign employees.

1. Click the Employee Assignment tab and click Add. The Assign Employee
dialog box is displayed.
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Figure 2-15 Assign Employee

2. Select employees to which the current role can be assigned and click Save.
3. (Optional) Select multiple employees and click Batch Delete to delete them

in batches.

----End

Reference
● Menu permissions: Configure system menus to restrict the menus available

to employees with the current role. For details, see Table 2-1.
● Operation permissions: Configure page operation functions to restrict the

operation permissions of employees with the current role. For details, see
Table 2-2.

● API permissions: Configure APIs that are available to employees with the
current role. For details, see Table 2-3.
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Table 2-1 Menu permissions

Permission Description

System
Manag
ement

Securit
y
Configu
ration

Function permissions for the system administrator, which do
not need to be configured at the tenant level.

Tenants
pace
Manag
ement

Tenant
Manag
ement

Service
Type
Manag
ement

Space
Type
Manag
ement

System
Manag
ement

● Operation Logs: View details about operation logs of
business accounts in the tenant space.

● Sign-in Logs: View details about sign-in logs of business
accounts in the tenant space.

● Menu Management: Manage operation menus in the
tenant space.

● Permission Management: Manage operation permissions
on menus in the tenant space.

User
Manag
ement

User
Manag
ement

● Organization: Manage OU information in the tenant
space.

● Employee: Manage business account information of
employees in the tenant space.

● Role: Manage function permission information of
employees in the tenant space.

● Account and Password Rule: Manage account and
password rules in the tenant space.

● Account Lock Management: Manage account lock status
in the tenant space.

● User Group Management: Manage employee group
information in the tenant space.

● Session Management: Manage sign-in sessions of
accounts in the tenant space.
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Permission Description

Online
Custo
mer
Service

Workb
ench

Audio and Video Workbench: When an agent signs in, the
voice and video workbench is automatically opened for
business handling.

Online
Studio

- Function permissions for the system administrator, which do
not need to be configured at the tenant level.

Call
Center
Monito
r

Monito
r
Configu
ration

● QC Relation Management: Manage inspection relations
between inspectors and agents.

● Full Screen Monitoring Configuration: Configure
fullscreen monitoring indicators.

● Report Subscribe Configuration: Configure subscribed
reports and periodically send information about the
subscribed reports to specified personnel via email. For
details about the email sending configuration, see Step 3.

● CMS System Configuration: This is a function permission
for the system administrator, which does not need to be
configured at the tenant level.

Monito
r
Manag
ement

● Agent Monitor: View agent sign-in information in the
tenant space, monitor agents, and dynamically adjust
agent resources based on business requirements. Tenant
administrators can monitor agent status, but cannot
perform inspection operations, such as skill queue
adjustment, on agents. Inspectors (whose platform role is
Quality checker) can perform inspection operations, such
as skill queue adjustment, on agents.

● Call QC: View the voice and video call details of agents in
the tenant space. Inspectors (whose platform role is
Quality checker) can preview or download recording files
of agent calls.

● Canceled Queuing Call Monitor: View details about
users who cancel queuing in the tenant space.

● Index Monitor: View data about the VDN, IVRs, skill
queues, and agents in the tenant space.

● Call Link Monitor: View details and tracks of calls in the
tenant space from 00:00 on the previous day.

● Offline Message Monitoring: View offline messages
received by agents in the tenant space.
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Permission Description

Report View the monitoring data of the call center, including the
following reports: Skill Queue Performance Report, Agent
Performance Report, Agent Outbound Call Report, Agent
Connection Operation Report, IVR Traffic Report, IVR
Traffic By AccessCode Report, Skill Queue Performance
Statistics Report by Access Code, Skill Queue Summary
Report, VDN Performance Report, VDN Performance
Statistics Report by Access Code, Abandoned Calls
(During Ringing) Summary Report, and Interval-based
VDN Traffic Report.

Intellig
ent
autom
atic
dialing

ISales
Manag
ement

● ISales Task Management: Configure outbound call task
details.

● Holiday Management: Set special dates and plan the
execution time of outbound call tasks.

● ISales Task Statistics: Monitor outbound call tasks and
check the execution of outbound call tasks.

● Outbound Black List Management: Configure the
outbound number blocklist to reduce invalid outbound
calls.

● Business Result Define: Define outbound call business
results to summarize business status.

● Outbound Call Result Definition: Define outbound call
execution results.

● Outbound Call Data Attribute Definition: Configure
different attributes for outbound call data and add
customer information.

● Outbound Call Template Management: Configure
outbound call task templates to reference templates
during outbound call task configuration.

● Special List Management: Configure the special list to
filter out invalid data during outbound call task
execution.

● Agent Work Statistics: Collect statistics on the outbound
call workbench and summarize outbound call tasks.

● Multimedia Marketing Management: Perform
multimedia marketing using SMS messages, emails, and
WhatsApp messages.

Outbou
nd
Execute

● Outbound Workbench: An agent can view and execute
outbound call tasks on the outbound call workbench.

● Appointment Outbound: An agent can reserve outbound
call tasks at specified time in advance.

Outbou
nd Call
Configu
ration

● Outbound Call File Server: Upload outbound call task
data from the server.

● Mapping Rule Import: Customize the mapping rules for
importing data related to outbound call tasks.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 33



Permission Description

Outbou
nd Call
DataSo
urce
Manag
ement

Back up and store outbound call data on other servers.

Outbo
und
Call
DataSo
urce
Manag
ement

- Back up and store outbound call data on other servers.

Intellig
ent
Trainin
g

Intellig
ent
training
manag
ement

Training Task Management: Configure training task details.

My
Trainin
g Tasks

My Tasks: An agent can participate in intelligent training
tasks.

Operat
ion
Risk
Contro
l

Operati
on Risk
Control

Function permissions for the system administrator, which do
not need to be configured at the tenant level. The
permissions include Strategy Management, Tenant
Strategy Configuration, Statistical Result, and Recording
Wording.

Operati
on Risk
Control

Operation Risk Control: View the execution of risk control
strategies.

Inspect
ion

Manual
Inspecti
on

Manage manual inspection rating rules, inspection tasks,
inspection categories, inspection relationships, and
inspection objects, view inspection results, and apply for
inspection review.

AI
Inspecti
on Rule

Manage AI inspection rules, including sensitive words,
sentences, inspection rules, rating settings, and business
scenarios.

AI
Inspecti
on
Result
Review

View the inspected call list, set sample inspection plans, and
view and handle inspection tasks.
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Permission Description

Knowl
edge
Base

Knowle
dge
Manag
ement

Manage and create knowledge.

Knowle
dge
Review

Review knowledge details.

Knowle
dge
Applica
tion

Search for knowledge and add knowledge to favorites.

Templa
te
manag
ement

Create and manage knowledge templates.

Survey
Config

Survey
Config

● Script Management: Configure survey details.
● Template Management: Manage survey templates.
● Questionnaire Query: Query the answer details of

surveys.
● Questionnaire Statistics: Collect statistics on details

about other business modules associated with surveys.
● My Answers: Query the survey details of the current

account.

Chann
el
Config
uration

Call
Center
Manag
ement

Function permissions for the system administrator, which do
not need to be configured at the tenant level.
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Permission Description

Call
Center
Configu
ration

Manage basic tenant space configurations.
● Basic Information: View basic tenant space information.
● Skill Queue: Manage tenant space skill queues.
● Agent Management: View tenant space agent

configurations.
● Called Route: Configure called routes.
● Access Code: View access code information of the tenant

space.
● Settings: Manage system parameter settings of the

tenant space. For details, see 2.17 Configuring Public
Resources and 2.3 Enabling Manual Services.
The permissions include Parameter Configuration,
Screen Pop-up, Call Reason, Mobile Agent, Callback
Url Configuration, Satisfaction Survey, SMS
Configuration, Authentication Configuration, Gray
Configuration, Gateway Configuration, Dynamic Data
Table, Page Configuration, Gateway monitoring,
Certificate, Rest Reason, Prompt Tone, Contact Data
Item, Resource Dump, Encryption Information
Management, Configuring the Voice Muting Agent,
Agent Routing Rules Configuration, Message flow
control management, Email Signature, System
Parameter Configuration, Special List, SP
Management, Federated App Management, UC
Integration, Voice Notification, Authentication, and
Harassment record review.

● Table Data: Query and configure data values in dynamic
data tables.

● Resource Dump Task: Manage business resource data
dump tasks.
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Permission Description

Agent
Inform
ation

● Agent Information: View information such as agent IDs,
skill queues, and business accounts.

● Contact Record: Query agent call records.
● Operation Record: Query agent operation record details.
● Transfer Record: Query details about call transfer records

of agents.
● Sign-In Log: Query agent sign-in records.
● Leave Message: Manage and reply to offline messages of

the current account.
● Agent Parameters: An agent can customize parameters

such as the calling number for making outbound calls,
agent answering mode, whether to integrate the
OpenEye softphone in the web system, and video display
of the OpenEye integrated with the web system.

● Rest Record: Query details about agent rest records in
the tenant space.

● Bidirectional Call Record: Query details about
bidirectional call records after the one-click bidirectional
call feature is enabled.

● Document Management: Query contract signing
information after the contract digital signature feature is
enabled.

● Reset Skill Record: Query skill queue adjustment details.
● Identity Authentication Record: Query details about all

identity authentication records.

Tenant
Space
Manag
ement

Function permissions for the system administrator, which do
not need to be configured at the tenant level.

IVR
Manag
ement

● Intelligent IVR: Configure intelligent IVR flows.
● IVR Voice: Manage uploaded voice files.
● Flow Management: Manage common IVR flows.
● Process Transfer Record: View the records of call transfer

to IVR flows in the tenant space.
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Permission Description

Notific
ation
Center

● View Notification: View the content of received
notifications.

● Send Notification: This is a function permission for the
system administrator, which does not need to be
configured at the tenant level.

● Notification Template Configuration: This is a function
permission for the system administrator, which does not
need to be configured at the tenant level.

● Agent Send Notification: Agents can send only internal
messages in internal notifications. They can send bulletin
notifications only after an administrator configures the
bulletin permission for them.

● Administrator Send Notification: Send notifications to
agents via email, SMS message, or bulletin.

● Notification Template: Configure administrator
notification templates.

● Variable Configuration: Use variables when configuring
internal message templates to send internal messages.

● Message Route Configuration: Distinguish email
messages from SMS messages.

● Notification Type Configuration: Configure different
notification types, for example, bulletin.

System
Manag
ement

System Version: This is a function permission for the system
administrator, which does not need to be configured at the
tenant level.

Custom
er
Center

Customer Center Management: Manage customer
information in the tenant space.

Service
Chann
el
Config
uration

Social
Media
Operati
ons

Permissions for operations personnel.

Operati
on
Manag
ement

● Channel Configuration: Configure multimedia access
channels, including WeChat, web, X (Twitter), email,
WhatsApp, Facebook, LINE, and 5G RCS channels.

● Multimedia Library Management: Configure multimedia
data of the common phrase, voice, video, image, address,
personalized emoji, and card template types for agents to
make calls.

● Workbench Configuration: Configure working time and
non-working time.

● Email Message Management: Manage emails.
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Permission Description

Online
Custom
er
Service

● Online Chat Workbench: An agent can handle business
information accessed through the WeChat, web, X
(Twitter), email, WhatsApp, Facebook, LINE, and 5G RCS
channels.

● Personalized Common Language: Configure common
phrases used by agents to handle businesses.

Home - Configure functions frequently used on the home page.

Case
Manag
ement
2.0

Case
Workb
ench

Create cases, merge cases, and create tasks.

Case
Configu
ration

● Case Status
● Case Field
● Case Template
● Case Template Content
● Case Type
● Case Role
● User Role

Historic
al Case

View historical cases.

My
Time

Agent
Schedul
e

● My Schedule: View my agent schedule.
● Other Schedules: View the agent schedules of others.

Trade Trade

Time-
off

● Details
● Calendar
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Permission Description

WFM Configu
ration

● BU
– Edit: Edit BUs.

● Skill Queue
● Agent

– Edit: Edit agents.
– Move Agent: Move agents from an OU to another.

● Site
– Edit: Edit sites.
– Move Agent: Move agents from an OU to another.

● Color
– Edit: Edit special colors.

● Activity
– Edit: Edit activities.

● State Group
– Edit

Adhere
nce

Details

Trade ● Trade List
– Approve Trade

Perfor
mance

Monitor

Schedul
e

● Scenario
– Publish: Publish schedule scenarios to the master

schedule.
– Edit: Edit schedule scenarios.
– Build: Build schedule scenarios.

● Master Schedule
– Edit: Edit the master schedule.
– Approve
– Clear
– Swap Shift

● Approve Change

Calend
ar

● Calendar Item
– Change Status
– Edit

● Time-off Limit
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Permission Description

Policy ● Time-off
– Edit

● Exception Type
– Edit: Edit exception types.

● Shift
– Edit: Edit shifts.

● Contract
– Edit: Edit contracts.

● Rotating Pattern
– Edit: Edit rotating patterns.

Forecas
t

● Scenario
– Adjust: Adjust the volume build data and staffing

build data after forecasting.
– Edit: Edit forecast scenarios.
– Build: Build forecast scenarios.

● Overlay
– Edit

● Historical Data
– Edit

AppCu
be
Applic
ation
Config
uration

AppCu
be
service
configu
ration
center

● The AppCube feature must be enabled.
● Go to the AppCube configuration page.

 

Table 2-2 Operation permissions

Permission Description

Messa
ge
Center

Messa
ge
Send

Send internal messages.

Notific
ation
Center

Sendin
g a
Bulleti
n

Send bulletins through the notification center.
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Permission Description

Group-
send
interna
l
messa
ges

Send internal messages to groups through the notification
center.

Agent
Mana
geme
nt

Modify
ing
Agent
Fixed-
Line
Phone
Numbe
r

An agent can modify Fixed-Line/Mobile Number on the
agent information page.

Config
ure
Agent

Configure agents, cancel agent configuration, and configure
agents in batches on the agent management page.
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Permission Description

Call
Center
Mana
geme
nt

Connec
tion
Manag
ement

Configure call answering operations that can be performed
by agents.
● Show Busy/Idle: The busy state indicates that the agent is

handling an inbound call, and the idle state indicates that
the agent is ready to answer an inbound call at any time.

● Break/End Break: An agent leaves and cannot handle
businesses. The rest duration does not exceed 24 hours.

● Transfer: An agent can transfer an inbound call to an
external number, another agent, or a skill queue. After an
inbound call is transferred, the call-related information is
also transferred.

● Hold/Unhold: An agent can hold a call with a customer.
During the hold period, the customer can hear the hold
music. The agent can perform other operations or make
an outbound or help call, and then continue to talk with
the customer.

● Outgoing Call: An agent can initiate a call.
● Three-Party Call: During a call between an agent and a

customer, the agent can initiate a three-party call with
another agent who is asked for help. If one party hangs
up, the other two parties can still talk with each other.

● Help-seeking: When an agent encounters a task that
cannot be handled immediately, the agent can ask for
help. If the agent selects two-party help, the customer's
call is held. If the agent selects three-party help, a three-
party call is set up.

● Mute/Unmute: An agent can mute or unmute the local
device.

● End Call: An agent can proactively end a call.
● Answer: An agent receives a call from a customer and

chooses to answer the call.
● Audio/Video switching: An agent can switch a video call

to a voice call or switch a voice call to a video call.
● Internal Call: An agent can dial the number of another

internal agent when there is no customer call.
● Agent multi-channel support: An agent can chat with

customers through multimedia access channels.
● Callback: The voice and video workbench allows agents to

initiate calls based on historical contact records to
continue interrupted businesses.

● Two-stage Dialing: An agent can call back a customer
number that exists in call records.

● Co-browsing
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Permission Description

Contac
t
Record
Manag
ement

● Querying All Contact Records: Query the contact records
of all business accounts.

● Play Recording Online: Play recordings in contact records
online.

● Recording Download: Download recording in contact
records.

● Contact Record Export: Export contact records.

Quality
Check

Inspectors can intervene in calls of common agents to ensure
smooth business handling, and can manage inspection
results. Inspection operations include Listen, Insert,
Switchover, Intercept, Forcible Exit, Forcible Set Idle,
Forcible Set Busy, Whisper, Query All Inspection Results,
Update Inspection Result, Delete Inspection Result,
Multimedia Session Monitoring, Multimedia Session
Insertion, and Multimedia Session Interception.

Operat
ion
Record
Manag
ement

The permissions include Query ALL Operation Record,
Query ALL Transfer Record, Query ALL Sign-In Log, Query
ALL Rest Record, and Sign-In Log export.
Rest record export: Export rest records.
Forwarding Logs export: Export transfer records.
Operation Logs export: Export operation records.

Privacy
Statem
ent

Function permissions for the system administrator, which do
not need to be configured at the tenant level.

Leave
Messa
ge
Manag
ement

● Play Leave Message: Play the recording of a message
online.

● Download Leave Message: Download the recording file
of a message.

● Query All Leave Message: Query all message records of
an agent.

IVR
Voice
Manag
ement

File Upload: Upload voice files for IVR flows.

Reset
Passwo
rd

Reset Tenant Password: Reset the passwords of employee
accounts in the tenant space.

Reset
Data

Reset tenant space system parameters on the Configuration
Center > System Management > Tenant Parameter page.
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Permission Description

IVR
Flow
Manag
ement

-

Tenant
AK/SK
Config
uration

Function permissions for the system administrator, which do
not need to be configured at the tenant level.

Email
Attach
ment

Upload or download attachments in an email when sending
an email notification. The permissions include Upload Email
Attachment and Download Email Attachment.

User
numbe
rs are
display
ed in
plainte
xt

Customer numbers are displayed in plaintext and are not
anonymized.
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Permission Description

Agent
Workb
ench

● Transfer pop-up parameters: If the page type of an
inbound call screen pop-up is set to external page,
parameters are carried when the third-party page is
accessed.

● Query customized data on the pop-up screen: Query the
customized data values on an inbound call screen pop-up.

● Modify customized data on the pop-up screen: Update
the customized data values on an inbound call screen pop-
up.

● Mail Agent Forwarding: An agent can forward emails.
● Local Multimedia File Sending by Agents: An agent can

send multimedia files.
● Local Attachment Sending by Email Agents: An agent

can upload local attachments when sending an email.
● Email Agent CC Bcc: An agent can set Cc and Bcc

recipients when sending an email.
● Send SMS Notifications: An agent can send SMS

notifications to customers during customer contact, view
message sending records in customer contact details, and
resend SMS notifications to customers.

● Send WhatsApp Notifications: An agent can send
WhatsApp notifications to customers during customer
contact, view message sending records in customer
contact details, and resend WhatsApp notifications to
customers.

● Send Email Notifications: An agent can send email
notifications to customers during customer contact, view
message sending records in customer contact details, and
resend email notifications to customers.

● Identity Verification: An agent can perform identity
authentication.

Basic
data
table
manag
ement

View demasking data: View demasked data in customized
dynamic data tables.

downlo
ad SK

Download SK information to the local PC.

Fullscr
een
Monito
r

● Viewing Public Large-Screen Monitoring: View details
about fullscreen monitoring data.

● Edit Public Large-Screen Monitoring: Customize
fullscreen monitoring data parameters.

● Querying Data of All Organizations: View the fullscreen
monitoring data of all OUs.
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Permission Description

Email
agent
manag
ement

● Dispatch emails to other agents: Forward emails to other
agents for handling.

● View all agent emails: View the emails sent and received
by all agents in the tenant space.

Report Querying All Organization Report Data: Query the report
data of all OUs in the tenant space.

Transfe
r
Record
Manag
ement

● Play Recording Online: Play recordings in call transfer
records online.

● Recording Download: Download recordings in call
transfer records.

Docum
ent
Manag
ement

Preview Document: Preview documents.
Download Document: Download documents.
Operation All Documents: Search for or invalidate any
document in the tenant space.

Skill
Queue
Manag
ement

Skill Queue Data Export: Export skill queue information.

index
monito
ring

Querying Data of All Organizations: Query the monitoring
indicator data of all OUs in the tenant space.

Special
List

Harassment record review: Review harassment records
submitted by agents. This permission is assigned to tenant
administrators by default and does not need to be configured
for tenants.

 

Table 2-3 API permissions

Permission Description

MR rest api
auth

Obtain the MR node service permission.

CaseBDF rest
api auth

CaseBDF rest api auth

SLA rest api
auth

Obtain the SLA node service permission.
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2.2.3 Configuring Employee Information
Employees indicate personnel employed by an enterprise. Employee accounts can
be used to sign in to the system and perform business operations.

Context
Assign administrator permissions to the new employee Jack in department A so
that Jack can work as an administrator.

Procedure

Step 1 Configure an OU. For details, see 2.2.1 Configuring OUs.

Step 2 Choose Configuration Center > Employee Center > Employee. The employee
information management page is displayed. The OU information is displayed on
the left, and employee information under the OU is displayed on the right.

Figure 2-16 Employee

Step 3 (Optional) Enter an OU name to fuzzily search for all employee information under
an OU based on the OU name.

Step 4 Click New. On the Add Employee page, configure employee information.
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Figure 2-17 Employee Info

● Account (mandatory): Employee account used by business personnel to sign
in to the AICC, for example, j100006.

● Employee (mandatory): Employee name, for example, Jack.
● Email (mandatory): Business email address used by an employee to receive

notifications.
● Phone Number: Phone number of an employee.

To receive the SMS verification code, you need to add the correct country
code before the mobile number, for example, 8612312345678 or
+8612312345678.

● Account and Password Rule Group (mandatory): Password setting rule of an
employee. By default, Default is selected.

● New password and Confirm Password (mandatory): Password for the first
sign-in.

NO TE

Set a new password based on this password during the first sign-in. The new password
must contain at least two different characters from the initial password.

Set a password that meets the password complexity requirements as prompted.

● Owning Organization (mandatory): OU to which an employee belongs.
● Accessable Organizations: OUs that can be accessed by an employee.
● Title: Title of an employee, which is used for the AI inspection business to

determine the operation permissions of the employee in the inspection task
handling process.

● Role: Function permissions and menu permissions that the business account
of an employee has. For details about how to configure role permissions, see
2.2.2 Configuring Role Permissions.

● Description: Remarks about an employee.
● Manager: Unavailable when an employee is created. Configure the manager

in the OU.

Step 5 Complete the employee creation and open the Configure Agent page.
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● Click Save to complete the employee creation. On the Employee page, click
Set corresponding to the new employee to open the Configure Agent page.

● Click SaveAndConfigure to complete the employee creation and directly open
the Configure Agent page.

Step 6 Configure agent information.

Figure 2-18 Configure Agent

● Agent Info
– Employee ID (mandatory): Select an agent ID and its softphone number,

agent type, and platform role.
– Agent Type: The default value is the agent type associated with the

selected Employee ID.
– Platform Role (mandatory): The default value is the platform role

associated with the selected Employee ID. The value can be changed.
The options are Common agent, Quality checker, and Callout agent.

– Softphone Number: The default value is the softphone number
associated with the selected Employee ID.

– Authentication Mode (mandatory): Agent information authentication
mode. The value is UAP Authentication.

– Agent Mobile/Fixed-Line Number: Mobile number or fixed-line phone
number of the agent.

– Home QC group: Inspection group to which the agent belongs. This
parameter is available when Platform Role is set to Quality checker.

– Home Traffic Group: Agent group to which the agent belongs.
– Intelligent Recognition: Configure whether the agent is an intelligent

agent. This switch is turned off by default. In addition to basic voice
control functions, intelligent agents support real-time ASR and related
intelligent recommendation functions. Before turning on this switch,
ensure that the number of agents for which intelligent recognition is
enabled does not exceed the number of intelligent agents allocated when
the tenant is created.

– Automatic Session Summary: This switch is turned off by default. After
this function is enabled, the system can intelligently summarize the call
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content, issue resolution result, and customer satisfaction when Call
Reason is configured on the workbench.
This parameter is available only when the Automatic Conversation
Summary feature is enabled and the Intelligent Recognition function is
enabled.

– Smart Form Filling: This switch is turned off by default. After this switch
is turned on, the system automatically extracts the information from the
dialog text between a customer and an agent when the agent creates a
case on the workbench. The system fills the information in the
corresponding case form to complete the case filling task, so that the
agent does not need to manually enter the information.
This parameter is available only when the tenant parameter Enabling
the Intelligent TT Filling Feature is set to Yes.
To turn on Smart Form Filling, turn on Intelligent Recognition first.

– Reply polishing: This switch is turned off by default. After this switch is
turned on, online agents can polish the plain text in the text box during a
session on the workbench. An agent can use the scripts to improve
service professionalism.
This parameter is available only for multimedia agents or versatile agents
for whom Reply polishing and Intelligent Recognition are enabled.

– Phone–Only Agent: After this switch is turned on, an agent can dial a
specified access code to access an IVR flow, press a key as prompted to
enter the agent ID and password to sign in, and answer calls on a mobile
phone. When this switch is turned on, system O&M personnel need to
customize the phone–only agent process for the tenant based on the
platform, and the tenant needs to provide number resources for accessing
the phone–only agent process.

– Agent Number Anonymization Flag: Flag for a third-party to mark
whether an agent has the anonymization feature. This is not a feature
switch. The anonymization feature enables agents to customize the
calling number displayed on the customer side (the calling number
displayed to the customer) and the calling number displayed on the
agent side (the calling number displayed to the agent).

● Sign-in Password
– New Password and Confirm Password: Password used by the agent to

log in to the softphone.
– Current account password: Password of the business account for which

employee information is configured, which is used to ensure account
security.

– Password Validity Period (Days): Validity period of the softphone login
password.

– Verification Code: Authentication mode used for password settings to
guarantee security of the current account. The verification code can be a
mobile phone verification code or an email verification code. For details
about the authentication mode, see the value of Two-factor
Authentication Method set by the system administrator.
Verification Code is available only when Two-factor Authentication
Method is set to SMS verification code or Email verification code. You
can click Obtain to obtain a verification code.
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▪ A verification code is valid for 1 to 5 minutes and is specified by the system
parameter Two-factor Authentication System-level Verification Code
Validity Period set by the system administrator.

▪ The interval for obtaining a verification code is 1 minute. If you enter a
verification code correctly but password change fails, you can obtain a new
verification code immediately.

● Skill Information
– Skill Type: Skill type of the agent configured for the current employee.

The options are Skill Queue and Skill Group.

– Select Skill Queue: Click  to select skill queues to be associated with
the agent configured for the current employee.

Step 7 (Optional) Filter data.
● Search for employee information by employee.
● Click More, enter an account, select a status, and click Search to filter

detailed data.

● Click  to refresh real-time data.
● Import employee information.

a. Click . The Import Users page is displayed.

Figure 2-19 Importing a user

b. Click Download Template to download the user information template to
the local PC.

c. Enter the user information.
For details about the requirements for importing user information, see
the description of User import information on the readme sheet.

d. Click  to upload a user information list.
e. Click Confirm. An import task is created.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 52



f. Click  and select Import User List to view the user import task list.
Select an import task according to the import time and click download
to view the import result.

Figure 2-20 Importing a user list

● Download employee information.

a. Select employees to be downloaded in batches and click  to create an
export task. If no employee is selected, information about all employees
is downloaded by default.

Figure 2-21 New export task

b. Enter the password for compressing the exported file and click OK to
create an export task.

c. Click  and select Export take view to view the export task list. Click
download corresponding to an export task based on Task Time to
download employee information to the local PC.
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Figure 2-22 Export task view

Step 8 Operate employee information in batches.
● Disable: Disable employee accounts in batches.

To search for a disabled account, set the search criterion Status to Forbid and
click Search.

CA UTION

A disabled account can be used only after it is deleted and then created
again. Exercise caution when performing this operation.

● Delete: Delete an invalid employee account.
A created account cannot be directly deleted. You need to disable the account
before deleting it.

● Suspend: Suspend an account that has security issues so that the account
cannot be used to sign in to the system.

● Resume: Resume a suspended account so that the account can be used to
sign in to the system.

● Reset Password: Reset the password of an employee account. The new
password takes effect only after the correct sign-in password of the current
operator is entered.
A verification code is required for resetting the password to guarantee security
of the current account. The verification code can be a mobile phone
verification code or an email verification code. For details about the
authentication mode, see the value of Two-factor Authentication Method
set by the system administrator.
Verification Code is available only when Two-factor Authentication
Method is set to SMS verification code or Email verification code. You can
click Obtain to obtain a verification code.
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– A verification code is valid for 1 to 5 minutes and is specified by the system
parameter Two-factor Authentication System-level Verification Code Validity
Period set by the system administrator.

– The interval for obtaining a verification code is 1 minute. If you enter a verification
code correctly but password reset fails, you can obtain a new verification code
immediately.

● Adding Roles in Batches and Deleting Roles in Batches: Set roles for
accounts in batches.

● Add Access Organization: Set accessible OUs for accounts in batches.

● Configuring Employees: If agent IDs have not been configured for employee
accounts, you can configure agent IDs and related agent information for the
employee accounts in batches.

● Cancel Configuration: If agent IDs have been configured for employee
accounts, you can cancel the configured agent IDs and related agent
information for the employee accounts in batches.

----End

2.2.4 Importing Federated Users
The VDN supports import of third-party system users, such as federated users.

Prerequisites
● The system administrator has added a federated app.

● The system administrator has configured a third-party authentication system
for a tenant when creating the tenant.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Employee Center > Employee.
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Step 2 Choose Import Federated User > Import Federated User, click Download
Template, open the template, and add information about the users to be
imported.

A maximum of 10,000 records can be imported using a template. The template
size cannot exceed 10 MB.

Step 3 Click , select the modified template, and click Submit.

Step 4 Click OK to close the dialog box.

Step 5 Choose Import Federated User > Federated User Import Result to view the
import result.

If Status is Success, the import is successful.

Step 6 Click Download in the Import Result column to download the import result
details.

NO TE

If the start time exceeds seven days, the Download button is not displayed and the import
result cannot be downloaded.
The downloaded data contains personal data. Exercise caution when processing the
downloaded data to prevent personal data leakage and abuse.

Step 7 Return to the Configuration Center > Employee Center > Employee page and
view the new federated user in the employee account list.

Step 8 Configure a role for the federated user. For details, see 2.2.2 Configuring Role
Permissions.

----End

2.2.5 Configuring User Groups
User groups can be used to distinguish inspection objects during configuration of
inspection relationships.

Procedure
Step 1 Choose Configuration Center > Employee Center > User Group.

Figure 2-23 User Group
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Step 2 Click  to add a user group and configure basic user group information.

Figure 2-24 Creating a User Group

● User Groups: Enter a user group name, which is mandatory. An example is
Administrator group. The value can contain a maximum of 64 characters
and cannot contain the following special characters: <>

● Description: Enter a user group description, which is optional.

Step 3 Click Save. The user group is created successfully.

Step 4 (Optional) Customize user group information.

● Select a user group from the user group list and click  to delete the user
group.

● Select a user group and click  on the Basic Info page on the right to modify
the name and description of the user group.

● Enter a user group name and click  to fuzzily search for user groups based
on the user group name.

Step 5 Select the new user group and click Add to assign employees to the user group.
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Figure 2-25 Assign Employee

Step 6 Click Save to save the assigned employees.

Step 7 (Optional) Configure employee information under the user group.

● Enter an account and click  to fuzzily search for employee information
based on the account.

● Select multiple employees and click Batch Delete to delete them from the
user group in batches.

● Click Delete corresponding to an employee to delete a single employee from
the user group.

----End

2.2.6 Configuring Account and Password Rules
The AICC provides a default account and password rule group Default, which
cannot be modified or deleted. A tenant administrator can customize account and
password rules.
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Procedure
Step 1 Choose Configuration Center > Employee Center > Account and Password

Rule.

Figure 2-26 Account and Password Rule

Step 2 Click  in the Rule group list to add a rule group.

Figure 2-27 Adding a Rule Group

Step 3 Customize the name and description of the rule group, and click Save. The rule
group is added successfully.

Step 4 (Optional) Customize rule group information.

● Click  to delete a customized rule group.

● Click  to modify the name and description of the rule group.

● Enter a rule group name and click  to fuzzily search for rule groups based
on the rule group name.

Step 5 Select the new account and password rule group. In the Rule List on the right,
click Modify corresponding to the rule to be modified to modify the rule.

NO TE

Changing or disabling some password rules (such as Minimum password length. and The
password must contain digits.) will affect password security and bring security risks.
Exercise caution when changing or disabling these rules.
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Step 6 Change the settings in the Value and Enable columns, and click Save.

----End

2.2.7 Managing Account Locks
A tenant administrator can manually lock or unlock agent accounts to ensure
agent account security and proper use.

Procedure
Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >

Employee Center > Account Lock.

Figure 2-28 Account Lock

Step 2 Enter the agent account to be managed and click  to search for business
account information.

Step 3 Manage the agent account.
● Click Lock to lock the business account and restrict agent sign-in.
● Click Unlock, enter the password of the current operator account, and click

OK to unlock the business account and enable normal agent sign-in.

Figure 2-29 Unlock

A verification code is required for unlocking the account to guarantee security
of the current account. The verification code can be a mobile phone
verification code or an email verification code. For details about the
authentication mode, see the value of Two-factor Authentication Method
set by the system administrator.
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– A verification code is valid for 1 to 5 minutes and is specified by the system
parameter Two-factor Authentication System-level Verification Code Validity
Period set by the system administrator.

– The interval for obtaining a verification code is 1 minute. If you enter a verification
code correctly but the account fails to be unlocked, you can obtain a new
verification code immediately.

----End

2.2.8 Managing Sessions
A tenant administrator can view information about established sessions of agents
online and manually terminate specified sessions.

CA UTION

If the agent for whom session termination is performed is in a call, the session
termination does not affect the call. If the agent performs other operations or
refreshes the page, the system forcibly signs out the agent. Therefore, exercise
caution when terminating sessions.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Employee Center > Session Management.

Figure 2-30 Session Management

● Account: Signed-in business account.

● Client Ip: Agent sign-in IP address.

● Begin Time: Time when an agent signs in to the AICC.

Step 2 Set the data filter criterion.

● Enter an account to search for session information by account.

● Click  to refresh data based on the criterion or refresh real-time data.

Step 3 Click  to set the table header.
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Figure 2-31 Column Configuration

● Click  or  to deselect a column.
● Drag a selected column to change its sequence.
● Click Reset to reset the column configuration to the state when the dialog

box is opened.

After the configuration is complete, click OK to save the new column
configuration. Data is displayed based on the new column configuration.

Step 4 Click Delete corresponding to a session to terminate it.

NO TE

After a session is terminated, the client cannot continue to perform operations and returns
to the sign-in page.

----End

2.3 Enabling Manual Services
After the employee information of the VDN is configured, you can configure the
service content.

2.3.1 Voice and Video Services
After a tenant administrator configures skill queues and called party routes and
associates business accounts with agent IDs, agents can handle call businesses.

2.3.1.1 Maintaining a Tenant Space Skill Queue

After the VCC is added, the tenant administrator needs to maintain the skill
queues and agent accounts on the VCC.

Step 1 Log in to the AICC as the tenant administrator.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 62



The tenant administrator account is created by the system administrator during
tenant space enabling and distributed to the enterprise.

Step 2 Choose  > Call Center Configuration > Skill Queue, click New to add a skill
queue for the VCC, and click Complete.

The parameters related to a skill queue are described as follows:

● Max. Calls in Queue
Maximum number of customers who are allowed to enter a queue when all
agents are busy.
If the number of customers in the queue reaches this value, no more
customers who dial the customer service hotline can be added to the queue.

● Max. Waiting Time (s)
Maximum period for a customer to wait in the queue when all agents are
busy.
If the waiting duration of a customer in the queue exceeds this value, the
customer will be disconnected.

● Type
Agents of the audio/video type handle voice businesses only. Agents of the
multimedia type handle multimedia services only.

● Duration(s) in arranging state
Duration for an agent to enter the arranging state after a call ends. The
default value is 5 seconds.
If the duration exceeds this value, the agent enters the idle state and can
answer calls from customers.

● Config Skillpara
Three scenarios can be configured: Skill Timeout, Skill Busy, and Skill
NoAgents.
Process Method
The options are Release and Transfer. If the process method is Transfer, you
need to add an IVR flow or a skill queue. Then, calls are transferred to the
new IVR or skill queue.
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● For compatibility purposes, Type of a skill queue is set to Audio/Video by default if it is
left empty.

● You can click Refresh to display the latest data.
● Process Method is set to Release by default.
● If the new skill queue is set to an audio/video type, you can select IVR or Skill Queue

from the Type column on the Skill Queue page.
● If the new skill queue is set to a multimedia type, you can select only Multimedia from

the Type column on the Skill Queue page.

----End

2.3.1.1.1 Configuring the Queue Waiting Tone

After a skill queue is added, a tenant administrator can customize the queue
waiting tone for the skill queue.

Prerequisites
The skill queue to be configured is of the voice or video type.

Business Scenarios
● A prompt tone needs to be played when a customer is waiting in a queue

before being connected to an agent.
● A prompt tone needs to be played when a customer is waiting in a queue

after an agent transfers the inbound call.

Procedure

Step 1 Upload the customized queuing tone.

For details, see 2.6.3.2 Managing Voice and Video Resources. Set Usage
Scenario to tone.

Step 2 Contact the system administrator to approve the uploaded queue waiting tone.

After the waiting tone is approved, go to the next step.

Step 3 Choose Configuration Center > Employee Center > Skill Queue, select a voice or
video skill queue, and click Edit in the Operation column.

Step 4 Click  to expand Skill Parameter Configuration.

Step 5 Under Queuing and waiting configuration, click Queuing Method and choose
Customizing the Wait Tone.
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Step 6 Click Please select a waiting tone, select the approved prompt tone, and click
OK.

Step 7 Click Save.

----End

2.3.1.1.2 Configuring the Hold Waiting Tone

After a skill queue is added, a tenant administrator can customize the hold
waiting tone for the skill queue.

Prerequisites
The skill queue to be configured is of the voice or video type.

Business Scenarios
A prompt tone needs to be played when an agent holds a voice call with a
customer.

Procedure

Step 1 Upload the customized hold waiting tone.

For details, see 2.6.3.2 Managing Voice and Video Resources. Set Usage
Scenario to tone.

Step 2 Contact the system administrator to approve the uploaded hold waiting tone.

After the waiting tone is approved, go to the next step.

Step 3 Choose Configuration Center > Employee Center > Skill Queue, select a voice or
video skill queue, and click Edit in the Operation column.

Step 4 Click  to expand Skill Parameter Configuration.

Step 5 Under Keeping and waiting configuration, click Keeping Method and choose
Customizing the Keeping Tone.

Step 6 Click Please select a keeping tone, select the approved prompt tone, and click
OK.

Step 7 Click Save.

----End

2.3.1.2 Configuring Called Routes
After receiving a call from a customer, the CTI routes the call to an IVR or agent
based on the routing policies. To allow agents to answer calls, you need to
configure called routes.

Prerequisites
A tenant has been created.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Called Party.

Step 2 Click New to create a called route for the VDN.

Figure 2-32 Creating a Called Party Configuration

The parameters are described as follows:

● Access Code: Click  to select an access code in the dialog box that is
displayed. The access code type is displayed in the dialog box. Select an access
code of the Audio/Video type for the manual voice business. You can select
an access code of a different type as required.

● Extension Code: Enter the number that needs to be dialed following the
access code to route to the target device. In this example, Extension Code is
set to 1, indicating that a customer needs to dial 66881 to access the
defaultAudioSkill skill queue.

● Device Type: Select Skill Queue for the manual voice business.

● Skill Queue: Click  to select a skill queue in the dialog box that is
displayed. The skill queues displayed in the dialog box are of the same type as
that of the access code. For example, if the access code is of the Audio/Video
type, all available skill queues are of the same type.

Step 3 Click Save to save the configuration.

----End

2.3.1.3 Associating an Allocated Agent ID with a Business Account and Skill
Queue

After a tenant administrator allocates a business account and skill queue to an
agent ID, the agent can handle voice and video call businesses.
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Prerequisites

A tenant has been created.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Employee Center > Agent Management.

Step 2 Select an agent ID and click Configure in the Operation column. The Agent Info
Configuration page is displayed.

Step 3 Configure a business account and skill queue.

Figure 2-33 Agent Info Configuration page

● Platform Role (mandatory): Select an agent role. Select Common agent for
the manual voice business.
– Common agent: This role can answer or transfer inbound calls from

customers.
– Quality checker: This role can intervene in calls between common agents

and customers. For example, this role can perform operations, such as
insertion, interception, and forcible busy state setting, to coach and
supervise agents' handling of inbound calls.

– Callout agent: This role can answer, transfer, or reject inbound calls from
customers.

● Agent Type (mandatory): Select an agent type based on the type of
businesses to be handled. Select Audio agent for the manual voice business.
– Voice agent
– Video agent
– Multimedia agent

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 67



– Versatile agent
● Agent Mobile/Fixed-Line Number: Enter a mobile number or fixed-line

phone number used by the agent. Leave this parameter empty for the manual
voice business.

● Account: Select a created employee account. For details, see 2.2.3
Configuring Employee Information. You can use the tenant administrator
account created during tenant creation first.

● Authentication Mode: Select a softphone authentication mode. Retain the
default value UAP Authentication.
– UAP Authentication: A softphone number and password need to be used

to log in to the OpenEye.
– Unified authentication: The system automatically authenticates a

softphone.
● Password Validity Period (Days): Enter the validity period of the agent ID

password, in days. Retain the default value.
● Intelligent Recognition: Configure whether the agent is an intelligent agent.

This switch is turned off by default. In addition to basic voice control
functions, intelligent agents support real-time ASR and related intelligent
recommendation functions. Before turning on this switch, ensure that the
number of agents for which intelligent recognition is enabled does not exceed
the number of intelligent agents allocated when the tenant is created.

● Automatic Session Summary: This switch is turned off by default. After this
function is enabled, the system can intelligently summarize the call content,
issue resolution result, and customer satisfaction when Call Reason is
configured on the workbench.
This parameter is available only when the Automatic Conversation
Summary feature is enabled and the Intelligent Recognition function is
enabled.

● Smart Form Filling: This switch is turned off by default. After this switch is
turned on, the system automatically extracts the information from the dialog
text between a customer and an agent when the agent creates a case on the
workbench. The system fills the information in the corresponding case form to
complete the case filling task, so that the agent does not need to manually
enter the information.
This parameter is available only when the tenant parameter Enabling the
Intelligent TT Filling Feature is set to Yes.
To turn on Smart Form Filling, turn on Intelligent Recognition first.

● Reply polishing: This switch is turned off by default. After this switch is
turned on, online agents can polish the plain text in the text box during a
session on the workbench. An agent can use the scripts to improve service
professionalism.
This parameter is available only for multimedia agents or versatile agents for
whom Reply polishing and Intelligent Recognition are enabled.

● Phone–Only Agent: After this switch is turned on, an agent can dial a
specified access code to access an IVR flow, press a key as prompted to enter
the agent ID and password to sign in, and answer calls on a mobile phone.
When this switch is turned on, system O&M personnel need to customize the
phone–only agent process for the tenant based on the platform, and the
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tenant needs to provide number resources for accessing the phone–only agent
process.

● Agent Number Anonymization Flag: Flag for a third-party to mark whether
an agent has the anonymization feature. This is not a feature switch. The
anonymization feature enables agents to customize the calling number
displayed on the customer side (the calling number displayed to the
customer) and the calling number displayed on the agent side (the calling
number displayed to the agent).

● Skill Type: Select Skill Queue and click  to set the skill queues of
the agent. Alternatively, select Skill Queue Group and set the skill queue
group of the agent. If multiple skill queues need to be added, ensure that the
media types of all the skill queues are the same, except for versatile agents.
For example, the media types of all the skill queues are voice and video, or
multimedia. Click default to specify the default skill queue.

NO TE

● Multiple default skill queues can be set, but only one default skill queue can be set for
each skill queue type.

● If Agent Type is set to Video agent, set the number of video agents allowed when
applying for tenant resources.

● If Agent Type is set to Multimedia agent, set the number of multimedia agents
allowed when applying for tenant resources.

● If Agent Type is set to Versatile agent, set the number of versatile agents allowed
when applying for tenant resources.

● To add more business accounts, choose Configuration Center > Employee Center >
Employee.

Step 4 Click Save. The business account and skill queue are associated with the agent ID.

Step 5 (Optional) Click Configure in the upper right corner of the page. On the Batch
Agent Info Configuration page, configure agent information in batches.
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Figure 2-34 Batch Agent Info Configuration page

● Batch Select: Select agents to be configured by agent ID or agent ID
segment.

● Agent Info Configuration: Set parameters by referring to Step 3.

Step 6 (Optional) Select some agents and click  to export agent information in

batches, or directly click  to export all agent information.

NO TE

The exported data contains personal data. Exercise caution when processing the exported
data to prevent personal data leakage and abuse.
If the tenant parameter Specifies whether to set the password of the compressed file
for exporting data. is set to No, an export task can be added without entering a
compression password.

----End

Follow-up Procedure
The tenant administrator needs to reset the agent's softphone password. The
system randomly generates a password. The agent can change the password later.

Step 1 Sign in to the system as a tenant administrator and choose Configuration Center
> Employee Center > Agent Management.

Step 2 Select an agent ID and click Reset Softphone Password in the upper right corner
of the page.
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NO TE

Remember the softphone number bound to the agent ID, which will be used during
verification.

Verification Code is available only when Two-factor Authentication Method is set to
SMS verification code or Email verification code. You can click Obtain to obtain a
verification code.

Step 3 Set Current Account Password and click OK.

----End

After the configuration of a signed-in agent is modified, the agent needs to sign in
again for the modification to take effect.

2.3.1.4 Configuring the Agent Answering Mode

After a skill queue is added, a tenant administrator can customize the agent
answering mode for the skill queue.

Prerequisites

The skill queue to be configured is of the voice or video type.

Business Scenario

A tone needs to be played to a customer when an agent answers a call from the
customer.

Procedure

Step 1 Upload the customized voices before and after the employee ID.

For details, see 2.6.3.2 Managing Voice and Video Resources. Set Usage
Scenario to before reporting employee ID or after reporting employee ID.

Step 2 Contact the system administrator to review the uploaded voices before and after
the employee ID.

After the voices are approved, go to the next step.

Step 3 Choose Configuration Center > Employee Center > Skill Queue, select a voice or
video skill queue, and click Edit in the Operation column.

Step 4 Click  to expand Skill Parameter Configuration.

Step 5 In the Skill AnswerMode area, set Answer Type to Report employee ID and
customized voices.

Step 6 Click the Voice Before Employee ID text box, select the approved voice before the
employee ID, and click OK.

Step 7 Click the Voice After Employee ID text box, select the approved voice after the
employee ID, and click OK.

Step 8 Click Save.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 71



NO TE

When Answer Type is set to Report employee ID and customized voices, the total
duration of the employee ID and voices before and after the employee ID cannot exceed 20
seconds. Otherwise, only the voice data of the first 20 seconds is played.

----End

2.3.2 Agent Workbench
A tenant administrator can centrally manage agent workbench settings for agents
to use during call business handling.

2.3.2.1 Configuring Call Reasons

A tenant administrator can configure call reasons for agents to select during
business handling.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Workbench Configuration > Call Reason.

Step 2 Click New to add a call reason.

Step 3 Set call reason parameters.

Figure 2-35 Create Call Reason
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Table 2-4 Call reason parameters

Parameter Description

Call
Reason

Call reason name. This parameter is mandatory. The value can
contain a maximum of 50 characters.

Parent Call
Reason

Upper-level call reason of a call reason. This parameter is optional.

Description Description. This parameter is optional. The value can contain a
maximum of 500 characters.

Associated
Case Type

Case type associated with a call reason.
This parameter can be set only after the Case 2.0 feature is
enabled.

 

Step 4 Click OK.

Step 5 (Optional) Click New corresponding to the configured reason and choose Add
Sub Level to configure a subreason for the reason. After the configuration is
complete, click OK.

----End

2.3.2.2 Configuring Rest Reasons

A tenant administrator can configure rest reasons, including the rest duration, for
agents to select for a rest.

Prerequisites
1. Sign in as a tenant administrator, choose Configuration Center > System

Management > Tenant Parameter, and set the following parameters:
– Forcibly End Agent Rest After Timeout: The options are 0 (no) and 1

(yes). Set this parameter to 0.
– Internal Message Template for Notifying Supervisor of Agent Rest

Timeout: Set this parameter to the ID of a created internal message
notification template. For details about how to configure an internal
message notification template, see Configuring an Internal Message
Notification Template.

2. The tenant administrator has set a manager for agents.

Scenario

When an agent needs to update the agent status to Rest after sign-in, the system
allows the agent to select a rest reason. After a reason code is selected, the rest
timing starts. After the agent has a rest, the agent can change the agent status
and end the rest timing. If the rest time exceeds the duration specified by the
selected reason code, the system displays a message indicating that the rest times
out and sends an internal message to the manager of the agent, notifying the
manager of the rest timeout.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Workbench Configuration > Rest Reason.

Step 2 Click New. The Add Rest Reason dialog box is displayed.

Table 2-5 Rest reason parameters

Element
/
Compon
ent

Ty
pe

Description Value
Range

Triggere
d Event

Remarks

Rest
Reason
Code

Tex
t
box

Reason code. The value
is a
number
ranging
from 1 to
255.

Enter The value must
be unique.

Descripti
on

Tex
t
box

Reason
description.

The value
can
contain a
maximum
of 100
characters.

Enter -
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Element
/
Compon
ent

Ty
pe

Description Value
Range

Triggere
d Event

Remarks

Rest
Duration

Dro
p-
do
wn
list

Rest duration. The value
contains
only digits
in the
format of
hh:mm:ss,
for
example,
00:00:00.
The rest
duration
must be
greater
than 0
seconds
and less
than 24
hours.

Enter -

 

Step 3 Click Save.

Step 4 Click Synchronize to synchronize the information to the CTI.

----End

Follow-up Procedure
You can perform the following operations on rest reasons:

● Click Edit to modify a rest reason.
● Click Delete to delete a rest reason.
● Click Delete on the top of the page to delete rest reasons in batches.

NO TE

● If a reason code exists in the AICC but does not exist on the call center platform, delete
the reason code from the AICC.

● If a reason code exists on the call center platform but does not exist in the AICC, add
the reason code to the AICC. The rest duration is 10 minutes by default.

● If a reason code exists both in the AICC and on the call center platform, compare the
basic information about the reason code. If any change occurs, update the reason code
in the AICC.

2.3.2.3 Configuring Contact Record Data Items
Customer information is recorded in contact records. In addition, useful customer
information can be obtained during contact record inspection, on the voice and
video workbench, or during analysis.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 75



2.3.2.3.1 Creating a Customized Extended Field

Prerequisites
The tenant has provided the AICC with the API for querying extended customer
information, the AICC has provided the secondary development API for connecting
to the customer query API, and the connection has been completed.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Expansion and Integration > Contact Data Item.

Step 2 Create a contact record dataset.

1. Click the Extended Contact Information Dataset tab and click New.
2. Set parameters based on Table 2-6.

Table 2-6 Dataset parameters

Parameter Description

Dataset Name Dataset name, which is customized. The value can
contain a maximum of 1024 characters. Multiple
datasets can be created, but their names must be
unique.

Dataset Source
Interface

API path developed by the AICC, which is used to
connect to the API provided by the customer for
querying extended customer information. Contact
O&M personnel to obtain the value.

 
3. Click Save.

Step 3 Create a customized extended field.

NO TE

A maximum of 10 extended data items can be added.

1. Click the Contact Record Data Item tab and click New.
2. Set parameters based on Table 2-7.

Table 2-7 Parameters for creating a customized extended field

Parameter Description

Data Type Select User-defined extended field.

Field Name Name of a customized extended field. The value
can contain a maximum of 1024 characters.

Data Item ID The value can contain a maximum of 128
characters.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 76



Parameter Description

Visible Contact
Record

Whether an extended field is visible in the contact
record list. The options are as follows:

– : yes

– : no

Field Order Display sequence of a field in contact records. A
field with a smaller No. is displayed in the front.
Fields with the same No. are displayed based on
their sequence in the list. The value is a number
ranging from 1 to 100.

Source Dataset The options are all extended contact information
datasets added to the tenant space.

Dataset Mapping
Field

Dataset mapping field. The value can contain a
maximum of 32 characters.

Extended Writeback
Field

Extended writeback field. The options are as
follows:
extField1–extField10

Data Type Data type. The options are as follows:
– String
– Data dictionary

Data Dictionary Value This parameter is mandatory when Data Type is
set to Data dictionary.
The format is Key 1:Value 1,Key 2:Value 2.

 
3. Click Save.

Step 4 After the configuration is complete, choose Contact History > Contact to view the
display effect of the customized extended field.

----End

2.3.2.3.2 Creating a Basic Extended Field

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Expansion and Integration > Contact Data Item.

Step 2 Create a basic extended field.

1. Click the Contact Record Data Item tab and click New.
2. Set parameters based on Table 2-8.
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Table 2-8 Parameters for creating a basic extended field

Parameter Description

Data Type Select Basic extended field.

Field Name The options are as follows:
– Handled Number
– Original Called Number
– Contact Number
– Call ID
– Collaborative Call ID
– Sign-In IP Address
– Customer Name
– Skill Queue ID
– Agent Organization

Data Item ID After you set Field Name, the value of this
parameter is automatically associated. It is dimmed
and cannot be modified.

Visible Contact
Record

Whether an extended field is visible in the contact
record list. The options are as follows:

– : yes

– : no

Field Order Display sequence of a field in contact records. A
field with a smaller No. is displayed in the front.
Fields with the same No. are displayed based on
their sequence in the list. The value is a number
ranging from 1 to 100.

 
3. Click Save.

Step 3 After the configuration is complete, choose Contact History > Contact to view the
display effect of the basic data.

----End

2.3.2.3.3 Configuring the Contact Customer Information Area

Prerequisites
● You have configured an extended contact information dataset. For details, see

Step 2.
● You have configured a dynamic data table. For details, see 2.3.2.8

Configuring Dynamic Data Tables.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Expansion and Integration > Contact Data Item.

Step 2 Add a data item to the contact customer information area.

1. Click the Contact Customer Information Area tab and click New.
2. Set parameters based on Table 2-9.

Table 2-9 Parameters for creating a data item in the contact customer
information area

Parameter Description

Field Name Field name.
The value can contain a maximum of 128
characters.

Data Item ID Field ID.
The value can contain a maximum of 64 characters.

Visible Whether a data item is displayed in the customer
information area on the voice and video
workbench.
The options are as follows:

– : yes

– : no

No. No. of a data item in the contact customer
information area.
The value ranges from 1 to 100.

Data Source Type Data source type.
The options are as follows:
– Call-associated data
– Information dataset
– Local data

Data Source Object Data source object ID.
– When Data Source Type is set to Information

dataset, the value is the name of a dataset
configured on the Extended Contact
Information Dataset page.

– When Data Source Type is set to Local data,
the value is the data configured on the
Configuration Center > Expansion and
Integration > Dynamic Data Table page.
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Parameter Description

Data Source Object
Mapping Field

Data source object mapping field.
The value can contain a maximum of 32 characters.
– When Data Source Type is set to Call-

associated data, the value of this parameter is
the mapping field of call-associated data.

– When Data Source Type is set to Information
dataset, the object name is the mapping field
name of the dataset object.

– When Data Source Type is set to Local data,
the object name is the mapping field ID of the
customized table object.

Extended Writeback
Field

Extended contact record writeback field.
This parameter is left blank by default. The value
ranges from extField1 to extField10.
If the value is not empty, a record is added to the
Contact Record Data Item page.

Data Type Data type.
The options are as follows:
– String
– Data dictionary

Data Dictionary Value Data dictionary value.
This parameter is displayed when Data Type is set
to Data dictionary.
The value can contain a maximum of 1024
characters.
The format is Key 1:Value 1,Key 2:Value 2.

Display Style
This parameter is displayed when Data Type is set to Data dictionary.

Background Color Background color.

Foreground Color Font color.

Font Font style.
– Regular
– Bold
– Italic
– Underlined

 
3. Click Save.
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Step 3 After the configuration is complete, choose Contact History > Contact to view the
display effect of the contact customer information area.

----End

2.3.2.4 Configuring the Voice Notification Function
You can configure callback information for voice notifications. When a voice
notification ends, the system calls back the configured URL and transfers call data.

Prerequisites
● The voice notification feature has been enabled for the tenant space.
● You have contacted the system administrator to add voice notification

callback URLs to the mobile agent callback URL trustlist.

Context
If the shared key is changed, you need to modify the involved voice notification
item as follows: Sign in to the system as a tenant administrator, choose
Configuration Center > Expansion and Integration > Voice Notification, click
Edit, and update the value of Shared Key.

Obtain the shared key from the customer.

Procedure
Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >

Expansion and Integration > Voice Notification, and configure the voice
notification callback URL.

Step 2 Click Edit to configure the hang-up callback URL for voice notifications.
● Hang-up Callback URL: Hang-up callback URL. The URL must start with http

or https.

NO TE

HTTP is not secure and may cause security risks. HTTPS is recommended.

● HTTP request method: The default value is POST.
● Secret key. The value must contain at least 16 characters.

NO TE

The shared key setting takes effect for configuration of the callback URL using an API.
If the shared key is not set, no authentication is performed. For configuration of the
callback URL on the GUI, no authentication is performed by default.
No authentication may cause security risks. Exercise caution when using this mode.

Step 3 Click Save.

----End

2.3.2.5 Configuring the One-Click Bidirectional Call Function
You can select a one-click bidirectional call type (CEC bidirectional call or ITA
bidirectional call) for the tenant space. The selected bidirectional call type is used
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when the agent bidirectional call API is invoked. In addition, you can configure
callback information for one-click bidirectional calls. When a one-click
bidirectional call ends, the system calls back the configured URL to transfer call
data.

Prerequisites
● The one-click bidirectional call feature has been enabled for the tenant space.
● You have contacted the system administrator to add one-click bidirectional

call callback URLs to the mobile agent callback address trustlist.

Context
● When the callback URL authentication mode is set to Shared Key, if the

shared key is changed, you can modify the involved one-click bidirectional call
item as follows: Sign in to the system as a tenant administrator, choose
Configuration Center > Expansion and Integration > Bidirectional Call,
click Edit, and update the value of Shared Key.

● When the callback URL authentication mode is set to OAuth 2.0, if the AK
and SK authorized by OAuth 2.0 are changed, you need to modify the
involved one-click bidirectional call items as follows: Sign in to the system as
a tenant administrator, choose Configuration Center > Expansion and
Integration > Bidirectional Call, click Edit, and update the values of AK and
SK.

● When the one-click bidirectional call type is set to ITA bidirectional call, if
the access key, app key, and secret key provided by the ITA are changed, you
need to modify the involved one-click bidirectional call items as follows: Sign
in to the system as a tenant administrator, choose Configuration Center >
Expansion and Integration > Bidirectional Call, click Edit, and update the
values of AccessKey, AppKey, and SecretKey.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Expansion and Integration > Bidirectional Call.

Step 2 Click Edit to configure the one-click bidirectional call function.

Step 3 Select a one-click bidirectional call type. The options are CEC bidirectional call
and ITA bidirectional call.

CEC bidirectional call indicates the bidirectional call function provided by the
AICC, and ITA bidirectional call indicates the ITA bidirectional call API
encapsulated on the AICC side. The selected bidirectional call type is used when
the agent bidirectional call API is invoked.

NO TE

If ITA bidirectional call is selected, ensure that the CDR push URL has been configured on
the ITA. Otherwise, the ITA cannot push CDRs to the CEC. An example push URL is as
follows:

https://10.243.7.176:28090/apiaccess/rest/cc-management/v1/ita/twopartiescall/statusnotify

Step 4 Configure the CEC bidirectional call function.
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1. Configure callback URLs.
– Connection Callback URL and Hang-up Callback URL: Connection

callback URL and hang-up callback URL. The URLs must start with http
or https.

NO TE

HTTP is not secure and may cause security risks. HTTPS is recommended.

– Method of Connection Callback and Method of Release Callback: The
default values are POST.

2. Configure URL authentication for interface invocation.
– Callback URL Authentication Mode: The options are Shared Key,

OAuth 2.0, and None.

NO TE

The callback URL authentication mode setting takes effect for configuration of
the callback URL using an API. For configuration of the callback URL on the GUI,
no authentication is performed by default.

No authentication may cause security risks. Exercise caution when using this
mode.

– Shared Key: This information is mandatory when Callback URL
Authentication Mode is set to Shared Key. The key must contain at
least 16 characters.

– OAuth 2.0 authorization information: This information is mandatory
when Callback URL Authentication Mode is set to OAuth 2.0.

▪ AK: Access key ID (AK), which is the unique identifier associated with
the SK.

▪ SK: Secret access key (SK), which is used with the AK.

▪ OAuth 2.0 Authentication Login URL: URL for obtaining the OAuth
2.0 access token. The OAuth 2.0 authentication mode is applicable
only to the AppCube component.

Step 5 Configure the ITA bidirectional call function.

1. Configure URL authentication for interface invocation.
– Callback URL Authentication Mode: The options are Shared Key,

OAuth 2.0, and None.

NO TE

The callback URL authentication mode setting takes effect for configuration of
the callback URL using an API. For configuration of the callback URL on the GUI,
no authentication is performed by default.

No authentication may cause security risks. Exercise caution when using this
mode.

– Shared Key: This information is mandatory when Callback URL
Authentication Mode is set to Shared Key. The key must contain at
least 16 characters.

– OAuth 2.0 authorization information: This information is mandatory
when Callback URL Authentication Mode is set to OAuth 2.0.
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▪ AK: Access key ID (AK), which is the unique identifier associated with
the SK.

▪ SK: Secret access key (SK), which is used with the AK.

▪ OAuth 2.0 Authentication Login URL: URL for obtaining the OAuth
2.0 access token. The OAuth 2.0 authentication mode is applicable
only to the AppCube component.

2. Configure ITA parameters.
– AccessKey: The value is provided by the ITA.
– SecretKey: The value is provided by the ITA.
– AppKey: The value is provided by the ITA.
– ITA Domain Name: The value is provided by the ITA.
– X Number Allocation Mode

▪ Automatic

▪ Specified

– X Number: Purchased number provided by the ITA.

Step 6 Click Save.

----End

Follow-up Procedure (Only for ITA Bidirectional Calls)

If you select ITA bidirectional call, perform the following steps to configure the
authentication certificate for ITA bidirectional calls.

Step 1 Obtain the ITA authentication certificate by referring to 2.17.6 Managing a
Certificate.

NO TE

To interconnect with the ITA bidirectional call function, you must upload the corresponding
authentication certificate. You can obtain the certificate from https://ITA domain name/v1/
ngin/axmn.

Step 2 Sign in to the AICC as the sysadmin user and choose Configuration Center >
System Management > Certificate.

Step 3 Click New, set Certificate Name to CERT_ITA, set Certificate Type to DER, and
select the obtained ITA authentication certificate.

Step 4 Click Save. After the certificate is uploaded, wait for 5 minutes for the certificate
to take effect.

----End

2.3.2.6 Configuring Screen Pop-ups

A tenant administrator can configure pages frequently used or customized by
agents as screen pop-ups. The screen pop-ups are displayed when agents answer
calls.
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Prerequisites
● You have contacted the system administrator to configure the third-party

URL.

● If the page is an internal page, you have configured the internal page in
advance. For details, see 2.3.2.7 Configuring Pages.

● If the page is an AppCube-integrated page, you have enabled the AppCube
feature and installed a non-AICC application package on AppCube.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Expansion and Integration > Pop-Up Screen.

Screen pop-up configuration support two page types: Audio/Video and
Multimedia.

NO TE

Pop-up pages can be integrated into the agent workbench. For example, an Audio/Video
pop-up page can be integrated into the voice and video workbench, and a Multimedia
pop-up page can be integrated into the online chat workbench.

Step 2 Click New. On the New Incoming Call Screen Pop-up page that is displayed,
configure screen pop-up information.

● The maximum number of screen pop-ups of the Audio/Video and
Multimedia types is specified by the system parameter Max. Screen Pop-ups
for Each Tenant. The value ranges from 1 to 10. By default, a maximum of
five screen pop-ups can be created for each type.

● You can configure internal pages, external pages, and AppCube-integrated
pages for the Audio/Video type, but can only configure external pages for the
Multimedia type.

Figure 2-36 Internal page
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Figure 2-37 External page

Figure 2-38 AppCube-Integrated Page
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Table 2-10 Inbound call screen pop-up parameters

Parameter Description

Page Name Page name, which is customized.

Page type The options are as follows:
– Internal page
– External page
– AppCube-Integrated Page

Open Mode The options are as follows:
– Embed (By default, internal pages can be opened only in

this mode.)
– Independently opened

Config Page This parameter is mandatory when Page type is set to
Internal page.
The value is the page customized and published in 2.3.2.7
Configuring Pages.

Select
Application

AppCube application that has been installed.

Select
Menu

Menu under the selected AppCube application.

Access
Address

This parameter is mandatory when Page type is set to
External page.
The value is the third-party URL configured by the system
administrator.
CAUTION

For example, if this parameter is set to https://www.huawei.com,
the passed URL is actually https://www.huawei.com?
callerNum=400124&calledNum=88880344&callid=1574662344-400&
mediaType=1&callType=1&workNo=1511&callskill=defaultAudioSkill&
callskillid=3&agentName=HW38539906. The following parameters
are added by default:
– callerNum: calling number
– calledNum: called number
– callid: ID of the current session
– mediaType: media type. The options are 1 (voice) and 5

(multimedia).
– callType: call type. The options are 0 (inbound call) and 1

(outbound call).
– workNo: platform agent ID
– callskill: skill queue
– callskillid: skill queue ID
– agentName: business account of an agent
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Parameter Description

Integration
Type

This parameter is mandatory when Page type is set to
External page or AppCube-Integrated Page. The options
are as follows:
– URL GET REQUEST Parameter: The page is integrated by

setting screen pop-up parameters. For details, see
Scenario 1: Integration by Using a URL (in GET
Parameter Transfer Mode).

– URL POST REQUEST Parameter: The page is integrated
by setting screen pop-up parameters and processing form
data. For details, see Scenario 2: Integration by Using a
URL (in POST Parameter Transfer Mode).

– Web API: The page is integrated using AICCSupport.js.
For details, see Scenario 3: Integration by Using a URL
(in Page JavaScript Invocation Mode).

 

Step 3 Click Save.

Step 4 (Optional) If the page is an external page or an AppCube-integrated page, set
screen pop-up parameters for the page.

If screen pop-up parameters are not set, the following six parameters are
transferred by default: callerNum, calledNum, callid, mediaType, callType, and
workNo.

1. Select the configured inbound call screen pop-up and click Config. The page
for setting external access address parameters is displayed.

2. Click  to add screen pop-up URL parameters to be passed. The
maximum number of parameters is specified by the system parameter Max.
Parameters Transferred in URL of Screen Pop-up for Each Tenant. The
value ranges from 1 to 20. By default, a maximum of 10 parameters can be
added.

3. Set Screen Pop-up URL Parameter, Associated System Data Parameter
Type, and Associated System Data Parameter.
– Call Data
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Figure 2-39 Selecting Call Data

The value of Associated System Data Parameter can be:

▪ callerNum: calling number

▪ calledNum: called number

▪ callid: ID of the current session

▪ mediaType: media type. The options are 1 (voice) and 5
(multimedia).

▪ callType: call type. The options are 0 (inbound call) and 1 (outbound
call).

▪ workNo: platform agent ID

▪ callskill: skill queue

▪ callskillid: skill queue ID

▪ agentName: business account of an agent

– Channel Associated Data
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Figure 2-40 Selecting Channel Associated Data

The value of Associated System Data Parameter is customized.
4. Click Close.

Step 5 Select the configured pop-up page and click  in the Enable column to
enable the pop-up page.

Step 6 If multiple inbound call screen pop-ups are enabled, click Up or Down in the
Operation column to adjust the pop-up sequence of a screen pop-up. The screen
pop-up on the top of the list pops up first.

----End

NO TE

Sign out and then sign in again for the configuration to take effect.

2.3.2.7 Configuring Pages
A tenant administrator can customize pages that can be referenced by inbound
call screen pop-ups.

Prerequisites
● The system administrator has enabled the Data customization feature for

the tenant space.
● A dynamic data table has been configured. For details, see 2.3.2.8

Configuring Dynamic Data Tables.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Expansion and Integration > Page Configuration.

Step 2 Click . The New Page dialog box is displayed.

Step 3 Configure information about the customized page. The value of Certificate
Description can contain a maximum of 256 characters and must be unique.

Step 4 Click Save.

Step 5 The configuration of a customized page includes the page layout and page
interface. Select the added customized page and configure it.

1. Configure the page layout.

Figure 2-41 Page Layout

Table 2-11 Page parameters

Parameter Description

Page Layout

Layout
type

The options are as follows:
– Block layout
– Grid layout

Number of
rows

The options are as follows:
– 2
– 3
– 4

Save Save the current page layout information.

Page Interface

Internal
interface

Configure the object list.

External
interface

External interfaces are configured on the API Management
page. Contact the system administrator.
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Parameter Description

Save Save the current page interface information.

 

2. Configure the page interface.

– Internal interface

Figure 2-42 Internal interface

Figure 2-43 Select Object Attribute

Table 2-12 Internal interface parameters

Paramete
r

Description

Add an object to the internal interface. A maximum of five
objects can be added.

Object List

Object
Name

Customize an object name.

Underlyin
g Table
Name

Select a published dynamic data table.

Selected
Object
Attributes

Select dynamic data table fields. You can select multiple
fields.
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Paramete
r

Description

Operation Perform operations on an object.

▪ : Save a new object.

▪ : Delete an object.

▪ : Edit an object.

▪ : Move an object down.

▪ : Move an object up.

▪ : Cancel a new object.

 
– External interface

Figure 2-44 External interface

External interfaces are configured on the API Management page.
Contact the system administrator.

Step 6 Click Save.

Step 7 Click the name of the customized page. The Page Layout page is displayed. Click
 on the left of the page name to publish the customized page.

----End

NO TICE

● Only published pages can be referenced by inbound call screen pop-ups. Pages
that have been referenced by inbound call screen pop-ups cannot be
unpublished.

● A maximum of five customized pages can be created. Delete unnecessary pages
promptly.
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Follow-up Procedure

You can perform the following operations on a configured page:

● Click  to modify the selected page.

● Click  to delete the selected page.

2.3.2.8 Configuring Dynamic Data Tables

A tenant administrator can customize dynamic data table fields to display stored
customer information on customized pages.

Prerequisites

The system administrator has enabled the Data customization feature for the
tenant space.

Business Scenario

When an enterprise tenant needs to store small-scale customer data in the call
center, the AICC provides a customized dynamic data table to store customer
information. Based on the customized page, the uploaded customer information
can be automatically queried when an inbound call is made. For details about how
to customize a page, see 2.3.2.7 Configuring Pages.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Expansion and Integration > Basic Table.

Step 2 Click New. The Creating a Base Table dialog box is displayed.

Step 3 Set dynamic data table parameters.

Figure 2-45 Creating a Base Table

NO TE

A maximum of five dynamic data tables can be created.
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● Table Name (mandatory): Enter a customized dynamic data table name. The
table name cannot contain special characters and can contain a maximum of
64 characters.

● Description (optional): Enter a dynamic data table description. The
description cannot contain special characters and can contain a maximum of
1024 characters.

Step 4 Click Save.

Step 5 On the Basic Table page, click Field Settings corresponding to the new dynamic
data table to configure fields for the dynamic data table.

Step 6 Click New. In the Creating a Field Column dialog box, set parameters, as shown
in Figure 2-46.

Figure 2-46 Creating a Field Column

NO TE

A maximum of one index field, 30 common fields, and 20 encrypted fields can be created.

● Field Name: This parameter is mandatory. The table name cannot contain
special characters and can contain a maximum of 64 characters.

● Used as index: This parameter is mandatory.
The options are as follows:

– : yes
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– : no

NO TE

If Used as index is set to Yes, the field cannot be encrypted and is mandatory.

● Encrypted: This parameter is mandatory.

The options are as follows:

– : yes

– : no

NO TE

If the data is personal or sensitive data, set this parameter to Yes to ensure data
security.

● Mandatory: This parameter is mandatory.

The options are as follows:

– : yes

– : no

● Field Type: This parameter is mandatory. The options are String, Number,
Date, DateTime, and Dictionary.

● Field length: This parameter is mandatory. The value ranges from 1 to 256.

● Masked: This parameter is mandatory. The options are Yes and No.

NO TE

If the data is personal or sensitive data, set this parameter to Yes to ensure data
security.

● Mask style: This parameter is mandatory when Masked is set to Yes. The
following uses 1234567890 as an example to describe the options.

– Reserve last four digits: ******7890 is displayed.

– Reserve first four digits: 1234****** is displayed.

– Mask last four digits: 123456**** is displayed.

– Mask first four digits: ****567890 is displayed.

– Mask all digits: ********** is displayed.

– Email mask: The first two digits and the last digit of an email address are
reserved, for example, to****3@aabbcc.com.

– Bank account mask: The first six digits and last four digits are reserved,
for example, 620000******1234.

– ID card number mask: The date of birth and last four digits are masked,
for example, 123456************.

Step 7 Click Save.

Step 8 (Optional) Click Top, Up, Down, or Bottom corresponding to a field to adjust the
field sequence.
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Figure 2-47 Basic Table Configuration

Step 9 On the Basic Table Configuration page, click Release corresponding to a
dynamic data table for which fields have been configured. In the Tips dialog box,
click OK to publish the dynamic data table.

----End

Follow-up Procedure

You can perform the following operations on a dynamic data table in Draft state:

● Click Edit to modify the dynamic data table name and description.
● Click Field Settings to configure fields for the dynamic data table.
● Click Delete to delete an unnecessary dynamic data table.
● Click Release to enable a dynamic data table for which fields have been

configured.

You can perform the following operations on a dynamic data table in Release
state:

● Click Field Settings to configure fields for the dynamic data table.
● Click Withdraw to update the dynamic data table status to Draft.
● Click Discard to update the dynamic data table status to Discard.

You can perform the following operations on a dynamic data table in Discard
state:

● Click Field Settings to configure fields for the dynamic data table.
● Click Delete to delete an unnecessary dynamic data table.

NO TE

● Only dynamic data tables in Release state can be referenced by pages.

● Dynamic data tables in Release state cannot be deleted. Only dynamic data tables in
Draft or Discard state can be deleted.

2.3.2.9 Querying Table Data

A tenant administrator needs to add specific table data to the configured dynamic
data table so that the data can be displayed on the configured screen pop-up
after a call is connected.

Prerequisites
● The data customization feature has been enabled for the tenant.
● A dynamic data table has been released. For details, see 2.3.2.8 Configuring

Dynamic Data Tables.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Expansion Management > Table Data.

Step 2 Click  and select a released dynamic data table to configure table data.

Step 3 Import table data.

1. Choose Import Data. The data import page is displayed.
2. Click Export Template to download the table data template to a local path

and fill in table data.

NO TE

– Only an Excel file can be uploaded. The file size cannot exceed 20 MB. The file
name can contain only Chinese characters, letters, digits, and underscores (_).

– The header of the uploaded Excel file must match that of the downloaded
template. Otherwise, the file processing fails.

– The imported data cannot start with +, =, or @. If the data starts with -, the data
must be in the format of -{One or more digits}{Several characters}.

3. Click . In the dialog box that is displayed, select the configured table data
file.

4. Click Submit. In the dialog box that is displayed, click OK to import the table
data.

Step 4 Click Import Result View. On the import result list page that is displayed, confirm
that the Status of the data import record is Completed.

Step 5 Click Return. The table data list page is displayed, showing details about the
imported data.

----End

Follow-up Procedure
● Data editing: Imported table data can be edited again.

– Click Edit. On the Edit page, edit table data except index data. After
confirming that the data is correct, click Submit to save the table data.

– Click Delete. In the dialog box that is displayed, click Yes to delete
unnecessary table data.

● Data export: Existing table data can be exported.

NO TE

The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

a. Click New Export Task. The Enter compression password dialog box is
displayed.

b. Enter the customized compression password and click Confirm. The data
is exported successfully.
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c. In the dialog box that is displayed, click OK to return to the table data
configuration page.

d. Click Export Task View. The export result page is displayed.
e. Select the export record whose Status is Success, and click Download to

export the table data file to a local path.
f. After the download is successful, open the exported file and enter the

compression password to view table data.

2.3.2.10 Managing the Multimedia Library
A tenant administrator can preconfigure some multimedia library data, including
common phrases, voices, videos, images, documents, addresses, personalized
emojis, rich texts, card templates, co-browsing URLs, and plain texts for agents to
improve work efficiency.

Prerequisites
To configure a card template for which a URL needs to be configured as a card
option, an application for adding the URL to the address trustlist has been
submitted to the system administrator and approved.

Context
After a version earlier than 23.100.0 is upgraded to the current version, the
uploaded AAC file needs to be uploaded again. Otherwise, the old AAC file fails to
be sent after the WhatsApp channel is connected to Infobip.

The multimedia file types supported by each channel are as follows.

Table 2-13 Multimedia data and channels

Multimedia Data Type Supported Sending Channel

Common phrase (including common phrases in
the multimedia library and personalized
common phrases)

● Web
● 5G RCS
● WeChat
● X (Twitter)
● Facebook
● LINE
● WhatsApp
● SMS
● Instagram
● Telegram
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Multimedia Data Type Supported Sending Channel

Voice ● Web: MP3 or AAC
● WeChat: MP3
● Facebook: MP3
● LINE: M4A
● WhatsApp: ACC
● Instagram: M4A
● Telegram: MP3 or M4A

Video ● Web
● WeChat
● X (Twitter)
● Facebook
● LINE
● WhatsApp
● Instagram
● Telegram

Image ● Web
● WeChat
● X (Twitter)
● Facebook
● LINE
● WhatsApp
● Telegram

Address ● Web
● 5G RCS
● LINE
● WhatsApp
● Instagram
● Telegram

Personalized emoji ● Web
● WeChat

Card template 5G card 5G RCS

5G rotating card

WhatsApp template message WhatsApp

WhatsApp interactive message

Web card Web

Rich text Web
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Multimedia Data Type Supported Sending Channel

Email draft (not maintained on the
Multimedia Library menu)

Email

SMS template (not maintained on the
Multimedia Library menu)

SMS

Co-browsing URL Web

Document ● Web: DOC, DOCX, PDF, or
ZIP

● WhatsApp: DOC, DOCX,
PDF, PPT, PPTX, XLSX, or
XLS

● Telegram: PDF or ZIP

Plain text ● Web
● 5G RCS
● WeChat
● X (Twitter)
● Facebook
● LINE
● WhatsApp
● SMS
● Instagram
● Telegram

 

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Resource Management > Multimedia Library.

Step 2 Configure the common phrase library.

1. Click the Phrase tab and click  to add a common phrase category and set
the following parameters:

– Category Name: Enter a maximum of 20 characters.

– Organizational Structure: Select the OU created in 2.2.1 Configuring
OUs.

2. Select the new category and click Create.

Only one common phrase can be added at a time. A common phrase can
contain a maximum of 500 characters. If there are multiple common phrases,
click Create to add them one by one.

Step 3 Configure the voice library, video library, image library, document library, and
personalized emoji library. The following uses the voice library as an example.
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1. Click the Voice tab and click  to add a voice category and set the following
parameters:
– Category Name: Enter a maximum of 20 characters.
– Organizational Structure: Select the OU created in 2.2.1 Configuring

OUs.
2. Select the new category and click Create.
3. Set Name and click +Select File to select a local voice file in MP3, AAC, or

M4A format.
4. Click Save. The file is uploaded.

You can perform the following operations on uploaded files:

– : Enter the list mode and display data in a list. This button is available
only for the video library, image library, and personalized emoji library.

– : Enter the preview mode and display data on cards. This button is
available only for the video library, image library, and personalized emoji
library.

– Click Play to play a voice file online.
– Click Preview to preview a video or image file online.
– Click Download to download an uploaded document online.
– Click Edit to modify the description of an uploaded file.
– Click Delete to delete an unnecessary multimedia file.
– Click Release to publish an image, video, or voice file to the 5G VAS CSP.

This button is not displayed in preview mode. The validity period of
multimedia data published to the 5G platform is two months.

– Click Release Result to view the result of releasing multimedia data to
the 5G platform.

NO TE

Before creating a 5G card or 5G rotating card, ensure that a multimedia resource
of the image, video, or voice type has been released and approved.

Step 4 Configure the address library.

1. Click the Address tab and click  to add an address category and set the
following parameters:
– Category Name: Enter a maximum of 20 characters.
– Organizational Structure: Select the OU created in 2.2.1 Configuring

OUs.
2. Select the new category and click Create.
3. Set Name, Longitude, and Latitude. The longitude ranges from –180 to 180

and can contain 0 to 6 decimal places. The latitude ranges from –90 to 90
and can contain 0 to 6 decimal places.

4. Click Save. The address is configured.
You can perform the following operations on uploaded addresses:
– Click Edit to modify the description of an uploaded address.
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– Click Delete to delete an unnecessary address.

Step 5 Configure rich texts or plain texts. The following uses rich texts as an example.

1. Click the Rich Text tab and click  to add a rich text category and set the
following parameters:
– Category Name: Enter a maximum of 20 characters.
– Organizational Structure: Select the OU created in 2.2.1 Configuring

OUs.
2. Select the new category and click Create.
3. Set Name and Description, and enter the rich text content.
4. Click Save. The rich text is configured.

You can perform the following operations on created rich texts:
– Click View to view a rich text.
– Click Edit to modify a rich text.
– Click Delete to delete an unnecessary rich text.

Step 6 Configure a card template.

Click the Card Template tab. The template list page is displayed.

● Configure a 5G card.

a. Choose 5G Card and click Create.
b. Set the following parameters:

▪ name, title, and Description: Customize the values.

▪ Media Type: The options are IMAGE, VIDEO, and AUDIO.

▪ Multimedia Resource: Select a media resource of the corresponding
type. The options are media resources that have been published and
approved in 3.

▪ Media height: The options are Short Height, Medium Height, and
Tall Height.

▪ (Optional) Organization Unit: Assign an OU.

▪ Card Options

1) Click Add Card Options to add a card option. A maximum of
three card options can be added.

2) Set Card Option Name and Card Display Text.
3) Select an option type and configure the option content.

If linking is selected, the option content must be a URL for
customers to click to go to the specified page.

NO TE

HTTP has security risks. Exercise caution when using it. You are advised
to use HTTPS, which is more secure.

If dial is selected, the option content must be a number for
customers to dial.
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If reply is selected, the option content must be a phrase for
customers to reply with.

4) Click Move Up to adjust the sequence.
c. Click Save. The 5G card template is configured.

● Configure a 5G carousel card.

a. Choose 5G Rotating Card and click Create.
b. Set the following parameters:

▪ name, title, and Description: Customize the values.

▪ Card Arrangement Direction: Currently, the value can only be
leveling.

▪ Image Alignment Mode: The options are Left Alignment and Right
Alignment.

▪ Card Width: The options are Medium Width and Smaller width.

▪ (Optional) Organization Unit: Assign an OU.

▪ Card Options: Click Select Card, select a maximum of five created
5G card templates, and click Save. Click Move Up to adjust the
playback sequence of a card.

c. Click Save.
● Configure a WhatsApp template message.

a. Choose WhatsApp Template Message and click Create.
b. Click Create. The Create WhatsApp Template page is displayed.

If you have created a template on the Configuration Center > Resource
Management > WhatsApp Template page, you can directly go to Step
6.e.

c. Set the following parameters:

▪ Template Name and Template Description: Customize the values.

▪ Template Channel: Select the WhatsApp channel configured on the
Channel Configuration page. For details about how to configure the
WhatsApp channel, see 2.5.8 Configuring the WhatsApp Channel.

▪ Language: Select the language of the template.

▪ Template availability times per day: Customize the number of
times the template can be sent in a day. If the value is exceeded, the
template message fails to be sent.

▪ Template Content: Configure the template content as required,
including Header, body, footer, and buttons.

d. Click Save to return to the WhatsApp template message configuration
page.

e. Set the following parameters:

▪ Template Message Name and Description: Customize the values.
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▪ Template Name: Select the WhatsApp template created in Step 6.b.
After a WhatsApp template is selected, other parameters are
automatically filled in with the data of the WhatsApp template.

f. Click Save.
● Create an interactive WhatsApp message.

a. Click the Card Template tab. The template list page is displayed.
b. Choose WhatsApp Interactive Messages and click Create. The

WhatsApp configuration page is displayed.
c. Configure basic information.

▪ Customize Message Name and Description.

▪ Set Business Solution Provider. The options are as follows:

○ infobip

○ Twilio

▪ Customize Unique ID of a template. This parameter is displayed
when Business Solution Provider is set to Twilio.

▪ Set Organization Unit.

▪ Set Message Type. The options are as follows:

○ Button Message

○ List Message
d. Set parameters in the Template Content area.

▪ Customize body and footer.

▪ Set Header. This parameter is displayed when Business Solution
Provider is set to infobip.

○ When Message Type is set to Button Message, select None,
Text, Image, Video, or Attachments.
If Text is selected, you need to set Header Content.
If you select Image, Video, or Attachments, you also need to

select a multimedia resource. Click  to select a media
resource of the corresponding type from the multimedia library.

○ When Message Type is set to List Message, set Header
Content.

▪ Customize body.

▪ Set footer. This parameter is displayed when Business Solution
Provider is set to infobip.

▪ Set Button (mandatory when Message Type is set to Button
Message).
Click Create to create a button. A maximum of three buttons can be
created.
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▪ Set List (mandatory when Message Type is set to List Message).

1) Enter a list title.
2) Click Create to create a list group. A maximum of 10 groups can

be added to a list.

3) Enter a group title and click  to expand the group.
4) Click Create to create a group option. A maximum of 10 options

can be added to a group.
e. Click Save. The interactive WhatsApp message is created.

● Configure a web card.

a. Choose WebCard and click Create.
b. Set the following card template parameters:

▪ name: Customize the value.

▪ template type: The options are as follows:

○ Common type: If this option is selected, you need to set the
following parameters:

○ title and Description: Customize the values.

○ Media Type: The options are IMAGE, Address, and VIDEO.

○ Multimedia Resource: Select a multimedia resource of the
corresponding type.

○ linking: Enter a URL for customers to click to go to the
specified page.

NO TE

HTTP requests have security risks. HTTPS is recommended.

○ Card Options

▪ Organization Unit: Select the OU created in 2.2.1 Configuring OUs.

c. Select a card display style. The options are as follows:

▪ transverse

▪ longitudinal

d. Add card options.

NO TE

When Card display style is set to transverse, a maximum of 15 card options can
be added. When Card display style is set to longitudinal, a maximum of five
card options can be added.

i. Click Add Card Options.
ii. Set the following parameters:

○ Image property: Select an image resource configured in Step 3.

○ Card display text: Enter a maximum of 32 characters. The value
cannot contain the following special characters: <>'"/\
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○ Option Type: The options are as follows:

○ reply

○ linking

○ select content

○ When Option Type is set to reply, the value can contain a
maximum of 256 characters and cannot contain the
following special characters: <>'"/\

○ When Option Type is set to linking, the value must start
with http or https.

NO TE

HTTP has security risks. Exercise caution when using it. You are
advised to use HTTPS, which is more secure.

e. Click Save. The web card template is configured.

Step 7 Create a co-browsing URL.

1. Click the Cobrowse Site tab. The co-browsing URL list page is displayed.
2. Click Create.
3. Set the following parameters:

– Name and Describe: Customize the values.
– Cobrowse Site: Enter a proper URL for agents to click to send co-

browsing requests to customers.

NO TE

HTTP requests have security risks. HTTPS is recommended.

4. Click Save.

----End

2.3.2.11 Configuring Identity Authentication Processes

A tenant administrator can configure identity authentication processes for agents
to authenticate the customer identity.

Prerequisites
● The Authentication permission has been enabled.
● An IVR flow voice has been configured.

Scenario

A third-party system needs to be connected when an agent needs to authenticate
the customer identity during a call.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Expansion and Integration > Authenticate.
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Step 2 Click New. The Add Identity Authentication Process dialog box is displayed.

Figure 2-48 Add Identity Authentication Process

Table 2-14 Parameters for adding an identity authentication process

Parameter Description

Authentication Mode Name Authentication mode name.
The value can contain a maximum of
128 characters.

Authentication Mode Code Authentication mode code.
The value can contain a maximum of
128 characters.

Authentication Process IVR flow that has been published in
the tenant.

 

Step 3 Click Save.

Step 4 Click  to enable the identity authentication process.

----End

Follow-up Procedure
You can perform the following operations when the configured identity
authentication process is not enabled:

● Click Edit to modify the identity authentication process.
● Click Delete to delete the identity authentication process.

2.3.3 Other Configurations
A tenant administrator can optimize tenant space configurations to improve agent
and customer experience.
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2.3.3.1 Configuring the Fault Prompt Tone
A tenant administrator can customize the fault prompt tone, which is played to
users when system agents are faulty.

Prerequisites
You have configured a customized fault prompt tone by choosing Configuration
Center > Resource Management > Audio and Video Resource Management
and uploading a voice file whose Usage Scenario is error. The voice file can be
used only after being approved by the system administrator.

Scenario
After a tenant administrator enables the fault prompt tone function, the transfer-
to-agent function of the tenant space becomes invalid. When a fault occurs, the
configured fault prompt tone is played. However, the function of directly calling an
agent is not affected by this feature.

For example, a transfer diagram element is configured in an IVR flow, and an
agent who transfers a call to a skill queue is configured for the diagram element.
When a customer accesses the IVR flow and chooses to transfer the call to a skill
queue, the system plays the fault prompt tone. In addition, the function of
transferring the call to an agent is invalid for all agents.

Procedure

Step 1 Sign in to the AICC as a tenant administrator. Choose Configuration Center >
System Management > Tenant Information.

Step 2 Under Feature, click  next to Breakdown Voice to enable the fault prompt
tone function for the tenant space.
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Figure 2-49 Breakdown Voice

Step 3 Select an approved prompt tone and click Save.

NO TE

● The function is disabled by default. Each time the function is disabled, the message
"Update tenant fault success." is displayed.

● The system provides a default prompt tone.

----End

2.3.3.2 Configuring Satisfaction Surveys

A tenant administrator can set satisfaction levels for tenant space satisfaction
surveys.

Business Scenarios
● Scenario 1: web channel satisfaction survey

When a customer connected to an agent on the web page clicks the button
for closing the chat window, a satisfaction survey page is displayed. The
customer selects a satisfaction level, enters comments, and closes the chat
window.

● Scenario 2: SMS satisfaction survey
When an agent or customer hangs up after the customer service call ends,
the system automatically sends a satisfaction survey SMS message to the
customer. The customer replies to the SMS message to provide the
satisfaction survey result.
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● Scenario 3: IVR voice satisfaction survey
When an agent hangs up after the customer service call ends, the customer is
transferred to the satisfaction survey. The customer presses a key to provide
the satisfaction survey result.

● Scenario 4: Instagram, WeChat, Facebook, X (Twitter), WhatsApp, 5G RCS,
Telegram, LINE, and SMS channel satisfaction surveys
After an agent ends a session, the system automatically sends a satisfaction
survey text message to the customer.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Workbench Configuration > Satisfaction.

Step 2 Set parameters on the Satisfaction Level tab page.
● Satisfaction Level Configuration: The default satisfaction levels are 1: Very

dissatisfied, 2: Dissatisfied, 3: General, 4: Satisfied, and 5: Very satisfied.

– Click  in the last row to add a satisfaction level. The  button is
displayed only when the number of satisfaction levels does not reach the
maximum.

– Click  to delete a satisfaction level.

– Click  or  to adjust the sequence of a satisfaction level.
– Select a satisfaction level from the Description drop-down list.

● Satisfaction Survey Type: Select a multimedia satisfaction survey type.
The options are as follows:
– Satisfaction evaluation
– Questionnaire

● Satisfaction Survey Template Content Configuration: Configure the
satisfaction survey template content. The content can contain a maximum of
500 characters.
This parameter is displayed only when Satisfaction Survey Type is set to
Satisfaction evaluation.

● Questionnaire Content: Configure the multimedia satisfaction survey
content.
The options are as follows:
– Has your issue been resolved?

▪ Yes

▪ No

– Please rate my service.

▪ Very dissatisfied

▪ Dissatisfied

▪ General
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▪ Satisfied

▪ Very satisfied

– How likely are you to recommend us to friends and colleagues?
0–9

This parameter is displayed only when Satisfaction Survey Type is set to
Questionnaire.

Figure 2-50 Satisfaction Level

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 112



NO TE

Three to five satisfaction levels must be configured.
The satisfaction levels used in the satisfaction survey of each channel are the same. The
satisfaction surveys include the voice satisfaction survey, SMS satisfaction survey, and web,
Instagram, WeChat, Facebook, X (Twitter), WhatsApp, 5G RCS, Telegram, LINE, and SMS
channel satisfaction surveys.
If a satisfaction-related voice flow already exists, perform the following operations after
satisfaction levels are updated:
● If the flow is an intelligent IVR flow, click Cancel Release corresponding to the flow on

the Configuration Center > Chatbot Management > Flow Configuration > Flow >
Orchestration page and click Edit. After confirming that satisfaction levels have been
synchronized, save and publish the flow.

● If the flow is a common IVR flow, click Cancel Release corresponding to the flow on the
Configuration Center > Chatbot Management > Flow Configuration > Common IVR
page and click Edit. After confirming that satisfaction levels have been synchronized,
save and publish the flow.

The system uses the default language of the tenant to generate the satisfaction survey
template content.
The satisfaction survey message template is used to send satisfaction survey messages to
customers through Instagram, Telegram, WhatsApp, LINE, Web Chat, Facebook, X (Twitter),
5G RCS, and SMS channels.

Step 3 Click Save.

Step 4 Set parameters on the Satisfaction Survey tab page.

● Switch: Click  to enable the satisfaction survey function. If this function
is enabled, the customer is automatically transferred to a satisfaction survey
after an agent releases the call.

● Satisfaction Survey Flow: Select a published IVR flow and ensure that the
flow contains the Satisfaction Configuration diagram element.
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– The procedure for configuring a common IVR flow is as follows:
1. Choose Configuration Center > Resource Management > Audio and Video,

upload the voice or video file used in the Satisfaction Configuration diagram
element, and approve the file.

2. Confirm that a main flow and an exception handling flow have been created
and published successfully.

3. Choose Configuration Center > Chatbot Management > Flow Configuration
and add a subflow.
Set Is Referenced to Yes.

4. Select the Satisfaction Survey diagram element on the flow editing canvas,
configure related information, and save the flow configuration.

5. Select the new flow and click Release. After the flow is published, it can be
used.

For details, see 2.6.3 Operator: Configuring a Common IVR.
– The procedure for configuring an intelligent IVR flow is as follows:

1. Choose Configuration Center > Resource Management > Audio and Video,
upload the voice or video file used in the Satisfaction Configuration diagram
element, and approve the file.

2. Choose Configuration Center > Chatbot Management > Flow Configuration
> Flow > Orchestration and create an IVR flow.

3. Select the Satisfaction Survey diagram element on the flow editing canvas,
configure related information, and save the flow configuration.

4. Select the new flow and click Release. After the flow is released, it can be used.
5. Choose Configuration Center > Chatbot Management > Flow Configuration

> Intelligent Chatbot and create a chatbot.
Set Flow Name to the flow created in Step 4.ii.

For details, see 2.6.2 Configuring an Intelligent Robot.

● SMS Sending Channel
– Huawei Cloud SMS
– SMS Gateway

● SMS Template: Select an SMS template whose Notification Type is External
Notification configured on the Notification Template page. For details, see
2.11.5 Configuring Notification Templates as an Administrator.

● Valid Reply Period (min): Validity period for replying to a satisfaction survey.
The value ranges from 1 to 1440, in minutes.
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Figure 2-51 Satisfaction Survey page

Step 5 Click Save.

Step 6 Set parameters on the Satisfaction Survey Policy tab page.
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● Policy Group Name: Name of a satisfaction survey strategy group. The value
can contain a maximum of 20 characters.

● Available Policies and Selected Policies: Under Available Policies, click 
to select policies.

● Handling Time
– Start Time: Start time of the time range in a day in which calls need to

be transferred to the satisfaction survey.
– End Time: End time of the time range in a day in which calls need to be

transferred to the satisfaction survey.
● Handling Date

– Start date: Start date of the time range in which calls need to be
transferred to the satisfaction survey.

– End date: End date of the time range in which calls need to be
transferred to the satisfaction survey.

● Call Duration
– Minimum Call Duration (s): Minimum call duration of calls transferred

to the satisfaction survey. The value is a number of 1 to 12 digits.
– Maximum Call Duration (s): Maximum call duration of calls transferred

to the satisfaction survey. The value is a number of 1 to 12 digits.
● Skill Queue: Skill queue to which calls transferred to the satisfaction survey

belong.
● Call Type: Type of calls transferred to the satisfaction survey.

– Inbound call
– Outbound call

Step 7 Click Save.

Step 8 Set parameters on the Channel Satisfaction Survey Policy tab page.
● Channel Type: Channel type to which a satisfaction survey policy applies.

– Voice or video channel
– Multimedia channels-WEB
– Multimedia channels-WECHAT
– Multimedia channels-FACEBOOK
– Multimedia channels-X(TWITTER)
– Multimedia channels-WHATSAPP
– Multimedia channels-5G RCS
– Multimedia channels-TELEGRAM
– Multimedia channels-LINE
– Multimedia channels-SMS
– Multimedia channels-INSTAGRAM

● Channel: Select a multimedia channel configured on the Configuration
Center > Access Configuration > Channel Configuration page. For details,
see 2.5 Configuring Multimedia Channels.
This parameter is displayed only when Channel Type is set to a value other
than Voice or video channel.
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● Priority: Priority of a channel satisfaction survey policy. The value ranges from
1 to 100. A smaller value indicates a higher priority. The policy with a higher
priority is preferentially matched to conduct the survey.

● Survey Type: Type of the channel satisfaction survey.
– When Channel Type is set to Voice or video channel, the options are as

follows:

▪ IVR voice

▪ SMS

▪ No survey

– When Channel Type is set to Multimedia channels-WEB, the options
are as follows:

▪ Web

▪ No survey

– When Channel Type is set to other multimedia channels, the options are
as follows:

▪ Text Message

▪ No survey

● Survey Policy: Select a policy group configured on the Satisfaction Survey
Policy page.

Step 9 Click Save.

----End

2.3.3.3 Configuring the Customized Tone (Agent Ringback Tone)
The customized tone (agent ringback tone) is centrally configured by a tenant
administrator. The ringback tones of all agents in the tenant space are the same.

Prerequisites
A voice file whose Usage Scenario is tone is available on the Configuration
Center > Resource Management > Audio and Video Resource Management
page.

Context
After a call is allocated to an idle agent, the agent ringback tone is played to the
calling party before the agent answers the call.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Workbench Configuration > Prompt Information.

Step 2 Set parameters on the Agent Ring Back Tone Configuration tab page.
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● Agent Ring Back Tone: Select Customization.
● Select Note File: Select an uploaded voice file and click OK.

Figure 2-52 Agent Ring Back Tone Configuration

Step 3 Click Save.

----End

2.3.3.4 Configuring Page Message Notifications

Customized page message notifications are centrally configured by a tenant
administrator. The page message notifications of all agents in the tenant space are
the same.

Prerequisites

None

Context

This configuration applies only when the page is hidden, such as when the
browser is minimized, or when the page is tabbed in the background.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Workbench Configuration > Prompt Information.

Step 2 Click Page Message Notification Configuration.

Step 3 Set Ringtones and Pop-up dialog box reminder under Audio and video
incoming call notification, Multimedia incoming call notification, and New
multimedia message notification.

The system provides the following ringtones, which can be played online. Select a
ringtone as required.
● msg
● news
● genie
● tip
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● tinkle

Step 4 Click OK.

----End

Follow-up Procedure
If a pop-up dialog box reminder is configured, when an agent signs in, the browser
displays a dialog box asking whether to allow notifications. The pop-up dialog box
reminder is valid only after the agent allows notifications.

Figure 2-53 Dialog box asking whether to allow notifications

2.3.3.5 Configuring Voice Silent Agents
Voice silent agents are used to assist the intelligent voice robot. If the robot
training is incomplete, agents can assist the robot in replying.

Prerequisites
● You have configured and published an intelligent IVR flow whose Work Mode

is Monitor or Insert.
● You have configured the following called routes. For details, see 2.3.1.2

Configuring Called Routes.
– Called route whose Device Type is IVR and Type is Audio/Video created

using the preceding intelligent IVR flow
– Called route whose Device Type is Skill Queue and Type is Multimedia

● A skill queue whose Type is Voice exists. For details, see 2.3.1.1 Maintaining
a Tenant Space Skill Queue.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Voice Silent Agent.

Step 2 Choose New. In the New Voice Silent Agent dialog box, set voice silent agent
parameters.
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Figure 2-54 New Voice Silent Agent

Table 2-15 Voice silent agent parameters

Parameter Description

Info Configuration

Called IVR Called IVR created using a published intelligent IVR flow whose
Work Mode is Monitor or Insert.

Silent Agent
Skill Queue

Multimedia called route.

Agent Skill
Queue

Voice skill queue.
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Parameter Description

Agent Work Time: A maximum of four working time segments can be added.

Workday Working time segment of the agent on workdays.

Non-workday Working time segment of the agent on non-workdays.

 

Step 3 Click Save.

----End

2.3.3.6 Managing Messages
A tenant administrator can query messages in the current tenant space by page
based on criteria, or assign, handle, play, or download them.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Message.

Step 2 Manually search for messages based on criteria.

Figure 2-55 Message list page

Table 2-16 Parameters for searching for messages

Parameter Description

Time The options are as follows:
● 1 Day
● 3 Days
● 7 Days
● Customization

Contact
number

Customer number.

Employee
ID

Agent ID of a tenant space agent.
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Parameter Description

Channel
Type

The options are as follows:
● Voice: Message handling, playback, and download are

supported.
● WEB: Message assignment, viewing, and handling are

supported.

 

Step 3 Choose To be allocated to assign messages to agents for handling.

1. Click Assign. The Assigning Messages dialog box is displayed.
2. Search for all agents that have been bound to accounts in the tenant space or

search for agents based on criteria. Click  to select an agent.
3. Click Submit. The message is assigned to the selected agent.
4. On the To be processed page, the agent ID and handler are updated to the

agent ID and business account of the selected agent, the update time is the
current time, and the message status changes from To be allocated to
Unprocessed.

Step 4 Play a message. You can perform the following operations:

● : Play or pause a voice message.

● : Fast forward or rewind the recording.

● : Adjust the playback volume.

● : Select a playback speed. The options are 0.5X, 0.75X, 1.0X, 1.25X, 1.5X,
and 2.0X.

Step 5 Download a message.

NO TE

The downloaded message contains personal data. Exercise caution when processing the
exported message to prevent personal data leakage and abuse.

The playback and download functions are available only for the current drive letter. For
example, if the current drive letter is Y and the drive letter is switched from Y to Z, playback
and download will fail. To play and download historical files properly, switch the drive letter
from Z back to Y.

1. Select the message to be downloaded and click Download.
2. Enter a customized compression password.

The compression password must contain letters, digits, and the following
special characters: _@%
The compression password can contain a maximum of 12 characters.

3. Click OK.

Step 6 Handle a received message as an agent.

1. Choose To be processed.
2. Click Process corresponding to a message. The Process Message dialog box is

displayed. The message status changes from Unprocessed to Processing.
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3. After confirming that the agent status is idle, click  to initiate a call to the
contact number to handle the message.

4. Return to the Handling Comments text box, enter comments, and click
Submit to complete the message handling. After the submission is successful,
the message status changes from Processing to Processed.

----End

2.3.3.7 Viewing Contact Records
A tenant administrator can search for or export contact records of the current
tenant space to learn about the working status of agents.

Prerequisites
To display contact record fields that are not displayed by default after the tenant
is created, configure them by referring to 2.3.2.3 Configuring Contact Record
Data Items.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Contact History >
Contact.

Step 2 Set search criteria to search for contact records based on the criteria.

Figure 2-56 Contact page
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Table 2-17 GUI elements on the Contact page

Element Type Description

1 Day Drop-down
list and
calendar
component

Time when a contact record is generated. Search
criterion.
The options are as follows:
● 1 Day
● 3 Days
● 7 Days
● Customization
Default value: 1 Day
NOTE

The maximum time span for searching for contact records
is determined by the Time Span for Contact Record
Query parameter.

Contact
number

Text box Calling number, called number, or handled number.
Search criterion.
This parameter is used for exact search. Only
contact records whose numbers are the same as the
entered number are displayed.

Organizati
on Unit

Drop-down
list

OU. Search criterion.
OUs are classified into Unorganized and organized
OUs.
You can filter organized OUs by keyword.

You can click  to delete the selected OU.

More Button Expand advanced search criteria.

Button Search for data based on search criteria again and
refresh data on the page.

Button Create an export task.
NOTE

Whether this button is displayed is determined by the
Contact Record Export permission. Agents without this
permission cannot export contact records. By default, a
tenant administrator has this permission.

Button View export tasks.
NOTE

Whether this button is displayed is determined by the
Contact Record Export permission. Agents without this
permission cannot view export tasks. By default, a tenant
administrator has this permission.
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Element Type Description

Call Type Drop-down
list

Call type. Search criterion.
The options are as follows:
● Outgoing Call
● Incoming Call
● Predicted outbound call
● Preview outgoing call
● Preempted outbound call
● ITA bidirectional call
● Fixed Outbound Call
● Double call
● Collaborative call
● Click-to-dial
● Intelligent Robot Outbound Call

Media
Type

Drop-down
list

Media type. Search criterion.
The options are as follows:
● Voice
● Video
● Multimedia

Skill
Queue

Drop-down
list

Skill queue. Search criterion.

Satisfactio
n
evaluation

Drop-down
list

Satisfaction level. Search criterion.
The options are as follows:
● Very dissatisfied
● Dissatisfied
● General
● Satisfied
● Very satisfied
● Not evaluated
● Evaluation failed
NOTE

Satisfaction levels can be customized. For details, see
2.3.3.2 Configuring Satisfaction Surveys.

Call
Reason
Set or Not

Drop-down
list

Whether the call reason is set. Search criterion.
The options are as follows:
● Yes
● No

Account
Name

Text box Business account name. Search criterion.
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Element Type Description

Employee
ID

Text box Agent ID. Search criterion.

Caller
Number

Text box Calling number. Search criterion.
If the number of agents of the tenant does not
exceed the value of the system parameter
Maximum number of agents for fuzzy query of
calling, called, and handled numbers in a tenant
contact record, a fuzzy search can be performed
when no record is exactly matched based on the
calling number and the time range for the search
does not exceed seven days.

Called
Number

Text box Called number. Search criterion.
If the number of agents of the tenant does not
exceed the value of the system parameter
Maximum number of agents for fuzzy query of
calling, called, and handled numbers in a tenant
contact record, a fuzzy search can be performed
when no record is exactly matched based on the
called number and the time range for the search
does not exceed seven days.

Handled
Number

Text box Handled number. Search criterion.
If the number of agents of the tenant does not
exceed the value of the system parameter
Maximum number of agents for fuzzy query of
calling, called, and handled numbers in a tenant
contact record, a fuzzy search can be performed
when no record is exactly matched based on the
handled number and the time range for the search
does not exceed seven days.

Customer
Name

Text box Customer name. Search criterion.

Call S/N Text box Call SN. Search criterion.

Call
Duration
Start

Text box Minimum call duration of a contact record. Search
criterion.
The value is a number greater than 0.
The unit is second.
This parameter is unavailable when the time span
for searching for contact records exceeds 31 days.
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Element Type Description

Call
Duration
End

Text box Maximum call duration of a contact record. Search
criterion.
The value is a number greater than 0.
The unit is second.
This parameter is used for fuzzy search. Contact
records whose numbers contain the entered number
are displayed.
This parameter is unavailable when the time span
for searching for contact records exceeds 31 days.

Contact
Number
(Fuzzy
Query)

Text box Calling number, called number, or handled number.
Search criterion.
This parameter is unavailable when the time span
for searching for contact records exceeds 31 days.

Reset Button Reset search criteria.

Search Button Search for contact records.

Call S/N Label Call SN, which is a 19-digit number randomly
generated by the system. You can click a value to
view the operations related to the handled number
in a call, including the conversation content, call
reason, contact records, and transfer records.

Customer
Number

Label Customer number.

Account
Name

Label Business account name.

Employee
ID

Label Agent ID.

Caller
Number

Label Calling number.

Called
Number

Label Called number.
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Element Type Description

Media
Type

Label Media type. If the media type is multimedia, the
specific multimedia channel is also displayed.
The options are as follows:
● Voice
● Video
● Multimedia –web
● Multimedia –WeChat
● Multimedia –Facebook
● Multimedia –Twitter
● Multimedia –5G
● Multimedia –Email
● Multimedia –LINE
● Multimedia –WhatsApp
● Multimedia –Telegram
● Multimedia –Instagram
● Multimedia –SMS

Call Type Label Call type.
The options are as follows:
● Outgoing Call
● Incoming Call
● Predicted outbound call
● Preview outgoing call
● Preempted outbound call
● ITA bidirectional call
● Fixed Outbound Call
● Double call
● Collaborative call
● Click-to-dial
● Intelligent Robot Outbound Call

Start Time Label Start time.

End Time Label End time.

Call
Duration
(s)

Label Call duration, in seconds.
The call duration is the duration from the time
when a call is connected to the time when the call is
released.
If the call duration is shorter than 1 second, 0 is
displayed. The recording file can be played and
downloaded.
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Element Type Description

Hang-up
Party

Label Hang-up party.
The options are as follows:
● User
● Agent

Skill
Queue

Label Skill queue.

Call
Reason

Label Call reason.

Call
Remarks

Label Call remarks.

Satisfactio
n
evaluation

Label Satisfaction level.
The options are as follows:
● Very dissatisfied
● Dissatisfied
● General
● Satisfied
● Very satisfied
● Not evaluated
● Evaluation failed
NOTE

● After the IVR voice satisfaction survey switch is turned
on and a satisfaction survey IVR flow is bound, if the
customer does not evaluate the service, the value is
empty.

● After the SMS satisfaction survey switch is turned on
and an SMS template is bound, if the customer does
not evaluate the service, the value is empty.

● After the channel satisfaction survey switch is turned
on, if the customer does not evaluate the service, the
value is empty.

● If the customer is not transferred to the satisfaction
survey flow, the value is empty.
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Element Type Description

Recording
File

Button
group

Operations that can be performed on the recording
file in a contact record.
The options are as follows:
● Play
● Download
NOTE

● Voice files can be played and downloaded in WAV
format.

● When the video application mode of an agent is SFU
video, the video file in the contact record generated for
a video call between the agent and a customer can be
played online or downloaded in MP4 format.

● When the video application mode of an agent is MCU
video, the video file in the contact record generated for
a video call between the agent and a customer can be
downloaded in TS format.

● If Video application mode is set to MCU(CloudVC),
an agent can download video files only after signing in.

After you click Play, the voice playback component
 is displayed above the list. This

component is used to play the recording in a
contact record.
You are advised to use video software other then
Windows Media Player to play downloaded videos.
If the Screen recording and screen inspection
feature is enabled to automatically record agents'
screen operations:
● After you click Play for a voice contact record,

the agent's screen operation video is displayed.
● After you click Play for a video contact record,

the Recording File Details dialog box is
displayed. Then, after you click Play for the
record whose Media Type is VRC, the agent's
screen operation video is displayed.

 

Step 3 Export contact records (excluding voice and video files) to the local PC in batches.

1. Click , set Data Scope and Export Field, and enter a compression
password.
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– For details about the complexity requirements of the compression password, see
the prompt on the page. The compression password is used to open the
downloaded package.

– The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

– The Compressed password parameter is not displayed when the tenant parameter
Specifies whether to set the password of the compressed file for exporting
data. is set to No.

2. Click  to view the export tasks in the last seven days. To open a file, you
need to enter the compression password set during export task creation.

Step 4 Play or download the recording file in a contact record.

1. Click Play in the Recording File column to play the recording file.
– After you click Play for a voice contact record, the agent's screen

operation video is displayed.
– After you click Play for a video contact record, the Recording File Details

dialog box is displayed. Then, after you click Play for the record whose
Media Type is VRC, the agent's screen operation video is displayed. After
you click Play for the record whose Media Type is Video, the video of the
video call is displayed.

2. Click Download in the Recording File column and enter a compression
password to download the recording file.

NO TE

The downloaded recording file contains personal data. Exercise caution when
processing the exported file to prevent personal data leakage and abuse.

You are advised to use video software other then Windows Media Player to play
downloaded videos.

----End

2.3.3.8 Viewing Bidirectional Call Records

A tenant administrator can search for or export bidirectional call records of the
current tenant space by page based on criteria, or play or download recording
files. In this version, bidirectional call records are available only for ITA
bidirectional calls.

Prerequisites

The one-click bidirectional call feature has been enabled for the tenant space.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Contact History > ITA
Call.

Step 2 Set search criteria to search for bidirectional call records based on the criteria.
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Figure 2-57 ITA Call page

Table 2-18 GUI elements on the ITA Call page

Element Typ
e

Description

Time Dro
p-
do
wn
list

The options are as follows:
● 1 Day
● 3 Days
● 7 Days
● Customization

Caller
Number

Tex
t
box

Agent number dialed after a one-click bidirectional call.
Advanced search criterion.

Called
Number

Tex
t
box

Customer number dialed after a one-click bidirectional call.
Advanced search criterion.

Reset But
ton

Reset search criteria.

Search But
ton

Search for bidirectional call records.

But
ton

Search for data based on search criteria again and refresh
data on the page.

But
ton

Add a task for exporting bidirectional call records.
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Element Typ
e

Description

But
ton

View export tasks.

Caller
Number

Lab
el

Agent-side number of a one-click bidirectional call.
The calling number can be displayed anonymously. If the
User numbers are displayed in plaintext permission is
available, the number is displayed in plaintext. Otherwise, the
number is displayed anonymously. By default, a tenant
administrator has the User numbers are displayed in
plaintext permission. If anonymous display is required, you
are advised to create a tenant administrator role, deselect the
User numbers are displayed in plaintext permission for the
role, and assign it to the tenant administrator.

Called
Number

Lab
el

Customer-side number of a one-click bidirectional call.
The called number can be displayed anonymously. If the User
numbers are displayed in plaintext permission is available,
the number is displayed in plaintext. Otherwise, the number
is displayed anonymously. By default, a tenant administrator
has the User numbers are displayed in plaintext
permission. If anonymous display is required, you are advised
to create a tenant administrator role, deselect the User
numbers are displayed in plaintext permission for the role,
and assign it to the tenant administrator.

Time
when a
call is
initiated

Lab
el

Time when a bidirectional call is initiated, that is, time when
the calling party is called.

Call End
Time

Lab
el

Time when the last party of a bidirectional call releases the
call.

Calling
Party
Answer
Time

Lab
el

Time when the calling party answers a call after the call is set
up.

Called
Answer
Time

Lab
el

Time when the called party answers a call after the calling
party answers the call.

Call
Duration
(s)

Lab
el

Call duration, in seconds. The call duration is calculated from
the time when the call is set up.

Release
Reason

Lab
el

Call release reason.

Operation Lab
el

● Play
● Download
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Element Typ
e

Description

Success
Rate

Lab
el

Bidirectional call success rate.
● Number of Successful Records: Number of successful

calls in the list.
● Number of Failed Records: Number of failed calls in the

list.

 

Step 3 Export bidirectional call records (excluding voice and video files) to the local PC in
batches.

1. Click  and enter a compression password.

NO TE

– For details about the complexity requirements of the compression password, see
the prompt on the page. The compression password is used to open the
downloaded package.

– The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

2. Click  to view the export tasks in the last seven days. To open a file, you
need to enter the compression password set during export task creation.

Step 4 Play a bidirectional call recording. You can perform the following operations:

● : Play or pause the recording.

● : Fast forward or rewind the recording.

● : Adjust the playback volume.

● : Select a playback speed. The options are 0.5X, 0.75X, 1.0X, 1.25X, 1.5X,
and 2.0X.

Step 5 Download a bidirectional call recording.

1. Select the bidirectional call recording to be downloaded and click Download.

NO TE

The downloaded bidirectional call recording contains personal data. Exercise caution
when processing the exported recording to prevent personal data leakage and abuse.

2. In the confirmation dialog box, click Yes.

----End

2.3.3.9 Configuring the Online Chat Service Time

A tenant administrator can set workdays and non-workdays in advance so that
agents can manage working hours more conveniently.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Workbench Configuration > Service Time.

Figure 2-58 Workbench Configuration

Step 2 Configure the work calendar.
● Select non-working days: Select several days in a week as non-workdays. For

example, select Saturday and Sunday as non-workdays. The selected dates
are synchronized to all months.

● Select Rest Dates: Select several dates as non-workdays. For example, select
the dates from October 1, 2019 to October 7, 2019 (National Day) as non-
workdays.

a. Click  to expand the area for adding rest dates.

NO TE

Disabling this function will clear all data in the table. Exercise caution when
performing this operation.

b. Click Add and set rest date parameters based on Figure 2-59.

Figure 2-59 Select Rest Dates

c. Click Save to save the configuration.
● Select Work Dates: Select several dates as workdays. The earliest date is the

current date of the last year. For example, select July 13, 2019 (Saturday;
temporary overtime) as a workday.

a. Click  to expand the area for adding work dates.

NO TE

Disabling this function will clear all data in the table. Exercise caution when
performing this operation.

b. Click Add and set work date parameters based on Figure 2-60.

Figure 2-60 Select Work Dates

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 135



c. Click Save to save the configuration.

Step 3 The configured workdays and non-workdays are displayed in the Calendar
preview area in real time. You can directly view the configuration result.

Figure 2-61 Calendar preview

----End

2.3.3.10 Viewing Skill Queue Adjustment Records

An agent or a tenant administrator can query skill queue adjustment details.

Prerequisites
● The agent has the Reset Skill Record menu permission.
● The agent's skill queue has been adjusted by referring to Follow-up

Procedure.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Work Log > Adjustment
Log.

Step 2 Set search criteria to search for skill queue adjustment records based on the
criteria.

Figure 2-62 Adjustment Log page

Table 2-19 GUI elements on the Adjustment Log page

Element Typ
e

Description

Time Dro
p-
do
wn
list

The options are as follows:
● 1 Day
● 3 Days
● 7 Days
● Customization
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Element Typ
e

Description

Adjust
Service
Account

Tex
t
box

Search criterion.
● Business account of the agent who adjusts a skill queue.
● Business account of an inspector.

Adjust
Agent
WorkNo

Tex
t
box

Search criterion.
● ID of the agent who adjusts a skill queue.
● Agent ID of an inspector.

Adjusted
Service
Account

Tex
t
box

Search criterion.
● Business account of the agent whose skill queue is

adjusted.
● Business account of the agent whose skill queue is

adjusted by an inspector.

Adjusted
Agent
WorkNo

Tex
t
box

Search criterion.
● ID of the agent whose skill queue is adjusted.
● ID of the agent whose skill queue is adjusted by an

inspector.

Reset But
ton

Reset search criteria.

Search But
ton

Search for skill queue adjustment records.

But
ton

Search for data based on search criteria again and refresh
data on the page.

Adjust
Service
Account

Lab
el

● Business account of the agent who adjusts a skill queue.
● Business account of an inspector.

Adjust
Agent
WorkNo

Lab
el

● ID of the agent who adjusts a skill queue.
● Agent ID of an inspector.

Adjusted
Service
Account

Lab
el

● Business account of the agent whose skill queue is
adjusted.

● Business account of the agent whose skill queue is
adjusted by an inspector.

Adjusted
Agent
WorkNo

Lab
el

● ID of the agent whose skill queue is adjusted.
● ID of the agent whose skill queue is adjusted by an

inspector.

Adjust
Time

Lab
el

Time when a skill queue is adjusted.
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Element Typ
e

Description

Skill
Queue
Before
Adjustme
nt

Lab
el

Skill queue to which an agent has signed in before skill queue
adjustment.

Skill
Queue
After
Adjustme
nt

Lab
el

Skill queue to which an agent signs in after skill queue
adjustment.

 

----End

2.3.3.11 Viewing Identity Authentication Records

An agent or a tenant administrator can query identity authentication details.

Prerequisites

The agent has the Identity Authentication Record menu permission.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Work Log > Auth Log.

Step 2 Set search criteria to search for identity authentication records based on the
criteria.

Figure 2-63 Auth Log page

Table 2-20 GUI elements on the Auth Log page

Element Typ
e

Description

Time Dro
p-
do
wn
list

The options are as follows:
● 1 Day
● 3 Days
● 7 Days
● Customization
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Element Typ
e

Description

Account Tex
t
box

Business account of the agent who performs identity
authentication. Advanced search criterion.
Whether this parameter is displayed is determined by the
Querying All Authentication Records permission. Agents
without this permission cannot view this parameter. By
default, a tenant administrator has this permission.

Employee
ID

Tex
t
box

ID of the agent who performs identity authentication.
Advanced search criterion.
Whether this parameter is displayed is determined by the
Querying All Authentication Records permission. Agents
without this permission cannot view this parameter. By
default, a tenant administrator has this permission.

Call S/N Tex
t
box

Call SN. Advanced search criterion.

Customer
Number

Tex
t
box

Customer number. Advanced search criterion.

Authentic
ation
Result

Dro
p-
do
wn
list

Search criterion.
● Not returned
● Pass
● Fail
● Error

Reset But
ton

Reset search criteria.

Search But
ton

Search for identity authentication records.

But
ton

Search for data based on search criteria again and refresh
data on the page.

Account Lab
el

Business account of the agent who performs identity
authentication.

Employee
ID

Lab
el

ID of the agent who performs identity authentication.

Call S/N Lab
el

Call SN.

Customer
Number

Lab
el

Customer number.
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Element Typ
e

Description

Authentic
ation
Time

Lab
el

Time when identity authentication is performed.

Authentic
ation
Mode

Lab
el

Identity authentication mode.

Authentic
ation
Result

Lab
el

Identity authentication result.
● Not returned
● Pass
● Fail
● Error

 

----End

2.3.3.12 Managing Documents
A tenant administrator can search for documents of the current tenant space by
page based on criteria, or invalidate, preview, or download documents.

Prerequisites
The contract digital signature feature has been enabled for the tenant space.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Contact History >
Document Management.

Step 2 Set search criteria to search for documents based on the criteria.

Figure 2-64 Document Management page
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Table 2-21 GUI elements on the Document Management page

Element Typ
e

Description

Searching
for
Documen
t Names

Tex
t
box

Document name.

Caller
Number

Tex
t
box

Advanced search criterion.
● When an agent initiates a call, the calling number is an

access code.
● When a customer initiates a call, the calling number is a

customer number.

Called
Number

Tex
t
box

Advanced search criterion.
● When an agent initiates a call, the called number is a

customer number.
● When a customer initiates a call, the called number is an

access code.

Documen
t Status

Dro
p-
do
wn
list

Document status. Advanced search criterion.
● Unsigned
● Signed
● Expired

Signature
Date

Dro
p-
do
wn
list

Signature date. Advanced search criterion.

Reset But
ton

Reset search criteria.

Search But
ton

Search for document management records.

But
ton

Search for data based on search criteria again and refresh
data on the page.
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Element Typ
e

Description

Caller
Number

Lab
el

● When an agent initiates a call, the calling number is an
access code.

● When a customer initiates a call, the calling number is a
customer number.

The calling number can be displayed anonymously. If the
User numbers are displayed in plaintext permission is
available, the number is displayed in plaintext. Otherwise, the
number is displayed anonymously. By default, a tenant
administrator has the User numbers are displayed in
plaintext permission. If anonymous display is required, you
are advised to create a tenant administrator role, deselect the
User numbers are displayed in plaintext permission for the
role, and assign it to the tenant administrator.

Called
Number

Lab
el

● When an agent initiates a call, the called number is a
customer number.

● When a customer initiates a call, the called number is an
access code.

The called number can be displayed anonymously. If the User
numbers are displayed in plaintext permission is available,
the number is displayed in plaintext. Otherwise, the number
is displayed anonymously. By default, a tenant administrator
has the User numbers are displayed in plaintext
permission. If anonymous display is required, you are advised
to create a tenant administrator role, deselect the User
numbers are displayed in plaintext permission for the role,
and assign it to the tenant administrator.

Documen
t Status

Lab
el

Document status.
● Unsigned
● Signed
● Expired

Documen
t Name

Lab
el

Document name.

Signature
Date

Lab
el

Date when a document is signed.

Update
Date

Lab
el

Date when a document is re-signed.
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Element Typ
e

Description

Operation Lab
el

● Invalidation
Select the document to be invalidated and click
Invalidation.

● Download
Select the document to be downloaded and click
Download.
NOTE

The downloaded documents contain personal data. Exercise
caution when processing the downloaded documents to prevent
personal data leakage and abuse.

● Preview
Select the document to be previewed and click Preview.

 

----End

2.3.3.13 Managing Harassment Records
A tenant administrator can review harassment records submitted by agents. After
the records are approved, they are added to the special list. The tenant
administrator and agents can view the review results.

Prerequisites
To view the review result, agents must have the Channel Configuration, Call
Center Configuration, Settings, Harassment record review menu permissions
and the Query Contact Record operation permission.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Resource Management > Harassment Record.

Step 2 Set search criteria as required to search for harassment record information.

Figure 2-65 Harassment Record page
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Table 2-22 Key elements on the Harassment Record page

Element Typ
e

Description

Applicatio
n time
range

Cal
end
ar
co
mp
one
nt

Application time range. Search criterion.
The time range cannot exceed seven days.

You can click  to delete the selected time range.

Status Dro
p-
do
wn
list

Harassment record status. Search criterion.
● To be approved
● Approved
● Rejected

You can click  to delete the selected state.

Special
List Type

Dro
p-
do
wn
list

Special list type. Search criterion.
● Black List
● Red List

Special
List Level

Dro
p-
do
wn
list

Special list level. Search criterion.

Operator Tex
t
box

Operator business account. Search criterion.

You can click  to delete the entered operator.

Subscribe
r number

Tex
t
box

Customer number. Search criterion.
● Phone number
● Email address

Example: 123@huawei.com

Reset But
ton

Reset search criteria.

Search But
ton

Search for harassment records.

But
ton

Search for data based on search criteria again and refresh
data on the page.

Subscribe
r number

Lab
el

Customer number.
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Element Typ
e

Description

Special
List Type

Lab
el

Special list type.
● Black List
● Red List

Applicatio
n Time

Lab
el

Time when a harassment record is created.

Operator Lab
el

Business account of the agent who creates a harassment
record.

Reason
for
Joining

Lab
el

Reason for adding a customer number to the special list.

Operation But
ton
gro
up

Operations that can be performed.
● Approval: Approve a record that has not been approved.
● View: View an approved or rejected record.

 

Step 3 Click Approval in the Operation column.
● Select Agree.

– Special List Level: Select a special list level.
– Effective Period: Set the time range when the special list record takes

effect. The time range specified by Effective Period must be within the
time range from the current time to January 19, 2038.

– Opinions: Enter the opinion on the harassment record. The value
contains a maximum of 500 characters.

● Select Reject.
Opinions: Enter the opinion on the harassment record. The value contains a
maximum of 500 characters.

Step 4 Click Save.

After the application is approved, you can choose Configuration Center >
Resource Management > Special List and click the Special List tab to view the
new special list record.

After the approval is complete, you can choose Configuration Center > Resource
Management > Harassment Record to view the approval result. Approved
harassment records are migrated to the history table every hour and cannot be
queried on the GUI.

----End

2.3.3.14 Configuring Service Guidance

A tenant administrator can configure visualized wizard-based service flow
guidance for complex business handling in the customer service center to instruct
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agents to efficiently and quickly provide satisfactory services for customers based
on the configured visualized flows.

Prerequisites
● The Agent Business Process Visualization feature has been enabled for the

tenant space.
● The common agent has the Service Guidance Configuration menu

permission.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Workbench Configuration > Service Guidance.

Step 2 Click  to create a level-1 service guidance category.

If data exists on the page, click  next to Service Category to create a level-1
service guidance category.

Table 2-23 Key elements on the page for creating a level-1 service guidance
category

Element Typ
e

Description

Name Tex
t
box

Name of a level-1 service guidance category.
The value can contain 1 to 200 characters.

Serial
Number

Dro
p-
do
wn
list
+
text
box

Sequence number of a level-1 service guidance category.
The value is an integer ranging from 0 to 99.

Parent
Category
Name

Dro
p-
do
wn
list

Name of the parent category of a level-1 service guidance
category.
The options are as follows:
● No Parent Category
● Names of service guidance categories that have been

created under the tenant
Select No Parent Category.

Descriptio
n

Tex
t
box

Description of a level-1 service guidance category.
The value can contain 0 to 1000 characters.

 

Step 3 Click Save.
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Step 4 Click  next to the name of the level-1 service guidance category created in Step
2 to create a level-2 service guidance category.

Table 2-24 Key elements on the page for creating a level-2 service guidance
category

Element Typ
e

Description

Name Tex
t
box

Name of a level-2 service guidance category.
The value can contain 1 to 200 characters.

Serial
Number

Dro
p-
do
wn
list
+
text
box

Sequence number of a level-2 service guidance category.
The value is an integer ranging from 0 to 99.

Selected
Category
Name

Lab
el

Category name selected when creating a level-2 service
guidance category.

New Type Dro
p-
do
wn
list

Relationship with the selected category name.
The options are as follows:
● Add Sub Level
● Add Peer Level
Select Add Sub Level.

Descriptio
n

Tex
t
box

Description of a level-2 service guidance category.
The value can contain 0 to 1000 characters.

 

Step 5 Click Save.

Step 6 Click the name of the level-2 service guidance category created in Step 4.

Step 7 Click New to create a service guidance flow.

Table 2-25 Key elements on the page for creating a service guidance flow

Element Typ
e

Description

Name Tex
t
box

Name of a service guidance flow.
The value can contain 1 to 200 characters.
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Element Typ
e

Description

Serial
Number

Dro
p-
do
wn
list
+
text
box

Sequence number of a service guidance flow.
The value is an integer ranging from 0 to 99.

Parent
Category
Name

Lab
el

Name of the level-2 service category to which a service
guidance flow belongs.

Call
Reason

Dro
p-
do
wn
list

Call reason of a service guidance flow.
The options are call reasons that have been created under
the tenant.

Customiz
ed Page
URL

Tex
t
box

Customized information displayed when an agent uses the
service guidance function.
The value can contain 1 to 200 characters.

Descriptio
n

Tex
t
box

Description of a service guidance flow.
The value can contain 0 to 1000 characters.

 

Step 8 Click Save.

After the service guidance flow is created, you can perform the following
operations:

● Click the flow name to view information about the service guidance flow.
● Click Edit in the Operation column to modify information about the service

guidance flow.
● Click Delete in the Operation column to delete the service guidance flow.

Step 9 Click  next to the name of the service guidance flow created in Step 7.

Step 10 Click Edit in the Operation column to access the guidance flow editing canvas
and edit the guidance flow.

Table 2-26 Key elements on the page for editing a flow

Element Typ
e

Description

Save But
ton

Set the flow status to Draft.
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Element Typ
e

Description

Release But
ton

Set the flow status to Release.

But
ton

View the thumbnail of the service guidance flowchart.
● Drag the thumbnail to move the flowchart canvas.

● Click  to zoom in or out the flowchart.

Toolbar -
Function
Diagram
Element

But
ton

: Add functional diagram elements to the canvas.

Toolbar -
Branch
Diagram
Element

But
ton

: Add a Branch Judgment diagram element to the canvas.

Toolbar -
Zoom In/
Zoom
Out

But
ton

: Adjust the display percentage of the current
canvas by clicking a value in the drop-down list or clicking
the zoom-in or zoom-out icon.

Toolbar -
Reset
View

But
ton

: Reset the canvas position and display the flow in the
current view.

Toolbar -
Full
Screen

But
ton

: Switch to the fullscreen mode.

Toolbar -
Undo/
Redo

But
ton

: Undo or redo operations such as adding or deleting
diagram elements in the canvas.

Toolbar -
Delete

But
ton

: Delete diagram elements or lines from the canvas.

 

Table 2-27 Key elements on the Node Attribute page of a diagram element

Element Typ
e

Description

Name Tex
t
box

Name of a function diagram element.
The value can contain 1 to 50 characters.
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Element Typ
e

Description

Node
Type

Opt
ion
but
ton

Node type of a diagram element.
● Task
● Branch

Execute
Type

Dro
p-
do
wn
list

Execution type of a diagram element.
The options are as follows:
● Common
● SMS
● Email
● Trans IVR
● Sub Flow
● Create Case

Execution
Content

Dro
p-
do
wn
list

Execution content of a diagram element.
This parameter is displayed when Execution Type is set to
any value except Common.
The options are as follows:
● When Execution Type is set to SMS, the options are all

SMS templates whose Notification Type is External
Notification under the tenant space.

● When Execution Type is set to Email, the options are all
email templates under the tenant space.

● When Execution Type is set to Trans IVR, the options are
all common IVR flows and intelligent IVR flows under the
tenant space.

● When Execution Type is set to Sub Flow, the options are
all service guidance flows under the tenant space.

● When Execution Type is set to Create Case, the options
are all case types under the tenant space.

Transfer
Type

Dro
p-
do
wn
list

Type of call transfer to IVR flows.
This parameter is displayed only when Execution Type is set
to Trans IVR.
The options are as follows:
● Release Transfer
● Hang-up Transfer

Explanati
on

Tex
t
box

Content that an agent needs to introduce to a customer.
The value can contain 0 to 200 characters.

Informati
on

Tex
t
box

Node description.
The value can contain 0 to 200 characters.
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Element Typ
e

Description

Associate
d Service
Handling
Link

Tex
t
box

URL of the associated business that can be handled.
The value can contain 0 to 200 characters.
Contact the system administrator to add the URL to the
address trustlist. Address Type must be set to Business
Guidance Process Trustlist.

 

Step 11 After the guidance flow is edited, click Release.

If the agent assistant needs to use the guidance flow, set Associated Data of the
Call Transfer diagram element in the flow of the intelligent agent assistant to the
name of the guidance flow.

After the flow is published, click View to view the efficiency comparison data of
the guidance flow in a specified period, including the number of contacts, average
call duration, and first resolution rate in the same period when the guidance flow
is used and when the guidance flow is not used. The timeliness requirement for
the data is that data generated 24 hours ago can be queried.

----End

2.3.3.15 Configuring SmartCare Integration Information
A tenant administrator can configure information about the interworked
SmartCare.

Prerequisites
● The SmartCare feature has been enabled for the tenant space.
● You need to apply to the system administrator to add the SmartCare

interconnection address to the address trustlist whose Address Type is set to
SmartCare interconnection address.

● You have the SmartCare Integration menu permission.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Expansion and Integration > SmartCare Integration. The SmartCare
Integration Information Configuration page is displayed.

Step 2 Click Edit to configure SmartCare information.
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Table 2-28 Key elements on the SmartCare Integration Information Configuration
page

Element Typ
e

Description

SmartCar
e
Interconn
ection
Address

Tex
t
box

SmartCare URL.
The URL must start with http or https.
NOTE

HTTP is not recommended, because it may bring risks. The secure
HTTPS protocol is recommended.
The value of SmartCare Interconnection Address must be added by
the system administrator to the address trustlist. Address Type is set
to SmartCare interconnection address.

AppId Tex
t
box

Provided by SmartCare.
The value ranges from 5 to 100.

AppSecret Tex
t
box

Provided by SmartCare.
The value ranges from 5 to 100.

Certificat
e

Sel
ecti
on
box

Select a certificate uploaded on the Configuration Center >
System Management > Certificate page.

Fast
boundary
scene
name

Tex
t
box

Name of the fast demarcation scenario.
Provided by SmartCare.
The value can contain a maximum of 64 characters.

Deep
boundary
scene
name

Tex
t
box

Name of the in-depth demarcation scenario.
Provided by SmartCare.
The value can contain a maximum of 64 characters.

 

Step 3 Click Save.

----End

2.4 Configuring a Mobile Agent
A tenant administrator can configure the mobile customer service to forward
inbound calls to specified skill queues or numbers.

2.4.1 (Optional) Configuring an Inbound Call Flow
You can configure a flow to directly transfer an inbound call to the number of a
customer manager who has provided services for the customer.
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Prerequisites
● You have completed the connection between the AICC and OIAP.
● You have obtained the information about the mobile agent and bidirectional

call interfaces in the API Fabric from the O&M personnel.

Context
The flow invokes the getCalledInfo interface to obtain the inbound call data, and
transfers the inbound calls to a specified number or a skill queue based on the
data.

Procedure

Step 1 Add a voice file, which is used as a voice prompt for an error flow.

1. Sign in to the AICC as a tenant administrator and choose Configuration
Center > Resource Management > Audio and Video.

2. Click Language Setting, click Set As Default next to the language to be set
as the default language, and click Save.

3. Click New in the upper right corner. The page for adding a voice file is
displayed.

4. Set voice prompt parameters.
– Resource Name: Enter the name of the file to be uploaded.
– Usage Scenario: Select IVR.

– Select Select a voice file, click , select a local WAV
voice file, and click Submit. If you do not have a voice file, select Online
Recording.

Figure 2-66 Adding a voice file
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5. Click Submit to submit the voice file to the system administrator for approval.

Step 2 Add an error flow.

A tenant space has only one error flow. The flow provides a solution for common
errors in a normal flow (for example, the next node cannot be found).
1. Choose Configuration Center > Chatbot Management > Flow

Management.
2. Click New.
3. Set flow parameters. Enter a flow name, set Type to Exception Handling

Flow, set Is Referenced to Yes, and click Save.
4. Click the flow to expand it and click Edit. The flow editing page is displayed.
5. Draw a flow, set the voice file added in Step 1 as the prompt tone for the

Play Voice node, as shown in the following figure, and click Save to save the
flow.

6. Expand the new error flow, click Release, select Official Release, and click
Confirm. The new flow is successfully published.

Step 3 Add the two interfaces to the trustlist.

The two interfaces are used for authentication and obtaining interface data.
1. Contact the system administrator to add the IP addresses and port numbers,

or domain names of the interfaces to the trustlist of the interface control
menu.

2. Choose Configuration Center > Chatbot Management > Flow
Configuration > Resource > Business Interface.

3. Click the Self-defined Interface tab and click New. The Add Business
Interface Configuration dialog box is displayed. Set interface parameters by
referring to Figure 2-67 to Figure 2-70.
Figure 2-67 and Figure 2-68 indicate the input and output parameters of the
getCalledInfo interface. Figure 2-69 and Figure 2-70 indicate the input and
output parameters of the token interface.
The token interface is used to obtain the token for AICC authentication. The
getCalledInfo interface is used to check whether the current calling number
has historical call records. If historical call records are available, the called
numbers are found.

Figure 2-67 Message header and output parameters of the getCalledInfo
interface
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Figure 2-68 Input parameters of the getCalledInfo interface

Figure 2-69 Message header and output parameters of the token interface

Figure 2-70 Input parameters of the token interface

Step 4 Add an inbound call flow.

1. Choose Configuration Center > Chatbot Management > Flow
Configuration > Flow > Orchestration.
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2. Click .
3. Set flow parameters. Enter a flow name, set Type to Subflow, and click Save.
4. Click the flow to expand it and click Edit. The flow editing page is displayed.
5. Click a diagram element on the canvas and create the following flow

variables on the right.
These variables are used to store the data returned by the interface in the
flow.

Figure 2-71 Configuring parameters

6. Drag diagram elements to the canvas and draw the flow as shown in the
following figure.

Figure 2-72 Drawing a flow

7. Configure nodes.
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Node Configuration

token Interface Invoking diagram element, which references the
token interface added in Step 3.
Message header:
– Set Content-Type to application/json.
– Set X-Token-Expire to 6000.
Input parameters:
– Set app_key to the AK.
– Set app_secret to the SK.
Output parameters:
– Set AccessToken to FLOW.AccessToken.

getCalledInfo Interface Invoking diagram element, which references the
getCalledInfo interface added in Step 3.
Message header:
– Set x-app-key to the value of AK.
– Set Authorization to Bearer ${FLOW.AccessToken}.
– Set Content-Type to application/json.
Input parameters:
– Set caller to ${SYS.callingNumber}.
– Set called to the system access code provided by the

mobile agent.
Output parameters:
– Set retCode to FLOW.retCode.
– Set result.devType to FLOW.devType.
– Set result.called to FLOW.called.
– Set result.skillId to FLOW.skillId.

Branch
Judgment
(left)

Branch Judgment diagram element, which is used to
determine whether an interface is successfully invoked.
If the value of FLOW.retCode is 0, the interface is
successfully invoked.

Branch
Judgment
(right)

Branch Judgment diagram element, which is used to
determine the flow direction.
– If the value of FLOW.devType is 1, the call is transferred

to the called number returned by the getCalledInfo
interface.

– If the value of FLOW.devType is 0, the call is transferred
to the skill queue specified by the call center.
NOTE

Note that the skill queue is a voice skill queue of common
agents, but not mobile agents.
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Node Configuration

Transferring
number

Call Transfer diagram element, which is used to transfer a
call to a third-party number.
Set Transfer Type to Third-party number and Route
Value to ${FLOW.called}.

Transferring
to a skill
queue

Call Transfer diagram element, which is used to transfer a
call to a skill queue.
Set Transfer Type to Skill Queue(Name) and Route Value
to an existing voice skill queue in the system.

 

8. Click  in the upper part of the canvas to save the flow.

9. Expand the new subflow, click Release, select Official Release, and click
Confirm.

Step 5 Set the called route and add the association between the flow and the system
access code.

1. Choose Configuration Center > Access Configuration > Called Party.

2. Click New to add a called route.

3. Click , select a system access code of the Audio/Video type, enter an
extension code, set Device Type to IVR, and select the flow configured in
Step 4.

4. Click Save.

----End

2.4.2 Configuring a Mobile Agent in the AICC
After a customer dials a tenant access code, the call is connected to a skill queue
or a specified number based on the mobile agent configuration.

Prerequisites

After the system administrator enables the mobile agent feature for a tenant
space, the tenant administrator can configure mobile agents.
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Procedure
Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >

Access Configuration > Mobile Agent.

Step 2 Click New. The Creating a Mobile Agent dialog box is displayed.

Step 3 Configure a mobile agent.

If you have configured a flow in "Configuring an Inbound Call Flow", set Purpose
Device Type to Numbers and select the softphone number or mobile number of a
mobile agent. When no call record of the customer is found, the call is directly
connected to the agent number configured in this step.

Figure 2-73 Creating a Mobile Agent

The parameters are described as follows:

● Called Number: Click the text box to select an access code in the dialog box
that is displayed. The access codes displayed in the dialog box are configured
on the Called Party page. For details, see the called route configuration in
"(Optional) Configuring an Inbound Call Flow."

● Purpose Device Type: Type of the device that an agent can connect to when
connecting to a call from a customer. The options are Skill Queue and
Numbers.

a. Skill Queue: Click the text box to select a skill queue in the dialog box
that is displayed. The skill queues displayed in the dialog box are of the
same type as that of the access code. For example, if the access code is of
the Audio/Video type, all available skill queues are of the same type.

b. Numbers: Click  to select a number in the dialog box that
is displayed. The numbers displayed in the dialog box are mobile agent
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softphone numbers configured by the system administrator during tenant
administrator creation.

Step 4 After adding a destination device for the VDN, click Save.

----End

2.5 Configuring Multimedia Channels
The AICC supports multiple access modes, including WeChat, web, X (Twitter),
email, WhatsApp, Facebook, LINE, and 5G RCS. Customers can access AICC
services anytime and anywhere.

After customer calls are connected, the calls are processed in a unified manner
and intelligently routed to agents. Agents do not need to pay attention to the
customer access mode.

Prerequisites
● Agents are available in a multimedia skill queue.
● You have configured a multimedia called route. For details, see 2.3.1.2

Configuring Called Routes.

2.5.1 Configuring the WeChat Channel
A tenant administrator can configure the WeChat channel for customers to access.

Prerequisites
● Prerequisites for key-based hosting

– The system administrator has uploaded the WeChat authentication
certificate on the Configuration Center > System Management >
Certificate page.

– In the test environment, you have logged in to the WeChat Official
Accounts Platform and applied for a test account access ID and secret in
advance.

i. Visit the test account website of the WeChat Official Accounts
Platform at https://mp.weixin.qq.com/debug/cgi-bin/sandboxinfo?
action=showinfo&t=sandbox/index, and use your personal WeChat
account to scan the QR code for login.

Figure 2-74 WeChat Official Accounts Platform
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ii. Obtain information about the test account.

Figure 2-75 Test account information

– In the commercial environment, you have accessed the WeChat Official
Accounts Platform and registered an official account in advance.

i. Visit the website of the WeChat Official Accounts Platform at
https://mp.weixin.qq.com/ and register a WeChat official account
by referring to the following WeChat documents. Among the
multiple WeChat official account types, you are advised to choose a
service account.

○ To register an account outside Chinese mainland, see https://
kf.qq.com/faq/220601uYfUz2220601UVJjmU.html.

ii. Log in to the WeChat official account and choose WeChat Official
Accounts Platform > Settings and Development > Basic
Configuration to obtain the AppID and AppSecret.

iii. Choose WeChat Official Accounts Platform > Settings and
Development > Basic Configuration to add the public IP address of
the AICC system in IP whitelist.
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● Prerequisites for QR code–based hosting
The enterprise official account has passed the WeChat authentication. In
addition, a third-party platform account has been created and released on the
entire network.

Context
● If the app ID and app secret provided by WeChat are changed, you need to

modify the involved WeChat channel as follows: Sign in as a tenant
administrator, choose Configuration Center > Access Configuration >
Channel Configuration, click Edit in the Operation column corresponding to
the involved channel, and update the values of App Id and App Secret.

● After enabling WeChat message encryption switch, set encodingAESKey to
the value on the WeChat Official Accounts Platform. If the value on the
WeChat Official Accounts Platform is changed, you need to change the value
on the AICC as follows:
– On the WeChat Official Accounts Platform: Log in using a developer

account, choose WeChat Official Accounts Platform > Develop > Basic
Settings, and update the value of EncodingAESKey.

– On the AICC: Sign in as a tenant administrator, choose Configuration
Center > Access Configuration > Channel Configuration, click Edit in
the Operation column corresponding to the involved channel, and
update the value of encodingAESKey.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Channel Configuration.

Step 2 Click Newly created. The Configure Channel page is displayed.

Step 3 Set channel information parameters.

Table 2-29 Channel information parameters

Parameter Description

Channel
Selection

Select WeChat.

Hosting
Method

The options are as follows:
● Key: For details about the parameters, see Table 2-30.
● QR code: For details about the operations, see Step 3.1.
Select a hosting mode based on site requirements.
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Table 2-30 Key-based hosting parameters

Parameter Description

App Id Enter the AppID and AppSecret obtained from the WeChat
Official Accounts Platform. To obtain the app ID and app
secret, see Applying for an Access ID and Secret.App Secret

Interconnectio
n Encryption
Algorithm

Encryption algorithm used for WeChat interconnection. The
options are as follows:
● SHA-1
● SHA-256
NOTE

SHA-1 is not strong enough, which poses security risks. If the platform
supports SHA-256, you are advised to use this algorithm, which is
stronger.

 

QR code–based hosting operations:

1. After setting Hosting Mode to QR code, click Scan WeChat QR Code To
Authorize. The Official Accounts Platform account authorization page
containing a QR code is displayed.

2. Use a WeChat account to log in to WeChat and scan the QR code. The system
displays a message indicating that the scanning is successful. Authorize the
account on your mobile phone.

NO TE

An official account or mini program account can be bound to only one open platform
account.

3. After the authorization, the system displays a message indicating that the
authorization is successful. The QR code–based hosting is complete. Return to
the channel configuration page to complete subsequent configurations.
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Step 4 Set basic configuration parameters.

Table 2-31 Basic configuration parameters

Parameter Description

Channel Name The channel name must be unique. The code can contain a
maximum of 64 characters, including only letters, digits, and
underscores (_), and can start only with a letter or an
underscore (_).

OU
Configuration

Select an OU created in 2.2.1 Configuring OUs to assign it to
channel resources.

Skill Queue The options are all multimedia called routes of the current
tenant space. For details about how to configure a called
route, see 2.3.1.2 Configuring Called Routes.

Keyword for
Transfer to
Agent

Keywords for switching from robot service to manual service.
After a customer enters any of the keywords on the client,
robot service is switched to manual service.
NOTE

If the intelligent robot is enabled, this parameter must be set.

Agent Work
Time

● Workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.

● Non-workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.
Non-working days are set on the Configuration Center >
Workbench Configuration > Service Time page.

Non-Working
Time
Notification

When a customer call is connected to an agent in non-working
time, this message is displayed to notify the customer that the
agent is in rest state.

More

Last Agent
Mode

For details, see 2.5.12.2 How Do I Enable the Last Agent
Mode?.

Session End
Due to No
Customer
Reply

For details, see 2.5.12.3 How Do I Set Session End Due to No
Customer Reply?.

Session
Transfer Due
to No Agent
Reply

For details, see 2.5.12.4 How Do I Set Session Transfer Due
to No Agent Reply?.

Session
Transfer

For details, see 2.5.12.5 How Do I Set Session Transfer?.
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Step 5 Set robot configuration parameters.

Table 2-32 Robot configuration parameters

Parameter Description

Connecting to
the Intelligent
Robot

For details, see 2.5.12.10 How Do I Enable Connection to the
Intelligent Robot?.

Access Robot
Assistant

For details, see 2.5.12.11 How Do I Enable Connection to the
Robot Assistant?.

 

Step 6 On the Channel Integration page, set parameters. This step is required only in
key-based hosting mode.

1. On the Channel Integration page, copy the values of URL and Verification
Code.

2. Copy the values of URL and Verification Code on the Channel Integration
page to the WeChat Official Accounts Platform.
– Test account: Go to the test page of the WeChat Official Accounts

Platform and enter the values of URL and Verification Code in the
Interface configuration information area. Click Submit to perform
token authentication.

– Official account: Choose WeChat Official Accounts Platform > Settings
and Development > Basic Configuration and enter the values of URL
and Verification Code in URL and Token in the server configuration
area.
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Customize the value of EncodingASEKey, which can be manually entered
or randomly generated and is used as the key for encrypting and
decrypting the message body. Customize the value of Message
Encryption Method.

Step 7 If the authentication is successful, the access is successful. Return to the channel
configuration page of the AICC and click Submit. The access success page is
displayed, and the WeChat channel access configuration is complete.

----End

Further Description
To set up a connection with an agent, scan the QR code of the test account and
send a message to its backend.

Follow-up Procedure
Export channel information.

NO TE

● All information under Basic Configuration and Robot Configuration can be exported.
Passwords and keys cannot be exported.

● A maximum of 100,000 channel records can be exported at a time, and a maximum of
2000 records are allowed in an exported file.

● If no channel is selected, all channel information is exported by default.

1. Return to the channel list.

2. Select the new channel and click  to export the channel information.

3. Click  and confirm that Status of the export task is Success.
4. Click Download to obtain the exported channel information.

2.5.2 Configuring the Web Channel
A tenant administrator can configure the web channel for customers to access.

Prerequisites
● This section describes only how to enable the web channel and verify the

functions. In actual scenarios, an enterprise needs to develop the client chat
page through JavaScript or API integration. For details about how an
enterprise performs integration and development, see Lightweight Web Chat
Control Integration (Token Mode) and Overview.
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● The tenant administrator has a multimedia agent that has been bound to the
tenant administrator's business account.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Channel Configuration.

Step 2 Click Newly created. The Configure Channel page is displayed.

Set Channel Access Code, select WEB, and click Next.

NO TE

The channel access code must be unique. The code can contain a maximum of 64
characters, including only letters, digits, and underscores (_), and can start only with a letter
or an underscore (_).

Step 3 Set channel information parameters.

Table 2-33 Channel information parameters

Parameter Description

Channel
Selection

Select Web.

 

Step 4 Set basic configuration parameters.

Table 2-34 WeChat channel parameters

Parameter Description

Channel Name The channel name must be unique. The code can contain a
maximum of 64 characters, including only letters, digits, and
underscores (_), and can start only with a letter or an
underscore (_).

OU
Configuration

Select an OU created in 2.2.1 Configuring OUs to assign it to
channel resources.

Skill Queue The options are all multimedia called routes of the current
tenant space. For details about how to configure a called
route, see 2.3.1.2 Configuring Called Routes.

Keyword for
Transfer to
Agent

Keywords for switching from robot service to manual service.
After a customer enters any of the keywords on the client,
robot service is switched to manual service.
NOTE

If the intelligent robot is enabled, this parameter must be set.

Click To Call For details, see 2.5.12.1 How Do I Set the Click-to-Dial
Called Route?.
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Parameter Description

Agent Work
Time

● Workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.

● Non-workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.
Non-working days are set on the Configuration Center >
Workbench Configuration > Service Time page.

Non-Working
Time
Notification

When a customer call is connected to an agent in non-working
time, this message is displayed to notify the customer that the
agent is in rest state.

Queue
reminder
interval

Customized notification interval for a customer waiting in a
queue.

Queue
reminder
content

Customized notification content for a customer waiting in a
queue.

More

Last Agent
Mode

For details, see 2.5.12.2 How Do I Enable the Last Agent
Mode?.

Session End
Due to No
Customer
Reply

For details, see 2.5.12.3 How Do I Set Session End Due to No
Customer Reply?.

Session
Transfer Due
to No Agent
Reply

For details, see 2.5.12.4 How Do I Set Session Transfer Due
to No Agent Reply?.

Session
Transfer

For details, see 2.5.12.5 How Do I Set Session Transfer?.

Third-party
authentication
key

For details, see 2.5.12.6 How Do I Set the Third-Party
Authentication Key?.

Offline
Messages

For details, see 2.5.12.7 How Do I Enable Offline Messages?.

Message Push For details, see 2.5.12.8 How Do I Enable Message Push?.

 

Step 5 Set robot configuration parameters.
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Table 2-35 Robot configuration parameters

Parameter Description

Connecting to
the Intelligent
Robot

For details, see 2.5.12.10 How Do I Enable Connection to the
Intelligent Robot?.

Access Robot
Assistant

For details, see 2.5.12.11 How Do I Enable Connection to the
Robot Assistant?.

 

Step 6 Click The next step. The Channel Integration page is displayed.

Step 7 (Optional) Click Try. On the page that is displayed, configure customer
information to simulate the dialog window on the client. Verify that customers
can chat with agents or the robot through the current channel.

1. Click Try, and click  in the lower right corner of the page that is
displayed.

If Connecting to the Intelligent Robot is enabled, the customer is connected
to the robot by default. Otherwise, the customer is automatically connected
to an agent.

2. In the Online Customer Service dialog box, enter the chat content, click
Send, and check the reply of the robot or agent.

If the chat content entered by the customer contains keywords configured for
the robot or agent, the robot or agent identifies the keywords and replies to
the customer. If the keywords cannot be identified, the robot or agent replies,
for example, "Sorry, I cannot understand."

NO TE

When communicating with the robot, the customer can click Transfer to Agent or
enter any keyword set in the Keyword for Transfer to Agent text box to switch from
the robot to an agent. However, the customer cannot switch to the robot or an agent
when communicating with an agent.

3. Sign in as a multimedia agent and choose Online Chat Workbench.

4. (Optional) Click , then click Evaluation to comment on the current
agent, including the satisfaction rating and content evaluation, and click
Confirm to submit the evaluation.

NO TE

The customer can only evaluate the services of agents who have at least one dialog
with the customer in the web channel. During and after a dialog, the customer can
evaluate the service of the agent at any time. The last evaluation is used.

Step 8 Return to the web channel access configuration page and click Close.

----End
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Follow-up Procedure
Export channel information.

NO TE

● All information under Basic Configuration and Robot Configuration can be exported.
Passwords and keys cannot be exported.

● A maximum of 100,000 channel records can be exported at a time, and a maximum of
2000 records are allowed in an exported file.

● If no channel is selected, all channel information is exported by default.

1. Return to the channel list.

2. Select the new channel and click  to export the channel information.

3. Click  and confirm that Status of the export task is Success.
4. Click Download to obtain the exported channel information.

2.5.3 Configuring the X (Twitter) Channel
A tenant administrator can configure the X (Twitter) channel for customers to
access.

Prerequisites
NO TE

This feature is available only to regions outside the Chinese mainland.

● The system administrator has uploaded the X (Twitter) authentication
certificate on the Configuration Center > System Management >
Certificate page.

● You have obtained developer information from the X (Twitter) Developer
Platform.

a. Visit the X (Twitter) Developer Platform at https://
developer.twitter.com/en to apply for a developer account for
personalized configuration. View the account information on the page
shown in the following figure.
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b. View the API Key & Secret and Access Token & Secret parameters.

Context
● X (Twitter) allows a project to connect to multiple systems, but the AICC

requires that one X (Twitter) project connect to one channel to prevent
duplicate messages.

● If the API key, API key secret, access token, and access token secret provided
by X (Twitter) are changed on X (Twitter), you need to modify the involved X
(Twitter) channel as follows: Sign in as a tenant administrator, choose
Configuration Center > Access Configuration > Channel Configuration,
click Edit in the Operation column corresponding to the involved channel,
and update the values of API key, API key secret, Access Token, and Access
Token Secret.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Channel Configuration.

Step 2 Click Newly created. The Configure Channel page is displayed.

Step 3 Set channel information parameters.

Table 2-36 Channel information parameters

Parameter Description

Channel
Selection

Select X (Twitter).
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Parameter Description

API key Enter the information obtained from the X (Twitter) Developer
Platform.

API Key Secret

Access Token

Access Token
Secret

Dev
environment
label

Value of Dev environment label of the X (Twitter) developer
account. This parameter is mandatory.

Interconnectio
n Encryption
Algorithm

Encryption algorithm used for X (Twitter) interconnection. The
options are as follows:
● SHA-1
● SHA-256
NOTE

SHA-1 is not strong enough, which poses security risks. If the platform
supports SHA-256, you are advised to use this algorithm, which is
stronger.

 

Step 4 Set basic configuration parameters.

Table 2-37 Basic configuration parameters

Parameter Description

Channel Name The channel name must be unique. The code can contain a
maximum of 64 characters, including only letters, digits, and
underscores (_), and can start only with a letter or an
underscore (_).

OU
Configuration

Select an OU created in 2.2.1 Configuring OUs to assign it to
channel resources.

Skill Queue The options are all multimedia called routes of the current
tenant space. For details about how to configure a called
route, see 2.3.1.2 Configuring Called Routes.

Keyword for
Transfer to
Agent

Keywords for switching from robot service to manual service.
After a customer enters any of the keywords on the client,
robot service is switched to manual service.
NOTE

If the intelligent robot is enabled, this parameter must be set.
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Parameter Description

Agent Work
Time

● Workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.

● Non-workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.
Non-working days are set on the Configuration Center >
Workbench Configuration > Service Time page.

Non-Working
Time
Notification

When a customer call is connected to an agent in non-working
time, this message is displayed to notify the customer that the
agent is in rest state.

More

Last Agent
Mode

For details, see 2.5.12.2 How Do I Enable the Last Agent
Mode?.

Session End
Due to No
Customer
Reply

For details, see 2.5.12.3 How Do I Set Session End Due to No
Customer Reply?.

Session
Transfer Due
to No Agent
Reply

For details, see 2.5.12.4 How Do I Set Session Transfer Due
to No Agent Reply?.

Session
Transfer

For details, see 2.5.12.5 How Do I Set Session Transfer?.

 

Step 5 Set robot configuration parameters.

Table 2-38 Robot configuration parameters

Parameter Description

Connecting to
the Intelligent
Robot

For details, see 2.5.12.10 How Do I Enable Connection to the
Intelligent Robot?.

Access Robot
Assistant

For details, see 2.5.12.11 How Do I Enable Connection to the
Robot Assistant?.

 

Step 6 Click The next step. The Channel Integration page is displayed.
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Step 7 Visit the URL and click Submit to perform token authentication. If the token
passes the authentication, the access is successful. Return to the AICC and click
Submit. The Successful access page is displayed.

----End

Follow-up Procedure
Export channel information.

NO TE

● All information under Basic Configuration and Robot Configuration can be exported.
Passwords and keys cannot be exported.

● A maximum of 100,000 channel records can be exported at a time, and a maximum of
2000 records are allowed in an exported file.

● If no channel is selected, all channel information is exported by default.

1. Return to the channel list.

2. Select the new channel and click  to export the channel information.

3. Click  and confirm that Status of the export task is Success.
4. Click Download to obtain the exported channel information.

2.5.4 Configuring AICC Information
A tenant administrator can configure the Facebook channel for customers to
access.

Prerequisites
● The system administrator has uploaded the Facebook authentication

certificate on the Configuration Center > System Management >
Certificate page.

● You have obtained developer information from Meta for Developers.
Visit Meta for Developers at https://developers.facebook.com/ to apply for a
developer account. View the account information on the page shown in the
following figure.
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Context
● Facebook allows an application to connect to multiple systems, but the AICC

requires that one Facebook application connect to one channel to prevent
duplicate messages.

● If the app secret and token secret provided by Facebook are changed on
Facebook, you need to modify the involved Facebook channel as follows: Sign
in as a tenant administrator, choose Configuration Center > Access
Configuration > Channel Configuration, click Edit in the Operation column
corresponding to the involved channel, and update the value of App Secret.
After saving the channel configuration, click Configuration in the Operation
column corresponding to the involved channel, and update the value of
Token Secret.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Channel Configuration.

Step 2 Click Newly created. The Configure Channel page is displayed.

Step 3 Set channel information parameters.

Table 2-39 Channel information parameters

Parameter Description

Channel
Selection

Select Facebook.

App Secret App secret on Meta for Developers.

Interconnectio
n Encryption
Algorithm

Encryption algorithm used for Facebook interconnection. The
options are as follows:
● SHA-1
● SHA-256
NOTE

SHA-1 is not strong enough, which poses security risks. If the platform
supports SHA-256, you are advised to use this algorithm, which is
stronger.
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Step 4 Set basic configuration parameters.

Table 2-40 Basic configuration parameters

Parameter Description

Channel Name The channel name must be unique. The code can contain a
maximum of 64 characters, including only letters, digits, and
underscores (_), and can start only with a letter or an
underscore (_).

OU
Configuration

Select an OU created in 2.2.1 Configuring OUs to assign it to
channel resources.

Skill Queue The options are all multimedia called routes of the current
tenant space. For details about how to configure a called
route, see 2.3.1.2 Configuring Called Routes.

Keyword for
Transfer to
Agent

Keywords for switching from robot service to manual service.
After a customer enters any of the keywords on the client,
robot service is switched to manual service.
NOTE

If the intelligent robot is enabled, this parameter must be set.

Agent Work
Time

● Workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.

● Non-workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.
Non-working days are set on the Configuration Center >
Workbench Configuration > Service Time page.

Non-Working
Time
Notification

When a customer call is connected to an agent in non-working
time, this message is displayed to notify the customer that the
agent is in rest state.

More

Last Agent
Mode

For details, see 2.5.12.2 How Do I Enable the Last Agent
Mode?.

Session End
Due to No
Customer
Reply

For details, see 2.5.12.3 How Do I Set Session End Due to No
Customer Reply?.

Session
Transfer Due
to No Agent
Reply

For details, see 2.5.12.4 How Do I Set Session Transfer Due
to No Agent Reply?.

Session
Transfer

For details, see 2.5.12.5 How Do I Set Session Transfer?.
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Step 5 Set robot configuration parameters.

Table 2-41 Robot configuration parameters

Parameter Description

Connecting to
the Intelligent
Robot

For details, see 2.5.12.10 How Do I Enable Connection to the
Intelligent Robot?.

Access Robot
Assistant

For details, see 2.5.12.11 How Do I Enable Connection to the
Robot Assistant?.

 

Step 6 Click The next step and go to Meta for Developers to configure the URL and
verification code.

Step 7 Visit the URL and click Submit to perform token authentication. If the token
passes the authentication, the access is successful. Return to the AICC and click
Submit. The Successful access page is displayed.

----End

Follow-up Procedure
● The Facebook channel supports multiple Facebook home pages, and each

Facebook home page can be configured only for one Facebook channel.

a. Click Create to configure multiple home pages for the Facebook channel
so that multiple Facebook home pages can be connected to agents.

i. Page ID: home page ID on Meta for Developers

ii. TokenSecret: token secret on Meta for Developers

b. Click Save.

● Export channel information.

NO TE

● All information under Basic Configuration and Robot Configuration can be
exported. Passwords and keys cannot be exported.

● A maximum of 100,000 channel records can be exported at a time, and a
maximum of 2000 records are allowed in an exported file.

● If no channel is selected, all channel information is exported by default.

a. Return to the channel list.

b. Select the new channel and click  to export the channel information.

c. Click  and confirm that Status of the export task is Success.

d. Click Download to obtain the exported channel information.
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2.5.5 Configuring the 5G RCS Channel
A tenant administrator can configure the 5G RCS channel for customers to access.

Prerequisites
● You have obtained the authentication certificate provided by 5G RCS and

uploaded it in 2.17.6 Managing a Certificate.
● After you enter information on the chatbot service platform (CSP) portal or

provide enterprise information offline for chatbot registration, the CSP
submits an application to China Mobile. After the application is approved, the
CSP allocates the chatbot address, app ID, and app secret for enterprise
access.

Context
If the chatbot address, app ID, and app secret provided by 5G RSC are changed,
you need to modify the involved 5G RCS channel as follows: Sign in as a tenant
administrator, choose Configuration Center > Access Configuration > Channel
Configuration, click Edit in the Operation column corresponding to the involved
channel, and update the values of Chatbot Address, App Id, and App Secret.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Channel Configuration.

Step 2 Click Newly created. The Configure Channel page is displayed.

Step 3 Set channel information parameters.

Table 2-42 Channel information parameters

Parameter Description

Channel
Selection

Select 5G RCS.

Chatbot
Address

Unified service address of industry messages. The client can
display all notifications based on this address.

App ID App ID allocated by the developer market.

App Secret Password allocated by the developer market to the app access
key.

Certificate File Select the uploaded 5G certificate.

 

Step 4 Set basic configuration parameters.
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Table 2-43 Basic configuration parameters

Parameter Description

Channel Name The channel name must be unique. The code can contain a
maximum of 64 characters, including only letters, digits, and
underscores (_), and can start only with a letter or an
underscore (_).

OU
Configuration

Select an OU created in 2.2.1 Configuring OUs to assign it to
channel resources.

Skill Queue The options are all multimedia called routes of the current
tenant space. For details about how to configure a called
route, see 2.3.1.2 Configuring Called Routes.

Keyword for
Transfer to
Agent

Keywords for switching from robot service to manual service.
After a customer enters any of the keywords on the client,
robot service is switched to manual service.
NOTE

If the intelligent robot is enabled, this parameter must be set.

Agent Work
Time

● Workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.

● Non-workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.
Non-working days are set on the Configuration Center >
Workbench Configuration > Service Time page.

Non-Working
Time
Notification

When a customer call is connected to an agent in non-working
time, this message is displayed to notify the customer that the
agent is in rest state.

More

Last Agent
Mode

For details, see 2.5.12.2 How Do I Enable the Last Agent
Mode?.

Session End
Due to No
Customer
Reply

For details, see 2.5.12.3 How Do I Set Session End Due to No
Customer Reply?.

Session
Transfer Due
to No Agent
Reply

For details, see 2.5.12.4 How Do I Set Session Transfer Due
to No Agent Reply?.

Session
Transfer

For details, see 2.5.12.5 How Do I Set Session Transfer?.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 179



Parameter Description

Offline
Messages

For details, see 2.5.12.7 How Do I Enable Offline Messages?.

 

Step 5 Set robot configuration parameters.

Table 2-44 Robot configuration parameters

Parameter Description

Connecting to
the Intelligent
Robot

For details, see 2.5.12.10 How Do I Enable Connection to the
Intelligent Robot?.

Access Robot
Assistant

For details, see 2.5.12.11 How Do I Enable Connection to the
Robot Assistant?.

 

Step 6 Click The next step and go to the 5G RCS configuration page to configure the
URL.

----End

Follow-up Procedure
Export channel information.

NO TE

● All information under Basic Configuration and Robot Configuration can be exported.
Passwords and keys cannot be exported.

● A maximum of 100,000 channel records can be exported at a time, and a maximum of
2000 records are allowed in an exported file.

● If no channel is selected, all channel information is exported by default.

1. Return to the channel list.

2. Select the new channel and click  to export the channel information.

3. Click  and confirm that Status of the export task is Success.
4. Click Download to obtain the exported channel information.

2.5.6 Configuring the Email Channel
A tenant administrator can configure the email channel for customers to access.

Prerequisites
The AICC can use the SMTP and POP3 services to send and receive emails. Before
configuring the email channel, ensure that the SMTP and POP3 services are
enabled and the authorization password is correct.
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For example, perform the following setting on the official website of the mailbox
service and obtain the authentication password for configuring the connection to
the mailbox client.

Procedure

Step 1 (Optional) Obtain the certificate file of the email server and upload the certificate.

Dedicated email service providers support the secure SMTP for email sending and
POP3 for email receiving. Certificate authentication must be enabled for secure
email sending and receiving protocols. Therefore, use the secure port provided by
the email server provider for security purposes.

Obtain the certificate and upload it by referring to 2.17.6 Managing a Certificate.
Set Cert Type to CER based on the file name extension.

Step 2 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Access Configuration > Gateway Configuration, and set parameters. The status
of the configured gateways must be displayed as Connection succeeded on the
Gateway Monitoring page.

Set Protocol Type to POP3 for the email receiving gateway and SMTP for the
email sending gateway.

Step 3 Choose Configuration Center > Access Configuration > Channel Configuration.

Step 4 Click Newly created. The Configure Channel page is displayed.
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Step 5 Set channel information parameters.

Table 2-45 Channel information parameters

Parameter Description

Channel
Selection

Select Email.

Email receiving
gateway

Select a configured email receiving gateway. For details about
how to configure a gateway, see 2.11.3.2 Configuring Email
Gateways.

Email sending
gateway

Select a configured email sending gateway. For details about
how to configure a gateway, see 2.11.3.2 Configuring Email
Gateways.

Max.
Recipients

Maximum number of recipient email addresses.
If this parameter is not set, the maximum number is
determined by the tenant parameter Maximum number of
recipients forwarded by email agents.
NOTE

The sum of the values of the three parameters in the Email Address
Quantity Configuration area cannot exceed 100.

Max. Cc
Recipients

Maximum number of Cc recipient email addresses.
If this parameter is not set, the maximum number is
determined by the tenant parameter Maximum number of Cc
by email agents.

Max. Bcc
Recipients

Maximum number of Bcc recipient email addresses.
If this parameter is not set, the maximum number is
determined by the tenant parameter Maximum number of
Bcc by email agents.

Reply with
Personal Email

This function is disabled by default. If the employee account is
set to an email address, the employee account can be used to
reply to emails after this function is enabled.

Email
Signature

This function is disabled by default. For details about how to
configure an email signature, see 2.17.11 Managing Email
Signatures.

 

Step 6 Set basic configuration parameters.

Table 2-46 Basic configuration parameters

Parameter Description

Channel Name The channel name must be unique. The code can contain a
maximum of 64 characters, including only letters, digits, and
underscores (_), and can start only with a letter or an
underscore (_).
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Parameter Description

OU
Configuration

Select an OU created in 2.2.1 Configuring OUs to assign it to
channel resources.

Skill Queue The options are all multimedia called routes of the current
tenant space. For details about how to configure a called
route, see 2.3.1.2 Configuring Called Routes.

Keyword for
Transfer to
Agent

Keywords for switching from robot service to manual service.
After a customer enters any of the keywords on the client,
robot service is switched to manual service.
NOTE

If the intelligent robot is enabled, this parameter must be set.

Agent Work
Time

● Workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.

● Non-workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.
Non-working days are set on the Configuration Center >
Workbench Configuration > Service Time page.

More

Last Agent
Mode

For details, see 2.5.12.2 How Do I Enable the Last Agent
Mode?.

Session End
Due to No
Customer
Reply

For details, see 2.5.12.3 How Do I Set Session End Due to No
Customer Reply?.

Session
Transfer Due
to No Agent
Reply

For details, see 2.5.12.4 How Do I Set Session Transfer Due
to No Agent Reply?.

Session
Transfer

For details, see 2.5.12.5 How Do I Set Session Transfer?.

Offline
Messages

For details, see 2.5.12.7 How Do I Enable Offline Messages?.

Automatic
reply during
working hours

For details, see 2.5.12.9 How Do I Enable the Auto Reply and
Non-Workday Reply Functions?.

Automatic
reply during
non working
hours
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Step 7 Set robot configuration parameters.

Table 2-47 Robot configuration parameters

Parameter Description

Robot
Configuration

For details, see 2.5.12.10 How Do I Enable Connection to the
Intelligent Robot?.

 

Step 8 Click Save, and the configuration is complete.

NO TE

In addition, the system automatically creates a message route based on the selected email
receiving gateway on the Configuration Center > Access Configuration > Notification
Route page.

----End

Follow-up Procedure
Export channel information.

NO TE

● All information under Basic Configuration and Robot Configuration can be exported.
Passwords and keys cannot be exported.

● A maximum of 100,000 channel records can be exported at a time, and a maximum of
2000 records are allowed in an exported file.

● If no channel is selected, all channel information is exported by default.

1. Return to the channel list.

2. Select the new channel and click  to export the channel information.

3. Click  and confirm that Status of the export task is Success.
4. Click Download to obtain the exported channel information.

2.5.7 Configuring the LINE Channel
A tenant administrator can configure the LINE channel for customers to access.

Prerequisites
NO TE

This feature applies only to regions outside the Chinese mainland.

● The system administrator has uploaded the LINE authentication certificate on
the Configuration Center > System Management > Certificate page.

● You have applied for a LINE account (used to bind a payment method for
package purchase).
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a. Access the LINE Official Account Manager (https://manager.line.biz/)
and register a LINE business account.

b. Create an official account in the LINE Official Account Manager (https://
manager.line.biz/).
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c. Use the LINE business account to log in to the LINE Developers console
(https://developers.line.biz/console/) to create a provider.

d. Click Create a new provider to create a provider.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 186

https://developers.line.biz/console/


e. In the LINE Official Account Manager (https://manager.line.biz/), click
Settings in the upper right corner, choose Messaging API from the
navigation pane, and select the provider created in the previous step
when enabling the messaging API.

f. In the LINE Official Account Manager (https://manager.line.biz/), bind a
payment method and purchase a package.

g. On the LINE Developers console (https://developers.line.biz/en/docs/
messaging-api/generate-json-web-token/#create-an-assertion-
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signing-key), generate private.key and public.key by referring to
"Generate using browser" and save them to the local PC.

h. On the LINE Developers console (https://developers.line.biz/console/),
click Register a public key and enter the public.key value generated in
the previous step to generate a key ID.
Place the generated public.key value in the JSON structure of the private
key. The value will be used to set Assertion Signing Key when the LINE
channel is created in the AICC.
Record the values of Channel ID, Channel Secret, and Assertion Signing
Key for channel configuration in the AICC.

i. In the LINE Official Account Manager, disable Auto-response and enable
Webhooks.

j. In the LINE Official Account Manager, disable Group and multi-person
chats.
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k. Unauthenticated official accounts cannot be found. You can download
the QR code from the LINE Official Account Manager and scan the QR
code on a mobile phone to add an official account.

Context

If the channel ID, channel secret, and assertion signing key provided by LINE are
changed, you need to modify the involved LINE channel as follows: Sign in as a
tenant administrator, choose Configuration Center > Access Configuration >
Channel Configuration, click Edit in the Operation column corresponding to the
involved channel, and update the values of Channel ID, Channel secret, and
Assertion Signing Key
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Channel Configuration.

Step 2 Click Newly created. The Configure Channel page is displayed.

Step 3 Set channel information parameters.

Table 2-48 Channel information parameters

Parameter Description

Channel
Selection

Select LINE.

Channel ID Enter the ID obtained from LINE.

Channel secret Enter the secret obtained from LINE.

Assertion
Signing Key

Interconnectio
n Encryption
Algorithm

Encryption algorithm used for LINE interconnection. The
options are as follows:
● SHA256WithRSA
● SHA256WithPSS
NOTE

SHA-256 with RSA is not strong enough, which poses security risks. If
the platform supports SHA-256 with PSS, you are advised to use this
algorithm, which is stronger.

 

Step 4 Set basic configuration parameters.

Table 2-49 Basic configuration parameters

Parameter Description

Channel Name The channel name must be unique. The code can contain a
maximum of 64 characters, including only letters, digits, and
underscores (_), and can start only with a letter or an
underscore (_).

OU
Configuration

Select an OU created in 2.2.1 Configuring OUs to assign it to
channel resources.

Skill Queue The options are all multimedia called routes of the current
tenant space. For details about how to configure a called
route, see 2.3.1.2 Configuring Called Routes.
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Parameter Description

Keyword for
Transfer to
Agent

Keywords for switching from robot service to manual service.
After a customer enters any of the keywords on the client,
robot service is switched to manual service.
NOTE

If the intelligent robot is enabled, this parameter must be set.

Agent Work
Time

● Workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.

● Non-workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.
Non-working days are set on the Configuration Center >
Workbench Configuration > Service Time page.

Non-Working
Time
Notification

When a customer call is connected to an agent in non-working
time, this message is displayed to notify the customer that the
agent is in rest state.

More

Last Agent
Mode

For details, see 2.5.12.2 How Do I Enable the Last Agent
Mode?.

Session End
Due to No
Customer
Reply

For details, see 2.5.12.3 How Do I Set Session End Due to No
Customer Reply?.

Session
Transfer Due
to No Agent
Reply

For details, see 2.5.12.4 How Do I Set Session Transfer Due
to No Agent Reply?.

Session
Transfer

For details, see 2.5.12.5 How Do I Set Session Transfer?.

 

Step 5 Set robot configuration parameters.

Table 2-50 Robot configuration parameters

Parameter Description

Connecting to
the Intelligent
Robot

For details, see 2.5.12.10 How Do I Enable Connection to the
Intelligent Robot?.

Access Robot
Assistant

For details, see 2.5.12.11 How Do I Enable Connection to the
Robot Assistant?.

 

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 191



Step 6 Click The next step. The Channel Integration page is displayed.

Step 7 Configure the Webhook URL in LINE.

After the LINE channel is created on the channel configuration page in the AICC,
the Webhook URL can be obtained. In the LINE Official Account Manager
(https://manager.line.biz/), select the official account to be configured, click
Settings in the upper right corner, choose Messaging API from the navigation
pane, and set Webhook URL.

----End

Follow-up Procedure

Export channel information.

NO TE

● All information under Basic Configuration and Robot Configuration can be exported.
Passwords and keys cannot be exported.

● A maximum of 100,000 channel records can be exported at a time, and a maximum of
2000 records are allowed in an exported file.

● If no channel is selected, all channel information is exported by default.

1. Return to the channel list.

2. Select the new channel and click  to export the channel information.

3. Click  and confirm that Status of the export task is Success.

4. Click Download to obtain the exported channel information.

2.5.8 Configuring the WhatsApp Channel
A tenant administrator can configure the WhatsApp channel for customers to
access.
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Prerequisites
NO TE

This feature applies only to regions outside the Chinese mainland.

You have obtained the following information from the WhatsApp service path
supplier:

● infobip

– Phone number for registering a WhatsApp service path provider user

– Username for registering with the WhatsApp service path provider

– Password for registering with the WhatsApp service path provider

– API URL prefix provided by the WhatsApp service path provider. An
application has been submitted to the system administrator and
approved to add the API URL prefix to the address trustlist.

This information corresponds to the value of BaseUrl in the AICC.

– Account key provided by the WhatsApp service path provider for
authentication

– Webhook password, which is the authentication password for the channel
to receive messages. The webhook password is customized by channel
configuration personnel. After the channel is configured, you need to
notify Infobip of the webhook password, which corresponds to the
account key of the webhook API in Infobip.

– Authentication certificate. To obtain the authentication certificate,
perform the following steps:

i. Visit the following website:

○ https://api.infobip.com/

○ API URL prefix provided by Infobip, for example, https://***.api-
us.infobip.com/

ii. Export a certificate from the browser. The following describes how to
export a certificate from https://api.infobip.com/.

1) Click  in the address box. The following information is
displayed.

2) Choose Connection is secure > Certificate is valid to view
certificate information.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 193

https://api.infobip.com/
https://api.infobip.com/


3) Click Export and select a local path to save the certificate.

Customize the value of File name and set Save as type to DER-
encoded binary, single certificate.

4) Click Save to export the certificate to the local PC.
iii. Repeat the preceding operations to export a certificate from https://

***.api-us.infobip.com/.
iv. Combine the two certificates into a JKS certificate. You can use the

certificate combination tool Portecle to combine the certificates.
Download URL: https://sourceforge.net/projects/portecle/
Procedure: The Java running environment must be available.

1) Open the CLI and go to the directory where portecle.jar is
stored.

2) Run the java -jar portecle.jar command to run Portecle.
3) Choose File > New Keystory Type, select JKS, and click OK.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 194

https://sourceforge.net/projects/portecle/


4) Click  and upload an obtained browser certificate to
Portecle.
You need to run the command twice.

5) Click , enter a new certificate password, and click OK.
6) Enter a new certificate name, which is customized, and click

Save.
v. Upload the authentication certificate by referring to 2.17.6

Managing a Certificate.
● other: The customer implements the BSP to connect to WhatsApp. The

current version supports only ITAU.

NO TE

When WhatsApp Business Solution Provider is set to other, the options of
Verification Method are as follows:

● basic: direct authentication of the WhatsApp service path provider

● oAuth: authentication of the WhatsApp service path provider using an API

The information to be obtained varies according to the value of Verification Method.

– Phone number for registering a WhatsApp service path provider user
This item is not required when Verification Method is set to oAuth.

– Username for registering with the WhatsApp service path provider
When Verification Method is set to oAuth, you need to contact the
system administrator to obtain the app key of the app that has
subscribed to the sendWhatsappMessage API and bound to the tenant
space for which the WhatsApp channel needs to be configured on the
Configuration Center > Expansion and Integration > API Management
> APP Service > APP Management page, and enter the app key in the
UserName text box.

– Password for registering with the WhatsApp service path provider
When Verification Method is set to oAuth, you need to contact the
system administrator to obtain the app secret of the app that has
subscribed to the sendWhatsappMessage API and bound to the tenant
space for which the WhatsApp channel needs to be configured on the
Configuration Center > Expansion and Integration > API Management
> APP Service > APP Management page, and enter the app secret in the
Password text box.

– API URL prefix provided by the WhatsApp service path provider
When Verification Method is set to oAuth, the API URL prefix must be
https://IP address:Port number/apiaccess/rest/ccmessaging, where IP
address:Port number indicates the IP address and port number for signing
in to the AICC and can be replaced with a domain name.

– Authentication key provided by the WhatsApp service path provider
This item is not required when Verification Method is set to oAuth.

– Authentication password for the channel to receive messages
– Trust certificate provided by the WhatsApp service path provider. You

have uploaded it by referring to 2.17.6 Managing a Certificate.
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– Identity certificate of the current system. You have uploaded it by
referring to 2.17.6 Managing a Certificate.
This item is not required when Verification Method is set to oAuth.

● cloud-api: Currently, this function can only be demonstrated and cannot be
put into commercial use.
– Information about the app created on Meta for Developers

i. Log in to Facebook using a Meta for Developers account and access
https://developers.facebook.com/apps to create an app.
Click Other, select the Business type, customize the app name, and
retain other default settings.

ii. Return to https://developers.facebook.com/apps, find the new app,
copy the app ID, access https://developers.facebook.com/apps/App
ID/settings/basic, and view the app information.

Figure 2-76 Obtaining app information

The app ID corresponds to the value of APP Key in the channel
configuration in the AICC.
The app secret corresponds to the value of APP Secret in the channel
configuration in the AICC.

iii. Add the WhatsApp product to the app.

Figure 2-77 Adding the product

iv. Choose WhatsApp > Quickstart to configure the quick start.
If the advertisement placement function is disabled for the Facebook
account, you need to apply for enabling the function.

v. Choose WhatsApp > API Setup and obtain the phone number and
base URL.

○ The test number corresponds to the value of Phone Number in
the AICC.

○ The URL in the red box corresponds to the value of BaseUrl in
the AICC.

○ The recipient number is the mobile number of an object served
through the WhatsApp channel and is a mobile number. The
recipient number needs to be manually added so that the
customer can access the WhatsApp channel.
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Figure 2-78 Obtaining the phone number and base URL

vi. Access https://business.facebook.com/settings/system-users, select
the business of the app, choose Users > System users, and add an
administrator.
Customize System user name and set System user role to
Employee.

Figure 2-79 Adding an administrator

vii. Add assets and generate a new token.
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Figure 2-80 Adding assets

Figure 2-81 Generating a new token

The generated token must have the whatsapp_business_messaging
and whatsapp_business_management permissions.
The generated token corresponds to the value of access token in the
channel configuration in the AICC.
When generating the token, you need to select a validity period,
which corresponds to the token validity period in the AICC.

– Trust certificate. You have uploaded it by referring to 2.17.6 Managing a
Certificate.

▪ In China: Direct access to https://graph.facebook.com/v8.0 is
restricted. You need to configure a proxy server and obtain the trust
certificate of the proxy server. The certificate must be in .der format.

▪ Outside China: Access https://graph.facebook.com/v8.0 and export
the certificate using a browser. The certificate must be in .der format.

– Identity certificate of the current system. You have uploaded it by
referring to 2.17.6 Managing a Certificate.
Access the current system and export the certificate using a browser.

● Twilio:
– Phone number for registering a WhatsApp service provider user
– API Key SID for registering a WhatsApp service provider
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– API Key Secret for registering a WhatsApp service provider
– API URL prefix provided by the WhatsApp service provider. An application

has been submitted to the system administrator and approved to add the
API URL prefix to the address trustlist.
This information corresponds to the value of BaseUrl in the AICC, for
example, https://api.twilio.com/2010-04-01.

– Account SID provided by the WhatsApp service provider for
authentication

– Webhook user, which is the authenticated user for the channel to receive
messages. The webhook user is customized by channel configuration
personnel. After the channel is configured, you need to notify Twilio of
the webhook user, which corresponds to the username of the webhook
API in Twilio.

– Webhook password, which is the authentication password for the channel
to receive messages. The webhook password is customized by channel
configuration personnel. After the channel is configured, you need to
notify Twilio of the webhook password, which corresponds to the
password of the webhook API in Twilio.

– Authentication certificate. To obtain the authentication certificate,
perform the following steps:

i. Visit the following website:
○ https://api.twilio.com/

ii. Export a certificate from the browser. The following describes how to
export a certificate from https://api.twilio.com/.

1) Click  in the address box. The following information is
displayed.

2) Choose Connection is secure > Certificate is valid to view
certificate information.
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3) Click Export and select a local path to save the certificate.
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Customize the value of File name and set Save as type to DER-
encoded binary, single certificate.

4) Click Save to export the certificate to the local PC.
iii. Upload the authentication certificate by referring to 2.17.6

Managing a Certificate.
Access the current system and export the certificate using a browser.

Context
If the information provided by the WhatsApp service path provider is changed, you
need to modify the involved WhatsApp channel as follows: Sign in as a tenant
administrator, choose Configuration Center > Access Configuration > Channel
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Configuration, click Edit in the Operation column corresponding to the involved
channel, and update the values of UserName, Password, BaseUrl, and
AccountKey.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Channel Configuration.

Step 2 Click Newly created. The Configure Channel page is displayed.

Step 3 Set channel information parameters.

Table 2-51 Channel information parameters

Parameter Description

Channel
Selection

Select WhatsApp.

Business
Solution
Provider

The options are as follows:
● infobip
● other
● cloud-api
● twilio

 

Set other parameters based on the information obtained in Prerequisites.

Step 4 Set basic configuration parameters.

Table 2-52 Basic configuration parameters

Parameter Description

Channel Name The channel name must be unique. The code can contain a
maximum of 64 characters, including only letters, digits, and
underscores (_), and can start only with a letter or an
underscore (_).

OU
Configuration

Select an OU created in 2.2.1 Configuring OUs to assign it to
channel resources.

Skill Queue The options are all multimedia called routes of the current
tenant space. For details about how to configure a called
route, see 2.3.1.2 Configuring Called Routes.

Keyword for
Transfer to
Agent

Keywords for switching from robot service to manual service.
After a customer enters any of the keywords on the client,
robot service is switched to manual service.
NOTE

If the intelligent robot is enabled, this parameter must be set.
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Parameter Description

Agent Work
Time

● Workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.

● Non-workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.
Non-working days are set on the Configuration Center >
Workbench Configuration > Service Time page.

Non-Working
Time
Notification

When a customer call is connected to an agent in non-working
time, this message is displayed to notify the customer that the
agent is in rest state.

More

Last Agent
Mode

For details, see 2.5.12.2 How Do I Enable the Last Agent
Mode?.

Session End
Due to No
Customer
Reply

For details, see 2.5.12.3 How Do I Set Session End Due to No
Customer Reply?.

Session
Transfer Due
to No Agent
Reply

For details, see 2.5.12.4 How Do I Set Session Transfer Due
to No Agent Reply?.

Session
Transfer

For details, see 2.5.12.5 How Do I Set Session Transfer?.

Offline
Messages

For details, see 2.5.12.7 How Do I Enable Offline Messages?.

 

Step 5 Set robot configuration parameters.

Table 2-53 Robot configuration parameters

Parameter Description

Connecting to
the Intelligent
Robot

For details, see 2.5.12.10 How Do I Enable Connection to the
Intelligent Robot?.

Access Robot
Assistant

For details, see 2.5.12.11 How Do I Enable Connection to the
Robot Assistant?.

 

Step 6 Click The next step. The Channel Integration page is displayed.
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● If the WhatsApp service provider is infobip, the following page is displayed.

Obtain the values of url used to send message to agent and url used to
send report to agent generated on the Channel Integration page and notify
Infobip of them offline.

● If the WhatsApp service provider is other, the following page is displayed.

Obtain the values of url used to send message to agent and url used to
send report to agent generated on the Channel Integration page and notify
the WhatsApp service provider of them offline.

● If the WhatsApp service provider is cloud-api, the following page is displayed.

Obtain the values of URL and Verification Code and configure them at
https://developers.facebook.com/apps/App ID/webhooks.

● If the WhatsApp service provider is Twilio, the following page is displayed.

Obtain the values of url used to send message to agent and url used to
send report to agent generated on the Channel Integration page and notify
the WhatsApp service provider of them offline.

Step 7 If scenario key:NO is displayed, click Generate.

Skip this step if the WhatsApp service provider is cloud-api.

----End

Follow-up Procedure

Export channel information.
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NO TE

● All information under Basic Configuration and Robot Configuration can be exported.
Passwords and keys cannot be exported.

● A maximum of 100,000 channel records can be exported at a time, and a maximum of
2000 records are allowed in an exported file.

● If no channel is selected, all channel information is exported by default.

1. Return to the channel list.

2. Select the new channel and click  to export the channel information.

3. Click  and confirm that Status of the export task is Success.
4. Click Download to obtain the exported channel information.

2.5.9 Configuring the SMS Channel
A tenant administrator can configure the SMS channel for customers to access.

Prerequisites
The AICC can use the SMPP service to send and receive SMS messages. Before
configuring the SMS channel, ensure that the SMPP service is enabled. For details,
see 2.11.3.1 Configuring SMS Gateways.

Procedure

Step 1 (Optional) Obtain the certificate file of the SMS server and upload the certificate.

Dedicated SMS service providers support the secure SMPP protocol and require
certificate authentication. Therefore, to ensure system security, use the secure port
provided by the SMS server provider.

Obtain the certificate and upload it by referring to 2.17.6 Managing a Certificate.
Set Cert Type to CER based on the file name extension.

Step 2 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Access Configuration > Gateway Configuration, and set parameters. The status
of the configured gateways must be displayed as Connection succeeded on the
Gateway Monitoring page.

The protocol type for SMS gateways is smpp.

Step 3 Choose Configuration Center > Access Configuration > Channel Configuration.

Step 4 Click Newly created. The Configure Channel page is displayed.

Step 5 Set channel information parameters.
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Table 2-54 Channel information parameters

Parameter Description

Channel
Selection

Select SMS.

SMS gateway Select a configured SMS receiving gateway. For details about
how to configure a gateway, see 2.11.3.1 Configuring SMS
Gateways.

 

Step 6 Set basic configuration parameters.

Table 2-55 Basic configuration parameters

Parameter Description

Channel Name The channel name must be unique. The code can contain a
maximum of 64 characters, including only letters, digits, and
underscores (_), and can start only with a letter or an
underscore (_).

OU
Configuration

Select an OU created in 2.2.1 Configuring OUs to assign it to
channel resources.

Skill Queue The options are all multimedia called routes of the current
tenant space. For details about how to configure a called
route, see 2.3.1.2 Configuring Called Routes.

Keyword for
Transfer to
Agent

Keywords for switching from robot service to manual service.
After a customer enters any of the keywords on the client,
robot service is switched to manual service.
NOTE

If the intelligent robot is enabled, this parameter must be set.

Agent Work
Time

● Workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.

● Non-workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.
Non-working days are set on the Configuration Center >
Workbench Configuration > Service Time page.

More

Last Agent
Mode

For details, see 2.5.12.2 How Do I Enable the Last Agent
Mode?.
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Parameter Description

Session End
Due to No
Customer
Reply

For details, see 2.5.12.3 How Do I Set Session End Due to No
Customer Reply?.

Session
Transfer Due
to No Agent
Reply

For details, see 2.5.12.4 How Do I Set Session Transfer Due
to No Agent Reply?.

Session
Transfer

For details, see 2.5.12.5 How Do I Set Session Transfer?.

Offline
Messages

For details, see 2.5.12.7 How Do I Enable Offline Messages?.

Auto Reply For details, see 2.5.12.9 How Do I Enable the Auto Reply and
Non-Workday Reply Functions?.

Non-Working
Day Reply

 

Step 7 Set robot configuration parameters.

Table 2-56 Robot configuration parameters

Parameter Description

Robot
Configuration

For details, see 2.5.12.10 How Do I Enable Connection to the
Intelligent Robot?.

 

Step 8 Click Saved. A message is displayed, indicating that the saving is successful.

NO TE

In addition, the system automatically creates a message route based on the selected SMS
gateway on the Configuration Center > Access Configuration > Notification Route page.
The message route record changes with the SMS gateway in the channel configuration.
When the channel is deleted, the message route record is also deleted.

----End

Follow-up Procedure
Export channel information.

NO TE

● All information under Basic Configuration and Robot Configuration can be exported.
Passwords and keys cannot be exported.

● A maximum of 100,000 channel records can be exported at a time, and a maximum of
2000 records are allowed in an exported file.

● If no channel is selected, all channel information is exported by default.
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1. Return to the channel list.

2. Select the new channel and click  to export the channel information.

3. Click  and confirm that Status of the export task is Success.
4. Click Download to obtain the exported channel information.

2.5.10 Configuring the Instagram Channel

2.5.10.1 Configuring Instagram Information
This section describes Instagram-related configurations and applications to enable
Instagram customers to chat with AICC agents online. If some pages or
configurations on Instagram are different from those described in this section, the
pages or configurations on Instagram prevail.

Prerequisites
None

Procedure

Step 1 Sign up for an Instagram personal account.

Sign-up address: https://www.instagram.com/
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Step 2 Sign up for a Facebook personal account.

Sign-up address: https://www.facebook.com/
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Step 3 Log in to Meta for Developers and apply for a Meta for Developers account.

1. Use the personal account to log in to Meta for Developers at https://
developers.facebook.com/.

2. Click Get Started in the upper right corner.

3. Create a Meta for Developers account as prompted.
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4. Verify the account. If the account has been verified during registration, skip
this step.

5. Check the email information.

6. Select Developer and click Complete Registration.

7. On the app creation page that is displayed, click Create App.

8. Select Business and click Next.
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9. Create an app.
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10. On the page that is displayed, select Messenger and Webhooks.

11. In the navigation pane, choose Messenger > Settings, and click Create new
Page.

12. Create a public home page. Set the name and category of the public home
page and click Create Page.
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You can skip the step for binding the public home page to WhatsApp.
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13. After the home page is created, click the avatar in the upper right corner to
switch to the home page.

14. Select Settings & privacy > Settings.
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15. Click Linked Accounts and bind the home page to your Instagram account.

16. Return to the Messenger page, choose Instagram settings, and click Add or
remove Pages.
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Click Continue as ***.
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17. Select the home page to be added and click Continue.

Step 4 Subscribe to Webhooks.

1. Return to the Messenger page, choose Instagram settings > Webhooks >
Edit Subscriptions.

2. Select the following options:
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3. Click Save.

Step 5 Generate a token.

1. Click Generate token on the added home page.

2. Record the generated token, which will be used in subsequent operations.
Then, click Done.

----End

2.5.10.2 Configuring AICC Information
A tenant administrator can configure the Instagram channel for customers to
access.

Prerequisites
● You have contacted the system administrator to obtain the app key and app

secret of the app that has subscribed to the instagram_north - v1.0.0,
ccmessage_north - v1.0.0, and file_donload_get-v1.0.0-manual - v1.0.0 APIs
and bound to the tenant space for which the Instagram channel needs to be
configured on the Configuration Center > Expansion and Integration > API
Management > APP Service > APP Management page.

● You have contacted the system administrator to set ApiFabric interface
Address to the IP address and port number of the API Fabric under
Configuration Center > System Management > System Parameter >
System parameters > Service Channels > Common. The format must be IP
address:Port number.

● You have submitted an application to the system administrator to add the IP
address and port number for logging in to the system frontend to the address
trustlist. The value must start with https://, for example, https://*.*.*.*:28090.
A domain name is not supported for this channel.

● You have obtained the authentication certificate provided by the API Fabric
and the identity certificate of the current system, and have uploaded them by
referring to 2.17.6 Managing a Certificate. To obtain the authentication
certificate, perform the following steps:

a. Contact O&M personnel to log in to the system backend and run the
following command on the active container node to generate a
certificate:
openssl s_client -showcerts -connect IP:28090 </dev/null 2>/dev/null|openssl x509 -outform 
PEM >mycertfile.pem

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 219



Set IP to the IP address for logging in to the system frontend or the IP
address of the server where the NSLB is located.

b. Convert the certificate format to obtain the authentication certificate.
openssl x509 -in mycertfile.pem -outform der -out mycert.cer

Context
If the app ID and app secret provided by the API Fabric are changed, you need to
modify the involved Instagram channel as follows: Sign in as a tenant
administrator, choose Configuration Center > Access Configuration > Channel
Configuration, click Edit in the Operation column corresponding to the involved
channel, and update the values of APP Key and APP Secret.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Channel Configuration.

Step 2 Click Newly created. The Configure Channel page is displayed.

Step 3 Set channel information parameters.

Table 2-57 Channel information parameters

Parameter Description

Channel
Selection

Select Instagram.

APP Key App ID information obtained from the API Fabric, which is the
AK.

APP Secret App secret information obtained from the API Fabric, which is
the SK.

BaseUrl IP address and port number for logging in to the system
frontend. The value must start with https://, for example,
https://*.*.*.*:28090. A domain name is not supported.

Trust
certificate

Authentication certificate of the API Fabric, which has been
uploaded in 2.17.6 Managing a Certificate.

Identity
certificate

Identity certificate of the current system, which has been
uploaded in 2.17.6 Managing a Certificate.

 

Step 4 Set basic configuration parameters.
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Table 2-58 Basic configuration parameters

Parameter Description

Channel Name The channel name must be unique. The code can contain a
maximum of 64 characters, including only letters, digits, and
underscores (_), and can start only with a letter or an
underscore (_).

OU
Configuration

Select an OU created in 2.2.1 Configuring OUs to assign it to
channel resources.

Skill Queue The options are all multimedia called routes of the current
tenant space. For details about how to configure a called
route, see 2.3.1.2 Configuring Called Routes.

Keyword for
Transfer to
Agent

Keywords for switching from robot service to manual service.
After a customer enters any of the keywords on the client,
robot service is switched to manual service.
NOTE

If the intelligent robot is enabled, this parameter must be set.

Agent Work
Time

● Workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.

● Non-workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.
Non-working days are set on the Configuration Center >
Workbench Configuration > Service Time page.

Non-Working
Time
Notification

When a customer call is connected to an agent in non-working
time, this message is displayed to notify the customer that the
agent is in rest state.

More

Last Agent
Mode

For details, see 2.5.12.2 How Do I Enable the Last Agent
Mode?.

Session End
Due to No
Customer
Reply

For details, see 2.5.12.3 How Do I Set Session End Due to No
Customer Reply?.

Session
Transfer Due
to No Agent
Reply

For details, see 2.5.12.4 How Do I Set Session Transfer Due
to No Agent Reply?.

Session
Transfer

For details, see 2.5.12.5 How Do I Set Session Transfer?.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 221



Parameter Description

Offline
Messages

For details, see 2.5.12.7 How Do I Enable Offline Messages?.

 

Step 5 Set robot configuration parameters.

Table 2-59 Robot configuration parameters

Parameter Description

Connecting to
the Intelligent
Robot

For details, see 2.5.12.10 How Do I Enable Connection to the
Intelligent Robot?.

Access Robot
Assistant

For details, see 2.5.12.11 How Do I Enable Connection to the
Robot Assistant?.

 

Step 6 Click The next step. The Channel Integration page is displayed.

Step 7 Configure the Webhook URL in Instagram.

After the Instagram channel is created on the channel configuration page, the
Webhook URL can be obtained. In Meta for Developers, set Callback URL to the
IP address of the API Fabric and the Webhook URL.

----End

Follow-up Procedure
Export channel information.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 222



NO TE

● All information under Basic Configuration and Robot Configuration can be exported.
Passwords and keys cannot be exported.

● A maximum of 100,000 channel records can be exported at a time, and a maximum of
2000 records are allowed in an exported file.

● If no channel is selected, all channel information is exported by default.

1. Return to the channel list.

2. Select the new channel and click  to export the channel information.

3. Click  and confirm that Status of the export task is Success.
4. Click Download to obtain the exported channel information.

2.5.11 Configuring the Telegram Channel

2.5.11.1 Configuring Telegram Information
This section describes Telegram-related configurations and applications to enable
Telegram customers to chat with AICC agents online. If some pages or
configurations on Telegram are different from those described in this section, the
pages or configurations on Telegram prevail.

Prerequisites
None

Procedure

Step 1 Sign up for a Telegram account. You can also install Telegram on your mobile
phone to sign up.

Sign-up address: https://www.telegram.com/
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Step 2 Create a Telegram chatbot.

1. Log in to the Telegram client using the registered account.
– To log in to the Telegram web client, visit https://web.telegram.org.
– To log in to the Telegram mobile client, download the app at https://

telegram.org first.
2. Search for @BotFather and add it as a contact.
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3. Click BotFather, send the /newbot command, send a chatbot name and
username, and save the generated token.
– The name is customized, for example, AICCCustomize_bot.
– The username is customized and ends with bot, for example,

AICCCustomize_TWbot.
– The token is automatically generated by the system and displayed on the

page, for example, 582***********4Qs. Save it for subsequent configuration.
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----End

2.5.11.2 Configuring AICC Information
A tenant administrator can configure the Telegram channel for customers to
access.

Prerequisites
● You have contacted the system administrator to obtain the app key and app

secret of the app that has subscribed to the
ccmessage_telegram_north_v1.0.0, telegram_north_v1.0.0, and
file_donload_get-v1.0.0-manual - v1.0.0 APIs and bound to the tenant space
for which the Telegram channel needs to be configured on the Configuration
Center > Expansion and Integration > API Management > APP Service >
APP Management page.

● You have contacted the system administrator to set ApiFabric interface
Address to the IP address and port number of the API Fabric under
Configuration Center > System Management > System Parameter >
System parameters > Service Channels > Common. The format must be IP
address:Port number.

● You have submitted an application to the system administrator to add the IP
address and port number for logging in to the system frontend to the address
trustlist. The value must start with https://, for example, https://*.*.*.*:28090.
A domain name is not supported for this channel.
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● You have obtained the authentication certificate provided by the API Fabric
and the identity certificate of the current system, and have uploaded them by
referring to 2.17.6 Managing a Certificate. To obtain the authentication
certificate, perform the following steps:

a. Contact O&M personnel to log in to the system backend and run the
following command on the active container node to generate a
certificate:
openssl s_client -showcerts -connect IP:28090 </dev/null 2>/dev/null|openssl x509 -outform 
PEM >mycertfile.pem

Set IP to the IP address for logging in to the system frontend or the IP
address of the server where the NSLB is located.

b. Convert the certificate format to obtain the authentication certificate.
openssl x509 -in mycertfile.pem -outform der -out mycert.cer

● You have installed the Telegram software.

Context
If the app ID and app secret provided by the API Fabric are changed, you need to
modify the involved Telegram channel as follows: Sign in as a tenant
administrator, choose Configuration Center > Access Configuration > Channel
Configuration, click Edit in the Operation column corresponding to the involved
channel, and update the values of APP Key and APP Secret.

Procedure
Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >

Access Configuration > Channel Configuration.

Step 2 Click Newly created. The Configure Channel page is displayed.

Step 3 Set channel information parameters.

Table 2-60 Channel information parameters

Parameter Description

Channel
Selection

Select Telegram.

APP Key App ID information obtained from the API Fabric, which is the
AK.

APP Secret App secret information obtained from the API Fabric, which is
the SK.

BaseUrl IP address and port number for logging in to the system
frontend. The value must start with https://, for example,
https://*.*.*.*:28090. A domain name is not supported.

Trust
certificate

Authentication certificate of the API Fabric, which has been
uploaded in 2.17.6 Managing a Certificate.

Identity
certificate

Identity certificate of the current system, which has been
uploaded in 2.17.6 Managing a Certificate.
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Step 4 Set basic configuration parameters.

Table 2-61 Basic configuration parameters

Parameter Description

Channel Name The channel name must be unique. The code can contain a
maximum of 64 characters, including only letters, digits, and
underscores (_), and can start only with a letter or an
underscore (_).

OU
Configuration

Select an OU created in 2.2.1 Configuring OUs to assign it to
channel resources.

Skill Queue The options are all multimedia called routes of the current
tenant space. For details about how to configure a called
route, see 2.3.1.2 Configuring Called Routes.

Keyword for
Transfer to
Agent

Keywords for switching from robot service to manual service.
After a customer enters any of the keywords on the client,
robot service is switched to manual service.
NOTE

If the intelligent robot is enabled, this parameter must be set.

Agent Work
Time

● Workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.

● Non-workday: A maximum of four working time segments
(from 00:00 to 24:00) can be configured. By default, a time
segment is displayed. You can click New to add a time
segment.
Non-working days are set on the Configuration Center >
Workbench Configuration > Service Time page.

Non-Working
Time
Notification

When a customer call is connected to an agent in non-working
time, this message is displayed to notify the customer that the
agent is in rest state.

More

Last Agent
Mode

For details, see 2.5.12.2 How Do I Enable the Last Agent
Mode?.

Session End
Due to No
Customer
Reply

For details, see 2.5.12.3 How Do I Set Session End Due to No
Customer Reply?.

Session
Transfer Due
to No Agent
Reply

For details, see 2.5.12.4 How Do I Set Session Transfer Due
to No Agent Reply?.

Session
Transfer

For details, see 2.5.12.5 How Do I Set Session Transfer?.
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Parameter Description

Offline
Messages

For details, see 2.5.12.7 How Do I Enable Offline Messages?.

 

Step 5 Set robot configuration parameters.

Table 2-62 Robot configuration parameters

Parameter Description

Connecting to
the Intelligent
Robot

For details, see 2.5.12.10 How Do I Enable Connection to the
Intelligent Robot?.

Access Robot
Assistant

For details, see 2.5.12.11 How Do I Enable Connection to the
Robot Assistant?.

 

Step 6 Click The next step. The Channel Integration page is displayed.

View and copy the value of url used to send message to agent to the local PC.

Step 7 Use the Telegram software to generate a token.

1. Use any account to log in to Telegram.
2. Search for @BotFather and add it as a contact.

3. Send the /newbot command.
4. Send the robot name AICCCustomize_TWbot.

The value must end with bot.
5. Save the generated token.
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Step 8 Set the callback URL for message forwarding.

Invoke the https://api.telegram.org/botToken/setWebhook API.

Token: Enter the token generated in Step 7.

Request parameter: Enter the value of url used to send message to agent
obtained in Step 6.

----End

Follow-up Procedure

Export channel information.

NO TE

● All information under Basic Configuration and Robot Configuration can be exported.
Passwords and keys cannot be exported.

● A maximum of 100,000 channel records can be exported at a time, and a maximum of
2000 records are allowed in an exported file.

● If no channel is selected, all channel information is exported by default.

1. Return to the channel list.

2. Select the new channel and click  to export the channel information.

3. Click  and confirm that Status of the export task is Success.

4. Click Download to obtain the exported channel information.

2.5.12 FAQ
This section describes the common problems that may occur during channel
configuration.

2.5.12.1 How Do I Set the Click-to-Dial Called Route?

After Click To Call is enabled, a customer can initiate a voice or video call during
a text chat with an agent.

Prerequisites

A click-to-dial called route has been configured.
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Procedure

Step 1 Click  to enable Click To Call.

Step 2 Set CTD Called Party Configuration. The options are as follows:

● Audio and video agent

● IVR

Step 3 Select a configured called route.

Step 4 Click The next step to complete the configuration.

----End

2.5.12.2 How Do I Enable the Last Agent Mode?

After Last Agent Mode is enabled, when a customer is connected to an agent
through a channel, the session is preferentially assigned to the agent who chats
with the customer last time.

Procedure

Step 1 Click  to enable Last Agent Mode.

Step 2 Select a mode for filtering last agents and set the corresponding parameter.

● Time range: an integer ranging from 1 to 168, in hours

● Current day: 00:00 on the current day to the current time

Step 3 Click The next step or Saved to complete the configuration.

----End

2.5.12.3 How Do I Set Session End Due to No Customer Reply?

After Session End Due to No Customer Reply is enabled, the timeout period for
no customer reply and session end message can be customized.

Context

You do not need to set the session end message (Conclusion) for the email and
SMS channels.

Procedure

Step 1 Click  to enable Session End Due to No Customer Reply.

Step 2 Set Customer Reply Timeout Period and Conclusion.

● Customer Reply Timeout Period: The value ranges from 1 to 60, in minutes.

The default value is 60 for the email channel and 20 for other channels.
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NO TE

The period specified by Customer Reply Timeout Period must be longer than that
specified by Max. Waiting Time (s) of the multimedia skill queue.

● Conclusion: The value can contain a maximum of 256 characters.

Step 3 Click The next step or Saved to complete the configuration.

----End

2.5.12.4 How Do I Set Session Transfer Due to No Agent Reply?

After Session Transfer Due to No Agent Reply is enabled, the timeout period for
session transfer due to no agent reply and prompt message for agent
reassignment can be customized.

Procedure

Step 1 Click  to enable Session Transfer Due to No Agent Reply.

Step 2 Set Agent Reply Timeout Period and Prompt for Agent Reassignment.
● Agent Reply Timeout Period: The value is an integer ranging from 1 to 5 and

must be less than or equal to that of Customer Reply Timeout Period.
● Prompt for Agent Reassignment: The value can contain a maximum of 256

characters.

NO TE

You do not need to set this parameter for the email and SMS channels.

Step 3 Click The next step or Saved to complete the configuration.

----End

2.5.12.5 How Do I Set Session Transfer?

You can set Session Transfer to configure multimedia skill queues displayed on
the transfer page.

Procedure

Step 1 Click  to enable Session Transfer.

● : When an agent transfers a session, multimedia skill queues of the
current channel type and non-subtype multimedia skill queues are displayed
on the transfer page.

● : When an agent transfers a session, skill queues of the current channel
type are displayed on the transfer page.

Step 2 Click The next step or Saved to complete the configuration.

----End
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2.5.12.6 How Do I Set the Third-Party Authentication Key?

Context
● Only the web channel supports this function.
● If the third-party authentication key provided by the third party is changed in

the third-party system, you need to modify the key in the AICC by referring to
the following procedure. Set secretKey to the new third-party authentication
key.

Procedure

Step 1 Click  to enable Third-party authentication key.

Step 2 Set secretKey.

Step 3 Click The next step to complete the configuration.

----End

2.5.12.7 How Do I Enable Offline Messages?
After Offline Messages is enabled, an agent can receive offline messages sent by
a customer during non-working time or when the agent fails to be connected. The
agent can also proactively contact the customer.

Prerequisites
None

Context
● If the page or interface is integrated into a web client, offline messages

cannot be automatically pushed. You need to manually invoke the interface
described in Proactively Polling Messages Sent by Agents (poll) to assign
offline messages. The push mode is recommended. That is, enable Message
Push in the channel configuration. For details, see 2.5.12.8 How Do I Enable
Message Push?.

● Only the web, 5G RCS, email, WhatsApp, SMS, Instagram, and Telegram
channels support this function.

Procedure

Step 1 Click  to enable Offline Messages.

Step 2 Customize Offline Message Prompt.

The value can contain a maximum of 256 characters and cannot contain the
following special characters: '"/<>\;

You do not need to set this parameter for the email and SMS channels.

Step 3 Set Offline Message Routing Time Limit.

The value is an integer ranging from 1 to 60. The default value is 30.
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Step 4 Set Agent Outbound Call Time Limit.

The value is an integer ranging from 0 to 10080. The default value is empty,
indicating that the timeout period is not limited. The value 0 indicates that agents
are not allowed to reply to offline messages.

Step 5 Set Called Customer Reply Timeout Period.

The value is an integer ranging from 1 to 5. The default value is 5 for the email
channel and 3 for other channels.

The value of Called Customer Reply Timeout Period must be less than that of
Customer Reply Timeout Period.

Step 6 Set Routing Mode. The options are as follows:
● Skill Queue Routing
● Last Agent Mode
● Connect to Chatbot

To select Last Agent Mode, enable the last agent mode first and ensure that the
configuration is the same as that under Last Agent Mode. For details, see 2.5.12.2
How Do I Enable the Last Agent Mode?

If you select Connect to Chatbot, set the robot access code. For details, see 2.6.2
Configuring an Intelligent Robot.

Step 7 Click  to enable Automatically reply to each email.

After this function is enabled, the templates specified in Automatic reply during
working hours and Automatic reply during non working hours are used to
reply. For details, see 2.5.12.9 How Do I Enable the Auto Reply and Non-
Workday Reply Functions?

Only the email channel is involved.

Step 8 Click The next step or Saved to complete the configuration.

----End

2.5.12.8 How Do I Enable Message Push?

Prerequisites

To use the message push function, you need to prepare a message push API. For
details about the API specifications, see 2.5.12.8.1 Message Push Interface
Specifications. After the API is developed, you need to submit an application to
the system administrator to add the message push address ({baseUrl}/
webhooks/v1/messages) to the address trustlist.

If {baseUrl} is an HTTPS URL, you also need to prepare an authentication
certificate. Only a JKS, DER, or PEM certificate is supported.

NO TE

HTTP has security risks. You are advised to use the secure HTTPS protocol.
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If two-way authentication is enabled for the message push address, you also need
to prepare the identity certificate of the current system.

Context
● Only the web and WhatsApp channels support message push.

For the WhatsApp channel, the system automatically pushes messages. No
manual configuration is required.

● If the message push key provided by the message pusher is changed, you
need to modify the key in the AICC by referring to the following procedure.
Enter the new message push key.

Procedure
Step 1 (Optional) If {baseUrl} is an HTTPS URL, upload the push address trust certificate

and system identity certificate.

1. Choose Configuration Center > System Management > Certificate.
2. Click New and set the certificate name and password as prompted.
3. Select the type of the certificate to be uploaded.

4. Click , select the trust certificate and identity certificate from
the local PC, and click Open.

5. Click Save.

Step 2 Go to the web channel configuration page.

Step 3 Click  to enable Message Push.

Step 4 Enter the prepared message push address, which is {baseUrl}.

Step 5 Upload the certificates. Perform this step when the push address is an HTTPS
address.

1. (Optional) Click Trust certificate and select the certificate uploaded in 1.
2. (Optional) Click Identity certificate and select the certificate uploaded in 1.

Step 6 Select an authentication mode. The options are Signature Authentication and
OAuth Authentication.
● If Signature Authentication is selected, messages are directly pushed to

customers. In this case, you need to set the following parameter:
Key: The value is a string of 43 characters and can contain only letters and
digits.

● If OAuth Authentication is selected, messages are pushed to the API Fabric,
and then the API Fabric pushes the messages to customers. In this case, you
need to set the following parameters:
App ID: Contact the system administrator to obtain the app key of the app
that has subscribed to the pushMsg API and bound to the tenant space for
which the web channel needs to be configured on the Online Studio > API
Management > APP Service > APP Management page, and enter the app
key here.
App Secret: Contact the system administrator to obtain the app secret of the
app that has subscribed to the pushMsg API and bound to the tenant space
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for which the web channel needs to be configured on the Online Studio >
API Management > APP Service > APP Management page, and enter the
app secret here.

Step 7 Click The next step to complete the configuration.

----End

2.5.12.8.1 Message Push Interface Specifications

Scenario

AICC will invoke this API to push messages which replied by agents or system
messages.

Method

POST

URI

{baseUrl}/webhooks/v1/messages

Request Description

Table 2-63 Request header parameters

No. Name Type Mandato
ry or Not

Description

1 Authorization string True Used for
authentication.
Value is auth-v2/
{accessKey}/
{timestamp}/
{SignedHeaders

 

Table 2-64 Request body parameters

No. Name Type Mandato
ry or Not

Description

1 messages list[DownLin
kMsg]

True Messages and events.

2 timestamp long True Send time, and it will
be used to generate
authentication
signature.
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Table 2-65 Parameter structure of DownLinkMsg

No. Name Type Mandato
ry or Not

Description

1 channel string True Message Channel
Type,Such as WEB.

2 isOfflineStatus Boolean False It is used in client to
judge whether can
send message in next
step.
When user wait
timeout, AICC will
push a message,
if async switch is on,
the value will be true.
If async switch is off,
the value will be false.

3 content string True Content of the MT
message sent to the
customer.
If controlType is CHAT,
and
If mediaType is TEXT,
the value is text
content.
If mediaType is
IMAGE/VIDEO/AUDIO,
the value is id of
resource, client should
use
downloadFileStream
API to get resource.
If mediaType is
LOCATE, the value is
location information,
format is latitude/
longtitude/description.
If controlType is READ,
the value is messageId
array which already
be read.

4 from string True ID of the message
sender. Channel ID.
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No. Name Type Mandato
ry or Not

Description

5 mediaType string True Message media type,
for example, text type
(TEXT), image
(IMAGE), video
(VIDEO), voice
(AUDIO), and location
(LOCATE).

6 senderNickname string False Nickname of the
message sender.

7 sourceType string True Message sender, for
example, agent
(AGENT), robot
(ROBOT), and system
(SYSTEM).

8 controlType string True Message control type,
such as
connect(CONNECT)
chat (CHAT) and
disconnect
(DISCONNECT),Transf
er to manual
service(TRANS2AGEN
T),Read report(READ)

9 timestamp long True Message sending
timestamp.

10 to string True userId

11 simQuestions string False Similarity Question
Content.

12 messageCode string False A Unique value which
is used to identify the
message agent sent.
Max length is 64.

 

Response Description
Status code: 200
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Table 2-66 Response body parameters

No. Name Type Mandato
ry or Not

Description

1 resultCode String True 0 is success, If returns
not HTTP 200 or
resultCode is not 0, it
means push message
failed.

2 resultDesc String False Customization

 

Example
● Request header:

Content-Type: application/json 
Authorization: Bearer XXXXXXXXXXXXXXXXXXXXXXX

● Request parameters:
{
    "timestamp": 1625898453913,
    "messages": [//1connected{
        "from": "202105284494222653",
        "channel": "WEB",
        "to": "44444444",
        "controlType": "CHAT",
        "mediaType": "TEXT",
        "content": "The call is connected to an agent.",
        "simQuestions": null,
        "senderNickname": "SYSTEM",
        "timestamp": 1625898453913,
        "sourceType": "SYSTEM",
        "callId": null,
        "messageCode": null,
    },
    //queuing{
        "from": "202105284494222653",
        "channel": "WEB",
        "to": "44444444",
        "controlType": "CHAT",
        "mediaType": "TEXT",
        "content": "Queuing...",
        "simQuestions": null,
        "senderNickname": "SYSTEM",
        "timestamp": 1625898453913,
        "sourceType": "SYSTEM", 
        "messageCode": null,
    },
    //disconnect because of agent
{
        "from": "202105284494222653",
        "channel": "WEB",
        "to": "44444444",
        "controlType": "DISCONNECT",
        "mediaType": null,
        "content": null,
        "simQuestions": null,
        "senderNickname": null,
        "timestamp": 1625898871961,
        "sourceType": "AGENT",
        "messageCode": null,    
    },
    //disconnect because of timeout, and async switch is off
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{
        "from": "202105284494222653",
        "channel": "WEB",
        "to": "44444444",
        "controlType": "DISCONNECT",
        "mediaType": null,
        "content": null,
        "simQuestions": null,
        "senderNickname": null,
        "timestamp": 1625898871961,
        "sourceType": "SYSTEM",
        "messageCode": null,    
    },
//disconnect because of timeout, and async switch[D1]  is on
{
        "from": "202105284494222653",
        "channel": "WEB",
        "to": "44444444",
        "controlType": "DISCONNECT",
          "isOfflineStatus":true,
        "mediaType": "TEXT",
        "content": "{TIPS}",
        "simQuestions": null,
        "senderNickname": null,
        "timestamp": 1625898871961,
        "sourceType": "SYSTEM",
        "messageCode": null,    
    },
//read{
        "from": "202105284494222653",
        "channel": "WEB",
        "to": "44444444",
        "controlType": "READ",
        "mediaType": null,
        "content": "messageId1,messageId2[D2] ",
        "simQuestions": null,
        "senderNickname": null,
        "timestamp": 1625898871961,
        "sourceType": "AGENT",
        "messageCode": null,    
    }
]
}

● Response parameters:
{
    "resultCode": "0",
    "resultDesc": "success."
}

2.5.12.9 How Do I Enable the Auto Reply and Non-Workday Reply
Functions?

After the functions are enabled, emails or SMS messages can be automatically
replied to customers based on the configured notification template.

Prerequisites
For the email channel, you have created an auto reply email template and non-
workday reply email template. For details about how to create the templates, see
Step 3.

For the SMS channel, you have created an auto reply SMS template and non-
workday reply SMS template. For details about how to create the templates, see
Step 2.
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Context
Only the email and SMS channels support the auto reply and non-workday reply
functions.

Procedure

Step 1 Enable the auto reply function.

1. Click  to enable the auto reply function.
2. Select a configured auto reply template.

For the email channel, select an email template.
For the SMS channel, select an SMS template of the SMS Gateway type.

Step 2 Enable the non-workday reply function.

1. Click  to enable the non-workday reply function.
2. Select a configured non-workday auto reply template.

For the email channel, select an email template.
For the SMS channel, select an SMS template of the SMS Gateway type.

Step 3 Click Saved to complete the configuration.

----End

2.5.12.10 How Do I Enable Connection to the Intelligent Robot?
After Connecting to the Intelligent Robot is enabled, a customer communicates
with the robot after accessing the system through a channel.

Context
For the email and SMS channels, only the following parameters are available:
Avatar, Name, Gender, and Robot.

Procedure

Step 1 Click  to enable Connecting to the Intelligent Robot.

Step 2 Set the avatar. Click Update to change the avatar. Seven system avatars are
available.

Step 3 Set the robot name and gender.

Step 4 Select a robot. The robot is configured in the intelligent IVR. For details, see 2.6.2
Configuring an Intelligent Robot.

NO TE

When configuring the intelligent IVR, you need to configure the call transfer diagram
element. The call transfer type cannot be 31, 32, or 33.

Step 5 Customize the default reply, timeout reply, and prompt for transferring calls to the
manual service.
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Step 6 Configure a silent agent skill queue. After the configuration, when the robot
encounters a problem that cannot be resolved during the conversation with a
customer, the robot can seek help from an agent in the skill queue.

Step 7 Click The next step or Saved to complete the configuration.

----End

2.5.12.11 How Do I Enable Connection to the Robot Assistant?

Context

Only the email and SMS channels do not support the robot assistant.

Procedure

Step 1 Click  to enable Access Robot Assistant.

Step 2 Select a robot assistant. The robot assistant is configured in the intelligent IVR. For
details, see 2.6.2 Configuring an Intelligent Robot.

Step 3 Click The next step to complete the configuration.

----End

2.5.12.12 Creating an App Using a Facebook Developer Account

Question

If I have a Facebook developer account, how can I directly create an app?

Answer
1. Use a Facebook account to log in to https://developers.facebook.com/.

2. Click My Apps in the upper right corner.

3. On the Apps page, click Create App in the upper right corner.

4. On the Create an app page, select Other and click Next.
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5. Select Business and click Next.

6. Enter an app name and click Create app.
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2.5.12.13 How Do I Set Automatic Email Reply?
The email channel supports automatic email reply using the intelligent robot.

Prerequisites
You have created an automatic email reply template by referring to Step 3.

Procedure

Step 1 Enable automatic reply for the email channel by referring to 2.5.12.9 How Do I
Enable the Auto Reply and Non-Workday Reply Functions?.

Step 2 Configure an intelligent robot for automatically replying to emails by referring to
2.6.2 Configuring an Intelligent Robot.
● Create a variable and set Data Type to Character and Default Value to a

value in Automatic reply email template ID,Personal email address format.
Use commas (,) to separate multiple items.

NO TE

Obtain Automatic reply email template ID on the Notification Template page after
you create an email template by referring to Step 3.
– 24.200 and earlier versions: Press F12 on the Notification Template page to query

the email template ID.
– Versions later than 24.200: Directly obtain the template ID on the Notification

Template page.

● Create an intelligent robot flow and drag the Robot Reply diagram element
to the canvas.
– Set Reply Way to TTS.
– Set Reply Source to Reply Variable.
– Set Reply Variable to the flow variable created in the previous step (the

options are global and flow variables).
– Set Reply Mode as required.

Step 3 Enable Connecting to the Intelligent Robot for the email channel by referring to
2.5.12.10 How Do I Enable Connection to the Intelligent Robot?.
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Set Robot to the robot created in the previous step.

----End

2.6 Robot Management and Configuration Guide

2.6.1 Getting Started
Online Intelligent Assistant Platform (OIAP) provides intelligent self-services. It
is an enhanced version of the traditional interactive voice response (IVR). (If the
OIAP is used with the IVR, voice enhancement can be implemented. If the OIAP is
used alone, intelligent text reply can be implemented.) Based on the enhanced
version of the IVR, customers can perform self-service operations in voice dialogs,
meeting customers' requirements on self-service and intelligence of customer
service systems. Enterprises can use SaaS-based OIAP services to reduce
customization difficulty and costs for building self-service customer service
centers.

Before using the OIAP to develop your dialog flow and configure dedicated
chatbots for your customers, you need to understand the following concepts and
prepare the following environment.

2.6.1.1 Common Concepts

Table 2-67 Concept list

Concept Description

Task-oriented
chatbot

Completes tasks with clear objectives such as booking
flight tickets, ordering meals, and subscribing to the RBT
service.

Q&A chatbot Provides answers based on users' questions.
The content of the answer is more knowledge-based
rather than user-oriented.
The main feature of Q&A-oriented chatbots is one
question and one answer. Even though the matching
scope can be expanded through similar questions and
answers.

Intention An intention can be understood as a question of a
customer. The customer achieves a certain goal such as air
ticket booking using one or a group of intentions.

Corpus A corpus refers to language texts that a user may say or
enter. By analyzing the questions that a user may ask
when performing a task and adding them as a corpus to
an intention template for semantic recognition model
training, a chatbot can better understand the user's
language.
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Concept Description

Slot Slots are parameters to be collected during dialogs. For
example, to implement a train ticket booking intention, a
user needs to provide information such as the departure
location, arrival location, and departure time. Such
information is called slots.

Entity An entity refers to a word that can be understood as a
parameter value in text content of a user. For example,
such words can be "3 kilograms" and "apple" in the
sentence "I want to buy 3 kilograms of apples", or "one",
"tomorrow", and "Beijing" in the sentence "One train
ticket to Beijing tomorrow."

Flow A flow represents an IVN task. You need to connect your
intentions and voice replies in the entire flow to provide
the self-service voice service for customers.
Flows are classified into main flows and subflows. No
obvious business logic division is available for main flows
and subflows. A recommended scenario is as follows:
Only one main flow can be configured for a tenant space.
If no flow is associated with the access code in 2.6.2.2.9
Configuring a Robot, the customer is connected to the
main flow directly.
Subflows can be used in other scenarios.

 

2.6.1.2 Environment Preparation

Table 2-68 Environment requirements

Item Requirement

Access address ● In the public cloud scenario, use the URL and access
account provided by the operation personnel.
The URL format is as follows: https://
servicestage.besclouds.com/service-cloud/sm/login/
login.html?redirectUrl=%2Fsm%2Fportal
%2Fhome.html%3Ftimestamp
%3D1582247986428&logoutReason=SessionInvalid.

● In the private cloud and on-premises scenarios, obtain
the OIAP login URL from the environment maintenance
personnel.

Client
configuration
requirements

Set the resolution to 1280 pixels x 1024 pixels or higher. The
height must be 1024 pixels or more; otherwise, the menu
may fail to be completely displayed on a page.
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Item Requirement

Voice file Static voice files must be recorded in advance, uploaded on
the Configuration Center > Resource Management >
Audio and Video page of the AICC, and approved by the
AICC system administrator.

Interface
invocation

● If you need to invoke the interface provided by the third-
party system to obtain the response information in the
robot flow, the AK/SK authentication information and
interface specifications of the third-party system are
required.

● If you require a third-party system to invoke the interface
of this system, provide the AK/SK and interface document
of this system to the third-party system.
Choose Configuration Center > Chatbot Management
> Flow Configuration > System > System Settings and
configure and view the AK/SK on the Third-party
password tab page.

● If you require AppCube to invoke the API of this system,
provide the AK/SK and API document of this system to
AppCube.
Choose Configuration Center > Chatbot Management
> Flow Configuration > System > System Settings and
configure and view the AK/SK on the AppCube Password
tab page.

RPA interface
invocation

If the agent workbench needs to use the intelligent case
robot to automatically create cases, collect data, and fill in
case information, the OIAP must be connected to the RPA
system. Choose Configuration Center > Chatbot
Management > Flow Configuration > System > System
Settings and configure and view the settings on the RPA
Settings tab page.
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2.6.1.3 Greeting the Robot

NO TICE

● The OIAP can be deployed independently or integrated with the AICC on the
public cloud. Therefore, the navigation paths vary depending on the
environment.

● In this document, all the navigation paths are those selected when the OIAP is
deployed independently. In the AICC public cloud scenario, you can choose
Configuration Center > Chatbot Management > Flow Configuration to
access the OIAP.

● To use the intelligent robot (intelligent IVR) on the public cloud, ensure that
you have subscribed to intelligent IVR, TTS, and ASR resources for the tenant
space.

For how to check whether IVR, TTS, and ASR resources have been subscribed to,
do as follows:

Log in to the Huawei Cloud console and choose  > Business Applications >
Cognitive Engagement Center. On the Cognitive Engagement Center page,
choose Instance Management and click Details corresponding to the desired
call center instance. On the IVR tab page, check whether intelligent IVR
resources have been subscribed to. On the TTS&ASR tab page, check whether
TTS and ASR resources have been subscribed to.

You can configure your dedicated robot online using flowcharts. To help you
understand the entire configuration process, this section describes the
configuration of a robot who replies with "Hello" to your greeting.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Semantic
Understanding > Knowledge Management > Domain Management, click

 in the upper right corner, enter a name, and click .

Step 2 Choose Intention Management, click Create, choose General intent, enter an
intention name, configure Corpus and Response, and click Save.
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Figure 2-82 Corpus

Figure 2-83 Response

Step 3 In the upper right corner of the Intention Management page, click Train.

Step 4 Choose Configuration Center > Chatbot Management > Semantic
Understanding > Knowledge Management > Domain Management and click
Active.

Figure 2-84 Activating a domain

Step 5 Choose Configuration Center > Chatbot Management > Flow Configuration >
Resource > Resource Template.
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In the integration environment, after the template type is set to TTS, the template
content is selected from a drop-down list. You need to choose Configuration
Center > Resource Management > Audio and Video, add a TTS text, and submit
the text for approval. After the system administrator approves the text, you can
select the text from the drop-down list.

Figure 2-85 Maintaining a resource template

Step 6 Choose Flow Management > Flow Orchestration, click Add in the upper part,
and set the robot script flow.

The script flow is as follows: After a call is connected, the customer hears "Hello"
from the robot, then the customer says "Hello", and finally the robot replies with
"Hello" again.

1. Select Blank Flow.
2. Drag diagram elements on the left to the canvas and connect them with lines.
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Figure 2-86 Dragging diagram elements

3. Click the Robot Reply diagram element and set Reply Template.
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4. Click the Semantic Recognition diagram element and set the recognition
condition to TOC.ChatBotIntentCode=="CMDHELLO".
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Figure 2-87 Configuring the Semantic Recognition diagram element

5. Click the connection line between the Semantic Recognition diagram
element and the last Robot Reply diagram element, and select a branch
condition.

Figure 2-88 Setting a branch
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6. Click the last Robot Reply diagram element and set Reply Template to the
template the same as that in the first Robot Reply diagram element.

7. Click  on the top of the canvas.

8. Click  on the top of the canvas. In the Publish dialog box, click

.

Step 7 Choose Chatbot Management > Flow Configuration > Intelligent Chatbot, and

click  to associate a flow access code with the new flow.

Step 8 Click Test Call corresponding to the flow and enter Hello. The robot then replies
with "Hello".

Step 9 If Dialog Type is set to Chatbot, configure a channel.

1. Choose Configuration Center > Access Configuration > Channel
Configuration.

2. Click New. In the Robot Configuration area, enable Connecting to the
Intelligent Robot and select the published robot.

Step 10 If Dialog Type to Voice navigation or IVR flow, configure a called route.

1. Choose Configuration Center > Access Configuration > Called Party.
2. Click New, set Access Code and Extension Code, set Device Type to IVR, and

select the published robot.
3. Click Save.

----End

Summary
What is the general process for configuring a robot?

1. Add a voice or video resource template.
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2. Configure the intentions to be recognized.
3. Orchestrate a script flow and publish it.
4. Configure a robot and associate it with the corresponding script flow.

2.6.2 Configuring an Intelligent Robot
You can drag diagram elements to draw a flow and configure a task-type multi-
round robot and a Q&A robot.

2.6.2.1 Overview
The OIAP supports the configuration of the chatbots listed in the following table.

Chatbot
Type

Function Industry-specific Example

Q&A-
oriented
chatbot

Provides answers
based on
customers'
questions.
The content of
the answer is
more knowledge-
based rather than
customer-
oriented.

In vertical domains,
technical emphases
are placed on the
technology of replying
to questions directly
using the knowledge
base and knowledge
graph.

Customer: I am in
Tianhe District. Where
can I request social
security handling?
Chatbot: (Query the
FAQ knowledge base
and find the
corresponding answer.)
B: Hello, the addresses
of service centers of
Social Security Bureau
are as follows: XXX in
Baiyun East Road in
Baiyun District; No.101
of Tianhe Building in
Tianhe District; XXX in
Yuexiu District...
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Chatbot
Type

Function Industry-specific Example

Task-
oriented
chatbot

Completes tasks
with clear
objectives such as
booking flight
tickets, ordering
meals, and
subscribing to the
RBT service.

In vertical domains
(limited information),
technologies such as
multi-round dialogs
and slot extraction are
required.

Customer: I want to
subscribe to a data
package.
B: We have 5 GB and
10 GB monthly data
packages and
unlimited data
package. Which do you
prefer?
Customer: 5 GB
monthly data package.
B: Are you sure you
want to subscribe to
the 5 GB monthly data
package?
Customer: Yes.
B: (Transfer the service
number and 5 GB
monthly data package
parameter to invoke
the service interface
for subscribing to the
package and receive a
success result.)
B: OK. You have
successfully subscribed
to the 5 GB monthly
data package. The
package takes effect
10 minutes later.
B: Do you need other
services?

 

2.6.2.2 Configuring an Appointment Chatbot (Task-oriented Robot)
This section uses a simple configuration example to describe how to configure a
task-oriented robot.

2.6.2.2.1 Configuration Scenario

This section describes how to configure a task-oriented robot.

Scenario
The following flowchart shows a scenario where a hospital uses the intelligent
voice navigation (IVN) to complete a simple robot-based appointment flow.
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Figure 2-89 Robot-based appointment flow

Note: The blue steps are performed by the IVN.

1. A customer dials the hospital customer service hotline 123456.
2. Initialize the language (Chinese or English).
3. Play the greeting.
4. The customer speaks.
5. Match the customer's words with existing intentions. If no appointment

intention is matched, notify the customer of an unknown intention.
6. If the appointment intention (with four mandatory slots: appointed

department, doctor, date, and time) is matched, ask the customer for the
appointed department, doctor, date, and time.

7. If the customer replies the preceding information, notify the customer of the
appointment information and ask the customer whether to confirm the
appointment.

8. The customer replies.
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9. Match the customer's words with existing intentions (whether to confirm the
appointment).

a. If the intention of confirming the appointment is matched, go to the next
step and notify the customer that the appointment is successful.

b. If the intention of not confirming the appointment is matched, return the
previous appointment information to the intention recognition in 5.

c. If the intention of an incorrect date is matched:

i. Ask the customer whether to change the appointed date.
ii. The customer replies.
iii. Match the customer's words with existing intentions (whether to

change the date).
iv. If the intention of not changing the date is matched, go to the next

step and notify the customer that the appointment is successful. If
the intention of changing the date is matched, ask the customer for
the new date.

v. The customer replies.
vi. Return the customer's reply and the previous appointment

information to the intention recognition in 5.
d. If no intention is matched, notify the customer of an unknown intention.

10. Notify the customer that the appointment is successful.
11. The customer hangs up.

Requirement Analysis
Based on the preceding flow, the following resources and configurations are
required.

Table 2-69 Requirement analysis

Step Resource Diagra
m
Element

Node Attribute Settings Remarks

Start - - -
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Step Resource Diagra
m
Element

Node Attribute Settings Remarks

Initialize the
language.

Business
interface
for
initializing
the
language

Variable name:
GLOBAL.language
Variable value: "en_US"

In the
actual
application
scenario,
you can
invoke a
real
interface
to
determine
the
language.
In this
robot
configurati
on
example,
this
diagram
element is
used to
assign a
value. You
can
directly
add a
cache
variable
and assign
a value to
it to
initialize
the
language,
without
selecting
an
interface
to be
invoked.
For
example,
to initialize
English, set
Response
Attribute
to the
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Step Resource Diagra
m
Element

Node Attribute Settings Remarks

following
value:
"en_US"

Play the
greeting.

- Set Reply Way to TTS.
Set Reply Source to Reply
Variable.
(The TTS dynamically plays
a voice based on the value
returned by the variable.)
Set Reply Variable to
FLOW.welcome.
Set Reply Mode to
Recognition after
playback.

Add a flow
variable as
follows:
Set
Variable
Name to
welcome.
Set Data
Type to
Character.
Set
Default
Value to
Welcome
to the
self-
service
appointm
ent
system.
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Step Resource Diagra
m
Element

Node Attribute Settings Remarks

Obtain the
customer's
reply.

Business
interface
for
caching
the dialog
interaction
result.

Variable name: FLOW.ask
Variable value:
IVRREQUEST.input

You can
directly
add a
variable
without
selecting
an
interface
to be
invoked.
Add a flow
variable as
follows:
Set
Variable
Name to
ask.
Set Data
Type to
Character.
Set
Default
Value to
Appoint $
{FLOW.do
cSlot}'s $
{FLOW.roo
mSlot} at
$
{FLOW.ti
meSlot}
on $
{FLOW.dat
eSlot}.
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Step Resource Diagra
m
Element

Node Attribute Settings Remarks

Recognize
intentions
(whether
intentions
are
matched).

Intention
template
for
appointme
nt

Set Semantic Recognition
Content to FLOW.ask.
Set the following variables:
● Variable for obtaining

the department that
matches intentions
– Variable name:

FLOW.roomSlot
– Variable value:

TOC.ChatBotroom
● Variable for obtaining

the doctor that matches
intentions
– Variable name:

FLOW.docSlot
– Variable value:

TOC.ChatBotdoctor
● Variable for obtaining

the date that matches
intentions
– Variable name:

FLOW.dateSlot
– Variable value:

TOC.ChatBotdate
● Variable for obtaining

the time that matches
intentions
– Variable name:

FLOW.timeSlot
– Variable value:

TOC.ChatBottime
In Judgment Conditions,
set the following
conditions:
● Condition when the

configured appointment
intention is matched
– Set Condition to

finish.
– Set Condition

Expression to
TOC.ChatBotIntentC
ode=='finish'.

Add flow
variables
as follows:
Set
Variable
Name to
roomSlot.
Set Data
Type to
Character.
Set
Variable
Name to
docSlot.
Set Data
Type to
Character.
Set
Variable
Name to
dateSlot.
Set Data
Type to
Character.
Set
Variable
Name to
timeSlot.
Set Data
Type to
Character.
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Step Resource Diagra
m
Element

Node Attribute Settings Remarks

● Condition when the
command word of the
mandatory department
slot of the configured
appointment intention
is matched
– Set Condition to

room.
– Set Condition

Expression to
TOC.ChatBotIntentC
ode=='room'.

● Condition when the
command word of the
mandatory doctor slot
of the configured
appointment intention
is matched
– Set Condition to

doctor.
– Set Condition

Expression to
TOC.ChatBotIntentC
ode=='doctor'.
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Step Resource Diagra
m
Element

Node Attribute Settings Remarks

Obtain the
department
that the
customer
needs to
appoint.
(The room
condition is
matched.)

Business
interface
for
querying
departmen
ts

Variable name:
FLOW.answer
Variable value:
FLOW.room
+TOC.ChatBotRespConten
t

You can
directly
add a
variable
without
selecting
an
interface
to be
invoked.
Add flow
variables
as follows:
Set
Variable
Name to
answer.
Set Data
Type to
Character.
Set
Variable
Name to
room.
Set Data
Type to
Character.
Set
Default
Value to
Currently,
the
available
departme
nts are
Internal
Medicine
and
Surgery.
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Step Resource Diagra
m
Element

Node Attribute Settings Remarks

- Set Reply Way to TTS.
Set Reply Source to Reply
Variable.
(The TTS dynamically plays
a voice based on the value
returned by the variable.)
Set Reply Variable to
FLOW.answer.
Set Reply Mode to
Recognition after
playback.

-
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Step Resource Diagra
m
Element

Node Attribute Settings Remarks

Obtain the
doctor that
the
customer
needs to
appoint.
(The doctor
condition is
matched.)

Business
interface
for
querying
doctors in
a
departmen
t

Variable name:
FLOW.answer
Variable value:
FLOW.doctor
+TOC.ChatBotRespConten
t

You can
directly
add a
variable
without
selecting
an
interface
to be
invoked.
Add flow
variables
as follows:
Set
Variable
Name to
answer.
Set Data
Type to
Character.
Set
Variable
Name to
doctor.
Set Data
Type to
Character.
Set
Default
Value to
Dr. Liu
and Dr. Li
are on
duty in
the
current
departme
nt.
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Step Resource Diagra
m
Element

Node Attribute Settings Remarks

- Set Reply Way to TTS.
Set Reply Source to Reply
Variable.
(The TTS dynamically plays
a voice based on the value
returned by the variable.)
Set Reply Variable to
FLOW.answer.
Set Reply Mode to
Recognition after
playback.

-

Notify the
customer of
the
appointment
information.
(The finish
condition is
matched.)

- Set Reply Way to TTS.
Set Reply Source to Reply
Variable.
(The TTS dynamically plays
a voice based on the value
returned by the variable.)
Set Reply Variable to
TOC.ChatBotRespContent.
Set Reply Mode to
Playback only.

-

Send the
default reply.
(No
condition is
matched.)

- Set Reply Way to TTS.
Set Reply Source to Reply
Variable.
(The TTS dynamically plays
a voice based on the value
returned by the variable.)
Set Reply Variable to
TOC.ChatBotRespContent.
Set Reply Mode to
Playback only.

NOTE
If no
condition
is matched
on a
connection
line, the
flow goes
to the
default
branch.
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Step Resource Diagra
m
Element

Node Attribute Settings Remarks

Ask whether
to confirm
the
appointment
information.

- Set Reply Way to TTS.
Set Reply Source to Reply
Variable.
(The TTS dynamically plays
a voice based on the value
returned by the variable.)
Set Reply Variable to
FLOW.check.
Set Reply Mode to
Interruption recognition.

Add a flow
variable as
follows:
Set
Variable
Name to
check.
Set Data
Type to
Character.
Set
Default
Value to
Are you
sure you
want to
confirm
the
preceding
informatio
n?
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Step Resource Diagra
m
Element

Node Attribute Settings Remarks

Recognize
intentions
(whether
intentions
are
matched).

Intention
template
for
confirmati
on

In Judgment Conditions,
set the following
conditions:
● Condition when the

intention of confirming
the appointment
information is matched
– Set Condition to yes.
– Set Condition

Expression to
TOC.ChatBotconfir
m=='yes'.

● Condition when the
intention of not
confirming the
appointment
information is matched
– Set Condition to no.
– Set Condition

Expression to
TOC.ChatBotconfir
m=='no'.

● Condition when the
intention of an incorrect
date is matched
– Set Condition to

part.
– Set Condition

Expression to
TOC.ChatBotconfir
m=='incorrect date'.

-

Use a cache
variable to
cache data
and
recognize
semantics to
confirm the
customer's
appointment
information.
(The no
condition is
matched.)

- Variable name: FLOW.ask
Variable value: 'Appoint '

You can
directly
add a
variable
without
selecting
an
interface
to be
invoked.
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Step Resource Diagra
m
Element

Node Attribute Settings Remarks

Confirm
whether the
customer
wants to
change the
date.
(The part
condition is
matched.)

Reply
template
for
confirming
whether to
change
the date

Set Reply Way to TTS.
Set Reply Source to Reply
Template.
(The TTS dynamically plays
a voice based on the value
returned by the variable.)
Set Reply Template to
redate.
Set Reply Mode to
Interruption recognition.

Add a
reply
template.

Intention
template
for
confirmati
on

In Judgment Conditions,
set the following
conditions:
● Condition when the

intention of not
changing the date is
matched
– Set Condition to yes.
– Set Condition

Expression to
TOC.ChatBotconfir
m=='yes'.

● Condition when the
intention of changing
the date is matched
– Set Condition to no.
– Set Condition

Expression to
TOC.ChatBotconfir
m=='no'.

-
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Step Resource Diagra
m
Element

Node Attribute Settings Remarks

Ask for the
new date
and
recognize
semantics
to confirm
the
appointme
nt
informatio
n.
(The no
condition
is
matched.)

Variable name:
FLOW.dateSlot
Variable value: ''
Variable name:
FLOW.answer
Variable value: 'What date
would you like to
appoint?' '

You can
directly
add a
variable
without
selecting
an
interface
to be
invoked.

Set Reply Way to TTS.
Set Reply Source to Reply
Variable.
(The TTS dynamically plays
a voice based on the value
returned by the variable.)
Set Reply Variable to
FLOW.answer.
Set Reply Mode to
Interruption recognition.

-

Variable name:
FLOW.dateSlot
Variable value:
IVRREQUEST.input
Variable name: FLOW.ask
Variable value: 'Appoint
'+FLOW.docSlot+''s
'+FLOW.roomSlot+' at
'+FLOW.timeSlot+' on
'+FLOW.dateSlot

You can
directly
add a
variable
without
selecting
an
interface
to be
invoked.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 271



Step Resource Diagra
m
Element

Node Attribute Settings Remarks

Notify the
customer of
the
appointment
information
and play a
thank-you
message.
(The yes
condition is
matched.)

- Set Reply Way to TTS.
Set Reply Source to Reply
Variable.
(The TTS dynamically plays
a voice based on the value
returned by the variable.)
Set Reply Variable to
FLOW.thanks.
Set Reply Mode to
Playback only.

Add a flow
variable as
follows:
Set
Variable
Name to
thanks.
Set Data
Type to
Character.
Set
Default
Value to
The
appointm
ent is
successful.
Thank
you.
Goodbye.

End - - -

 

NO TICE

To ensure fault tolerance, you need to configure an unknown intention for
situations where no intention is matched.

In intention recognition, the following information needs to be further analyzed.
The following takes the appointment intention as an example. Other intentions
can be analyzed using a similar method.

● Statements that the customer may use to reply appointment information.
(corpus)

– I want to see a doctor.

– Appointment

– I want to make an appointment.

– I want to appoint Dr. Li's Internal Medicine at 16:00 tomorrow afternoon.

Consider as many scenarios as possible to ensure the accuracy of intention
matching.
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● Information that needs to be obtained from the customer's reply. (slot and
entity)
For example, if the customer replies "Appoint 16:00", "16:00" is the slot
information that needs to be obtained. You need to add the slot information
to the intention. The slot information needs to be associated with a time
entity, so you need to check whether a similar entity exists in entity
configuration. In this example, you can use the system entity @system.time.
If the customer replies "Appoint Dr. Li", "Dr. Li" is the slot information that
needs to be obtained. You need to add the slot information to the intention.
The slot information needs to be associated with a doctor entity but the
entity does not exist among system entities, so you need to manually add the
entity.

● Command word used for intention matching, that is, the value of
TOC.ChatBotIntentCode required by the Semantic Recognition diagram
element, which must be globally unique. (response)
Branch conditions can be set for responses in the intention. You can directly
add branches to reply different values of TOC.ChatBotIntentCodes.

2.6.2.2.2 Adding Business Interfaces

Business interfaces are encapsulated from third-party interfaces, and are then
associated and invoked by the Interface Invoking diagram element. The IVN
supports RESTful interfaces.

According to the analysis in 2.6.2.2.1 Configuration Scenario, you need to add
multiple business interfaces. All the business interfaces are used in cache variable
mode, and no real interface is invoked. If you need to invoke a real interface in
actual scenarios, refer to this section.

NO TICE

The business interface orchestration capability is insufficient. Therefore, in actual
applications, the interface adaptation team must provide the invoked interfaces to
prevent the interface definition differences between different systems.
For example, if we need to invoke an interface to obtain the values of two
parameters from two interfaces in the actual business system, the interfaces need
to be orchestrated to one interface for invocation.

Prerequisites

You have contacted the system administrator to add the IP address or domain
name of the third-party interface to be invoked to the trustlist.

Procedure

Step 1 Sign in as a tenant administrator and choose Configuration Center > Chatbot
Management > Flow Configuration.

Step 2 Choose Resource > Business Interface. Click New.
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Step 3 Add an interface by automatically generating a message body or manually
entering a message body. The following describes how to add an interface in
either of the two ways.

Step 4 Add an interface by automatically generating a message body.

1. On the Automatic Message Body tab page, set basic information about the
interface to be invoked, including the interface name, request method, and
request URL.

– When Request Method is set to TUC, enter one of the following URLs in
the Request URL text box based on site requirements. For details about
the input and output parameters of the interface, see 2.6.2.5.3 TUC
Interfaces.

Table 2-70 Request URLs when Request Method is set to TUC

URL Description

/chatbot/rest/tuc/v1/nlp/
detectRegularEntity

Rule entity detection used in the
case flow.

/chatbot/rest/tuc/v1/nlp/identify Language interface.

/chatbot/rest/tuc/v1/
recommendFaq

FAQ recommendation interface.

/chatbot/rest/tuc/v1/
qualityInspection/qiOnline/
recognize

Interface for intelligent assistant
real-time inspection.
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URL Description

/chatbot/rest/tuc/v1/nlp/feedback Satisfaction feedback interface.

/chatbot/rest/tuc/v1/nlp/
textClassify

Text classification interface.

/chatbot/rest/tuc/v1/nlp/
detectEntity

Entity recognition interface.

/chatbot/rest/tuc/v1/
qualityInspection

Intelligent training interface.

 

NO TICE

HTTP is not secure and may cause security risks. HTTPS is recommended.

– Sign: Set this parameter based on whether signature verification is
performed on the third-party interface. If signature verification is
enabled, contact the third party to provide the shared key.

NO TE

▪ If signature verification is disabled, security risks exist. You are advised to
enable signature verification.

▪ If signature verification is enabled, after the shared key provided by the third
party is changed periodically, change the shared key on this page accordingly.

2. (Optional) If the interface has query parameters, add the query parameters,
that is, Interface request URL?Path parameter 1=Parameter value&Path
parameter 2=Parameter value.

3. Add interface input parameters. On the Input Parameter tab page, click Add.
Generally, the input parameters of the interface are the same as those of the
third-party system interface specifications.
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NO TICE

For security purposes, set Encrypted to  if the input parameter
contains personal data, such as the customer ID card number.

4. Add interface output parameters. On the Output Parameter tab page, click
Add. The output parameters of the interface are the same as those of the
third-party system interface specifications.
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NO TICE

For security purposes, set Encrypted to  if the output parameter
contains personal data, such as the customer ID card number.

The following figure shows how to set Path. To obtain the entire return result,
set Path to $. To obtain a field, add $ at the beginning and use periods (.) to
separate each level. The level structure must be the same as the structure of
the return result. Otherwise, the parsing fails, or the required field cannot be
obtained.
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Figure 2-90 Output parameter configuration example

5. (Optional) Add an interface message header. On the Message Header tab
page, add the authentication information required by the interface. If the
information does not exist, ignore this step. The authentication information is
configured based on the specifications of the third-party system.

NO TICE

For security purposes, set Encrypted to YES if the interface message header
contains personal data, such as the customer ID card number.

6. On the Message Body tab page, view the automatically generated message
body. You can copy the generated message to the commissioning tool to
check whether the interface can be invoked successfully.

7. Click Confirm.

Step 5 Add an interface by manually entering a message body.

1. Click the Manual Message Body tab. Set basic information about the
interface to be invoked, including the interface name, request method, and
request URL. For details about the parameters, see Step 4.1.

2. (Optional) If the interface has query parameters, add the query parameters,
that is, Interface request URL?Path parameter 1=Parameter value&Path
parameter 2=Parameter value.

3. Add interface output parameters. On the Output Parameter tab page, click
Add. The output parameters of the interface are the same as those of the
third-party system interface specifications.
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NO TICE

For security purposes, set Encrypted to  if the output parameter
contains personal data, such as the customer ID card number.

The following figure shows how to set Path. To obtain the entire return result,
set Path to $. To obtain a field, add $ at the beginning and use periods (.) to
separate each level. The level structure must be the same as the structure of
the return result. Otherwise, the parsing fails, or the required field cannot be
obtained.
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Figure 2-91 Output parameter configuration example

4. (Optional) Add an interface message header. On the Message Header tab
page, add the authentication information required by the interface. If the
information does not exist, ignore this step. The authentication information is
configured based on the specifications of the third-party system.

NO TICE

For security purposes, set Encrypted to YES if the interface message header
contains personal data, such as the customer ID card number.

5. Add a message body. On the Message Body tab page, enter the request
message body. The following is an example:
{
    "callId": "${businessReqId}",
    "provId": "202205130514",
    "busiType": "0",
    "params": {
        "tenantId": "${tenantId}"
    }
}

If a message body is manually entered, the input parameters cannot be
manually added. Instead, the input parameters are automatically generated
by parsing the message body content. In the preceding example, two input
parameters businessReqId and tenantId are generated. The input parameters
businessReqId and tenantId can be variables that need to be transferred
when the interface is invoked in the subsequent flow.

6. Click Confirm.

----End
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2.6.2.2.3 Adding Resource Templates

Resources include static voice files, TTS voice files, and SMS messages. Before
orchestrating flows, you need to add the involved resources, including voice and
SMS templates, to the system.

Context

Table 2-71 Description of the resources that can be added

Templa
te Type

Description Configuration Prerequisites

TTS When Reply
Way of the
Robot Reply
diagram
element is set
to TTS, the
resource is
configured for
playing the
configured text
information
using the TTS.

If the text contains parameters, ensure that the
parameters to be used have values in the current
step.
For example, when a slot of a certain intention is
used as a variable, the related value must be
obtained before the step.

SMS When the SMS
Sending
diagram
element is
used, you need
to select a
content
template for
sending SMS
messages.

If the text contains parameters, ensure that the
parameters to be used have values in the current
step.
For example, when a slot of a certain intention is
used as a variable, the related value must be
obtained before the step.

Static
voice

When Reply
Way of the
Robot Reply
diagram
element is set
to Static
voice, the
resource is
configured for
directly using
the voice file
on the server.
The
configuration
here is for
reference only.

Parameter variables cannot be configured. You need
to upload the voice file with the same name of the
template to the UAP file server first.
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Templa
te Type

Description Configuration Prerequisites

Video
file

When Reply
Way of the
Robot Reply
diagram
element is set
to Video, the
resource is
configured for
directly using
the video file
on the server.
The
configuration
here is for
reference only.

Parameter variables cannot be configured. You need
to upload the video file with the same name of the
template to the UAP file server first.

Card
templat
e

When Reply
Way of the
Robot Reply
diagram
element is set
to Card, the
resource is
configured for
directly using
the card on
the server.

You can select a card template only after it has
been configured under Configuration Center >
Resource Management > Multimedia Library in
the AICC.

Multime
dia

When Reply
Way of the
Robot Reply
diagram
element is set
to
Multimedia,
the resource is
configured for
directly using
the
multimedia
content on the
server.

You can select a rich text, image, location, or other
templates only after it has been configured under
Configuration Center > Resource Management >
Multimedia Library in the AICC.
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Templa
te Type

Description Configuration Prerequisites

WhatsA
pp
Interacti
ve
Messag
es

When Reply
Way of the
Robot Reply
diagram
element is set
to WhatsApp
Interactive
Messages, the
resources
configured
here need to
be used.

To set the template content, choose Configuration
Center > Resource Management > Multimedia
Library > Card Template > WhatsApp Interactive
Messages.

 
According to Table 2-69, you need to add a reply template for the Robot Reply
diagram element. The following describes how to add a reply template for
determining whether to change the date.

Procedure
Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose Resource > Resource Template. Click New.

Step 3 Set Name, set Type to TTS, set Content as follows, and click Confirm.

In the integration environment, after the template type is set to TTS, the template
is selected from a selection box. You need to choose Configuration Center >
Resource Management > Audio and Video, add a TTS text, and submit the text
for approval. After the system administrator approves the text, you can select the
text from the selection box. Only IVR voice files in the current language are
displayed in the selection box.

Figure 2-92 Resource template configuration page (integration environment)
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Figure 2-93 Selecting the template content

NO TE

The Configure Intention Template switch provides a simple tree-structured intention
adding entry for guiding flow configurations in the intelligent agent assistant scenario. This
function is not enabled in the current version.

----End

Reference

To configure the dialog template for intelligent recommendation, you can obtain
required information by querying customers with the intention list in the resource
template.

2.6.2.2.4 Adding an Intention

An intention can be understood as a question of a customer. The customer can
achieve a certain goal such as seat booking using one or a group of intentions.
During IVR flow orchestration, if the semantic recognition service diagram element
is selected, the intention template needs to be configured for the semantic
recognition diagram element to recognize customer intentions.

Intentions can be classified into the following types:

● General Intention: intention driven by corpora. The general intention is the
most commonly used. It is usually configured when the Semantic
Recognition diagram element is used to recognize the semantic content in
the customer statements in a dialog flow.
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● Unknown Intention: intention selected when customer input is not recognized.
Each domain needs this type for the intentions not matched in the domain.
The unknown intention is preset.

● Event Intention: intention selected when a specific event is triggered. For
example, if a sensitive word configured in the system exists in customer
statements, the Sensitive Word event is triggered. The event intention is
usually used to match specific events and return the matched events. The
Sensitive Word and Clear Context event intentions are preset.

NO TE

What are the differences between a general intention and an unknown intention?

A general intention is a common intention that contains corpus information. For example,
queries about weather and air tickets are general intentions. An unknown intention is an
intention that is not recognized and contains no corpus information. It contains only
response information.

You need to understand the following concepts during the intention configuration:

● Corpora are all possible statements of customers for an intention. For
example, you need to prepare a template for playing music for customers. In
this template, all possible statements related to music playback need to be
listed, for example, "Play music for me" and "Play a song".

● For details about how to add a common corpus, see Step 3.4. For details
about how to add a rule corpus, see 2.6.2.6.12 How Do I Use a Rule
Corpus?.

NO TE

Corpora are classified into corpora and rule corpora. What are the differences between
a corpus and a rule corpus?

● Corpus: all possible statements of customers for an intention.

Slots can be marked in a corpus. When marking slots directly, use a corpus.

● Rule corpus: corpus that is configured to match the customer input. A rule corpus
cannot mark slots, but can be applicable to all expressions of the same sentence.
When expressing statements in fixed sentence patterns, use a rule corpus. For
example, in [Help me|I want to] (subscribe to a data package|subscribe to the
broadband service), the square bracket defines optional rules, the vertical bars (|)
indicate multiple choices, and the parentheses define mandatory parts. In this case,
subscribe to a data package and subscribe to the broadband service can be
recognized through the Semantic Recognition diagram element.

● Slots are parameters to be collected during dialogs. For example, to
implement a train ticket booking intention, a customer needs to provide
information such as the departure city, arrival city, and departure time. Such
details are called slots. To obtain a customer intention, you can obtain
customer information, such as the time, location, and category, and add the
information as slots.

● Entities refer to words that can be understood as parameter values in the
voice content of a customer. For example, such words can be 3 kilograms and
apple in the content I want to buy 3 kilograms of apples or one,
tomorrow, and Beijing in the content One train ticket to Beijing tomorrow.
The difference of the entity and slot is as follows: A slot represents the nature
of an intention. An entity is not dedicated to an intention but used to fill a
slot. In this way, modeling is performed for parameters and values separately.
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Based on Table 2-69, you need to add two intentions and two entities. You can
use the two preset entities. The following describes how to add an appointment
intention.

Procedure

Step 1 Add a domain. For details, see 2.6.2.4.5 Adding Domains.

Step 2 Add a doctor entity and department entity. For details, see 2.6.2.4.6 Adding
Entities.

Figure 2-94 Adding a doctor entity

Figure 2-95 Adding a department entity

Step 3 Add an appointment intention.

1. Go to the new domain, click Create, and choose General Intent.
2. Enter an intention name, for example, Appointment.
3. On the Context tab page, click Create in the Input Context area to add a

context for the current intention. In this example, no context is added.
Context indicates that the robot processes multiple groups of statements as
the same round of dialogs based on the value in a multi-round dialog. When
an intention is specified, character strings configured in the context can be
used to locate it.
An intention context can be understood as the dialog memory of a robot. A
robot identifies and handles multiple rounds of dialogs that have the same
context as one task. For example, by multiple rounds of Q&A, a robot
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successively obtains the departure time, departure location, and destination
for flight reservation. When the robot receives other contexts in the flight
reservation context, such as a weather query context, the robot switches to a
new intention that corresponds to the customer's questions. In this way,
multi-intention conversion is realized.

4. On the Corpus tab page, click Create.
Analyze the customer's possible answers and add the answers to the corpus.
For example, if the customer may answer "I want to appoint Dr. Li's Internal
Medicine at 16:00 tomorrow afternoon", double-click the text box and enter I
want to appoint Dr. Li's Internal Medicine at 16:00 tomorrow afternoon.
Then, select tomorrow afternoon and choose @system.date from the
displayed menu, and select 16:00 and choose @system.time from the
displayed menu.

NO TE

How to mark a slot?
After the corpus is entered, press Enter to automatically mark the slot. However, some
corpora are special (such as this example), that is, the slot that is automatically
marked after you press Enter does not meet the requirements. Therefore, you need to
manually mark the slot.

You can add the following corpus information.

5. On the Slot tab page, set the slot name, whether the slot is mandatory, and
the question information provided by the system when the slot information is
missing.
The name of the slot will be part of the slot variable name used during flow
orchestration.
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NO TICE

The complete time, date, department, and doctor must be provided to
confirm an appointment. Therefore, the four slots are mandatory. Enable
Mandatory for them.

6. On the Response tab page, click Add, and configure the command word
returned after the intention matching succeeds.

Response means the text or command word to be reported when the
intention is matched. A response can return different texts or command words
depending on the condition expressions. When you need a matched intention
to return prompt information to the customer, configure the TTS. When you
need a matched event to be written into TOC.IntentCode and returned to the
invoker (for example, the dialog flow), configure the command word.

Click the Command text box, and set it to finish.

Click , set Reply Type to TTS, and set Reply to You have
appointed {$doctor}'s {$room} at {$time} on {$date}.

7. Click Save in the lower right corner.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 288



8. Click Train in the upper right corner. A message is displayed, indicating that
the training is successful.

9. Click Test in the upper right corner to test the current intention.
If you have configured the context when adding an intention, enter the
configured context in the context text box on the chat page before asking the
robot. Otherwise, you do not need to enter the context.
During the test, ask the robot based on your corpus and check the robot reply.
If the following information is displayed, the matching is successful.

----End

2.6.2.2.5 Adding Flows

A flow represents an IVN task. You need to connect your intentions and voice
replies in the entire flow to provide the self-service voice service for customers.

Flows are classified into main flows and subflows. No obvious business logic
division is available for main flows and subflows. A recommended scenario is as
follows:

Only one main flow can be configured for a tenant space. If no flow is associated
with the access code in 2.6.2.2.9 Configuring a Robot, the customer is connected
to the main flow directly.

Subflows can be used in other scenarios.

For details about the description and usage of each node in the flow, see 2.6.2.5.1
Diagram Elements.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose Flow > Orchestration and click New.

Step 3 Set the flow template to Blank Flow. A blank template is used as an example to
describe the usage of common diagram elements.
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NO TE

What are the benefits of using a flow template?

The flow templates for inbound and outbound calls are preset, including complete
recognition nodes, recognition parameters, and branch conditions for processing logic that
fails to recognize an intention for three times. You only need to add the corresponding reply
templates, variables, and branch condition values for the flows. You can use a template to
quickly configure a robot in corresponding scenarios.

In the Thai environment, the inbound call flow template and outbound call flow template
cannot be selected.

Step 4 Set flow parameters.

1. Click + in the Flow Variable area.

2. In the dialog box that is displayed, set Variable Name and Data Type.

This variable is used to store data in other diagram elements. According to
the plan, you also need to add the following variables:

– welcome: greeting. The value is a string. The default value is Welcome
to the self-service appointment system.

– answer: reply variable for the question asking for the appointed
department or doctor or the new date. The value is a string. There is no
default value.

– room: variable for asking for the appointed department. The value is a
string. The default value is Currently, the available departments are
Internal Medicine and Surgery.
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– doctor: variable for asking for the appointed doctor. The value is a string.
The default value is Dr. Liu and Dr. Li are on duty in the current
department.

– check: variable for asking whether to confirm the appointment
information. The value is a string. The default value is Are you sure you
want to confirm the preceding information?

– docSlot: appointed doctor. The value is a string. There is no default value.
– roomSlot: appointed department. The value is a string. There is no

default value.
– dateSlot: appointed date. The value is a string. There is no default value.
– timeSlot: appointed time. The value is a string. There is no default value.
– ask: customer reply, which is used for semantic recognition and intention

matching. The value is a string. The default value is Appoint $
{FLOW.docSlot}'s ${FLOW.roomSlot} at ${FLOW.timeSlot} on $
{FLOW.dateSlot}.

– default: default reply when no intention is matched. The value is a string.
The default value is Excuse me, please say it again.

– thanks: thank-you message. The value is a string. The default value is
The appointment is successful. Thank you. Goodbye.

3. Select an encryption type and click Confirm.

NO TICE

For security purposes, set Encryption Type to Encrypted for storage and
decrypted upon retrieval or Encrypted for storage and retrieval if the flow
variable contains personal data, such as the customer ID card number.

Step 5 Drag the corresponding diagram elements to the canvas on the right and connect
the diagram elements based on Figure 2-89 and Table 2-69.

The following figure shows the flow after the configuration is complete. When
configuring a flow, you can right-click the canvas to move the canvas on the page.

NO TE

After condition judgment is performed on a diagram element, you need to add a branch
without selecting a condition name, that is, the default branch. Ensure that the IVR flow
can find the next node when other conditions are not met.
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Step 6 Configure information for each node and connection in sequence. The
configuration methods of diagram elements of the same type are similar. This
section describes only one diagram element of each type. For other configurations,
complete them based on Table 2-69.

1. Configure a flow to ask whether to change the appointed date.
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Set Reply Way to TTS, and select the template configured in 2.6.2.2.3 Adding
Resource Templates for Reply Template.
If Reply Mode is set to Interruption recognition, the customer can speak
before the voice playback ends, which saves the service time.

2. Configure the Semantic Recognition node.
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The configuration indicates that the diagram element has a branch based on
the returned result. That is, the branch whose intention code is finish is
matched successfully, and the values of the slot variables doctor, date, time,
and room in the matched intention are assigned to the flow variables
docSlot, dateSlot, timeSlot, and roomSlot.

NO TICE

If an intention has multiple slots (for example, book time query node), you
need to set Event to Clear Current Context Cache during semantic
recognition setting. Besides, judgment control needs to be performed in the
flow. For details, see 2.6.2.6.4 How Do I Configure the Scenario Where
Multiple Slots Are Filled Repeatedly?. In this example, for ease of
understanding, the case of multiple rounds of slot filling is not considered.

3. Click the connection line between the Semantic Recognition and Robot
Reply diagram elements (the voice recognition matches the reply information
configured in the intention response), and select the branch corresponding to
the connection line as the branch configured in the previous step.
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4. Configure the Interface Invoking node.
If the Business Interface Invocation diagram element is applied to the
interface invocation scenario, you need to select an interface configured in
2.6.2.2.2 Adding Business Interfaces. Set input parameters of the interface.
In this scenario, real interfaces do not need to be invoked. The Business
Interface Invocation diagram element is used to add cache variable names.

Step 7 After diagram elements are configured and connection lines and branches are
correctly selected, click Save on the top of the canvas.

----End

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 295



2.6.2.2.6 Importing Flows

In the following scenarios, importing flows is more convenient, efficient, and
secure than manually adding flows:

Business scenario 1: Import historical data. When the company introduces a new
system, the retained data of previous years needs to be imported into the system.

Business scenario 2: Import summary data. Due to permission issues, not everyone
can use the system. Therefore, data needs to be summarized level by level and
imported into the system by a specific person.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose Flow > Orchestration and click Import. The Import Flow dialog box is
displayed.

Figure 2-96 Import Flow

Step 3 Click Select File, select the file to be imported, click Upload, and click Confirm.

NO TE

1. In the ZIP package, each file must be in JSON format, and its size cannot exceed 4 MB.
Otherwise, the import fails.

2. The size of the ZIP package must be less than 20 MB. Otherwise, the import fails.

3. In a JSON file, the request URL of the business interface and the database URL in the
stored procedure must be added to the trustlist. Otherwise, the import fails. Contact the
administrator to configure the trustlist.

----End

2.6.2.2.7 Adding Gray Rules

A gray rule indicates that a publishing rule can be specified when a flow is
published so that a customer who meets the rule can experience the flow. A
number segment can be specified for the current gray rule, which is used in the
test phase.
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Procedure

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose System > Gray Rule and click Create.

Step 3 Configure a number segment for the gray rule and click Confirm.

----End

2.6.2.2.8 Publishing a Flow

The newly added flow is in draft state. You need to publish the flow for the flow
to take effect. To modify a published flow, you need to bring the flow offline, edit
the flow, and publish the flow again.

Currently, the system supports gray release and official release. The difference is
that only customer numbers that meet the gray rules can use the flow after the
gray release is complete.

Currently, the flow of the silent agent system can be connected. When the silent
agent system is connected, you can set Work Mode to Monitor (silent agents
only view the replies of the robot), Insert (silent agents assist the robot in
replying), or Common (default).

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose Flow > Orchestration and click Publish corresponding to the flow to be
published.

NO TE

You can also go to a specific flow page and click Save and Publish on the top of the canvas
to publish a flow.

Step 3 Set publishing parameters and click Confirm, as shown in the following figure.
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----End

If features need to be modified in a published flow, you are advised to click
Upgrade to save the current flow as a new version. After the new version is
modified, bring the old version offline and publish the new version.

2.6.2.2.9 Configuring a Robot

After the flow is published, associate your flow with the robot to generate the
robot access code. Then, choose Configuration Center > Access Configuration >
Called Party to bind the robot access code. Your customer service hotline consists
of the access code and extension code.

The OIAP supports the access in the following scenarios:

● Voice navigation: applicable to the general voicebot scenario.
● Intelligent outgoing call: applicable to the scenario where a flow is

automatically triggered during outbound calls.
● Chatbot: applicable to the scenario where a chatbot is used.
● IVR flow: applicable to the scenario where the AICC is connected.

In this example, the first scenario is used.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose Intelligent Chatbot. Click New.

Step 3 Enter information by referring to the following figure and click Confirm to save
the configuration.
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Figure 2-97 Add Chatbot

● Chatbot Name: Enter a customized name.
● Chatbot Access Code: Enter an identifier for associating with the flow when a

called route is added in the IVR or AICC.
– In the public cloud scenario where the OIAP is integrated with the AICC,

this code is automatically generated. The system automatically
synchronizes the flow access code information to the WAS console.

● Dialog Type: Select Voice navigation.
The mappings between dialog types and scenarios are as follows:
– When the robot interacts with a customer using voices, set Dialog Type

to Voice navigation.
– When the robot is connected to text chat platforms of the AICC as an

intelligent chatbot, set Dialog Type to Chatbot.
– When a robot survey is required for outbound calls, set Dialog Type to

Intelligent outgoing call. This function is not enabled in the current
version.

– When the traditional key pressing function is required on the AICC, set
Dialog Type to IVR flow. This function is not used on the OIAP. You can
choose Configuration Center > Flow Configuration > Flow in the AICC
to configure flows.

● Flow Name: Select a flow that has been orchestrated and published. If a flow
has been upgraded for multiple times, that is, the same flow code has
multiple versions, the drop-down list displays only one flow and does not
display the version information. When a customer initiates a call, the backend
selects a flow version based on the calling number of the customer. If the
calling number of the customer is within the number range specified by the
gray rule of a version, the flow of this version is preferentially selected.
Otherwise, the default flow is selected.
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● Number of Calls Processed Only by Agent: This parameter is used to
distinguish the maximum number of calls directly transferred to manual
service from the maximum number of calls transferred to manual service
after consultation during report statistics. The default value is 3.

NO TE

● How to match the flow only with the intention in the specified domain?
When configuring the access code, set the ID of the specified domain. Ensure that the
configured domain has been activated.

Step 4 Click  corresponding to the new robot and choose Bind Domain to set its
domain range.

In addition, you can bind Q&As to the robot, and the robot preferentially matches
the result of the Q&As.

----End

2.6.2.2.10 Testing a Robot

You can test your robot to determine whether your configuration is correct.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose Intelligent Chatbot. Click Test Call in the last column corresponding to
the access code to be tested.

Step 3 In the test dialog box that is displayed, click Start Call.
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Figure 2-98 Testing a robot

----End

2.6.2.2.11 Viewing Flow Tracks

A flow track refers to the flow nodes that a call passes through after the call
accesses the flow on the OIAP and the information returned by each node. When
an error occurs in the test robot, you can use the test number to view the value
change on each node in the flow track and locate the cause of the error.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Add the test number to the tracking trustlist.

1. Choose System > System Settings. Click the Track Settings tab.
2. Click Track Calling Number, add a calling number, and click Save, as shown

in the following figure.
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3. Alternatively, click Tracking Robots and add a robot to track the flow based
on the robot access code.

Step 3 Choose Flow > Flow Tracking.

Step 4 Enter a calling number, set the tracking time range, and select an access code.

Step 5 Test the robot again by referring to 2.6.2.2.10 Testing a Robot.

Step 6 Return to the Flow Tracking page, click Search, and click the record that is
displayed.

Step 7 Click the node where the fault occurs in the flowchart, and view the log
information and error information.
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● Click >> next to Current node information for details.
● Or click View Current Flow Track below. On the page that is displayed, view

the configurations of the flow node.

----End

Follow-up Procedure
Choose System > System Settings. On the Track Settings tab page, delete the
added calling number.

2.6.2.2.12 Performing Dialog Tests

If you already have a large number of intelligent robots and need to frequently
test whether these robots function properly, you can create dialog test cases,
execute them in batches, and check whether functions are normal based on the
results.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration > Flow > Dialog Test.

Step 2 Create a test case group.

1. Click , enter test case group information, and click .
The test case group is successfully created.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 303



Figure 2-99 Add Test Case Group

2. Alternatively, click Batch operation and choose Generate Case to generate a

test case group in the Initialize state. Click  to filter selected
records.

Figure 2-100 Generate Dialog Case
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Figure 2-101 Filter Selected Records

NO TE

The filtering function can be used only if the oifde.chatrecord.switch parameter in
the configuration file is enabled.

Step 3 Create a test case.

1. Click Manage corresponding to the new test case group. The Manage Test
Case dialog box is displayed.

Figure 2-102 Add Test Case

2. Click  to create a test case.

3. After a test case is created, in the Manage Test Case dialog box, click
Manage corresponding to the new test case, create call content information,

and click .
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Figure 2-103 Manage Case Details

Step 4 Perform a dialog test.
● Return to the Dialog Test page, and click Execute in the Operation column

on the right of the new case group to execute the entire case group. After the
execution is successful, Status changes to Finish.

● Select some case groups, click Batch operation, and choose Execute to
execute the selected case groups in batches. After the execution is successful,
Status changes to Finish.

Figure 2-104 Executing some case groups

● In the Manage Test Case dialog box, select some test cases, click Batch
operation, and choose Execute to execute the selected test cases in batches.
After the execution is successful, Status changes to Success.

Figure 2-105 Executing some test cases
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Step 5 View the execution result and export the test report.

1. After executing a test case group, view the number of tested cases, number of
passed cases, number of failed cases, and pass rate.

Figure 2-106 Viewing the execution result

2. Select the test case group that has been executed and click  to export
the test report.

----End

2.6.2.3 Adding a Q&A-oriented Robot

If there is a large number of Q&A corpora, and complex scenarios such as invoking
an interface to dynamically obtain information or performing multiple interactions
do not need to be implemented, you can use a Q&A-oriented robot to quickly add
questions and answers.

A Q&A-oriented robot answers a customer's questions based on knowledge rather
than the customer's objective.

Before adding a Q&A-oriented robot, you need to add an FAQ group, which is
similar to a domain used in a task-oriented robot. An FAQ group is used to answer
specific business questions, such as a product tariff question.

Step 1 Choose Configuration Center > Chatbot Management > Semantic
Understanding > Knowledge Management > FAQ Management.

Step 2 Click .

Step 3 Enter an FAQ group name and click .

Step 4 Enter a question and click  to check whether a similar question has been
added to the current FAQ group. If no, go to the next step.

Step 5 Click the number in the Quantity column. The Manage FAQ Group dialog box is
displayed.

Step 6 Click  and set the question, standard answer, and reply type (TTS or
Resource template), as shown in the following figure.
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Step 7 To improve the answer matching accuracy, click  next to Question or 
next to Keyword1 to add a similar question or keyword.

Step 8 Click .

Step 9 (Optional) To improve efficiency in managing Q&As, enter them in a specified
format and import them into the system in batches.

1. Select a Q&A and click .

The system exports a .json file, as shown in the following figure.

Multiple records are supported for simQuestions, simAnswers, and
keyWords. They must be entered in formats provided in the preceding figure.

2. After entering all Q&A records, click , click , select

the .json file on the local PC, and click .
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If certain questions to be uploaded exist in the FAQ group, when you select
Overwrite Existing Configuration, they overwrite the existing ones.
Otherwise, they will be imported as new records.

Step 10 Test the Q&A-oriented robot.

1. Click Active in the Status column to activate the Q&A-oriented robot.
2. Close the Manage FAQ Group * dialog box, click More corresponding to the

new FAQ group, choose Test, and select Test activated FAQ group to activate
the FAQ group.

3. In the input area, enter a question or keyword, and click .
The Q&A-oriented robot returns an answer and a list of similar questions.

----End

2.6.2.4 Other Operations
This section describes other operations related to an IVR flow.

2.6.2.4.1 Managing Variables

Variables are used in dialog flows to store data generated during flow execution.
Variables defined in a flow can be used only in this flow. If a variable is involved in
multiple flows, you need to define the variable as a global variable. Global
variables can be referenced by all flows. Global variables are used in flows. The
format of a global variable is ${GLOBAL.ParamName}.

Adding a Global Variable

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose Resource > Variable and click .

Step 3 Set Variable Name and Data Type, as shown in the following figure.

Step 4 Select an encryption type and click Confirm.

NO TE

For security purposes, set Encryption Type to Encrypted for storage and decrypted upon
retrieval or Encrypted for storage and retrieval if the variable contains personal data,
such as the customer ID card number.
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----End

Modifying a Built-in Variable

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose Resource Management > Variable Management and click the Built-in
Variable tab.

Step 3 Click Edit in the Actions column of one of the following built-in variables and
change the default value based on site requirements.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 310



Table 2-72 Built-in variables

Variabl
e Name

Description Data
Type

Value Range Default Value

languag
e

Use this variable to
set the language
of the tenant.

Chara
cter

● Chinese
● English
● Spanish
● Arabic
● Thai
● Portuguese
● French

Chinese

timezon
e

Use this variable to
set the offset of
the time zone in
which the tenant
resides.

Floati
ng-
point
numb
er

–12 to 12 None

channel
type

Use this variable to
set the channel of
the tenant.

Chara
cter

default default

respons
estyle

Use this variable to
set the style of the
tenant.

Chara
cter

default default

ttsSpee
d

Use this variable to
set the TTS speech
speed of the
tenant.

Integ
er

–500 to 500 0

ttsVolu
me

Use this variable to
set the TTS volume
of the tenant.

Integ
er

0 to 100 50

ttsPitch Use this variable to
set the TTS
fundamental
frequency of the
tenant.

Integ
er

–500 to 500 0

voiceNa
me

Use this variable to
set the TTS
speaker of the
tenant.

Chara
cter

● Graceful
● Mature
● Soft
● Sweet
● Natural

Graceful
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Step 4 After the modification is complete, click .

----End

2.6.2.4.2 Maintaining Stored Procedures

When deploying and running the OIAP system independently, a carrier can use
stored procedures to interact with a third-party system database to obtain or
update data, for example, to query the work order types defined by the third-party
system.

The system supports the MySQL, Oracle, and GaussDB stored procedures. The
stored procedures must be predefined.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose Resource > Stored Procedure, click the Stored Procedure Databases tab,

and click  to configure the database connection information of
stored procedures. If this information has been configured, click Edit. A maximum
of 200 records are allowed.

● Database Name: Database name. The value can contain only letters, digits,
spaces, underscores (_), and single quotation marks (').

● Database Type: The options are MySQL, GaussDB, and Oracle. Select a value
based on site requirements.
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● Database Driver: Driver used for connecting to the database. Generally, you
do not need to set this parameter.

● Database URL: Database connection string, which is a JDBC connection
string. Contact the administrator to add it to the trustlist.

Table 2-73 Configuration format of the database connection string

Database Configuration Format Configuration
Example

MySQL jdbc:mysql://IP
address:Port number/
SID

jdbc:mysql://IP
address:Port number/
oiap?
useUnicode=true&cha
racterEncoding=utf-8
&useSSL=false

GaussDB jdbc:zenith:@IP
address:Port number

jdbc:zenith:@IP
address:Port number

Oracle jdbc:oracle:thin:@Host
IP address:Port
number:SID

jdbc:oracle:thin:@IP
address:Port
number:oiap

 
● Database User and Database Password: Username and password for

connecting to the database.
● If the database password provided by the third-party system is changed

periodically, return to this page and click Edit to change the database
password correspondingly.

Step 3 Choose Resource > Stored Procedure and click  in the upper right
corner of the Stored Procedures tab page.

Step 4 Enter the basic information about the stored procedure.

● Stored Procedure: Enter a customized value based on the function of the
stored procedure.
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● Value: Enter the name of an existing stored procedure in the database.
● Database Connection: Select the database created in 2.

Step 5 Click the Input Parameter tab. Click Add and configure the input parameters of
the stored procedure one by one.

The input parameters of a stored procedure are usually in the same line as
CREATE PROCEDURE and are identified by IN. For example, four input
parameters are defined in the following stored procedure definition, where
varchar corresponds to the Character data type in the system.

CREATE PROCEDURE p_modify_column_name (in tableName varchar(128), in oldName varchar(128), in 
newName varchar(128), in incolumnType varchar(128))

Step 6 Click the Output Parameter tab. Click Add and configure the output parameters
of the stored procedure one by one.

Step 7 Click .

----End

2.6.2.4.3 Creating Work Calendar Templates

A tenant administrator can create a work calendar template to directly reference it
in the Time Selection diagram element to reduce the workload.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose Resource > Work Calendar and click .

Step 3 Configure work calendar information.
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Figure 2-107 Add Work Calendar

● Work Calendar Name: (Mandatory) Field displayed in the Time Selection
diagram element. The value must be unique and can contain a maximum of
128 characters, including only letters, digits, spaces, underscores (_), and
single quotation marks (').

● Description: (Optional) The value can contain a maximum of 2048
characters.

● Week Selection: (Mandatory) At least one day must be selected. After a day
is selected, it is regarded as a working day.

● Service Period: (Mandatory) 1 to 10 service periods must be configured. This
parameter is used with Week Selection, both of which are mandatory.

● Specified Non-service Date: (Optional) A maximum of 50 records are
allowed. After a date is specified as a non-service date, it is regarded as a
non-working day. This parameter has the highest priority. If a date is specified
as both a non-service date and a service date, it is regarded as a non-service
date.

● Specified Service Date: (Optional) A maximum of 50 records are allowed.
This parameter is used to specify service dates that are not within the working
days specified by Week Selection. After a date is specified as a service date, it
is regarded as a working day.

Step 4 Click Confirm to save the information.

Step 5 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 6 Choose Flow > Orchestration and add a flow. The created work calendar
template can be referenced in the Time Selection diagram element.
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Figure 2-108 Time Selection diagram element

----End

2.6.2.4.4 Adding Data Tables

If customized data is required in a flow, you can add a customized data table and
then add or import data to it. When editing a flow, you can use the Data Table
diagram element to use data in a customized data table.

Procedure
Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose Resource > Data Table and click . The Adding a Data
Table dialog box is displayed.

Step 3 Enter basic data table information.

Figure 2-109 Adding a Data Table
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● Table Name: Enter a globally unique table name. The value can contain a
maximum of 64 characters.

● Table ID: Enter a globally unique table ID. The value can contain a maximum
of 32 characters, including letters, digits, and underscores (_), and cannot
start with a digit.

● Description: Enter a table description. The value can contain a maximum of
255 characters.

Step 4 Click . The Adding a Table Field dialog box is displayed.

Step 5 Enter basic table field information.

Figure 2-110 Adding a Table Field

● Field ID: Enter a unique field ID in the data table. The value can contain a
maximum of 32 characters, including letters, digits, and underscores (_), and
cannot start with a digit.

● Field Name: Enter a unique field name in the data table. The value can
contain a maximum of 64 characters.

● Field Type: Select a field type. The options are Character, Integer, and
LogTime.

● Field Length: Enter a field length. The total length of all fields cannot exceed
10,000 characters. This parameter needs to be set only when Field Type is set
to Character or Integer.
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● Default Value
– When Field Type is set to Character, enter a maximum of 255 characters

as the default value.
– When Field Type is set to Integer, enter an integer as the default value.
– When Field Type is set to LogTime, select a date as the default value.

● Description: Enter a field description. The value can contain a maximum of
255 characters.

● Encrypted: Determine whether a field needs to be encrypted for storage.

Step 6 In the Adding a Table Field dialog box, click Confirm to save the table field.

Step 7 In the Adding a Data Table dialog box, click Confirm to save the data table.

Step 8 Click Data to add table data.

Figure 2-111 Data

Step 9 Click Add to add data.

Figure 2-112 Add Data

Step 10 In the Add Data dialog box, click Save to save the data.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 318



Step 11 Click Edit to edit data.

Figure 2-113 Edit Data

Step 12 Click Delete. In the Confirm deletion dialog box, click . The data is
deleted successfully.

----End

2.6.2.4.5 Adding Domains

A domain is considered as an independent task-oriented robot, which recognizes
and replies to a group of intentions.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Semantic
Understanding.

Step 2 Choose Knowledge Management > Domain Management, and click Create.

Step 3 Set Name and Language, and click Save.
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Figure 2-114 New Domain

Step 4 Save the settings and click Active in the Status column to activate the domain.

----End

NO TE

How to divide domains?

A domain is considered as a robot that handles a business. Therefore, domains are usually
divided based on business scenarios. For example, the telecom field can have call fee query,
service provisioning, and other robots.

2.6.2.4.6 Adding Entities

Entities are variables or parameters, which can be used to configure multiple
dialogs of a task-oriented robot to recognize specific customer purposes. They can
also be used to temporarily store parameter values in interfaces for future
calculation. For example, when a customer needs to purchase a flight ticket, you
need to know the departure city, destination city, departure time, and flight
company for the flight. The departure city, arrival city, departure time, and flight
company can be considered as entities.

Context

Entities can impose specification constraints on the values filled in a slot, similar
to defining data types for variables. Some entities are preset, such as system.date,
system.time, system.number, and system.phonekeyboard. You can view entities
on SYSTEM ENTITY and ENVIRONMENT ENTITY (by choosing Template
Management > Entity Management). You can also click Test Entity under My
Entity to check whether the variables that you need can be recognized. If the
preset entities do not meet your requirements, customize your entities. Customer
entities are classified into the following types:

● General entity: entity corresponding to a single variable. For example, a
departure city, a destination city, and a flight company are general entities.
For customized general entities, only enumerated values and their synonyms
can be set. Complex functions such as fuzzy match cannot be implemented.

● Composite entity: combination of multiple entities. For example, an identity
entity, a city entity, a region entity, and a street entity form a mailing address
entity together. Composite entities are usually used to define complex and
structured texts.
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● Rule entity: entity that defines a fixed format (prefix and suffix), and part-of-
speech rules. When a type of entity has fixed features in sentence expressions,
for example, all entities have the same prefix or suffix, you can define a rule
entity to expand the capture range of this entity.

During the application of an entity, the system matches the entity values with
customer statements. If the matching is successful, the system considers that the
entities are contained in the customer statements and uses the entity values for
subsequent processing.

Configuring a General Entity
To add a flight company entity, perform the following steps:

Step 1 Choose Configuration Center > Chatbot Management > Semantic
Understanding.

Step 2 Choose Knowledge Management > Entity Management. Click Create, and
choose General entity.

Step 3 Set Name, click Create to add entity values and their synonyms, and click Save.

Step 4 Click Test Entity in the upper right corner, and enter an entity value or synonym
in the text box. If the AI robot returns @Flight Company=Emirates, the
configuration takes effect.
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----End

Configuring a Composite Entity
You need to add a location entity that indicates the direction and distance, for
example, 100 meters eastwards.

Step 1 Choose Configuration Center > Chatbot Management > Semantic
Understanding.

Step 2 Choose Knowledge Management > Entity Management. Add a general entity
that indicates a direction by referring to Configuring a General Entity. A direction
entity includes four elements: East, West, South, and North.

Step 3 Click Create, and choose Composite entity.

Step 4 Set Name, and click .

Step 5 Configure a composite entity.

1. Select the entity added in 2 from the drop-down list.

2. Click  to add the second drop-down list, and select
@system.number (indicating a number) from the drop-down list.

3. Click  to add the third drop-down list, hover the pointer over the

drop-down list, click  next to the drop-down list to switch from the entity
selection mode to the text input mode, and enter Meter.
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Step 6 Click Save.

----End

Configuring a Rule Entity
You need to add a rule entity to identify a company name entity of XXX Co., Ltd.

Step 1 Choose Configuration Center > Chatbot Management > Semantic
Understanding.

Step 2 Choose Knowledge Management > Entity Management. Click Create, and
choose Rule entity.

Step 3 Set Name.

Step 4 Set parameters as follows:

A rule supports the following filtering of a character string:

● If both Part-of-speech and Suffix are set, the character string that meets the
part-of-speech requirement is obtained after the suffix is matched. The length
of the character string cannot exceed the value of Maximum length.
In addition to common adjectives, nouns, numbers, and quantifiers, special
nouns are further classified into the following types.
– Gerund: If you use phrases that can be used as verbs to compose the

name of an entity, for example, XX Daily Wholesale Co., Ltd., you can set
Part-of-speech to Gerund to better match the entity.

– Localizer: Without the prefix and suffix, the remaining characters indicate
a localizer such as front, back, upper, and lower.
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– OU name: Without the prefix and suffix, the remaining characters
indicate an OU group.

– Place name: Without the prefix and suffix, the remaining characters
indicate a city and province.

● If Part-of-speech is not set, characters between the prefix and suffix are used.
The length cannot exceed the value of Maximum length.

Exact Matching determines whether the prefix and suffix are used for
matching.

Include Prefix In Entity Result and Include Suffix In Entity Result
determine whether information corresponding to the prefix and suffix is used
as the entity content. For example, in this example, Include Suffix in Entity
Result needs to be enabled. The matched entity is XX Co., Ltd.

Step 5 Click Save.

----End

2.6.2.4.7 Adding Sensitive Words

Sensitive words are configured to check customer input. If the customer input
contains a sensitive word, the robot receives a sensitive word triggering event for
further processing.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Semantic
Understanding.

Step 2 Choose Knowledge Management > Entity Management and click the Sensitive
Word tab.
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Step 3 Click  in the category area on the left to add a category for sensitive words,
for example, Forbidden Words, and click Save.

Step 4 Select the new category on the left and click Create on the right to add sensitive
words. Press Enter to add multiple records.

----End

2.6.2.4.8 Adding Knowledge Gray Rules

The system supports the configuration of knowledge gray rules to restrict users
who use intentions. You can configure a group of usernames. After an intention is
associated with a knowledge gray rule, the intention can be accessed only by users
configured in the gray rule.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Semantic
Understanding.

Step 2 Choose System Management > Knowledge Gray Rule. Click Create.

Step 3 Set Name and click Confirm.

Step 4 Click the number in the Quantity column. In the Manage Blocklist/Trustlist

dialog box, click  to add a customer name. To enter multiple customer

names, press Enter after each record to add them. Click .
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Step 5 Choose Knowledge Management > Intention Management and click Not Set
corresponding to the intention to be associated.

Figure 2-115 Setting gray rules

Step 6 Click Create, select knowledge rules, and click .

----End

2.6.2.4.9 Managing Models

A tenant administrator can manage models.

Step 1 Sign in to the AICC as a tenant administrator.

Step 2 Choose Configuration Center > Chatbot Management > Semantic
Understanding > System Management > Model Management.

Step 3 Click Create and set Name, Language, Model Type, and Description.
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Figure 2-116 Add Model

Step 4 Click Save.

----End

2.6.2.4.10 Managing Robot Test Cases

You can maintain commonly used sentences in test cases, and periodically execute
the test cases to verify that a robot can respond properly.

Prerequisites
You have configured the dialog flow and robot by referring to 2.6.2.2 Configuring
an Appointment Chatbot (Task-oriented Robot).

NO TE

What are the benefits of managing test cases?
You can test conversations in batches with automated texts to verify that the robot's
responses meet expectations, and to reduce the workload of verifying that the corpus is
correct.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Semantic
Understanding.

Step 2 Choose Training Check > Knowledge Test. Click Create.

Step 3 Enter a test case group name, for example, Ticket Booking Chatbot, select a
robot, and set the calling number.
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Step 4 Click Save.

Step 5 Click the link in the Test Cases column corresponding to the new test case group.
The Manage Test Case page is displayed.

Step 6 Click Create and enter the case name.

Step 7 Click Manage Case Details. The details page is displayed.

Step 8 Click Add and set the parameters.

NO TE

If a large number of questions need to be tested, click Download Template to obtain a
batch template, enter test case information in the template, and click Import to add test
cases in batches.

Step 9 Click Confirm. On the Add Test Case page, click Save.

Step 10 On the Manage Test Case page, select the desired test case and click Execute
Test.

The system then automatically executes the test case in the activated domain and
generates the test result.

----End

For a failed case, you can click Call Details to view the actual response text or
click the flow link in the Flow Track column to view the session track.
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2.6.2.4.11 Reviewing a Historical Message

The OIAP records historical sessions to the table of a corresponding time period at
an interval (24 hours by default) specified by History Dialog Table Division
Interval. You can query the session records in a specified time period, and process
historical messages.

On the Historical Message Review page, intention matching is recorded. If an
error occurs in intention matching, check the contents recognized by automatic
speech recognition (ASR), and the command words matched by the intention.

Step 1 Choose Training Check > Historical Message Review.

Step 2 Select a time period, and click Query. Generally, select the first record, which
indicates the latest one.

In the search criteria, you can also query a session based on Status (whether the
intention is successfully matched), Start Time, End Time, Access Identifier, and
Subscriber Number.

Step 3 Click Subscriber Number, and view the action that matches the current intention,
as shown in the following figure.

In the preceding instance where Access Code is 110112, if a customer enters (or
says) 4 Persons, Identified Intention is completely matched, and the intention
returns 4 in Response text and NUMBER as the command word.

Step 4 Perform the following operations for an intention that is not identified or correctly
matched:

Add unidentified texts (or events), or incorrectly identified texts (or events) as
corpora to the existing intentions.

Create unidentified texts (or events), or incorrectly identified texts (or events) as
corpora to the new intentions.
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The following describes how to add them to an existing intention:

1. Click Request text.
2. Select Add To Existing Intention.
3. Select a domain or enter a domain name, and click Query.
4. Click + next to the intention to which a corpus needs to be added.
5. On the page that is displayed, select Corpus, and check whether the new

corpus is listed.
6. Click SAVE.
7. Go to the Domain page, and click Train for the configuration to take effect.

----End

2.6.2.4.12 Processing a Question Clustering Task

Perform a question clustering analysis periodically on sessions in a specified time
period, and collect statistics on subscriber questions and their occurrence
frequencies in the time period for corpus analysis.

Step 1 Choose Training Check > Question Clustering Task.

Step 2 Click Start, set Start Time and End Time, and click START.

NO TICE

Ensure that the selected time period contains session records that can be used for
analysis.
After the subscriber list is imported, the clustering task analyzes only the session
records corresponding to the number.
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Step 3 Set the time period to be queried in the search criteria, and click Query.

Step 4 Click the task link, and view the analysis.

You can click Frequency to sort the questions by the number of times they occur.

Step 5 Click the question link, and check whether to add the question to the intention as
a corpus.

You can click New General Intention or Add to Existing Intention to add the
question as a corpus.

Step 6 Click  next to the question, and set Status. For example, set this parameter to
Marked.

Step 7 Return to the question list, and click  next to the main task. If Status is set to
Marked, the task is completed.

----End
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2.6.2.4.13 Setting Intelligent Engine Parameters

Configuration personnel can modify system parameters and intention parameters
of the current tenant as required. However, the modification of these parameters
will affect services. Therefore, ensure that you understand the parameter functions
before performing operations.

Procedure

Step 1 Choose Configuration Center > Flow Configuration > > Intelligent IVR. The
Intelligent IVR Management page is displayed.

Step 2 Choose System Management > Intelligent Engine Parameter. On the System
Parameters tab page, click Edit in the row that contains the parameter to be
modified, select a variable value, and click Save.

Step 3 On the Intention Parameters page, select the language to be modified, modify
the parameters to be modified, and click Save.

----End
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2.6.2.4.14 Managing the Call History

Tenant administrators can query and manage historical customer service call
records.

Querying the Call History

An agent can view historical calls and their details.

Prerequisites

You have contacted the tenant space administrator to choose Configuration
Center > Chatbot Management > Flow Configuration > System > System
Settings > System Settings and set CHATRECORDFLAG to Enable.

Figure 2-117 Setting CHATRECORDFLAG

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose System > Historical Call and click the Call History tab.

Step 3 Set at least one of the time range and calling number as the search criterion.

Step 4 Click Search to search for all records that meet the criterion.

Step 5 Click Call Details to view the details of a single call record.

NO TE

After the tenant space administrator enables the intelligent IVR recording parameter
FLOWRECORDFLAG in the system settings, sys_err may be displayed in the call record
details after a user hangs up, which does not affect services.

----End

Querying the Call Statistics Dashboard

An operator can view robot call statistics, including the number of inbound calls,
number of calls disconnected without consulting the robot, number of calls
transferred to agents without consulting the robot, number of calls that consult
the robot without transferring to agents, number of calls transferred to agents
after consulting the robot, net self-service resolution rate of the robot, number of
dialog rounds, average number of dialog rounds, total number of interface
invocations, number of successful interface invocations, and interface invocation
success rate.
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Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose System > Historical Call and click the Call Statistics Dashboard tab.

Step 3 Set the search criteria.
● If you select By hour, the date and access code are mandatory.
● If you select By day, the access code is mandatory.

Step 4 Click Search.

NO TE

By hour: The hourly statistics of the access code on the specified day are queried.
By day: The daily statistics in the last 30 days are queried.

----End

Querying the Service Capability Dashboard

An operator can view robot service capability statistics, including the total number
of replies, number of successful replies, number of unknown replies, success reply
rate, total amount of feedback, amount of satisfied feedback, and satisfaction
rate.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose System > Historical Call and click the Service Capability Dashboard tab.

Step 3 Set the search criteria.
● If you select By hour, the date and access code are mandatory.
● If you select By day, the access code is mandatory.

Step 4 Click Search.

Figure 2-118 By hour
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Figure 2-119 By day

NO TE

By hour: The hourly statistics of the access code on the specified day are queried.

By day: The daily statistics in the last 30 days are queried.

----End

Querying the Knowledge Dashboard

An operator can view the robot knowledge statistics, including the valid
knowledge statistics and hit knowledge distribution.

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose System > Historical Call and click the Knowledge Dashboard tab.

Step 3 Set the search criteria.
● If you select By day, the date is mandatory.
● If you select Last 30 days, data in the last 30 days is queried.

Step 4 Click Search.

Figure 2-120 By day
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Figure 2-121 Last 30 days

NO TE

By day: The statistics of the specified day are queried.

Last 30 days: The total statistics of the last 30 days are queried.

----End

2.6.2.4.15 Viewing Flow Analysis

You can collect statistics on the IVR key usage through flow analysis, which
provides data reference for subsequent IVR hot key analysis and menu analysis.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose System > System Settings, click the Flow Analysis Settings tab, and add
the robot access code to be analyzed.

Figure 2-122 Access Code Settings

Step 3 Run the robot. The branch execution statistics of the flow are collected by hour.

----End
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2.6.2.4.16 Checking Flows

You can check the usage of composite diagram elements, business interfaces,
stored procedures, gray rules, resource templates, global variables, and flows
variables in all flows.

Procedure

Step 1 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 2 Choose Flow > Flow Check and click  to obtain the latest statistics.

Figure 2-123 Flow Check

Step 3 Click the Never Used sector or legend in the pie chart to view details about
unused resources.

----End

2.6.2.4.17 Adding Gray Rules

A gray rule defines the adaptation rules for customer numbers in a number
segment by configuring the start number and end number. After a gray rule is
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configured, it takes effect only after it is associated with a published IVR flow.
When a voice call is transferred to an IVR flow, calls that meet the gray rules will
be automatically transferred to the corresponding gray release flow.

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Chatbot Management > Flow Configuration > System.

Step 2 Choose Gray Rule. The rule configuration page is displayed.

Figure 2-124 Gray rule list

Step 3 Click . The dialog box for adding a rule is displayed.

Figure 2-125 Adding a gray rule

● Rule Name: name of a rule. The value can contain a maximum of 128
characters and cannot contain special characters.

● Begin Number and End Number: strings of a maximum of 32 digits. The
number of digits in the start number must be the same as that in the end
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number, and the end number must be greater than or equal to the start
number.

Step 4 Click Complete to save the rule configuration.

Step 5 (Optional) In the gray rule list, click a rule record to expand the rule. You can view
the flow information bound to the current gray rule. You can perform the
following operations on gray rules:
● Click Edit corresponding to a gray rule to modify the rule information.
● Click Delete corresponding to a gray rule to delete the rule.
● Click View References corresponding to a gray rule to view the flows bound

to the rule.

NO TE

Gray rules that have been used in flows cannot be deleted.

----End

2.6.2.4.18 Configuring 2D Virtual Humans

A tenant administrator can configure virtual humans to select one when
configuring the Avatar Reply diagram element in an IVR flow later.

Prerequisites
● The 2D Digital Man feature has been enabled.

● The Intelligent IVR feature has been enabled.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Chatbot Management > Flow Configuration > Resource.

Step 2 Choose Virtual Human. The Virtual Human page is displayed.
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Figure 2-126 Virtual Human

Step 3 Click . The Create Virtual Human page is displayed.

Figure 2-127 Create Virtual Human

● Name: Enter a name. The value can contain a maximum of 64 characters and
cannot contain special characters.

● Description: Enter a description. The value can contain a maximum of 255
characters and cannot contain special characters.

● Role: Select a role for the virtual human. To add role data, contact the system
administrator.

● Background: Upload a background image corresponding to the role
resolution.

● Positioning: Select a positioning setting mode.
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a. Position template: If this option is selected, you need to select a
template.

b. Precisely adjust: You can drag the virtual human to accurately adjust the

positioning. Hover the pointer over the virtual human. When  is
displayed, hold down the left mouse button, keep the pointer in the
image, and drag the virtual human to adjust the positioning.

● Image Ratio: Set the ratio of the virtual human image to the original image.

Step 4 Click Save to save the configuration.

Step 5 (Optional) In the 2D virtual human list, you can perform the following operations
on a 2D virtual human:
● Click Edit to edit the 2D virtual human.
● Click Delete to delete the 2D virtual human.

----End

2.6.2.4.19 Configuring the SmartCare Intelligent Robot

Scenario Description
When a network fault occurs in some regions or cells of a carrier's system,
customers may need to call the carrier's service hotline for consultation or
complaint. The AICC and SmartCare integration aims to improve user experience
and help voice agents and case agents process their own services, thereby
reducing the user complaint rate and improving the user satisfaction with carrier
services.
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Business Process

Figure 2-128 SmartCare intelligent robot scenario

Configuring an Intelligent IVR Flow

Procedure

Step 1 Sign in to the AICC as a system administrator and choose Configuration Center >
Chatbot Management > Flow Configuration > System > Trustlist.

Step 2 Click Create. On the page that is displayed, add the IP address and port number
for invoking the SmartCare API to the whitelist of the corresponding tenant space.
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Step 3 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Chatbot Management > Flow Configuration.

Step 4 Choose Resource > Business Interface and click Create. The Add Business
Interface Configuration page is displayed.

1. Configure the SmartCare API for querying users with common issues.

a. Basic information: request URL: https://{IP}:{PORT}/apiaccess/CC-
Management/v1/smartcare/queryfaultyuser

b. Message header example:
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x-app-key:9******************************3  
Authorization:Bearer e******************************e  
Content-Type:application/json

c. Message body example:
{
"msisdn": "${msisdn}",
"faultTime": "${faultTime}",
"complaintScene": "${complaintScene}",
"backtraceDuration": "${backtraceDuration}",
"sessionID": "${sessionID}",
"queryFlag": "${queryFlag}"
}
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d. Output parameter:

2. Configure the SmartCare quick fault demarcation API.

a. Basic information: request URL: https://{IP}:{PORT}/apiaccess/CC-
Management/v1/smartcare/submitquickdelimit

b. Message header: Authorization and x-api-key
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c. Message body example:
{
"msisdn": "${msisdn}",
"startTime": "${startTime}",
"endTime": "${endTime}",
"locale": "${locale}",
"scene": "${scene}",
"longitude": "${longitude}",
"latitude": "${latitude}",
"radius": "${radius}"
}
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d. Output parameter: taskId of the demarcation task

3. Configure the SmartCare API for quick demarcation result query.

a. Basic information: request URL: https://{IP}:{PORT}/apiaccess/CC-
Management/v1/smartcare/queryquickresult

b. Message header: Authorization and x-api-key
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c. Message body:
{
"taskId": "${taskId}"
}

d. Output parameter: rootcause returned by the API
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Step 5 Choose Configuration Center > Chatbot Management > Flow Configuration >
Flow > Orchestration and click Create. The Create Flow page is displayed.

1. Create a flow.

2. Edit the IVR flow.

a. IVR flow configuration overview:
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b. Configure the start diagram element, as shown in the following figure.

c. Configure the token query API diagram element, as shown in the
following figure.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 350



CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 351



d. Configure the diagram element of the SmartCare API for querying users
with common issues. (By default, the fault time is the current system
timestamp, and the MSISDN is the calling number.)
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e. Configure the branch judgment diagram element, as shown in the
following figure.

f. Configure the robot reply diagram element, as shown in the following
figure.
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g. As shown in the following figure, you can use the Variable assignment
diagram element to set the fault start time for query. (The start time is
the system time minus one day.)
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h. Configure the SmartCare quick fault demarcation API, as shown in the
following figure.
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i. Configure the robot reply diagram element, as shown in the following
figure.

j. Configure the SmartCare API for quick demarcation result query, as
shown in the following figure.
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k. Configure the branch judgment diagram element, as shown in the
following figure.

l. Configure the variable assignment diagram element, as shown in the
following figure.
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m. Configure voice playback for troubleshooting suggestion result
processing, as shown in the following figure.
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----End

Testing the Intelligent Robot

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Chatbot Management > Flow Configuration > Intelligent Chatbot, and click
Create.
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● Chatbot Name: Enter a user-defined name, for example, SmartCare
intelligent robot.

● Dialog Type: Select a robot.
● Flow Name: Select the flow created in step Step 5.

Step 2 Click Save. The intelligent robot is created successfully.

Step 3 Click Test Call to start the call verification process.

----End
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2.6.2.5 Reference

This section describes the references, including the diagram element reference,
parameter reference, and TUC interface reference, in an intelligent IVR flow.

2.6.2.5.1 Diagram Elements

The ODFS provides diagram elements for configuring a flow. You can drag a
diagram element to the canvas on the right or click a diagram element to use it
on the canvas.

NO TE

What are the tips for drawing a flowchart?

● When dragging a diagram element, observe the line between the new diagram element
and the existing one on the canvas, and align the diagram elements based on the tips.

● Drag a diagram element to the canvas, and then click to drag it.

● In a diagram element, a cache object cannot be duplicate. The cache variable name
must be unique. Otherwise, the latest cache variable name is used.

Start

This diagram element is used to mark the beginning of a flow.

Diagram Element

Parameter Description
● Node Name: name of a node.

● Description: details of a node.

Using the Diagram Element

You do not need to add this diagram element. By default, it is available in a new
flow. A flow can have only one Start diagram element.

Typical Application Scenario

None

Robot Reply

This diagram element is used to respond to customers in the IVN. It is used to play
voices to customers in a flow.
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Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Reply Way: The options are Static voice, TTS, Video, Multimedia, Card,

Voice and text, Variable voice, and WhatsApp Interactive Messages.

NO TE

Currently, variable voices do not support recording in IVR flows.

– Static voice: The voice file on the voice file server is played directly. This
type is used in scenarios where the context is unchanged. Make sure that
the voice file exists on the UAP file server.

– TTS: The configured text is provided for the TTS for conversion and
playback. Variables can be added to the reply text, and the TTS
dynamically plays a voice based on the return values of the variables.

– Video: name of a video file on the file server.
– Multimedia: The configured multimedia information is provided for the

corresponding player through a channel gateway. This option is displayed
only in the integration environment.

– Card: The configured card information is provided for a channel gateway
for playback. This option is displayed only in the integration environment.

– Voice and text: Voice files and texts are combined and then played.
– WhatsApp Interactive Messages support interaction between robots

and WhatsApp.
– Variable voice: Set Language, Type, and Reply Variable to dynamically

play a UAP voice package.

i. Language: Multiple languages are available.
ii. Type: Select a voice playback type. The options are Phone number,

Number, time(hh:mm:ss), Date(yyyymmdd), and Price.
● Reply Source: source of the voice content to be played. The options are Reply

Template, Reply Variable, and Reply Resource.
● Reply Template: This parameter is displayed when Reply Source is set to

Reply Template. Select a content template configured on the Configuration
Center > Chatbot Management > Flow Configuration > Resource >
Resource Template page.

a. If Reply Way is set to Multimedia and Reply Template is set to Plain
Text, the corresponding parameter values are displayed. To set the plain
text content, choose Configuration Center > Resource Management >
Multimedia Library > Plain Text.

b. If Reply Way is set to WhatsApp Interactive Messages, only the
WhatsApp interactive message template configured under Resource >
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Resource Template can be used as the reply template. To set the
template content, choose Configuration Center > Resource
Management > Multimedia Library > Card Template > WhatsApp
Interactive Messages. Then, the parameter values to be set are displayed
on the right.

c. The parameter values in the reply template must be enclosed in
quotation marks, as shown in the following figure.

Figure 2-129 Variable value

● Reply Variable: This parameter is displayed when Reply Source is set to
Reply Variable. Select a reply variable.

a. If Reply Way is set to Voice and text, set this parameter in {Recording
file URL}~${Text}$~{Recording file URL}~${Text}$ format, for
example, /xxx/xx1.wav~$abc$~/xxx/xx2.wav. In the format, {Text}
cannot contain variables. The value can contain a maximum of five voice
and text records.

b. When Reply Way is set to Static voice, set this parameter in the {Voice
file URL} format, for example, /xxx/xx1.wav.

● Reply Resource: This parameter is displayed when Reply Source is set to
Reply Resource. Select a resource configured on the Configuration Center >
Resource Management > Audio and Video or Configuration Center >
Resource Management > Multimedia Library page.

● Reply Mode: This parameter is mandatory. The options are as follows:

– Playback only: Only the voice or video is played, and customer input
does not need to be received. Generally, this option is selected for static
voice playback.

– Interruption recognition: The customer needs to answer by voice.
Generally, this option is selected for replying to text.

– Interruption by key presses: The keys pressed by the customer need to
be obtained. If Reply Mode of the Robot Reply diagram element is set to
Interruption by key presses and the key interaction result needs to be
obtained, the Robot Reply diagram element cannot be directly connected
to the Call Ending diagram element, and the Key Recognition and
Semantic Recognition diagram elements cannot be directly connected
before the Call Ending diagram element.

– Recognition and key presses: Both voice and key information can be
received. The information received first is used for matching.
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– Recognition after playback: The system starts to identify the voice or
video only after the voice or video is played. If a customer speaks during
the playback, the system does not receive the voice.

– Recognition and key presses after playback: The system starts to
identify the voice or video and collect digits only after the voice or video
is played. If a customer speaks or presses a key during the playback, no
information can be received. If a customer speaks or presses a key after
the playback, the information that is received first is used for matching.

– No interruption after digit collection: Keys can be pressed when the
voice or video is played, but the playback is not interrupted.

– Custom Variable Value: whether voice playback can be interrupted. If
voice playback can be interrupted, set Minimum Voice Playing Duration.
String true -- Voice playback can be interrupted during recognition, and
the minimum voice playback duration can be passed.
String false -- Recognition is performed after voice playback.

● Timeout Interval: timeout period, in seconds. If this parameter is not set, the
default value 15 is used. If the duration exceeds the value of this parameter,
the system determines that timeout occurs. The value range of this parameter
varies with vendors. Currently, the maximum value is 180.
– If Reply Mode is set to Recognition after playback, the duration starts

from the time when the TTS voice playback ends to the time when the
recognition stops.

– If Reply Mode is set to Interruption by key presses or Interruption
recognition, the duration starts from the time when the voice playback
ends. For example, if a customer does not speak after the TTS voice
playback ends, the robot goes to the next diagram element when the
timeout period ends.

– If Reply Mode is set to Playback only, the timeout period does not take
effect.

NO TE

Pay attention to the setting of the timeout period in the following scenarios: long TTS
voice playback, many keys (such as an ID card) to be pressed by a customer, and
many opinions to be said by a customer. When Reply Mode is set to Interruption by
key presses or Interruption recognition, if the timeout period is short, the
recognition may start before the voice playback ends, or the recognition may end
before the customer completes key pressing. If the timeout period is long, there may
be a long-time silence after the customer completes key pressing, and a timeout
notification is displayed after a long time.

Robot Message Reply Timeout Processing
– waitFlag: session identifier. If the value of timeout is less than the

remaining timeout period of the current session, the value of waitFlag is
true. Otherwise, the value is false.

– waitTimeout: message timeout period.
– waitBeginTime: When the value of waitFlag is true, the value of

waitBeginTime is set to the current time.
– When the value of waitFlag is true, reply timeout is processed. When the

value of waitFlag is false, the original message processing logic is used.
– Processing logic: After a message times out, the CC-Messaging triggers

the timeout flow and pushes the robot response to the customer.
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● Extended Parameter: Enter data required by the IVR, for example, the
provider information. The value is sent back to the IVR using the vendor
parameter of the dialog interface. This interface is available only to the Robot
Reply diagram element in historical flows. If an old flow uses this parameter,
you are advised to enter the value of this parameter in the ASR Extended
Parameter text box.

● Number of Collected Digits: maximum number of collected digits in the IVR
system. This parameter is displayed when Reply Mode is set to Interruption
by key presses, Recognition and key presses, or No interruption after digit
collection.

● Digit collection timeout: Timeout interval for pressing a key. For example, if
this parameter is set to 2 seconds, the flow proceeds when the key pressing
interval exceeds 2 seconds, even though the number of collected digits does
not reach the specified value.

● Cancel Key: whether to use the star key (*) as the cancel key during IVR digit
collection. This parameter is displayed when Reply Mode is set to
Interruption by key presses, Recognition and key presses, or No
interruption after digit collection.

● Confirm Key: whether to use the pound key (#) as the confirm key during
IVR digit collection. This parameter is displayed when Reply Mode is set to
Interruption by key presses, Recognition and key presses, or No
interruption after digit collection.

● TTS Advanced Settings: Enable or disable this function. By default, this
function is disabled.

● Voice: The options are Male, Female, and Custom Sound Effect. The default
value is Female. This parameter is configurable when TTS Advanced Settings
is enabled.

● Voice Speed: The options are Slow, Medium, Fast, and Custom Speed. The
default value is Slow. This parameter is configurable when TTS Advanced
Settings is enabled.

● Default Values for Extended TTS Parameters.: Enable or disable this
function. By default, this function is disabled.

● TTS Extended Parameter: Enter the data required by the TTS business on the
IVR side, for example, the vendor information. The value is sent back to the
IVR using the ttsMRCPVendor parameter of the dialog interface.

Extended parameter of the TTS server. Set this parameter based on the
requirements of the TTS server vendor. The values of speed, pitch, volume,
and voice_name can be GLOBAL and FLOW variables of the character type
or any character string. If the value of a variable is not within the standard
range, the default value is used.

The default values and format requirements are as follows:
speed=GLOBAL.ttsSpeed;pitch=GLOBAL.ttspitch;volume=GLOBAL.ttsVolume;voice_name=GLOBAL.voice
Name;

a. The value of speed ranges from –500 to 500. The default value is 0.

b. The value of pitch ranges from –500 to 500. The default value is 0.

c. The value of volume ranges from 0 to 100. The default value is 50.

d. The default value of voicename is cn_kefuman_common.
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NO TE

● To use the TTS function, you need to contact the system administrator to sign
in to the AICC, choose Configuration Center > Chatbot Management >
Flow Management > System > TTS/ASR, and configure a TTS server for your
tenant space.

● To set the default values of extended parameters of the TTS server, contact
the tenant administrator to sign in to the AICC and choose Configuration
Center > Chatbot Management > Flow Configuration > Resource >
Variable > Built-in Variable.

● ASR Advanced Settings: Enable or disable this function. By default, this
function is disabled.

● Recognition Type: The option is Common. The default value is Common.
This parameter is configurable when ASR Advanced Settings is enabled.

● Subscriber Silence Timeout Interval: The default value is 100, in seconds.
The value ranges from 0 to 32000. This parameter is configurable when ASR
Advanced Settings is enabled.

● Recognition Timeout Interval: The default value is 200, in seconds. The
value ranges from 0 to 600. This parameter is configurable when ASR
Advanced Settings is enabled.

● Subscriber Pause Timeout Interval: The default value is 500, in milliseconds.
The value ranges from 300 to 2000. This parameter is configurable when ASR
Advanced Settings is enabled.

● ASR Extended Parameter: Enter the data required by the ASR business on
the IVR side, for example, the vendor information. The value is returned to the
IVR system using the vendor parameter of the dialog interface.

Using the Diagram Element
● Click the diagram element or drag it to the canvas. Before setting response

parameters, maintain the resource templates related to voice and video
resources, and then select a reply template that you has maintained in the
Service Parameter area.

● The Robot Reply diagram element is used by the robot in the email channel
to automatically reply to customers' emails. In this case, configure the
diagram element as follows:
– Set Reply Way to TTS.
– Set Reply Source to Reply Variable.
– Set Reply Variable to a global variable or a flow variable. The value of

the variable must be in the following format (use a comma as the
separator):
Auto reply email template ID,Personal email address

The auto reply email template ID can be created in Configuring
Notification Templates as an Administrator.

– Set Reply Mode as required.

Typical Application Scenario

The following describes how to use the Robot Reply diagram element to play a
welcome tone to customers.
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Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.

2. Click + in the Flow Variable area. In the dialog box that is displayed, set the
variable name and data type. The default value of the variable will be played
to the customer.

Figure 2-130 Adding a flow variable

Figure 2-131 Flow orchestration example

3. Save and publish the flow.

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot and click Test Call in the last column corresponding
to the robot. In the Test dialog box, click Start Call to test the robot. If the robot
automatically answers the variable value in the flow orchestration, the
configuration is successful.
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----End

Conversation Analysis

This diagram element is used to invoke a large language model workflow to
obtain the semantic recognition, sentiment analysis, and Q&A search results in
dialog content.

Diagram Element

Parameter Description
● Node Name: diagram element name which can be customized.
● Description: details of a node.
● Function: check box. The semantic recognition, sentiment analysis, and Q&A

search functions are provided.
● Conversation Content: request parameter for invoking the selected function.

If this parameter is left empty, the IVRREQUEST.input parameter is used by
default.

● Timeout Interval: timeout interval for invoking an API function, in seconds.
The value ranges from 1 to 60. The value of this parameter is the smallest
one among the value of the current parameter, the API invoking timeout
interval, and session timeout interval configured in the system. Default value:
5

● Extended Data: request parameter for invoking the selection function. This
parameter is a reserved extended field like call-associated data.
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● Result processing - Variable assignment: The content returned by the
diagram element is stored in the intent variable TOC.DialogAnalysis. Variable
assignment is supported. The value entered on the right is assigned to the
variable entered on the left.

Using the Diagram Element

This diagram element is used together with agent assistant services.

Typical Application Scenario

For details about how to use the conversation analysis diagram element, see the
archiving flow of 2.6.5.1.2 LLM-based Agent Assistant.

Subflow

This diagram element is used to transfer the current flow to the specified node of
another flow for execution.

Diagram Element

Parameter Description
● Node Name: name displayed on the diagram element, which can be

customized.

● Description: details of a node.

● Target Flow: code of a target flow. You can select an existing flow from the
drop-down list, including flows that are not published. This parameter is
mandatory.

● Target Node: ID of a target node. You can select a node in the selected flow
from the drop-down list. If this parameter is left empty, the flow is executed
from the Start node of the selected flow.

Using the Diagram Element

The Subflow diagram element is used to associate the flows that are split from a
long and complex flow. It is also used when all or part of the steps in other flows
can be reused. Note that it cannot pass parameters. To pass parameters, use a
composite diagram element.

Click the diagram element or drag it to the canvas, and select the desired subflow
and node.
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Typical Application Scenario
For details about how to use the Subflow diagram element, see Figure 2-133.
The typical application scenario of the Call Ending diagram element involves the
Subflow diagram element.

Call Ending

This diagram element is used to mark the end of a flow.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Invoked Interface: interface to be invoked. Select an interface added on the

Resource Management > Business Interface page.
● Start Time and End Time: start time and end time during which an interface

can be invoked. The configured interface will be invoked to execute related
tasks only in the specified time period.
The time format is HH:MM:SS. For example, if Start Time is set to 00:00:00
and End Time is set to 23:59:59, the configured interface is invoked when the
Call Ending diagram element is reached at any time of a day.

● Sending Interval: interval for invoking the interface, in days. The value is an
integer and cannot exceed 365. If this parameter is set to -1, the interface is
not invoked periodically. The invocation is triggered when the Call Ending
diagram element is reached at any time.

Using the Diagram Element
Click the diagram element or drag it to the canvas.

Typical Application Scenario
If you need to invoke a third-party interface to implement a specific business
when using the Call Ending diagram element, you can perform the following
operations to ensure that the Call Ending diagram element can be reached in any
case:

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and add a normal end flow that contains only
the Start and Call Ending diagram elements, as shown in the following
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figure. You do not need to configure the invoked interface for the Call Ending
diagram element.

Figure 2-132 Normal end flow

2. Save and publish the flow.
3. Choose Flow > Orchestration and add an actual business flow. Do not

directly connect a Call Ending diagram element as the last diagram element
of the flow. Instead, connect a Subflow diagram element to transfer the flow
to the normal end flow added in Step 2.1. In this way, the Call Ending
diagram element can be reached in any case, including after the flow is
transferred.

Figure 2-133 Actual business flow (Subflow diagram element)
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Figure 2-134 Actual business flow (Call Ending diagram element)

4. Save and publish the flow.

NO TE

When the flow execution passes through the Call Transfer diagram element and the
transfer is successful, the third-party interface configured in the Call Ending diagram
element is not invoked.

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Trace Settings and enable Calling
Number Tracing. Click Start Call to test the robot.

NO TE

If you do not set Calling Number before making a call, the default calling number
123456789 is used.

Step 5 Choose Flow Management > Flow Tracking and query the flow check result of
the test number. The following figure shows that the flow has reached the Call
Ending diagram element through the Subflow diagram element.
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Figure 2-135 Flow track log page

----End

Switching Between Voice and Video Calls

During a customer's call to the IVR, you can switch between voice and video calls.

Diagram Element

Parameter Description
The following figure shows the parameters of the Change Media diagram
element.
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The parameters are described as follows:

● Node Name: Enter a diagram element name.
● Media: Select a target media type. The options are Audio and Video.

Condition Branch Description

Table 2-74 Condition branch description

Condition
Branch

Description Usage

Switching
failure

Failure to
switch from a
voice call to a
video call or
from a video
call to a voice
call

Triggered upon a switching failure.

 

Typical Application Scenario
Voice and video calls need to be switched between each other when businesses
are handled for a customer. The corresponding media capabilities are used to
intuitively display businesses.
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Voice Playback
This diagram element is used to play a voice (for example, welcome voice) or
video segment without interacting with the customer. The system supports WAV
(8 kHz, 8 bits) voice files, TTS files, and video files.

Diagram Element

Parameter Description
The following figure shows the parameters of the Voice Playback diagram
element.

The parameters are described as follows:

● Node Name: Enter a diagram element name. The value can be customized.
● Voice Prompt: Select Voice, TTS, Video, or Variable voice. You can click an

option button to select a voice type.
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– Voice: Upload a voice file in WAV format. Currently, the UAP supports
only WAV (8 kHz, 8-bit) voice files.

– TTS: Generate a voice file in TTS mode. TTS channels must have been
configured. You can enable Advanced TTS settings to set voice playback

parameters. Click  in the drop-down list to select a sound effect and
speaking speed. If this function is disabled, Sound effect is set to Female
voice, Speaking speed is set to Low, and TTS extended parameter is
not set by default.

▪ Sound effect: Select the sound effect. The options are Male voice
and Female voice.

▪ Speaking speed: Select the speaking speed. The options are Low,
Medium, and High.

▪ TTS extended parameter: Set this parameter based on site
requirements. The value contains a maximum of 200 characters.

NO TE

To use the TTS function, you need to contact the system administrator to
sign in to the AICC, choose Configuration Center > Chatbot Management
> Flow Management > System > TTS/ASR, and configure a TTS server for
your tenant space.

– Video: Upload a video file in 3GP format, whose size must be less than or
equal to 5 MB.

– Voice File: The system filters approved voice files, TTS files, or video files
based on the selected voice type, and displays the files in the drop-down

list. You can click  and select a required file.
– Variable voice: Voices can be customized by setting the language, type,

and content.
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▪ Language: Select a voice playback language.

NO TE

If you select a non-Mandarin or non-English language for the variable voice,
contact O&M personnel to customize the syntax package and voice file.

▪ Type: Select a voice playback type. The options are Phone number,
Number, time(hh:mm:ss), Date(yyyymmdd), and Price.

▪ Content: Select the content defined by the global variable
(GLOBAL.*) or flow variable (FLOW.*).

NO TE

If Type is set to date or time, the format of the selected variable must be
consistent with that in the brackets.

● Click Save to save all parameters set on the current page.

Condition Branch Description

Table 2-75 Condition branch description

Condition
Branch

Description Usage

Voice
playback
failure

Failure to play
a voice, video,
TTS, or
variable voice

Triggered upon a playback failure.

 

Typical Application Scenario
● When a voice call is transferred to an IVR flow, the system plays the welcome

voice.
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● During execution of an IVR flow or when an IVR flow is about to end, the
system plays a voice prompt.

Voice Playback and Digit Collection

This diagram element is used to play a voice or video segment to interact with a
customer, for example, to play the voice "Please enter xx."

Diagram Element

Parameter Description
The following figure shows the parameters of the Play Voice & Collect Digit
diagram element.
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Figure 2-136 Play Voice & Collect Digit

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 382



Figure 2-137 Advanced Settings

The parameters are described as follows:

● Node Name: name displayed on the diagram element, which can be
customized.

● Voice Prompt: Select Voice, TTS, or Video. You can click an option button to
select a voice type.
– Voice: Upload a voice file in WAV format. Currently, the UAP supports

only WAV (8 kHz, 8-bit) voice files. You can click the text box and select a
voice file in the dialog box that is displayed. The options are approved
voice files of the current tenant.

– TTS: Generate a voice file in TTS mode. You can enable Advanced TTS

settings to set voice playback parameters. Click  in the drop-down list
to select a sound effect and speaking speed. If this function is disabled,
Sound effect is set to Female voice, Speaking speed is set to Low, and
TTS extended parameter is not set by default.
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▪ Sound effect: Select the sound effect. The options are Male voice
and Female voice.

▪ Speaking speed: Select the speaking speed. The options are Low,
Medium, and High.

▪ TTS extended parameter: Set this parameter based on site
requirements. The value contains a maximum of 200 characters.

– Video: Upload a video file in 3GP format, whose size must be less than or
equal to 5 MB.

● Voice File: The system filters approved voice files, TTS files, or video files
based on the selected voice type, and displays the files in the drop-down list.

You can click  and select a required file.
● Received Digits: This area displays parameters used to receive the external

input.
– Max. number of digits received: maximum number of input digits that

can be received. The default value is 24. If this parameter is set and the
number of digits entered by a customer reaches the maximum value, the
system automatically goes to the next step.

– Save user input: parameter for carrying information required by the
diagram element. Click the text box. In the displayed dialog box, select a
global variable or flow variable as required, for example,
FLOW.IDNumber. The system saves the information entered by the
customer by using a variable of the string type. Therefore, you can select
only a variable of the string type.

– Waiting Time for Digit Collection: time to wait for the digit input. If the
time when a customer stops the input exceeds that specified by Waiting
Time for Digit Collection, the system records a failure, automatically
executes Digit collection timed out, and continues to wait for the digit
input.

– Max. Failure Times: maximum number of input attempts that are
allowed. When an error occurs during digit collection, the system records
a failure, automatically executes Digit collection failure, and continues
to wait for the digit input.

– Timeout interval for digit collection: Timeout interval for pressing a
key. For example, if this parameter is set to 2 seconds, the flow proceeds
when the key pressing interval exceeds 2 seconds, even though the
number of collected digits does not reach the specified value.

● Advanced Settings: You can click Advanced Settings + to expand this area
and click Close to collapse this area.

– Digit collection failure: You can click  to enable the capability
of playing a voice upon a digit collection error. Then, if digits fail to be
collected before the number of a customer's input attempts reaches the
maximum specified by Max. Failure Times, the system plays a voice to
notify the customer.

– Digit collection timed out: You can click  to enable the
capability of playing a voice upon digit collection timeout. Then, if digits
fail to be collected after the wait time reaches the maximum specified by
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Waiting Time for Digit Collection, the system plays a voice to notify the
customer.

NO TE

● By default, Digit collection failure and Digit collection timed out are disabled in the
Advanced Settings area. If the capabilities are disabled, the system replays the voice
configured for the voice playback and digit collection diagram element upon a failure.

● When the number of a customer's input attempts reaches the maximum specified by
Max. Failure Times, the system executes the common failure exit.

Condition Branch Description

Table 2-76 Condition branch description

Condition
Branch

Description Usage

Voice
playback or
digit
collection
failure

Voice
playback or
digit
collection
failure

Triggered upon a voice playback or digit
collection failure.

 

Typical Application Scenario
The system needs to interact with a customer and continue with the subsequent
flow based on the input of the customer. For example, the system can handle a
business only after a customer enters an identification number.

Language Selection

This diagram element is a public diagram element. For details, see 2.6.3.10.7
Language Selection.

Semantic Recognition

This diagram element is used to submit customer voices to the TUC dialog engine
for intention matching.

Diagram Element

Parameter Description
● Node Name: name of a node.
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● Description: details of a node.
● Context: used to filter intentions to be matched to improve the matching

speed.
● Semantic identification content: content to be matched for semantic

identification. The value can be a character string or an existing variable of
the current node. If it is left empty, the system directly identifies the customer
voice.

● Event: whether to clear the slot data in the matched intention if the node is
not entered for the first time in the flow. Generally, the value is Clear Current
Context Cache if you need to allow customers to modify information in the
halfway.
– Clear Session Cache: used to clear the values of all variables in the

current flow instance.
– Clear Current Context Cache: used to clear the variable value of the

current intention. Generally, it is used to execute the same semantic
recognition for multiple times, and to clear the intention data retained
previously.

● Intention Quantity: number of intentions. This applies to the scenario where
multiple intentions can be returned. The value needs to be a positive integer.
If this parameter is left blank, the value is the same as that of Max.
Intentions(1,5) set on the Configuration Center > Chatbot Management >
Semantic Understanding > System Management > Intelligent Engine
Parameter > Intention Parameters page by default.

● Confidence Interval: maximum confidence difference between each intention
and the first intention. This applies to the scenario where multiple intentions
are returned.

● Cache Variable and Response Attribute: flow variables and their values. The
response parameters or slot parameters of the intention can only be valid on
the current node. If you want to use the value in subsequent flow nodes,
define a cache variable and assign the value of the response parameter or slot
parameter in the intention to the cache variable.

● Condition and Condition Expression: branches of the exit of the current
diagram element. For example, the intention matching success and failure can
be configured as two branches. Different subsequent flows can be specified
for each branch.
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Condition Branch Description

Table 2-77 Condition branch description

Condition
Branch

Description Usage

timeout1 First timeout Triggered when a third-party system (for
example, the IVR system) determines that a
timeout occurs in receiving the customer
feedback and sends a message whose input is
timeout to the OIAP.
This branch is generally used on the connection
line between the Semantic Recognition
diagram element and subsequent node,
indicating that semantic recognition times out
before a response is received from the customer.

timeout2 Second
timeout

Triggered when the trigger condition of
timeout1 occurs for the second time during a
call.
During script flow design, a flow retry is required
when the first timeout occurs. If the second
timeout occurs, the current step is skipped, and
the subsequent steps are performed.

nomatch1 First
recognition
failure

Triggered in either of the following scenarios:
● The Semantic Recognition diagram element

does not match a result (that is, the diagram
element returns the command word
indicating an unknown intention).

● A third-party system (for example, the IVR
system) returns a message whose input is
nomatch.
In this scenario, the ASR system fails to
recognize the intention and sends a failure
response to the IVR system.

nomatch2 Second
recognition
failure

Triggered when the trigger condition of
nomatch1 occurs for the second time during a
call.

error3 Third error Triggered when the trigger condition of
timeout1 or nomatch1 occurs for the third time
during a call.
If the number of error times does not need to be
accumulated, use the Error Count Clearance
diagram element to clear the number of error
times before using this branch.

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.
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Condition
Branch

Description Usage

SYSERROR_I
NTERFACE

Business
interface
invocation
failure

Triggered if an error occurs when the Business
Interface Invocation diagram element is used
to invoke a third-party interface.
This branch is generally used on the connection
line between the Business Interface Invocation
diagram element and subsequent node.

slientInsertR
eply

Direct reply by
a silent agent

Used only when the silent agent system is
configured for the Semantic Recognition
diagram element. After an agent directly replies
to a customer, the flow can continue to go to
other expected business flows.

 

Using the Diagram Element

The Semantic Recognition diagram element is used when intention matching
needs to be performed for customer voices to identify customer requirements.

Click the diagram element or drag it to the canvas. Before using this diagram
element, add an intention or Q&A to TUC management.

Typical Application Scenario

The following describes how to use the Semantic Recognition diagram element
to interact with a robot.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Semantic Understanding.

Step 2 Configure a domain and an intention.

1. Choose Knowledge Management > Domain Management, click Create in
the upper right corner, set Name, and click Save.

Figure 2-138 Creating a domain

2. Click the name of the new domain. The Intention Management page is
displayed.
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3. Click Create, choose General intent, enter an intention name, configure
Corpus and Response, and click Save.

Figure 2-139 Creating an intention

4. Select the new intention and click Active to activate the new intention.

Step 3 Configure an intelligent IVR flow. The flow orchestration scenario is as follows:
After a customer is connected to the robot, the customer hears that the robot says
"Hello". After the customer says "Hello", the robot recognizes the customer voice
and says "Hello" again.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type. You need to add the welcome variable to play
the default value (for example, Hello) of the variable to a customer after the
customer is connected, and add the default variable to send the default reply
(for example, Intention not identified) when semantics are not identified.
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Figure 2-140 Adding a flow variable

Figure 2-141 Flow orchestration example
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– Use the reply variable FLOW.ChatBotRespContent for the Robot Reply
diagram element below the Semantic Recognition diagram element to
reply "Hello" to the customer after the customer says "Hello".

– Use the reply variable default for the Robot Reply diagram element on
the right of Semantic Recognition diagram element to reply "Intention
not identified" when no "Hello" said by the customer is matched.

3. Save and publish the flow.

Step 4 Choose Intelligent Chatbot and bind the flow to a robot.

Step 5 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
More and choose Bind Domain to bind an active domain.

Step 6 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Start Call to test the robot. Enter
"Hello". If the robot replies "Hello", semantic recognition is successful.

----End

Menu Configuration

This diagram element is used to prompt a customer to select a menu to enter the
corresponding branch for processing a specific business.

Diagram Element

Parameter Description
The following figure shows the parameters of the Menu configuration diagram
element.
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Figure 2-142 Menu configuration
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Figure 2-143 Advanced Settings

The parameters are described as follows:

● Node Name: name displayed on the diagram element, which can be
customized.

● Voice Prompt: Select Voice, TTS, or Video. You can click an option button to
select a voice type.
– Voice: Upload a WAV voice file. The UAP supports only the WAV voice

files in the following format: 8 bit, 8000 Hz, 64 kbit/s, and mono.
– TTS: Generate a voice file in TTS mode. You can enable Advanced TTS

settings to set voice playback parameters. Click  in the drop-down list
to select a sound effect and speaking speed. If this function is disabled,
Sound effect is set to Female voice, Speaking speed is set to Low, and
TTS Extended Parameter is not set by default.
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▪ Sound effect: Select the sound effect. The options are Male voice
and Female voice.

▪ Speaking speed: Select the speaking speed. The options are Low,
Medium, and High.

▪ TTS Extended Parameter: Set this parameter based on site
requirements. The value contains a maximum of 200 characters.

– Video: Upload a video file in 3GP format, whose size must be less than or
equal to 5 MB.

● Voice File: The system filters approved voice files, TTS files, or video files
based on the selected voice type, and displays the files in the drop-down list.

You can click  and select a required file.

● Menu Key Configuration: service option provided in a flow. Each button
maps a service option. You can click New to add a service option. Multiple
service options are allowed.

– Buttons: number key or character button available on the keyboard or
screen, such as 1, 2, or 3.

– Description: service introduction of a key or button, which can be
displayed in the menu. For example, if you set Buttons to 1 and
Description to Query member information, a customer can press 1 to
query member information.

– Operation: You can click New to add a service option, click Delete to
delete a service option, and click Down or Up to adjust the sequence of a
service option.

● Waiting Time for Digit Collection: time to wait for the digit input. If the
time when a customer stops the input exceeds that specified by Waiting
Time for Digit Collection, the system records a failure, automatically
executes Digit collection timed out, and continues to wait for the digit input.

● Max. Failure Times: maximum number of input attempts that are allowed.
When an error occurs during digit collection, the system records a failure,
automatically executes Digit collection failure, and continues to wait for the
digit input.

● Advanced Settings: You can click Advanced Settings + to expand this area
and click Close to collapse this area.
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– Digit collection failure: You can click  to enable the capability
of playing a voice upon a digit collection error. Then, if digits fail to be
collected before the number of a customer's input attempts reaches the
maximum specified by Max. Failure Times, the system plays a voice to
notify the customer.

– Digit collection timed out: You can click  to enable the
capability of playing a voice upon digit collection timeout. Then, if digits
fail to be collected after the wait time reaches the maximum specified by
Waiting Time for Digit Collection, the system plays a voice to notify the
customer.

NO TE

● By default, Digit collection failure and Digit collection timed out are disabled in the
Advanced Settings area. If the capabilities are disabled, the system replays the voice
configured for the voice playback and digit collection diagram element upon a failure.

● When the number of a customer's input attempts reaches the maximum specified by
Max. Failure Times, the system executes the common failure exit.

● You can click Save to save all parameters set on the current page.

Condition Branch Description

Table 2-78 Condition branch description

Condition
Branch

Description Usage

Timeout or
other keys

Digit
collection
timeout or
out-of-range
key

Triggered when digit collection times out or the
key is out of the range.

 

Typical Application Scenario
In a flow, multiple service options need to be provided for a customer to select.
For example, a customer can press 1 to query member information, 2 to query
traffic information, 3 to make complaints or provide suggestions, or 0 to obtain
manual services.

Call Transfer

This diagram element is used to transfer a call to an IVR flow (an existing key
pressing flow) or an agent.

Diagram Element
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Parameter Description

Figure 2-144 Node Attribute

● Node Name: name of a node.

● Description: details of a node.

● Transfer Type: The options are as follows:

– Skill Queue (Route Extension Code) (1)

– IVR (2)

– Skill Queue (Name) (3)

– Transfer to Skill Queue (Customized Route) (10)

– Agent (4)
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– Third-party number (5)
– Online Digital Assistant (6)
– Audio and video familiar customers (9)
– Multimedia familiar customer (7)
– Skill queue (MAgent) (8)
– Familiar customer message (31)
– Skill queue message (name or access code) (32)
– Message to an Agent (33)

● Route Value: Select a value from the drop-down list box.
– If Transfer Type is set to Skill Queue (Route Extension Code), set this

parameter to the extension code for transferring to a skill queue. For this
configuration, you need to ensure that the manual flow and the current
flow are under the same system access code. The call is transferred to the
manual skill queue through the extension code configured on the Called
Party page.

Figure 2-145 Extension Code

– If Transfer Type is set to IVR, set this parameter to the IVR flow access
code.
The following figure shows the IVR flow access code in the AICC
integrated deployment mode.
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– If Transfer Type is set to Skill Queue (Name), set Route Value to the
name of the skill queue where the agent to whom the call is transferred
resides, for example, Agent Group 1. You can choose Configuration
Center > Employee Center > Skill to view the skill queue name.

– If Transfer Type is set to Transfer to Skill Queue (Customized Route),
set the corresponding routing policy.

– If Transfer Type is set to Agent, set this parameter to the platform agent
ID of the agent to whom the call is transferred.

– If Transfer Type is set to Third-party number, set this parameter to the
third-party number.

– If Transfer Type is set to Online Digital Assistant, set this parameter to
the flow route code agreed with the third-party intelligent system.

– If Transfer Type is set to Audio and video familiar customers, you do
not need to set the route value, but you need to configure the call-
associated data by referring to Table 3.

– If Transfer Type is set to Multimedia familiar customer, you do not
need to set the route value, but you need to configure the call-associated
data by referring to Table 3.

– If Transfer Type is set to Skill queue (MAgent), set this parameter to
the platform agent ID or variable corresponding to the agent to whom
the call is transferred.

– If Transfer Type is set to Familiar customer message, you do not need
to set the route value, but you need to configure the call-associated data
by referring to Table 3.
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– If Transfer Type is set to Skill queue message (name or access code),
set this parameter to the name or access code of the skill queue where
the agent to whom the call is transferred resides.

– If Transfer Type is set to Message to an Agent, set this parameter to the
platform agent ID or variable corresponding to the agent to whom the
call is transferred.

● Routing Policy: This parameter needs to be set only when Transfer Type is
set to Transfer to Skill Queue (Customized Route). The options are
Percentage and Number segment.

Figure 2-146 Setting Routing Policy to Percentage

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 399



Figure 2-147 Setting Routing Policy to Number segment

● Percentage configuration: When Routing Policy is set to Percentage, you
need to configure multiple skill queues and their routing percentages. During
call transfer, the system dynamically assigns calls to skill queues based on the
percentage configuration.
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Table 2-79 GUI elements for the percentage configuration

Elemen
t/
Compo
nent

Typ
e

Description Value
Range

Trig
geri
ng
Eve
nt

Remarks

Skill
Queue

Dro
p-
do
wn
list

Skill queue to
which calls are
transferred.

All skill
queues
except
multimedia
skill queues

Click ● A skill queue
cannot be
selected
repeatedly.

Percent
age

Tex
t
box

Percentage of
calls transferred
to a skill queue
during
transferred-to
skill queue
assignment.

1 to 100 Ente
r

The total
percentage must
be 100.

But
ton

Delete a
percentage
setting.

- Click -

But
ton

Add a percentage
setting.

- Click -

 
● Default Skill Queue: When Routing Policy is set to Number segment, you

need to select a skill queue as the default skill queue to which calls are
transferred when no skill queue is matched based on the number segment
matching rule configuration.

● Matching rule: When Routing Policy is set to Number segment, you need
to select a matching rule. The options are Prefix and Suffix.

● Number segment matching rule configuration: When Routing Policy is set to
Number segment, you can select different skill queues and configure
different prefixes or suffixes for them. During call transfer, the system
transfers calls whose calling numbers exactly match the configured prefixes or
suffixes to the corresponding skill queues.
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Table 2-80 GUI elements for the number segment matching rule
configuration

Elemen
t/
Compo
nent

Typ
e

Description Value
Range

Trig
geri
ng
Eve
nt

Remarks

Skill
Queue

Dro
p-
do
wn
list

Skill queue to
which calls are
transferred.

All skill
queues
except
multimedia
skill queues

Sele
ct

● A skill queue
cannot be
selected
repeatedly.

Prefix/
Suffix

Tex
t
box

Prefix/Suffix used
for calling
number matching
during call
transfer to a skill
queue.

- - -

But
ton

Delete a number
segment
matching rule
setting.

- Click -

But
ton

Add a number
segment
matching rule
setting.

- Click -

 
● Associated Data: The call-associated data can be in JSON format (flow

variables and global variables are supported). Manually enter a value, or click
the edit icon and add information in the Set TransferData dialog box.
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Figure 2-148 Set TransferData (transfer to a skill queue, including manual
and multimedia skill queues)

Figure 2-149 Set TransferData (transfer to the last agent, including manual
and multimedia agents)
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Figure 2-150 Set TransferData (transfer to others)

The format of the generated complete JSON data is as follows:
{
  "wait": "Y",
  "isSpecifyAccessCode": "true",
  "type": "1",
  "time": "30",
  "starttime": ""
  "data": {
    "serviceId": ${FLOW.test},
    "yy": "bbb"
  },
}

Table 2-81 Call-associated data parameters

Eleme
nt/
Comp
onent

Key in
JSON
Data

Ty
pe

Description Value
Range

Tri
gg
eri
ng
Eve
nt

Remarks

Queue
Queui
ng

wait Sw
itc
h

Whether a call
can wait in a
skill queue
until the
session times
out when the
call is
transferred to
the skill
queue.

● Y
● N

Clic
k

This
parameter
can be set
only when a
call is
transferred to
a skill queue,
including
manual and
multimedia
skill queues.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 404



Eleme
nt/
Comp
onent

Key in
JSON
Data

Ty
pe

Description Value
Range

Tri
gg
eri
ng
Eve
nt

Remarks

Specifi
ed
Chann
el
Access
Code

isSpecify
AccessCo
de

Sw
itc
h

Whether to
transfer to the
current
channel when
a call is
transferred to
the last agent.

● true
● false

Clic
k

This
parameter
can be set
only when a
call is
transferred to
the last
agent,
including
manual and
multimedia
agents.

Famili
ar
Custo
mer
Mode

type Dr
op
-
do
wn
list

Mode of
selecting the
last agent.

1: agent
within the
specified
minutes
2: agent
within the
specified
time
range
3: agent
on the
current
day

Sel
ect

This
parameter
can be set
only when a
call is
transferred to
the last
agent,
including
manual and
multimedia
agents.

Transf
er
Data

data Ta
ble

Call-associated
data that
needs to be
carried during
call transfer.

- - -
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Eleme
nt/
Comp
onent

Key in
JSON
Data

Ty
pe

Description Value
Range

Tri
gg
eri
ng
Eve
nt

Remarks

Transf
er
Param
eters

Customiz
ed key

Te
xt
bo
x

Key in call-
associated
data.

- Ent
er

● To obtain
the
customer
type field,
set the
transferred
parameter
to
customerE
ntityNam
e.

● To use a
visualized
service
guidance
flow, set
the
transferred
parameter
to
serviceRe
quest.
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Eleme
nt/
Comp
onent

Key in
JSON
Data

Ty
pe

Description Value
Range

Tri
gg
eri
ng
Eve
nt

Remarks

Value - Te
xt
bo
x

Value of the
key in call-
associated
data.

- Ent
er

● Variables
can be
used, for
example, $
{FLOW.var
iable}.

● To obtain
the
customer
type field,
set the
value to
account or
contact.

● To use a
visualized
service
guidance
flow, set
the value
to the
name of a
visualized
flow
configured
on the
Configura
tion
Center >
Workbenc
h
Configura
tion >
Service
Guidance
page, that
is, the
name of
the flow
created in
Step 7.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 407



Eleme
nt/
Comp
onent

Key in
JSON
Data

Ty
pe

Description Value
Range

Tri
gg
eri
ng
Eve
nt

Remarks

Action
s

- Bu
tto
n

Delete a line
of call-
associated
data.

- Clic
k

-

Add - Bu
tto
n

Add a line of
call-associated
data.

- Clic
k

-

Cancel - Bu
tto
n

Cancel the
editing.

- Clic
k

-

Confir
m

- Bu
tto
n

Fill back the
call-associated
data in JSON
format.

- Clic
k

-

 
● Calling Number

– When Transfer Type is set to Third-party number (5), the number set
here is used as the calling number.

– When Transfer Type is set to Audio and video familiar customers (9),
the variable set here is used as the calling number of the customer. The
default value is SYS.callingNumber.

● Enable Recording: This check box is displayed only when Transfer Type is set
to Third-party number (5). You can select this check box to enable recording
during call transfer from an intelligent IVR to a third-party number. After you
select this check box, set the following parameters:
– Recording File Name: Enter a flow variable, for example,

FLOW.recordPath.
– Recording Service Node ID: Enter a flow variable, for example,

FLOW.serviceNo.

NO TE

The recording files in the intelligent IVR can be played and downloaded on the
Contact History > Transfer Record page.
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Condition Branch Description

Table 2-82 Condition branch description

Condition
Branch

Description Usage

SUCCESS Transfer
success

Triggered when a call is transferred successfully.

FAILED Transfer
failure

Triggered when a call fails to be transferred.
After this branch is triggered, the flow is not
interrupted and does not automatically go to
the exception handling flow.

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS.

 

Using the Diagram Element
The Call Transfer diagram element is used when a call needs to be transferred to
another destination device in the AICC, for example, to a common IVR self-service
flow or an agent.

Click the diagram element or drag it to the canvas, and set Transfer Type and
Route Value as prompted.

Typical Application Scenario
The following describes how to use the Call Transfer diagram element to transfer
a call from an intelligent IVR flow to a common IVR flow when call-associated
data in JSON format is carried.

Step 1 Sign in to the AICC.

Step 2 Configure a common IVR flow.

1. Choose Configuration Center > Chatbot Management > Flow
Configuration and add a common IVR flow.

2. Add flow variables, as shown in the following figure, and configure an Assign
diagram element.
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3. Configure a Condition Judgement diagram element for conditional judgment
based on the call-associated data.

4. Configure a Voice Playback diagram element for playing a variable voice.

5. Save and publish the flow.

Step 3 Configure an intelligent IVR flow.
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1. Choose Configuration Center > Chatbot Management > Flow
Configuration.

2. Choose Flow > Orchestration, add an intelligent IVR flow, add a Call
Transfer diagram element, and set service parameters of the diagram
element, as shown in the following figure.

3. Save and publish the flow.
4. Choose Intelligent Chatbot and bind the flow to a robot.
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Step 4 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the intelligent IVR added in Step 3.

Step 5 Log in to the OpenEye and dial the access code added on the Called Party page.
If "10000" is heard, the call-associated data (service_id: 10000) transferred by the
intelligent IVR is successfully obtained.

----End

Error Count Clearance

This diagram element is used to clear previous error records when a customer
needs to be transferred to another flow due to a number of intention matching
errors.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.

Condition Branch Description

Table 2-83 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Using the Diagram Element

The Error Count Clearance diagram element is used when the number of
semantic recognition and key pressing errors do not need to be accumulated.

Click the diagram element or drag it to the canvas.

Typical Application Scenario

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Semantic Understanding.
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Step 2 Configure a domain and an intention.

1. Choose Knowledge Management > Domain Management, click Create in
the upper right corner, set Name, and click Save.

Figure 2-151 Creating a domain

2. Click the name of the new domain. The Intention Management page is
displayed.

3. Click Create, choose General intent, enter an intention name, configure
Corpus and Response, and click Save.

Figure 2-152 Creating an intention

4. Click Active corresponding to the new intention to activate it.

Step 3 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type.
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Figure 2-153 Flow variables to be added
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Figure 2-154 Flow orchestration example (Semantic Recognition diagram
element)

– Use the reply variable FLOW.answer for the Robot Reply diagram
element below the Semantic Recognition diagram element to send the
reply to the matched intention.

– Use the reply variable FLOW.error3 for the Robot Reply diagram
element below the error3 condition branch of the Semantic Recognition
diagram element to send the reply "The number of errors is 3" for three
semantic recognition errors.

3. Save and publish the flow.

Step 4 Choose Intelligent Chatbot and bind the flow to a robot.
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Step 5 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Start Call to test the robot. Enter
incorrect corpuses continuously. If the robot keeps replying "Unknown intent" and
does not reply "The number of errors is 3" for more than three semantic
recognition errors, the Error Count Clearance diagram element takes effect in the
flow.

Figure 2-155 Testing the robot

----End

Branch Judgment

This diagram element is used to judge branches.

Diagram Element
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Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Condition and Condition Expression: branches of the exit of the current

diagram element.

Condition Branch Description

Table 2-84 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Using the Diagram Element

The Condition Judgment diagram element is used when branch flows need to be
executed based on different conditions. It makes the flow logic clearer.

Click the diagram element or drag it to the canvas, and click  under
Condition Branch to add a condition expression.

Typical Application Scenario

For details about how to use the Branch Judgment diagram element, see Typical
Application Scenario. The typical application scenario of the Key Recognition
diagram element involves the Branch Judgment diagram element.

Logic Loop

This diagram element is used to perform an operation on an object repeatedly
until a certain condition is met.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Counter: flow variable that stores the number of elements in a list.
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● Loops: objects to be traversed. Generally, the object list is the value obtained
by the previous node, for example, the customer list obtained by a stored
procedure.

● Loop Object: flow variable that stores the value of the object obtained each
time when the object list is traversed.

In addition to four variables, the Logic Loop diagram element provides two
default branches: inLoop and outLoop. The inLoop branch executes the logic
when a loop is entered, that is, some actions during object list traversal. The
outLoop branch executes the actions after object list traversal.

Condition Branch Description

Table 2-85 Condition branch description

Condition
Branch

Description Usage

inLoop Loop list
traversing

Triggered when the loop list traversing is not
completed.

outLoop Completed
loop list
traversing

Triggered when the loop list traversing is
completed.

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Using the Diagram Element
The Logic Loop diagram element is used when an operation needs to be
performed repeatedly until a certain condition is met.

Click the diagram element or drag it to the canvas, and set loop conditions and
objects.

Typical Application Scenario

Step 1 Sign in to the AICC and choose Configuration Center > Flow Configuration >
Intelligent IVR.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type.
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Figure 2-156 Flow variables to be added

Figure 2-157 Flow orchestration example (Logic Loop diagram element)

– The Robot Reply diagram element of the inLoop condition branch
traverses FLOW.list and outputs the values in FLOW.list.

– The Robot Reply diagram element of the outLoop condition branch
outputs FLOW.out, indicating that the loop ends.

3. Save and publish the flow.

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Start Call to test the robot. If the
robot outputs results properly, the configuration is successful.
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Figure 2-158 Testing the robot

----End

Variable Assignment

Use this diagram element by referring to the JSON Data Invoking diagram
element. This diagram element is used to obtain call-associated data and assign
values.

Diagram Element

Parameter Description

None

Condition Branch Description

Table 2-86 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no satisfaction option is selected, the
flow goes to the exception handling flow.
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Using the Diagram Element
(1) When the call-associated data is in JSON format, this diagram element can be
used to obtain the parameters of a specified node and assign values to the
parameters.

(2) Built-in functions described in 2.6.2.5.4 Built-in Functions can be used if data
processing, such as truncation, length obtaining, conversion, and check, is required
by businesses.

Click the diagram element or drag it to the canvas, and set parameters based on
the parameter description.

Typical Application Scenario
A customer makes a call to the AICC, and the call is routed to a skill queue. When
all agents in the skill queue are busy, if Queuing Method is set to IVR and an
intelligent IVR flow is selected for the skill queue, the intelligent IVR flow can use
this diagram element to obtain the current queuing status of the customer and
play the waiting tone to the customer. Therefore, the customer can determine
whether to continue waiting based on the queuing status.

Scenario 1: Assigning Values to Variables

Step 1 During data value assignment, in addition to string and integer data, expression
calculation is also supported. Integer data supports the following arithmetic
operations: +, -, *, and % (). Data supports FLOW, GLOBAL, and SYS. Example:
(FLOW.xxx+FLOW.yyy)*GLOBAL.zzz. Note that when / is used for division, the
calculation result needs to be received using data of the string type. Integers do
not support decimals. String data supports comparison, case conversion, character
string concatenation, substring calculation, and length calculation. Example:
FLOW.aaa=="Huawei" FLOW.bb.to FLOW.a.toUpperCase()
FLOW.A.toLowerCase() FLOW.hua+FLOW.wei
FLOW.len.substring(0,3)FLOW.zzzz.length()
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1. Configure an intelligent robot and set Dialog Type to IVR flow.

Step 2 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the added intelligent IVR.

Step 3 Log in to the OpenEye using a softphone number to simulate a customer, and dial
the access code added on the Called Party page. If the current queuing
information is heard, the configuration is successful.

----End

Scenario 2: Obtaining Call-associated Data

Step 1 Orchestrate a flow.

Example 1: Assume that the call-associated data is {"data":{"test": "Call-
associated data test"}}.
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Use the Variable assignment diagram element to assign the value of the test
field in the call-associated data to the flow variable FLOW.str1. In this example,
the value of FLOW.str1 is Call-associated data test.

Example 2: If the call-associated data of an outbound call task is {"iSales":
{"name":"Tom"}}, the content Tom can be obtained by setting iSales.name.

The following figure shows the screenshot based on example 1.

Figure 2-159 Obtaining call-associated data

1. Configure an intelligent robot and set Dialog Type to IVR flow.
2. Configure a common IVR, add the Transfer diagram element, select Transfer

to Intelligent IVR, and configure call-associated data.
3. Add the Variable assignment diagram element to the intelligent IVR flow,

and configure a variable on the Obtaining Associated Data tab page to
receive call-associated data from the common IVR.

Step 2 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the added intelligent IVR.

Step 3 Log in to the OpenEye using a softphone number to simulate a customer, and dial
the access code added on the Called Party page. Check whether the call-
associated data obtained in the intelligent IVR flow is correct.

----End

Scenario 3: Extended CDR Fields

You can set 10 service information fields (extfield1 to extfield10) to collect
customer information and customer operations to be saved in the IVR flow. These
fields can be used only when the system parameter IVRCDRCTRLPARAMS is
enabled. Do not assign values to encrypted variables. The values of encrypted
variables are processed as ****** for storage.
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Rule Validation V2

This diagram element is used to verify the customer input or output based on
rules.

Diagram Element
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Parameter Description

Figure 2-160 Rule validation V2 parameters

● Variable to be Verified: Enter the variable corresponding to the parameter to
be verified, for example, IVRREQUEST.input.

● End of Special Key: Specify the end character of the parameter to be verified.
The options are as follows:
– With #
– With *
– With # or *
– Without special keys

● Contains Characters: Specify the characters that can be contained in the
parameter to be verified. You can select multiple values. The options are as
follows:
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– Matches numbers
– Matches uppercase letters
– Matches lowercase letters
– Matches letters, digits, and underscores (_)
– Empty character

Verification Rules
● Name: Select a verification rule. The options are as follows:

– Minimum Length
– Maximum Length
– Length Range
– Min.
– Max.
– Value Range
– Email
– URL
– Time Format
– Decimal Number
– Positive Integer
– IP Address
– Alphanumeric Underscore (not starting with a number)

● Rule Parameters: Enter rule parameters. Variables are supported.

Condition Branch Description

Table 2-87 Condition branch description

Condition
Branch

Description Usage

SUCCESS Successful
verification

Triggered when the verification is successful.

FAILED Verification
failure

Triggered when the verification fails.

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Using the Diagram Element

This diagram element is used to verify the customer voice or keyboard input based
on rules.
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Click the diagram element or drag it to the canvas, and set parameters based on
the parameter description.

Typical Application Scenario
The following describes how to use the Rule validation V2 diagram element to
verify whether the customer input is a valid date.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type. The default value of the variable will be played
to the customer.

Figure 2-161 Add Variable
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Figure 2-162 Flow orchestration example (Rule validation V2 diagram
element)

– Select the reply text SUCCESS for the Robot Reply diagram element of
the SUCCESS condition branch, indicating that the time meets the format
requirements.

– Select the reply text FAILED for the Robot Reply diagram element of the
FAILED condition branch, indicating that the time does not meet the
format requirements.

3. Save and publish the flow.

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Start Call to test the robot. If the
robot answers SUCCESS or FAILED based on the time entered by the customer,
the configuration is successful.
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Figure 2-163 Testing the robot

----End

Time Selection

The orchestration capability varies depending on the time. That is, the holiday
time of each region may be different. During flow orchestration, perform different
orchestration operations based on the holidays and working days.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Week Selection: Select the working days of a week.
● Service Period: Select the start working time and end working time.
● Specified Service Date: Specify one or more dates as working dates.
● Specified Non-service Date: Specify one or more dates as non-working

dates.

The time zone is that set by the system administrator when the tenant space is
created. If the time zone is not set when the tenant space is created, the value of
the built-in variable timezone is used.
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The configuration priority is as follows: Specified Non-service Date > Specified
Service Date > Week Selection.

Condition Branch Description

Table 2-88 Condition branch description

Condition
Branch

Description Usage

NON_SPECI
FIC_TIME

Non-working
time

Triggered when the current time is non-working
time.

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Using the Diagram Element
The holiday time of each region may be different. During flow orchestration,
perform different orchestration operations based on the holidays and workdays.

Click the diagram element or drag it to the canvas, and set parameters based on
the parameter description.

Typical Application Scenario
The following describes how to use the Time Selection diagram element to
determine whether the current time is working time for subsequent business
handling.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent robot.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type.
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Figure 2-164 Flow variable to be added

Figure 2-165 Flow orchestration example (Time Selection diagram element)
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Figure 2-166 Referencing a work calendar template

For the Robot Reply diagram element, set Reply Variable to FLOW.response
to reply to the customer with "The current time is working time. What kind of
business do you want?" if the current time is working time.

3. Save and publish the flow.

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Start Call to test the robot. If the
robot replies based on whether the current time is working time, the configuration
is successful.

----End

Interface Invocation

This diagram element is used when a third-party system interface needs to be
invoked to implement a function. If no interface is selected, you can directly add
parameters and assign values to the parameters to implement the function of the
diagram element.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
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● Interface Type: Select the type of the interface to be invoked. The options are
inner interface and self defined interface. If inner interface is selected, the
following two built-in interfaces are available:
– Record Q&A: This interface used to record the survey ID, question title,

user reply intention, original user reply, and other information.
– Obtain the APIFabric token: This interface is used to obtain the API

Fabric token. After a robot successfully invokes this interface, the token is
recorded in the cache and can be directly obtained from the cache within
the validity period. If the AK/SK is changed, the original cache is not
cleared, and this interface fails to be invoked within the cache validity
period. To invoke this interface immediately, you can bind the flow to a
new robot.

● Invoked Interface: interface to be invoked. Select an interface added on the
Resource Management > Business Interface page.

● Variable assignment: variable name and variable value. The output
parameter returned by the interface is valid only on the current node. If you
want to use the value in subsequent flow nodes, define a variable here and
assign the value of the output parameter to the variable.

● Condition branch: condition name and condition expression. Define the
branches of the exit of the current diagram element. For example, you can set
a branch based on the value of an output parameter. Different subsequent
flows can be specified for each branch.

● Method Invocation: Built-in functions described in 2.6.2.5.4 Built-in
Functions can be used if data processing, such as truncation, length
obtaining, conversion, and check, is required by businesses.

Condition Branch Description

Table 2-89 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

SYSERROR_I
NTERFACE

Interface
invocation
failure

Triggered when an interface invocation
exception occurs. If no option is selected, the
flow goes to the exception handling flow.

 

Using the Diagram Element

Click the diagram element or drag it to the canvas, and select the interface to be
invoked. The invoked interface needs to be configured on the Resource > Business
Interface page in advance. Alternatively, in the dialog box that is displayed, click
Add to add an interface. If you use this diagram element to assign a value, you do
not need to select an interface. Instead, you can directly add a cache variable and
assign a value to it. In this case, you need to maintain global variables in advance.
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Typical Application Scenario
For details about how to use the Interface Invoking diagram element, see Typical
Application Scenario. In the typical application scenario of the Rule Validation
diagram element, the parameter value assignment function of the Interface
Invoking diagram element is used.

Data Table

This diagram element is used to search for configuration data. It is used with the
Branch Judgement diagram element to determine which branch to go to or the
next step to process data.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Data Table Name: name of the data table to be searched.
● Search Page: page number of the data table to be searched. Enter an integer

or a variable. If this parameter is left blank, the first page is searched by
default. The page size is fixed at 10.

● Search Criteria: condition for searching a data table.
– If the field is of the character type, the operator can be =, >, >=, <, <=, !=,

like, or in. If the field value is of the character type, it does not need to
be enclosed in quotation marks. If the operator is in and the field value is
of the list type, each list item must be enclosed in double quotation
marks, for example, ["watermelon","apple"].

– If the field is of the integer type, the operator can be =, >, >=, <, <=, !=, or
in.

– If the field is of the date type, the operator can be =, >, >=, <, <=, or !=.
Set Field Value to a timestamp, in milliseconds. A value or variable of the
character type or long integer type is supported. A value or variable of
the character type does not need to be enclosed in double quotation
marks.

● Return Records: variable for saving search results. Enter a variable of the list
type.

● Total: variable for saving the total number of search results. Enter a variable
of the integer type.
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Condition Branch Description

Table 2-90 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Using the Diagram Element
The Data Table diagram element is used when you need to search a customized
data table for data.

Click the diagram element or drag it to the canvas. Select a data table and add
search conditions.

Typical Application Scenario
Use the Data Table diagram element in an IVR flow to search for the milk brand,
price, and inventory.

The following describes how to use the Data Table diagram element to search for
data and then process the data.

Query data records with milkCount being greater than 10 from the milkInfo
table. If the condition is not met, the robot returns a message indicating that no
such data record is found. If the condition is met, the robot returns the total
number of such data records, data records on the first page that meets the
condition, and milkName of the first data record.

Prerequisites
You have added a data table by referring to 2.6.2.4.4 Adding Data Tables, as
shown in the following figure.

Figure 2-167 Table fields

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 435



Figure 2-168 Table data

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type.
3. Save and publish the flow.

Figure 2-169 Flow variables to be added
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Figure 2-170 Example of data table diagram element configuration

Figure 2-171 Example of branch judgment diagram element configuration
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Figure 2-172 Flow orchestration example

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call. In the test dialog box that is displayed, click Start Call to test the robot.

NO TE

Only 10 data records on the specified search page are queried. If no search criteria are
specified, the first page is queried by default.

----End
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Stored Procedure

The Stored Procedure diagram element interacts with the database.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Stored Procedure: stored procedure added on the Configuration Center >

Flow Configuration > Resource > Stored Procedure page.
● Cache Variable and Response Attribute: flow variables and their values. The

output parameter returned by the stored procedure is valid only on the
current node. If you want to use the value in subsequent flow nodes, define a
cache variable here and assign the value of the output parameter to the
cache variable.

● Condition and Condition Expression: branches of the exit of the current
diagram element. For example, you can set a branch based on the value of an
output parameter in the stored procedure. Different subsequent flows can be
specified for each branch.

Using the Diagram Element
The Stored Procedure diagram element is used when data needs to be imported
to the database. It cannot be used in public cloud scenarios. In scenarios where
the OIAP is independently deployed, the database you access needs to be
deployed in the same security zone as the OIAP for security purposes.

Currently, the stored procedure applications of the MySQL database, Oracle
database, and GaussDB are supported.

Click the diagram element or drag it to the canvas, select the stored procedure to
be invoked, set its input parameters, and add cache variables to temporarily save
its output parameters. For the list type in output parameters, you need to set it
separately based on rules.

Typical Application Scenario
The following describes how to use the Stored Procedure diagram element.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure a database.

1. Contact the system administrator to add the database URL to the trustlist.
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2. Choose Resource > Stored Procedure, click the Stored Procedure Databases
tab, and click Create.

Figure 2-173 Configuring a stored procedure database

Step 3 Configure a stored procedure.

1. Obtain the developed stored procedure script. An example is as follows:

Figure 2-174 Stored procedure script example

2. Choose Resource > Stored Procedure, click the Stored Procedures tab, and
click Create.
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Figure 2-175 Basic Information page

Figure 2-176 Input Parameter page
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Figure 2-177 Output Parameter page

Step 4 Configure an intelligent IVR flow. The usage of the Stored Procedure diagram
element is similar to that of the Business Interface Invocation diagram element.
Select the configured stored procedure, set input parameters, and assign output
parameters to variables as required.

1. Choose Resource > Variable, click the Custom Variable tab, and click Create
to add a system variable for receiving the output parameters of the stored
procedure.

Figure 2-178 System variable to be added

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 442



2. Choose Flow > Orchestration and click New to add a simple flow.

Figure 2-179 Flow orchestration example (Stored Procedure diagram
element)

Use the reply variable GLOBAL.xxxx for the Robot Reply diagram element to
reply the number output by the stored procedure to the customer.

3. Save and publish the flow.
4. Choose Intelligent Chatbot and bind the flow to a robot.

Step 5 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the added intelligent IVR.

Step 6 Log in to the OpenEye using a softphone number to simulate a customer, and dial
the access code added on the Called Party page. If the robot can query the
number output by the stored procedure based on the calling number and reply it
to the customer, the configuration is successful.

----End

Information Query

This diagram element is used to query the status of the current customer in the
queue. When all agents are busy, the system plays the waiting tone to the
customer through the IVR.

Currently, you can query the queuing position, the number of all online agents in
a skill queue, and the estimated time required for accessing an agent.

This diagram element is used to query details about agents in configured skill
queues.

This diagram element is used to query whether the customer is in the special list.
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Diagram Element

Parameter Description
● Querying queuing information

– Query Type: information type that can be queried using this diagram
element. Currently, queuing information can be queried.
The queuing information is queried using an IVR flow when a call is
transferred to a skill queue.

– Query result

▪ Queue Position: position of a customer in the current skill queue,
that is, the number of queuing customers in front of the customer.
You can use a global variable (GLOBAL.*) or flow variable (FLOW.*)
to save the value for subsequent operations.

▪ Number of online agents: total number of online agents in the skill
queue to which a customer belongs. You can use a global variable
(GLOBAL.*) or flow variable (FLOW.*) to save the value for
subsequent operations.

▪ Estimated waiting time: estimated duration for connecting a call to
an agent during queuing. This parameter is affected by Queue
Position and Number of online agents. You can use a global
variable (GLOBAL.*) or flow variable (FLOW.*) to save the value for
subsequent operations. The estimated waiting time depends on the
queue model. The result may be inaccurate. Therefore, use this
parameter properly.

● Querying queue information
– Query Type

Queue Information: Query queue information before a call is transferred
to a skill queue.

– Request Parameter
Skill Queue: skill queue to which a call is transferred.

– Query result

▪ Number of queues: number of customers in the current skill queue
before a call is transferred to another skill queue. You can use a
global variable (GLOBAL.*) or flow variable (FLOW.*) to save the
value for subsequent operations.

▪ Number of online agents: total number of online agents in the skill
queue to which a call is transferred. You can use a global variable
(GLOBAL.*) or flow variable (FLOW.*) to save the value for
subsequent operations.
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▪ Number of idle agents: total number of online and idle agents in
the skill queue to which a call is transferred. You can use a global
variable (GLOBAL.*) or flow variable (FLOW.*) to save the value for
subsequent operations.

▪ Estimated waiting time: estimated time for connecting a call to an
agent after the call is transferred to a skill queue. You can use a
global variable (GLOBAL.*) or flow variable (FLOW.*) to save the
value for subsequent operations. The estimated waiting time
depends on the queue model. The result may be inaccurate.
Therefore, use this parameter properly.

● Querying the queue name
– Query Type

Queue Name: The name of a skill queue to which an agent belongs can
be queried based on the agent ID.
The scenario is to query the skill queue name based on the agent ID
before the call is transferred to the skill queue to which the agent
belongs.

– Request Parameter
Agent ID: agent ID. Flow variables or constants are supported.

– Query result
Queue Name: name of the voice skill queue with the highest weight in
the skill queue to which the agent ID belongs. Use the global variable
(GLOBAL.*) or flow variable (FLOW.*) for subsequent operations.
You can choose Configuration Center > Employee Center > Agent
Management to configure the skill queue weight.

● Querying special list information
– Query Type

Special List Information: Currently, the system can check whether a
customer is in the special list based on the customer number. The next
process varies depending on the special list query result.
The special list refers to the blocklist.

– Query result
Identifier in the special list: whether the calling number exists in the
special list. Use the global variable (GLOBAL.*) or flow variable (FLOW.*)
for subsequent operations.
The values of Identifier in the special list are as follows: 0 indicates that
the calling number does not exist in the special list, and 1 indicates that
the calling number exists in the special list.
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Condition Branch Description

Table 2-91 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Using the Diagram Element
The Information query diagram element can be used to query information such
as the queuing status and special list information of the current customer.

Click the diagram element or drag it to the canvas, and set parameters based on
the parameter description.

Typical Application Scenario
A customer makes a call to the AICC, and the call is routed to a skill queue. When
all agents in the skill queue are busy, if Queuing Method is set to IVR and an
intelligent IVR flow is selected for the skill queue, the intelligent IVR flow can use
this diagram element to obtain the current queuing status of the customer and
play the waiting tone to the customer. Therefore, the customer can determine
whether to continue waiting based on the queuing status.

Scenario 1: Query queuing information.

Step 1 Choose Configuration Center > Employee Center > Skill Queue, click Edit
corresponding to the skill queue, and set Queuing Method to IVR.

Figure 2-180 Page for editing skill queue parameters
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Step 2 Orchestrate a flow. In the flow, use the Information query diagram element to
query data, including the number of online agents, queuing position, and
estimated waiting time.

1. Create three flow variables to receive the query result.

Figure 2-181 Flow variables to be added

2. Configuring an IVR voice. Use the created flow variables in the IVR voice
content.

Figure 2-182 Added IVR voice

3. Configure a resource template.
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Figure 2-183 Page for configuring a resource template

4. Create a flow, use the Information query diagram element to assign values
to the three flow variables, and use the Robot Reply diagram element to
select the configured resource template.

Figure 2-184 Flow orchestration example

5. Configure an intelligent robot and set Dialog Type to IVR flow.

Step 3 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the intelligent IVR added in Step 2.
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Step 4 Log in to the OpenEye using a softphone number to simulate a customer, and dial
the access code added on the Called Party page. If the current queuing
information is heard, the configuration is successful.

----End

Scenario 2: Query queue information.

Step 1 Orchestrate a flow.

1. Create four flow variables to receive the query result.

Figure 2-185 Flow variables to be added

2. When using the diagram element to create a flow, if you want to transfer a
call to a skill queue in the flow, you can query the information about the skill
queue and then determine whether to transfer the call to the skill queue. The
subsequent businesses are determined based on site requirements.
The flow is shown in the following figure. You need to select a skill queue to
be queried.
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Figure 2-186 Flow orchestration example

3. Configure an intelligent robot and set Dialog Type to IVR flow.

Step 2 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the added intelligent IVR.

Step 3 Log in to the OpenEye using a softphone number to simulate a customer, and dial
the access code added on the Called Party page. If the current queue information
is heard, the configuration is successful.

----End

Scenario 3: Query special list information.

Step 1 Orchestrate a flow.

1. Create a flow variable to receive the query result.
2. Configure a flow by referring to the following figure. When the flow runs to

the special list information query node, the flow invokes an interface to query
special list information, obtains the query result, and enters different flows
based on the query result.
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Figure 2-187 Flow orchestration example

3. Configure an intelligent robot and set Dialog Type to IVR flow.

Step 2 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the added intelligent IVR.

Step 3 Log in to the OpenEye using a softphone number to simulate a customer, and dial
the access code added on the Called Party page. If the current special list
information is heard, the configuration is successful.

----End

User Level

The priority (user level) of a call can be set. The call of a user with a higher
priority is transferred to an agent first.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● User Level: Enter a non-negative integer or a string variable. The default

value is 0, and the maximum value is 14. After calls are transferred to the
manual service, the call from a high-level user is processed preferentially.
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Condition Branch Description

Table 2-92 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

fail User level
setting failure

Triggered when the call priority of a user fails to
be set.

 

Using the Diagram Element

This diagram element is used when the priority (user level) of a call needs to be
set and the call of a user with a higher priority is transferred to an agent first.

Click the diagram element or drag the diagram element to the canvas and set user
level service parameters.

Typical Application Scenario

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.

2. Click + in the Flow Variable area. In the dialog box that is displayed, set the
variable name and data type.

Figure 2-188 Flow variables to be added
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Figure 2-189 Flow orchestration example (User Level diagram element)

Figure 2-190 Flow orchestration example (Call Transfer diagram element)

3. Save and publish the flow.

4. Choose Intelligent Chatbot and bind the flow to a robot.

Step 3 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the intelligent IVR added in Step 2.

Step 4 Set the current agent to the busy state, log in to the OpenEye using two
softphone numbers to simulate two customers, and dial the access code added on
the Called Party page at the same time. Answer the user level according to the
voice prompt. You are advised to set different user levels for the two customers.
Then, set the current agent to the idle state. If the customer of a higher level is
connected to the agent first, the configuration is successful.

----End
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Message Leaving

The system records the message of a customer. After the recording is successful,
the system returns the directory for storing the recorded message.

Diagram Element

Parameter Description
The following figure shows the parameters of the Leave Message diagram
element.
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● Node Name: name displayed on the diagram element, which can be
customized.

● Specify Agent for Processing
Specified Agent ID: Configure constants or flow variables as required. The
constants or flow variables are used to automatically allocate messages to the
specified agent ID. If the specified agent ID does not exist, the message status
changes to allocation failure. If no agent is specified, messages will be
allocated by the administrator.

● Recording file
Save File Name (first text box): Click the text box. In the dialog box that is
displayed, select a global variable or flow variable for saving the recording file
name as required. The system saves the recording file name using a variable
of the string type. Therefore, you can select only a variable of the string type.
Saving the localtionID (second text box): Select the UAP node set during
installation. This parameter is used in call center pool mode.

● Recording Parameter
Max. Recording Duration: Enter the maximum duration of a recording. When
the maximum recording duration is reached, the recording ends. The default
value is 20, in seconds.

● Play the beep tone: If the check box is selected, a beep tone is played before
the recording starts. Otherwise, the recording is performed directly.
By default, the recording is ended with the pound key (#).: After leaving a
message, you can press the pound key (#) to end the recording. After the
subscriber hangs up, the end diagram element is invoked directly.

● Record message information.: If this check box is selected, messages are
saved as records. If this check box is not selected, messages cannot be queried
on the message management page.

● Click Save to save all parameters set on the current page. When the recording
is saved, the system automatically queries the recording directory information
of the current tenant and combines the directory with the current date and a
random digit string to form a file name. An example is Recording drive letter:/
VDNID/record/20190424/20190424153126-record.wav. The recording file is in
the .wav format by default.

NO TE

● When a tenant is deleted, the Customer Service Cloud automatically deletes all
recording files of the tenant.

● The retention period of recording files is the same as the recording storage period
configured during tenant registration. The scheduled task scans recording files at a
specified time every day and periodically deletes recording files that have been stored
for a period longer than expected.
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Condition Branch Description

Table 2-93 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Typical Application Scenario
This diagram element is used in the scenario where a voice message needs to be
stored in a recording file.

SMS

You can send common SMS messages and satisfaction survey SMS messages to
the calling party. The SMS messages can be Huawei Cloud SMS messages or SMS
gateway messages.

Diagram Element

Figure 2-191 Text Message
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Parameter Description

Figure 2-192 Common SMS message parameters
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Figure 2-193 Satisfaction survey SMS message parameters

The parameters are described as follows:

● Message Sending Mode: Currently, Short Message and Satisfaction Survey
are supported.
– To send a satisfaction survey SMS message, you need to set Valid Reply

Period(Minutes). The value ranges from 1 to 1440.

Figure 2-194 Valid Reply Period(Minutes)

● Channel: The options are Huawei Cloud and SMS Gateway.
– Huawei Cloud: The SMS service provided by Huawei Cloud is used to

send SMS messages.
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– SMS Gateway: Huawei SMS gateway is used to send SMS messages.
● Template: This parameter is mandatory. The administrator SMS message

templates that have been configured in the notification center are displayed
based on the selected channel.

● Country Code: This parameter is mandatory. The country or region code is
required for sending an SMS message. If the SMS message needs to be sent
to a national number, the country or region code is also required. For
example, the country code of China is +86.

● Mobile Number: This parameter is optional. If this parameter is left empty,
the SMS message is sent to the calling party by default. If this parameter is
set, the SMS message is sent to the specified number. Only one number is
supported and the value cannot contain the country code.

Condition Branch Description

Table 2-94 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Typical Application Scenario
When a user calls the CEC and the call is routed to the IVR, if the IVR is configured
with a Short Message diagram element, the Short Message diagram element is
used to send an SMS message to the user.

The configuration method is as follows:

● Application Scenario

Step 1 Choose Configuration Center > Flow Configuration > Flow Management, click
New, set the flow name and type, and set Is Referenced to Yes.

Figure 2-195 Adding a flow
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Step 2 Click Edit to develop the flow as follows.

Step 3 Click or drag the Short Message diagram element in the Feature area on the left.
The Short Message diagram element is added to the canvas.

Step 4 Set parameters of the Short Message diagram element and click Save. (Huawei
Cloud SMS is used as an example.)

Figure 2-196 Short Message
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Figure 2-197 Satisfaction Survey

Step 5 Add connection lines. If there are no other diagram elements, the flow is shown in
the following figure.
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Figure 2-198 Example

Step 6 Perform subsequent operations based on business requirements. You can add

other diagram elements. After the configuration is complete, click 
to save the flow.

----End

Satisfaction Configuration

This diagram element is used to play voices or videos to instruct customers to
press keys for interaction and collect their satisfaction details about corresponding
calls.

Diagram Element

Parameter Description

The following figure shows the parameters of the Satisfaction Configuration
diagram element.
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Figure 2-199 Voice
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Figure 2-200 TTS
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Figure 2-201 Video

The parameters are described as follows:

● Node Name: diagram element name which can be customized.

● ccivr.nms.satisfactionservice.evaluateObject: Select Robot or Agent.

● Satisfaction Survey Type: Satisfaction Result, NPS Score, and Resolved or
Not are available.

● Voice Prompt: Select Voice, TTS, or Video. You can click an option button to
select a voice type.

– Voice: Upload a WAV voice file. Currently, the UAP supports only WAV (8
kHz, 8-bit) voice files.

– TTS: Generate a voice file in TTS mode. You can enable Advanced TTS

settings to set voice playback parameters. Click  in the drop-down list
to select a sound effect and speaking speed. If this function is disabled,
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Sound effect is set to Female voice, Speaking speed is set to Low, and
TTS Extended Parameter is not set by default.

▪ Sound effect: Select the sound effect. The options are Male voice
and Female voice.

▪ Speaking speed: Select the speaking speed. The options are Low,
Medium, and High.

▪ TTS Extended Parameter: Set this parameter based on site
requirements. The value contains a maximum of 200 characters.

– Video: Upload a video file in 3GP format, whose size must be less than or
equal to 5 MB.

● Satisfaction Button Configuration: satisfaction options provided in a flow.
Each key or button corresponds to a satisfaction option. For details about how
to configure the satisfaction level, see 2.3.3.2 Configuring Satisfaction
Surveys.
– Buttons: number key or button available on the keyboard or screen, such

as 1, 2, or 3.
– Description: satisfaction introduction of a key or button, which can be

displayed in the menu.

NO TE

Configure satisfaction levels for the satisfaction survey on the Survey > Survey
Config page. If the flow has been published, you can clone, edit, save, or
republish the flow to replace the original flow so that the updated satisfaction
levels can be used.

– Waiting Time for Digit Collection: time to wait for the digit input. If the
time when a customer stops the input exceeds that specified by Waiting
Time for Digit Collection, the system records a failure, automatically
executes Digit collection timed out, and continues to wait for the digit
input.

– Max. Failure Times: maximum number of input attempts that are
allowed. When an error occurs during digit collection, the system records
a failure, automatically executes Digit collection failure, and continues
to wait for the digit input.

● Advanced Settings: You can click Advanced Settings + to expand this area
and click Close to collapse this area.
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– Digit collection failure: You can click  to enable the capability of
playing a voice upon a digit collection error. Then, if digits fail to be
collected before the number of a customer's input attempts reaches the
maximum specified by Max. Failure Times, the system plays a voice to
notify the customer.

– Digit collection timed out: You can click  to enable the
capability of playing a voice upon digit collection timeout. Then, if digits
fail to be collected after the wait time reaches the maximum specified by
Waiting Time for Digit Collection, the system plays a voice to notify the
customer.

NO TE

● If the time when a customer stops the input exceeds that specified by Waiting Time for
Digit Collection, the system records a failure, automatically executes Digit collection
timed out, and continues to wait for the digit input.

● When an error occurs during digit collection, the system records a failure, automatically
executes Digit collection failure, and continues to wait for the digit input.

● By default, Digit collection failure and Digit collection timed out are unavailable in
the Advanced Settings area. If they are unavailable, the system replays the voice
configured for the voice playback and digit collection diagram element upon a failure.

● When the number of a customer's input attempts reaches the maximum specified by
Max. Failure Times, the system executes the common failure exit.

Condition Branch Description

Table 2-95 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no satisfaction option is selected, the
flow goes to the exception handling flow.

 

Typical Application Scenario
This diagram element is used when an agent hangs up without completing the
flow.

NO TE

The application scenario of the Satisfaction Configuration diagram element is as follows:
● After an agent hangs up, the system releases the call and transfers the call to the IVR

flow that contains the Satisfaction Configuration diagram element.
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Key Recognition (Expired and Not Recommended)

This diagram element is used to recognize keys pressed by customers. For
example, a customer uses this diagram element when entering a password for
identity verification.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Rule Expression: expression to verify the type of customer input. For example,

if you select month verification, the month format is yyyyMM.
– Validate mobile number format (with # and *)

i. * — MAIN branch
ii. # — CURRENT branch
iii. 11-digit number ending with a number sign (#) and starting with

135 to 139, 150 to 152, 157 to 159, 147, 182 to 184, 187, 188, or 198
— ValueCheck branch

iv. 11-digit number ending with a number sign (#) and starting with
1340 to 1348 — ValueCheck branch

– Validate mobile number format (without # or *)

i. 11-digit number starting with 135 to 139, 150 to 152, 157 to 159,
147, 182 to 184, 187, 188, or 198 — ValueCheck branch

ii. 11-digit number starting with 1340 to 1348 — ValueCheck branch
– Validate password format (with # and *)

i. * — MAIN branch
ii. # — CURRENT branch
iii. 6-digit number — ValueCheck branch

– Validate password format (with *)

i. * — MAIN branch
ii. 6-digit number — ValueCheck branch

– Validate mobile number (with # and *)

i. * — MAIN branch
ii. # — CURRENT branch
iii. 11-digit number — ValueCheck branch

– Validate mobile number (with *)
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i. * — MAIN branch
ii. 11-digit number — ValueCheck branch

– Validate month input

i. * — MAIN branch
ii. # — CURRENT branch
iii. Valid month in yyyyMM format — ValueCheck branch

● Keyboard Input Type: If this parameter is left blank, the month input
verification is performed by default (Rule Expression must be set to Validate
month input). The entered month must be in yyyyMM format.
– keyBoard_phone: input from a phone keyboard. Enter this value when

the OpenEye or a mobile phone is used.
– checkoldpassword: input from a password keyboard.

● Variable: variable for saving customer input.
● Context: used to filter intentions to be matched to improve the matching

speed. When Keyboard Input Type is set to checkoldpassword, this
parameter is invalid, because semantic recognition is not performed on the
keyboard input.

Using the Diagram Element
The Key Recognition diagram element mainly follows the Robot Reply diagram
element (when Reply Mode is set to a mode related to digit collection, such as
Interruption by key presses or No interruption after digit collection) to save
the pressing content to a variable for further logic processing.

Click the diagram element or drag it to the canvas, and set parameters based on
the parameter description.

Typical Application Scenario
The following describes how to use the Key Recognition diagram element to
enable customers to select a business to be handled by pressing a key.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type. The default value of the variable will be played
to the customer.
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Figure 2-202 Flow variables to be added

Figure 2-203 Flow orchestration example (Key Recognition diagram element)

Figure 2-204 Flow orchestration example (Branch Judgment diagram
element)

– Use the response variable FLOW.key0 for the Response diagram element
of the Key0 condition branch to reply to the customer that the call fee
business is selected.

– Use the response variable FLOW.key1 for the Response diagram element
of the Key1 condition branch to reply to the customer that the data
package business is selected.
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3. Save and publish the flow.

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call. In the test dialog box that is displayed, click Start Call to test the robot.
If the robot answers different businesses based on different keys pressed by the
customer, the configuration is successful.

Figure 2-205 Testing the robot

----End

Rule Verification (Expired and Not Recommended)

This diagram element is used to verify the customer input or output based on
rules.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Text Variable: variable whose value has been obtained before this node. For

example, if a customer wants to query the bills of a month and the customer
says "13", this month can be saved as a flow variable using the Semantic
Recognition diagram element. In this case, the variable is extracted for
month verification.
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● Rule Expression: expression to verify the type of customer input. For example,
if you select month verification, the month format is yyyyMM.

● Validate mobile number format (with # and *)

a. * — true branch
b. # — true branch
c. 11-digit number ending with a number sign (#) and starting with 135 to

139, 150 to 152, 157 to 159, 147, 182 to 184, 187, 188, or 198 — true
branch

d. 11-digit number ending with a number sign (#) and starting with 1340 to
1348 — true branch

● Validate mobile number format (without # or *)

a. 11-digit number starting with 135 to 139, 150 to 152, 157 to 159, 147,
182 to 184, 187, 188, or 198 — true branch

b. 11-digit number starting with 1340 to 1348 — true branch
● Validate password format (with # and *)

a. * — true branch
b. # — true branch
c. 6-digit number — true branch

● Validate password format (with *)

a. * — true branch
b. 6-digit number — true branch

● Validate mobile number (with # and *)

a. * — true branch
b. # — true branch
c. 11-digit number — true branch

● Validate mobile number (with *)

a. * — true branch
b. 11-digit phone number — true branch

● Validate month input

a. * — true branch
b. # — true branch
c. Valid month in yyyyMM format — true branch

● Keyboard Input Type: If this parameter is left blank, the month input
verification is performed by default (Rule Expression must be set to Validate
month input). The entered month must be in yyyyMM format.
– keyBoard_phone: input from a phone keyboard. Enter this value when

the OpenEye or a mobile phone is used.
– checkoldpassword: input from a password keyboard.

● Variable: variable for saving customer input.
● Context: used to filter intentions to be matched to improve the matching

speed. When Keyboard Input Type is set to checkoldpassword, this
parameter is invalid, because semantic recognition is not performed on the
keyboard input.
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Using the Diagram Element
This diagram element is used to verify the customer voice or keyboard input based
on rules.

Click the diagram element or drag it to the canvas, and set parameters based on
the parameter description.

Typical Application Scenario
The following describes how to use the Rule Validation diagram element to verify
whether the customer input is a valid month.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type. The default value of the variable will be played
to the customer.

Figure 2-206 Add Variable

In this example, the Business Interface Invocation diagram element does not
invoke an interface. Instead, it is used to assign values to parameters.

Figure 2-207 Flow orchestration example (Rule Validation diagram element)

– For the false condition branch of the Robot Reply diagram element, set
Reply Variable to FLOW.FalseResponse to reply to the customer with
"The month you entered is invalid".

– For the true condition branch of the Robot Reply diagram element, set
Reply Variable to FLOW.TrueResponse to reply to the customer with
"The month you entered is valid".
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3. Save and publish the flow.

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Start Call to test the robot. If the
robot answers that the month is valid or invalid based on the month entered by
the customer, the configuration is successful.

Figure 2-208 Testing the robot

----End

Date Processing (Expired and Not Recommended)

This diagram element is used to offset the date that a customer speaks by month
or hour. For example, if a customer says "March 2019", this diagram element can
be used to offset March 2019 backward by two months and output "May 2019".

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Offset Period

– By month
– By hour

● Source Character String: variable of the string that has been defined and
assigned a value in the previous flow. The string format is yyyyMM for
offsetting by month and yyyyMMddHHmmss for offsetting by hour. For
example, "201903" said by a customer can be transferred using a variable.
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● Target Character String: variable of the correct string after time conversion.
This parameter is usually set to a flow variable.

● Number of Offsets: mode of converting the source month.

Using the Diagram Element
The Date Processing diagram element is used when the relative time expressed
by a customer needs to be fuzzily processed.

Click the diagram element or drag it to the canvas, and set parameters based on
the parameter description.

Typical Application Scenario
The following describes how to use the Date Processing diagram element to
offset the month said by a customer backward by one month.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type. The default value of the variable will be played
to the customer.

Figure 2-209 Flow variables to be added
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Figure 2-210 Flow orchestration example

3. Save and publish the flow.

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Start Call to test the robot. The robot
outputs input parameters, and the customer enters any month. Then, the robot
offsets the month forward by one month and outputs the result.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 476



Figure 2-211 Testing the robot

----End

SMS Sending (Expired and Not Recommended)

This diagram element is used to invoke an interface for sending SMS messages to
send an SMS message based on a template.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● SMS Template: You can select an SMS template defined under Resource

Management > Resource Template. This function is supported only when
the OP is independently deployed.

● SMS Content: If you do not need an SMS template for a simple content, you
can enter the content here.
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Condition Branch Description

Table 2-96 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS.

SYSERROR_I
NTERFACE

Business
interface
invocation
failure

Triggered if an error occurs when the Business
Interface Invocation diagram element is used
to invoke a third-party interface.
This branch is generally used on the connection
line between the Business Interface Invocation
diagram element and subsequent node.

 

Using the Diagram Element
The SMS Sending diagram element is used to send an SMS message.

Click the diagram element or drag it to the canvas, and select an SMS template or
add an SMS content. If you need an SMS template, define it under Resource
Management > Resource Template in advance.

Typical Application Scenario
The following describes how to use the SMS Sending diagram element to send a
dinner reservation SMS message after the dinner reservation time is confirmed.

Step 1 Add an interface for sending SMS messages. For details, see 2.6.2.2.2 Adding
Business Interfaces.

The message body of the interface must contain the input parameters smsContent
and userMobile. Set other parameters based on the site requirements. The
following is an example:

When you manually enter the message body to configure the interface:
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When the automatically generated message body is used:

Step 2 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 3 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
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2. Click + in the Flow Variable area. In the dialog box that is displayed, set the
variable name and data type.

Figure 2-212 Flow variables to be added

Figure 2-213 Flow orchestration example (SMS Sending diagram element)

– Use the reply variable FLOW.ask for the Robot Reply diagram element
to ask the customer about the dinner reservation date: "What date would
you like to make a reservation for dinner?"

– The input parameters smsContent and userMobile of the SMS message
sending diagram element interface do not need to be set. If they are set,
they are used preferentially.

– You can select an SMS template (variables can be set) or customize the
SMS content.

– SmsContent, SMS template, and SMS content. The priorities of the values
are as follows: smsContent > SMS template > SMS content

– userMobile and the user number obtained by the system. The priority is
as follows: userMobile & > User number obtained by the system

3. Save and publish the flow.

Step 4 Choose Intelligent Chatbot and bind the flow to a robot.
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Step 5 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Start Call to test the robot.

----End

JSON Data Invoking (Expired and Not Recommended)

This diagram element is used to parse and assign values to call-associated data in
JSON format.

Diagram Element

Parameter Description
● Node Name: name of a node.

● Description: details of a node.

● Cache Variable and Response Attribute: flow variables and their values. The
output parameter returned by the interface is valid only on the current node.
If you want to use the value in subsequent flow nodes, define a cache variable
here and assign the value of the output parameter to the cache variable.

NO TE

● When the call-associated data that the common IVR returns to the intelligent IVR
is in the {"data":{"xx": "aaa", "yy":"bbb"}, "ivrType": "0"} format, to obtain aaa,
set Response Attribute of the JSON Data Invoking diagram element in the
intelligent IVR to IVRREQUEST.transin_data.data.xx.

● When a CC-iSales outbound call is transferred to the intelligent IVR, the CC-iSales
converts the call-associated data (for example, "callData":"{\\\"xxx\\\":\\
\"123456\\\",\\\"yyy\\\":\\\"123\\\"}") carried by the API for adding an outbound
number to the format of {"iSales":
{"UniqueID":"***","ServiceID":"***","xxx":"123456","yyy":"123"}. To obtain
123456, set Response Attribute of the JSON Data Invoking diagram element in
the intelligent IVR to IVRREQUEST.transin_data.iSales.xxx.

Using the Diagram Element

When the call-associated data is in JSON format, this diagram element can be
used to obtain the parameters of a specified node and assign values to the
parameters.

Click the diagram element or drag it to the canvas, and set parameters based on
the parameter description.
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Typical Application Scenario
Scenario 1: Transfer a call from a common IVR flow to an intelligent IVR flow
when call-associated data in JSON format is carried.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration, add an intelligent IVR flow, and set parameters
as shown in the following figure. The value of Response Attribute must be
the same as the parameter name transferred by the common IVR.

Figure 2-214 Flow orchestration example

2. Save and publish the flow.
3. Choose Intelligent Chatbot and bind the flow to a robot.

Step 3 Configure a common IVR flow.

1. Choose Configuration Center > Chatbot Management > Flow
Configuration, add a common IVR flow, and orchestrate the flow, as shown
in the following figure.
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Figure 2-215 Flow orchestration example

2. Save and publish the flow.

Step 4 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the common IVR added in Step 3.

Step 5 Log in to the OpenEye and dial the access code added on the Called Party page.

Step 6 Choose Flow Management > Flow Tracking and query the flow check result of
the test number. If the result is the similar to that shown in the following figure,
the intelligent IVR node successfully obtains the value of the call-associated data
parameter (service_id) passed by the common IVR.

Figure 2-216 Flow track log page

----End
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Scenario 2: Transfer a CC-iSales outbound call to an intelligent IVR flow when
call-associated data in JSON format is carried.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent robot.

1. Choose Flow > Orchestration and add an intelligent IVR flow whose Type is
Main flow. Configure the JSON Data Invoking diagram element, as shown in
the following figure. For the Robot Reply diagram element, set Reply Source
to Reply Variable and Reply Variable to FLOW.response.

Figure 2-217 Flow orchestration example

2. Save and publish the flow.

Step 3 Configure an intelligent outbound call task in the CC-iSales.

1. Choose Configuration Center > Call Config > Data Attr and create
attributes, as shown in the following figure. That is, create call-associated
data fields used during outbound call creation. You can click Call Data
corresponding to an outbound call task to bind the call-associated data fields
added here. Publish the attribute.
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Figure 2-218 Create Attribute page

2. Choose Outbound Call > Call Mgmt, click Create, and choose Robot
Outbound.

3. Configure an intelligent outbound call task. Set Task Type to Intelligent
Outbound Call and IVR Flow to the intelligent IVR flow added in Step 2, and
save the configuration.

Figure 2-219 Page for configuring an intelligent outbound call task

4. Click Outbound Call Data in the Operation column corresponding to the
new intelligent outbound call task, click New, and add CC-iSales outbound
numbers (for example, 88882020) one by one and configure the call-
associated data to be passed.
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NO TE

To import outbound call data in batches, see 2.13.3.7.1 Configuring Outbound Call
Data.

Figure 2-220 Configuring outbound call data

Figure 2-221 Configuring the call-associated data to be passed

Step 4 Log in to the OpenEye using a configured outbound number, and start the
intelligent outbound call task. After answering the call, you can hear the call-
associated data (ServiceID) passed by the CC-iSales outbound call.

Step 5 Choose Flow Management > Flow Tracking and query the flow check result of
the test number. If the result is the same as that shown in the following figure, the
intelligent IVR node successfully obtains the value of the call-associated data
parameter (ServiceID) passed by the CC-iSales outbound call.
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Figure 2-222 Flow track log page

----End

Composite

A composite diagram element is a combination of multiple diagram elements that
an operator customizes for simplified operations.

Diagram Element

NO TE

What are the differences between a composite diagram element and a Flow Transfer
diagram element?

In a flow, input and output parameters can be defined by using composite diagram
elements. That is, after the flow in a composite diagram element is executed, other steps in
the original flow can be continued. After the flow is transferred, however, the current flow
ends, and the data in the transferred flow can no longer be obtained to execute the original
flow.

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Input Parameters: list of input parameters for the composite diagram

element.
● Output parameters: list of output parameters for the composite diagram

element.

Using the Diagram Element

A composite diagram element can function as a specific sub-function module. You
can use a composite diagram to combine operations frequently used in flows. If
multiple flows use the same operations, you can use a composite diagram
element to write the same operations. During orchestration of a complex flow, if
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the number of diagram elements exceeds 100, you can use composite diagram
elements to store remaining operations of the flow.

Before creating a composite diagram element, you need to perform the following
operations:

1. Create a composite diagram element catalog. (A maximum of 100 catalogs
can be added.)

2. Enter the basic information about the composite diagram element, select a
catalog for storing the diagram element, and edit its flow.

3. Edit the composite diagram element canvas. After creating a composite
diagram element, orchestrate its flow on the canvas based on the basic flow
orchestration logic. You can use basic diagram elements to define a composite
diagram element on the Resource > Complex Cell page.

Typical Application Scenario
The following describes how to use a composite diagram element to greet and
interact with the robot.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Add a composite diagram element.

1. Choose Resource > Complex Cell, click the Composite Diagram Element

Catalog tab, and click .

Figure 2-223 Page for adding a composite diagram element catalog

2. Click the Composite Diagram Element tab and click .

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 488



Figure 2-224 Page for adding a composite diagram element

3. Click Edit Canvas in the Operation column to orchestrate the composite
diagram element.

Step 3 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type.

Figure 2-225 Flow variables to be added
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Figure 2-226 Flow orchestration example (composite diagram element)

Set the input parameter of the composite diagram element to FLOW.answer
to transfer the customer answer to the composite diagram element.

3. Save and publish the flow.

Step 4 Choose Intelligent Chatbot and bind the flow to a robot.

Step 5 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call. In the test dialog box that is displayed, click Start Call to test the robot.
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If the dialog with the robot is normal, the composite diagram element is
configured successfully.

----End

Avatar Reply

This diagram element is used to configure virtual humans who respond to
customers in intelligent video customer service. It can be used to play virtual
human videos to customers in flows.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Operation: The options are Initiate, TTS, and Call Ending.

Figure 2-227 Setting Operation for the Avatar Reply diagram element

– Initiate: A session with the virtual human service is initiated. You need to
specify the virtual human to be used.

– TTS: The configured text is provided for the virtual human service for
video synthesis and playback. Variables can be added to the reply text,
and the virtual human service dynamically plays a voice based on the
return values of the variables.

– Call Ending: The session with the virtual human service is ended.
● Avatar Image: This parameter is displayed when Operation is set to Initiate.

Select a virtual human configured on the Configuration Center > Chatbot
Management > Flow Configuration > Resource > Virtual Human page.
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Figure 2-228 Selecting a virtual human

● Reply Variable: This parameter is displayed when Operation is set to TTS.
Enter the text variable to be used by the virtual human to reply.

Figure 2-229 Selecting TTS

a. Reply Template: This parameter is displayed when Operation is set to
TTS. Select a template whose Type is TTS under Configuration Center >
Chatbot Management > Flow Configuration > Resource > Resource
Template.

b. Reply Variable: This parameter is displayed when Operation is set to
TTS. Set Reply Variable to a variable of the Character type.

c. Reply Resource: This parameter is displayed when Operation is set to
TTS. Select a text resource whose Status is Approved under
Configuration Center > Resource Management > Audio and Video.

● Reply Mode: This parameter is mandatory. The options are as follows:
– Playback only: Only the voice or video is played, and customer input

does not need to be received. Generally, this option is selected for static
voice playback.
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– Interruption recognition: The customer needs to answer by voice.
Generally, this option is selected for replying to text.

– Interruption by key presses: The keys pressed by the customer need to
be obtained. If Reply Mode of the Robot Reply diagram element is set to
Interruption by key presses and the key interaction result needs to be
obtained, the Robot Reply diagram element cannot be directly connected
to the Call Ending diagram element, and the Key Recognition and
Semantic Recognition diagram elements cannot be directly connected
before the Call Ending diagram element.

– Recognition and key presses: Both voice and key information can be
received. The information received first is used for matching.

– Recognition after playback: The system starts to identify the voice or
video only after the voice or video is played. If a customer speaks during
the playback, the system does not receive the voice.

– Recognition and key presses after playback: The system starts to
identify the voice or video and collect digits only after the voice or video
is played. If a customer speaks or presses a key during the playback, no
information can be received. If a customer speaks or presses a key after
the playback, the information that is received first is used for matching.

– No interruption after digit collection: Keys can be pressed when the
voice or video is played, but the playback is not interrupted.

– Custom Variable Value: whether voice playback can be interrupted. If
voice playback can be interrupted, set Minimum Voice Playing Duration.
String true -- Voice playback can be interrupted during recognition, and
the minimum voice playback duration can be passed.
String false -- Recognition is performed after voice playback.

● Timeout Interval: timeout period, in seconds. If this parameter is not set, the
default value 15 is used. If the duration exceeds the value of this parameter,
the system determines that timeout occurs. The value range of this parameter
varies with vendors. Currently, the maximum value is 180.
– If Reply Mode is set to Recognition after playback, the duration starts

from the time when the TTS voice playback ends to the time when the
recognition stops.

– If Reply Mode is set to Interruption by key presses or Interruption
recognition, the duration starts from the time when the voice playback
ends. For example, if a customer does not speak after the TTS voice
playback ends, the robot goes to the next diagram element when the
timeout period ends.

– If Reply Mode is set to Playback only, the timeout period does not take
effect.

NO TE

Pay attention to the setting of the timeout period in the following scenarios: long TTS
voice playback, many keys (such as an ID card) to be pressed by a customer, and
many opinions to be said by a customer. When Reply Mode is set to Interruption by
key presses or Interruption recognition, if the timeout period is short, the
recognition may start before the voice playback ends, or the recognition may end
before the customer completes key pressing. If the timeout period is long, there may
be a long-time silence after the customer completes key pressing, and a timeout
notification is displayed after a long time.
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Robot Message Reply Timeout Processing
– waitFlag: session identifier. If the value of timeout is less than the

remaining timeout period of the current session, the value of waitFlag is
true. Otherwise, the value is false.

– waitTimeout: message timeout period.
– waitBeginTime: When the value of waitFlag is true, the value of

waitBeginTime is set to the current time.
– When the value of waitFlag is true, reply timeout is processed. When the

value of waitFlag is false, the original message processing logic is used.
– Processing logic: After a message times out, the CC-Messaging triggers

the timeout flow and pushes the robot response to the customer.
● ASR Advanced Settings: The options are Enable and Disable. The default

value is Disable.
– Recognition Type: The option is Common. The default value is Common.

This parameter is configurable when ASR Advanced Settings is set to
Enable.

– Subscriber Silence Timeout Interval: The default value is 100, in
seconds. The value ranges from 0 to 32000. This parameter is
configurable when ASR Advanced Settings is set to Enable.

– Recognition Timeout Interval: The default value is 200, in seconds. The
value ranges from 0 to 600. This parameter is configurable when ASR
Advanced Settings is set to Enable.

– Subscriber Pause Timeout Interval: The default value is 500, in
milliseconds. The value ranges from 300 to 2000. This parameter is
configurable when ASR Advanced Settings is set to Enable.

– ASR Extended Parameter: Enter the data required by the ASR business
on the IVR side, for example, the vendor information. The value is
returned to the IVR system using the vendor parameter of the dialog
interface.

● TTS Advanced Settings: The options are Enable and Disable. The default
value is Disable.

Figure 2-230 TTS Advanced Settings

– Speaker: Enter the speaker to be used by the virtual human. This
parameter is available when TTS Advanced Settings is enabled.

– Voice Speed: Enter a value ranging from 0.5 to 1.5. Only one decimal
place is supported. 1.0 indicates the normal voice speed. 0.5 indicates the
slowest voice speed, and 1.5 indicates the fastest voice speed. This
parameter is available when TTS Advanced Settings is enabled.

● Composite Video Configuration: Enable or disable this function. By default,
this function is disabled.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 494



Figure 2-231 Composite Video Configuration

● Actions: Enter the action to be used by the virtual human. This parameter is
available when Composite Video Configuration is enabled.

● Picture and Video Settings: Configure Front Image, Backend Image, Front
Video, and Backend Video.

Figure 2-232 Picture and Video Settings

– Front Image: Select the foreground image used during virtual human
video synthesis. A maximum of five foreground images can be configured
for a diagram element.

▪ Image: Select a 2D virtual human image configured on the
Configuration Center > Resource Management > Audio and Video
page.

▪ Abscissa: Enter the horizontal coordinate for image display. The
value is an integer greater than 0. The default value is 0.

▪ Ordinate: Enter the vertical coordinate for image display. The value
is an integer greater than 0. The default value is 0.

▪ Scale: Enter the zoom ratio of the image to be displayed. Only one
decimal place is supported. The value ranges from 0.5 to 1.0.

▪ Start Time (ms): Enter the time when the image starts to be
displayed. The value is an integer greater than 0, in milliseconds. This
parameter can be left blank.

▪ Display Duration (ms): Enter the duration for displaying the image.
The value is an integer greater than 0, in milliseconds. This
parameter can be left blank.

– Backend Image: Select the background image used during virtual human
video synthesis. A maximum of five background images can be
configured for a diagram element.
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▪ Image: Select a 2D virtual human image configured on the
Configuration Center > Resource Management > Audio and Video
page.

▪ Abscissa: Enter the horizontal coordinate for image display. The
value is an integer greater than 0. The default value is 0.

▪ Ordinate: Enter the vertical coordinate for image display. The value
is an integer greater than 0. The default value is 0.

▪ Scale: Enter the zoom ratio of the image to be displayed. Only one
decimal place is supported. The value ranges from 0.5 to 1.0.

▪ Start Time (ms): Enter the time when the image starts to be
displayed. The value is an integer greater than 0, in milliseconds. This
parameter can be left blank.

▪ Display Duration (ms): Enter the duration for displaying the image.
The value is an integer greater than 0, in milliseconds. This
parameter can be left blank.

– Front Video: Select the foreground video used during virtual human
video synthesis. Only one foreground video can be configured for a
diagram element.

▪ Video: Select a 2D virtual human video configured on the
Configuration Center > Resource Management > Audio and Video
page.

▪ Abscissa: Enter the horizontal coordinate for image display. The
value is an integer greater than 0. The default value is 0.

▪ Ordinate: Enter the vertical coordinate for image display. The value
is an integer greater than 0. The default value is 0.

▪ Scale: Enter the zoom ratio of the video to be displayed. Only one
decimal place is supported. The value ranges from 0.5 to 1.0.

▪ Start Time (ms): Enter the time when the video starts to be
displayed. The value is an integer greater than 0, in milliseconds. This
parameter can be left blank.

– Backend Video: Select the background video used during virtual human
video synthesis. Only one background video can be configured for a
diagram element.

▪ Video: Select a 2D virtual human video configured on the
Configuration Center > Resource Management > Audio and Video
page.

▪ Abscissa: Enter the horizontal coordinate for image display. The
value is an integer greater than 0. The default value is 0.

▪ Ordinate: Enter the vertical coordinate for image display. The value
is an integer greater than 0. The default value is 0.

▪ Scale: Enter the zoom ratio of the video to be displayed. Only one
decimal place is supported. The value ranges from 0.5 to 1.0.
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▪ Start Time (ms): Enter the time when the video starts to be
displayed. The value is an integer greater than 0, in milliseconds. This
parameter can be left blank.

Condition Branch Description

Table 2-97 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS.

 

Using the Diagram Element
● Click the diagram element or drag it to the canvas. Before configuring virtual

human reply parameters, you need to maintain virtual humans in advance.
Then, you can select one of them in the Service Parameter area.

Typical Application Scenario
The following describes how to use the Avatar Reply diagram element to play a
welcome tone to customers.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type. The default value of the variable will be played
to the customer.

Figure 2-233 Adding a flow variable
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Figure 2-234 Flow orchestration example

3. Save and publish the flow.

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call. In the test dialog box that is displayed, click Start Call to test the robot.
If the robot automatically answers the video path generated by the virtual human
service, the configuration is successful.

----End

Connection Lines Between Diagram Elements

The connection line indicates the execution sequence of a flow with its arrow
direction.

Appearance
● The following figure indicates that no node is selected.
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● The following figure indicates that nodes are selected and the connection is
successful.

Parameter Description
● Branch Condition: branch condition corresponding to the current flow

connection line.

Except the preset timeout or unmatched condition, other conditions are the
branch conditions configured by the diagram element in the previous step.

The following table describes the preset branches.

Table 2-98 Preset branches

Name Description Usage Method

timeout1 First timeout This branch condition is triggered when a
third party system (for example, the IVR)
determines that a timeout occurs in receiving
the customer feedback and sends a message
to the OIAP, indicating that the value of input
is timeout.
This branch is generally used on the
connection line between the Semantic
Recognition diagram element to the
subsequent node, indicating that semantic
recognition times out before a response is
received from the customer.

timeout2 Second
timeout

During a call, timeout2 is triggered when
timeout1 occurs for the second time.
During script flow design, a flow retry is
required when the first timeout occurs. If the
second timeout occurs, the current step is
skipped and the subsequent steps are
performed.

nomatch1 First
recognition
failure

nomatch1 is triggered in either of the
following scenarios:
● The Semantic Recognition diagram

element does not match a result (that is,
the diagram element returns the command
word of an unknown intention).

● A third-party system (for example, the IVR)
returns a message in which the value of
input is nomatch.
In this scenario, the ASR system fails to
recognize the intention and sends a failure
response to the IVR.
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Name Description Usage Method

nomatch2 Second
recognition
failure

During a call, nomatch2 is triggered when
nomatch1 occurs for the second time.

error3 Third error If the trigger condition corresponding to
timeout1 and nomatch1 occur for the third
time during a call, error3 is triggered.
If the number of error times does not need to
be accumulated, use the Error Count
Clearance diagram element to clear the
number of error times before using this
condition.

SYSERROR_
INTERFACE

Business
interface
invoking
failure

This branch condition is triggered if an error
occurs when the Business Interface
Invocation diagram element is used to invoke
a third-party interface.
This branch is generally used on the
connection line between the Business
Interface Invocation diagram element and
subsequent node.

SYSERROR_
INNER

ODFS
internal error

This branch condition is triggered when other
unknown errors occur in the ODFS.

slientInsert
Reply

Direct reply
by silent
agents

This branch condition can be used only when
the Semantic Recognition diagram element
of the silent agent system is configured. By
using this diagram element, agents can
directly answer the call and continue to
execute other expected business flows.

 
● Description: details of the current branch.

Using Connection Lines

Each diagram element in a flow must be connected, except the Call Ending
diagram element in special scenarios.

2.6.2.5.2 Parameters

Parameters can be set for other diagram elements except Start and Flow transfer
diagram elements. Two types of parameters are preset in the system, that is,
system variables and slot variables in intentions. You can directly enter a system
variable in a text box. You need to add a specified prefix to a slot variable in a text
box.

The variables are set as follows:

1. Move the cursor to the text box for variable input, and select a prefix of the
desired variable that is associated by the text box.
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– FLOW: flow variable, which is valid only in one flow.
– GLOBAL: global variable, which needs to be preset by choosing Resource

Management > Global Variable and is valid in the entire session
instance of a flow.

– SYS: system variable, which is preset and usually obtained from public
data in the system and sessions, such as the system time and access
code.

– TOC: intention variable. Parameters returned by the Semantic
Recognition diagram element are valid only for the diagram element. If
you want to use the parameters later, assign values to flow variables and
transfer them to subsequent nodes.

– IVRREQUEST: IVR request variable, which is transferred using the OIAP
dialog interface when the IVR flow invokes an intelligent flow.

2. Manually enter a period (.) after the selected prefix, move the cursor to the
period, and select a desired parameter from the associated parameters.

System Variable (SYS)

In general, preset system variables are obtained from the public data such as the
system time and access code in the system environment and session.

Parameter Description

SYS.systemDate System date. The value is a character string.
The value format is YYYYMMDD, with four digits for
the year, two digits for the month, and two digits for
the date. If the number of digits is insufficient, use 0
for padding. For example, April 12, 2019 can be
expressed as 20190412.

SYS.systemMonth System year and month. The value is a character string.
The value format is YYYYMM, with four digits for the
year and two digits for the month. If the number of
digits is insufficient, use 0 for padding. For example,
April 2019 can be expressed as 201904.

SYS.systemTime Current system time. The value is a character string.
The value format is HHmmss, with two digits for each
of the hour (24-hour format), minute, and second. If
the number of digits is insufficient, use 0 for padding.
For example, 16:00 can be expressed as 160000.
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Parameter Description

SYS.callingNumber Customer phone number. When a call is connected to
the AICC, this parameter indicates the calling number.
When a call is made by the AICC, this parameter
indicates the called number. Both the calling number
and called number are customer phone numbers. The
value is a character string. The number is transferred by
an IVR flow.

SYS.calledNumber Access code. The value is a character string. The access
code is transferred by an IVR flow, and can be viewed
on the web application server (WAS) console of the
computer telephony integration (CTI) platform.

SYS.realCalledNumber Access code configured on the Called Party page for
the flow, that is, the hotline number dialed by the flow.

SYS.callId Session ID on the ODFS. The value is a character string.
The ID is transferred by the IVR flow, that is,
IVRREQUEST.call_id.

SYS.cti_callid CTI call ID transferred by the IVR flow, that is,
IVRREQUEST.cti_callid on the IVR side.

SYS.tenantId Current tenant ID. The value is a character string.

SYS.language Current customer language. The value is a character
string.
To support multiple languages, assign a value to this
variable. For example, assign en_US for English.

SYS.timeStamp Timestamp, which is a character string. Total number of
seconds from 1970-01-01 00:00:00 (GMT) (Beijing time
1970-01-01 08:00:00) to the current time.

SYS.callMediaType Call media type.
● 1: voice
● 3: voice and video

SYS.currentTime Current system time, which is in yyyyMMddHHmmss
format.

SYS.createTime Call start time.

 

Expressions that contain parameters comply with JavaScript syntax, and the result
is of the boolean type. For example, in the Batch Judgment diagram element, you
can determine whether the current time is within or beyond the service time using
the following expressions.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 502



● Service Hours: (SYS.systemTime > '110000') && (SYS.systemTime <
'220000')

● Non-service hours: (SYS.systemTime < '110000') || (SYS.systemTime >
'220000')

Intention/Slot Variable (TOC)

You can use a parameter for value assignment or judgment in the semantic
recognition service diagram element. This parameter is valid only in the current
diagram element. If you want to use it in subsequent diagram elements, define a
flow variable and assign a value to it. The following table describes the flow
variables.

NO TE

The system directly recognizes intention slot variables as those of the character string type.
Therefore, use the same type of flow variables when associating the slot variables with flow
variables.
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Parameter Description

TOC.ChatBotIntentCod
e

Code of a matched intention in semantic recognition.
The value is a character string.
The following ChatBotIntentCodes are preset in the
system and can be directly used:
● systemQA
Generally, you can obtain the value of this parameter
to determine whether the correct intention is matched.

ChatBotRespContent Reply for the intention matched in semantic
recognition, including the reply configured in the slot
and response.
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Parameter Description

TOC.ChatBotScenario-
Name

Name of the intention that is matched after the
semantic recognition is executed. The value is a
character string.
For example, you can set TOC.ChatBotScenarioName
to Seat Type in the following scenario.

TOC.ChatBotSlot
name

This parameter is the slot parameter set in the
intention. The value is a character string. You can use
the intention to view the slot parameters of the
intention.
Choose Configuration Center > Chatbot
Management > Semantic Understanding >
Knowledge Management > Intention Management,
select a domain from the first drop-down list, click the
name link, and then click the Slot tab to view the slot
variable names in the Name column.
For example, to obtain the slot value in the following
intention, you can set it as follows:
TOC.ChatBotsitType = "Suite"
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Parameter Description

TOC.ChatBotResponse This parameter returns all the content in the
recognition interface. An example structure is as
follows: {"intents":[{"simQuestions":
[],"scenarioType":"normal","scenarioStatus":"finish"
,"confidence":1.0,"responses":
["Balance"] ,"priority":0,"params":
{},"scenarioName": "Call fee query 2","commands":
["21312","TEXT"]}],"statusCode":200}
To obtain similar questions, use
TOC.ChatBotResponse.intents[0].simQuestions.

TOC.DialogAnalysis This parameter returns all content processed by the
conversation analysis diagram element. The structure is
as follows:
Sentiment analysis function response example:
{"Intend":"","call_script":
[],"call_script_matchedstep":"systemQA","role":"","sensi
tive_word":
{},"sentiment_analysis":"negative","sentiment_analysis_
score":0.0}
Q&A search function response example:
{"Intend":"","call_script":
[],"call_script_matchedstep":"systemQA","recomand_KP
":[{"answers":["Today
iscloudy"],"faqGroupId":13113,"faqGroupName":"Weat
her","faqId":21304,"prob":24.0,"question":"How's the
weather"}],"role":"user","sensitive_word":
{},"sentiment_analysis_score":0.0}
Intent recognition function response example:
{"Intend":"Buy insurance","call_script":
[{"intentcode":"Insurance","intentDsp":"Buy
insurance","status":"finished","childintent":
[{"intentcode":"Insurance","intentDsp":"Buy
insurance","status":"finished"}]}],"call_script_matchedst
ep":"Insurance","recomand_KP":
[],"role":"user","sensitive_word":
{},"sentiment_analysis_score":0.0}

 

Global Variable (GLOBAL)

To define a variable that can be used in different flows, you can add a global
variable, for example, Param1, under Resource > Variable.

The following variable data types are supported:

● Integer

● Character
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● Long integer
● Floating-point number
● List
● Object

You can use this variable in the flow variable definition area and Semantic
Recognition, Interface Invoking, and Robot Reply diagram elements. The format
is as follows:

GLOBAL.Variable name

Example: GLOBAL.Param1

NO TE

In the attribute names in the response, the data type of the value that you assign to the
parameter must match the data type set in the Variable Management. If the value is of
the character type, you need to add quotation marks.

Flow Variable (FLOW)

A cache variable that you add to a flow is called a flow variable. The variable can
be used in the subsequent nodes of the flow.

Flow variables are represented by FLOW.Flow variable name. In the TTS template
or SMS template, you need to use ${FLOW.Flow variable name} to specify
parameters.

For example, you can define the following variables in a flow.
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You can assign values to flow variables in the Semantic recognition diagram
element.
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The following figure shows the reply to a customer in the SMS template after the
reservation is successful.

IVR Request Variable (IVRREQUEST)

The OIAP provides IVR interfaces for the IVR to invoke. Therefore, during flow
orchestration, fields in IVR requests can be directly used as variables.

The following describes the method.

Parameter Description

IVRREQUEST.cti_callid Call ID of the CTI which a call is connected to and
transferred by Huawei IVR. In other scenarios, this
parameter is left empty. The value can contain a
maximum of 32 characters.
Currently, this parameter is reserved.
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Parameter Description

IVRREQUEST.input Dialog interaction result.
● Voice recognition result or text input. The voice

recognition result is the text converted from the
voice. The text input result is the text content.

● Voice key result, which is the key value, for example,
1 and 201801.

● playover: voice playback completed
● timeout: timeout
● nomatch: recognition failure or key pressing failure
● sys_err: system exception
● hangup: hangup
● recordend: recording ended
If the result is hangup, the hangup response of the
ODFS can be triggered.
The value can contain a maximum of 1024 characters.

IVRREQUEST.IACmd Field dedicated for intelligent match and intelligent
case filling.
● This parameter must be set to match when

intelligent match is used.
● This parameter can be set to any of the following

values when intelligent case filling is used:
match: A case filling request is submitted.
rematch: Re-identify an event when the
classification of the identified event is incorrect.
confirm: When an agent selects a field, the system
notifies the ODFS that the field has been confirmed.

IVRREQUEST.TextSour
ce

Source of the request text.
● This parameter specifies whether the input text is

from an agent or a subscriber when IACmd is set to
match (same for intelligent match and intelligent
case filling). This parameter can be set to operator
or user.
operator: agent
user: customer

● The name of the field selected by the agent is
transferred when IACmd is set to confirm, for
example, object level 2.

● This parameter is optional when IACmd is set to
rematch.

IVRREQUEST.transin_d
ata

Associated data parameters agreed by the access party
and the OIAP, for example, data packet parameters
transferred by the IVR.
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Parameter Description

IVRREQUEST.begin_pl
ay

Voice playback start time.

IVRREQUEST.end_play Voice playback end time.

IVRREQUEST.call_id Unique call ID, which is the same as the value of userid
and is used by the flow.
The value can contain a maximum of 64 characters.

IVRREQUEST.inter_idx Number of consecutive interactions with a subscriber,
which is recorded on the ODFS side.

IVRREQUEST.feedback Satisfaction. The options are 1 (satisfactory) and 0
(unsatisfactory). Integer.

IVRREQUEST.feedback
Content

Dissatisfaction reason. If the feedback is satisfactory,
leave this parameter empty.

IVRREQUEST.channelT
ype

Type of the channel through which a customer accesses
the system. The options are WEB (web), INSTAGRAM
(Instagram), TELEGRAM (Telegram), WECHAT
(WeChat), FACEBOOK (Facebook), TWITTER (X
(Twitter)), EMAIL (email), LINE, WHATSAPP
(WhatsApp), 5G (5G RCS), and SMS.

IVRREQUEST.emailTitl
e

Subject of the email received during email channel
access.

IVRREQUEST.ieValue The IE information transmitted in the flow can be
obtained. Currently, only the User To User option is
available.

 

2.6.2.5.3 TUC Interfaces

This section describes the interfaces used by the TUC.

/chatbot/rest/tuc/v1/nlp/detectRegularEntity

Function

Rule (address) entity recognition interface.

Input Parameters

Parameter Type Mandatory
(Yes/No)

Description

language String Yes Language. The
option is zh_CN.
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Parameter Type Mandatory
(Yes/No)

Description

sentence String Yes Recognition text.

 

Output Parameters
Parameter Type Description

addr1 List<String> User-defined address
entity.

addr2 List<String> User-defined address
entity (layer 2).

 

Request Example
{
   "language": "${language}",
   "sentence": "${sentence}"
}

/chatbot/rest/tuc/v1/nlp/identify

Function
Language identification interface.

Input Parameters

Table 2-99

Parameter Type Mandatory
(Yes/No)

Description

text String Yes Text information
entered by a
customer.

 

Output Parameters
Parameter Type Description

returnCode String Result code.

returnMsg String Return information.

params LangIdOutputParams Language recognition
result.
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LangIdOutputParams is described as follows.

Parameter Type Description

language String Language. The options are as
follows:
zh_CN
en_US
The following are minority
languages. To use these languages,
you need to download the minority
language recognition model.
ar
es_ES
pt_BR
th_TH
fr_FR

score Float Confidence.

 

Request Example
{
    "callId": "${businessReqId}",
    "provId": "fangyg",
    "busiType": "0",
    "params": {
        "text": "${text}"
    }
}

The values of callId, provId, and busiType are automatically generated by the
system.

/chatbot/rest/tuc/v1/recommendFaq

Function
FAQ recommendation interface.

The recommended knowledge list is matched based on the text in the request.
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Input Parameters

Table 2-100

Parameter Type Mandatory
(Yes/No)

Description

user String Yes ID of the user
who initiates the
question.

sentence String Yes Sentence that
needs to match
the recommended
FAQ. The
description cannot
exceed 1024
characters.

language String Yes Language.
The options are as
follows:
● en_US: English
● ar: Arabic
● es_ES: Spanish
● zh_CN: Chinese
● fr_FR: French

threshold Double No FAQ confidence
threshold.
Default value: 0. If
the value is a
number, the
system returns
only the FAQs
whose confidence
is greater than
the value.

 

Output Parameters
Parameter Type Description

recommends List [FaqAnswer] Returned FAQ result set.

 

FaqAnswer is described as follows.
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Parameter Type Description

faqGroupId Integer FAQ group ID.

faqGroupName String FAQ group name.

faqId Integer FAQ ID.

question String Question.

answers List <String> Answer list.

prob Double Confidence. The value is a
probability greater than 0.

 

Request Example
{
    "user": "${user}",
    "sentence": "${sentence}",
    "language": "${language}",
    "threshold": "${threshold}
}

/chatbot/rest/tuc/v1/qualityInspection/qiOnline/recognize

Function
Online inspection interface.

Input Parameters

Table 2-101

Parameter Type Mandatory
(Yes/No)

Description

role String No Role. The options
are staff,
customer,
operator, and
user.

beginTime long No Start time.

endTime long No End time.

callId String Yes Call ID.

content int Yes Description.

language int Yes Language. The
options are zh_CN
and en_US.
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Output Parameters

Parameter Type Description

role String Role.

emotion EmotionResult Recognition type.

dialogRules List<DialogRule> Dialog rule.

silenceRules List<SilenceRules> Silence rule.

speedRules List<SpeedRules> Speed rule.

interposalRules List<InterposalRules> Interruption rule.

 

EmotionResult is described as follows.

Parameter Type Description

score int Score.

emotionType String The value can be positive or
negative.

 

DialogRule is described as follows.

Parameter Type Description

id String Rule ID.

name String A maximum of 128 characters are
allowed.

description String A maximum of 1024 characters are
allowed.

severity String Rule type. The options are normal
and critical.

min int Minimum number of dialog logics.
The value ranges from 1 to 100.

score int Rule score. The value ranges from –
100 to 100.

method String The rule is positive or negative. The
options are positive and negative.

callBegin long Call start time.

callEnd long Call end time.
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SilenceRules is described as follows.

Parameter Type Description

id String Rule ID.

name String Rule name.

score int Score. The value ranges from 0 to
100.

silenceSeconds int Silence duration. The value range is
[1, -].

silenceTimes int Number of silence times. The value
range is [1, -].

exception SilenceException Expression between groups.

callBegin long Dialog start time.

callEnd long Dialog end time.

 

SpeedRules is described as follows.

Parameter Type Description

id String Rule ID.

name String Rule name (a maximum of 64
characters).

minSpeed int Minimum speed. The value ranges
from 1 to 220.

maxSpeed int Maximum speed. The value range is
[1, -].

score int Score. The value ranges from –100
to 0.

callBegin long Call start time.

callEnd long Call end time.

 

InterposalRules is described as follows.

Parameter Type Description

id String Rule ID.

name String A maximum of 128 characters are
allowed.
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Parameter Type Description

score int Rule score. The value ranges from –
100 to 0.

interposalTimes int Interruption times. The value
ranges from 1 to 10000.

interposalSeconds int Interruption duration. The value
ranges from 1 to 10000.

callBegin long Call start time.

callEnd long Call end time.

 

Request Example
{
      "role": "${role}",
      "beginTime": "${beginTime}",
      "endTime": "${endTime}",
      "callId": "${callId}",
      "content": "${content}",
      "language": "${language}"
}

/chatbot/rest/tuc/v1/nlp/feedback

Function
Satisfaction feedback interface.

Input Parameters
Parameter Type Mandatory

(Yes/No)
Description

accessCode String Yes Access code.

callId String Yes Call ID.

interactId String Yes Interaction ID.

satisfaction int Yes Satisfied or not.

reason String No Dissatisfaction
reason.

 

Output Parameters
Parameter Type Description

errorCode String Error code.
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Parameter Type Description

errorMsg String Error information.

 

Request Example
{
    "accessCode": "${accessCode}",
    "callId": "${callId}",
    "interactId": "${interactId}",
    "satisfaction": "${satisfaction}",
    "reason": "${reason}"
}

/chatbot/rest/tuc/v1/nlp/textClassify

Function

Text classification interface.

Input Parameters

Table 2-102 Request input parameters

Parameter Type Mandatory
(Yes/No)

Description

language String Yes Language. The
option is zh_CN.

text String Yes Recognition text.

 

Output Parameters

Parameter Type Description

results List<TextLabel> For details, see Table
2-103.

 

Table 2-103 TextLabel description

Parameter Type Description

label String Label.

probability Double Confidence.
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Request Example
{
    "language": "${language}",
    "text": "${text}"
}

/chatbot/rest/tuc/v1/nlp/detectEntity

Function

Entity recognition interface.

Input Parameters

Parameter Type Mandatory
(Yes/No)

Description

language String Yes Language. The
options are as
follows:
zh_CN
en_US
ar
es_ES
pt_BR
th_TH
multi
fr_FR

sentence String Yes Recognition text.

 

Output Parameters

Parameter Type Description

entityMsgV2List List <EntityMsgV2> For details, see Table
2-104.

count Integer Number of identified
entities.

 

Table 2-104 EntityMsgV2 description

Parameter Type Description

FORMAT_RAW String Format.

id Integer ID.
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Parameter Type Description

citation String Reference name of an entity, for
example, reference name of an
address in a system entity
(@system.address).

type Integer Entity type.
● -1: system or environment entity,

not a user entity
● 0: common entity
● 1: composite entity
● 2: rule entity
● 3: entity identified by the LODAS

userEntity Boolean Whether the entity is a user entity.

envEntity Boolean Whether the entity is an
environment entity.

beginIndex Integer Start sequence number in the input
statement when the entity value is
identified.

endIndex Integer End sequence number in the input
statement when the entity value is
identified.

values Map <String,
String>

Identified entity value pair.
The value is in Entity type:Entity
value format.
Example: "@system.address":
"Yuelu District, Changsha City,
Hunan Province"

formats List <String> List of reference formats that
identify the entity.
For example, in the value
["raw","province"], "raw"
indicates the original value, and
"province" indicates the province.

synonyms List <String> Synonym.

 

Request Example
{
    "language": "${language}",
    "sentence": "${sentence}"
}
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/chatbot/rest/tuc/v1/qualityInspection

Function
Intelligent training interface. After the training model is deployed and trained on
the LODAS, the business interface in the intelligent IVR is invoked to send the user
voice text information to the LODAS and obtain the scoring result from the
intelligent engine. With the help of intelligent capabilities, an integrated system is
built to implement capabilities such as customer chatbot simulation call training,
automatic evaluation of reply accuracy, and automatic evaluation of operation
accuracy. The following are implemented to improve work efficiency from the
perspectives of employees, systems, and operations: pre-job tests and appraisals
for new employees, training and appraisals for key and difficult business
capabilities, job rotation training and appraisals for on-the-job employees, and
reinstatement training and appraisals for employees awaiting job assignment.

Input Parameters

Table 2-105 Parameters in the request body

Parameter Type Mandatory
(Yes/No)

Description

language String Yes Language. The
options are as
follows:
zh_CN: Chinese
en_US: English

channelType String Yes Inspection type.
Training scoring:
exam.
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Parameter Type Mandatory
(Yes/No)

Description

speeches JSON string Yes Dialog content to
be scored.
If channelType is
set to exam, the
value of this
parameter is the
question ID and
agent's answer.
The following is
an example.
"speeches":
"{\"examID
\":\"jsex001\",\"s
peech\":\"*******
\"}"
Method of using
variables:
"speeches":
"{\"examID\":\"$
{examID}
\",\"speech\":\"$
{speech}\"}"

callTime Long Yes Dialog timestamp,
accurate to
seconds.
In the training
scoring scenario,
set the
timestamp to -1,
which is
meaningless.

 

Output Parameters

Table 2-106 Parameters in the response body

Parameter Type Description

examResponse ExamResponse Training scoring result,
which is returned during
training scoring.
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Parameter Type Description

qiResponse QiResponse Inspection score result,
which is returned for
common inspection.
(In the inspection scoring
scenario, this parameter
is not used currently.)

 

Table 2-107 Description of the examResponse field

Parameter Type Description

examId String Question ID.

score Integer Exam score (excluding sensitive
words).

answerRules List <Object> Answer rules and score details.

sensitiveWordRules sensitiveWordRul
eMatch

Sensitive words involved in answers
and points deducted.

 

Table 2-108 Description of the answerRules field

Parameter Type Description

positiveAnswer String Answer to the positive assessment
point.

positiveWeight Float Weight of the positive assessment
point.

positiveScore Float Score of the positive assessment
point.

negativeAnswer String Answer to the negative assessment
point.

negativeWeight Float Weight of the negative assessment
point.

negativeScore Float Score of the negative assessment
point.

 

Table 2-109 Description of the sensitiveWordRules field

Parameter Type Description

id String Sensitive word ID.
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Parameter Type Description

name String Content of sensitive words.

score Integer Sensitive word score.

beginTime Long Start timestamp of the training
content, accurate to seconds.

endTime Long End timestamp of the training
content, accurate to seconds.

speechId Integer Training content ID.

 

Request Example
{
    "language": "zh_CN",
    "channelType": "exam",
    "speeches": "{\"examID\":\"${examID}\",\"speech\":\"${speech}\"}",
    "callTime": "${callTime}"
}

Response Example
{
    "examResponse": {
        "examId": "TQ5",
        "score": 80.0,
        "answerRules": [
            {
                "positiveAnswer": "Positive answer of No.18",
                "positiveWeight": 0.5,
                "positiveScore": 40.0,
                "negativeAnswer": null,
                "negativeWeight": 0.0,
                "negativeScore": 0.0
            },
            {
                "positiveAnswer": "Positive answer of No.18",
                "positiveWeight": 0.5,
                "positiveScore": 40.0,
                "negativeAnswer": null,
                "negativeWeight": 0.0,
                "negativeScore": 0.0
            }
        ],
        "sensitiveWordRules": {
            "sensitiveWordRuleMatch": []
        }
    },
    "qiResponse": null
}

Input Parameter Configuration Example
In the manually entered message body, enter a request example. The ${Variable
name} variable is automatically displayed on the Input Parameter tab page.
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Output Parameter Configuration Example
Parameter Path Description

score $.examResponse.score Exam score (excluding
sensitive words).
This parameter is
returned during training
scoring.

 

2.6.2.5.4 Built-in Functions

During intelligent IVR flow orchestration, built-in functions can be used to split
and truncate variables in the flow based on site requirements.

● When the following built-in functions are used for multiple operations,
parentheses must be added to subexpressions.

● In conditional expressions, == can be used for judgment, which applies only to
strings and numbers and does not apply to objects or lists (except for null
judgment).
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Table 2-110 Built-in functions

Function Description

length() Obtains the length of a string.
Example: If there is a flow variable Answer and the value
of FLOW.Answer is abcde, you can use the
FLOW.Answer.length() expression to obtain the string
length of the flow variable Answer. The result is 5.

size() Obtains the number of elements in a variable of the array
or object type.
Example: If there is a flow variable Answer and the value
of FLOW.Answer is [1,2,3,4,5], you can use the
FLOW.Answer.size() expression to obtain the number of
elements of the flow variable Answer. The result is 5.
NOTE

For an object or array defined by a flow variable, if no default
value is set and no value is assigned, the value is not null and the
size is 0.

divideString (index,
"Separator")

Splits a string.
● index: Sequence number of the character used for the

splitting. The value starts from 1.
● Separator: If the separator is a regular special

character, such as a period (.), dollar sign ($), plus sign
(+), vertical bar (|), or asterisk (*), the separator must
be enclosed in square brackets, for example,
FLOW.XXX.divideString(index,"[+]").

Example: If there is a flow variable Answer and the value
of FLOW.Answer is
{"UniqueID":"123","ServiceID":"1234","orderid":"1234
5"}, you can use the FLOW.Answer.divideString(3,",")
expression to obtain "orderid":"12345" in the value.
NOTE

If the value of a list or object uses square brackets or periods and
this built-in function needs to be invoked, the value must be
cached to a flow variable of the string type before the invocation.

substring(beginInde
x, endIndex)

Truncates a string.
● beginIndex: Start position of the truncation. The value

starts from 0. The value 0 indicates the first character.
● endIndex: End position of the truncation, excluding

the character specified by endIndex.
Example: If there is a flow variable Answer and the value
of FLOW.Answer is "orderid":"12345", you can use the
FLOW.Answer.substring (11, 16) expression to obtain
the 12345 in the value.
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Function Description

startsWith("xxx") Checks whether a variable starts with a string.
Example: If there is a flow variable Answer and the value
of FLOW.Answer is abcde, you can use the
FLOW.Answer.startsWith("a") expression to check
whether the value starts with a. The result is yes.
Generally, this function is used in conditional expressions.

endsWith("xxx") Checks whether a variable ends with a string.
Example: If there is a flow variable Answer and the value
of FLOW.Answer is abcde, you can use the
FLOW.Answer.endsWith("e") expression to check
whether the value ends with e. The result is yes.
Generally, this function is used in conditional expressions.

Null check Checks whether a variable is null.
Example: If there is a flow variable Answer and the value
of FLOW.Answer is null, you can use the
FLOW.Answer==null or FLOW.Answer!=null expression
to check whether the flow variable Answer is null.

+ The following addition operations are supported:
● String + String = Combined string
● String + Integer = Combined string
● Integer + Integer = Addition calculation result
Example: If there are flow variables Str and Num, the
value of FLOW.Str is 123, and the value of FLOW.Num is
123,
you can use the FLOW.Str+FLOW.Num expression to
obtain the string 123123.

/ Divides a number.
Example: If there are flow variables Num1 and Num2,
you can use the FLOW.Num1/FLOW.Num2 expression to
assign the result to another flow variable result, which
must be of the floating-point number type.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 528



Function Description

put() Adds an attribute to an object.
Example: If a flow variable FLOW.person is of the object
type and the value is {"name":"Jack"}, you can use
FLOW.person.put("age","18") in the cache variable area
to add the age attribute to FLOW.person. You can cache
the result {"name":"Jack","age":"18"} to any variable of
the object type. If a flow variable FLOW.age of the
integer type whose value is 18 is available, you can also
use FLOW.person.put("age",FLOW.age) to add an
attribute. The result is {"name":"Jack","age":"18"}.
NOTE

In FLOW.person.put(key,value), both key and value can be
variable names. If value is a constant, the attribute value is of
the string type by default regardless of whether double quotation
marks are added. If value is a variable, the data type of the
attribute value depends on that of the variable.

add() Adds an element to a list.
Example: If a flow variable FLOW.arrayList is of the list
type and the value is [1], you can use
FLOW.arrayList.add(2) in the cache variable area to add
an element whose value is 2 to the end of
FLOW.arrayList. You can cache the result [1,"2"] to any
variable of the list type. If a flow variable FLOW.num of
the integer type whose value is 18 is available, you can
also use FLOW.arrayList.add(FLOW.num) to add an
element. The result is [1,18].
NOTE

In FLOW.arrayList.add(value), value can be a variable name. If
value is a constant, the attribute value is of the string type by
default regardless of whether double quotation marks are added.
If value is a variable, the data type of the attribute value depends
on that of the variable.
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Table 2-111 String operation methods

Function Description

strSplit() Splits a string based on a separator.
The return object is the string array generated after splitting.
There are two parameters: string to be split and separator.
Example:
If a flow variable FLOW.str is of the string type and the value is
"aa,cc,dd,ee", you can invoke this method in the method
invocation area to split the string based on a separator (,). You
can cache the splitting result to any variable (FLOW.array) of
the list type. You can assign values to the method parameters
using variables or manually. You do not need to add quotation
marks when entering values for the method parameters (the
same below).
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Function Description

strSubstring(
)

Extracts a substring.
The return object is the extracted substring. There are three
parameters: string to be truncated, start index (integer), and
end index (integer). (The indexes start from 0, and the character
with the end index is excluded.)
Example:
If a flow variable FLOW.str is of the string type and the value is
"abcdef", you can invoke this method in the method invocation
area to extract a substring based on indexes. You can cache the
truncation result to any variable (FLOW.result) of the string
type. You can assign values to the method parameters using
variables or manually.
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Function Description

strIndex0f() Obtains the index of the first occurrence of a specified string.
The return object is an index, which is an integer. There are two
parameters: string to be searched and specified string.
Example:
If a flow variable FLOW.str is of the string type and the value is
"abcdef", you can invoke this method in the method invocation
area to obtain the index of the first occurrence of a specified
string. You can cache the obtained result to any variable
(FLOW.result) of the integer type. You can assign values to the
method parameters using variables or manually.

strStartsWit
h()

Checks whether a string starts with a prefix.
The return object is the check result. The value is 0 or 1. There
are two parameters: string to be checked and prefix (string).
Example:
If a flow variable FLOW.str is of the string type and the value is
"abcdef", you can invoke this method in the method invocation
area to check whether the string starts with a prefix. You can
cache the check result to any variable (FLOW.result) of the
integer type. You can assign values to the method parameters
using variables or manually.
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Function Description

strEndsWith(
)

Checks whether a string ends with a suffix.
The return object is the check result. The value is 0 or 1. There
are two parameters: string to be checked and suffix (string).
Example:
If a flow variable FLOW.str is of the string type and the value is
"abcdef", you can invoke this method in the method invocation
area to check whether the string ends with a suffix. You can
cache the check result to any variable (FLOW.result) of the
integer type. You can assign values to the method parameters
using variables or manually.

strParseJSO
N()

Converts a JSON string to an object.
The return object is the JSON object generated after conversion.
There is one parameter: string to be converted.
Example:
If a flow variable FLOW.strJson1 is of the string type and the
value is {"a":"1","b":"2"} in JSON format, you can invoke this
method in the method invocation area to convert the string to
an object. You can cache the result to any variable (FLOW.obj1)
of the object type. You can assign a value to the method
parameter using a variable or manually.
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Function Description

strParseInt() Converts a string to an integer.
The return object is the integer generated after conversion.
There is one parameter: string to be converted.
Example:
If a flow variable FLOW.str1 is of the string type and the value
is "11", you can invoke this method in the method invocation
area to convert the string to an integer. You can cache the result
to any variable (FLOW.int1) of the integer type. You can assign
a value to the method parameter using a variable or manually.

strParseFloa
t()

Converts a string to a floating point number.
The return object is the floating point number generated after
conversion. There is one parameter: string to be converted.
Example:
If a flow variable FLOW.str1 is of the string type and the value
is "0.56", you can invoke this method in the method invocation
area to convert the string to a floating point number. You can
cache the result to any variable (FLOW.float1) of the floating
point number type. You can assign a value to the method
parameter using a variable or manually.
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Function Description

strLength() Obtains the length of a string.
The return object is the string length, which is an integer. There
is one parameter: string whose length needs to be calculated.
Example:
If a flow variable FLOW.str1 is of the string type and the value
is "qwer", you can invoke this method in the method invocation
area to obtain the length of the string. You can cache the result
to any variable (FLOW.int1) of the integer type. You can assign
a value to the method parameter using a variable or manually.

strToUpperCa
se()

Converts lowercase in a string to uppercase.
The return object is the string generated after conversion. There
is one parameter: string to be converted.
Example:
If a flow variable FLOW.str1 is of the string type and the value
is "qwer", you can invoke this method in the method invocation
area to convert all letters in the string to uppercase letters. You
can cache the result to any variable (FLOW.str1) of the integer
type. You can assign a value to the method parameter using a
variable or manually.
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Function Description

strToLowerCa
se()

Converts uppercase in a string to lowercase.
The return object is the string generated after conversion. There
is one parameter: string to be converted.
Example:
If a flow variable FLOW.str1 is of the string type and the value
is "QWER", you can invoke this method in the method
invocation area to convert uppercase in the string to lowercase.
You can cache the result to any variable (FLOW.str1) of the
integer type. You can assign a value to the method parameter
using a variable or manually.
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Table 2-112 Array operation methods

Function Description

arrayAdd() Adds an element to an array.
The return value of this method is the flag indicating whether
the addition is successful. If the addition is successful, 1 is
returned. Otherwise, 0 is returned.
There are three parameters: array to be modified, position of the
addition (the element is added at the end by default if the
parameter is left empty), and element to be added.
Example:
If a flow variable FLOW.array is of the list type and the value is
[1,2,3,4], you can invoke this method in the method invocation
area to add an element to FLOW.array. The second parameter
specifies the position (index) of the addition. You can cache the
addition result to any variable (FLOW.result) of the integer
type. After the addition is successful, the new value of
FLOW.array is [1,2,3,4,5] and is stored in the cache until the
flow ends or the value is changed again. You can assign values
to the method parameters using variables or manually.

If you do not need to cache the flag indicating whether the
addition is successful and only need to add data at the end of
an array, you do not need to enter the return value of the
method. In this case, the first method parameter is the array
FLOW.list to be added, the second method parameter is left
empty, and the third method parameter is the element to be
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Function Description

added. IVRREQUEST.input in the following figure is the input of
the user.
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Function Description

arrayAddAll() Adds all elements in another set to an array.
The return object is the addition result. The value is 1 (addition
successful) or 0 (addition failed). There are three parameters:
array to be modified, position of the addition (by default, the
elements are added at the end), and elements to be added.
Example:
If flow variables FLOW.array and FLOW.array2 are of the list
type and their value are [1,2,3,4] and [5,6,7,8], respectively, you
can invoke this method in the method invocation area to add
elements in another set to FLOW.array. The second parameter
specifies the position (index) of the addition. You can cache the
addition result to any variable (FLOW.result) of the integer
type. After the addition is successful, the new value of
FLOW.array is [1,2,3,4,5,6,7,8] and is stored in the cache until
the flow ends or the value is changed again. You can assign
values to the method parameters using variables or manually.
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Function Description

arrayContain
s()

Checks whether an element is in an array.
The return object is the check result. The value is 0 or 1. There
are two parameters: array to be checked and element.
Example:
If a flow variable FLOW.array is of the list type and the value is
[a,b,c,d], you can invoke this method in the method invocation
area to check whether an element is in FLOW.array. You can
cache the return result to any variable (FLOW.result) of the
integer type. You can assign values to the method parameters
using variables or manually.

arrayGet() Obtains an element from an array based on an index.
The return object is an array element. There are two
parameters: array and index.
Example:
If a flow variable FLOW.array is of the list type and the value is
[a,b,c,d], you can invoke this method in the method invocation
area to obtain an element from FLOW.array based on an index.
You can cache the return result to a variable (FLOW.result). You
can assign values to the method parameters using variables or
manually.
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Function Description

arrayRemove
Idx()

Deletes an element from an array based on an index.
The return object is the deletion result. The value is 1 (deletion
successful) or 0 (deletion failed). There are two parameters:
array and index.
Example:
If a flow variable FLOW.array is of the list type and the value is
[a,b,c,d], you can invoke this method in the method invocation
area to delete an element from FLOW.array based on an index.
You can cache the deletion result to any variable (FLOW.result)
of the integer type. After the deletion is successful, the new
value of FLOW.array is [a,b,d] and is stored in the cache until
the flow ends or the value is changed again. You can assign
values to the method parameters using variables or manually.
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Function Description

arrayRemove
AllIdx()

Deletes elements corresponding to an index set from an array.
The return object is the deletion result. The value is 1 (deletion
successful) or 0 (deletion failed). There are two parameters:
array and index set.
Example:
If flow variables FLOW.array and FLOW.indexArray are of the
list type and their values are [a,b,c,d,e,f] and [2,3,4],
respectively, you can invoke this method in the method
invocation area to delete elements from FLOW.array based on
an index set. The second parameter specifies the index set. You
can cache the deletion result to any variable (FLOW.result) of
the integer type. After the deletion is successful, the new value
of FLOW.array is [a,b,f] and is stored in the cache until the
flow ends or the value is changed again. You can assign values
to the method parameters using variables or manually.

NOTE
FLOW.indexArray is an index set of FLOW.array. Its elements support
non-negative integers and cannot exceed the maximum index value of
FLOW.array.
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Function Description

arrayClear() Deletes all elements from an array.
The return object is void. The text box is dimmed and cannot be
edited. There is one parameter: array to be cleared.
Example:
If a flow variable FLOW.array is of the list type and the value is
[a,b,c,d], you can invoke this method in the method invocation
area to delete all elements from FLOW.array. After this method
is invoked, the new value of FLOW.array is [] and is stored in
the cache until the flow ends or the value is changed again. You
can assign a value to the method parameter using a variable.

arraySize() Obtains the length of an array.
The return object is the array length, which is an integer. There
is one parameter: array whose length needs to be calculated.
Example:
If a flow variable FLOW.array is of the list type and the value is
[a,b,c,d,e,f], you can invoke this method in the method
invocation area to obtain the length of FLOW.array. You can
cache the obtained result to any variable (FLOW.result) of the
integer type. You can assign a value to the method parameter
using a variable or manually.
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Function Description

arraySubList(
)

Truncates and returns a part of an array.
The return object is a subarray. There are three parameters:
array to be truncated, start position of the truncation, and end
position of the truncation.
Example:
If a flow variable FLOW.array is of the list type and the value is
[a,b,c,d,e,f], you can invoke this method in the method
invocation area to truncate a part of FLOW.array. You can cache
the truncation result to any variable (FLOW.subArray) of the
list type. The extracted value (FLOW.subArray) is [c,d,e],
includes the character with the start index, and excludes the
character with the end index. You can assign values to the
method parameters using variables or manually.
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Function Description

arrayJoin() Converts an array to a string.
The return object is the string generated after conversion. There
are two parameters: array to be converted and connection
string.
Example:
If a flow variable FLOW.array is of the list type and the value is
[a,b,c,d], you can invoke this method in the method invocation
area to convert the array to a string based on a symbol. You can
cache the conversion result to any variable of the string type
(FLOW.result). In the following example, the return result is
a=b=c=d. You can assign values to the method parameters using
variables or manually.
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Table 2-113 Map operation methods

Function Description

mapPut() Adds an element to a map.
The return object is null if the key does not exist or the original
value of the object type if the key exists. There are three
parameters: map to be modified, key (only the string type is
supported), and element to be added.
Example:
If a flow variable FLOW.person is of the object type and the
value is {"name":"Jack","sex":"boy"}, you can invoke this
method in the method invocation area to add an element to
FLOW.person. You can cache the addition result to a variable
(FLOW.result). After the addition is successful, the new value of
FLOW.person is {"name":"Jack","sex":"boy","age":"25"} and
is stored in the cache until the flow ends or the value is changed
again. You can assign values to the method parameters using
variables or manually.

NOTE
To manually assign values to the parameters of a variable of the object
type, the values cannot be enclosed in double quotation marks. To use
flow variables to assign values, refer to the preceding example.
To add list data to a variable of the object type, the third parameter
must be a predefined variable. You cannot directly enter an array in the
text box. By default, the value in the text box is of the string type.
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Function Description

mapGet() Obtains the value of a key in a map.
The return object is the value of the key. There are two
parameters: map to be processed and key (only the string type
is supported).
Example:
If a flow variable FLOW.person is of the object type and the
value is {"name":"Jack","sex":"boy"}, you can invoke this
method in the method invocation area to obtain the value of a
key in the map. You can cache the obtained result to a variable
(FLOW.result). You can assign values to the method parameters
using variables or manually.
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Function Description

mapRemove(
)

Deletes a key-value pair from a map.
The return object is the original value of the key in the map or
null if the map does not contain the key. There are two
parameters: map to be processed and key (only the string type
is supported).
Example:
If a flow variable FLOW.person is of the object type and the
value is {"name":"Jack","sex":"boy"}, you can invoke this
method in the method invocation area to delete a key-value
pair from the map. You can cache the deletion result to a
variable (FLOW.result). After the deletion is successful, the new
value of FLOW.person is stored in the cache until the flow ends
or the value is changed again. You can assign values to the
method parameters using variables or manually.
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Function Description

mapClear() Deletes all key-value pairs from a map.
The return object is void. The text box is dimmed and cannot be
edited. There is one parameter: map to be cleared.
Example:
If a flow variable FLOW.person is of the object type and the
value is {"name":"Jack","sex":"boy"}, you can invoke this
method in the method invocation area to clear all key-value
pairs from the map. After this method is invoked, the new value
of FLOW.person is stored in the cache until the flow ends or the
value is changed again. You can assign a value to the method
parameter using a variable.

mapSize() Obtains the total number of keys in a map.
The return object is the number of keys in the map, which is an
integer. There is one parameter: map whose number of keys
needs to be calculated.
Example:
If a flow variable FLOW.person is of the object type and the
value is {"name":"Jack","sex":"boy"}, you can invoke this
method in the method invocation area to obtain the total
number of keys in the map. After this method is invoked, you
can cache the obtained result to any variable (FLOW.result) of
the integer type. You can assign a value to the method
parameter using a variable.
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Table 2-114 Data operation methods

Function Description

offsetMonth(
)

Offsets data by month.
The return object is the offset data, which is a string.
There are two parameters. One is the time variable to be offset,
whose value is a string in the format of yyyyMM, for example,
202308. The other is the offset, whose value is an integer and
can be negative, for example, -6 (indicating that the source
string is offset six months forward).
Example:
If a flow variable FLOW.date is of the string type and the value
is 202308, you can invoke this method in the method invocation
area to obtain the offset date. After this method is invoked, you
can cache the obtained result to any variable (FLOW.result) of
the integer type. You can assign a value to the method
parameter using a variable.
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Function Description

offsetHour() Offsets data by hour.
The return object is the offset data, which is a string.
There are two parameters. One is the time variable to be offset,
whose value is a string in the format of yyyyMMddHHmmss, for
example, 20230808122020. The other is the offset, whose value
is an integer and can be negative, for example, -6 (indicating
that the source string is offset six hours forward).
Example:
If a flow variable FLOW.date is of the object type and the value
is 20230831165801, you can invoke this method in the method
invocation area to obtain the offset hour. You can cache the
obtained result to a variable (FLOW.result). You can assign
values to the method parameters using variables or manually.

 

2.6.2.6 FAQs

2.6.2.6.1 Why Do I Need to Configure Stop Words?

During the intention configuration, it is found that the Are you a Robot corpus is
configured in intention A. However, during the actual test, the input are you a
robot matches other corpuses. Why?

In the system, Are is not configured as a stop word, the chatbot restores the word
are to be, and the word form is in the corpus is also restored to be. As a result,
when are you a robot is entered, the system matches other intentions based on
the corpus. This problem can be resolved by configuring a stop word.

Some words in the actual language have no actual meaning and only serve as a
join, for example, be verbs in English. To prevent these words from participating in
semantic parsing, you need to add these words as stop words on the STOP WORD
tab under Knowledge Management > Entity Management.

Figure 2-235 Stop word list

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 551



2.6.2.6.2 Why Are Some Intentions Matched Despite Low Matching Rates?

After the information entered by the user is parsed by the TUC, a matching rate is
generated. The matching rate is compared with the matching rate threshold
defined in the system to determine whether the intention is matched or not.

Configure the matching rate under System Management >System Configuration
> Intelligent Engine Parameter Configuration > Intention Parameters.

NO TICE

Improper settings of intention parameters will cause the semantic recognition
module to run abnormally or decrease the accuracy. Therefore, exercise caution
when setting intention parameters under the guidance of engineers.

Currently, the intention decision module has two parameters:

If the matching rate is greater than the value of Upper Limit, the intention is
matched and returned. If the matching rate is less than the value of Lower Limit,
the intention is regarded as an unknown intention. If the matching rate is between
the values of Lower Limit and Upper Limit, the intentions are also regarded as
matched intentions. That is, in the configuration, as long as the intention
matching rate is greater than 20%, the intention is matched.

2.6.2.6.3 Why TTS Cannot Identify the Date Format?

Description

During dialog identification in Spanish, the text to speech (TTS) plays a character
string in YYYYMMDD format (for example, 20190801) as a number instead of as
the year, month, and date. This affects the customer experience. Therefore,
measures must be taken so that a character string in YYYYMMDD format is played
as expected.

Analysis

It is found that the obtained ODFS system date SYS.systemDate and the obtained
TUC slot date entity value are both in YYYYMMDD format. They do not support
automatic format conversion. Therefore, engineers preliminarily suspect that the
TTS system used onsite has a specific requirement on the date format.

According to the interconnection commissioning of the TTS provided by the site, a
date string in YYYY/MM/DD format (2019/08/01) can be played as expected.
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Therefore, the data format needs to be converted before the voice is played to
resolve the problem.

Solution
Add a Business interface invoke diagram element next to the Semantic
recognition diagram element, and convert the format of the slot variable value in
the Semantic recognition diagram element by using the Java string processing
function substring().

Specific parameter value:

TOC.ChatBotMonth.substring(0,4)+"/"+TOC.ChatBotMonth.substring(4,6)+"/"+TOC
.ChatBotMonth.substring(6,8)+ " a
"+TOC.ChatBotMonth.substring(9,13)+"/"+TOC.ChatBotMonth.substring(13,15)+"/
"+TOC.ChatBotMonth.substring(15,17)

NO TE

Month: slot variable name obtained when the semantic identification diagram element is
executed. In the system, it is represented by TOC.ChatBotMonth.
For details about how to use slot variables, see 2.6.2.5.2 Parameters.

2.6.2.6.4 How Do I Configure the Scenario Where Multiple Slots Are Filled
Repeatedly?

Description
To enable a customer to interact with the chatbot to order a meal, the system
needs to obtain the slot information such as the order date, time, and number of
diners. The slot information that has been filled in needs to be updated at any
time during the interaction with the robot.

For example, when a customer says "6:00 p.m. tomorrow, three persons", the
system needs to record the information in the slots. When the customer changes
his or her mind and says "7:00 p.m." during confirmation, the system needs to fill
the new time in the slot.

The existing processing mode of the ODFS has the following problem: If the
system uses mandatory slot information verification of the intention template, the
slot information that needs to be updated cannot be updated immediately. If the
system clears the context to fill in the slots again, the slots that do not need to be
updated are also cleared.
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Solution
Use the following method to support the scenario where a customer changes
information repeatedly in multiple rounds of dialogs:

Step 1 During intention template configuration, all slots are made optional slots. In this
way, the TUC does not cache the filled slots in an intention. Wait for the next
interaction to obtain the information about the next slot. In this way, the problem
of failing to update filled slots is avoided.

Step 2 Add the judgment logic for returning different command words based on slot
information on the Response tab page.

Step 3 On the flow orchestration page, the system determines the branch of the
command word returned by the intention based on the flow and plays different
voices accordingly.

For each identification interaction, slots are filled. Different intention codes are
returned to the dialog flow for one or more slots filled. The dialog flow caches the
slot information obtained in each interaction to the flow variables. In this way, the
content filled in the slots can be updated according to the information cached by
the ODFS each time the identification is performed.
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----End

2.6.2.6.5 How Do I Resolve the Problem of Infinite Loop During Interaction
Between the IVR and ODFS?

Description

When the voice fails to be played in the IVR dialing test due to reasons such as the
TTS connection exception or the file non-existence, the flow ends abnormally. The
check of the IVR and ODFS logs shows that the infinite loop may occur. The main
symptom is that the TTS keeps reporting the system error.

Analysis

When the IVR fails to play the voice returned by the system, the IVR sends a
sys_err request to the OIAP system. The system cannot process the sys_err request
again and triggers an exception. However, the system does not find the exception
subflow in the dialog flow, and therefore the default abnormal TTS content of the
IVR is returned.

The IVR fails to play the default TTS content and continues to send the sys_err
request to the OIAP. The OIAP continues to trigger an exception. Even if the
customer hangs up, the IVR business fails to capture the hang-up event. The IVR
simply continues sending the sys_err request. As a result, an infinite loop occurs.

Based on the preceding analysis, the possible causes are as follows:

● The sys_err intention is not configured or identified.

● No abnormal condition branch is configured in the dialog flow.
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Solution
Check the intention templates and dialog flows as follows:

● Check whether the branch judgment is comprehensive.

1. When defining condition branches for diagram elements, ensure that the set
of all conditions contains all normal and abnormal scenarios. If some
scenarios are omitted, some actual result may fail to match any of the
configured branches. If no condition is selected for the subsequent connection
line of a diagram element, the connection line is the default branch. The
connection line of this branch must be processed.

2. An exception subflow needs to be created in the dialog flow. In the subflow, a
system exception voice can be simply played. The system only needs to
support voice playback and does not need to support key pressing and
identification. After the voice is played, the flow ends directly.

● Check whether unknown intentions are configured in the intention template.
In 8.9.0 and 8.10.0, several common intention templates have been preset in
the new domain. Ensure that these templates are not deleted. If no unknown
intention exists, configure one and ensure that Command on the Response
tab page of the unknown intention is set to UNKNOWN_INTENT, as shown
in Figure 2-236.
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Figure 2-236 Unknown intention configuration page

2.6.2.6.6 How Do I Configure the Number of Voice Recognition Errors in a Flow?

Description

During the semantic identification, the dialog flow provides the default maximum
number of errors. The processing mechanism is as follows:

1. If the IVR identification times out, the system records a timeout error.

2. If the IVR identification is incorrect or the intention template rejects the
identification, the system records a nomatch error.

3. The OIAP accumulates the total number of timeout errors and rejection
errors. When the accumulation reaches three, the OIAP records an error3
condition by default.

NO TE

The accumulation is performed on the same IVR identification diagram element.

The preceding fixed rules apply only to the same identification scenario. The stop
condition is that the total number of timeout errors and rejection errors reaches
three.

However, the preceding rule does not apply to the scenarios where the number of
timeout errors and the number of rejection errors are counted separately, where
the number of errors in more than one identification is counted together, where
the errors are accumulated in other error scenarios, or where the number of error
times is greater than three.

Solution

If the default rule does not meet requirements, use the business number counting
rule as follows:

Use the business interface invoking diagram element to customize counting
variables. The levels GLOBAL and FLOW can be selected in different counting
scenarios. Different branches can be set for the recognition timeout and rejection
scenarios, and the corresponding times accumulation diagram elements can be
connected.
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The system determines the branch to select based on the error times variable, for
example, the branch for playing an error voice or the branch for directly returning
and replaying the prompt voice again.

2.6.2.6.7 How Do I Configure an Entity That Matches Any Character String?

The preset entity system.any can return only the entire sentence of a subscriber,
but cannot return a slot in a sentence. To obtain a slot in a sentence, you need to
develop rules. If the programmer says "add a button, 5 cm long, 2 cm high, button
name is click", or "add a button, button name is click, 5 cm long, 2 cm high", you
can define rules by using rule entities to distinguish whether the button name is
"click" or "click, 5 cm long, 2 cm high", and to correctly extract the entity.

2.6.2.6.8 What Causes Incorrect ASR?

1. Mixed accents, for example, a mixed accent of British and American.

2. Poor voice quality due to factors such as packet loss and jitter.

2.6.2.6.9 How Do I Transfer the Disconnection Reason Code to the Specified
Business Interface?

When a call is disconnected, a specified interface may be required to report the
disconnection reason code. To implement this function, you need to define the
specified interface on the Business Interface page, create an exception flow, and
record the disconnection reason code in the flow using a global variable.

Clarify the types of call disconnection reasons. From the perspective of
participants, the reasons can be classified into the following types:

● 1. A customer hangs up the call. Assume that the reason code is 2.

● 2. The call is disconnected when the flow ends normally. Assume that the
reason code is 0.

● 3. The call is disconnected when the flow ends abnormally. Assume that the
reason code is 1.

This section describes how to configure the flow, variable, and interface to report
the three types of disconnection reason codes to the specified interface.

Step 1 Define a global variable to identify the disconnection reason.

When adding a global variable, specify the default value, which must be the
reason code for calls disconnected by customers. For example, set the global
variable name, data type, and default value to release_type, Character, and 2,
respectively, as shown in the following figure.
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Step 2 Add an exception flow and set the reason code for abnormal disconnection.

Create a flow by referring to 2.6.2.2.5 Adding Flows and set Scenario Type to
Exception Flow. Generally, a Robot Reply diagram element is required in an
exception flow to play etiquette expressions about causing the inconvenience, for
example, "Sorry, we are facing some technical issues. Please try after some time.
Thank you."

Use the Interface Invoking diagram element to assign a value to the global
variable, indicating the reason code of abnormal disconnection in the flow. In this
example, set the global variable to 1. Use the Call Ending diagram element to
end the call in an exception flow.

Step 3 Set the reason code of normal disconnection in front of the Call Ending diagram
element in a normal flow.

You do not need to change the logic of the current normal flow. You only need to
add an Interface Invoking diagram element in front of the Call Ending diagram
element in a normal flow and assign a value to the global variable, indicating the
reason code of normal disconnection in the flow. In this example, set the global
variable to 0. The following is an example.
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Step 4 Set the parameters for the specified interface.

Add a business interface based on the interface information provided by the
business side by referring to section 4.1.1. However, set the preceding variable that
indicates the disconnection reason code to the input parameter of the message
body in the interface, as shown in the following figure.

Step 5 Invoke the specified interface for the Call Ending diagram element in the main
flow.

By referring to Call Ending, invoke the configured interface for the Call Ending
diagram element in the main flow to report different reason codes after a flow
disconnects a call.

----End

2.6.2.6.10 How Do I Configure the Language Recognition Interface?

The OIAP provides the language recognition interface. You can invoke the
interface by configuring the Business interface invoking diagram element in a
flow. The interface supports Chinese, English, Arabic, and Spanish. When you
configure an OIAP multi-language flow, the configuration of the language
recognition interface is mandatory.

Step 1 Add the language recognition interface to the Business interface invoking
diagram element.

1. Choose Resource Management > Business Interface to add an interface.
Select Message Body Automatically Generated, set Interface Name,
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Request Method, and Interface Code to Language recognition interface,
TUC, and /chatbot/u-route/api/langid/identify, respectively.

2. Enter input parameters, as shown in the following figure.
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3. Enter output parameters, as shown in the following figure.

Step 2 Use the language recognition interface in a flow.
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Select the Business interface invoking diagram element, set Invoked Interface in
the Service Parameter area and text in the Interface Input Parameter List area
to Language recognition interface and IVRREQUEST.input, respectively. The
language and score output parameters can be directly referenced in the variable.

Step 3 Test result.

The call result is as follows.
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----End

2.6.2.6.11 How Do I Configure Dynamic Flow Variables?

In the integrated environment, when the Template Type is set to Static voice or
Video file on the Resource Template page, the button Enable dynamic settings
for flow variables is displayed next to the template type. After the function is
enabled, you can enter flow variables in the content text boxes. After the variables
are set, their static voice or video file paths can be obtained in the business flow.

1. Choose Flow Management > Flow Orchestration and click Add to create a
flow. Click  in the lower right corner, create a flow variable, and click
Confirm.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 564



2. Choose Resource Management > Resource Template and click Add to
create a resource template. Enable the Enable dynamic settings for flow
variables function, enter the flow variable created in the previous step in
Content 1 in the Template Content area in the format of ${FLOW. Flow
variable name}, and click Confirm.

NO TE

Enable dynamic settings for flow variables is displayed only when Template Type is
set to Static voice or Video file.

3. Open the flow created in step 1, click the Response diagram element, and set
service parameters. Select a response type. Select the resource template
created in the previous step from the Response Template drop-down list box
and save the template.
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2.6.2.6.12 How Do I Use a Rule Corpus?

As a supplement to common corpuses, rule corpuses are used to identify users'
intents based on rules. They have the following features:

● The configuration is simple, explicit, and flexible, which greatly reduces the
threshold for configuring corpuses.

● When there are a large number of intents, misidentification can be effectively
prevented.

Procedure

Step 1 The intent management page is displayed.

Step 2 Create an intent or open an existing intent, click the Rule Corpus tab, and click
Add to add a rule corpus.
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Step 3 The tag on the left of the corpus indicates whether the rule format is correct. If
the rule format is incorrect, an error message is displayed.

Step 4 The Exact Match button on the right of the corpus can be used to determine
whether to perform exact match for the corpus.

Step 5 (Optional) Click Add again to add another rule corpus. Click  on the right of
the corpus to delete the corpus. Double-click the corpus text to edit the corpus.

Step 6 Test the rule corpus. Chat with the chatbot by text to check whether the
configured rule takes effect. When the rule takes effect, the intent confidence
displayed in the chat window is an integer greater than or equal to 1.
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NO TE

When both common corpuses and rule corpuses are configured, the system preferentially
matches rule corpuses. If no rule is matched, the system matches common corpuses.

----End

2.6.2.6.13 How Do I Assign Values to and Use Lists and Objects?

During flow orchestration, if a reply variable in the Robot Reply diagram element,
a cache variable (attribute in the response) in other diagram elements, or a
variable in a conditional expression needs to operate or use list or object data, you
can use the following methods for value assignment and usage.

Methods
● Value assignment: If a flow variable is of the list type, you can assign a value

in ["1","2","3"] format. If a flow variable is of the object type, you can assign
a value in {"keyA":"valueA","keyB":"valueB"} format. Each element in a list
or object can be a list or object.

● Usage

– If a flow variable FLOW.arr1 is of the list type and the default value is
["1","2","3"], you can use the FLOW.arr1[0] expression to obtain the
value "1" of the first element.

If a flow variable FLOW.arr2 is of the list type and the default value is
[[1,2], [3,4]], you can use the FLOW.arr2[1][0] expression to obtain the
value 3 of the first element.

– If a flow variable FLOW.obj1 is of the object type and the default value is
{"keyA":"valueA","keyB":"valueB"}, you can use the
FLOW.obj1["keyA"] or FLOW.obj1.keyA expression to obtain valueA.

If a flow variable FLOW.obj2 is of the object type and the default value is
{"keyA":"valueA","keyB":{"keyC":"valueC"}}, you can use the
FLOW.obj2["keyB"]["keyC"] or FLOW.obj2.keyB.keyC expression to
obtain valueC.

NO TE

List or object elements obtained using methods can be properly calculated with other
variable values and operated using built-in functions.
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2.6.2.6.14 How Do I Parse Call-associated Data?

Description

During flow orchestration, the IVRREQUEST.transin_data variable is used to
obtain the call-associated data string. You can use the following solution to parse
the call-associated data.

Solution

Assume that the call-associated data is {"data":{"test": "Call-associated data
test"}}.

Use the Variable assignment diagram element to assign the value of the test
field in the call-associated data to the flow variable FLOW.str1. In this example,
the value of FLOW.str1 is Call-associated data test.

Figure 2-237 JSON data invoking

2.6.2.6.15 How Do I Press a Key to Collect Digits or Return to the Upper-Level
Menu When the Play Voice & Collect Digit Diagram Element Does Not Support the
Asterisk (*) Key?

Description

How do I press a key to collect digits or return to the upper-level menu when the
Play Voice & Collect Digit diagram element does not support the asterisk (*) key?

Analysis

The Play Voice & Collect Digit diagram element does not support the asterisk (*)
key. To collect digits or return to the upper-level menu, you need to use the Menu
configuration and Play Voice & Collect Digit diagram elements together. Use the
Menu configuration diagram element to collect the first digit 1, and use the Play
Voice & Collect Digit diagram element to collect the remaining digits.
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Figure 1 shows a flow example when the Menu configuration and Play Voice &
Collect Digit diagram elements are used together to collect the mobile number.
After a customer presses 1, the Play Voice & Collect Digit diagram element
collects the remaining digits of the mobile number. In this case, the first digit
collected by the Play Voice & Collect Digit diagram element is actually the
second digit of the mobile number (the first digit has been collected by the Menu
configuration diagram element). Therefore, the timeout of the first key pressing
on the Play Voice & Collect Digit node is considered as inter-digit timeout, which
is controlled by Timeout interval for digit collection instead of Waiting Time
for Digit Collection and Max. Failure Times. If key pressing on the Play Voice &
Collect Digit node times out, the flow completes the collection of digits that have
been pressed and goes to the next diagram element. If no key is pressed, the flow
also goes to the next diagram element but does not involve the digit collection
timeout configuration in the Advanced Settings area of the Play Voice & Collect
Digit diagram element.

Figure 2-238 Play Voice & Collect Digit and Menu configuration used together to
collect digits

2.6.3 Operator: Configuring a Common IVR

2.6.3.1 Introduction to the IVR Flow
Before configuring an IVR flow, you are advised to understand related concepts,
such as flow status and flow operations.

IVR Flow Status
The status transition diagram of an IVR flow describes the IVR flow status and the
status transition relationships, as shown in Figure 1.
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Figure 2-239 Flow status transition diagram

● New
After a flow is created, it enters the initial state New. In this state, the flow
can be edited or deleted.

● Editing
When a flow in New or Unreleased state is edited, it enters the Editing state.
In this state, no other operations can be performed on the flow and the flow
cannot be operated by other users. When the editing ends, the flow can be
published.

● Unreleased
If the editing ends, the edit page is closed during editing, an exception occurs
during editing, or the publishing is canceled for a flow in Official Release or
Gray Release state, the flow enters the Unreleased state. An exception can
be an editing timeout error caused by network interruption or power outage.
By default, if no request is sent on the editing page within 5 minutes, the flow
times out.

● Official Release
After a flow is published successfully, it is in Official Release state. A flow in
Official Release state can be cloned, tested, and canceled.

● Gray Release
After a flow is published successfully, it is in Gray Release state. A flow in
Gray Release state can be cloned, tested, published, canceled, and viewed. A
flow in Gray Release state can only be published as an official version.

For all flows, you can view the values of Type and Is Referenced by clicking
Attribute. Table 2-115 describes the operations supported for flows in different
states.
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NO TE

● For flows in New or Unreleased state, you can modify Type and Is Referenced by
clicking Attribute. If a tenant has a main flow and an exception handling flow, the
value of Type cannot be changed to Main flow or Exception handling flow for other
flows.

● For a flow in Official Release or Gray Release state, you can click Test to manually
configure the operation result on the Flow Test page, simulate the execution result of
each diagram element in the flow, and test flow status transition.

Table 2-115 Flow status and supported operations

Flow Status Supported Operation

New Edit and Delete

Editing Unlock

Unreleased Release, Edit, and Delete

Official Release Clone, Test, Cancel Release, and Query
Info

Gray Release Clone, Test, Release, Cancel Release,
Details, and Query Info

 

IVR Configuration Process
You can configure an IVR flow based on the flowchart. Figure 2-240 shows the
editing and handling process of an IVR flow.
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Figure 2-240 IVR flow configuration process

2.6.3.2 Managing Voice and Video Resources

A voice or video file carries a piece of voice content. After a voice or video file is
associated with an IVR flow, the system can play voices based on the file after a
customer enters the IVR flow in a voice call. To enable voice playback, you need to
create a voice or video file in advance based on site requirements.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Resource Management > Audio and Video.

Step 2 Click . The Language Setting dialog box is displayed.
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Currently, voice files in the following languages are supported: Chinese, English,
Portuguese, Thai, Spanish, French, and Arabic.

1. Select the language to be added and click Add. The language is added
successfully.

2. Click Set As Default to set a language as the default language.
3. Click Save to save the language setting.

Step 3 Click  to create an IVR voice or video file.

● Name: file name, which is customized. The value cannot contain special
characters.

● Usage Scenario: This parameter is used to distinguish uploaded files. The
options are as follows:
– IVR: A voice file, video file, or TTS can be created, which is used for flow

configuration.
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– tone: Only a voice file can be created, which is used for agent ringback
tone configuration.

– error: Only a voice file can be created, which is used for configuration of
the Breakdown Voice tenant space feature.

– questionnaire: A voice file or TTS can be created, which is used for IVR
survey configuration.

– Voice notification: A voice file or TTS can be created, which is used for
interface configuration.

– before reporting employee ID and after reporting employee ID: Only a
voice file can be created, which is used to play the employee ID when a
customer is connected to an agent.

– Virtual Human: An image or video file can be created, which is used for
Avatar Reply diagram element configuration (when the 2D Digital Man
feature has been enabled for the tenant).

● Language: Only the default language set in the language configuration is

displayed. You can click  to add a language.
● File type

– Select a voice file
Upload File: The MP3 and WAV formats are supported, and the file size
cannot exceed 12 MB. Voice file format: 8-bit, 8 kHz, 64 kbps, mono. You
can set voice files or texts in different languages at the same time. The
maximum length of a voice file or text is 1024 bytes. During voice
playback, the system automatically plays the corresponding voice file
based on the language selected by the user.
Online Recording: The recording duration cannot exceed 2 minutes.

NO TE

1. Currently, the UAP supports only WAV (8 kHz, 8-bit) voice files. MP3 voice
files can be uploaded on the GUI, which are converted to voice files supported
by the UAP in the system.

2. Only voice files are supported for voices before and after the employee ID.
The file size cannot exceed 1 MB.

– Select a video file: When Usage Scenario is set to IVR, the video file to
be uploaded must be in 3GP format, and the file size cannot exceed 5
MB. When Usage Scenario is set to Virtual Human, the video file to be
uploaded must be in MP4 format, the file size cannot exceed 5 MB, and
the resolution cannot exceed 720p.

– Select an image file: This file type is available only when Usage
Scenario is set to Virtual Human. The image to be uploaded must be in
JPG, PNG, or JPEG format, the file size cannot exceed 2 MB, and the
resolution cannot exceed 720p.

– TTS: Enter a text to be converted to a voice. The maximum length is 1024
bytes.
If Usage Scenario is set to Voice notification, pay attention to the
following points:

▪ Text: The maximum length is 500 bytes. Variables are supported. The
variable values can be filled in by the templateParams parameter in
the voice notification API (V2.0.0).
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Text content requirements:

1) The template content cannot start with a variable.
2) The template content can contain a maximum of 500 bytes.
3) A variable can contain a maximum of 32 bytes. (If a variable

contains more than 32 bytes, you are advised to split it into
multiple variables.)

4) The following variable formats are supported:

○ ${TXT_Number}: String. Number indicates the maximum
number of characters in the string. For example, ${TXT_9}
indicates a string of a maximum of nine characters.

○ ${NUM_Number}: Number. Number indicates the maximum
number of digits for this variable. For example, ${NUM_6}
indicates a maximum number of six digits.

○ ${DATE}: Date, in the format of YYYY/MM/DD. YYYY indicates
the year, MM indicates the month, and DD indicates the day. An
example is 2017/07/16.

○ ${TIME}: Time, in the format of HH:MM or HH:MM:SS. HH
indicates the hour, MM indicates the minute, and SS indicates
the second. Examples are 14:30 and 14:30:30.

Template examples:
○ Example 1: Dear ${TXT_8}, your initial password is ${NUM_6}.
○ Example 2: Please pick up your express delivery before $

{TIME} on ${DATE}.

NO TE

${TIME} and ${DATE} must be separated by " on ".

▪ timbre: Voices can be played based on the selected timbre. The
options are Graceful, Mature, Soft, Sweet, and Natural.

▪ speed: Voices can be played based on the selected speed. The value
ranges from –200 to 500.

▪ volume: Voices can be played based on the selected volume. The
value ranges from 0 to 100.

Step 4 Click OK.

The submitted voice file or video file is in the To Review state. It can be associated
with an IVR flow only after being approved.

NO TE

● If Voice resource review mode is set to Auto Pass for the tenant, the review status
automatically changes to Approved after the voice resource is uploaded and submitted.

● An IVR voice that has been associated with IVR flow diagram elements cannot be
deleted. You can click View to view the flows that reference the IVR voice.

● After a tenant expires, the AICC automatically deletes all voice and video files created by
the tenant.

Step 5 Click Preview.
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1. Click  to play the voice or video file.

Step 6 (Optional) Click Updates to update the IVR voice file or video file.
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Figure 2-241 Updating the file

NO TE

● Only approved voice and video files can be updated.
● Voice files whose Usage Scenario is before reporting employee ID or after reporting

employee ID cannot be updated.
● After an updated voice or video file is approved, it is synchronized to IVR flows that

reference the original voice or video file.

Step 7 (Optional) Different tenants have different requirements for TTS servers from
different vendors. A system administrator can create multiple TTS servers. For
details, see "Managing Servers" and "Managing TTS and ASR" under "Intelligent
Flow Configuration Guide > System Administrator: Managing Tenants and
Systems" in AICC **** Product Documentation ** at the Huawei support website.

Step 8 Click View References.

You can view the IVR flows or resource templates that reference the resource.
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----End

2.6.3.3 Configuring a Common IVR
An IVR flow is a voice transfer flow predefined by a tenant administrator of a
tenant space, including the main flow, subflow, and exception handling flow. An
agent can select an IVR flow or directly call the called route associated with an
IVR flow to transfer a voice call to the IVR flow.

2.6.3.3.1 Creating a Flow

IVR flows are classified into the following types: main flow, subflow, and exception
handling flow. This section describes how to create an IVR flow.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Chatbot Management > Flow Configuration > Common IVR.

Step 2 Click . In the dialog box for creating an IVR flow, configure IVR flow
information.
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Figure 2-242 Creating a common IVR

Table 2-116 Parameters in the dialog box for adding a flow

Parameter Description

Chatbot Name Robot name, which is used to identify
a flow. A voice call can be transferred
to an IVR flow based on the flow
name.

Type A tenant administrator can configure
only one main flow, one exception
handling flow, and one or more
subflows. Multiple flow versions can
be configured through cloning.
Flows are classified into the following
types:
● Main Flow: Flow that an inbound

voice call is connected first. It is the
main flow involved in voice call
transfer.

● Subflow: Flow used to process a
task. After an operation is specified,
a customer jumps from the main
flow to the corresponding subflow.

● Exception Handling flow: Flow
used to handle an exception that
occurs in a voice call.
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Parameter Description

Is Referenced ● Yes: An IVR flow can be selected in
external access mode. For example,
the IVR flow can be selected when
you make a call to a called number
through the OpenEye or choose
Call Transfer > IVR on the
connection bar.

● No: An IVR flow can be used only
for internal IVR flow transfer.

 

Step 3 Click Complete to save the IVR flow information.

Step 4 Repeat Step 2 to configure IVR subflows and exception handling flows.

Step 5 (Optional) Click a flow record to expand it.

By default, the latest version information about a flow is displayed in the flow list.
You can click the flow record to view all version information and supported
operations of it, such as edit and delete.

----End

NO TE

● An exception handling flow must be available in the IVR flows.
● A tenant space has only one exception handling flow.

2.6.3.3.2 Editing a Flow

After creating a flow, you need to drag diagram elements provided on the GUI to
edit the flow content to implement specific business capabilities.

Prerequisites
● A flow has been created. For details, see 2.6.3.3.1 Creating a Flow.
● Voice files to be involved in the flow have been configured.

Context
Before editing a flow, you are advised to understand the layout of the flow editing
page and the capabilities of each area. Figure 2-243 shows the flow editing page.
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Figure 2-243 Page for editing a flow

Table 2-117 Introduction to areas on the flow editing page

ID Area Description

1 Buttons Cancel a flow, save a
flow as a draft, save
data, or save and publish
a flow.

2 Diagram element area Drag diagram elements
to the canvas area to edit
a flow.

3 Canvas area Edit an IVR flow.

4 Diagram element
parameter area

Set parameters of a
selected diagram
element.

5 Canvas toolbar Reset the view, zoom in
or out the view, enter the
fullscreen mode, undo or
redo an operation, or
delete a diagram
element or line.
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ID Area Description

6 Variable area View basic information
about flow variables,
global variables, system
variables, IVR request
variables, and intention
variables. A variable can
be dragged to a variable
text box in the diagram
element parameter area.
Variables can be
searched and filtered.

shows a variable text
box.
Intention variables can
be used only in an
intelligent IVR.

 

Scenario
After a voice call is transferred to an IVR flow, the system plays the welcome voice
of the customer service hotline, prompts the customer to select a language, and
then provides multiple menus for processing different tasks, for example, member
information service, timeout, or other keys. When the customer chooses the
member information service, the system transfers the call to the corresponding
subflow. When the customer input times out or the customer presses other keys,
the system plays a voice to notify the customer and ends the flow.

Procedure

Step 1 Select a flow in New or Unreleased state, expand the flow information, and click
Edit.

When the canvas is initialized, a start diagram element and an end diagram
element are displayed by default. The start diagram element cannot be deleted.
The end diagram element can be deleted. You can also add multiple end diagram
elements. Ensure that at least one end diagram element exists in the flow.

Step 2 Drag diagram elements to the canvas area and set diagram element parameters,
as shown in Figure 2-244.

To connect two diagram elements, move the pointer to the source diagram
element. When a dotted-line box is displayed on the diagram element, move the
pointer to the target diagram element. Except subflow diagram elements, all other
diagram elements must have a default connection line, and the start point and
end point of the connection line must be on the diagram element. For details, see
2.6.3.10 Diagram Elements.
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Figure 2-244 Editing a flow

Step 3 After the flow editing is complete, click Save. In the success dialog box that is
displayed, click OK to close the flow editing page.

NO TE

During the flow editing, you can click Save to save the edited flow at any time. After the
flow editing is complete, you need to close the flow editing page so that you can publish
the flow in the flow list.

----End

2.6.3.3.3 Publishing a Flow

A flow that is added or edited can be used only after being published.

Procedure

Step 1 Select a flow in New or Unreleased state, expand the flow information, and click
Release. The Release Flow dialog box is displayed.

Step 2 Select a publish mode and click Confirm, as shown in the following figure.

Two publish modes are supported: gray release and official release. A flow can
have only one official release version and one gray release version.

After a flow is published successfully, the status of the flow is displayed as Gray
Release or Official Release according to the selected publish mode.
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The publish modes of an IVR flow are as follows:

● Gray release: You need to configure a gray rule and select the gray rule
configured for the current tenant from the drop-down list box. For a flow
published in gray release mode, only voice calls from numbers that match the
selected gray rule can be transferred to the IVR flow.

● Official release: For a flow published in official release mode, voice calls from
all numbers can be transferred to the IVR flow.

NO TE

– After a flow is published, the system automatically allocates an access code to the
flow.

– Flows in Official Release or Gray Release state can be cloned to configure
multiple versions. The initial version of a new flow is V1.0. Each time the flow is
cloned, the version number increases by 0.1. For example, when a flow is cloned
for the first time, version V1.1 is created.

– A flow can have only one official release version and one gray release version.
When a cloned version is published, the existing official release version or gray
release version is replaced with the current version.

– A published exception handling flow must be available for official release and gray
release.

– To cancel the publishing of an exception handling flow, ensure that no published or
gray release flow exists.

– Abnormal flows support gray release.

----End

2.6.3.4 Configuring Robot Tracking

After the IVR is referenced by an agent, the agent can view the detailed
information about the IVR flow in the contact record.

Prerequisites

A published IVR flow exists, and the Call Transfer diagram element has been
configured.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Chatbot Management > Flow Configuration.

Step 2 Choose System > System Settings and click the Track Settings tab.

Step 3 On the Tracking Robots tab page, click .

Step 4 Select a robot access code and click Confirm.

A maximum of 20 robot access codes can be added.

NO TE

If neither the flow access code nor the flow track is configured, the IVR flow is empty in the
contact record.

----End

Follow-up Procedure
After the IVR bound to the traced flow access code is used by an agent, choose
Customer Contact History > Contact Record, click the call SN of the
corresponding contact record to access the contact record details page, and click
View Current Flow Track to view the configured flow track details. The traced
flow contains call-associated data, which cannot be edited.

2.6.3.5 Configuring a Called Route
A called route refers to the called number associated with an IVR flow and
consists of an access code and an extension code. A customer can trigger the IVR
flow by directly dialing the called number or connect to the called number of the
CEC through the core network. A called number can be associated with only one
IVR flow. An IVR flow can be associated with multiple called numbers.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Called Party.

Step 2 Click New and configure called route information, as shown in Figure 2-245.
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Figure 2-245 Creating a Called Party Configuration

Table 2-118 Key parameters in the Creating a Called Party Configuration dialog
box

Parameter Description

Access Code A customer can directly dial Access
code+Extension code to access an IVR
flow.
The available access codes are
allocated by the system administrator
when the system administrator creates
the tenant.

Extension Code A customer can directly dial Access
code+Extension code to access an IVR
flow.
An extension code is a string of 1 to
12 characters and can contain only
digits, asterisks (*), and number signs
(#).

Device Type Select IVR to transfer voice calls to an
IVR flow.

Please Choose IVR. Select a published IVR flow as
required.

 

Step 3 Click Save.

The configured flow is automatically synchronized to the intelligent IVR. The
intelligent IVR saves the flow information based on the flow access code.

----End
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2.6.3.6 Configuring a Flow Track

By adding a calling number and using the OpenEye to call a called route that has
been associated with an IVR flow, you can view the track of the flow after the
voice is transferred to the IVR, for example, the transition of each diagram
element in the flow, for fault locating.

Flow Tracking is a common module. For details, see 2.6.2.2.11 Viewing Flow
Tracks.

2.6.3.7 Configuring IVR Recording

You can configure IVR recording to enable or disable recording in common IVR call
flows.

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Choose System > System Settings > System Settings and edit the
CCIVRRECORDFLAG parameter.

Step 3 Set Value to Enable to enable recording or Disable to disable recording.

Step 4 Log in to the OpenEye and dial the access code added on the Called Party page.
If you can hear the tone played by the robot, the call can be completed normally,
and the recording file can be obtained from the storage device of the server, the
configuration is successful.

Figure 2-246 System parameter for configuring IVR recording
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Figure 2-247 Selecting Enable for the recording flag

----End

2.6.3.8 Querying Flow Transfer Records
A customer initiates a voice call to an agent. The call is transferred to a third party
after a self-service flow is triggered. After the customer is in a call with the third
party, the recording is enabled during call. The customer can query the flow
transfer record and download the recording to resolve problems.

Prerequisites
● The following configuration has been completed for the self-service flow:

The Transfer diagram element has been configured, Transfer Configuration
has been set to Transfer To Third Party, and Recording has been selected.

● The agent must:
– Have the Process Transfer Record menu permission.
– Have the Play Recording Online and Recording Download operation

permissions.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Contact History >
Transfer Record.

By default, all flow transfer records of the current tenant are displayed in the list.
The records are stored for 90 days by default.

Step 2 Select a flow transfer record and click Download or Play in the Recording file
column to obtain the recording file.

NO TE

The downloaded recording file contains personal data. Exercise caution when processing the
exported file to prevent personal data leakage and abuse.
The playback and download functions are available only for the current drive letter. For
example, if the current drive letter is Y and the drive letter is switched from Y to Z, playback
and download will fail. To play and download historical files properly, switch the drive letter
from Z back to Y.

----End
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2.6.3.9 Typical Configuration Example
This section describes a complete IVR flow instance and the functions of each
diagram element.

Scenario
Carrier A needs to configure an IVR flow, as shown in the following figure.

Figure 2-248 IVR flow instance

Requirement Analysis
Table 2-119 describes the diagram elements involved in the flow instance
configuration according to the analysis.
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Table 2-119 Diagram elements involved in the flow instance

Involved Diagram
Element

Description

Voice Playback Plays all voices required in the flow, including the
welcome voice.

Select Language Provides Chinese and English for customers to select.

Menu configuration Configures the following menus:
● For Chinese service, press 1.
● For English service, press 2.
● For member information, press 1.
● For self-service, press 2.
● For cooperation service, press 3.
● For manual service, press 0.

Play Voice & Collect
Digit

Plays the voice "Enter the ID card number and press
the pound key (#)."

Time Selection Configures the time for providing services.

Condition Judgment Determines the result.

Transfer Transfers a call to a skill queue, an external number,
or an agent.

Subflow Transfers a call to the self-service subflow.

 

Procedure

Step 1 Prepare the required voice files.

In this scenario, you need to prepare the following voice files: welcome voice, voice
to be played when a flow is about to end, and service time notification voice.

Step 2 Configure the voice files. For details, see 2.6.3.2 Managing Voice and Video
Resources.

The configured voice files can be used only after being approved.

Step 3 Configure an empty main flow and an empty subflow. For details, see 2.6.3.3.1
Creating a Flow.

You are advised to configure the self-service subflow before the main flow.

Step 4 Edit the flow. For details, see 2.6.3.3.2 Editing a Flow. Figure 2-249 shows the
editing process.

Before using diagram elements to edit a flow, define all customized parameters
involved in the flow, for example, the idCardNum parameter indicating the ID
card number and the 3rdNo parameter indicating the number of a third party to
which a voice call can be transferred.
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Figure 2-249 Flowchart of the configuration instance

Step 5 Publish the flow. For details, see 2.6.3.3.3 Publishing a Flow.

Step 6 Configure a called route. For details, see 2.6.3.5 Configuring a Called Route.

----End

Verification
Use OpenEye to dial the called number. If the voice call can be transferred
according to the configurations, the flow configuration is successful.

2.6.3.10 Diagram Elements
This section describes the names and functions of the diagram elements involved
in a common IVR flow and how to use the diagram elements.

NO TICE

A maximum of 4096 characters are allowed in the text box of a single diagram
element in a flow.

2.6.3.10.1 Start
This diagram element is used only to mark the beginning of a flow and does not
have any internal logic.

Diagram Element
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Parameter Description

None

Typical Application Scenario

This diagram element is used to mark the beginning of a flow.

2.6.3.10.2 Subflow

This diagram element is used to configure subflows for implementing tasks. No
diagram element can be configured after a subflow.

Diagram Element

Parameter Description

The following figure shows parameters of the subflow diagram element.

The parameters are described as follows:
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● Node Name: diagram element name to be displayed, which is customized.
● Description: diagram element description, which is customized.
● Target Flow: name of a subflow to be entered. You can select a published

subflow of the current tenant from the drop-down list.
● Target Node: flow node to be executed. After a node is selected, the subflow

starts from it.

Typical Application Scenario
An independent task needs to be processed. Generally, some common operations
of a certain type can be extracted to form a subflow, making it easy to be reused.

2.6.3.10.3 Call Ending

This diagram element is used to mark the end of a flow.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Invoked Interface: interface to be invoked. Select an interface added on the

Resource Management > Business Interface page.
● Start Time and End Time: start time and end time during which an interface

can be invoked. The configured interface will be invoked to execute related
tasks only in the specified time period.
The time format is HH:MM:SS. For example, if Start Time is set to 00:00:00
and End Time is set to 23:59:59, the configured interface is invoked when the
Call Ending diagram element is reached at any time of a day.

● Sending Interval: interval for invoking the interface, in days. The value is an
integer and cannot exceed 365. If this parameter is set to -1, the interface is
not invoked periodically. The invocation is triggered when the Call Ending
diagram element is reached at any time.

Using the Diagram Element
Click the diagram element or drag it to the canvas.

Typical Application Scenario
If you need to invoke a third-party interface to implement a specific business
when using the Call Ending diagram element, you can perform the following
operations to ensure that the Call Ending diagram element can be reached in any
case:
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Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and add a normal end flow that contains only
the Start and Call Ending diagram elements, as shown in the following
figure. You do not need to configure the invoked interface for the Call Ending
diagram element.

Figure 2-250 Normal end flow

2. Save and publish the flow.
3. Choose Flow > Orchestration and add an actual business flow. Do not

directly connect a Call Ending diagram element as the last diagram element
of the flow. Instead, connect a Subflow diagram element to transfer the flow
to the normal end flow added in Step 2.1. In this way, the Call Ending
diagram element can be reached in any case, including after the flow is
transferred.

Figure 2-251 Actual business flow (Subflow diagram element)
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Figure 2-252 Actual business flow (Call Ending diagram element)

4. Save and publish the flow.

NO TE

When the flow execution passes through the Call Transfer diagram element and the
transfer is successful, the third-party interface configured in the Call Ending diagram
element is not invoked.

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Trace Settings and enable Calling
Number Tracing. Click Start Call to test the robot.

NO TE

If you do not set Calling Number before making a call, the default calling number
123456789 is used.

Step 5 Choose Flow Management > Flow Tracking and query the flow check result of
the test number. The following figure shows that the flow has reached the Call
Ending diagram element through the Subflow diagram element.
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Figure 2-253 Flow track log page

----End

2.6.3.10.4 Switching Between Voice and Video Calls

During a customer's call to the IVR, you can switch between voice and video calls.

Diagram Element

Parameter Description
The following figure shows the parameters of the Change Media diagram
element.
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The parameters are described as follows:

● Node Name: Enter a diagram element name.
● Media: Select a target media type. The options are Audio and Video.

Condition Branch Description

Table 2-120 Condition branch description

Condition
Branch

Description Usage

Switching
failure

Failure to
switch from a
voice call to a
video call or
from a video
call to a voice
call

Triggered upon a switching failure.

 

Typical Application Scenario
Voice and video calls need to be switched between each other when businesses
are handled for a customer. The corresponding media capabilities are used to
intuitively display businesses.
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2.6.3.10.5 Voice Playback
This diagram element is used to play a voice (for example, welcome voice) or
video segment without interacting with the customer. The system supports WAV
(8 kHz, 8 bits) voice files, TTS files, and video files.

Diagram Element

Parameter Description
The following figure shows the parameters of the Voice Playback diagram
element.

The parameters are described as follows:

● Node Name: name displayed on the diagram element, which can be
customized.

● Voice Prompt: Select Voice, TTS, Video, or Variable voice. You can click an
option button to select a voice type.
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– Voice: Upload a voice file in WAV format. Currently, the UAP supports
only WAV (8 kHz, 8-bit) voice files.

– TTS: Generate a voice file in TTS mode. TTS channels must have been
configured. You can enable Advanced TTS settings to set voice playback

parameters. Click  in the drop-down list to select a sound effect and
speaking speed. If this function is disabled, Sound effect is set to Female
voice, Speaking speed is set to Low, and TTS extended parameter is
not set by default.

▪ Sound effect: Select the sound effect. The options are Male voice
and Female voice.

▪ Speaking speed: Select the speaking speed. The options are Low,
Medium, and High.

▪ TTS extended parameter: Set this parameter based on site
requirements. The value contains a maximum of 200 characters.

NO TE

To use the TTS function, you need to contact the system administrator to
sign in to the AICC and configure a TTS server for your tenant space.

– Video: Upload a video file in 3GP format, whose size must be less than or
equal to 5 MB.

– Voice File: The system filters approved voice files, TTS files, or video files
based on the selected voice type, and displays the files in the drop-down

list. You can click  and select a required file.
– Variable voice: Voices can be customized by setting the language, type,

and content.
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▪ Language: Select a voice playback language.

NO TE

If you select a non-Mandarin or non-English language for the variable voice,
contact O&M personnel to customize the syntax package and voice file.

▪ Type: Select a voice playback type. The options are Phone number,
Number, time(hh:mm:ss), Date(yyyymmdd), and Price.

▪ Content: Select the content defined by the global variable
(GLOBAL.*) or flow variable (FLOW.*).

NO TE

If Type is set to date or time, the format of the selected variable must be
consistent with that in the brackets.

● Click Save to save all parameters set on the current page.

Condition Branch Description

Table 2-121 Condition branch description

Condition
Branch

Description Usage

Voice
playback
failure

Failure to play
a voice, video,
TTS, or
variable voice

Triggered upon a playback failure.

 

Typical Application Scenario
● When a voice call is transferred to an IVR flow, the system plays the welcome

voice.
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● During execution of an IVR flow or when an IVR flow is about to end, the
system plays a voice prompt.

2.6.3.10.6 Voice Playback and Digit Collection

The function of this diagram element is the same as that of the Play Voice &
Collect Digit diagram element for configuring an intelligent robot. For details, see
Voice Playback and Digit Collection.

2.6.3.10.7 Language Selection

This diagram element is used to set the language for playing voices.

Diagram Element

Parameter Description
The following figure shows parameters of the Select Language diagram element.

The parameters are described as follows:

● Node Type: The value is Select Language, which cannot be changed.
● Node Name: Enter the diagram element name to be displayed on the canvas.
● Language: Select a language, based on which a branch can be selected in the

flow later. Currently, Chinese, English, Portuguese, Thai, Spanish, French,
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and Arabic are supported. The options are the languages configured in
2.6.3.2 Managing Voice and Video Resources.

Typical Application Scenario
This diagram is used in the scenario where a customer needs to select a language.
After the system executes the Play Voice & Collect Digit diagram element
configured for a customer to select a language, the customer selects a language
as prompted. For example, the customer can press 0 for Chinese, 1 for English, or
2 for Thai.

2.6.3.10.8 Menu Configuration

This diagram element is used to prompt a customer to select a menu to enter the
corresponding branch for processing a specific business.

Diagram Element

Parameter Description
The following figure shows the parameters of the Menu configuration diagram
element.
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Figure 2-254 Menu configuration
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Figure 2-255 Advanced Settings

The parameters are described as follows:

● Node Name: name displayed on the diagram element, which can be
customized.

● Voice Prompt: Select Voice, TTS, or Video. You can click an option button to
select a voice type.
– Voice: Upload a WAV voice file. The UAP supports only the WAV voice

files in the following format: 8 bit, 8000 Hz, 64 kbit/s, and mono.
– TTS: Generate a voice file in TTS mode. You can enable Advanced TTS

settings to set voice playback parameters. Click  in the drop-down list
to select a sound effect and speaking speed. If this function is disabled,
Sound effect is set to Female voice, Speaking speed is set to Low, and
TTS Extended Parameter is not set by default.
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▪ Sound effect: Select the sound effect. The options are Male voice
and Female voice.

▪ Speaking speed: Select the speaking speed. The options are Low,
Medium, and High.

▪ TTS Extended Parameter: Set this parameter based on site
requirements. The value contains a maximum of 200 characters.

– Video: Upload a video file in 3GP format, whose size must be less than or
equal to 5 MB.

● Voice File: The system filters approved voice files, TTS files, or video files
based on the selected voice type, and displays the files in the drop-down list.

You can click  and select a required file.

● Menu Key Configuration: service option provided in a flow. Each button
maps a service option. You can click New to add a service option. Multiple
service options are allowed.

– Buttons: number key or character button available on the keyboard or
screen, such as 1, 2, or 3.

– Description: service introduction of a key or button, which can be
displayed in the menu. For example, if you set Buttons to 1 and
Description to Query member information, a customer can press 1 to
query member information.

– Operation: You can click New to add a service option, click Delete to
delete a service option, and click Down or Up to adjust the sequence of a
service option.

● Waiting Time for Digit Collection: time to wait for the digit input. If the
time when a customer stops the input exceeds that specified by Waiting
Time for Digit Collection, the system records a failure, automatically
executes Digit collection timed out, and continues to wait for the digit input.

● Max. Failure Times: maximum number of input attempts that are allowed.
When an error occurs during digit collection, the system records a failure,
automatically executes Digit collection failure, and continues to wait for the
digit input.

● Advanced Settings: You can click Advanced Settings + to expand this area
and click Close to collapse this area.
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– Digit collection failure: You can click  to enable the capability
of playing a voice upon a digit collection error. Then, if digits fail to be
collected before the number of a customer's input attempts reaches the
maximum specified by Max. Failure Times, the system plays a voice to
notify the customer.

– Digit collection timed out: You can click  to enable the
capability of playing a voice upon digit collection timeout. Then, if digits
fail to be collected after the wait time reaches the maximum specified by
Waiting Time for Digit Collection, the system plays a voice to notify the
customer.

NO TE

● By default, Digit collection failure and Digit collection timed out are disabled in the
Advanced Settings area. If the capabilities are disabled, the system replays the voice
configured for the voice playback and digit collection diagram element upon a failure.

● When the number of a customer's input attempts reaches the maximum specified by
Max. Failure Times, the system executes the common failure exit.

● You can click Save to save all parameters set on the current page.

Condition Branch Description

Table 2-122 Condition branch description

Condition
Branch

Description Usage

Timeout or
other keys

Digit
collection
timeout or
out-of-range
key

Triggered when digit collection times out or the
key is out of the range.

 

Typical Application Scenario
In a flow, multiple service options need to be provided for a customer to select.
For example, a customer can press 1 to query member information, 2 to query
traffic information, 3 to make complaints or provide suggestions, or 0 to obtain
manual services.

2.6.3.10.9 Call Transfer

This diagram element is used to transfer a call to an IVR flow (an existing key
pressing flow) or an agent.

Diagram Element
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Parameter Description

Figure 2-256 Node Attribute

● Node Name: name of a node.

● Description: details of a node.

● Transfer Type: The options are as follows:

– Skill Queue (Route Extension Code) (1)

– IVR (2)

– Skill Queue (Name) (3)

– Transfer to Skill Queue (Customized Route) (10)

– Agent (4)
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– Third-party number (5)
– Online Digital Assistant (6)
– Audio and video familiar customers (9)
– Multimedia familiar customer (7)
– Skill queue (MAgent) (8)
– Familiar customer message (31)
– Skill queue message (name or access code) (32)
– Message to an Agent (33)

● Route Value: Select a value from the drop-down list box.
– If Transfer Type is set to Skill Queue (Route Extension Code), set this

parameter to the extension code for transferring to a skill queue. For this
configuration, you need to ensure that the manual flow and the current
flow are under the same system access code. The call is transferred to the
manual skill queue through the extension code configured on the Called
Party page.

Figure 2-257 Extension Code

– If Transfer Type is set to IVR, set this parameter to the IVR flow access
code.
The following figure shows the IVR flow access code in the AICC
integrated deployment mode.
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– If Transfer Type is set to Skill Queue (Name), set Route Value to the
name of the skill queue where the agent to whom the call is transferred
resides, for example, Agent Group 1. You can choose Configuration
Center > Employee Center > Skill to view the skill queue name.

– If Transfer Type is set to Transfer to Skill Queue (Customized Route),
set the corresponding routing policy.

– If Transfer Type is set to Agent, set this parameter to the platform agent
ID of the agent to whom the call is transferred.

– If Transfer Type is set to Third-party number, set this parameter to the
third-party number.

– If Transfer Type is set to Online Digital Assistant, set this parameter to
the flow route code agreed with the third-party intelligent system.

– If Transfer Type is set to Audio and video familiar customers, you do
not need to set the route value, but you need to configure the call-
associated data by referring to Table 3.

– If Transfer Type is set to Multimedia familiar customer, you do not
need to set the route value, but you need to configure the call-associated
data by referring to Table 3.

– If Transfer Type is set to Skill queue (MAgent), set this parameter to
the platform agent ID or variable corresponding to the agent to whom
the call is transferred.

– If Transfer Type is set to Familiar customer message, you do not need
to set the route value, but you need to configure the call-associated data
by referring to Table 3.
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– If Transfer Type is set to Skill queue message (name or access code),
set this parameter to the name or access code of the skill queue where
the agent to whom the call is transferred resides.

– If Transfer Type is set to Message to an Agent, set this parameter to the
platform agent ID or variable corresponding to the agent to whom the
call is transferred.

● Routing Policy: This parameter needs to be set only when Transfer Type is
set to Transfer to Skill Queue (Customized Route). The options are
Percentage and Number segment.

Figure 2-258 Setting Routing Policy to Percentage
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Figure 2-259 Setting Routing Policy to Number segment

● Percentage configuration: When Routing Policy is set to Percentage, you
need to configure multiple skill queues and their routing percentages. During
call transfer, the system dynamically assigns calls to skill queues based on the
percentage configuration.
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Table 2-123 GUI elements for the percentage configuration

Elemen
t/
Compo
nent

Typ
e

Description Value
Range

Trig
geri
ng
Eve
nt

Remarks

Skill
Queue

Dro
p-
do
wn
list

Skill queue to
which calls are
transferred.

All skill
queues
except
multimedia
skill queues

Click ● A skill queue
cannot be
selected
repeatedly.

Percent
age

Tex
t
box

Percentage of
calls transferred
to a skill queue
during
transferred-to
skill queue
assignment.

1 to 100 Ente
r

The total
percentage must
be 100.

But
ton

Delete a
percentage
setting.

- Click -

But
ton

Add a percentage
setting.

- Click -

 
● Default Skill Queue: When Routing Policy is set to Number segment, you

need to select a skill queue as the default skill queue to which calls are
transferred when no skill queue is matched based on the number segment
matching rule configuration.

● Matching rule: When Routing Policy is set to Number segment, you need
to select a matching rule. The options are Prefix and Suffix.

● Number segment matching rule configuration: When Routing Policy is set to
Number segment, you can select different skill queues and configure
different prefixes or suffixes for them. During call transfer, the system
transfers calls whose calling numbers exactly match the configured prefixes or
suffixes to the corresponding skill queues.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 613



Table 2-124 GUI elements for the number segment matching rule
configuration

Elemen
t/
Compo
nent

Typ
e

Description Value
Range

Trig
geri
ng
Eve
nt

Remarks

Skill
Queue

Dro
p-
do
wn
list

Skill queue to
which calls are
transferred.

All skill
queues
except
multimedia
skill queues

Sele
ct

● A skill queue
cannot be
selected
repeatedly.

Prefix/
Suffix

Tex
t
box

Prefix/Suffix used
for calling
number matching
during call
transfer to a skill
queue.

- - -

But
ton

Delete a number
segment
matching rule
setting.

- Click -

But
ton

Add a number
segment
matching rule
setting.

- Click -

 
● Associated Data: The call-associated data can be in JSON format (flow

variables and global variables are supported). Manually enter a value, or click
the edit icon and add information in the Set TransferData dialog box.
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Figure 2-260 Set TransferData (transfer to a skill queue, including manual
and multimedia skill queues)

Figure 2-261 Set TransferData (transfer to the last agent, including manual
and multimedia agents)

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 615



Figure 2-262 Set TransferData (transfer to others)

The format of the generated complete JSON data is as follows:
{
  "wait": "Y",
  "isSpecifyAccessCode": "true",
  "type": "1",
  "time": "30",
  "starttime": ""
  "data": {
    "serviceId": ${FLOW.test},
    "yy": "bbb"
  },
}

Table 2-125 Call-associated data parameters

Eleme
nt/
Comp
onent

Key in
JSON
Data

Ty
pe

Description Value
Range

Tri
gg
eri
ng
Eve
nt

Remarks

Queue
Queui
ng

wait Sw
itc
h

Whether a call
can wait in a
skill queue
until the
session times
out when the
call is
transferred to
the skill
queue.

● Y
● N

Clic
k

This
parameter
can be set
only when a
call is
transferred to
a skill queue,
including
manual and
multimedia
skill queues.
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Eleme
nt/
Comp
onent

Key in
JSON
Data

Ty
pe

Description Value
Range

Tri
gg
eri
ng
Eve
nt

Remarks

Specifi
ed
Chann
el
Access
Code

isSpecify
AccessCo
de

Sw
itc
h

Whether to
transfer to the
current
channel when
a call is
transferred to
the last agent.

● true
● false

Clic
k

This
parameter
can be set
only when a
call is
transferred to
the last
agent,
including
manual and
multimedia
agents.

Famili
ar
Custo
mer
Mode

type Dr
op
-
do
wn
list

Mode of
selecting the
last agent.

1: agent
within the
specified
minutes
2: agent
within the
specified
time
range
3: agent
on the
current
day

Sel
ect

This
parameter
can be set
only when a
call is
transferred to
the last
agent,
including
manual and
multimedia
agents.

Transf
er
Data

data Ta
ble

Call-associated
data that
needs to be
carried during
call transfer.

- - -
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Eleme
nt/
Comp
onent

Key in
JSON
Data

Ty
pe

Description Value
Range

Tri
gg
eri
ng
Eve
nt

Remarks

Transf
er
Param
eters

Customiz
ed key

Te
xt
bo
x

Key in call-
associated
data.

- Ent
er

● To obtain
the
customer
type field,
set the
transferred
parameter
to
customerE
ntityNam
e.

● To use a
visualized
service
guidance
flow, set
the
transferred
parameter
to
serviceRe
quest.
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Eleme
nt/
Comp
onent

Key in
JSON
Data

Ty
pe

Description Value
Range

Tri
gg
eri
ng
Eve
nt

Remarks

Value - Te
xt
bo
x

Value of the
key in call-
associated
data.

- Ent
er

● Variables
can be
used, for
example, $
{FLOW.var
iable}.

● To obtain
the
customer
type field,
set the
value to
account or
contact.

● To use a
visualized
service
guidance
flow, set
the value
to the
name of a
visualized
flow
configured
on the
Configura
tion
Center >
Workbenc
h
Configura
tion >
Service
Guidance
page, that
is, the
name of
the flow
created in
Step 7.
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Eleme
nt/
Comp
onent

Key in
JSON
Data

Ty
pe

Description Value
Range

Tri
gg
eri
ng
Eve
nt

Remarks

Action
s

- Bu
tto
n

Delete a line
of call-
associated
data.

- Clic
k

-

Add - Bu
tto
n

Add a line of
call-associated
data.

- Clic
k

-

Cancel - Bu
tto
n

Cancel the
editing.

- Clic
k

-

Confir
m

- Bu
tto
n

Fill back the
call-associated
data in JSON
format.

- Clic
k

-

 
● Calling Number

– When Transfer Type is set to Third-party number (5), the number set
here is used as the calling number.

– When Transfer Type is set to Audio and video familiar customers (9),
the variable set here is used as the calling number of the customer. The
default value is SYS.callingNumber.

● Enable Recording: This check box is displayed only when Transfer Type is set
to Third-party number (5). You can select this check box to enable recording
during call transfer from an intelligent IVR to a third-party number. After you
select this check box, set the following parameters:
– Recording File Name: Enter a flow variable, for example,

FLOW.recordPath.
– Recording Service Node ID: Enter a flow variable, for example,

FLOW.serviceNo.

NO TE

The recording files in the intelligent IVR can be played and downloaded on the
Contact History > Transfer Record page.
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Condition Branch Description

Table 2-126 Condition branch description

Condition
Branch

Description Usage

SUCCESS Transfer
success

Triggered when a call is transferred successfully.

FAILED Transfer
failure

Triggered when a call fails to be transferred.
After this branch is triggered, the flow is not
interrupted and does not automatically go to
the exception handling flow.

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS.

 

Using the Diagram Element
The Call Transfer diagram element is used when a call needs to be transferred to
another destination device in the AICC, for example, to a common IVR self-service
flow or an agent.

Click the diagram element or drag it to the canvas, and set Transfer Type and
Route Value as prompted.

Typical Application Scenario
The following describes how to use the Call Transfer diagram element to transfer
a call from an intelligent IVR flow to a common IVR flow when call-associated
data in JSON format is carried.

Step 1 Sign in to the AICC.

Step 2 Configure a common IVR flow.

1. Choose Configuration Center > Chatbot Management > Flow
Configuration and add a common IVR flow.

2. Add flow variables, as shown in the following figure, and configure an Assign
diagram element.
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3. Configure a Condition Judgement diagram element for conditional judgment
based on the call-associated data.

4. Configure a Voice Playback diagram element for playing a variable voice.

5. Save and publish the flow.

Step 3 Configure an intelligent IVR flow.
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1. Choose Configuration Center > Chatbot Management > Flow
Configuration.

2. Choose Flow > Orchestration, add an intelligent IVR flow, add a Call
Transfer diagram element, and set service parameters of the diagram
element, as shown in the following figure.

3. Save and publish the flow.
4. Choose Intelligent Chatbot and bind the flow to a robot.
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Step 4 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the intelligent IVR added in Step 3.

Step 5 Log in to the OpenEye and dial the access code added on the Called Party page.
If "10000" is heard, the call-associated data (service_id: 10000) transferred by the
intelligent IVR is successfully obtained.

----End

2.6.3.10.10 Error Count Clearance

This diagram element is used to clear previous error records when a customer
needs to be transferred to another flow due to a number of intention matching
errors.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.

Condition Branch Description

Table 2-127 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Using the Diagram Element

The Error Count Clearance diagram element is used when the number of
semantic recognition and key pressing errors do not need to be accumulated.

Click the diagram element or drag it to the canvas.

Typical Application Scenario

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Semantic Understanding.
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Step 2 Configure a domain and an intention.

1. Choose Knowledge Management > Domain Management, click Create in
the upper right corner, set Name, and click Save.

Figure 2-263 Creating a domain

2. Click the name of the new domain. The Intention Management page is
displayed.

3. Click Create, choose General intent, enter an intention name, configure
Corpus and Response, and click Save.

Figure 2-264 Creating an intention

4. Click Active corresponding to the new intention to activate it.

Step 3 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type.
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Figure 2-265 Flow variables to be added
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Figure 2-266 Flow orchestration example (Semantic Recognition diagram
element)

– Use the reply variable FLOW.answer for the Robot Reply diagram
element below the Semantic Recognition diagram element to send the
reply to the matched intention.

– Use the reply variable FLOW.error3 for the Robot Reply diagram
element below the error3 condition branch of the Semantic Recognition
diagram element to send the reply "The number of errors is 3" for three
semantic recognition errors.

3. Save and publish the flow.

Step 4 Choose Intelligent Chatbot and bind the flow to a robot.
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Step 5 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Start Call to test the robot. Enter
incorrect corpuses continuously. If the robot keeps replying "Unknown intent" and
does not reply "The number of errors is 3" for more than three semantic
recognition errors, the Error Count Clearance diagram element takes effect in the
flow.

Figure 2-267 Testing the robot

----End

2.6.3.10.11 Branch Judgment

This diagram element is used to judge branches.

Diagram Element
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Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Condition and Condition Expression: branches of the exit of the current

diagram element.

Condition Branch Description

Table 2-128 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Using the Diagram Element

The Condition Judgment diagram element is used when branch flows need to be
executed based on different conditions. It makes the flow logic clearer.

Click the diagram element or drag it to the canvas, and click  under
Condition Branch to add a condition expression.

Typical Application Scenario

For details about how to use the Branch Judgment diagram element, see Typical
Application Scenario. The typical application scenario of the Key Recognition
diagram element involves the Branch Judgment diagram element.

2.6.3.10.12 Logic Loop

This diagram element is used to perform an operation on an object repeatedly
until a certain condition is met.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Counter: flow variable that stores the number of elements in a list.
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● Loops: objects to be traversed. Generally, the object list is the value obtained
by the previous node, for example, the customer list obtained by a stored
procedure.

● Loop Object: flow variable that stores the value of the object obtained each
time when the object list is traversed.

In addition to four variables, the Logic Loop diagram element provides two
default branches: inLoop and outLoop. The inLoop branch executes the logic
when a loop is entered, that is, some actions during object list traversal. The
outLoop branch executes the actions after object list traversal.

Condition Branch Description

Table 2-129 Condition branch description

Condition
Branch

Description Usage

inLoop Loop list
traversing

Triggered when the loop list traversing is not
completed.

outLoop Completed
loop list
traversing

Triggered when the loop list traversing is
completed.

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Using the Diagram Element
The Logic Loop diagram element is used when an operation needs to be
performed repeatedly until a certain condition is met.

Click the diagram element or drag it to the canvas, and set loop conditions and
objects.

Typical Application Scenario

Step 1 Sign in to the AICC and choose Configuration Center > Flow Configuration >
Intelligent IVR.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type.
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Figure 2-268 Flow variables to be added

Figure 2-269 Flow orchestration example (Logic Loop diagram element)

– The Robot Reply diagram element of the inLoop condition branch
traverses FLOW.list and outputs the values in FLOW.list.

– The Robot Reply diagram element of the outLoop condition branch
outputs FLOW.out, indicating that the loop ends.

3. Save and publish the flow.

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Start Call to test the robot. If the
robot outputs results properly, the configuration is successful.
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Figure 2-270 Testing the robot

----End

2.6.3.10.13 Variable Assignment

Use this diagram element by referring to the JSON Data Invoking diagram
element. This diagram element is used to obtain call-associated data and assign
values.

Diagram Element

Parameter Description

None

Condition Branch Description

Table 2-130 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no satisfaction option is selected, the
flow goes to the exception handling flow.
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Using the Diagram Element
(1) When the call-associated data is in JSON format, this diagram element can be
used to obtain the parameters of a specified node and assign values to the
parameters.

(2) Built-in functions described in 2.6.2.5.4 Built-in Functions can be used if data
processing, such as truncation, length obtaining, conversion, and check, is required
by businesses.

Click the diagram element or drag it to the canvas, and set parameters based on
the parameter description.

Typical Application Scenario
A customer makes a call to the AICC, and the call is routed to a skill queue. When
all agents in the skill queue are busy, if Queuing Method is set to IVR and an
intelligent IVR flow is selected for the skill queue, the intelligent IVR flow can use
this diagram element to obtain the current queuing status of the customer and
play the waiting tone to the customer. Therefore, the customer can determine
whether to continue waiting based on the queuing status.

Scenario 1: Assigning Values to Variables

Step 1 During data value assignment, in addition to string and integer data, expression
calculation is also supported. Integer data supports the following arithmetic
operations: +, -, *, and % (). Data supports FLOW, GLOBAL, and SYS. Example:
(FLOW.xxx+FLOW.yyy)*GLOBAL.zzz. Note that when / is used for division, the
calculation result needs to be received using data of the string type. Integers do
not support decimals. String data supports comparison, case conversion, character
string concatenation, substring calculation, and length calculation. Example:
FLOW.aaa=="Huawei" FLOW.bb.to FLOW.a.toUpperCase()
FLOW.A.toLowerCase() FLOW.hua+FLOW.wei
FLOW.len.substring(0,3)FLOW.zzzz.length()
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1. Configure an intelligent robot and set Dialog Type to IVR flow.

Step 2 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the added intelligent IVR.

Step 3 Log in to the OpenEye using a softphone number to simulate a customer, and dial
the access code added on the Called Party page. If the current queuing
information is heard, the configuration is successful.

----End

Scenario 2: Obtaining Call-associated Data

Step 1 Orchestrate a flow.

Example 1: Assume that the call-associated data is {"data":{"test": "Call-
associated data test"}}.
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Use the Variable assignment diagram element to assign the value of the test
field in the call-associated data to the flow variable FLOW.str1. In this example,
the value of FLOW.str1 is Call-associated data test.

Example 2: If the call-associated data of an outbound call task is {"iSales":
{"name":"Tom"}}, the content Tom can be obtained by setting iSales.name.

The following figure shows the screenshot based on example 1.

Figure 2-271 Obtaining call-associated data

1. Configure an intelligent robot and set Dialog Type to IVR flow.
2. Configure a common IVR, add the Transfer diagram element, select Transfer

to Intelligent IVR, and configure call-associated data.
3. Add the Variable assignment diagram element to the intelligent IVR flow,

and configure a variable on the Obtaining Associated Data tab page to
receive call-associated data from the common IVR.

Step 2 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the added intelligent IVR.

Step 3 Log in to the OpenEye using a softphone number to simulate a customer, and dial
the access code added on the Called Party page. Check whether the call-
associated data obtained in the intelligent IVR flow is correct.

----End

Scenario 3: Extended CDR Fields

You can set 10 service information fields (extfield1 to extfield10) to collect
customer information and customer operations to be saved in the IVR flow. These
fields can be used only when the system parameter IVRCDRCTRLPARAMS is
enabled. Do not assign values to encrypted variables. The values of encrypted
variables are processed as ****** for storage.
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2.6.3.10.14 Rule Validation V2

This diagram element is used to verify the customer input or output based on
rules.

Diagram Element
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Parameter Description

Figure 2-272 Rule validation V2 parameters

● Variable to be Verified: Enter the variable corresponding to the parameter to
be verified, for example, IVRREQUEST.input.

● End of Special Key: Specify the end character of the parameter to be verified.
The options are as follows:
– With #
– With *
– With # or *
– Without special keys

● Contains Characters: Specify the characters that can be contained in the
parameter to be verified. You can select multiple values. The options are as
follows:
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– Matches numbers
– Matches uppercase letters
– Matches lowercase letters
– Matches letters, digits, and underscores (_)
– Empty character

Verification Rules
● Name: Select a verification rule. The options are as follows:

– Minimum Length
– Maximum Length
– Length Range
– Min.
– Max.
– Value Range
– Email
– URL
– Time Format
– Decimal Number
– Positive Integer
– IP Address
– Alphanumeric Underscore (not starting with a number)

● Rule Parameters: Enter rule parameters. Variables are supported.

Condition Branch Description

Table 2-131 Condition branch description

Condition
Branch

Description Usage

SUCCESS Successful
verification

Triggered when the verification is successful.

FAILED Verification
failure

Triggered when the verification fails.

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Using the Diagram Element

This diagram element is used to verify the customer voice or keyboard input based
on rules.
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Click the diagram element or drag it to the canvas, and set parameters based on
the parameter description.

Typical Application Scenario
The following describes how to use the Rule validation V2 diagram element to
verify whether the customer input is a valid date.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type. The default value of the variable will be played
to the customer.

Figure 2-273 Add Variable
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Figure 2-274 Flow orchestration example (Rule validation V2 diagram
element)

– Select the reply text SUCCESS for the Robot Reply diagram element of
the SUCCESS condition branch, indicating that the time meets the format
requirements.

– Select the reply text FAILED for the Robot Reply diagram element of the
FAILED condition branch, indicating that the time does not meet the
format requirements.

3. Save and publish the flow.

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Start Call to test the robot. If the
robot answers SUCCESS or FAILED based on the time entered by the customer,
the configuration is successful.
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Figure 2-275 Testing the robot

----End

2.6.3.10.15 Interface Invocation

This diagram element is used when a third-party system interface needs to be
invoked to implement a function. If no interface is selected, you can directly add
parameters and assign values to the parameters to implement the function of the
diagram element.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Interface Type: Select the type of the interface to be invoked. The options are

inner interface and self defined interface. If inner interface is selected, the
following two built-in interfaces are available:
– Record Q&A: This interface used to record the survey ID, question title,

user reply intention, original user reply, and other information.
– Obtain the APIFabric token: This interface is used to obtain the API

Fabric token. After a robot successfully invokes this interface, the token is
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recorded in the cache and can be directly obtained from the cache within
the validity period. If the AK/SK is changed, the original cache is not
cleared, and this interface fails to be invoked within the cache validity
period. To invoke this interface immediately, you can bind the flow to a
new robot.

● Invoked Interface: interface to be invoked. Select an interface added on the
Resource Management > Business Interface page.

● Variable assignment: variable name and variable value. The output
parameter returned by the interface is valid only on the current node. If you
want to use the value in subsequent flow nodes, define a variable here and
assign the value of the output parameter to the variable.

● Condition branch: condition name and condition expression. Define the
branches of the exit of the current diagram element. For example, you can set
a branch based on the value of an output parameter. Different subsequent
flows can be specified for each branch.

● Method Invocation: Built-in functions described in 2.6.2.5.4 Built-in
Functions can be used if data processing, such as truncation, length
obtaining, conversion, and check, is required by businesses.

Condition Branch Description

Table 2-132 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

SYSERROR_I
NTERFACE

Interface
invocation
failure

Triggered when an interface invocation
exception occurs. If no option is selected, the
flow goes to the exception handling flow.

 

Using the Diagram Element

Click the diagram element or drag it to the canvas, and select the interface to be
invoked. The invoked interface needs to be configured on the Resource > Business
Interface page in advance. Alternatively, in the dialog box that is displayed, click
Add to add an interface. If you use this diagram element to assign a value, you do
not need to select an interface. Instead, you can directly add a cache variable and
assign a value to it. In this case, you need to maintain global variables in advance.

Typical Application Scenario

For details about how to use the Interface Invoking diagram element, see Typical
Application Scenario. In the typical application scenario of the Rule Validation
diagram element, the parameter value assignment function of the Interface
Invoking diagram element is used.
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2.6.3.10.16 Data Table

This diagram element is used to search for configuration data. It is used with the
Branch Judgement diagram element to determine which branch to go to or the
next step to process data.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Data Table Name: name of the data table to be searched.
● Search Page: page number of the data table to be searched. Enter an integer

or a variable. If this parameter is left blank, the first page is searched by
default. The page size is fixed at 10.

● Search Criteria: condition for searching a data table.
– If the field is of the character type, the operator can be =, >, >=, <, <=, !=,

like, or in. If the field value is of the character type, it does not need to
be enclosed in quotation marks. If the operator is in and the field value is
of the list type, each list item must be enclosed in double quotation
marks, for example, ["watermelon","apple"].

– If the field is of the integer type, the operator can be =, >, >=, <, <=, !=, or
in.

– If the field is of the date type, the operator can be =, >, >=, <, <=, or !=.
Set Field Value to a timestamp, in milliseconds. A value or variable of the
character type or long integer type is supported. A value or variable of
the character type does not need to be enclosed in double quotation
marks.

● Return Records: variable for saving search results. Enter a variable of the list
type.

● Total: variable for saving the total number of search results. Enter a variable
of the integer type.

Condition Branch Description

Table 2-133 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.
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Using the Diagram Element
The Data Table diagram element is used when you need to search a customized
data table for data.

Click the diagram element or drag it to the canvas. Select a data table and add
search conditions.

Typical Application Scenario
Use the Data Table diagram element in an IVR flow to search for the milk brand,
price, and inventory.

The following describes how to use the Data Table diagram element to search for
data and then process the data.

Query data records with milkCount being greater than 10 from the milkInfo
table. If the condition is not met, the robot returns a message indicating that no
such data record is found. If the condition is met, the robot returns the total
number of such data records, data records on the first page that meets the
condition, and milkName of the first data record.

Prerequisites
You have added a data table by referring to 2.6.2.4.4 Adding Data Tables, as
shown in the following figure.

Figure 2-276 Table fields

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 644



Figure 2-277 Table data

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.
2. Click + in the Flow Variable area. In the dialog box that is displayed, set the

variable name and data type.
3. Save and publish the flow.

Figure 2-278 Flow variables to be added
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Figure 2-279 Example of data table diagram element configuration

Figure 2-280 Example of branch judgment diagram element configuration
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Figure 2-281 Flow orchestration example

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call. In the test dialog box that is displayed, click Start Call to test the robot.

NO TE

Only 10 data records on the specified search page are queried. If no search criteria are
specified, the first page is queried by default.

----End
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2.6.3.10.17 Stored Procedure

This diagram element uses a stored procedure to interact with the database.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● Stored Procedure: stored procedure added on the Configuration Center >

Flow Configuration > Resource > Stored Procedure page.
● Cache Variable and Response Attribute: flow variables and their values. The

output parameter returned by the stored procedure is valid only on the
current node. If you want to use the value in subsequent flow nodes, define a
cache variable here and assign the value of the output parameter to the
cache variable.

● Condition and Condition Expression: branches of the exit of the current
diagram element. For example, you can set a branch based on the value of an
output parameter in the stored procedure. Different subsequent flows can be
specified for each branch.

Using the Diagram Element
The Stored Procedure diagram element is used when data needs to be imported
to the database. It cannot be used in public cloud scenarios. In scenarios where
the OIAP is independently deployed, the database you access needs to be
deployed in the same security zone as the OIAP for security purposes.

Currently, the stored procedure applications of the MySQL database, Oracle
database, and GaussDB are supported.

Click the diagram element or drag it to the canvas, select the stored procedure to
be invoked, set its input parameters, and add cache variables to temporarily save
its output parameters. For the list type in output parameters, you need to set it
separately based on rules.

Typical Application Scenario
The following describes how to use the Stored Procedure diagram element.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure a database.

1. Contact the system administrator to add the database URL to the trustlist.
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2. Choose Resource > Stored Procedure, click the Stored Procedure Databases
tab, and click Create.

Figure 2-282 Configuring a stored procedure database

Step 3 Configure a stored procedure.

1. Obtain the developed stored procedure script. An example is as follows:

Figure 2-283 Stored procedure script example

2. Choose Resource > Stored Procedure, click the Stored Procedures tab, and
click Create.
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Figure 2-284 Basic Information page

Figure 2-285 Input Parameter page
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Figure 2-286 Output Parameter page

Step 4 Configure an intelligent IVR flow. The usage of the Stored Procedure diagram
element is similar to that of the Interface Invoking diagram element. Select the
configured stored procedure, set input parameters, and assign output parameters
to a variable as required.

1. Choose Resource > Variable, click the Custom Variable tab, and click Create
to add a system variable for receiving the output parameters of the stored
procedure.

Figure 2-287 System variable to be added

2. Choose Flow > Orchestration and click New to add a simple flow.
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Figure 2-288 Flow orchestration example (Stored Procedure diagram
element)

Use the reply variable GLOBAL.xxxx for the Robot Reply diagram element to
reply the number output by the stored procedure to the customer.

3. Save and publish the flow.
4. Choose Intelligent Chatbot and bind the flow to a robot.

Step 5 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the added intelligent IVR.

Step 6 Log in to the OpenEye using a softphone number to simulate a customer, and dial
the access code added on the Called Party page. If the robot can query the
number output by the stored procedure based on the calling number and reply it
to the customer, the configuration is successful.

----End

2.6.3.10.18 Time Selection

The orchestration capability varies depending on the time. That is, the holiday
time of each region may be different. During flow orchestration, perform different
orchestration operations based on the holidays and working days.
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Diagram Element

Parameter Description
● Node Name: name of a node.

● Description: details of a node.

● Week Selection: Select the working days of a week.

● Service Period: Select the start working time and end working time.

● Specified Service Date: Specify one or more dates as working dates.

● Specified Non-service Date: Specify one or more dates as non-working
dates.

The time zone is that set by the system administrator when the tenant space is
created. If the time zone is not set when the tenant space is created, the value of
the built-in variable timezone is used.

The configuration priority is as follows: Specified Non-service Date > Specified
Service Date > Week Selection.

Condition Branch Description

Table 2-134 Condition branch description

Condition
Branch

Description Usage

NON_SPECI
FIC_TIME

Non-working
time

Triggered when the current time is non-working
time.

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Using the Diagram Element

The holiday time of each region may be different. During flow orchestration,
perform different orchestration operations based on the holidays and workdays.

Click the diagram element or drag it to the canvas, and set parameters based on
the parameter description.
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Typical Application Scenario

The following describes how to use the Time Selection diagram element to
determine whether the current time is working time for subsequent business
handling.

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent robot.

1. Choose Flow > Orchestration and click New to add a simple flow.

2. Click + in the Flow Variable area. In the dialog box that is displayed, set the
variable name and data type.

Figure 2-289 Flow variable to be added

Figure 2-290 Flow orchestration example (Time Selection diagram element)
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Figure 2-291 Referencing a work calendar template

For the Robot Reply diagram element, set Reply Variable to FLOW.response
to reply to the customer with "The current time is working time. What kind of
business do you want?" if the current time is working time.

3. Save and publish the flow.

Step 3 Choose Intelligent Chatbot and bind the flow to a robot.

Step 4 Choose Intelligent Chatbot. In the last column corresponding to the robot, click
Test Call.

In the test dialog box that is displayed, click Start Call to test the robot. If the
robot replies based on whether the current time is working time, the configuration
is successful.

----End

2.6.3.10.19 Information Query

This diagram element is used to query the status of the current customer in the
queue. When all agents are busy, the system plays the waiting tone to the
customer through the IVR.

Currently, you can query the queuing position, the number of all online agents in
a skill queue, and the estimated time required for accessing an agent.

This diagram element is used to query details about agents in configured skill
queues.

This diagram element is used to query whether the customer is in the special list.

Diagram Element
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Parameter Description
● Querying queuing information

– Query Type: information type that can be queried using this diagram
element. Currently, queuing information can be queried.
The queuing information is queried using an IVR flow when a call is
transferred to a skill queue.

– Query result

▪ Queue Position: position of a customer in the current skill queue,
that is, the number of queuing customers in front of the customer.
You can use a global variable (GLOBAL.*) or flow variable (FLOW.*)
to save the value for subsequent operations.

▪ Number of online agents: total number of online agents in the skill
queue to which a customer belongs. You can use a global variable
(GLOBAL.*) or flow variable (FLOW.*) to save the value for
subsequent operations.

▪ Estimated waiting time: estimated duration for connecting a call to
an agent during queuing. This parameter is affected by Queue
Position and Number of online agents. You can use a global
variable (GLOBAL.*) or flow variable (FLOW.*) to save the value for
subsequent operations. The estimated waiting time depends on the
queue model. The result may be inaccurate. Therefore, use this
parameter properly.

● Querying queue information
– Query Type

Queue Information: Query queue information before a call is transferred
to a skill queue.

– Request Parameter
Skill Queue: skill queue to which a call is transferred.

– Query result

▪ Number of queues: number of customers in the current skill queue
before a call is transferred to another skill queue. You can use a
global variable (GLOBAL.*) or flow variable (FLOW.*) to save the
value for subsequent operations.

▪ Number of online agents: total number of online agents in the skill
queue to which a call is transferred. You can use a global variable
(GLOBAL.*) or flow variable (FLOW.*) to save the value for
subsequent operations.

▪ Number of idle agents: total number of online and idle agents in
the skill queue to which a call is transferred. You can use a global
variable (GLOBAL.*) or flow variable (FLOW.*) to save the value for
subsequent operations.

▪ Estimated waiting time: estimated time for connecting a call to an
agent after the call is transferred to a skill queue. You can use a
global variable (GLOBAL.*) or flow variable (FLOW.*) to save the
value for subsequent operations. The estimated waiting time
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depends on the queue model. The result may be inaccurate.
Therefore, use this parameter properly.

● Querying the queue name
– Query Type

Queue Name: The name of a skill queue to which an agent belongs can
be queried based on the agent ID.
The scenario is to query the skill queue name based on the agent ID
before the call is transferred to the skill queue to which the agent
belongs.

– Request Parameter
Agent ID: agent ID. Flow variables or constants are supported.

– Query result
Queue Name: name of the voice skill queue with the highest weight in
the skill queue to which the agent ID belongs. Use the global variable
(GLOBAL.*) or flow variable (FLOW.*) for subsequent operations.
You can choose Configuration Center > Employee Center > Agent
Management to configure the skill queue weight.

● Querying special list information
– Query Type

Special List Information: Currently, the system can check whether a
customer is in the special list based on the customer number. The next
process varies depending on the special list query result.
The special list refers to the blocklist.

– Query result
Identifier in the special list: whether the calling number exists in the
special list. Use the global variable (GLOBAL.*) or flow variable (FLOW.*)
for subsequent operations.
The values of Identifier in the special list are as follows: 0 indicates that
the calling number does not exist in the special list, and 1 indicates that
the calling number exists in the special list.

Condition Branch Description

Table 2-135 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Using the Diagram Element
The Information query diagram element can be used to query information such
as the queuing status and special list information of the current customer.
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Click the diagram element or drag it to the canvas, and set parameters based on
the parameter description.

Typical Application Scenario
A customer makes a call to the AICC, and the call is routed to a skill queue. When
all agents in the skill queue are busy, if Queuing Method is set to IVR and an
intelligent IVR flow is selected for the skill queue, the intelligent IVR flow can use
this diagram element to obtain the current queuing status of the customer and
play the waiting tone to the customer. Therefore, the customer can determine
whether to continue waiting based on the queuing status.

Scenario 1: Query queuing information.

Step 1 Choose Configuration Center > Employee Center > Skill Queue, click Edit
corresponding to the skill queue, and set Queuing Method to IVR.

Figure 2-292 Page for editing skill queue parameters

Step 2 Orchestrate a flow. In the flow, use the Information query diagram element to
query data, including the number of online agents, queuing position, and
estimated waiting time.

1. Create three flow variables to receive the query result.
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Figure 2-293 Flow variables to be added

2. Configuring an IVR voice. Use the created flow variables in the IVR voice
content.

Figure 2-294 Added IVR voice

3. Configure a resource template.

Figure 2-295 Page for configuring a resource template
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4. Create a flow, use the Information query diagram element to assign values
to the three flow variables, and use the Robot Reply diagram element to
select the configured resource template.

Figure 2-296 Flow orchestration example

5. Configure an intelligent robot and set Dialog Type to IVR flow.

Step 3 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the intelligent IVR added in Step 2.

Step 4 Log in to the OpenEye using a softphone number to simulate a customer, and dial
the access code added on the Called Party page. If the current queuing
information is heard, the configuration is successful.

----End

Scenario 2: Query queue information.

Step 1 Orchestrate a flow.

1. Create four flow variables to receive the query result.
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Figure 2-297 Flow variables to be added

2. When using the diagram element to create a flow, if you want to transfer a
call to a skill queue in the flow, you can query the information about the skill
queue and then determine whether to transfer the call to the skill queue. The
subsequent businesses are determined based on site requirements.
The flow is shown in the following figure. You need to select a skill queue to
be queried.
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Figure 2-298 Flow orchestration example

3. Configure an intelligent robot and set Dialog Type to IVR flow.

Step 2 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the added intelligent IVR.

Step 3 Log in to the OpenEye using a softphone number to simulate a customer, and dial
the access code added on the Called Party page. If the current queue information
is heard, the configuration is successful.

----End

Scenario 3: Query special list information.

Step 1 Orchestrate a flow.

1. Create a flow variable to receive the query result.
2. Configure a flow by referring to the following figure. When the flow runs to

the special list information query node, the flow invokes an interface to query
special list information, obtains the query result, and enters different flows
based on the query result.
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Figure 2-299 Flow orchestration example

3. Configure an intelligent robot and set Dialog Type to IVR flow.

Step 2 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the added intelligent IVR.

Step 3 Log in to the OpenEye using a softphone number to simulate a customer, and dial
the access code added on the Called Party page. If the current special list
information is heard, the configuration is successful.

----End

2.6.3.10.20 User Level

The priority (user level) of a call can be set. The call of a user with a higher
priority is transferred to an agent first.

Diagram Element

Parameter Description
● Node Name: name of a node.
● Description: details of a node.
● User Level: Enter a non-negative integer or a string variable. The default

value is 0, and the maximum value is 14. After calls are transferred to the
manual service, the call from a high-level user is processed preferentially.
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Condition Branch Description

Table 2-136 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

fail User level
setting failure

Triggered when the call priority of a user fails to
be set.

 

Using the Diagram Element

This diagram element is used when the priority (user level) of a call needs to be
set and the call of a user with a higher priority is transferred to an agent first.

Click the diagram element or drag the diagram element to the canvas and set user
level service parameters.

Typical Application Scenario

Step 1 Sign in to the AICC and choose Configuration Center > Chatbot Management >
Flow Configuration.

Step 2 Configure an intelligent IVR flow.

1. Choose Flow > Orchestration and click New to add a simple flow.

2. Click + in the Flow Variable area. In the dialog box that is displayed, set the
variable name and data type.

Figure 2-300 Flow variables to be added
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Figure 2-301 Flow orchestration example (User Level diagram element)

Figure 2-302 Flow orchestration example (Call Transfer diagram element)

3. Save and publish the flow.

4. Choose Intelligent Chatbot and bind the flow to a robot.

Step 3 Choose Configuration Center > Access Configuration > Called Party and add a
called route. Set the IVR to the intelligent IVR added in Step 2.

Step 4 Set the current agent to the busy state, log in to the OpenEye using two
softphone numbers to simulate two customers, and dial the access code added on
the Called Party page at the same time. Answer the user level according to the
voice prompt. You are advised to set different user levels for the two customers.
Then, set the current agent to the idle state. If the customer of a higher level is
connected to the agent first, the configuration is successful.

----End
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2.6.3.10.21 Message Leaving

The system records the message of a customer. After the recording is successful,
the system returns the directory for storing the recorded message.

Diagram Element

Parameter Description
The following figure shows the parameters of the Leave Message diagram
element.
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● Node Name: name displayed on the diagram element, which can be
customized.

● Specify Agent for Processing
Specified Agent ID: Configure constants or flow variables as required. The
constants or flow variables are used to automatically allocate messages to the
specified agent ID. If the specified agent ID does not exist, the message status
changes to allocation failure. If no agent is specified, messages will be
allocated by the administrator.

● Recording file
Save File Name (first text box): Click the text box. In the dialog box that is
displayed, select a global variable or flow variable for saving the recording file
name as required. The system saves the recording file name using a variable
of the string type. Therefore, you can select only a variable of the string type.
Saving the localtionID (second text box): Select the UAP node set during
installation. This parameter is used in call center pool mode.

● Recording Parameter
Max. Recording Duration: Enter the maximum duration of a recording. When
the maximum recording duration is reached, the recording ends. The default
value is 20, in seconds.

● Play the beep tone: If the check box is selected, a beep tone is played before
the recording starts. Otherwise, the recording is performed directly.
By default, the recording is ended with the pound key (#).: After leaving a
message, you can press the pound key (#) to end the recording. After the
subscriber hangs up, the end diagram element is invoked directly.

● Record message information.: If this check box is selected, messages are
saved as records. If this check box is not selected, messages cannot be queried
on the message management page.

● Click Save to save all parameters set on the current page. When the recording
is saved, the system automatically queries the recording directory information
of the current tenant and combines the directory with the current date and a
random digit string to form a file name. An example is Recording drive letter:/
VDNID/record/20190424/20190424153126-record.wav. The recording file is in
the .wav format by default.

NO TE

● When a tenant is deleted, the Customer Service Cloud automatically deletes all
recording files of the tenant.

● The retention period of recording files is the same as the recording storage period
configured during tenant registration. The scheduled task scans recording files at a
specified time every day and periodically deletes recording files that have been stored
for a period longer than expected.
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Condition Branch Description

Table 2-137 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Typical Application Scenario
This diagram element is used in the scenario where a voice message needs to be
stored in a recording file.

2.6.3.10.22 SMS

You can send common SMS messages and satisfaction survey SMS messages to
the calling party. The SMS messages can be Huawei Cloud SMS messages or SMS
gateway messages.

Diagram Element

Figure 2-303 Text Message
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Parameter Description

Figure 2-304 Common SMS message parameters
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Figure 2-305 Satisfaction survey SMS message parameters

The parameters are described as follows:

● Message Sending Mode: Currently, Short Message and Satisfaction Survey
are supported.
– To send a satisfaction survey SMS message, you need to set Valid Reply

Period(Minutes). The value ranges from 1 to 1440.

Figure 2-306 Valid Reply Period(Minutes)

● Channel: The options are Huawei Cloud and SMS Gateway.
– Huawei Cloud: The SMS service provided by Huawei Cloud is used to

send SMS messages.
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– SMS Gateway: Huawei SMS gateway is used to send SMS messages.
● Template: This parameter is mandatory. The administrator SMS message

templates that have been configured in the notification center are displayed
based on the selected channel.

● Country Code: This parameter is mandatory. The country or region code is
required for sending an SMS message. If the SMS message needs to be sent
to a national number, the country or region code is also required. For
example, the country code of China is +86.

● Mobile Number: This parameter is optional. If this parameter is left empty,
the SMS message is sent to the calling party by default. If this parameter is
set, the SMS message is sent to the specified number. Only one number is
supported and the value cannot contain the country code.

Condition Branch Description

Table 2-138 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Typical Application Scenario
When a user calls the CEC and the call is routed to the IVR, if the IVR is configured
with a Short Message diagram element, the Short Message diagram element is
used to send an SMS message to the user.

The configuration method is as follows:

● Application Scenario

Step 1 Choose Configuration Center > Flow Configuration > Flow Management, click
New, set the flow name and type, and set Is Referenced to Yes.

Figure 2-307 Adding a flow
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Step 2 Click Edit to develop the flow as follows.

Step 3 Click or drag the Short Message diagram element in the Feature area on the left.
The Short Message diagram element is added to the canvas.

Step 4 Set parameters of the Short Message diagram element and click Save. (Huawei
Cloud SMS is used as an example.)

Figure 2-308 Short Message
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Figure 2-309 Satisfaction Survey

Step 5 Add connection lines. If there are no other diagram elements, the flow is shown in
the following figure.
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Figure 2-310 Example

Step 6 Perform subsequent operations based on business requirements. You can add

other diagram elements. After the configuration is complete, click 
to save the flow.

----End

2.6.3.10.23 Survey

This diagram element is used to add a survey for an automatic outbound call task.

Diagram Element

Parameter Description
The following figure shows the parameters of the questionnaire diagram
element.
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The parameters are described as follows:

● Node Name: name displayed on the diagram element, which can be
customized.

Condition Branch Description

Table 2-139 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no option is selected, the flow goes to
the exception handling flow.

 

Typical Application Scenario
The questionnaire diagram element is used only when an automatic outbound
call task needs to be associated with an IVR survey flow. After an intelligent
outbound call task is started, if the IVR flow associated with the outbound call
task contains the questionnaire diagram element, the survey content specified for
the outbound call task is played to the user.

2.6.3.10.24 Satisfaction Configuration

This diagram element is used to play voices or videos to instruct customers to
press keys for interaction and collect their satisfaction details about corresponding
calls.
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Diagram Element

Parameter Description
The following figure shows the parameters of the Satisfaction Configuration
diagram element.
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Figure 2-311 Voice
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Figure 2-312 TTS
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Figure 2-313 Video

The parameters are described as follows:

● Node Name: diagram element name which can be customized.

● ccivr.nms.satisfactionservice.evaluateObject: Select Robot or Agent.

● Satisfaction Survey Type: Satisfaction Result, NPS Score, and Resolved or
Not are available.

● Voice Prompt: Select Voice, TTS, or Video. You can click an option button to
select a voice type.

– Voice: Upload a WAV voice file. Currently, the UAP supports only WAV (8
kHz, 8-bit) voice files.

– TTS: Generate a voice file in TTS mode. You can enable Advanced TTS

settings to set voice playback parameters. Click  in the drop-down list
to select a sound effect and speaking speed. If this function is disabled,
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Sound effect is set to Female voice, Speaking speed is set to Low, and
TTS Extended Parameter is not set by default.

▪ Sound effect: Select the sound effect. The options are Male voice
and Female voice.

▪ Speaking speed: Select the speaking speed. The options are Low,
Medium, and High.

▪ TTS Extended Parameter: Set this parameter based on site
requirements. The value contains a maximum of 200 characters.

– Video: Upload a video file in 3GP format, whose size must be less than or
equal to 5 MB.

● Satisfaction Button Configuration: satisfaction options provided in a flow.
Each key or button corresponds to a satisfaction option. For details about how
to configure the satisfaction level, see 2.3.3.2 Configuring Satisfaction
Surveys.
– Buttons: number key or button available on the keyboard or screen, such

as 1, 2, or 3.
– Description: satisfaction introduction of a key or button, which can be

displayed in the menu.

NO TE

Configure satisfaction levels for the satisfaction survey on the Survey > Survey
Config page. If the flow has been published, you can clone, edit, save, or
republish the flow to replace the original flow so that the updated satisfaction
levels can be used.

– Waiting Time for Digit Collection: time to wait for the digit input. If the
time when a customer stops the input exceeds that specified by Waiting
Time for Digit Collection, the system records a failure, automatically
executes Digit collection timed out, and continues to wait for the digit
input.

– Max. Failure Times: maximum number of input attempts that are
allowed. When an error occurs during digit collection, the system records
a failure, automatically executes Digit collection failure, and continues
to wait for the digit input.

● Advanced Settings: You can click Advanced Settings + to expand this area
and click Close to collapse this area.
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– Digit collection failure: You can click  to enable the capability of
playing a voice upon a digit collection error. Then, if digits fail to be
collected before the number of a customer's input attempts reaches the
maximum specified by Max. Failure Times, the system plays a voice to
notify the customer.

– Digit collection timed out: You can click  to enable the
capability of playing a voice upon digit collection timeout. Then, if digits
fail to be collected after the wait time reaches the maximum specified by
Waiting Time for Digit Collection, the system plays a voice to notify the
customer.

NO TE

● If the time when a customer stops the input exceeds that specified by Waiting Time for
Digit Collection, the system records a failure, automatically executes Digit collection
timed out, and continues to wait for the digit input.

● When an error occurs during digit collection, the system records a failure, automatically
executes Digit collection failure, and continues to wait for the digit input.

● By default, Digit collection failure and Digit collection timed out are unavailable in
the Advanced Settings area. If they are unavailable, the system replays the voice
configured for the voice playback and digit collection diagram element upon a failure.

● When the number of a customer's input attempts reaches the maximum specified by
Max. Failure Times, the system executes the common failure exit.

Condition Branch Description

Table 2-140 Condition branch description

Condition
Branch

Description Usage

SYSERROR_I
NNER

ODFS internal
error

Triggered when an unknown error occurs in the
ODFS. If no satisfaction option is selected, the
flow goes to the exception handling flow.

 

Typical Application Scenario
This diagram element is used when an agent hangs up without completing the
flow.

NO TE

The application scenario of the Satisfaction Configuration diagram element is as follows:
● After an agent hangs up, the system releases the call and transfers the call to the IVR

flow that contains the Satisfaction Configuration diagram element.
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2.6.3.10.25 Call Ending (Expired and Not Recommended)

This diagram element is used to identify the end of a flow. Each flow has at least
one Call Ending diagram element. In a complex flow, multiple Call Ending
diagram elements can be used to identify the end of different branches.

Diagram Element

Parameter Description

The following figure shows the parameters of the Call Ending diagram element.

The parameters are described as follows:
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● The interface needs to be invoked when a call ends: Select the text box to
configure the interface to be invoked. The interface is invoked before the call
ends.

● Select Interface: Select an interface name from the drop-down list box. The
interfaces that can be selected have been configured for the current tenant.
For details about the interface configuration, see 2.6.2.2.2 Adding Business
Interfaces.

● Input Parameter: This area displays the input parameters of the selected
interface. When an input parameter exists, you can assign a value, such as a
constant and variable, to the input parameter as required. Variables must be
defined in the system, for example, FLOW.ID.

● Output Parameter: This area displays the output parameters of the selected
interface. If there are specific output parameters, you can assign values to the
output parameters as required. You can enter FLOW or GLOBAL variables.

● Click Save to save all parameters set on the current page.

Typical Application Scenario

This diagram element is used at the end of a flow.

NO TE

The application scenarios of the end diagram element are as follows:

● When a user hangs up, the system invokes the end diagram element by default. In this
case, only one end diagram element exists in the flow, and the flow does not need to be
connected to the end diagram element.

● If an active hangup is required in the IVR flow, the end diagram element needs to be
invoked. In this case, ensure that the flow has been connected to the end diagram
element.

2.6.3.10.26 Condition Judgment (Expired and Not Recommended)

This diagram element is used to set multiple conditions, based on which the
system enters different branches. During configuration, you can click the
connection line of a branch and select the corresponding condition.

Diagram Element

Parameter Description

The following figures show parameters of the Condition Judgment diagram
element.
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Figure 2-314 Condition Judgment

Figure 2-315 Branch

The parameters are described as follows:

● Module: diagram element name, which can be customized as required. The
name is not displayed on the diagram element.

● Condition Editing: In this area, you can configure different judgment
conditions, based on which different branches can be implemented in a flow.
If you click Simple Expression, the following parameters need to be set:
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– Parameter 1: Click the text box. In the displayed Select Variables dialog
box, select a global variable, flow variable, or system variable as required.

– Relational Operator: relational operator, which is used to define the
relationship between parameter 1 and parameter 2.

– Parameter 2: Enter a variable or constant. If parameter 2 is a string
constant, enclose it with double quotation marks, for example,
"0123456789".

– Logical Operator: The options are And and Or. The priorities of different
operators are the same, and conditions are judged one at a time from top
to bottom.
By selecting a logical operator, you can add multiple condition
expressions in the same condition. If you select And, multiple condition
expressions must be met at the same time. If you select Or, only one of
the condition expressions must be met.

– You can click Delete to delete a condition expression.
If you click Complex Expression, a complex condition expression must be
entered in the text box. The expression can contain the parameter name,
value, and complex operation. After a series of operations, the complex
expression returns a value of the Boolean type, for example, true or false.
– The formats of flow variables, system variables, and global variables are

as follows: FLOW.Parameter name, SYS.Parameter name, and
GLOBAL.Parameter name.

– The priorities of operators used in complex expressions are as follows:
parentheses > arithmetic operators > relational operators > logical
operators. Operators at the same level (except arithmetic operators) have
the same priority. The operators of other levels have the same priority.
The symbols of each type are as follows:
Parentheses: ()
Arithmetic operator: *, /, %, +, – (The priorities of the asterisk, slash, and
percent sign are higher than those of the plus sign and minus sign.)
Relational operators: >, >=, <, <=, ==, !=
Logical operators: &&, ||
In addition to basic logical expressions, functions based on the mvel2
expression are also supported. For example, the flow variable
FLOW.testvalue is set to abc, and the contains function is used to
determine whether the d character is contained. If the determination
result is false, the branch is not executed.
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Similarly, simple functions may be used as follows:
FLOW.testvalue.substring(0,1)=='d' checks whether the first character is d.
FLOW.testvalue.endsWith(classification) checks whether the value ends
with c.
If other functions are required, develop them under the guidance of
Huawei engineers.

● You can click New Condition to add multiple conditions, which can map
different branches.
A maximum of 20 conditional branches are allowed.

● Click  to delete a condition.
● Click Save to save all parameters set on the current page.
● branch: Click the connection line between a condition judgment diagram

element and a branch diagram element, and select the condition to enter the
branch from the drop-down list. If no condition is selected, the branch is used
as a default branch, which is executed when none of the conditions are met.

Typical Application Scenario
The system enters a branch in a flow based on the input condition. For example,
the system can enter different branches based on the flow execution result
(success or failure).

2.6.3.10.27 Ringing (Expired and Not Recommended)

This diagram element is used in the video call scenario to determine whether to
display the video content on the customer side or agent side.

Diagram Element

Parameter Description
The following figure shows the parameters of the Ringing diagram element.
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The parameters are described as follows:

● Node Name: Enter a diagram element name. The value can be customized.

● Video mode:

– Send Only: Only the video image on the agent side is displayed.

– Receive only: Only the video image on the customer side is displayed.

– sendrecv: Both the video images on the agent and customer sides are
displayed.

Typical Application Scenario

The Ringing diagram element is used only for video calls in the ringing state.
When selecting the video content to be displayed, you need to associate the
Ringing diagram element.

2.6.3.10.28 Response (Expired and Not Recommended)

This diagram element is used with the Ringing diagram element. When Ringing is
used with the Transfer diagram element and Transfer Configuration is set to
Transfer to Skill Queue, you need to configure the Robot Reply diagram element
to provide the agent answering capability.

Diagram Element
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Parameter Description
The following figure shows the parameters of the Robot Reply diagram element.

The parameters are described as follows:

● Node Name: Enter a diagram element name. The value can be customized.

Typical Application Scenario
This diagram element is used with the Ringing diagram element.

2.6.3.10.29 User Level (Expired and Not Recommended)

This diagram element is used to set the user level. When multiple users are in the
queue, the user with a higher level can be connected to the idle agent first.

Diagram Element

Parameter Description
The following figure shows the parameters of the User Level diagram element.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 688



The parameters are described as follows:

Node Name: Enter a diagram element name.

User Level: Enter a user level, which is used to set the level of the calling number.
The calling number with a higher level is preferentially connected to an agent.
Currently, user levels 1 to 14 are supported. You can use a global variable
(GLOBAL.*) or flow variable (FLOW.*) to save the value for subsequent
operations. (A decimal is not supported. If the value is a decimal, the default value
1 is used.)

Typical Application Scenario
A user calls an IVR flow. The flow invokes a third-party interface to obtain the user
level, uses the User Level diagram element to set the user level, and uses the
Transfer diagram element to transfer the call to an agent.

If the user with highest level is in a queue, the call is preferentially connected to
an agent.

2.6.3.10.30 Time Selection (Expired and Not Recommended)

This diagram element is used to configure the service provision time by time
range, week day, or date. The system provides services based on the configured
service time range on selected week days within the period that is configured.
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Diagram Element

Parameter Description

The following figure shows parameters of the Time Selection diagram element.

The parameters are described as follows:

● Node Name: Enter a diagram element name. The value can be customized.
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● Service Time Range: This area is used to configure time ranges in which
services are provided. The time ranges are specified in 24-hour format.
Different time ranges cannot overlap each other.

● Week Day: week day on which services are provided.
● Date: period in which services are provided. You can specify one period or

multiple inconsecutive periods. The system provides services based on Service
Time Range only on the dates that fall within the periods specified by Week
Day and Date.

NO TE

If Date is set to multiple inconsecutive periods and other services need to be provided
in the period intervals, you need to add another time selection diagram element and
configure the time for providing services in the intervals. In addition, you need to add
a branch connection line between the two time selection diagram elements and set
the branch condition to Wrong Time. For example, October 1, 2019 to October 7,
2019 are not workdays, but personnel need to be assigned on duty. In this case, you
need to add another time selection diagram element with Date set to 2019-10-01 to
2019-10-07, add a branch connection line between the two time selection diagram
elements, and set the branch condition to Wrong Time.

By default, the Time Selection diagram element corresponds to the GMT+8
time zone. To set another time zone, perform the following steps:

a. Choose Configuration Center > Flow Configuration > Intelligent IVR.
On the page that is displayed, choose Resource Management > Variable
Management.
If you have not subscribed to the intelligent IVR feature, you cannot
access the page in your tenant space. In this case, contact the system
administrator to enable the corresponding function.

b. Click the Built-in Variable tab, click Edit next to timezone and set the
value to the corresponding time zone. For example, set the value to -3 for
GMT-3, as shown in the following figure.
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NO TE

The system identifies the time zone settings in the following sequence:
● The system preferentially uses the value of GLOBAL.timezone, that is,

timezone added on the Custom Variable tab page under Intelligent IVR >
Resource Management > Variable Management.
The system variable timezone has been preset in the system. Therefore, you
are advised not to set the time zone using the global variable.

● If GLOBAL.timezone is not added, the system obtains the value of timezone
on the Built-in Variable tab page under Intelligent IVR > Resource
Management > Variable Management.

● If neither of them is configured, the default time zone is GMT+8.

c. Click Confirm.

● Click Save to save all parameters set on the current page.

Typical Application Scenario
Businesses need to be provided at a restricted service time. For example, if
business A can be handled at store A only between 08:00 and 17:30 on Monday to
Friday all the year round, you need to set Service Time Range to 8:00-17:30,
Week Day to Monday to Friday, and Date to 2019-01-01 to 2019-12-31 for
business A.

2.6.3.10.31 Assignment (Expired and Not Recommended)

This diagram element is used to assign values to flow variables or global variables,
and assign specified values to parameters.

NO TE

The call-associated data is carried in a call. The data is stored in the call until the call ends.

Diagram Element

Parameter Description
The following figure shows the parameters of the Assign diagram element.
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Figure 2-316 Assign TransferData

Figure 2-317 Assign OthersData
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Figure 2-318 Set TransferData

Figure 2-319 Assign IEData

The parameters are described as follows:

● Node Name: Enter a diagram element name. The value can be customized.
● Data assignment: Assign a value to the current flow in one of the following

ways:
– Assign TransferData
– Assign OthersData
– Set TransferData
– Assign IEData

● Prepare assignment parameters: Configure the parameters to be carried
when the value of the call-associated data or other data is assigned. Such
parameters are used to carry remarks, which do not affect the flow logic.
– Value: Enter a parameter value, which is optional.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 694



i. Assign TransferData
Scenario: The agent transfers the call-associated data to the IVR flow.
The IVR flow obtains the call-associated data. The call-associated
data must be in the following format:
{"callid":"1598006316-4672","calldata":"{\\\"key1\\\":\\\"v1\\\", \
\\"key2\\\":\\\"v2\\\"}","isDataEncoded":"false"}
The call-associated data is obtained based on calldata.key1 and
calldata.key2.
When a call is transferred from an intelligent IVR flow to a common
one, the data is in the JSON format defined by the customer. The
customer obtains parameter values by directly obtaining the values
of parameters at the first layer and obtaining the values of
parameters at the second layer in a.b format.

ii. Assign OthersData
During data value assignment, in addition to string and integer data,
expression calculation is also supported.
Integer data supports the following arithmetic operations: +, -, *, and
% (). Data supports FLOW, GLOBAL, and SYS.
Example: (FLOW.xxx+FLOW.yyy)*GLOBAL.zzz. Note that when / is
used for division, the calculation result needs to be received using
data of the string type. Integers do not support decimals.
String data supports comparison, case conversion, character string
concatenation, substring calculation, and length calculation.
Example: FLOW.aaa=="Huawei" FLOW.bb.to
FLOW.a.toUpperCase() FLOW.A.toLowerCase() FLOW.hua
+FLOW.wei FLOW.len.substring(0,3)FLOW.zzzz.length()

iii. Set TransferData
When the IVR flow is running, you can set the call-associated data
through this parameter to transmit data with sessions.
The call-associated data must be in key-value format. Multiple key-
value pairs can be set and are combined as follows: {"data":
{"key":"value","key1":"value1"}}. Agents can obtain the value of this
parameter.

iv. Assign IEData
The IE information transmitted in the flow can be obtained.
Currently, only the User To User option is available.
Click the Prepare assignment parameters text box. The global
variable and flow variable lists are displayed for selection.

– Click New to add a parameter record. The value of Transfer Parameters
must be unique in each record.

– Click Delete to delete the current record.
● Click Save to save all parameters set on the current page.

Typical Application Scenario
After an agent sets call-associated data and transfers the call to the IVR, the IVR
can obtain the call-associated data from the Assign diagram element, assign a
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value to a parameter at any time, and add the parameter to a flow variable or
global variable.

2.6.3.10.32 Transfer (Expired and Not Recommended)

This diagram element is used to transfer a call from the current flow to another
channel, such as an agent, a third party, or an intelligent IVR. After the call is
successfully transferred, the Call Ending diagram element needs to be connected.

NO TICE

If an agent clicks  on the connection bar and transfers a call to an IVR flow in
hang-up transfer mode, the IVR flow cannot use the Transfer diagram element to
further transfer the call to another device. The call transfer to another device will
fail.

Diagram Element

Parameter Description
The following figure shows the parameters of the Transfer diagram element.
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Figure 2-320 Transfer to Skill Queue
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Figure 2-321 Transfer to Third Party

Figure 2-322 Recording File
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Figure 2-323 Transfer to Intelligent IVR
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Figure 2-324 Transfer to Agent
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Figure 2-325 Audio and video familiar customers

The parameters are described as follows:

● Node Name: Enter a diagram element name. The value can be customized.
● Transfer Configuration: This area displays parameters for transferring a call

from the current flow. The following transfer methods are available:
– Transfer to Skill Queue: The system transfers a call from the current

flow to an agent. If this method is selected, you need to select an agent
from the Select Skill Queue drop-down list. You can also enter a self-
defined parameter. The available skill queues are configured on the
Configuration Center > Employee Center > Skill Queue page of the
tenant. When a video call is transferred, select an agent that supports the
video function.
The customized parameter must be in FLOW.Parameter name format, for
example, FLOW.IDNumber. It must also be defined as a flow parameter.
Otherwise, the parameter is meaningless. The value of the customized
parameter is the latest one used before the transfer diagram element in
the flow. If the parameter value is not reassigned in the flow, the initial
value is used.
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For example, if a customer enters the value of FLOW.IDNumber in the
voice playback and digit collection diagram element, which is executed
before the Transfer diagram element, the parameter value to be
transferred in the Transfer diagram element is the latest one entered by
the customer. Otherwise, the initial parameter value is used.
Click the text box. In the dialog box that is displayed, select a global
variable or flow variable as required. The system saves the recording file
name using a variable of the string type. Therefore, you can select only a
variable of the string type.

– Transfer to Third Party: The system transfers a call from the current flow
to a third party. If this method is selected, you need to set Forwarding
number (mandatory) and Calling Number (optional). The forwarding
number can be a mobile phone number, fixed-line phone number, or
customized parameter. The calling number must be an access code
allocated by the system or a customized parameter. When Transfer to
Third Party is selected, you can select Recording. If Recording is
selected, the dialogs between the user and the third party are recorded
and saved, and the recording file name is saved to a variable of the string
type. During recording, an announcement is played to notify the user that
the conversation between the user and the third party will be recorded.
The announcement can be configured in Voice or TTS mode. The variable
for saving the recording service node ID is used in the call center pool
mode.

– Transfer to Intelligent IVR: The system transfers a call from the current
flow to an intelligent IVR flow. Select an IVR flow from the drop-down
list. The intelligent IVR flow is published on the OIAP.

– Transfer to Agent: The system transfers a call from the current flow to a
specific agent. If this method is selected, you need to enter the ID of the
agent to whom the call is transferred. The ${FLOW.workNo} flow
variable is supported.

– Transfer to last agent: The system transfers a call from the current flow
to the last agent. The last agent refers to the agent who has a call with a
customer number recently within a period. Enter a customer number in
the Calling Number text box. The ${SYS.callingNumber} system
variable is supported. You can set Last Agent Mode to Time range or
Current day.

▪ Time range: Enter an integer ranging from 1 to 10080. For example,
if you enter 100, the call is transferred to the last agent contacted in
100 minutes.

▪ Current day: Select a time zone. The call is transferred to the last
agent who is contacted on the current day in the specified time zone.

Specify Channel Access Code: Select this check box to prevent
transferring to an incorrect last agent when routing to the last agent is
enabled for multiple channels.

● Parameter Configuration: This area is used to configure parameters to be
carried when a call is transferred to a skill queue, an intelligent IVR, an agent,
or the last agent. A maximum of 16 parameters are allowed. Such parameters
are used to carry remarks, which do not affect the flow logic.
– Transfer Parameters: Enter the name of a parameter to be transferred,

which is optional.
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– Value: Enter a parameter value, which is optional.

NO TE

The call-associated data consists of the transferred parameter, parameter value,
and IVR type, which contains a maximum of 4000 bytes. The JSON format is
supported. An example is as follows:
{"data":{"xx": "aaa" , "yy":"bbb"}, "ivrType": "0"}
To obtain the customer type field, set the transferred parameter to
customerEntityName and set the parameter value to account or contact.

– Click New to add a parameter record. The value of Transfer Parameters
must be unique in each record.

– Click Delete to delete the current record.
● Click Save to save all parameters set on the current page.

Typical Application Scenario
A voice call needs to be transferred from the current flow to a skill queue or third
party.

2.6.3.10.33 Interface Invocation (Expired and Not Recommended)

This diagram element is used to invoke a configured interface of a tenant. During
interface invocation, you can assign values to the input and output parameters of
the interface as required.

Diagram Element

Parameter Description
The following figure shows the parameters of the Invoke Interface diagram
element.
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The parameters are described as follows:

● Node Name: Enter a diagram element name. The value can be customized.
● Select Interface: Select an interface name from the drop-down list box. The

interfaces that can be selected have been configured for the current tenant.
For details about the interface configuration, see 2.6.2.2.2 Adding Business
Interfaces.
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● Input Parameter: This area displays the input parameters of the selected
interface. When there are specific input parameters, constants and variables
can be combined, for example, id ${FLOW.ID}. You can also assign values to
input parameters. The values can be constants and variables. Note that the
input variables such as FLOW.ID must be defined in the system.

● Output Parameter: This area displays the output parameters of the selected
interface. If there are specific output parameters, you can assign values to the
output parameters as required. You can associate FLOW or GLOBAL variables.
When the value is obtained from the interface, JSON data nesting is
supported. The value is obtained in the result.name result.id format.

● Click Save to save all parameters set on the current page.

Typical Application Scenario
This diagram element is used to invoke an interface.

2.6.4 Configuring the Preconfiguration Intelligent Flows

2.6.4.1 Importing Flows
By default, no flow exists for intelligent information matching after a tenant is
created. If a tenant subscribes to the intelligent information matching service,
operations personnel need to provide related flows for the tenant administrator to
import. After the tenant administrator slightly configures or modifies the flows,
functions such as intelligent knowledge recommendation can be implemented.

Flow packages are released with the AICC installation package and archived in the
AICC_*.*.*_ODFS.zip/flowinfo directory in the installation package.

NO TE

*.*.* indicates the AICC version number.

● Agent assistant package
This package is used in the intelligent agent assistant scenario to improve the
ODFS flow of the agent assistant in the baseline version. The following
information is added to the returned information in real time: speaking speed,
silence and interruption information, sensitive words and categories, real-time
notification of script violations (based on the configured real-time inspection
rules), and emotion recognition.

● Information matching package
This package is used in the intelligent agent assistant scenario to check
forbidden words based on the quasi-real-time interaction records between
agents and customers, send script reminders, and recommend content.
This package is used in earlier versions. For versions later than 8.13.0, use the
agent assistant flow package.

● multiCellFLow.zip
This package contains preconfigured composite diagram elements and is used
in the Q&A scenario. Q&As and answer branch processing in typical outbound
calls are supported. If a subscriber enters incorrect questions for three
consecutive times on the chatbot page, the system displays a message
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indicating that the number of attempts reaches the upper limit, and the chat
text box is unavailable. This package is used in test outbound call Q&A flows
and simple flows with common exception composite diagram elements.

● Satisfaction feedback package
This package is used for customer satisfaction feedback on chatbot replies.
Satisfaction feedback is required for Q&A-based replies, knowledge graph-
based replies, and final replies in multiple rounds of dialogs.

● IVR test flow package
This package is used to test IVR digit collection and voice playing.

● IVR test flow intention package
This package contains intention data required by IVR test flows and is used
together with the IVR test flow package.

● Intelligent revisit package
This package is used for robots to make outbound calls to users for
conducting satisfaction surveys after businesses are handled for the users.

● RPA intelligent case modification flow package
This package is used for RPA robots to intelligently modify or supplement case
information after agents create cases.

● Intelligent training package
This package is used in the intelligent agent training scenario.

● RBT intention recognition package
● Package of address and person entities

NO TICE

A tenant administrator can contact O&M personnel to import the preceding flows
or obtain them from O&M personnel. Perform the following steps to import the
flows.

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Chatbot Management > Flow Configuration > Flow > Orchestration, and click

.

Step 2 In the dialog box that is displayed, click , select the flow package
that needs to be imported, for example, the information matching package, and

click .

----End

2.6.4.2 Configuring the Intelligent Agent Assistant
To implement the intelligent agent assistant function, perform related
configurations on the Intelligent IVR page.
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2.6.4.2.1 Overall Configuration

This section describes the overall process of configuring the intelligent agent
assistant.

Step 1 Import and release the baseline flow.

1. Choose Configuration Center > Chatbot Management > Flow
Configuration.

2. On the Flow Configuration page, choose Flow > Orchestration and click

. In the dialog box that is displayed, click  to select the
archived flow package ODFS_flow***.zip and click Upload.

3. Configure the preconfigured intelligent agent assistant flow. For details, see
2.6.4.2.5 Configuring the Intelligent Agent Assistant Flow.

4. Click Release.

Step 2 Create a flow access code.

1. Choose Intelligent Chatbot.

2. Click  to add an intelligent robot. Set Dialog Type and Flow
Name to Voice navigation and the published baseline flow, respectively.

Step 3 Configure a flow access code. Sign in to the AICC and choose Configuration
Center > System Management > Tenant Information. On the Tenant
Information page, enable Intelligent Recognition and Intelligent Agent
Assistant, select a robot assistant, and save the settings. The robot assistant name
is the same as the value of Chatbot Name configured in Step 2.

----End

2.6.4.2.2 Scripts

To use the intention and script recommendation functions of the intelligent agent
assistant, perform the following operations.

Step 1 Configure a domain. Choose Configuration Center > Chatbot Management >
Semantic Understanding > Knowledge Management > Domain Management
and click Create to create a domain.

Step 2 Add an intention. Choose Knowledge Management > Intention Management
and create intentions and scripts as intentions.

For example, in the intention of a loss report, the script may be "your ID card
number" or "your mobile number". Therefore, create three intentions at a time.

1. Click Create to create a general intention. On the Basic Info tab page, set
Name to the name of a script or intention displayed on the GUI.
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2. Click the Corpus tab. Corpus indicates the keywords for recognition. Click
Create to create a corpus. For example, set the corpus for the loss report to
Loss Report.

3. Click the Response tab to set an intention command. The intent command
must be unique. Click Create to create a response.

4. After configuring the Loss Report, Your Mobile Number, and Your ID Card
Number intentions, click Train to train the robot.

Step 3 Configure a resource template.

1. Choose Resource > Resource Template and click New to add a resource
template. Set Type to TTS. Enable Configure Intention Template.

2. Click Add Top Node and set the configured Loss Report intention to the top
node.

3. Click Add on the right of the Loss Report intention, set the Your Mobile
Number intention to the lower-level node, and save the settings.

4. Set the Your ID Card Number intention to the lower-level node in a similar
way and save the settings.

Step 4 Configure a greeting. Greetings are preconfigured in the baseline flow. To
customize greetings, modify GreetingWord in the resource template. For details
about how to set other TTS texts to greetings, see Greeting Resource Templates.
To match a greeting, create an intention on the Intention Management page. It
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is recommended that the name and keyword of the intention be the same as
those of the greeting. The intention command must be set to GreetingWord.

For details about how to add an intention, see Step 2.

----End

2.6.4.2.3 Q&As

To use the FAQ recommendation function of the intelligent agent assistant,
configure Q&As in the intelligent IVR.

Step 1 Choose Knowledge Management > FAQ Management and click  to
create an FAQ group. Multiple Q&A pairs can be created in an FAQ group.

NO TE

To use a URL, set Description in the markdown format ([Description](https://url), for
example, [Baidu](https://www.baidu.com)).

Step 2 After the configuration is complete, return to the Intention Management page
and click Active to activate the intention.

----End

2.6.4.2.4 Sensitive Words

To use the sensitive word prompt function of the intelligent agent assistant, create
sensitive words on the Intelligent IVR page.

Step 1 Choose Knowledge Management > Entity Management and click the
SENSITIVE WORD tab.

Step 2 Click Add to create a sensitive word category. You can configure multiple sensitive
word categories based on the site requirements.

Step 3 Click Add on the right to create a sensitive word. For example, create a forbidden
word category, and then create a password under the category as a forbidden
word.

----End
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2.6.4.2.5 Configuring the Intelligent Agent Assistant Flow

The following figure shows the preconfigured intelligent agent assistant flow.

This flow implements the following functions:

1. The Greeting response diagram element plays the greeting to the customer.
Customize the voice files in Chinese and English.

2. The Interface Invoking diagram element at position 1 separates the texts
sent by the client by spaces based on the interaction records, and records
whether the texts are sent by the customer or agent.

3. The diagram element at point 3 performs real-time inspection on
conversations based on the interaction records.

4. The Semantic Recognition diagram element identifies the interaction
information as follows:
– If sensitive words exist, the sensitive word prompt is triggered. The

Interface Invoking diagram element at point 4 assigns the sensitive
words to flow variables.

– If no sensitive word exists and the intention is matched, the Interface
Invoking diagram element at point 5 is entered, and the matched
intention name is used to invoke the Q&A interface to obtain a
recommended reply.

– If an error such as timeout or unknown intention occurs, the Interface
Invoking diagram element at point 2 is invoked. The interaction
information is directly used to invoke the Q&A interface to obtain a
recommended reply.

5. The response diagram element returns the recommended replies and sensitive
words.
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6. If the reply is sent to a customer, the sensitive words are empty. If the reply is
sent to an agent, the sensitive words are not empty and the next cycle starts.

Modify the greeting voice templates and invoke the specific recommendation and
knowledge obtaining interfaces in an Interface Invoking diagram element to
implement the intelligent agent assistant function.

Greeting Resource Templates

Resource templates in the first response of the intelligent agent assistant flow can
be configured and modified by the customer or preconfigured by the business
personnel based on the customer requirements.

Step 1 Choose Flow > Orchestration and click Edit corresponding to the agent assistant
flow.

Step 2 Click the first response diagram element to view the response template name on
the right.

Step 3 Choose Resource > Resource Template.

Step 4 Click Edit next to the template described in Step 2.

Step 5 On the Edit Template page, modify the template as required and click Confirm.

----End

2.6.4.3 Configuring the Intelligent Information Matching Flow
The following figure shows the preconfigured intelligent information matching
flow.

This flow implements the following functions:
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1. The response diagram element plays the greeting to the customer. Customize
the voice files.

2. The Interface Invoking diagram element at position 1 separates the texts
sent by the client by spaces based on the interaction records, and records
whether the texts are sent by the customer or agent.

3. The Semantic Recognition diagram element identifies the interaction
information as follows:
– If sensitive words exist, the sensitive word prompt is triggered. The

Interface Invoking diagram element at point 3 assigns the sensitive
words to flow variables.

– If no sensitive word exists and the intention is matched, the Interface
Invoking diagram element at point 4 is entered, and the matched
intention name is used to invoke the Q&A interface to obtain a
recommended reply.

– If an error such as timeout or unknown intention occurs, the Interface
Invoking diagram element at point 2 is invoked. The interaction
information is directly used to invoke the Q&A interface to obtain a
recommended reply.

4. The response diagram element returns the recommended replies and sensitive
words.

5. After a reply is triggered, the sensitive words are empty and the next cycle
starts.

Modify the greeting voice templates and invoke the specific recommendation and
knowledge obtaining interfaces in an Interface Invoking diagram element to
implement the information matching function.

2.6.4.3.1 Greeting Resource Templates

Resource templates in the first response of the information matching flow can be
configured and modified by the customer or preconfigured by the business
personnel based on the customer requirements.

Step 1 Choose Flow Management > Flow Orchestration and click  next to the
information matching flow.

Step 2 Click the first response diagram element to view the response template name on
the right.

Step 3 Choose Resource Management > Resource Template.

Step 4 Click Edit next to the template described in Step 2.

Step 5 On the Edit Template page, modify the template as required and click Confirm.

----End

2.6.4.3.2 Interface Invoking Diagram Element

The information matching flow supports user-defined modification and update of
invoked diagram element types and settings based on business requirements.

Step 1 Choose Flow > Orchestration and click Edit next to the information matching
flow.
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Step 2 Click the Interface Invoking diagram element and set Select Interface on the
right to implement the knowledge or script recommendation function.

NO TE

Modify the configuration based on site requirements.

To configure the knowledge base for a customer, invoke the corresponding interface. If no
interface is required, the cache parameter recommand is not invoked, but the attribute
name in the response must be set to a fixed character string. This step can be performed by
the customer or preconfigured by the business personnel by using interface parameters.

Perform operations based on site requirements. To configure a business interface, choose
Resource > Business Interface. For details, see "Adding Business Interfaces" in 20-AICC IVR
Flow Configuration Guide.

----End

2.6.4.3.3 Response Templates Returned to the Semantic Recognition Invoker

Response templates can be configured by the customer or configured by the
business personnel based on the customer requirements. After a template is
configured, the backend automatically reads the parameter information.

The JSON format of the response template PromptText in the second response
diagram element in the information matching flow is fixed. Ensure that the
referenced parameter name is the same as the variable name defined in the flow.

Step 1 Choose Flow Management > Flow Orchestration and click  next to the
information matching flow.

Step 2 Click the Response diagram element in the lower part to view the response
template name.

Step 3 Choose Resource Management > Resource Template.

Step 4 Click Edit next to the template described in Step 2.

Step 5 On the Edit Template page, modify the JSON content as required. Ensure that the
parameter names in the JSON file are the same as the variable names defined in
the information matching flow.

----End

2.6.4.4 Configuring the Satisfaction Feedback Flow

In a call test, the GUI and flow orchestration are used to implement the
satisfaction feedback function.

During flow orchestration, determine the businesses for which satisfaction
feedback is required. Generally, satisfaction feedback is not required for chat
sessions, auxiliary sessions, slotted sessions, and clarification sessions. It is required
for Q&A-based replies, knowledge graph replies, and final replies in multiple
rounds of dialogs.

The following figure shows the preconfigured satisfaction feedback flow.
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Step 1 Return the needFeedBackResponse response template in the branch that requires
feedback. The data structure in the response template must be the same as that
agreed by the frontend.

The response template needFeedBackResponse provides the result to be returned
for the current business and the reason for dissatisfaction. The frontend parses the
result for display.

Step 2 Check the user input. If the value of IVRREQUEST.feedback is 0 or 1, the user is
satisfied and the satisfaction feedback enters the feedback branch.
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Step 3 Check whether the feedback branch invokes the CallFeedBack interface provided
by the TUC.

Step 4 Check the configuration of the satisfaction feedback interface in the following
figure.

----End

2.6.4.5 Releasing Flows and Testing Calls

This section describes how to release a flow and how to test the released flow.
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2.6.4.5.1 Flows

After a flow is imported, it is in Invalidate state. The flow can be used only after it
is successfully released. The call test can be performed only after the configuration
takes effect.

Step 1 Choose Flow Management > Flow Orchestration.

Step 2 Click  next to a flow to release the flow for it to take effect.

----End

2.6.4.5.2 Call Tests

You can test the configured chatbot to determine whether the configuration is
correct.

Step 1 Choose Chatbot Management.

Step 2 Click Add to add an access code. Set required information, select the flow to be
tested, and click Confirm.

Step 3 Click Test Call in the last column of the desired access code.

Step 4 In the dialog box that is displayed, enter the information to perform the test.

----End

2.6.5 Large Language Model Service Zone

2.6.5.1 LLM-based Application Services
The ODFS provides a series of intelligent tools based on large language models to
assist customer service personnel in knowledge collection, editing, and Q&A,
improving agent work efficiency and customer satisfaction.

2.6.5.1.1 Preparation

Configuring a Model

The LLM Engine provides multiple common models for users to select from based
on the actual service and budget.

Prerequisites
You have contacted the system administrator to enable the LLM Engine feature for
the tenant.

Procedure

Step 1 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Large Model Service > System Management >
Model Management, and bind a model.
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Step 2 On the Large Model tab, click . The Adding a Model page is displayed.

Figure 2-326 Adding a model

Parameter Description

Name This parameter is user-defined. It is recommended that this
parameter be related to the model type for future use.

Type Select a model based on the actual service.

Version Large language model version which is set as required.

Using azure_openai as an example

api_base URL for requesting a large model.

api_key ● Function: api_key is a key used for identity authentication. It
needs to be provided each time a request is sent to the OpenAI
API. This is the key to ensuring that only authorized users can
access the API service.

● Obtaining method: To obtain the value of api_key, you need to
register with the OpenAI official website and create an
account. After you create an account and log in to the system,
you can find your API key on the OpenAI user console.

● Security: api_key is sensitive information and must be kept
properly. Do not expose your API key in public code libraries or
client codes to prevent unnecessary fees and security risks.
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Parameter Description

api_version ● Function: api_version allows users to specify the version to be
used through an API request. This is especially important when
the API is updated, because a new version may introduce new
functions or change existing functions. If you want to use an
API of a specific version or ensure backward compatibility, set
api_version.

● Obtaining method: The API version information can be found in
the official documents or release notes of OpenAI. The API
version may be displayed in the URL of the API or the specific
version information may be provided in the API document.

● Setting method: In some API client libraries or invocations, you
may need to specify the API version in the request
configuration. For example, you may set the version number in
the request URL or request header, or set api_version in the
configuration of some libraries.

deploymen
t_id

● Function: deployment_id is used to specify a specific model
deployment instance. This parameter is used to select a specific
deployment for API invocation when multiple models or
versions are deployed.

● Model management: During model management and O&M,
deployment_id allows users to control and reference different
model deployments. This is very important for managing
multiple model versions or performing A/B testing of models in
the PR environment.

 

Step 3 Click Save. The large model is created successfully.

----End

2.6.5.1.2 LLM-based Agent Assistant

The agent assistant is a function that assists agents in serving customers based on
the large language model (LLM). It provides operation support for the services of
the voice and video workbench and online chat workbench, including sentiment
analysis and knowledge search.

Selecting a Model Type.

The following model types of the agent assistant are supported: Large Model,
Combined Model, and Small Model, of which capabilities are in descending
order. You can select a model based on cost and service requirements.

Prerequisites
You have contacted the system administrator to enable the LLM Engine feature for
the tenant.
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Procedure

Step 1 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Flow Configuration > System > System Settings, and
click the System Settings tab.

Step 2 Enter EMOTIONRECOGNITIONWORKFLOWPARAMS in the search box and click

 to view the parameter.

Step 3 Click Edit on the right of the parameter and select a model type.

Figure 2-327 Edit Sentiment Analysis Workflow Parameters page

● Model Type: Options are Large Model, Small Model, and Combined Model.
A large language model has powerful sentiment analysis capabilities, but its
cost is higher than that of a small language model. Select a model based on
actual requirements.

● Confidence Threshold: Retain the default value.

Step 4 Click Save.

----End

Configuring Information on the LLM Engine

Prompt templates help a model narrow down the text generation scope,
preventing generation of texts that differ greatly from expected content. For
example, if the template content theme is sport, the model generates sports game
content. The AICC provides preset prompt templates. This section describes how to
download and import a prompt template.

Prerequisites
Contact the system administrator to sign in to the AICC, choose Call Center >
Tenant Management, enable the LLM Engine feature for the tenant space, and
select Sentiment analysis, Q&A retrieval, and Intent recognition.
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Procedure

Step 1 Contact Huawei technical support to download the AICC_*.*.*_ODFS.zip package
from https://support.huawei.com.

Step 2 Decompress the AICC_*.*.*_ODFS.zip package.

NO TE

*.*.* indicates the AICC version number.

Step 3 Go to the /flowinfo/LLM_Agent_Assistant.zip/ directory to obtain the
workflow.zip package.

Step 4 Decompress the workflow.zip package.

Step 5 Obtain the emotionRecognition.tar.gz package.

Step 6 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Large Model Service > Workflow Management >
Workflow Orchestration, and click the import button to import the
emotionRecognition.tar.gz package.

Step 7 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Large Model Service > Large Model Zone > Prompt
Template, and click the Customized Template tab.

Step 8 Click the emotion scenario, edit the emotion prompt template, and select an
available model from the Large Model drop-down list. For details about how to
configure a model, see Configuring a Model.

Figure 2-328 Large model drop-down list

Step 9 Click Save and Publish to publish the prompt template.

Step 10 Obtain the intentRecognition.tar.gz package.

Step 11 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Large Model Service > Workflow Management >
Workflow Orchestration, and click the import button to import the
intentRecognition.tar.gz package.
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Step 12 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Large Model Service > Large Model Zone > Prompt
Template, and click the Customized Template tab.

Step 13 Click the Intent recognition scenario and click the Intent recognition prompt
template. On the Template Details page that is displayed, click Unpublish to
change the status of the template to Not released.

Step 14 Edit the Intent recognition prompt template and select an available model from
the Large Model drop-down list. Configure the model by referring to Configuring
a Model.

Figure 2-329 Large model drop-down list

Step 15 On the Editing a template page, turn on  to enable model parameters,
and set response_format to json_object.

Figure 2-330 Enabling model parameters

Step 16 Click Save and Publish to publish the prompt template.

Step 17 Obtain the recommendFaq.tar.gz package.
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Step 18 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Large Model Service > Workflow Management >
Workflow Orchestration, and click the import button to import the
recommendFaq.tar.gz package.

----End

Configuring Information on the ODFS

This section describes how to import a flow to create an intelligent robot.

Prerequisites
Contact the system administrator to sign in to the AICC, choose Call Center >
Tenant Management, and enable the Intelligent IVR feature for the tenant
space.

Procedure

Step 1 Contact Huawei technical support to download the AICC_*.*.*_ODFS.zip package
from https://support.huawei.com.

Step 2 Decompress the AICC_*.*.*_ODFS.zip package.

NO TE

*.*.* indicates the AICC version number.

Step 3 Go to the /flowinfo/LLM_Agent_Assistant.zip/ directory to obtain the
LLM_Agent_Assistant_FLOW.zip package.

Step 4 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Chatbot Management > Flow Configuration.

Step 5 Choose Flow Management > Flow Orchestration, click , import
LLM_Agent_Assistant_FLOW.zip, check the imported flow, and publish the flow.

Step 6 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 7 Click Intelligent Chatbot. Click Create to create a robot, as shown in the
following figure.
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Figure 2-331 Create Chatbot page

Dialog Type: Voice navigation

Flow Name: Select the flow created in step Step 5.

Step 8 Click Save. The intelligent robot is created successfully.

----End

Configuring Information on the TUC

This section describes how to create intents, FAQs, and sensitive words.

Prerequisites
None

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Chatbot Management > Semantic Understanding > Knowledge Management
> Domain Management, and click Create to create a domain.
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Figure 2-332 Domain management

Step 2 Choose Configuration Center > Chatbot Management > Semantic
Understanding > Knowledge Management > Intention Management.
Configure, activate, and train an intent, as shown in the following figure.

Figure 2-333 Selecting a domain

Figure 2-334 Configuring an intent - Basic Information
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Figure 2-335 Configuring an intent - Corpus

Figure 2-336 Configuring an intent - Response

Step 3 Choose Configuration Center > ChatBot Management > Semantic
Understanding > Knowledge Management > Entity Management > Sensitive
Word and configure sensitive words.

Figure 2-337 Configuring sensitive words

Step 4 Choose Configuration Center > ChatBot Management > Semantic
Understanding > Knowledge Management > FAQ Management and configure
FAQs. Activate and train the corresponding FAQs after the configuration is
complete.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 725



Figure 2-338 Creating FAQs

Figure 2-339 Adding Q&As

----End

Configuring Information on the Workbench

This section describes how to bind an agent assistant on the workbench.

Prerequisites
● You have contacted the system administrator to enable the intelligent agent

feature for the tenant space.
● The system administrator has commissioned the intelligent transcription

function and intelligent agent assistant. Note that the optional operations
related to the intelligent agent assistant also need to be performed.

● The system administrator has commissioned the manual voice service.
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● To use the LODAS sentiment analysis model, you have commissioned the
sentiment analysis function. For details, see "Commissioning the Sentiment
Analysis Model Function" in OIAP Product Documentation.

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Employee Center > Agent Management, and enable the intelligent recognition
feature for agents.

Figure 2-340 Enabling the Intelligent Recognition feature

Step 2 Sign in to the AICC as a tenant administrator, choose Configuration Center >
System Management > Tenant Information, and enable Intelligent Recognition
and Intelligent Agent Assistant features. Bind the robot assistant to the
intelligent robot created in Step 8.

Figure 2-341 Binding an intelligent robot

Step 3 Choose Configuration Center > Access Configuration > Channel Configuration,
and click New to bind the intelligent robot created in Step 8 to the robot assistant
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in Access Robot Assistant on the Configure Channel page that is displayed
before the online workbench function can be used.

Figure 2-342 Channel configuration page

----End

Verification

Verifying the agent assistant function by referring to this section.

Prerequisites
None

Procedure

Step 1 The agent accesses the audio and video workbench and clicks  on the right
if the voice call mode is selected. If the question reported by the customer
matches a keyword in Intention Management and FAQ Management on the
TUC configured in Configuring Information on the TUC, the corresponding script

recommendation and FAQ recommendation are generated. Click  to view
the transcription result, agent's sentiment analysis result, and customer emotion.

Step 2 The agent accesses the online chat workbench and clicks  on the right to
view the customer emotion, intent, script recommendation, and FAQ
recommendation if the multimedia chat mode is selected. If an agent enters
sensitive words or content with negative emotions, the corresponding prompt is
displayed and the content cannot be sent to the customer.
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Figure 2-343 FAQ recommendation

Figure 2-344 Script recommendation

Figure 2-345 Negative emotion
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Figure 2-346 Sensitive word

----End

2.6.5.1.3 Building the LLM-based Intelligent Case Filling Service

Intelligent case filling uses the LLM technology to automatically extract
information from the texts of conversations between customers and agents as
well as quickly and accurately fill the information in the corresponding case form,
reducing the pressure of manual case filling.

Prerequisites
● The LLM Engine, Intelligent order filling, Case 2.0, AppCube, Customer

Center, and Intelligent Agent (the number of intelligent agents is greater
than 0) features have been enabled for the tenant space, and the Case type
identification and Case field identification services have been selected for
the LLM Engine feature.

● The tenant parameter Intelligent order filling has been enabled for the
tenant space on the Configuration Center > System Management > Tenant
Parameter page.

● The tenant space administrator has enabled the Smart Form Filling feature
for agents on the Configuration Center > Employee Center > Agent
Management page.

Configuring Information on the LLM Engine

The case type identification and case field identification features included in the
intelligent case feature based on large language models are implemented by
invoking workflows of the LLM Engine. This section describes how to create the
workflow and prompt templates.

Procedure

Step 1 Contact Huawei technical support to download the AICC_*.*.*_ODFS.zip package
from https://support.huawei.com.

Step 2 Decompress the AICC_*.*.*_ODFS.zip package.
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NO TE

*.*.* indicates the AICC version number.

Step 3 Go to the /flowinfo/LLM_Agent_Assistant.zip/ directory to obtain the
workflow.zip package.

Step 4 Decompress the workflow.zip package.

Step 5 Obtain the caseTypeClassificationAICC.tar.gz package.

Step 6 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Large Model Service > Workflow Management >
Workflow Orchestration, and click the import button to import the
caseTypeClassificationAICC.tar.gz package.

Figure 2-347 Workflow import success page

Step 7 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Large Model Service > Large Model Zone > Prompt
Template, and click the Customized Template tab.

Step 8 Click the Intelligent order filling scenario, edit the Work order type
identification prompt template, and select an available large model from the
Large Model drop-down list. For details about how to configure a model, see
Configuring a Model.

Step 9 Click Save and Publish to publish the prompt template.

Step 10 Obtain the caseFieldExtractionAICC.tar.gz package from the workflow.zip
package in step Step 4.

Step 11 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Foundation Model Service > Workflow
Management > Workflow Orchestration, and click the import button to import
the caseFieldExtractionAICC.tar.gz package.

Step 12 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Large Model Service > Large Model Zone > Prompt
Template, and click the Customized Template tab.

Step 13 Click the Intelligent order filling scenario, edit the Work order field extraction
prompt template, and select an available large model from the Large Model
drop-down list. For details about how to configure a model, see Configuring a
Model.
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Step 14 Click Save and Publish to publish the prompt template.

----End

Configuring Case 2.0 Information

?.1. Customized Case Field

An enterprise can flexibly set fields based on the business scenario.

Prerequisites
● The Case 2.0 feature has been enabled for the tenant space.
● You have the Case Configuration permission.

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Case Configuration 2.0 >
Case Configuration > Case Field.

Step 2 Click Create. In the Create dialog box, set field parameters as required.

Figure 2-348 Create

Step 3 Click .

Step 4 (Follow-up operation) Choose Case Configuration > Case Template and click
Config corresponding to a template. The new field is displayed under Custom
Field. Drag the field to the Container area so that it is referenced by the template.
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Figure 2-349 Configure Case Template

----End

?.2. Case Template

A case template contains the information to be collected from cases and the
display format of the information, including the format of the page displayed
during case creation, modification, or query. You can define the fields to be
displayed in the case template and the layout of the fields.

Prerequisites
● The case 2.0 feature has been enabled for the tenant space.
● You have the Case Configuration permission.

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Case Configuration 2.0 >
Case Configuration > Case Template.

Figure 2-350 Case Template

Step 2 Click Create. On the Create page, enter a template name and template
description, and click Save.
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Step 3 Click Config corresponding to the new template to access the view page and add
content. If a customized field is set as a mandatory field, you must add the
customized field to the create view.

Figure 2-351 View page

Step 4 Click  to save the content and click  to preview the content.

NO TE

Save the content after adding a field to the create view to prevent the content from being
lost. For example, after adding field A to the edit view, if you do not save the content
before previewing it, field A will be lost.
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Step 5 (Follow-up operation) Enable a case template so that you can reference it when
configuring a case content template and synchronize it to the Metadata
Management page.

Figure 2-352 Synchronizing a case template to the Metadata Management page

----End

?.3. Case Type

To differentiate businesses, you can classify cases into different types, such as
complaint or consultation cases. Different types of cases can be associated with
different statuses to meet business requirements.

Procedure

Step 1 Sign in to the AICC, choose Configuration Center > Case Configuration 2.0 >

Case Configuration > Case Type, and click .

Figure 2-353 Create

Step 2 On the Create page, enter case type information and click Save.
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Table 2-141 Case type parameters

Parameter Description

Case Type Name Enter a case type name, for example, Complaint.

Case Type Description Enter a case type description, for example,
Complaint content, Complaint target, or
Complaint source.

Cascader Select an upper-level case type.

Case Template Select a value from the drop-down list.

Case Context Template Associate a case content template.

Case Process Add case statuses.

Strictly Follow the Status
Sequence

Enable or disable this function. If this function is
enabled, the case can only be handled step by
step. If disabled, the case status can be
transitioned to any status as required.

Verify task status Enable or disable this function. If this function is
enabled, the status of the associated tasks is
verified when the case is closed. If disabled, the
status of the associated tasks is not verified.

 

Step 3 After the case type is created, you can switch its status to  to enable it. You
can select only an enabled case type when creating a case on the Case 2.0 > Case
Workbench page.

Figure 2-354 Enabling a case type

Step 4 After a case type is enabled, synchronize it to the Metadata Management page.
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Figure 2-355 Metadata Management

Step 5 If the case type has not been referenced, you can switch its status to  to
disable the case type. After the case type is disabled, you can edit or delete the
case type.

----End

Configuring Information on the ODFS

On the Metadata Management page, prompt words are added to service fields
so that large language models can better understand services and accurately
extract key fields. The metadata comes from the case types under Configuration
Center > Case Configuration > Case Type and the case fields under
Configuration Center > Case Configuration > Case Template.

Prerequisites
● The LLM Engine, Intelligent order filling, Case 2.0, AppCube, Customer

Center, and Intelligent Agent (the number of intelligent agents is greater
than 0) features have been enabled for the tenant space, and the Case type
identification and Case field identification services have been selected for
the LLM Engine feature.

● The tenant parameter Intelligent order filling has been enabled for the
tenant space on the Configuration Center > System Management > Tenant
Parameter page.

● The tenant space administrator has enabled the Smart Form Filling feature
for agents on the Configuration Center > Employee Center > Agent
Management page.

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Chatbot Management > Flow Configuration > System > Metadata
Management. The Metadata Management page is displayed.
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Figure 2-356 Metadata management page

Step 2 (Optional) Synchronize historical data in the case system to the AICC if the case
system has been running before the large language model feature is enabled for
the tenant space. Click Synchronize to synchronize the enabled existing case types
and templates in the case system to the ODFS database.

Step 3 Select a data record and click Edit. The metadata editing page is displayed.

Figure 2-357 Metadata editing page

Step 4 Click the prompt word description to be modified, modify the description, and click
Save. The modified prompt word description is synchronized to the LLM Engine.
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Figure 2-358 Editing prompt word description

----End

Verification

Both the Online Chat and Call workbenches support the intelligent case filling
function.

Prerequisites
● The LLM Engine, Intelligent order filling, Case 2.0, AppCube, Customer

Center, and Intelligent Agent (the number of intelligent agents is greater
than 0) features have been enabled for the tenant space, and the Case type
identification and Case field identification services have been selected for
the LLM Engine feature.

● The tenant parameter Intelligent order filling has been enabled for the
tenant space on the Configuration Center > System Management > Tenant
Parameter page.

● The tenant space administrator has enabled the Smart Form Filling feature
for agents on the Configuration Center > Employee Center > Agent
Management page.

Procedure

Step 1 Sign in to the AICC as an agent and click Sign In.

Step 2 Click  in the upper right corner on the online workbench. The Select Work
Case Type drop-down list is displayed.
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Figure 2-359 Smart form filling button

Step 3 Select a case type to display the case information on the right. In addition, the
system automatically obtains the customer name, address, contact information,
and fault description based on the dialog content and adds them to the case
information on the right.

Step 4 Click Save. The case is saved successfully.

Step 5 Choose Case 2.0 > Case Workbench and view the intelligent case created on the
workbench.

NO TE

Currently, the case system supports only Chinese, English, and Spanish.

----End

2.6.5.1.4 Mining the FAQ Knowledge Base Based on a Large Language Model

Large language models can be used to upload documents to the knowledge base
and extract Q&A pairs from the documents. After being reviewed and edited, the
Q&A pairs can be directly used for Q&A management of the semantic
understanding service.

Configuring Information on the LLM Engine

Prerequisites

Contact the system administrator to sign in to the AICC, choose Call Center >
Tenant Management, and enable the LLM Engine and FAQ-assisted mining
features for the tenant space.

Procedure

Step 1 Sign in to the AICC as a tenant administrator.

Step 2 Choose Configuration Center > Large Model Service > Prompt Template. The
prompt template management page is displayed.
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Figure 2-360 Prompt template management page

Step 3 Choose Preset Template > question answer template and click Copy to create a
user-defined template.

Figure 2-361 Prompt template details page

Figure 2-362 Template creation page
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● Scene: Indicate the template application scenario. You can click 
to create a scenario.

● Template Name: Indicate the prompt template name.
● Language: Only Chinese and English are supported.
● Version: This parameter must start with letter v or V followed by at least one

digit.
● Template Content: Generate the LLM prompt template.
● content: Indicates the variable in the template content. The input content can

be submitted for assessment.
● Large Model: Select a large language model service created by the tenant.
● Model Parameters: Indicate the model parameter switch.
● Submit Review: Test the Q&A pair extraction result related to the current

content.
● Save and Publish: Save and publish the prompt template.

Step 4 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Chatbot Management > Large Model Service > Large Model Zone > Document

management. Click  to create a knowledge base.

Figure 2-363 Document management page

Step 5 Choose Document Management > Documentation Enabled and click Upload to
upload documents to the knowledge base.

Figure 2-364 Document upload page
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Step 6 After the document status changes to Read successfully, click the document
name to view the text segments.

Figure 2-365 Document details page

Step 7 Click Generate. Then the document status changes to Generated successfully.
Q&A pairs are generated based on the text segments.

Step 8 Wait for the result generation to be complete. You can edit, accept, or discard the
Q&A pairs.

Figure 2-366 Q&A result generation page

----End

Configuring Information on the TUC

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Semantic Understanding > FAQ Management > FAQ Group, and check whether
an FAQ group with the same name as the knowledge base created in step Step 8
is generated.
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Figure 2-367 FAQ management page

Step 2 Click the number in the Quantity column and check whether the Q&A pairs in the
Q&A group are the same as those used in step Step 8.

Figure 2-368 Q&A details page

Step 3 Click Inactive in the Status column to activate the FAQ group.

Step 4 Select an FAQ group, click Train in the upper right corner, and select Training
Selection.

----End

Configuring Information on the ODFS

This section describes how to configure an intelligent robot to demonstrate Q&A
group usage in the intelligent robot. Create an intelligent robot that meets the
service requirements based on the actual service scenario.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Chatbot Management > Flow Configuration.

Step 2 Choose Flow > Orchestration and click Create.

Step 3 Set the flow template to Blank Flow, enter the flow name, and click Save. The
canvas is displayed.
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Figure 2-369 Create Flow page

Step 4 Drag diagram elements to the canvas, as shown in the following figure.

Figure 2-370 Canvas

Table 2-142 Diagram element description

Diagram Element Node Attribute Remarks

- -

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 745



Diagram Element Node Attribute Remarks

● Set Reply Way to
TTS.

● Set Reply Source to
Reply Resource.

● Set Reply Mode to
Interruption
recognition.

● Variable Assignment:
FLOW.response=TOC.
ChatBotRespContent

● Condition branch:
TOC.ChatBotIntentCo
de=="systemQA"
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Diagram Element Node Attribute Remarks

● Set Reply Way to
TTS.

● Set Reply Source to
Reply Variable.

● Enter FLOW.response
in Reply Variable.
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Diagram Element Node Attribute Remarks

● Set Reply Way to
Static voice.

● Set Reply Source to
Reply Variable.

● Enter No matching
Q&A in Reply
Variable.

● Set Reply Mode to
Interruption
recognition.

- -

 

Step 5 After the flow is created, click Save and Publish to publish the flow.

Step 6 Choose Configuration Center > Chatbot Management > Flow Configuration.

Step 7 Click Intelligent Chatbot. Click Create, enter the information shown in the
following figure, and click Save to save the configuration.

Figure 2-371 Create Chatbot page

● Dialog Type: Select Chatbot.
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● Flow Name: Select the flow created in step Step 5.

Step 8 Click Save. The intelligent robot is created successfully.

Step 9 Select the created intelligent robot and click Test Call to test it. Click Start Call to
start a dialog, and enter the Q&A pairs configured in the Step 7. If the dialog is
normal, the correct result is returned, as shown in the following figure.

Figure 2-372 Intelligent robot test

----End

2.6.5.1.5 Refining Response Based on a Large Language Model

Refining response means processing reply texts for higher smoothness, accuracy,
and completeness. This process usually includes checking for grammatical and
spelling mistakes, ensuring that words are used accurately and friendly, adding
relevant information and content to provide more context, and reorganizing the
text structure to make it easier for customers to understand.

Configuring Information on the LLM Engine

Prerequisites

Contact the system administrator to sign in to the AICC, choose Call Center >
Tenant Management, and enable the LLM Engine feature for the tenant space.

Procedure

Step 1 Contact Huawei technical support to download the AICC_*.*.*_ODFS.zip package
from https://support.huawei.com.
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Step 2 Decompress the AICC_*.*.*_ODFS.zip package.

NO TE

*.*.* indicates the AICC version number.

Step 3 Go to the /flowinfo/LLM_Agent_Assistant.zip/ directory to obtain the
workflow.zip package.

Step 4 Decompress the workflow.zip package.

Step 5 Obtain the textRefine.tar.gz package.

Step 6 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Large Model Service > Workflow Management >
Workflow Orchestration, and click the import button to import the
textRefine.tar.gz package.

Figure 2-373 Import success page

Step 7 Choose Configuration Center > Chatbot Management > Large Model Service >
Large Model Zone > Prompt Template and click the Customized Template tab.

Step 8 Select the Refine response scenario and click the Refine response prompt
template. The Template Details page is displayed. Click Unpublish to change the
status of the template to Not released.

Step 9 Edit the Refine response prompt template and select an available model from the
Large Model drop-down list. For details about how to configure a model, see
Configuring a Model.

Step 10 Click Save and Publish to publish the prompt template.

----End

Verification

Prerequisites
● The LLM Engine, reply polishing, and intelligent agent features have been

enabled for the tenant.

● The agent type is versatile agent or multimedia agent.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Employee Center > Agent Management, and turn on the Intelligent
Recognition and Reply polishing switches.

Figure 2-374 Agent configuration page

Step 2 Sign in to the AICC as a multimedia agent and click  on the top to
sign in to the platform and access the online workbench.

Step 3 The agent clicks  to polish the texts during a text chat with a customer. Only
10 AI polishing operations are supported in a single session. AI polishing supports
friendly and professional styles.

Figure 2-375 Text chat workbench page

----End
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2.6.5.1.6 Summarizing Sessions Based on a Large Language Model

Based on the large language model technology, a workflow is constructed to
extract key sentences or phrases from sessions, such as customer requirements
and agent answers, generate an abstract, and record the abstract in the call
reason.

Prerequisites
● You have contacted the system administrator to enable the LLM Engine and

Automatic Conversation Summary features for the tenant.
● The intelligent transcription function has been commissioned for voice agents.

Configuring Information on the LLM Engine

The session summary function based on large language models needs to be
implemented by invoking the workflows of the LLM Engine. This section describes
how to create the workflow and prompt templates.

Prerequisites
Contact the system administrator to sign in to the AICC, choose Call Center >
Tenant Management, and enable the LLM Engine and Automatic Conversation
Summary features.

Procedure

Step 1 Contact Huawei technical support to download the AICC_*.*.*_ODFS.zip package
from https://support.huawei.com.

Step 2 Decompress the AICC_*.*.*_ODFS.zip package.

NO TE

*.*.* indicates the AICC version number.

Step 3 Go to the /flowinfo/LLM_Agent_Assistant.zip/ directory to obtain the
workflow.zip package.

Step 4 Decompress the workflow.zip package.

Step 5 Obtain the textSummary.tar.gz package.

Step 6 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Large Model Service > Workflow Management >
Workflow Orchestration, and click the import button to import the
textSummary.tar.gz package.

Step 7 Sign in to the AICC as a tenant space administrator, choose Configuration Center
> Chatbot Management > Large Model Service > Large Model Zone > Prompt
Template, and click the Customized Template tab.

Step 8 Click the Automatic Conversation Summary scenario and click the Automatic
Conversation Summary prompt template. The Template Details page is
displayed. Click Unpublish to change the status of the template to Not released.

Step 9 Click the Automatic Conversation Summary prompt template and then click
Edit. On the editing page that is displayed, select an available LLM. For details
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about how to configure a model, see Configuring a Model. Turn on the Model
Parameters switch and set temperature to 0.2 and max_tokens to 300.

Step 10 Click Save and Publish to publish the prompt template.

----End

Verification

Verifying the session summary function by referring to this section.

Prerequisites

None

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Employee Center > Agent Management, and enable the Automatic
Conversation Summary function for agents.

Step 2 Sign in to the AICC as a multimedia agent and click  on the top to
sign in to the platform and access the online workbench.

Step 3 Click the History tab and then  after the conversation with the customer
ends. The call reason page is displayed.

Figure 2-376 Call reason page

Step 4 Click  to generate a session summary on the call reason page. Click Save to
save the call reason and session summary.
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Figure 2-377 Intelligent summary page

Step 5 (Optional) Sign in to the AICC as a tenant administrator and choose Contact
History > Contact. Click Call S/N to access the call reason page and summarize
the session.

Figure 2-378 Contact record details page
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NO TE

The number of summarization times of a single session is restricted by the Number of text
refine API calls allowed per session parameter, which can be set on the Configuration
Center > Chatbot Management > Flow Configuration > System > System Settings >
System Settings page.

----End

2.6.6 Small Language Model Zone

2.6.6.1 Building the Intelligent Case Filling Service Based on a Small
Language Model

Intelligent case filling uses the TUC and LODAS models to automatically extract
information from the texts of conversations between customers and agents as
well as quickly and accurately fill the information in the corresponding case form,
reducing the pressure of manual case filling.

Prerequisites
● Contact the system administrator to sign in to the AICC, choose Call Center >

Tenant Management, and enable the Intelligent Case Filling, Case 2.0,
AppCube, Customer Center, and Intelligent Agent (the number of
intelligent agents is greater than 0) features.

● The LLM Engine feature has been disabled for the tenant, or the case type
identification and case field identification services are not selected after the
LLM Engine feature is enabled.

● The tenant space administrator has set Enabling the Intelligent TT Filling
Feature to Yes on the Configuration Center > System Management >
Tenant Parameter page.

● The tenant space administrator has enabled the Smart Form Filling feature
for agents on the Configuration Center > Employee Center > Agent
Management page.

2.6.6.1.1 Configuring Case 2.0 Information

For details, see Configuring Case 2.0 Information.

2.6.6.1.2 Configuring Information on the ODFS

When the AICC uses the entity recognition model configured in the TUC to extract
case fields, the fields for offline training on the entity mapping management page
need to be mapped to the case fields on the case configuration page to ensure
that fields in the output result of the small language model and those on the
intelligent order filling page are in one-to-one mapping relationship.

Prerequisites
● Contact the system administrator to sign in to the AICC, choose Call Center >

Tenant Management, and enable the Intelligent Case Filling, Case 2.0,
AppCube, Customer Center, and Intelligent Agent (the number of
intelligent agents is greater than 0) features.
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● The LLM Engine feature has been disabled for the tenant, or the case type
identification and case field identification services are not selected after the
LLM Engine feature is enabled.

● The tenant space administrator has set Enabling the Intelligent TT Filling
Feature to Yes on the Configuration Center > System Management >
Tenant Parameter page.

● The tenant space administrator has enabled the Smart Form Filling feature
for agents on the Configuration Center > Employee Center > Agent
Management page.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Chatbot Management > Chatbot Management > Flow Configuration > System
> Label Mapping Management. The label mapping management page is
displayed.

Figure 2-379 Label mapping management page

Step 2 Click Create. On the page that is displayed, enter the label name, label
description, and label type.

Figure 2-380 Label data creation page
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Step 3 Select an associated service field name, click OK, and then click Save.

Figure 3 Selecting an associated service field

----End

2.6.6.1.3 Verification

Both the Online Chat and Call workbenches support the intelligent case filling
function.

Prerequisites
● The LLM Engine, Intelligent order filling, Case 2.0, AppCube, Customer

Center, and Intelligent Agent (the number of intelligent agents is greater
than 0) features have been enabled for the tenant space, and the Case type
identification and Case field identification services have been selected for
the LLM Engine feature.

● The tenant parameter Intelligent order filling has been enabled for the
tenant space on the Configuration Center > System Management > Tenant
Parameter page.

● The tenant space administrator has enabled the Smart Form Filling feature
for agents on the Configuration Center > Employee Center > Agent
Management page.

Procedure

Step 1 Sign in to the AICC as an agent and click Sign In.

Step 2 Click  in the upper right corner on the online workbench. The Select Work
Case Type drop-down list is displayed.
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Figure 2-381 Smart form filling button

Step 3 Select a case type to display the case information on the right. In addition, the
system automatically obtains the customer name, address, contact information,
and fault description based on the dialog content and adds them to the case
information on the right.

Step 4 Click Save. The case is saved successfully.

Step 5 Choose Case 2.0 > Case Workbench and view the intelligent case created on the
workbench.

NO TE

Currently, the case system supports only Chinese, English, and Spanish.

----End

2.7 IVR Journey Analysis

2.7.1 KPI Description
This section describes the KPIs that you need to understand before using the IVR
analysis system.
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Table 2-143 KPIs involved in the IVR analysis

Category KPI Definition Description Formula

Business KPIs Direct Number of
calls that
reach the
node through
the shortest
path.

If a customer
does not
press the
asterisk (*) or
pound (#)
key before
reaching a
business
node, the
customer's
call is
considered as
a direct call.

Direct = Visits
– Non Direct

Direct Rate Percentage of
direct calls to
total visits to
the business
node.

Direct Rate +
Non Direct
Rate = 1

Direct Rate =
Direct/Visits

Non Direct Number of
IVR calls that
pass through
other nodes
at the same
level with the
target node
or lower-level
nodes before
reaching the
target node.

- Non Direct =
Visits – Direct

Non Direct
Rate

Percentage of
non-direct
calls to total
visits to the
business
node.

Direct Rate +
Non Direct
Rate = 1

Non Direct
Rate = Non
Direct/Visits

Visits Total number
of calls that
reach the
business
node.

- Visits =
Number of
Successes +
Number of
Failures +
Number of
abandoned
calls
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Category KPI Definition Description Formula

Hang Up Number of
calls that are
hung up after
they reach
the business
node.

On a
navigation
node, if a
customer
does not
press the
asterisk (*)
key as
prompted to
return and
hangs up the
call instead
after pressing
an incorrect
key, the
customer's
call is not
considered as
a hung-up
call.

-

Number of
calls in which
customers
return to
previous
menus

Number of
calls in which
customers
press the
asterisk (*)
key to return
to previous
menus after
reaching the
business
node.

This KPI does
not include
the number
of times that
customers
press the
asterisk (*)
key to return
after pressing
incorrect keys
on navigation
nodes.

-

Number of
calls in which
customers
return to the
main menu

Number of
calls in which
customers
press the
pound (#) key
to return to
the main
menu after
reaching the
business
node.

- -
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Category KPI Definition Description Formula

Number of
Successes

Number of
calls with
successful
business
handling,
consultation,
or query.

A call is
considered as
a success if
more than
half of the
business
consultation
voice is
played or the
SMS message,
MMS
message,
WAP Push
message, or
email is
successfully
triggered.

Number of
Successes =
Visits –
Number of
Failures –
Number of
abandoned
calls

Number of
Failures

Number of
calls with
failed
business
handling,
consultation,
or query.

A call is
considered as
a failure if the
voice
indicating
business
failure is
played on a
query,
consultation,
or business
handling
node. This KPI
is inapplicable
to navigation
nodes.

Number of
Failures =
Visits –
Number of
Successes –
Number of
abandoned
calls
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Category KPI Definition Description Formula

Number of
abandoned
calls

● Less than
half of the
consultatio
n voice is
played on
a
consultatio
n node.

● No voice
indicating
business
success or
failure is
played on
a query or
business
handling
node, for
example,
when a
call is hung
up during
password
verification
.

This KPI is
inapplicable
to navigation
nodes and
transfer-to-
manual
nodes.

Number of
abandoned
calls = Visits –
Number of
Successes –
Number of
Failures

Success rate Percentage of
calls with
successful
business
handling,
consultation,
or query to
total visits.

- Success rate =
Number of
Successes/
Visits

Failure Rate Percentage of
calls with
failed
business
handling,
consultation,
or query to
total visits to
the business
node.

- Failure Rate =
Number of
Failures/Visits
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Category KPI Definition Description Formula

Abandon rate Percentage of
abandoned
calls to total
visits to the
business
node.

- Abandon rate
= Number of
abandoned
calls/Visits

Rehear Number of
nodes on
which voices
are replayed.

If the voice is
replayed for
multiple
times in a
node visit, the
value
increases only
by 1.

-

Rehear Rate Percentage of
nodes on
which voices
are replayed
to total visits.

- Rehear Rate =
Rehear/Visits

Rehear Once Number of
nodes on
which voices
are replayed
once.

- -

Rehear Twice Number of
nodes on
which voices
are replayed
twice.

- -

Average
Service
Duration

Average
duration of
business
handling,
query, or
consultation
on a business
node.

Proportion of
IVR service
duration to
node visits.

Average
Service
Duration =
IVR service
duration/
Visits
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Category KPI Definition Description Formula

Reduced
manual
service
duration

Product of the
number of
successful
calls for a
business node
and the
average
duration of
manual
service for the
business
node.

The average
duration of
manual
service is
automatically
synchronized
from the
IVRMAP.

-

Average
business path
length before
the business
node

The path
length before
calls reach
the business
node
indicates the
number of
business
nodes which
calls pass
through
before
reaching the
target
business
node.

Proportion of
the total path
length before
calls reach
the business
node to total
node visits.

Average
business path
length before
the business
node = Total
path length
before the
business
node/Visits

Average key
pressing times
before the
business node

Total number
of key
pressing times
before calls
reach the
business
node,
including
invalid key
pressing times
on a
navigation
node and
excluding key
pressing times
for the
collection of
multi-digit
numbers.

Proportion of
key pressing
times before
the business
node to total
node visits.

Average key
pressing times
before the
business node
= Number of
key pressing
times before
the business
node/Visits
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Category KPI Definition Description Formula

Flowing into
lower-level
menus

Number of
calls that
access lower-
level menus
through
upper-level
menus.

- -

Transfer-to-
manual rate

Number of
visits that are
transferred to
agents
because IVR
flows cannot
meet the
business
handling
requirements
of customers.

Percentage of
visits that are
transferred to
manual
service to
total visits to
the business
node, for
example, the
percentage of
visits that are
transferred to
manual
service at the
main menu.

Transfer-to-
manual rate =
Number of
transferred-
to-manual
calls/Visits

Number of
sent
SMS/MMS
messages

The number
of sent SMS
or MMS
messages for
consultation,
query, and
business
handling is
determined
by the
number of
times the
system plays
the voice
indicating
SMS or MMS
message
sending
success.

- -

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 765



Category KPI Definition Description Formula

Number of
sent faxes

The number
of faxes sent
for
consultation,
query, and
business
handling is
determined
by the
number of
times the
system plays
the voice
indicating fax
sending
success.

- -

Number of
sent emails

The number
of emails sent
for
consultation,
query, and
business
handling is
determined
by the
number of
times the
system plays
the voice
indicating
email sending
success.

- -
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Category KPI Definition Description Formula

Number of
sent WAP
Push
messages

The number
of sent WAP
Push
messages for
consultation,
query, and
business
handling is
determined
by the
number of
times the
system plays
the voice
indicating
WAP Push
message
sending
success.

- -

Number of
businesses
that are
successfully
handled

Total number
of business
requests that
are
successfully
handled on
all business
handling
subnodes,
including
requests for
business
subscription,
cancellation,
and
modification.

- -

Number of
successful
business
queries

Total number
of successful
business
requests on
all query
subnodes.

- -
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Category KPI Definition Description Formula

Equivalent
commission

Product of the
number of
businesses
that are
successfully
handled and
corresponding
commissions.

- Equivalent
commission =
Number of
businesses
that are
successfully
handled x
Commissions

SMS
satisfaction

Percentage of
customer
replies with 3,
4, and 5 to
customer
replies with 1,
2, 3, 4, and 5.

- SMS
satisfaction =
Number of
customer
replies with 3,
4, and 5/
Number of
customer
replies with 1,
2, 3, 4, and 5

Query success
rate

Percentage of
successful
business
query
requests to
total business
query
requests.

- Query success
rate =
Number of
successful
business
query
requests/
Number of
business
query
requests

Business
handling
success rate

Percentage of
businesses
that are
successfully
handled
through self-
service to
businesses
that are
handled
through self-
service.

- Business
handling
success rate =
Number of
businesses
that are
successfully
handled
through self-
service/
Number of
businesses
that are
handled
through self-
service.
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Category KPI Definition Description Formula

Total visits
that request
manual
service

Total number
of visits that
request
manual
service.

- -

Manual-to-
IVR calls

Number of
calls that are
transferred to
the IVR after
customers
request
manual
service on
hearing the
menu voice
on the first
node.

- -

Manual-to-
IVR rate

Percentage of
calls that are
transferred to
the IVR after
customers
request
manual
service on
hearing the
menu voice
on the first
node to
transferred-
to-manual
calls.

- Manual-to-
IVR rate =
Manual-to-
IVR calls/
Number of
transferred-
to-manual
calls

Average
manual
service
duration

Average
duration of
manual
service for
customer
visits.

- -

IVR-to-
manual calls

Number of
calls that are
transferred to
manual
service after
customers
access the
IVR.

- -
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Category KPI Definition Description Formula

Number of
failed
manual-to-
IVR calls

Number of
failed calls
that are
transferred to
the IVR in the
subsequent
handling
process after
customers
request
manual
service on
hearing the
menu voice
on the first
node.

- -

Redirected
calls

Number of
calls that
jump to other
nodes.

- -
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Category KPI Definition Description Formula

Traffic KPIs Valid IVR
Service

An IVR call is
valid if one of
the following
conditions is
met:
● The

business
request is
successfull
y handled
or the
business
query is
successful.

● More than
half of the
business
consultatio
n voice is
played or
the SMS
message,
MMS
message,
WAP Push
message,
or email is
successfull
y triggered.

If multiple
businesses are
handled
successfully
for a call, only
one valid
service is
counted.

- -
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Category KPI Definition Description Formula

Valid inbound
call rate

Percentage of
IVR inbound
calls in which
customers
reply with
keys to total
IVR inbound
calls.

If an inbound
call is directly
hung up
when the
greeting or
the menu
voice of the
first node is
played, the
call is not
considered as
a valid
inbound call.

Valid inbound
call rate =
Number of
valid inbound
calls/Number
of inbound
calls

Effective
Service Rate

An IVR call is
effective if
one of the
following
conditions is
met:
● The

business
request is
successfull
y handled
or the
business
query is
successful.

● More than
half of the
business
consultatio
n voice is
played or
the SMS
message,
MMS
message,
WAP Push
message,
or email is
successfull
y triggered.

Effective
Service Rate
indicates the
percentage of
calls with
effective
services to
total IVR
inbound calls.

Effective
Service Rate =
Number of
calls with
effective
services/
Number of
IVR inbound
calls
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Category KPI Definition Description Formula

Number of
transferred-
to-manual
calls

Number of
inbound calls
that request
manual
service.

If a call
requests
manual
service for
multiple
times, only
one request is
counted.

-

Number of
transferred-
to-manual
calls on the
first node

Number of
calls in which
customers
request
manul service
on the first
node.

If a call
requests
manual
service for
multiple
times on the
first node,
only one
request is
counted.

-

Transferred-
to-manual
rate on the
first node

Percentage of
calls
transferred to
manual
service on the
first node.

- Transferred-
to-manual
rate on the
first node =
Number of
transferred-
to-manual
calls on the
first node/
Number of
inbound calls

Number of
non-
transferred-
to-manual
calls on the
first node

Number of
calls that are
transferred to
manual
service in the
subsequent
handling
process after
customers
access the IVR
on hearing
the menu
voice on the
first node.

- Number of
non-
transferred-
to-manual
calls on the
first node =
Number of
transferred-
to-manual
calls –
Number of
transferred-
to-manual
calls on the
first node
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Category KPI Definition Description Formula

Self-service
volume

Number of
IVR calls that
are not
transferred to
manual
service.

- Self-service
volume =
Total number
of inbound
calls –
Number of
transferred-
to-manual
calls

Proportion of
manual traffic

Percentage of
inbound calls
that request
manual
service to
total IVR
inbound calls.

- Proportion of
manual traffic
= Number of
transferred-
to-manual
calls/Number
of inbound
calls

Pure IVR
service rate

Percentage of
inbound calls
with no
manual
service to
total inbound
calls.

- Pure IVR
service rate =
Number of
inbound calls
with no
manual
service/
Number of
inbound calls

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 774



Category KPI Definition Description Formula

Transferred to
Manual
Successful

Number of
calls that are
successfully
transferred to
agents.

An IVR call is
successfully
transferred to
an agent if
the call is
successfully
transferred to
a queue and
does not
return to the
IVR through
the timeout
flow due to
the queuing
timeout.
NOTE

● If
agentSucc
Flag is 1,
the call is
successfull
y
transferred
to an
agent.

● If
agentSucc
Flag is 0,
the call
fails to be
transferred
to an
agent.

-

Transferred-
to-manual
success rate

Percentage of
calls that are
successfully
transferred to
manual
service to
total calls
that request
manual
service.

- Transferred to
manual
successful
rate =
Transferred to
Manual
Successful/
Number of
transferred-
to-manual
calls
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Category KPI Definition Description Formula

Number of
non-direct
behaviors

If there are
multiple non-
direct
behaviors in a
call, one non-
direct
behavior is
counted.

- -

Non-direct
behavior rate

Proportion of
non-direct
behaviors to
total inbound
calls.

- Non-direct
behavior rate
= Number of
non-direct
behaviors/
Number of
inbound calls

IVR One-time
Resolution
Rate

If a hotline
inbound call
with a valid
service does
not request
manual
service and
the customer
does not call
the customer
service
platform
again within
two hours
after the call
is hung up,
the customer
concern is
considered to
be resolved in
one IVR call.

- IVR One-time
Resolution
Rate = (Valid
IVR service
volume – IVR
Repeat Calls)/
Valid IVR
service
volume

Average call
duration

Average
duration of
customers'
interaction
with the IVR
in all hotline
calls that do
not request
manual
service.

- Average call
duration =
Total duration
of IVR service/
Number of
inbound calls
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Category KPI Definition Description Formula

IVR system
error rate

Percentage of
IVR inbound
calls with
flow or voice
invocation
errors to total
IVR inbound
calls.

- IVR system
error rate =
Number of
calls with
flow or voice
invoking
errors/
Number of
inbound calls

Average Path
Length

The business
path length
indicates the
number of
business
nodes,
including
consultation,
query,
business
handling, and
navigation
nodes, which
calls pass
through.

- Average Path
Length =
Business path
length/
Number of
inbound calls

Repeated
Incoming
Calls

Number of
calls from
calling parties
who dial the
customer
service hotline
repeatedly
within 2
hours.

- -

Repeated Call
Rate

Percentage of
repeated calls
to total calls.

- Repeated Call
Rate =
Repeated
Incoming
Calls/Total
number of
inbound calls
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Category KPI Definition Description Formula

Number of
IVR inbound
calls

Number of
IVR inbound
calls that are
connected to
the customer
business
platform and
in which IVR
voices are
successfully
played. The
value is
slightly
smaller than
the number
of IVR
inbound calls
collected by
the platform.
If a call is
connected to
the IVR
multiple
times, only
one call is
counted.

- -

Total IVR
service
duration

Total duration
of IVR service.

This KPI does
not include
the waiting
time and
manual
service
duration of
calls that are
transferred to
manual
service. The
unit is second.

-
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Category KPI Definition Description Formula

Voice
playback
node path
length

Number of
times calls
pass through
voice
playback
nodes.

If a voice is
automatically
replayed by
the IVR due
to the
timeout of
digit
collection,
only one
voice
playback is
counted.

-

IVR Repeat
Calls

Number of
IVR inbound
calls with
valid services
and no
manual
service that
are connected
to the hotline
again within
two hours
after the calls
are hung up.

- -

Number of
function node
visits

Number of
calls that
reach
consultation,
query, or
business
handling
nodes.

- -
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Category KPI Definition Description Formula

Average key
pressing times

Number of
times
customers
press keys on
hearing menu
voices,
including
invalid key
pressing times
at the
navigation
menu and
excluding key
pressing times
for the
collection of
multi-digit
numbers.

- Average key
pressing times
= Number of
key pressing
times/
Number of
inbound calls

Key Error
Return

Number of
times
customers
press the
asterisk (*)
key to return
to previous
menus after
pressing
incorrect keys
on navigation
nodes.

- -

Number of
hang-up calls
due to
incorrect key
pressing

Number of
calls in which
customers
hang up
instead of
pressing the
asterisk (*)
key as
prompted to
return to
previous
menus after
pressing
incorrect keys
on navigation
nodes.

- -
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Category KPI Definition Description Formula

Number of
customers

Number of
inbound
customer
numbers after
deduplication.

- -

Number of
local
customers

Number of
customers in
a specific city
or region.

- -

Active traffic
distribution
rate

Percentage of
calls with key
pressing for
self-service on
the first node
to total calls
with key
pressing for
self-service or
manual
service on the
first node.

- Active traffic
distribution
rate =
Number of
calls with key
pressing for
self-service on
the first node/
(Number of
calls with key
pressing for
self-service on
the first node
+ Number of
calls with key
pressing for
manual
service on the
first node)

Number of
pure IVR
customers

Number of
customers
who are
connected to
the IVR and
are not
transferred to
manual
service in a
month after
deduplication.

- -
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Category KPI Definition Description Formula

Number of
loyal
customers

Number of
customers
who call the
IVR system
every month
for three
consecutive
months and
whose calls
are not
transferred to
manual
service.

- -

Average path
length with
key pressing

Average path
length of
inbound calls
that enter the
main flow.

- -

Hang-up calls
on the first
node

Number of
inbound calls
in which no
keys are
pressed.

- -

Number of
customers
who hang up
before
reaching the
first node

Number of
customers
who do not
reply with
keys after
deduplication.

- -

Hang-up rate
before calls
reach the first
node

Percentage of
calls that are
hung up
before
reaching the
first node to
total inbound
calls.

- Hang-up rate
before calls
reach the first
node = Hang-
up calls on
the first node/
Number of
inbound calls

Average
duration of
calls with key
pressing

Average
duration of
inbound calls
that enter the
main flow.

- -
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Category KPI Definition Description Formula

Node arrival
rate

Percentage of
calls that
reach
function
nodes to calls
with key
pressing on
the first node.
The keys
pressed on
the first node
do not
contain 0.

- -

Number of
calls with key
pressing on
the first node

Number of
inbound calls
with key
pressing on
the first node.

- Number of
calls with key
pressing on
the first node
= Number of
IVR inbound
calls – Hang-
up calls on
the first node

Number of
calls with key
pressing for
self-service on
the first node

Number of
calls with
keys except 0
pressed on
the first node.

- Number of
calls with key
pressing for
self-service on
the first node
= Number of
calls with key
pressing on
the first node
– Number of
calls with key
pressing for
manual
service on the
first node

 

2.7.2 IVR Overview
On the IVR Overview page, you can view the overall operations status of a
selected chatbot flow from a macro perspective.

Prerequisites
● You have the IVR Analysis > IVR Overview menu permission.
● The IVR analysis and intelligent IVR features have been enabled for the tenant

space.
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● The chatbot flow to be analyzed has call records in the query time range.

Procedure

Step 1 Sign in to the AICC and choose IVR Analysis > IVR Overview.

Step 2 Set the access code, version name, and time range in the filter criteria boxes and
press Enter. The query result is displayed, as shown in Figure 2.

Figure 2-382 IVR Overview

Step 3 In the Operation Status area, learn about the overall status of IVR operations.

NO TE

The Operation Status area displays the overall IVR operations status based on the month-
on-month increase or decrease rate of core KPIs of IVR flows (arithmetic average value of
the absolute values of the month-on-month (MoM) rates of all core KPIs).
If the average increase or decrease rate of core KPIs is less than 5%, the operations status is
Good. If the increase or decrease rate ranges from 5% to 10%, the operations status is
General. If the increase or decrease rate is greater than 10%, the operations status is Poor
and the situation needs to be handled in time. If no MoM value is available, the operations
status is set to Good by default.

Step 4 Click More to go to the Alarm Event page. For details, see 2.7.7 Alarm Event.

Step 5 In the Business Rankings area, click a node name to go to the Flow Analysis
page. For details, see 2.7.3 Flow Analysis.
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Figure 2-383 Node name

NO TE

● Success rate = ∑Number of successes (SuccessCalls)/∑Number of visits (journeynum)
● Failure rate = ∑Number of failures (FailedCalls)/∑Number of visits (journeynum)
● Hang-up rate = ∑Number of calls that are hung up (HangupNum)/∑Number of visits

(journeynum)

Step 6 (Follow-up procedure) Learn about the descriptions and formulas of KPIs. For
details, see 2.7.1 KPI Description.

----End

2.7.3 Flow Analysis
By analyzing the access paths of IVR flows, you can learn about the common
access paths of users and ensure that these access paths remain unchanged when
adjusting flows.

You can analyze the traffic of each node to learn about the traffic information of
each node or business, find out inefficient menu nodes and business flows, and
identify the weaknesses of the IVR design.

You can view the non-direct call information to learn about the operations
performed by users on a node and optimize the node accordingly.

You can also learn about the proportion of the traffic of a subnode to the
outgoing traffic of its upper-layer node.

Prerequisites
● You have the IVR Analysis > Flow Analysis menu permission.
● The IVR analysis and intelligent IVR features have been enabled for the tenant

space.
● The chatbot flow to be analyzed has call records in the query time range.
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Procedure

Step 1 Sign in to the AICC and choose IVR Analysis > Flow Analysis.

Step 2 Set the access code, version name, and time range in the filter criteria boxes and
press Enter. The query result is displayed, as shown in Figure 2.

Figure 2-384 Flow Analysis

NO TE

A scheduled task collects statistics on business data of the past three hours every hour.

Step 3 Enter a node name in the Node Name text box to search for the node. The node
is highlighted.

Step 4 Enable  to display the reverse traffic.

Step 5 Double-click a node in the flowchart to go to the corresponding node analysis
page.

Step 6 Click the aerial view in the lower left corner to quickly locate specific flow
information.
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Figure 2-385 Aerial view

Step 7 Double-click the main flow to access the main flow analysis details page.

Figure 2-386 Analysis of the main flow

Step 8 Double-click a subflow to access the sub-flow analysis details page.
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Figure 2-387 Subflow

Step 9 Double-click a composite diagram element to access the analysis details page of
the composite diagram element.

Figure 2-388 Composite diagram element

Step 10 (Follow-up procedure) Double-click a node to go to the analysis details page. The
details page contains the Node Overview, Trend Analysis, and Outflow Detailed
Distribution tab pages.
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Figure 2-389 Tab pages

Step 11 Click the Node Overview tab to view the inflow distribution chart, outflow
distribution chart, node traffic chart, and KPI statistics.

Figure 2-390 Inflow distribution

NO TE

● Direct Rate: percentage of direct calls to total visits to the business node
● Non Direct Rate: percentage of non-direct calls to total visits to the business node
● For details, see 2.7.1 KPI Description.
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Figure 2-391 Outflow distribution

NO TE

● Non Direct: number of IVR calls that pass through other nodes at the same level with
the target node or lower-level nodes before reaching the target node

● Flowing into lower-level menus: number of calls that go to lower-level nodes after
reaching the business node

● Hang Up: number of calls that are hung up after they reach the business node
● For details, see 2.7.1 KPI Description.
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Figure 2-392 Node Traffic Chart (Number of Indicators)

Figure 2-393 Indicator quantity statistics

Step 12 (Follow-up procedure) Click the Trend Analysis tab to view the value trend
distribution chart, efficiency trend distribution chart, and complexity trend
distribution chart.
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Figure 2-394 Value Trend Distribution

NO TE

● Direct: number of calls that reach the node through the shortest path
● Non Direct: number of IVR calls that pass through other nodes at the same level with

the target node or lower-level nodes before reaching the target node
● Visits: total number of calls that reach the business node
● Hang Up: number of calls that are hung up after they reach the business node
● Number of Successes: number of calls with successful business handling, consultation,

or query
● Number of Failures: number of calls with failed business handling, consultation, or

query
● For details, see 2.7.1 KPI Description.

Figure 2-395 Efficiency Trend Distribution
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NO TE

● Direct Rate: percentage of direct calls to total visits to the business node
● Non Direct Rate: percentage of non-direct calls to total visits to the business node
● Hang Up Rate: percentage of calls that are hung up to total visits to the business node
● Success rate: percentage of calls with successful business handling, consultation, or

query to total visits
● Failure Rate: percentage of calls with failed business handling, consultation, or query to

total visits
● For details, see 2.7.1 KPI Description.

Figure 2-396 Complexity Trend Distribution

NO TE

● Rehear: Rehear, Rehear Once, and Rehear Twice
● Rehear: number of nodes on which voices are replayed
● Rehear Once: number of nodes on which voices are replayed once
● Rehear Twice: number of nodes on which voices are replayed twice
● Rehear Rate: percentage of nodes on which voices are replayed to total visits
● Average Service Duration: average duration of business handling, query, or

consultation on a business node
● Average Path Length: Path length refers to the number of business nodes which calls

pass through before reaching the target business node. Average Path Length indicates
the proportion of the total path length to total node visits.

● For details, see 2.7.1 KPI Description.

Step 13 (Follow-up procedure) Click the Outflow Detailed Distribution tab to view the
detailed outflow distribution based on an amount chart and a percentage chart.
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Figure 2-397 Outflow detailed distribution amount

Figure 2-398 Outflow detailed distribution percentage
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NO TE

The preceding figures show the outflow distribution of a node, for example, from node A to
node B by pressing key 1 or key 2.

----End

2.7.4 KPI Analysis
You can analyze and export information about IVR KPIs including Calls Volume,
IVR Repeat Calls, IVR One-time Resolution Rate, and Effective Service Rate.
You can also view Node Overview, Trend Analysis, and Outbound Detailed
Distribution for each KPI through KPI drilling.

Prerequisites
● You have the IVR Analysis > KPI Analysis menu permission.
● The IVR analysis and intelligent IVR features have been enabled for the tenant

space.
● The chatbot flow to be analyzed has call records in the query time range.

Procedure
Step 1 Sign in to the AICC and choose IVR Analysis > KPI Analysis.

Step 2 Set the access code, version name, and time range and press Enter.

Figure 2-399 KPI Analysis
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NO TE

MoM indicates the value of the KPI in the previous month. For example, if the current
query time range is June 1 to June 5, MoM is the value of the KPI of the time range from
May 1 to May 5.

Step 3 Click a bar on the Calls Volume tab page to view the number of node visits.

Figure 2-400 Bar chart

Step 4 Click a bar in the bar chart of node visits to view node details. For details, see
2.7.3 Flow Analysis.

Figure 2-401 Bar chart of node visits

Step 5 In the Extended Metrics area, click  to select required KPIs.
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Figure 2-402 Column Configuration

Step 6 Click  to download information about extended KPIs.

NO TE

For details about the KPIs involved in this section, see 2.7.1 KPI Description.

----End

2.7.5 Version Comparison

Scenario

A flow has only one release version by default, but can have multiple historical
versions. The version comparison function is used to compare the traffic and
business KPIs of a version with those of the previous version, analyze the impact
of version changes on KPIs, and evaluate the effect of flow adjustment.

Prerequisites
● You have the IVR Analysis > Flow Compare menu permission.
● The IVR analysis and intelligent IVR features have been enabled for the tenant

space.
● The chatbot flow to be analyzed has an access code.
● The chatbot flow to be analyzed has call records in the query time range.
● The selected flow version has release time.

Procedure

Step 1 Sign in to the AICC and choose IVR Analysis > Flow Compare.
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Step 2 Set the chatbot, flow version, and query time range and press Enter to compare
the KPIs before and after the release.

Figure 2-403 Flow Compare

Step 3 Click  in the upper right corner to customize the KPIs to be displayed.

Figure 2-404 Indicator Setting

Step 4 Click a node name link to go to the node overview page. For details, see 2.7.3
Flow Analysis.

Figure 2-405 Node name
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For details about the KPIs involved in this section, see 2.7.1 KPI Description.

----End

2.7.6 Optimization Suggestion

Scenario
Based on the key pressing track and number of key pressing times on the user
side, optimization suggestions are provided for the current IVR flow, which can be
used as a reference for flow optimization.

Prerequisites
● You have the IVR Analysis > Optimization menu permission.
● The IVR analysis and intelligent IVR features have been enabled for the tenant

space.
● The chatbot flow to be analyzed has an access code.
● The chatbot flow to be analyzed has call records in the query time range, and

the call records have been collected by a scheduled task. (The scheduled task
is executed every hour.)

Figure 2-406 Access Code Settings

Procedure

Step 1 Sign in to the AICC and choose IVR Analysis > Optimization.
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Figure 2-407 Optimization

Step 2 Set the chatbot, flow version, and query time range and press Enter.

Step 3 Enter a node name in the text box on the left to search for the node.

Step 4 Click the Voice broadcast sequence optimization tab to view Current Voice
Playback Key Usage Statistics and Recommended voice broadcast sequence on
the right.

Step 5 Click the Voice definition optimization tab to view Repeated Listening Times
and Optimization Suggestions.

----End

2.7.7 Alarm Event

Scenario

You can use the alarm event function to obtain alarm event logs for quick
troubleshooting.

Prerequisites
● You have the IVR Analysis > Alarm Event menu permission.
● The IVR analysis and intelligent IVR features have been enabled for the tenant

space.
● You have configured a warning condition for your chatbot on the IVR

Analysis > Service Pre-warning Configuration page.
● Your chatbot has warning records that meet the warning condition, and the

records have been collected by a scheduled task. (The scheduled task is
executed every hour.)

Procedure

Step 1 Sign in to the AICC and choose IVR Analysis > Alarm Event.

Step 2 Set the chatbot, flow version, and time range.
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Step 3 Press Enter.

----End

2.7.8 Warning Condition

Prerequisites
● You have the IVR Analysis > Service Pre-warning Condition Configuration

menu permission.
● The IVR analysis and intelligent IVR features have been enabled for the tenant

space.
● You have configured an SMS gateway or email gateway.

Procedure

Step 1 Sign in to the AICC and choose IVR Analysis > Service Pre-warning Condition
Configuration.

Figure 2-408 Service Pre-warning Configuration

Step 2 Set the chatbot and flow version. The options for the chatbot selection box are IVR
flows and intelligent IVR flows. Select a version of the flow corresponding to the
selected chatbot.

Step 3 Click New. The Creating a Service Pre-alarm Condition dialog box is displayed.
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Figure 2-409 Creating a Service Pre-alarm Condition

● Chatbot Access Code: The options are common IVR flows and intelligent IVR
flows in the tenant space.

● Version: IVR flow version.
● Statistical Indicators: The options are Direct Rate, Non Direct Rate, Hang

Up Rate, Failure Rate, Rehear Rate, and Transfer-to-manual rate. For
details about the KPIs, see 2.7.1 KPI Description.

● Pre-warning condition: The options are absolute value and MoM Value.
absolute value indicates the distance of a value from zero. MoM Value
indicates the change in the current month's value compared with the value in
the previous month.

● Warning level: The options are Low, Middle, and High.
● Pre-warning Validity Period: The options are Permanently valid and

Specifies the validity period.
● Reminder Mode: The options are SMS and Email.
● Reminder object: You can select multiple employees in the tenant space to

send notifications.
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Step 4 Click Save to save the warning condition.

Step 5 If your chatbot has warning records that meet the warning condition, and the
records have been collected by a scheduled task, alarm events are generated.
(The scheduled task is executed every hour.)

Step 6 Click Edit to edit the warning condition again.

----End

2.8 Monitoring Outbound Call Risks
When the number of outbound calls of a tenant exceeds the warning threshold in
the configured policy, a risk control record is generated. The system administrator
notifies the tenant administrator of the risk control record. The tenant
administrator can view the execution status of the risk control policy.

NO TE

For details about how to configure the warning threshold in the outbound call risk
monitoring policy, see "System Administrator Guide > Outbound Call Risk Monitoring
Guide" in AICC Operation Configuration Guide.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Monitoring > Operation
Risk Control.

Step 2 Select a risk control record assigned by the system administrator and click View to
view the details.

----End

2.9 Managing Cases

2.9.1 About This Document
This document is applicable only to the public cloud environment. Sign in to the
AICC to use this document.
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Figure 2-410 Case function overview

2.9.2 Getting Started
Cases are an efficient communication and collaboration tool that helps enterprises
resolve problems that require cross-department and cross-region collaboration to
provide customers with high-quality services.

Enterprises can view the real-time case handling status in the case overview.

Through case configuration, enterprises can implement case solutions based on
business requirements.

2.9.2.1 Adding an Account

Prerequisites
● You have signed in to the AICC as the system administrator, chosen Call

Center Management > TenantSpace Management, and enabled the Case
2.0, AppCube, and Customer Center features.
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Procedure

Step 1 Sign in to the AICC as the system administrator.

Your enterprise will obtain an administrator account from Huawei after
successfully applying for a tenant in the AICC. Use this account to sign in.

NO TICE

To ensure data security, change the initial password of the account upon the first
sign-in.

Step 2 Add a role.

1. Choose Configuration Center > Employee Center > Role.

2. In the navigation pane, select your tenant space and click .
3. Enter a role name and click Next.
4. Click Add and select related permissions under Case Management 2.0 and

Customer Center. You can also add other permissions as required, for
example, the Reset User Password permission under User Management.
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Figure 2-411 Adding permissions

5. Click OK. In the dialog box that is displayed, click OK.
6. Click NEXT.
7. Click Finish.

Step 3 Add a case handler account.

1. Choose Configuration Center > Employee Center > Employee.
2. In the navigation pane, select the upper-level OU of Default OU and click

New.
3. Set Account, Employee, Email, Phone Number, New password, Confirm

Password, and Organization Unit.
4. Click Confirm to save the new account.

Step 4 Choose Configuration Center > Case Configuration 2.0 > Case Configuration >
User Role.

Step 5 Click Create on the right, associate the role with the user, and click Save.

----End

2.9.2.2 Handling Your First Case

After you quickly complete case configuration and create your first case on the
online customer service side, you can handle the case.
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Step 1 Sign in to the AICC as a case handler.

You need to change the password upon the first sign-in. Set a new password as
prompted and sign in again.

Step 2 Choose Case 2.0 > Case Workbench.

Step 3 Click the Todo tab and click a case. The case details page is displayed.

Step 4 You can perform the following operations on a claimed case:

● : Follow an important or urgent case.

● : Send an email or SMS notification to urge the case owner to handle a
case that is about to expire. The prerequisite is that case reminder notification
has been configured. For details, see Configuring Case Reminder
Notification.

● : Upgrade the case level. After the upgrade, an upgrade flag is added to
the case title.

● : Suspend a case that does not need to be handled temporarily.

● : Transfer the case to change the case owner.

● : Cancel the case.

● : Close the case.

● : Restart the case.
● Comment: Add comments when you handle the case.
● Add Attachment: Add supplementary information for the case, for example,

fault screenshots provided by the customer. The total size of attachments
cannot exceed 5 MB, and the number of attachments cannot exceed 5. JPG,
PNG, PDF, JPEG, GIF, DOC, and DOCX attachments are supported.

● Create on the Case Task tab page: Create a task and trace the handling when
the case needs to be handled based on department collaboration.
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Figure 2-412 Create task page

NO TE

Multiple tasks can be created for a case.

● Associated Case tab page: View associated cases after merging cases. For
details about how to merge cases, see 2.9.4.4 Merging Cases.

● Internal Record tab page: Only the case owner and tenant administrator
have the permission to perform operations on this tab page. An internal
record can contain a maximum of 20,000 characters. If an image needs to be
added, click Add Attachment to upload it.
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Figure 2-413 Internal Record tab page

----End

2.9.3 Administrator Guide

2.9.3.1 Case Configuration

Prerequisites
● You have the Case Configuration permission. For details about how to assign

permissions, see 2.9.3.1.9 Case Role and 2.9.3.1.11 User Role.
● The case 2.0 feature has been enabled for the tenant space.

2.9.3.1.1 Case Status

You can customize case statuses on the Case Status page during case handling.

Prerequisites
● You have the Case Configuration permission.
● The case 2.0 feature has been enabled for the tenant space.

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Case Configuration 2.0 >
Case Configuration > Case Status.

Step 2 Click Create and enter a status name.

Step 3 Click Confirm.

Step 4 (Follow-up operation) Choose Configuration Center > Case Configuration 2.0 >
Case Configuration > Case Type and select the created case status for a case
type.

----End

2.9.3.1.2 Customized Case Field

An enterprise can flexibly set fields based on the business scenario.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 809



Prerequisites
● The Case 2.0 feature has been enabled for the tenant space.
● You have the Case Configuration permission.

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Case Configuration 2.0 >
Case Configuration > Case Field.

Step 2 Click Create. In the Create dialog box, set field parameters as required.

Figure 2-414 Create

Step 3 Click .

Step 4 (Follow-up operation) Choose Case Configuration > Case Template and click
Config corresponding to a template. The new field is displayed under Custom
Field. Drag the field to the Container area so that it is referenced by the template.
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Figure 2-415 Configure Case Template

----End

2.9.3.1.3 Case Template

A case template contains the information to be collected from cases and the
display format of the information, including the format of the page displayed
during case creation, modification, or query. You can define the fields to be
displayed in the case template and the layout of the fields.

Prerequisites
● The case 2.0 feature has been enabled for the tenant space.
● You have the Case Configuration permission.

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Case Configuration 2.0 >
Case Configuration > Case Template.

Figure 2-416 Case Template

Step 2 Click Create. On the Create page, enter a template name and template
description, and click Save.
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Step 3 Click Config corresponding to the new template to access the view page and add
content. If a customized field is set as a mandatory field, you must add the
customized field to the create view.

Figure 2-417 View page

Step 4 Click  to save the content and click  to preview the content.

NO TE

Save the content after adding a field to the create view to prevent the content from being
lost. For example, after adding field A to the edit view, if you do not save the content
before previewing it, field A will be lost.
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Step 5 (Follow-up operation) Enable a case template so that you can reference it when
configuring a case content template and synchronize it to the Metadata
Management page.

Figure 2-418 Synchronizing a case template to the Metadata Management page

----End

2.9.3.1.4 Case Content Template

Prerequisites
● The Case 2.0 feature has been enabled for the tenant space.
● You have the Case Configuration permission.
● An enabled case template is available.

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Case Configuration 2.0 >
Case Configuration > Case Template Content.

Figure 2-419 Case Template Content page

Step 2 Click Create. In the Case Content Template Information area, set Content
Template Name and Associated Case Template, and click Save.
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Figure 2-420 Case Content Template Information area

Table 2-144 Parameters in the Case Content Template Information area

Parameter Description

Content Template Name Mandatory.

Associated Case Template Select a value from the drop-down list.
The options are case templates on the
Case Configuration > Case Template
page. For details about how to create
a case template, see 2.9.3.1.3 Case
Template.

 

Step 3 Click Edit. On the editing page, enter case template information.

Figure 2-421 Edit button

Figure 2-422 Case Template Info area
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Table 2-145 Parameters in the Case Template Info area

Parameter Description

Title Case title. The value can contain a
maximum of 128 characters.

Content Description Case content description.

Priority ● Low
● Medium
● High
● Critical

Source ● Voice
● Whatsapp
● webchat
● Email

Deadline Case deadline.

Associated Customer ● The options are customers in the
customer center. You can sign in to
the AICC as a tenant administrator
and choose Customer Center >
Customer Center Management to
view customers. For details, see
2.12 Managing the Customer
Center.

● You can directly create a customer.
For details, see 2.9.4.2 Creating a
Customer.

Assignment Mode ● If this parameter is set to Manual,
you can assign the case to a skill
queue or an agent.

● If this parameter is set to Auto, the
case will be assigned based on the
case assignment rule on the Case
Configuration > Case Assignment
Rule page. For details, see 2.9.3.1.6
Case Assignment Rule.

Owner The options are all employees in the
tenant space. If you select Claim, the
owner is the case creator by default.

 

----End
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2.9.3.1.5 Case Type

To differentiate businesses, you can classify cases into different types, such as
complaint or consultation cases. Different types of cases can be associated with
different statuses to meet business requirements.

Procedure

Step 1 Sign in to the AICC, choose Configuration Center > Case Configuration 2.0 >

Case Configuration > Case Type, and click .

Figure 2-423 Create

Step 2 On the Create page, enter case type information and click Save.

Table 2-146 Case type parameters

Parameter Description

Case Type Name Enter a case type name, for example, Complaint.

Case Type Description Enter a case type description, for example,
Complaint content, Complaint target, or
Complaint source.

Cascader Select an upper-level case type.

Case Template Select a value from the drop-down list.

Case Context Template Associate a case content template.

Case Process Add case statuses.

Strictly Follow the Status
Sequence

Enable or disable this function. If this function is
enabled, the case can only be handled step by
step. If disabled, the case status can be
transitioned to any status as required.
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Parameter Description

Verify task status Enable or disable this function. If this function is
enabled, the status of the associated tasks is
verified when the case is closed. If disabled, the
status of the associated tasks is not verified.

 

Step 3 After the case type is created, you can switch its status to  to enable it. You
can select only an enabled case type when creating a case on the Case 2.0 > Case
Workbench page.

Figure 2-424 Enabling a case type

Step 4 After a case type is enabled, synchronize it to the Metadata Management page.

Figure 2-425 Metadata Management

Step 5 If the case type has not been referenced, you can switch its status to  to
disable the case type. After the case type is disabled, you can edit or delete the
case type.

----End
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2.9.3.1.6 Case Assignment Rule

When creating a case, you can choose to automatically assign the case to an
owner. The automatic assignment will be performed based on the automatic
assignment rule set on the platform. Only one automatic assignment rule can take
effect under a tenant.

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Case Configuration 2.0 >
Case Configuration > Case Assignment Rule.

Step 2 Click Create. The page for creating a case assignment rule is displayed.

Figure 2-426 Add Automatic Allocation page

Step 3 Enter a rule name.

Step 4 Add rule items. For example, if you want to assign cases whose titles contain Fault
to a customer service team, you can add a rule item as follows: In the Rule
Content area, select the Case title attribute, set Filter Condition to Include, and
set Value to Fault. Set Owner Type to Skill Queue, select the customer service
team from the Owner drop-down list, and click Save.
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Figure 2-427 Add Rule Category page

Step 5 To assign cases to an agent, set Owner Type to Seats and select the agent from
the Owner drop-down list.

Step 6 (Follow-up operation) When creating a case, set Assignment Mode to Auto to
start the case assignment rule.

Figure 2-428 Create Case page
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● Only one case assignment rule can be activated at the same time.

● A maximum of 10 rule items can be added to a rule.

● The rule items are matched from top to bottom. If a rule item is met, the case is
automatically assigned to the owner set in the rule item. If no rule item is met, the case
is assigned to the default owner.

----End

2.9.3.1.7 Case SLA Rule

After a case is created, a warning notification and a timeout notification will be
sent after the case reaches the corresponding deadlines configured in the case SLA
rule.

Prerequisites
● The Case 2.0 feature has been enabled for the tenant space.
● You have the Case Management 2.0 > Case > Case Configuration

permission.
● To ensure that SMS messages and emails can be sent, you have configured an

SMS gateway and an email gateway in advance. For details, see Configuring
Gateways.

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Case Configuration 2.0 >
Case Configuration > Case SLA.

Step 2 Click Create on the right and enter rule information in the Basic Info area.

Figure 2-429 Created Case SLA Rule

Step 3 Click the Timeout Notification tab. You can choose to configure timeout
notification or warning notification.
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Figure 2-430 Timeout Notification

1. Set the deadline and enter a notification name.

2. Choose to send a timeout notification via email or SMS message.

3. If the case title, deadline, case details link, or other fields do not have fixed
values during email filling, insert variables to automatically fill in the email
subject and body, reducing the number of case SLA rule setting times. For
details about how to create variables, see 2.9.3.1.2 Customized Case Field.

4. Click Save.

Step 4 Click the Warning Notification tab.

Figure 2-431 Warning Notification

Step 5 Enable Configure Warning Notification.

1. Set the deadline and enter a notification name.

2. Choose to send a warning notification via email or SMS message.

3. If the case title, deadline, or other fields are not the same during case filling,
insert variables to automatically fill in the email subject and content, reducing
the number of case SLA rule setting times. For details about how to create
variables, see 2.9.3.1.2 Customized Case Field.

4. Click Save.

NO TE

– Only one SLA rule can be activated for cases of the same type.

– The warning notification time must be earlier than the timeout notification time.

Step 6 (Follow-up operation) Enable the rule in the case SLA rule list. After a case for
which the case type is set to a case type bound with the rule is created, the
corresponding SLA instance data is generated in the SLA instance table.

Step 7 (Follow-up operation) A scheduled task reads SLA instance data. If the warning
time or timeout time in the instance data is earlier than the current time, the
scheduled task obtains the corresponding waring notification content or timeout
notification content and notifies the owner via SMS message or email.

----End
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2.9.3.1.8 Case Reminder

Prerequisites
● The Case 2.0 feature has been enabled for the tenant space.
● You have the Case Management 2.0 > Case > Case Configuration

permission.
● To ensure that SMS messages and emails can be sent, you have configured an

SMS gateway and an email gateway. For details, see 2.11.3.1 Configuring
SMS Gateways and 2.11.3.2 Configuring Email Gateways.

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Case Configuration 2.0 >
Case Configuration > Case Reminder. Currently, automatic notification, case
reminder notification, and customer notification are supported.

Figure 2-432 Case Reminder

----End

Configuring Automatic Notification

Step 1 Enable Automatically send notifications.
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Figure 2-433 New Automatic Notification

1. Enter a notification name.

2. Select a notification scenario. Currently, the options are Create, Close, Pause,
Restore, Cancel, Transfer, Merge, Reboot, and ReOpenHis.

3. Choose to send a case reminder via email or SMS message.

4. If the case title, case ID, case details link, or other fields do not have fixed
values during email filling, insert variables to automatically fill in the email
subject and body, reducing the number of case reminder rule setting times.
For details about how to create variables, see 2.9.3.1.2 Customized Case
Field.

5. Click Save.

Step 2 (Follow-up operations) Access the case details page and change the case owner,
for example, transfer a case, restart a historical case, merge cases, restart a case,

or create a case. An automatic notification is triggered. You can click  to view
the email or SMS notification on the Notification Center page.

Figure 2-434 Transfer Case
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Figure 2-435 Notification Center

----End

Configuring Case Reminder Notification

Step 1 Click the Reminder Notice tab.

Figure 2-436 Reminder Notice

1. Enter a notification name.
2. Choose to send a case reminder via email or SMS message.
3. If the case title, case ID, case details link, or other fields do not have fixed

values during email filling, insert variables to automatically fill in the email
subject and body, reducing the number of case reminder rule setting times.

4. Click Save.

Step 2 (Follow-up operation) On the case details page, click  to manually send a case
reminder. Alternatively, on the case workbench, click reminder to manually send a
case reminder. After a case reminder is sent, the case owner receives the email or
SMS notification.
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Figure 2-437 Manually sending a case reminder

Figure 2-438 reminder button on the case workbench

Step 3 (Optional) If you use the Case for the first time and have not configured case

reminder notification, you can go to the case details page and click  to send a
case reminder. The system sends an email to the corresponding owner by default.

Figure 2-439 Case reminder notification disabled

----End

Configuring Customer Notification

Step 1 Click the Customer notice tab.
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Figure 2-440 Customer notice

1. View the default template provided for customer notification. By default, the
information shown in the preceding figure is used in the initial environment.

2. Modify the information as required.
3. Set parameters. All parameters on the Customer notice tab page are

mandatory.
4. Enter an email subject.
5. If the case title, case ID, case details link, or other fields do not have fixed

values during email body filling, insert variables to automatically fill in the
body, reducing the number of case reminder rule setting times.

6. Click Save.

Step 2 (Follow-up operation) Sign in to the AICC, choose Case 2.0 > Case Workbench,
and select Notified by Email or Notified by SMS when creating a case to notify
the customer after the case is created. Alternatively, go to the case details page,
change the case status, and select Notified by Email or Notified by SMS to
notify the customer of the case status change.

----End

2.9.3.1.9 Case Role

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Case Configuration 2.0 >
Case Configuration > Case Role.

Step 2 Click Create on the right, set role information, and click Save.
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Figure 2-441 Role information

Table 2-147 Permission description

Permissio
n
Category

Permission Description

Case close If this case permission is selected,
the Query All will be automatically
selected. Employees with this role
can view cases of all employees in
the tenant space and have the
permission to close cases of other
employees.

Query All If this case permission is selected,
employees with this role can view
cases of all employees in the tenant
space.

Transfer If this case permission is selected,
the Query All will be automatically
selected. Employees with this role
can view cases of all employees in
the tenant space and have the
permission to transfer cases of
other employees.

cancel If this case permission is selected,
the Query All will be automatically
selected. Employees with this role
can view cases of all employees in
the tenant space and have the
permission to cancel cases of other
employees.
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Permissio
n
Category

Permission Description

Recovery If this case permission is selected,
the Query All will be automatically
selected. Employees with this role
can view cases of all employees in
the tenant space and have the
permission to resume cases of
other employees.

restart If this case permission is selected,
the Query All will be automatically
selected. Employees with this role
can view cases of all employees in
the tenant space and have the
permission to restart cases of other
employees.

Pause If this case permission is selected,
the Query All will be automatically
selected. Employees with this role
can view cases of all employees in
the tenant space and have the
permission to suspend cases of
other employees.

Upgrade/downgrade If this case permission is selected,
the Query All will be automatically
selected. Employees with this role
can view cases of all employees in
the tenant space and have the
permission to upgrade or
downgrade cases of other
employees.

Editing If this case permission is selected,
the Query All will be automatically
selected. Employees with this role
can view cases of all employees in
the tenant space and have the
permission to modify case
information and status of other
employees.

Report If this case permission is selected,
employees with this role have the
permission to view case reports of
all employees.
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Permissio
n
Category

Permission Description

History Case If this case permission is selected,
the Query All permission will be
automatically selected. Employees
with this role have the permission
to view and restart historical cases.

Task Transfer If this task permission is selected,
employees with this role have the
permission to transfer tasks to
other employees.

Editing If this task permission is selected,
employees with this role can
modify tasks of other employees.

Case
Configurati
on

Configuration Management If this permission is selected,
employees with this role have the
case configuration permission.

 

----End

2.9.3.1.10 Case Queue

You can use case queues to create organizations and invite or remove members to
implement team management. If you select a queue when creating a case,
members in the queue can view the pending case.

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Case Configuration 2.0 >
Case Configuration > Case Queue.

Step 2 Click Create.

Step 3 Enter basic information, add members, and click Save.

----End

2.9.3.1.11 User Role

You can add or delete roles to manage the permissions of members.

Procedure

Step 1 Sign in to the AICC and choose Configuration Center > Case Configuration 2.0 >
Case Configuration > User Role.

Step 2 Click Create on the right to associate a role with a user. After you click Save, the
role is associated with the user.
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Figure 2-442 Associating a role with a user

----End

2.9.4 Case Handling

2.9.4.1 Creating a Case

Procedure

Step 1 Sign in to the AICC, choose Case 2.0 > Case Workbench, and click Create.
Alternatively, directly click the quick entry shown in Figure 2-444 to create a case.

Figure 2-443 Create button

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 830



Figure 2-444 Quick entry for creating a case

Step 2 On the Create Case page, set mandatory parameters and click Save.

NO TE

After a case is created, if data on the Case Workbench page is not refreshed, manually
refresh the page.

Figure 2-445 Create Case

● Case Type: The options are the enabled case types on the Configuration
Center > Case Configuration 2.0 > Case Configuration > Case Type page.

● Title: The value can contain a maximum of 128 characters.
● Content Description: The value can contain a maximum of 20,000 characters.
● Deadline: The value must be later than or equal to the current time.
● Priority: The options are Low, Medium, High, and Critical. Critical indicates

the highest priority.
● Source: Source channel of a case. The options are Voice, Whatsapp,

webchat, and Email.
● Associated Customer

1. The options are customers in the customer center. You can sign in to the
AICC as a tenant administrator and choose Customer Center > Customer
Center Management to view customers.
For details, see 2.12 Managing the Customer Center.
2. You can directly create a customer. For details, see 2.9.4.2 Creating a
Customer.
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NO TE

You can access the customer center only when the customer center feature is enabled
for the tenant space.

● Assignment Mode: The options are Manual and Auto. If this parameter is set
to Auto, the case will be assigned based on the case assignment rule on the
Case Configuration > Case Assignment Rule page. If this parameter is set to
Manual, you can assign the case to a skill queue or an agent.

● Attachment: The total size of attachments cannot exceed 5 MB, and the
number of attachments cannot exceed 5. JPG, PNG, PDF, JPEG, GIF, DOC, and
DOCX attachments are supported.

● Customer Notification--Email or Customer Notification--SMS: Whether to
send an email or SMS notification to the customer when the case status
changes. To use the notification function, you need to configure a customer
notification template in advance. For details, see 2.9.3.1.8 Case Reminder.

----End

2.9.4.2 Creating a Customer

When creating a case, if the customer to be associated is not maintained in the
system, you can directly create the customer and associate it with the case to
improve work efficiency. This helps you track the case progress and provide better
customer service when communicating with customers.

Procedure

Step 1 Sign in to the AICC, choose Case 2.0 > Case Workbench, and click Create.

Step 2 Click the Associated Customer selection box. The Associated Customer dialog
box is displayed.

Figure 2-446 Associated Customer
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Step 3 Click  and enter customer information. In the case of duplicate customer
names, enter correct phone numbers and email addresses to distinguish the
customers.

Step 4 Click .

Step 5 Search for and select the customer created in 3 based on the customer's name or
phone number.
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Figure 2-447 Associated Customer

Step 6 Click . The customer is associated with the case successfully.

----End

2.9.4.3 Viewing Cases Associated with a Customer
You can view historical cases associated with a customer and analyze the handling
processes and results of the cases to understand the customer's requirements and
promptly resolve the customer's problems. This helps you improve customer
satisfaction and loyalty.

Procedure

Step 1 Sign in to the AICC, choose Case 2.0 > Case Workbench, and click a case. The
case details page is displayed.

Step 2 In the Case Associated with the Customer area on the right, click a case to view
details about the historical case associated with the customer.
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Figure 2-448 Case Associated with the Customer

----End

2.9.4.4 Merging Cases

An agent can merge multiple cases of the same type to improve the work
efficiency.

Procedure

Step 1 Sign in to the AICC, choose Case 2.0 > Case Workbench, select cases of the same
type from the Todo list, and click Merge.

Figure 2-449 Merge

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 835



Step 2 After the merging is successful, a case is retained and a case track is generated.

NO TE

A maximum of five cases can be merged at a time.

----End

2.9.4.5 Transferring a Case

If you are no longer the owner of a case, you can transfer the case to a new
owner.

Procedure

Step 1 Sign in to the AICC, choose Case 2.0 > Case Workbench, and click the Todo or
Unassigned tab.

Step 2 Transfer cases one by one or in batches. After a case is transferred to a specified
owner, the owner has the permission to handle the case.

Figure 2-450 Transferring cases in batches

Step 3 Alternatively, click  on the details page of a case to transfer the case.

----End

2.9.4.6 Accepting a Case

You can handle a case in a queue only after accepting the case.

Procedure

Step 1 Sign in to the AICC, choose Case 2.0 > Case Workbench, and click the
Unassigned tab.

Step 2 Accept cases one by one or in batches. After accepting a case, you have the
permission to handle the case, and the case is added to the Todo list.
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Figure 2-451 Accepting cases

NO TE

A maximum of 100 cases can be accepted at a time.

----End

2.9.4.7 Searching for Cases

Procedure

Step 1 Sign in to the AICC, choose Case 2.0 > Case Workbench, enter a case title, and
press Enter to search for the case.

Step 2 Click Advanced Search and set advanced search criteria to search for cases.

Figure 2-452 Advanced Search

Step 3 Filter cases by tab page. You can view cases on the Todo, Unassigned, What I'm
concerned about, What I created, Processed, or All tab page.
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Figure 2-453 Tab page

Step 4 Click  to export cases based on filter criteria.

Step 5 Click  to customize the view. Select the columns to be displayed in the list. To
restore the default configuration, click Reset.
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Figure 2-454 Column configuration

----End

2.9.4.8 Case Details

Procedure

Step 1 On the Case Workbench page, click a case. The case details page is displayed.
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Figure 2-455 Case details page

Step 2 (Optional) On the right of the case details page, view customer information and
historical cases associated with the customer, or evaluate the case.

Step 3 You can perform the following operations on the case:

● : Follow an important or urgent case.

● : Send an email or SMS notification to urge the case owner to handle a
case that is about to expire. The prerequisite is that case reminder notification
has been configured. For details, see Configuring Case Reminder
Notification.

● : Upgrade the case level. After the upgrade, an upgrade flag is added to
the case title.

● : Suspend a case that does not need to be handled temporarily.

● : Transfer the case to change the case owner.

● : Cancel the case.

● : Close the case.

● : Restart the case.

● Comment on the Case Track tab page: Add comments when you handle the
case.

● Add Attachment: Add supplementary information for the case, for example,
fault screenshots provided by the customer. The total size of attachments
cannot exceed 5 MB, and the number of attachments cannot exceed 5. JPG,
PNG, PDF, JPEG, GIF, DOC, and DOCX attachments are supported.

● Create on the Case Task tab page: Create a task and trace the handling when
the case needs to be handled based on department collaboration.
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Figure 2-456 Create task

NO TE

Multiple tasks can be created for a case.

● Associated Case tab page: View associated cases after merging cases. For
details about how to merge cases, see 2.9.4.4 Merging Cases.

● Internal Record tab page: Only the case owner and tenant administrator
have the permission to perform operations on this tab page. An internal
record can contain a maximum of 20,000 characters. If an image needs to be
added, click Add Attachment to upload it.
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Figure 2-457 Internal Record

● InteractionId field: View contact records. Only contact records generated in
the last seven days can be viewed. If the case is created on the voice and
video workbench, a contact record ID is generated and displayed in the Case
Information area. Click an ID in blue to go to the contact record details page.

Figure 2-458 InteractionId

----End

2.9.4.9 Case Report

Prerequisites
● You have the Case Workbench permission.
● The Case 2.0 feature has been enabled for the tenant space.

Procedure

Step 1 Sign in to the AICC and choose Case 2.0 > Case Workbench.

Step 2 In the Overview area, view statistics on the Created Cases Today, Completed
Cases Today, Uncompleted Cases Today, Overdue unfinished case today, and
Average Handling Duration Today cards. Click a number in blue to view the
corresponding statistics in the case list.
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Figure 2-459 Number in blue

Step 3 Click Statistics Report. The Case Report page is displayed.

Figure 2-460 Statistics Report

Step 4 On the Case Report page, click the calendar control to set the date range for
querying the number of cases on each date. Data of the last 31 days (excluding
the current day) can be queried.

Figure 2-461 Case Report

Step 5 Select Case Classification from the drop-down list and select a case type to filter
cases by case type.
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Figure 2-462 Filtering cases by case type

----End

2.9.4.10 Handling a Task

Procedure

Step 1 Sign in to the AICC, choose Case 2.0 > Case Workbench, and click a case. On the

case details page, click the Task tab and click  to create a task.

Figure 2-463 Create task
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Step 2 Click . The task is created successfully.

Step 3 Click the Task tab, enter a task name, and press Enter to search for the task.

Step 4 Click Advanced Search and set advanced search criteria to search for tasks.

Figure 2-464 Advanced Search

Step 5 Click a task. The task details page is displayed.

Step 6 On the task details page, click  to transfer the task or click  to edit the
task.

Step 7 Click  to change the task status based on the current task
handling status.

----End

2.9.5 Historical Case

Prerequisites
● You have the Case Management 2.0 > Case > Historical Case permission.
● The case 2.0 feature has been enabled for the tenant space.

Procedure

Step 1 Sign in to the AICC and choose Case 2.0 > Historical Case. On the page that is
displayed, enter a case title to search for the case or set advanced search criteria
to search for cases.
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Figure 2-465 Historical Case page

Step 2 Click  to set the period for moving cases to the historical case list. The default
period is 90 days.

Figure 2-466 Setting Case to history cycle

NO TE

When a completed or canceled case in the tenant space reaches the configured period, the
case is moved to the historical case list.

Step 3 Click a case title to view the case details and task details.

Step 4 Click Restart to restart a historical case as a pending or completed case.
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Figure 2-467 Restarting a case

NO TE

You do not need to specify an owner when restarting a historical case as a completed case.

----End

2.9.6 FAQs
This section provides solutions to case operation questions to help you better use
case functions.

2.9.6.1 What Do I Do If Two Languages Are Displayed on the Case Page After
Language Switching

Symptom
After you switch the language, the language of some GUI elements is switched
successfully, but the language of some GUI elements remains unchanged, as
shown in 1.

Figure 2-468 Case workbench
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Analysis
The Case 2.0 is developed based on AppCube. If the language environment of the
Case 2.0 is different from that of AppCube, this problem occurs.

Solution
Switch the AICC language to another language and then switch it back. In this
way, the language environment of the Case 2.0 becomes consistent with that of
AppCube.

2.10 Managing Inspections
The AICC provides the manual and AI post-event inspection functions. This section
describes how to configure rating rules for inspectors to perform corresponding
inspections.

2.10.1 Overview on Inspection Management
Inspection management refers to post-event inspection managed to restrict and
rate agent statements and behavior during the service process, and evaluate their
service quality.

Currently, the system supports the following inspection modes:

● Manual inspection: The system allocates call records to an inspector based on
rules, and the inspector evaluates the recordings and manually rates them
based on the configured rating template.

● AI inspection: Specified rules are preset in the system, for example, the points
deducted when a sensitive word is found, or when the agent is silent for a
specified period or interrupts a customer. The system automatically identifies
all call records and allocates a proportion of the rated records to an inspector
based on manual review rules, and the inspector then rechecks the call
records.

The roles involved in an inspection are as follows:

● AI trainer: sorts out and configures the violation or compliance rules for an AI
inspection, for example, forbidden words and speaking speed limit. For
accuracy and fairness purposes, AI trainers check call recordings for multiple
times to adjust the rules.

● Inspection supervisor: reviews a result appeal submitted by an agent and
assigns the appeal to an inspector for reevaluation.

● Inspector: listens to call recordings and evaluates the service process
manually.

● Agent supervisor: reviews an appeal submitted by an agent.
● Agent: generates call records and recordings for an inspector or the system to

evaluate services. If an agent does not agree on an AI inspection result, the
agent can submit an appeal.

Currently, roles such as AI trainer, inspection supervisor, and agent supervisor are
not preset in the AICC. If you want to manage the tenant administrator and the

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 848



preceding roles separately, you can choose Configuration Center > Employee
Center > Role to create a role and add required menu permissions, or add
required menu permissions to an existing role. In general, employees with the
required menu permissions can perform the corresponding manual inspection
operations.

2.10.2 Typical Scenario: Configuring Manual Inspection Tasks
Manual inspection refers to the process in which an inspector extracts details from
call records based on specified inspection rules, plays back the records, and
evaluates agent services based on the rating criteria.

To enable the inspection, create rating items and templates, maintain inspection
relationships, and configure the policy for extracting call details in advance.

Prerequisites
You have configured Platform Role for the involved inspectors and agents on the
Configuration Center > Employee Center > Agent Management page.

Context
After the tenant space is enabled, the administrator needs to configure the
following items for inspectors in the tenant space to execute inspection tasks.
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Figure 2-469 Configuration flow

Scenario Description

The following rating rules are specified in a call center to evaluate the agent
standardized service, attitude, and skills during calls:

● Service Awareness

– Whether an agent answers questions effectively.

– Whether an agent confirms with a customer about other questions
before the service ends.

● Process Specifications

– Whether an agent begins with greetings and a self-introduction.

– Whether an agent ends a call with a statement similar to the following:
"Thanks for calling. If you have any additional questions, please call us."

● Service Attitude

– Whether an agent argues with a customer.

The current inspection task lasts one week.

Procedure

Step 1 Configure rating items.

1. Choose Configuration Center > Quality Management > Rating Item.
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2. Select the rating categories on the left in sequence and click Add on the right
to add the rating items in Context by referring to 2.10.3.1 Configuring
Rating Items.
Service Awareness, Process Specifications, and Service Attitude are preset.
If these categories are unavailable, they may be deleted by other operators.

Click  to add the categories.

Step 2 Configure a rating item template.

1. Choose Configuration Center > Quality Management > Rating Template.
2. Click Add on the right to add Agent inspection rating template by referring

to 2.10.3.2 Configuring Rating Templates.
3. Save the settings and click Release.

Step 3 Configure an inspection task.

1. Choose Quality Inspection > Inspection Task Management.
2. Click Add on the right to add Agent inspection task of September by

referring to 2.10.3.6 Configuring Inspection Tasks.
Set Task Type and Channel to Manual post-event inspection and Audio,
respectively.

NO TICE

Currently, the AICC supports manual post-event inspection only for voice and
multimedia channels. The features corresponding to other options will be
implemented in later versions.

If no inspector is available, check whether you have configured the Quality
checker role in Prerequisites.

3. Click Release.

----End

Follow-up Procedure
After an inspection task is added, the specified inspector can perform the
following operations within the task validity period:

1. Choose Quality Inspection > Inspection Task Management to view the
inspection task.

2. Click Task. On the page that is displayed, click Obtain To-Be-Inspected
Record to view the call records that can be inspected.
If no record is available, the inspector added to the inspection task has not
completed a call and generated a call record.

3. Click Start Inspection. On the Manual Inspection page, rate the desired
record based on the rating items and click Submit.

2.10.3 Managing Manual Inspections
This section describes how to configure the manual inspection management,
including the inspection score, inspection relationship, and inspection object.
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2.10.3.1 Configuring Rating Items
This section describes how to configure the rating items for the inspections on
agents.

Context
After the tenant space is enabled, the AICC provides the following rating
categories by default. You can add or modify the rating categories as required.

● Service Awareness
● Process Specifications
● Service Attitude

A maximum of five category levels are supported. Rating items can be added only
to the rating category of a leaf node. No rating category can be added to a rating
category that contains rating items.

The rating category name must be unique under the current tenant. The rating
item name must be unique under the current tenant.

A maximum of five levels can be created for a rating category tree.

Rating categories that contains rating items cannot be deleted. At least one rating
category must exist.

Business Scenario
An administrator adds the rating category Professional Skill and adds the rating
item Answering Proficiency to the category to specify the proficiency in
answering customer questions. The score ranges from 1 to 10.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Rating Item.

Step 2 Click  on the left to add the rating category Professional Skill under a root
category.

To add a category under a non-root node, click  and ensure that no rating item
exists under the selected parent category.

Step 3 Select the new category Professional Skill and click Add. The Add Rating Item
dialog box is displayed.

Step 4 Configure a rating item.
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Figure 2-470 Basic information in the Add Rating Item dialog box

Figure 2-471 Rating Level area in the Add Rating Item dialog box

Set the following parameters:

● Rating Item: Name of a rating item, for example, Answering Proficiency.
● Minimum Score: Lowest score for rating, for example, 1.
● Maximum Score: Highest score for rating, for example, 10.
● Rating Level: Click Add to add a rating level.

– Level Name: Name of the level to which a score belongs, for example,
Excellent.

– Score: Score corresponding to a rating level, for example, 10.
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– Description: Description of a rating level.
– Operation: Click Delete to delete a rating level.

Step 5 Click OK. The rating item configuration is saved.

----End

2.10.3.2 Configuring Rating Templates

A rating template contains rating items and their display sequence. When creating
an inspection task, you need to associate it with a rating template.

Context

You can configure different rating templates for inspection tasks in different
scenarios. For example, to evaluate the agent service quality during an inspection,
including the service attitude, clearness, instruction effectiveness, you can create a
template and add the preceding rating items to the template.

A rating template can be in Draft, Released, or Discarded state. The following
figure shows the relationships between the three states.

Figure 2-472 Life cycle of a rating template

Only a template in Released state can be associated with an inspection task. After
a task in Released or Draft state is deleted, the template enters the Discarded
state.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Rating Template.

Step 2 Click Add. On the Create Rating Template page, set template parameters.

Figure 2-473 Create Rating Template page

Set the following parameters:

● Template Name: Customized name, which is mandatory.
● Description: Template description, which is optional.
● Rating Item: Rating item. If multiple rating items are selected, their display

sequence can be adjusted.

Step 3 Click Save. The rating template configuration is complete, and the rating template
list page is displayed.

Step 4 Select the new template and click Release. In the dialog box that is displayed,
click YES to release the template.

Step 5 The message "The template is released successfully." is displayed, and the
template can be used.

----End

Follow-up Procedure

You can perform the following operations on a rating template in Draft state:

● Click Details to view the template content.
● Click Modify to modify the template.
● Click Discard to change the template status to Discarded. Discarded

templates cannot be modified, released, or used.

You can perform the following operations on a rating template in Released state:

● Click Details to view the template content.
● Click Discard to change the template status to Discarded. Discarded

templates cannot be modified, released, or used.
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● Click Withdraw to change the template status to Draft. Draft templates
cannot be used for rating.

You can perform the following operations on a rating template in Discarded state:

● Click Details to view the template content.

2.10.3.3 Managing Inspection Categories

Inspection category management includes the management of inspection
categories and inspection category items under the categories. After creating an
inspection category, you can add inspection category items for the category. You
can select multiple inspection categories when managing inspection object types.

Context

You can define inspection category items from different dimensions to categorize
inspection results. For example, you can define inspection category items from the
rating level and business type dimensions. If you associate the defined inspection
category with the inspection object type and inspection task, you can select the
rating level and business type when rating the records related to an inspection
task.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Inspection Category.

Step 2 Choose Add. In the Add Inspection Category dialog box, set category parameters.

Figure 2-474 Add Inspection Category dialog box

Set the following parameters:

● Category Name: Customized name, which is mandatory. The value can
contain a maximum of 1024 characters.

● Description: Category description, which is optional.
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● Enable Multiple Choice: Whether a category supports selection of multiple
category items. The options are Yes and No.

● SN: Display sequence of a category on the manual inspection page.

Step 3 Click OK. The category configuration is saved, and the inspection category list
page is displayed.

Step 4 Select the new inspection category and click Set Category Item. The Modify
Inspection Category Item page is displayed.

Figure 2-475 Modify Inspection Category Item page

Step 5 Click  to add a category item and set category item parameters.
● Name: Name of a category item.
● Description: Description of a category item.

Step 6 Click Save. The category item configuration is complete.

----End

Follow-up Procedure
Click Modify to modify an inspection category.

Click Delete to delete an inspection category that is no longer used.

2.10.3.4 Managing Inspection Object Types
Inspection category management includes the definition of inspection levels and
inspection category items for different object types. When creating an inspection
task, you need to select an inspection object type.

Context
You can define different object types based on agent capabilities or businesses. For
example, you can define common and VIP frontend and backend agents, and
define different inspection levels and categories for different object types.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Inspection Object Type.

Step 2 Click  to add an inspection object. Set basic information, inspection levels, and
category items as prompted, and click Save.
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Figure 2-476 Page for creating an inspection object type

Step 3 Set inspection object parameters.

1. Set Name and Description.
2. Click Add and set the parameters in the Inspection Level area.
3. Click Select Category Item and select category items.

Step 4 Click Save. The inspection object configuration is complete, and a saving success
message is displayed.

----End

2.10.3.5 Managing Inspection Relationships
A tenant space administrator manages the organizations to which inspectors
belong and allocates inspected tasks in a unified manner.

Context
You can define inspection relationships based on organizations and user groups.
For example, if you want to classify user organizations by province or city, you can
define inspection relationships to maintain the inspection relationships between
different organizations. For a single organization, you can define whether the
inspection relationship is applicable to all the members or lower-level
organizations of the organization. Similarly, this also applies to the user group. You
can select the relationship type when creating an inspection relationship. However,
only one inspection relationship can be used.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Inspection Relationship.
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Figure 2-477 Page for managing inspection relationships

Step 2 Click Add and set the name, description, and relationship type as prompted.

Figure 2-478 Page for creating an inspection relationship

Step 3 Click  on the right of the Inspector Group text box to select an inspector
group and inspectors.

Figure 2-479 Dialog box for selecting inspector members

Step 4 Click Select an inspected member. and select an inspected member.
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Figure 2-480 Dialog box for selecting an inspected member

Step 5 Click Save.

Step 6 Check that a message is displayed, indicating that the settings have been saved
successfully.

----End

Follow-up Procedure

Click Modify to modify an inspection relationship.

Click Delete to delete an inspection relationship that is no longer used.

2.10.3.6 Configuring Inspection Tasks

A tenant administrator can create, query, modify, release, or delete inspection
tasks, and configure inspection rules for inspectors.

Context

An inspection task can be in the Draft or Released state. In the Draft state, the
inspection task can be modified, deleted, or released. In the Released state, the
inspection task cannot be modified or deleted.

You can view the task details and results of released manual inspection tasks.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Inspection > Task
Mgmt.

Step 2 Click Add. The Create Inspection Task page is displayed.
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Figure 2-481 Create Inspection Task page

Step 3 Configure basic inspection task information.
● Task Name: Task name, which is customized. The value can contain a

maximum of 1024 characters.
● Task Type: The options are Manual post-event inspection and Automatic

post-event inspection.
● Channel: Call channel. The options are Audio, Video, and Multimedia.
● Total Number of Inspections: Number of inspections to be performed. The

value is an integer ranging from 0 to 99999.
● Start Time: Start time of an inspection task.
● End Time: End time of an inspection task.
● Call Begin Time: Start time of the communication in an inspection task.
● Call End Time: End time of the communication in an inspection task.
● Inspection Object Type: Inspection object type. For details about how to

configure inspection object types, see 2.10.3.4 Managing Inspection Object
Types.

● Inspection Relationship Type: Inspection relationship type. The options are
Custom, By organization, and By user group.

● Customer Number: Customer number. The value can contain a maximum of
50 characters.

● Satisfaction: Satisfaction. The default options are Very dissatisfied,
Dissatisfied, General, Satisfied, and Very satisfied.
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● Call Type: Call type. The options are Outgoing Call, Incoming Call,
Predicted outbound call, Preview outgoing call, Collaborative call, and
Click-to-dial.

● Call Duration Range (s): Call duration range. The value is an integer ranging
from 0 to 9999.

Step 4 If Inspection Relationship Type in the BASIC INFORMATION area is set to
Custom, configure INSPECTOR INFORMATION and INSPECTED PARTY
INFORMATION.

● INSPECTOR INFORMATION

a. Click Select Inspector Member. The inspector information configuration
page is displayed.

Figure 2-482 Page for selecting users

b. Set Select an OU or a user group. and select a specific group or OU.

c. Select inspector accounts and click OK to save the inspector information.

● INSPECTED PARTY INFORMATION

a. Click Select an inspected member. to access the information
configuration page.

Figure 2-483 Page for selecting users

b. Set Select an OU or a user group. and select a specific group or OU.

c. Select inspected member accounts and click OK to save the inspected
member information.

Step 5 If Inspection Relationship Type in the BASIC INFORMATION area is set to By
organization or By user group, configure INSPECTION RELATIONSHIP.

1. Click Select Inspection Relationship. The relationship list page is displayed.
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Figure 2-484 Page for selecting inspection relationships

2. Select inspection relationships. For details about how to configure inspection
relationships, see 2.10.3.5 Managing Inspection Relationships.

3. Click OK to save the selected inspected relationships.

Step 6 Configure a rating template.

In the RATING TEMPLATE area, select a template and click Save to generate an
inspection task. Manual inspection rating templates in Released state are
displayed in the area. You can click Preview in the Operation column to preview a
template.

Figure 2-485 Area for selecting a rating template

Step 7 (Optional) Choose Inspection > Task Mgmt, query inspection tasks, and click
Download The Inspection Result to export the Task Result of the inspection
tasks to a file.

NO TE

The downloaded data contains personal data. Exercise caution when processing the
downloaded data to prevent personal data leakage and abuse.

----End

2.10.3.7 Viewing All Inspection Results

A tenant administrator can view all inspection results.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Inspection > Task
Result.

Step 2 Set search criteria and click Search to obtain the search result. Click Reset to clear
the existing search criteria.

Step 3 Click Details in the Operation column corresponding to an inspection result to go
to the Manual Inspection page.
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Figure 2-486 Page for searching for inspection results

----End

2.10.4 Typical Scenario: Configuring AI Inspection Tasks
AI inspection refers to the process in which the AICC automatically rates agent call
records based on specified rules such as wording, pause, and silence during a call
between an agent and a customer. This reduces the inspection workload and labor
cost in the call center. In addition, the AICC supports the second inspection by an
inspector to supplement the AI inspection result, which avoids misjudgment.

Prerequisites
● You have set positions for employees involved in AI inspection on the

Configuration Center > Employee Center > Employee page.

The titles and corresponding operations are as follows:
– Inspection Supervisor: allocates an agent appeal application to an

inspector.
– Inspector: performs the second inspection based on the AI inspection

result.
– Agent Director: reviews the appeal application submitted by an agent.
– Agents: provides call records for inspection and files possible appeals.
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NO TICE

You have synchronized the preceding personnel titles to the AI inspection
engine (currently, a third-party AI inspection engine).
By default, the AICC synchronizes information to the AI inspection engine
every 10 minutes. If the information modified in the AICC is required, wait for
10 minutes before performing operations.

● You have configured Platform Role for the involved inspectors and agents on
the Configuration Center > Employee Center > Agent Management page.

Context
After the tenant space is enabled, the administrator needs to configure the
following items for the AICC to execute AI inspection tasks.
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Figure 2-487 Configuration flow

Scenario Description

The following AI inspection scenarios and sample inspection plans are specified in
a call center:

● Points are deducted if an agent does not begin with a self-introduction.

● Points are deducted if agent statements contain abusive words during a call.

● Points are deducted if an agent pauses for more than 5 seconds during a call
without telling a customer "Please wait".
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● Points are deducted if an agent interrupts a customer during a call.
● All call records are inspected intelligently and 5% of them are inspected

manually.
● The rating items for manual sample inspection are the same as those for

manual post-event inspection.

Procedure

Step 1 Configure semantics and keywords.

1. Choose Configuration Center > Quality Management > Sentence.
2. Add the following tags by referring to 2.10.5.1 Managing Sentences.

Table 2-148 Configuring semantics and keywords

Tag
Name

Tag Type Description

Self-
introducti
on at the
beginning

Semantics Hello, this is agent ABC of the
XXX call center.

Sensitive
words

Keyword Use commas (,) to separate
multiple sensitive words.

Waiting
prompt

Semantics Please wait.
Please wait a moment.
Please hold on.

 

Step 2 Configure sentences.

1. Choose Configuration Center > Quality Management > Sentence.
2. Click Create Sentence in the upper right corner to add a sentence for each of

the three tags in the previous step. For details, see 2.10.5.1 Managing
Sentences.

3. Click Training Quality Inspection Model in the upper right corner to train
semantics, keywords, and related configurations.

Step 3 Configuring inspection rules.

1. Add a dialog rule by referring to 2.10.5.3.2 Configuring Dialog Rules.
Based on the scenario, you can add two dialog rules. One is used to check
whether an agent begins with a self-introduction, and the other is used to
check whether sensitive words are contained in a call.
The following uses the rule Introduction at the call beginning as an
example.
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During the configuration, pay attention to the following points:
– Scoring Method and Implementation Mode: used to configure whether

the rule is mandatory for compliance and whether the score is deducted
when the rule logic is met.
For example, if Scoring Method and Implementation Mode are set to
Deducted point and This rule is mandatory for compliance,
respectively, the rule is mandatory for compliance and no point is added
or deducted when its logic is met. When its logic is not met, points are
deducted. Similarly, if Scoring Method and Implementation Mode are
set to Added point and This rule is forbidden for compliance.,
respectively, the rule is forbidden for compliance and no point is added or
deducted when its logic is not met. When its logic is met, points are
added.

– Number of Matched Dialog Logic: The current rule is met only when a
specified number of logics are successfully matched in the rule.
Occurrence in the Dialog Logic area: The logic is met only when it
occurs for the number of specified times.

– Configure the optional items properly, including Description and Trigger
Condition. If these items are not configured, the inspection rule cannot
be associated in subsequent configuration due to incompleteness.

2. Add a silence rule by referring to 2.10.5.3.1 Configuring Silence Rules, as
shown in the following figure.
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Step 4 Configure an inspection rating rule. For details, see 2.10.5.4 Configuring
Inspection Rating Rules.

Step 5 Configure a business scenario.

1. For details, see 2.10.5.5 Configuring Business Scenarios.

In the preceding configuration, Inspection Rule for Sensitive Word specifies
whether to display sensitive word violations in inspection reports. Currently,
the AICC does not rate sensitive words. For details about how to configure
sensitive words, see 2.10.5.1 Managing Sentences.

2. On the Business Scenario page, click Enable next to the new business
scenario.

Step 6 Configure a sample inspection plan. For details, see 2.10.5.7 Configuring Sample
Inspection Plans.
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NO TICE

If no inspector or agent is available, check whether the corresponding titles in
Prerequisites have been added for the employees.

----End

Follow-up Procedure
After operations in Step 5 are complete, the administrator can view the AI
inspection result by referring to 2.10.5.6 Viewing AI Inspection Results.

After the operation in Step 6 is complete, the inspector can execute the inspection
task by referring to 2.10.5.8 Creating Sample Inspection Tasks.
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2.10.5 Managing AI Inspections (Self-Developed)
Tenant administrators can configure sentences, sensitive words, inspection rules,
and scores to implement intelligent inspection management.

2.10.5.1 Managing Sentences
Sentences consist of a group of elements such as semantics and keywords to
generally specify a complete purpose. This section describes how to manage
sentences.

Context
Sentences are used to form rules. You can classify and manage sentences.

Sentences can be added on the GUI.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Sentence.

Step 2 Click  to add a sentence category.

Step 3 Enter a sentence category name and click OK.

Step 4 Select the configured sentence category and click Create Sentence. The Create
Sentence page is displayed.

Step 5 Configure a sentence.

1. Enter Sentence Name and select Sentence Category. The category to which
a new sentence belongs can be modified.

2. Select Semantics and keyword and click Add. The Add Label page is
displayed.

3. Set Tag Type, configure Synonymous Corpus and Antonym Corpus, click
Add, and click OK. The tag is added.

4. On the Create Sentence page, click OK. If the sentence is created
successfully, the message "Operation succeeded" is displayed. In the dialog
box that is displayed, click OK.

Step 6 (Optional) If your sentence category is improper, select the sentence and click
Move Category to move the sentence to the new category.

----End

2.10.5.2 Managing Sensitive Words
This section describes how to configure sensitive words in inspection rules for
inspection management.

Context
Sensitive words in inspection rules can be configured and managed by category.
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Sensitive words can be added on the GUI.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Sensitive Word.

Step 2 Click  to add a sensitive word category.

Step 3 Enter a sensitive word category name and click OK.

Step 4 Select the created sensitive word category and click Add Sensitive Word. On the
page that is displayed, set the parameters as required and click OK.

Step 5 (Optional) To move a sensitive word to a new category, select the sensitive word
and click Move Category.

----End

2.10.5.3 Configuring Inspection Rules

Inspection rules include silence rules, dialog rules, speed rules, and interruption
rules. This section describes how to manage and configure these rules.

2.10.5.3.1 Configuring Silence Rules

The behavior of an agent can be reviewed based on the duration in which the
agent falls silent in a call. This section describes how to maintain silence rules.

A silence rule regulates the silence duration in a conversation between an agent
and customer. If the silence duration is too long, it may affect the satisfaction of
the customer. Therefore, silence rules can be configured to review agents on the
Inspection Rule page. For some special situations, for example, a customer needs
to find something in a call with an agent. During this period, the agent falls silent.
In this case, exception rules can be set for reviewing agents more fairly

Silence rules can be created on the GUI.

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Quality Management > Inspection Rule, and click the SILENCE RULE tab.

Step 2 Click Add Rule. The Add Silence Rule page is displayed.

Figure 2-488 Adding a silence rule
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Figure 2-489 Exception settings

Step 3 Set parameters as required and click Save. The silence rule is added successfully.

----End

2.10.5.3.2 Configuring Dialog Rules

A dialog rule contains basic rule information, inspection conditions, and dialog
logic. A dialog logic contains the dialog content which describes what the
customer and agent need to say in different call phases.

Context
You can configure different dialog rules to be referenced when business scenarios
are configured. For example, you can configure an agent introduction in a dialog
rule for the return visit scenario, including the employee ID and thanks. The
introduction semantics can be configured on the Sentence and Semantic/
Keyword pages. To configure a complete dialog rule, you can reference a series of
sentences to form a dialog logic.

Dialog rules can be created on the GUI.

Procedure
Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >

Quality Management > Inspection Rule, and click the DIALOG RULE tab.

Step 2 Click Add Rule and configure rule information.

Figure 2-490 Creating a dialog rule

● Basic Information includes Rule Name, Description, Rule Type, Scoring
Method, Rule Score, Implementation Mode, and Number of Matched
Dialog Logic.
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● Trigger Condition includes Call Start Time and Call End Time.

Step 3 Configure the dialog logic.

1. Click Add Dialog Logic, and set the dialog logic name and number of
occurrences as prompted.

2. Click Add Dialog Content, and set the call phase, dialog role, dialog rule,
sentence category, and sentence content as prompted.

3. Click  to add a sentence category and a sentence. Click  to delete a
sentence category and a sentence. Click Delete to delete the dialog content.

4. Click Preview to preview the added dialog logic. On the preview page, click
Modify to modify the dialog logic. On the preview page, click Delete to
delete the undesired dialog logic.

Figure 2-491 Adding and modifying a dialog logic

Figure 2-492 Previewing a dialog logic

Step 4 Click Save to save the dialog rule and return to the DIALOG RULE page.

----End

Follow-up Procedure

On the DIALOG RULE page, you can click Search to search for desired dialog rules
based on the search criteria, click Reset to reset the search criteria, click View to
modify the dialog rules, and click Delete to delete undesired dialog rules.

Figure 2-493 DIALOG RULE page
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2.10.5.3.3 Configuring Speed Rules

A speed rule contains basic rule information, inspection conditions, and exception
sentences. In a scenario where an exception sentence exists, the violation rule is
not met.

Context

You can configure different speed rules to be referenced when business scenarios
are configured.

Speed rules can be created on the GUI.

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Quality Management > Inspection Rule, and click the SPEED RULE tab.

Figure 2-494 SPEED RULE page

Step 2 Click Add Rule and configure rule information.

Figure 2-495 Creating a speed rule

● Basic information includes Rule Name, Deducted Point, Min. Speaking
Speed, and Max. Speaking Speed.

● Trigger Condition includes Call Start Time and Call End Time.

Step 3 Configure parameters for exception settings.

1. Click +Add Sentence, and set the sentence category and sentence content.
2. Click Delete to delete the created sentence.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 875



Step 4 Click Save to save the speed rule and return to the SPEED RULE page.

----End

Follow-up Procedure
On the SPEED RULE page, you can click Search to search for desired speed rules
based on the search criteria, click Reset to reset the search criteria, click View to
modify the speed rules, and click Delete to delete undesired speed rules.

Figure 2-496 Speed rules

2.10.5.3.4 Configuring Interruption Rules

An interruption rule contains the rule name, upper limit for crosstalk seconds and
times, deducted points, and trigger conditions.

Context
When an agent and a customer speak at the same time, the agent is regarded as
interrupting the customer during the call. You can configure different interruption
rules to be referenced when business scenarios are configured. In an interruption
rule, you can configure the upper limit for crosstalk seconds and times to
determine whether an agent is compliant with the rule during a call. If the rule is
violated, points are deducted.

Interruption rules can be created on the GUI.

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Quality Management > Inspection Rule, and click the INTERRUPTION RULE
tab.

Step 2 Click Add Rule and configure rule information.

Figure 2-497 Creating or modifying an interruption rule

● Basic information includes Rule Name, Deducted Point, Crosstalk (s), and
Crosstalk (Times).
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● Trigger Condition includes Call Start Time and Call End Time.

Step 3 Click Save to save the interruption rule and return to the INTERRUPTION RULE
page.

----End

2.10.5.4 Configuring Inspection Rating Rules
You can customize inspection rating rules for AI inspection tasks. This section
describes how to set inspection scores.

Business Scenario
An inspection trainer sets inspection scores for an insurance industry template
online. The start score, minimum score, and maximum score are set to 80, 0, and
100, respectively.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Appraise Score Setting.

Step 2 Click Add to add an inspection rating rule.

Step 3 Configure a rating item.

Set Rule Name, Start Score, Minimum Score, and Maximum Score.

Step 4 Click OK to save the rating configuration.

Step 5 Click Apply to apply the new inspection rating rule. The inspection rating rule is
then applied to the AI inspection of call recording.

----End

2.10.5.5 Configuring Business Scenarios
Inspection business scenarios can be configured. Each scenario contains multiple
inspection rules. The system implements AI inspections based on business
scenarios.

Context
A business scenario is a set of multiple inspection rules. A condition can be set for
a business scenario. Calls that meet the condition will be inspected. An inspection
rule can belong to multiple business scenarios. For example, a call of a business
department belongs to business scenario A. After the business scenario is
modified, inspected calls will not be inspected again. Only new calls belong to this
modified business scenario will be inspected.

Only business scenarios in Enabled state can be used for AI inspections. You can
manually switch the business scenario states.

You can maintain business scenarios by adding them on the GUI or by importing
them offline.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 877



In the offline scenario, you can fill in an Excel template offline and import
elements such as business scenarios, semantics, keywords, sensitive words,
sentences, and rules for specified AI inspection tasks.

NO TE

Data that is not associated with businesses can be imported individually. For example, to
import a sensitive word associated with a sentence, you need to configure the
corresponding sentence data. If the sensitive word is not associated with a sentence, you
can directly import it.

In the Excel template scenario, pay attention to the following:

● One sheet corresponds to the configuration item of one element. When a
template is imported, only the configuration items corresponding to the sheet
with content are updated.
The following lists the sheets in a template and the corresponding content to
be entered:
– business-scenario: Enter business scenarios.
– intent-category: Enter sentences.
– intent-corpus: Enter the semantics content.
– intent-rule-corpus: Enter keywords.
– sensitive-group-word: Enter sensitive words.
– dialog-rule: Enter the basic content of dialog rules.
– dialog-flow: Enter the logic content of dialog rules.
– dialog-sentence-group: Enter sentences of dialog rules.
– silence-rule: Enter the content of silence rules.
– speed-rule: Enter the content of speed rules.
– interruption-rule: Enter the content of interruption rules.

● The business scenarios in each sheet are identified by name. If the name of a
business scenario is different from that of the element of the same type in the
system, the configuration item can be added. If they are the same, the
configuration item cannot be added.

NO TE

If the name of a business scenario already exists in the system, update the name of
the existing business scenario.

● The column names in the Excel file can be modified based on site
requirements, but they cannot be deleted. In addition, the sequence of each
column must be fixed. Otherwise, errors may occur during the import.

● Pay attention to special characters in the Excel file, such as < (less-than sign)
and > (greater-than sign), which indicates hypertext tags. Otherwise, the
import may fail.

Procedure
Scenario 1: Adding a business scenario online

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Business Scenario.
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Step 2 Click Add to add a business scenario.

Step 3 On the Add Business Scenario page, set Name, Description, Call Start Time, and
Call End Time, set Inspection Type to Voice Type or Text Type, select inspection
rules, and click Save.

Step 4 In the dialog box that is displayed, click OK.

----End

Scenario 2: Importing business data offline

Step 1 Download the import template from the GUI.

Step 2 Fill in the sheets of the import template by referring to the following table.

NO TICE

The content on each sheet is imported to the corresponding configuration page in
the system. If data with the same name exists on the configuration page, the
import fails.

Table 2-149 business-scenario sheet

Column Description Value Example

Scenario
Name

Business scenario name. This
column is mandatory.

-

Scenario
Description

Business scenario description. -

Ignore
Sensitive
Words

Whether to ignore sensitive words.
This parameter is mandatory.
● 0: no
● 1: yes

1

Scenario
Status

Whether a business scenario is
enabled. This parameter is
mandatory.
● 0: no
● 1: yes

1

Call Start
Time

Call start time.
Format: YYYY/MM/DD HH:MM:SS

-

Call End
Time

Call end time.
Format: YYYY/MM/DD HH:MM:SS

-

Dialog
Rule

Dialog rule, which must be
configured in the dialog-rule sheet.

-
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Column Description Value Example

Silence
Rule

Silence rule, which must be
configured in the silence-rule sheet.

-

Speed Rule Speed rule, which must be
configured in the speed-rule sheet.

-

Interruptio
n Rule

Interruption rule, which must be
configured in the interruption-rule
sheet.

-

Interaction
Type

Interaction type of a business
scenario. If this parameter is not set,
the voice type is used by default.
● 0: voice type
● 2: text type

0

 

Table 2-150 intent-category sheet

Column Description Value Example

Sentence
Category Name

Sentence category name. This
column is mandatory.

-

Sentence Name Sentence name. This column is
mandatory.

-

Sentence
Category Usage

Sentence category usage.
● dialog_rule: dialog rule
● speaker_identify_rule: rule for

distinguishing speaker roles

dialog_rule

 

Table 2-151 intent-corpus sheet

Column Description Value Example

Sentence Name Sentence name. This column is
mandatory.

-

Corpus Semantic name. This column is
mandatory.

-

Language Semantic internationalization.
This column is mandatory.
● zh_CN: Chinese
● en_US: English

-
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Column Description Value Example

Negative
Sample

Whether the corpus is an
antonym corpus. This column is
mandatory.
● false: synonym corpus.
● true: antonym corpus.

-

Full Match Whether the semantic content
needs to be fully matched. This
column is mandatory.
● false: partial match.
● true: full match.

false

 

Table 2-152 intent-rule-corpus sheet

Column Description Value Example

Sentence Name Sentence name. This column is
mandatory.

-

Corpus Keyword. This column is
mandatory.

-

Language Keyword internationalization. This
column is mandatory.
● zh_CN: Chinese
● en_US: English

-

Negative
Sample

Whether the corpus is an
antonym corpus. This column is
mandatory.
● false: positive sample.
● true: negative sample.

-

Full Match Whether full match is required for
the keyword content. This column
is mandatory.
● false: partial match.
● true: full match.

false

 

Table 2-153 sensitive-group-word sheet

Column Description Value Example

Sensitive Word
Category Name

Sensitive word category name.
This column is mandatory.

-
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Column Description Value Example

Sensitive Word Sensitive word. This column is
mandatory.

-

Score Rule score, which indicates that
points are deducted for violation.
This column is mandatory.
The value is an integer ranging
from –100 to 0. If this parameter
is left empty, the value 0 is
automatically assigned. If a
decimal point exists, round down
the value.

-5

Agent
Exception

Sentence name.
Multiple sentences can be
separated by vertical bars (|).

Sentence name 1|
Sentence name 2

Customer
Exception

Sentence name.
Multiple sentences can be
separated by vertical bars (|).

Sentence name 2

 

Table 2-154 rule-dialogue sheet

Column Description Value Example

Rule Name Dialog rule name. This column is
mandatory.

-

Rule
Description

Description of a dialog rule. -

Score Rule score. This column is
mandatory.
The value is an integer ranging
from –100 to +100. If this
parameter is left empty, the value
0 is automatically assigned. If a
decimal point exists, round down
the value.
● If the rule is used for point

deduction, points deducted for
violation are displayed.

● If the rule is used for point
adding, points added for
compliance are displayed.

● If the rule score is 0, the score
is not calculated.

-5
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Column Description Value Example

Rule Type Rule type. This column is
mandatory.
● normal: general rule.
● critical: important rule.

normal

Rule Mode Rule mode. This column is
mandatory.
● positive: positive rule. This rule

is mandatory for compliance.
● negative: negative rule. This

rule is mandatory for violation.

negative

Number of
Dialog Logics
for Compliance

Number of dialog logics for
compliance. This column is
mandatory.
The value is an integer ranging
from 1 to 100. If a decimal point
exists, round down the value.

1

Trigger Start
Time

Call start time.
Format: YYYY/MM/DD HH:MM:SS

-

Trigger End
Time

Call end time.
Format: YYYY/MM/DD HH:MM:SS

-

 

Table 2-155 dialog-flow sheet

Column Description Value Example

Dialog Logic
Name

Dialog logic name. This column is
mandatory.

-

Dialog Rule Dialog rule name. This column is
mandatory.

-

Sentence Group
Name

Name of the sentence group. This
column is mandatory.
Multiple sentence groups can be
separated by vertical bars (|).

Sentence group name 1|
Sentence group name 2
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Column Description Value Example

Expression Expression of a sentence group.
● must: must say
● must|then: must say|goes on

saying
● must|and: must say|also says
● must|and|then: must say|also

says|goes on saying
● if|after: Before the previous

sentence|must say
● if|after|and: Before the previous

sentence|must say|also says
● if|after|then: Before the

previous sentence|must say|goes
on saying

● if|iand: If says|must say (Either)
● if|iand|and: If says|must say

(Either)|also says
● if|iand|then: If says|must say

(Either)|goes on saying
● if|then not: cannot say
● if|then: After the previous

sentence|must say
● if|then|and: After the previous

sentence|must say|also says
● if|then|then: After the previous

sentence|must say|goes on
saying

if|then not

Minimum
Number of
Repetitions

Number of times the dialog logic is
repeated.
The value is an integer ranging
from 2 to 127. If a decimal point
exists, round down the value.

-

 

Table 2-156 dialog-sentence-group sheet

Column Description Value Example

Sentence Group
Name

Sentence group name. This
column is mandatory.

-

Dialog Rule
Name

Dialog rule name. This column is
mandatory.

-
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Column Description Value Example

Dialog Logic
Name

Dialog logic name. This column is
mandatory.

-

Dialog Type Dialog rule type. This column is
mandatory.
● must: must say
● if: if says
● must_say: must say
● must_not_say: cannot say
● then: goes on saying
● and: also says

-

Optional Reserved field. This parameter is
mandatory.
● true: optional
● false: mandatory

-

Dialog Role Matching role, which specifies
whether a customer or an agent
speaks in a dialog rule. This
column is mandatory.
● any: not specified.
● staff: agent.
● customer: customer

any

Call Phase Call phase.
● any: not specified.
● top: beginning of a call.
● bottom: end of a call.
● set: sets the interval.

any

Interval Call interval. The value ranges
from 1 to 9999. The value must
be an integer. If a decimal point
exists, round down the value.
This column is mandatory only
when Call Phase is set to top,
bottom, or set.

-

Sentence Sentence name.
Multiple sentences can be
separated by vertical bars (|).

-
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Table 2-157 silence-rule sheet

Column Description Value Example

Rule Name Name of a silence rule. This
column is mandatory.

-

Score Rule score. This column is
mandatory.
The value is an integer ranging
from –100 to 0. If this parameter
is left empty, the value 0 is
automatically assigned. If a
decimal point exists, round down
the value.

-5

Consecutive
Silence Seconds
for Violation

Consecutive silence seconds for
violation. This column is
mandatory.
The value is an integer ranging
from 1 to 2147483647. If a
decimal point exists, round down
the value.

3

Number of
Silence Times
for Violation

Number of silence times for
violation. This column is
mandatory.
The value is an integer ranging
from 1 to 2147483647. If a
decimal point exists, round down
the value.

1

Trigger Start
Time

Call start time.
Format: YYYY/MM/DD HH:MM:SS

-

Trigger End
Time

Call end time.
Format: YYYY/MM/DD HH:MM:SS

-

Exception
Settings for an
Agent Before
Silence

Exception settings for an agent
before silence. Enter the sentence
name. Multiple sentences can be
separated by vertical bars (|).

Sentence name 1|
Sentence name 2

Exception
Settings for a
Customer
Before Silence

Exception settings for a customer
before silence. Enter the sentence
name. Multiple sentences can be
separated by vertical bars (|).

Sentence name 1|
Sentence name 2

Exception
Settings for an
Agent After
Silence

Exception settings for an agent
after silence. Enter the sentence
name. Multiple sentences can be
separated by vertical bars (|).

Sentence name 1|
Sentence name 2
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Table 2-158 speed-rule sheet

Column Description Value Example

Rule Name Name of a speed rule. This
column is mandatory.

-

Score Rule score. This column is
mandatory.
The value is an integer ranging
from –100 to 0. If this parameter
is left empty, the value 0 is
automatically assigned. If a
decimal point exists, round down
the value.

-5

Minimum
Number of
Words/min

If the value is less than the value
of this parameter, the speaking
speed is too low and a violation is
met. This parameter is
mandatory.
The value is an integer ranging
from 1 to 220. If a decimal point
exists, round down the value.

180

Maximum
Number of
Words/min

If the value is greater than the
value of this parameter, the
speaking speed is too high and a
violation is met. This parameter is
mandatory.
The value is an integer ranging
from 1 to 2147483647. If a
decimal point exists, round down
the value.

300

Trigger Start
Time

Call start time.
Format: YYYY/MM/DD HH:MM:SS

-

Trigger End
Time

Call end time.
Format: YYYY/MM/DD HH:MM:SS

-

Customer
Statement
When the
Speed Is Higher
Than the
Maximum

Customer statement when the
speed is higher than the
maximum. Enter the sentence
name. Multiple sentences can be
separated by vertical bars (|).

Sentence name 1|
Sentence name 2

Customer
Statement
When the
Speed Is Lower
Than the
Minimum

Customer statement when the
speed is lower than the minimum.
Enter the sentence name.
Multiple sentences can be
separated by vertical bars (|).

Sentence name 1|
Sentence name 2
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Table 2-159 interruption-rule sheet

Column Description Value Example

Rule Name Name of the interruption rule.
This column is mandatory.

-

Score Rule score. This column is
mandatory.
The value is an integer ranging
from –100 to 0. If this parameter
is left empty, the value 0 is
automatically assigned. If a
decimal point exists, round down
the value.

-5

Crosstalk
Duration (s)

Crosstalk seconds. This column is
mandatory.
The value is an integer ranging
from 1 to 10000. If a decimal
point exists, round down the
value.

5

Number of
Crosstalks

Number of crosstalk times. This
column is mandatory.
The value is an integer ranging
from 1 to 10000. If a decimal
point exists, round down the
value.

1

Trigger Start
Time

Call start time.
Format: YYYY/MM/DD HH:MM:SS

-

Trigger End
Time

Call end time.
Format: YYYY/MM/DD HH:MM:SS

-

 

Step 3 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Business Scenario.

Step 4 Click Import to import the business scenario file.

If the import fails, the system displays the message "Failed to import the file.
Check the data." In the dialog box that is displayed, click OK to reselect the
business scenario file.
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Step 5 Click OK. The task is successfully imported.

Step 6 (Optional) Select a business scenario and click Export. A message is displayed,
asking you whether to download the business scenario. After you click OK, the
business scenario is exported successfully.

The dialog rules associated with the selected business scenario cannot contain
sentences or sensitive words in the Uncategorized category. Otherwise, the
exported Excel file cannot be imported.

Figure 2-498 Uncategorized page

NO TE

A maximum of 100 records can be exported.
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Figure 2-499 Confirmation dialog box

----End

2.10.5.6 Viewing AI Inspection Results
A tenant administrator can query inspection records. After call files are uploaded,
the AI inspection and manual review results can be viewed.

Context
A tenant administrator can upload desired call files. The AI inspection system
checks the business rules for the call recordings on the backend to determine
whether the customer or agent violates the rules. For example, the system checks
whether dirty words or sensitive words exist. This improves inspection efficiency.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Quality Inspection >
Inspected Call List.

On the Inspected Call List page, brief search criteria and the list of inspected calls
are displayed.

Step 2 Click Upload Call to upload the desired calls. Set File Type to Audio or Text, click
 to select a file from the local PC, set other information, and click OK to upload

the file.

NO TE

A text file must be in CSV format, and its size cannot exceed 1 MB. If the file contains
Chinese characters, set the CSV encoding format to UTF-8 or use the template to upload.

Step 3 (Optional) On the Inspected Call List page, click To-Be-Inspected Call List to
switch from the completed call list to the pending call list.

Step 4 Click View in the list. The Inspected Call Details page is displayed.

Step 5 Click  on the left to switch between the session content
page and the call information page as required.

Step 6 Click  of the recording player to play the recording. You can click  or  to
rewind or fast-forward the recording for 10 seconds.
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Step 7 Click Audio Track Marking. A red dot is displayed in the player on the left, and
you can click the red dot to locate the audio track. Click Unmark Audio Tracks.
The red dot is hidden in the player on the left

Step 8 (Optional) Implement fuzzy search in the text box. The keywords are highlighted
in the dialog box below. On the Call Information tab page, you can view the call
information details.

Step 9 (Optional) Click Switch Speaker Role and click YES in the dialog box that is
displayed to exchange the customer role with the agent role. The call is inspected
again and the inspection result is updated.

Step 10 (Optional) Click  next to an agent or customer to play the corresponding voice.

Step 11 Click Switch to Other Inspection Scenarios. The page for selecting an inspection
scenario is displayed on the right.

After an inspection scenario is selected, the details about the scenario are
displayed in the table on the main page.

----End

2.10.5.7 Configuring Sample Inspection Plans
An inspection supervisor needs to configure a scheduled sample inspection plan
before creating manual sample inspection tasks to re-inspect the calls that have
been intelligently inspected.

Context
An inspection supervisor can set a scheduled sample inspection plan to perform
the intelligent sample inspection. The inspection supervisor can assign new sample
inspection tasks to inspectors.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Quality Inspection >
Spot-Check Plan.

Step 2 Click New to create and configure a sample inspection plan.

Step 3 Configure the new sample inspection plan.
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Figure 2-500 Add Sample Inspection Plan page
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Figure 2-501 Assign Inspector page
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Figure 2-502 Set Execution Frequency page

Step 4 Click Finish. A scheduled sample inspection plan is created.

----End

2.10.5.8 Creating Sample Inspection Tasks

An inspection supervisor can create manual sample inspection tasks to re-inspect
the calls that have been intelligently inspected.

Prerequisites
● A sample inspection plan has been configured.

● The AI inspection has been performed on the call records.

Context

On the My Inspection Task page, the calls that have been intelligently inspected
can be assigned to inspectors for manual inspection. An inspection supervisor can
view, create, modify, delete, assign, reserve, validate, or terminate inspection tasks.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Quality Inspection >
My Inspection Task.

Step 2 Click Pending Task List. The Pending Task List page is displayed. Click New to
configure a manual sample inspection.

The new task can be created only when at least one call exists.

Figure 2-503 Creating a task

Step 3 Click Back to My Sample Inspection and select a created manual sampling
inspection. Click Assign to assign an inspector to inspect the call.
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Figure 2-504 Page for assigning inspectors

You can click Reserve, Effective, Modify, Delete, or Stop to perform the
corresponding operation on an inspection task.

Figure 2-505 Managing inspection tasks

Step 4 On the My Inspection Task page, click View next to a desired task. The task
details page is displayed. You can assign reviewers to the completed inspection
tasks.

Figure 2-506 Task details page
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Step 5 On the Basic Task Details page, click View. The Call Inspection Details page is
displayed. The inspection administrator can view the call details and modify the
sample inspection result.

----End

2.10.5.9 Performing Text and Speech Analysis

2.10.5.9.1 Configuring Text Analysis

You can enable text and speech analysis by setting the analysis interaction type,
analysis percentage, and agents to be analyzed.

NO TE

To enable text and speech analysis, you must set the analysis type (text, speech, or both)
on the Text Analysis Configuration page and enable the text analysis feature.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Text Analysis Configuration.

Figure 2-507 Text Analysis Configuration page

Step 2 Select an interaction type. The options are Text type, voice type, and Text type,
voice type.

Step 3 Set the analysis percentage to a number ranging from 0 to 100. If this parameter
is not set, the default value 100 is used. The backend determines whether to
enable text and speech analysis based on the analysis percentage.

Step 4 Set the agents to be analyzed. Click +. On the Select Agent page that is displayed,
select agents.
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Figure 2-508 Select Agent page

Step 5 Click OK to save the text analysis configuration.

----End

2.10.5.9.2 Searching for Inspection Results Based on Keywords

Inspection results after text and speech analysis can be filtered based on keywords
and other conditions.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Speech Text Analysis >
Keyword Search.

Figure 2-509 Keyword Search page
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Step 2 Set the start time and end time, and click Search. The default time range is last 7
days.

NO TE

The time range must be less than or equal to 31 days.

Step 3 Set other conditions. Click Save Filter Condition and set the filter condition name
to save the combination of all the current filter conditions.

Step 4 Click ... in the Select filter condition. selection box to select a saved filter
condition.
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----End

2.10.5.9.3 Viewing the Word Frequency

The word frequency display function is used to collect statistics on hot words
generated during calls after AI inspection is complete.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Speech Text Analysis >
Word Frequency Display.

Step 2 Click the HOT WORD DISPLAY tab. By default, the bar chart of hot word statistics
in the last month is displayed. You can set Agent ID, Time Query, and Number of
Displayed Items to filter data based on criteria.
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Figure 2-510 HOT WORD DISPLAY tab page

Step 3 Click the DISPLAY OF HOT INTENTIONS tab. By default, the bar chart of hot
intention statistics in the last month is displayed. You can set Agent ID, Time
Query, and Number of Displayed Items to filter data based on criteria.

Figure 2-511 DISPLAY OF HOT INTENTIONS tab page

Step 4 Click the HOT CALL REASON DISPLAY tab. By default, the bar chart of hot call
reason statistics in the last month is displayed. You can set Agent ID, Time Query,
and Number of Displayed Items to filter data based on criteria.
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Figure 2-512 HOT CALL REASON DISPLAY tab page

----End

2.10.5.9.4 Collecting Text Analysis Indicator Statistics

The text analysis indicator statistics function is used to query call record statistics
after AI inspection is complete.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Speech Text Analysis >
Text Analysis Indicator Statistics.

Figure 2-513 Text Analysis Indicator Statistics page

Step 2 Set Display granularity, Time Query, Interaction Type, Agent ID, and Grouping
Condition to filter data based on criteria.

Step 3 Click Adding an Export Task. On the page that is displayed, set zip password and
click Save.
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Figure 2-514 Added export task page

Step 4 Click View Export Tasks to go to the Export Results page to view export tasks.
Click Download to download a package.

Figure 2-515 Export Results page

NO TE

The exported data contains personal data. Exercise caution when processing the exported
data to prevent personal data leakage and abuse.

----End

2.10.5.9.5 Configuring Custom Indicators
Indicators generated based on custom filter criteria and calculation logic can be
used for indicator statistics display.

Procedure
Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >

Quality Management > Analysis Field Define.

Figure 2-516 Custom Metric page
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Step 2 Click Search. All custom indicators of the tenant are queried by default. You can
query indicators based on the field ID, field name, field type, or status.

Step 3 Click Add to go to the Adding a user-defined counter page. Click Modify to go
to the Editing a User-Defined Metric page. Click Delete to delete a custom
indicator. Click Release to publish a custom indicator. Click Unpublish to
unpublish a custom indicator.

Step 4 Enter basic information (Field ID, Field Name, Field Type, Write to Target Table,
and Field Description) and add filter condition (New Conditions or Added
Brackets And Conditions.), enter the field calculation logic, and click Save.

Figure 2-517 Editing a User-Defined Metric page

----End

2.10.5.9.6 Managing Indicator Categories

Step 1 Sign in to the AICC as a tenant administrator and choose Speech Text Analysis >
Indicator Category Management.

Figure 2-518 Indicator Category Management page

Step 2 Click Search. All indicator categories of the tenant are queried by default. You can
query the indicator category based on the indicator category name, display
granularity, and status.

Step 3 Click Add to go to the Add Indicator Category page. Click Modify to go to the
Edit Indicator Category page. Click Delete to delete an indicator category. Click
Publish to publish a custom indicator category. Click Unpublish to unpublish a
custom indicator category.

Step 4 Enter the basic information (Indicator Category Name, Target Table, and
Indicator Category Description), set display indicator (Add Basic Indicator or
Add Custom Indicator), grouping condition, filter condition (Add Basic Filter
Condition, Add Custom Filter Condition, Add Basic Brackets Filter Condition,
or Add Custom Brackets Filter Condition), display granularity (15min, 30min,
60min, or Day), and display time segment (On the same day, 7 Days, 31 Days,
or a custom period), and click Save.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 904



Figure 2-519 Add Indicator Category page

Step 5 Click Publish and then click Indicator Statistics. A dialog box is displayed,
showing the data of the current indicator category.

Figure 2-520 Counter Type Statistics page

----End

2.11 Managing the Notification Center
This section describes how to manage notifications in the notification center.

NO TICE

The notification center can send Huawei Cloud SMS messages. To use this
function, configure SMS messages by referring to 2.11.2 Configuring SMS
Messages.

2.11.1 Configuring Bulletin Types
Tenant administrators can configure bulletin types for recipients to distinguish
bulletins.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Workbench Configuration > Notification Type.
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Figure 2-521 Notification Type

Step 2 Click New. The Create Bulletin Type dialog box is displayed.

Figure 2-522 Create Bulletin Type

● Basic Info
– Bulletin Type Name: Enter a customized name. The value can contain a

maximum of 128 characters.
– Description: Enter a customized description. The value can contain a

maximum of 256 characters.
● Default Expiration Time
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– Low: Enter a value ranging from 1 to 2000, in days. The default value is
7.

– Medium: Enter a value ranging from 1 to 2000, in days. The default value
is 7.

– High: Enter a value ranging from 1 to 2000, in days. The default value is
7.

– Critical: Enter a value ranging from 1 to 2000, in days. The default value
is 7.

Step 3 Click Save.

Step 4 (Optional) You can perform the following operations on the new bulletin type:
● Edit: Edit the bulletin type information.
● Delete: Delete the bulletin type.

----End

2.11.2 Configuring SMS Messages
A tenant administrator can set SMS parameters for the notification center to send
Huawei Cloud SMS messages. A tenant administrator can configure an SMS
message sender number to enable the public number to send SMS gateway
messages.

Prerequisites

To use the Huawei SMS function, you must have enabled the Huawei Cloud SMS
service at Message & SMS.

Context

If information, such as the app key and app secret, is changed on Huawei Cloud
SMS, you need to modify the configuration in the AICC as follows: Choose
Configuration Center > Access Configuration > SMS Configuration, click Edit,
and update the values of parameters, such as App Key and App Secret.

Configuring Huawei Cloud SMS Messages

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > SMS Configuration.

Step 2 Click the HUAWEI CLOUD SMS tab and click Edit to enter the editing mode.

Step 3 Set the following SMS parameters:
● App Key
● App Secret
● App Access Address
● Signature Channel ID

NO TE

The preceding parameters are obtained from the enabled Huawei Cloud service.
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● Whether to enable certificate verification

– If this parameter is set to YES, certificate verification is enabled. You need
to obtain a certificate file from the Huawei Cloud SMS service and upload
it on the Configuration Center > System Management > Certificate
page.

– If this parameter is set to NO, certificate verification is disabled, which
may cause peer identity spoofing risks. Exercise caution when using this
value.

● Certificate File: This parameter is available only when certificate verification
is enabled. Select the Huawei Cloud SMS certificate uploaded on the
Configuration Center > System Management > Certificate page.

Step 4 Click Save.

----End

Configuring SMS Message Sender IDs

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > SMS Configuration.

Step 2 Click the SMS sender ID configuration tab.

Step 3 Click New. The New SMS sender ID dialog box is displayed.

● Type: Type of an SMS message sender ID. The options are SMS Message
Number and Company/Brand Name.

● Sender Country Code: SMS message sender number.
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● SMS Message Number: A specific number is required when Type is set to
SMS Message Number. Enter the SMS sender ID. The value is a string of 1 to
20 digits and case-sensitive characters.

● Company/Brand Name: A specific company/brand name is required when
Type is set to Company/Brand Name.
The company or brand name can contain only digits, letters, and spaces. It
cannot start or end with a space and can contain a maximum of 11
characters.

Step 4 Click OK.

----End

2.11.3 Configuring Gateways
A tenant administrator can configure gateway parameters to implement the SMS
and email notification functions.

NO TICE

Before deleting an SMS or email gateway, ensure that the gateway is not used by
other businesses. Otherwise, the configured businesses will become invalid.
Determine the gateway application scenario based on the actual business
configuration. The involved scenarios are as follows:
● Notification center: 2.11.6 Configuring Message Receiving Routes and 2.11.7

Sending Notifications as an Administrator
● Channel configuration: 2.5.6 Configuring the Email Channel and 2.5.9

Configuring the SMS Channel
● One-click trial use on Huawei Cloud: automatic email sending and automatic

SMS message sending
● Intelligent IVR: 2.7.8 Warning Condition

2.11.3.1 Configuring SMS Gateways

A tenant administrator can configure SMS gateways to send and receive SMS
messages.

Context

If the user password for connecting to the SMS gateway is changed, you need to
modify the configuration in the AICC as follows: Choose Configuration Center >
Access Configuration > Gateway Configuration, click Edit in the Operation
column corresponding to the gateway to be modified, click the Message protocol
parameters tab, and enter the new login password.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Gateway Configuration.
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Figure 2-523 Gateway Configuration

Step 2 Click New. The Create Gateway page is displayed.

Figure 2-524 Create Gateway - Basic Information

Step 3 After basic information is configured, click Next. The Gateway Address
Interconnection Configuration page is displayed.
● Basic Configuration: Parameters in this area are mandatory.

Figure 2-525 Gateway Address Interconnection Configuration - Basic
Configuration

– SMG Address (mandatory): IP address of the SMS gateway, for example,
10.10.10.10.

– SMG Port (mandatory): Port number of the SMS gateway.
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– Login Name: Account for logging in to the gateway. This parameter is
optional when a gateway simulator is used.

– Login Password: Password for logging in to the gateway. This parameter
is optional when a gateway simulator is used.

– Receiving And Sending Mode (mandatory): Whether the protocol device
is used to send or receive SMS messages. The default value is Send and
receive SMS messages. The options are as follows:

▪ Send and receive SMS messages: The protocol device is used to
process messages received from the SMSC and send SMS messages.

▪ Receive SMS messages: The protocol device is used to process
messages received from the SMSC.

▪ Send SMS Messages: The protocol device is used to send SMS
messages.

– SMPP PDU Type (mandatory): Type of the SMPP PDU used for sending
SMS messages. The default value is submit_sm. The options are as
follows:

▪ submit_sm

▪ data_sm

– Sender ID Prefix (mandatory): Prefix of the number segment configured
on the gateway for which SMS messages can be sent. The value can
contain only letters and digits.
Sender ID prefix rule: In a number in the AICC, the part following the
country code starts with a sender ID prefix. For example, if the number in
the AICC is +86123xxxxxxxx, set this parameter to 123. Use semicolons (;)
to separate multiple prefixes.

– Accepted Number Prefix (mandatory): Prefix of the number segment
configured on the gateway for which SMS messages can be received.
Value range: a number made up of digits
Accepted number prefix rule: In a customer number, the part following
the country code starts with an accepted number prefix. For example, if
the customer number is +86123xxxxxxxx, set this configuration item to
123. Use semicolons (;) to separate multiple prefixes.

– Default sender ID: default sender ID of the gateway. The value is the ID
configured in Configuring SMS Message Sender IDs.

● ESME Connection Configuration: Parameters in this area are set by default
and can be modified as required.
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Figure 2-526 Gateway Address Interconnection Configuration - ESME
Connection Configuration

– Client Port (mandatory): Number of an unoccupied port for the CC-
Notification server. The port number is used to connect to the SMS
gateway. If the client port needs to be specified for the SMS gateway, set
this parameter. The value ranges from 0 to 65535.
The default value is 0, indicating that the CC-Notification randomly
allocates a port number.

– Port for receiving upstream messages: Port number for receiving MO
messages. The value ranges from 0 to 65535.
The default value is 0, indicating that the CC-Notification automatically
allocates a port number.

– Heartbeat Interval(ms): Interval for sending heartbeat messages to the
SMS gateway to maintain the persistent connection between the CC-
Notification and SMS gateway. This parameter specifies the interval for
sending heartbeat messages. The value is a number of 1 to 10 digits. The
value must be greater than that of Transaction Timeout Interval(ms)
and less than that of Receiving Timeout Interval(ms).
The default value is 30000, in milliseconds.

– Max Connection Times Upon No Heartbeat Response: Maximum
number of consecutive heartbeat response failures. When this value is
exceeded, the CC-Notification disconnects from the gateway. The value is
a number of 0 to 5 digits.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 912



The default value is 3.

– Resending Times: Maximum number of resending times. After the CC-
Notification sends a heartbeat message, if the CC-Notification does not
receive a heartbeat response within the transaction timeout interval, the
CC-Notification waits for a period of time (specified by Resending
Waiting Time(ms)) and then resends the heartbeat message. The value
is a number of 0 to 10 digits.

The default value is 0.

– Resending Waiting Time(ms)

Interval for resending an SMS message after the CC-Notification receives
an SMS message sending failure response from the SMS gateway. The
value is a number of 0 to 10 digits.

The default value is 0.

– Receiving Timeout Interval(ms) (mandatory): Maximum duration for
allowing no data transmission after an SMS device connects to the
gateway. If the SMS device does not receive data from the peer device
within this duration, automatic disconnection occurs. The value is a
number of 1 to 10 digits. The value must be greater than those of
Heartbeat Interval(ms) and Transaction Timeout Interval(ms). To
prevent invalid connections, do not set this parameter to 0.

The default value is 180000.

– Max Error Packets Received: Number of error packets consecutively
received by a device. If this value is reached, the link is faulty and will be
disconnected. The value is a number of 0 to 10 digits.

The default value is 10.

– Sliding Window Size (mandatory): Instantaneous concurrent processing
capability of the CC-Notification. This parameter is used to limit the
number of messages sent by the CC-Notification, preventing errors that
may occur on the SMSC due to great pressure. The value is a number of 2
to 5 digits.

The default value is 16. Generally, set this parameter to a multiple of 16.

– Transaction Timeout Interval(ms): Maximum duration for an SMS
device to wait for a response from the peer device after sending a
message. If the peer device does not respond within this duration, the
SMS device does not wait any longer. The value is a number of 0 to 10
digits. The value must be less than those of Heartbeat Interval(ms) and
Receiving Timeout Interval(ms).

The default value is 6000, in milliseconds.

– Max Message Length (bytes) (mandatory): Maximum message length
specified by the protocol. The value is a number of 1 to 5 digits.

The default value is 2048, in bytes.

– Oversized SMS Splitting Mode (mandatory): Mode of splitting an SMS
message when the message content length exceeds the value of Max
Content Length (bytes). The options are as follows:

▪ disabled: A long SMS message is not sent, and an exception is
reported on the CC-Notification.
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▪ not split: The system directly sends an SMS message without
checking whether it is too long.

▪ physical splitting: A long SMS message is segmented into multiple
independent SMS messages based on the value of Max Content
Length(bytes).

▪ ultra-long split: A long SMS message is split into several continuous
SMS messages, that is, the system adds the combination control
information to each sub-message. Terminals that support continuous
SMS messages can combine the sub-messages into a complete SMS
message.

The default value is disabled.
– Max Content Length(bytes) (mandatory): Maximum message content

length specified by the protocol. A long SMS message is split based on
the value of this parameter. The value is a number of 1 to 5 digits.
The default value is 140, in bytes.

– Min Sending Thread Pools (mandatory): Minimum number of threads
that start in the thread pool when the protocol stack is used to send
messages. The value is a number of 1 to 5 digits.
The default value is 20.

– Max Sending Thread Pools (mandatory): Maximum number of threads
that start in the thread pool when the protocol stack is used to send
messages. The value is a number of 1 to 5 digits.
The default value is 200.

– Sending Thread Pool Queue Length (mandatory): Length of the thread
queue to be processed in the sending thread pool. The value is a number
of 1 to 5 digits.
The default value is 2000.

– Min Receiving Thread Pools (mandatory): Minimum number of state
report receiving threads. Set this parameter by referring to the settings of
the sending thread pool, but the values can be different. The value is a
number of 1 to 5 digits.
The default value is 20.

– Max Receiving Thread Pools (mandatory): Maximum number of state
report receiving threads. The value is a number of 1 to 5 digits.
The default value is 200.

– Receiving Thread Pool Queue Length (mandatory): State report
receiving thread queue length. The value is a number of 1 to 5 digits.
The default value is 2000.

– Max Receiving Rate: Maximum rate at which messages are received
using a protocol. The value can be empty or a positive integer. If the
value is empty, the values of Max Sending Rate and Extra Traffic
Processing Policy must also be empty.

– Max Sending Rate: Maximum rate at which messages are sent using a
protocol. The value can be empty or a positive integer. If the value is
empty, the values of Max Receiving Rate and Extra Traffic Processing
Policy must also be empty.
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– Extra Traffic Processing Policy: Policy for sending messages when the
traffic exceeds the threshold. The value can be empty or a positive
integer. If the value is empty, the values of Max Receiving Rate and Max
Sending Rate must also be empty.

– Long Message Concatenation Mode (mandatory): Mode of combining
long SMS messages. The options are GSM User Data Header and SMPP
parameters.
The default value is GSM User Data Header.

● Message protocol parameters: Parameters in this area are set by default and
can be modified as required.

Figure 2-527 Gateway Address Interconnection Configuration - Message
protocol parameters

– ESME Type: External short message entity (ESME) type. The value can
contain a maximum of 13 characters.
For details, see the description of the system_type field in the bind
message of the SMPP protocol.

– ESME Address Type Code: Address type ID of the extended SMS message
entity. The value is a positive integer less than 28.
For details, see the description of the addr_ton field in the bind message
of the SMPP protocol.

– ESME Address Encoding Mode: Address encoding mode of the extended
SMS message entity. The value is a number of 0 to 10 digits.
For details, see the description of the addr_npi field in the bind message
of the SMPP protocol.

– ESME Address Range: Address encoding mode of the extended SMS
message entity. The value can contain a maximum of 15 characters.
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For details, see the description of the address_range field in the bind
message of the SMPP protocol.

– Service Type: Type of the SMS application service specified by the
gateway. The value can contain a maximum of 500 characters.
For details, see the description of the service_type field in the
submit_sm/data_sm message of the SMPP protocol.

– Source Address Code Type (mandatory): Type of the code in the source
address in SMPP SubmitMessage. The value is a number of 1 to 10 digits.
The default value is 0. For details, see the description of the
source_addr_ton field in the submit_sm/data_sm message of the SMPP
protocol.

– Source Address Code Scheme (mandatory): Scheme of the code in the
source address in SMPP SubmitMessage. The value is a number of 1 to 10
digits.
The default value is 0. For details, see the description of the
source_addr_npi field in the submit_sm/data_sm message of the SMPP
protocol.

– Destination Address Code Type (mandatory): Type of the code in the
destination address in SMPP SubmitMessage. The value is a number of 1
to 10 digits.
The default value is 0. For details, see the description of the
dest_addr_ton field in the submit_sm/data_sm message of the SMPP
protocol.

– Destination Address Code Scheme (mandatory): Scheme of the code in
the destination address in SMPP SubmitMessage. The value is a number
of 1 to 10 digits.
The default value is 0. For details, see the description of the
dest_addr_npi field in the submit_sm/data_sm message of the SMPP
protocol.

– Message Type (mandatory): Message type. The value is a number of 1 to
10 digits.
The default value is 0. For details, see the description of the esm_class
field in the submit_sm/data_sm message of the SMPP protocol.

– Message Format (mandatory): SMS message encoding mode. The
options are as follows:

▪ ASCII string: ASCII string in which one character occupies one byte

▪ binary information

▪ UCS2 encoding: ISO/IEC-10646 in which one character occupies two
bytes

The default value is ASCII string.
– Protocol ID (mandatory): GSM protocol ID. The value is a number of 1 to

10 digits.
The default value is 0. For details, see the description of the data_coding
field in the submit_sm message of the SMPP protocol.

– Return Status Confirmation Report (mandatory): State reports to be
returned. The options are as follows:
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▪ 0: No state report is received.

▪ 1: Success and failure state reports are returned.

▪ 2: Failure state reports are returned.

The default value is 2.
– Replacement Flag (mandatory): Whether to replace the existing SMS

messages whose source addresses and destination addresses are the
same. The options are Not replace and Replace.
The default value is Not replace.

– Default Message ID (mandatory): ID of a predefined SMS message. It is
the index of a predefined SMS message created by the administrator of
the message center. The value can contain a maximum of 500 characters.
The default value is 0. For details, see the description of the
sm_default_msg_id field in the submit_sm message of the SMPP
protocol.

Step 4 After gateway interconnection information is configured, click Save.

----End

Follow-up Procedure
● Rebuild a gateway.

a. Choose Configuration Center > System Management > Gateway
Monitoring.

b. Click Rebuilding.
● Disconnect a gateway that fails to be connected.

a. Choose Configuration Center > System Management > Gateway
Monitoring.

b. Click Disconnected.

2.11.3.2 Configuring Email Gateways

A tenant administrator can configure gateways to enable the AICC to send and
receive emails.

Context

If the user password for connecting to the email gateway is changed, you need to
modify the configuration in the AICC as follows: Choose Configuration Center >
Access Configuration > Gateway Configuration, click Edit in the Operation
column corresponding to the gateway to be modified, click the Gateway Address
Interconnection Configuration tab, and enter the new user password.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Gateway Configuration.
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Figure 2-528 Gateway Configuration

Step 2 Click New. The Create Gateway page is displayed.

Figure 2-529 Create Gateway - Basic Information

Step 3 After basic information is configured, click Next. The Gateway Address
Interconnection Configuration page is displayed.

Figure 2-530 Gateway Address Interconnection Configuration
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● Host (mandatory): Address of the email server, for example, 10.10.10.1 or
www.****.com.

● User ID: Username for logging in to the email server. The value can contain a
maximum of 500 characters.

● User Password: Password for logging in to the email server. The value can
contain a maximum of 64 characters.

● Default Email Address: Default email address for sending emails.
● Default User Name: Default username for sending emails. After this

parameter is set, the username is displayed in front of the email address
when an agent sends an email through the email channel on the text chat
workbench. The username is not displayed when an email is sent using the
notification sending function of the notification center.

● Authentication Flag: Whether the email address requires password
authentication. The options are True and False. The default value is True.

CA UTION

False may cause security risks. True is recommended to enable password
authentication.

● Encoding Mode: Email encoding mode. The default value is UTF-8.
● Port: Host port number. Contact the O&M personnel of the email server.
● Encryption Mode: Email encryption mode. The options are as follows:

– NONE: Data is transmitted in plaintext.
– TLS: TLS is used to create a secure connection between two applications

through the network to prevent data from being intercepted or tampered
with during data exchange.

– STARTTLS: STARTTLS is an extension of plaintext communication
protocols, which offers a way to upgrade a plaintext connection to an
encrypted (using TLS or SSL) connection instead of using a separate port
for encrypted communication. STARTTLS uses opportunistic encryption.

CA UTION

NONE indicates that data is transmitted in plaintext, which may cause
information leakage.
STARTTLS is an insecure protocol, which may cause security risks. TLS is
recommended.
TLS indicates TLSv1.2 by default.

● Certificate File: Certificate file. This parameter is mandatory when
Encryption Mode is set to TLS or STARTTLS. For details about how to
manage certificates, see 2.17.6 Managing a Certificate.

● Case sensitivity: Select whether the email address is case sensitive. By default,
it is case insensitive. The sender's email address is in lowercase when the CC-
Notification receives emails and sends MO messages.
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Step 4 After gateway interconnection information is configured, click Save.

----End

Follow-up Procedure
● Rebuild a gateway.

a. Choose Configuration Center > System Management > Gateway
Monitoring.

b. Click Rebuilding.
● Disconnect a gateway that fails to be connected.

a. Choose Configuration Center > System Management > Gateway
Monitoring.

b. Click Disconnected.

2.11.3.3 Monitoring Gateways
A tenant administrator can view the gateway status on the Gateway monitoring
page and perform operations such as reconnection and disconnection.

Procedure
Step 1 Sign in to the AICC as the system administrator and choose Configuration Center

> System Management > Gateway Monitoring.

Figure 2-531 Gateway Monitoring

● GatewayName: Gateway name, which is customized.
● Type: Gateway type, which is Email or SMS.
● Mspld: Deployment address of the notification center.
● Modified At: Time when the gateway status is last modified.
● Status: Gateway connection status, which is Connection succeeded,

Connection stopped, Connection error, Initialization, or Connecting. Only
gateways in Connection error state can be disconnected.

● Operation: Operations that can be performed on a gateway, including
Rebuilding and Disconnected.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 920



Step 2 Set data filter criteria.

● Enter a gateway name and click  to filter gateway status data based on
the gateway name.

● Click More to expand advanced search criteria. Set Mspld and Status, and
click Search to filter detailed data.

● Click  to refresh real-time data or filter data based on filter criteria.

Step 3 Configure the gateway connection status.
● Select multiple gateways in Connection error state and click

 to disconnect them in batches.

● Select multiple gateways and click  to rebuild them in
batches.

● Click Disconnected or Rebuilding in the Operation column corresponding to
a gateway to update its connection status.

----End

2.11.3.4 Configuring Notification Settings
A tenant administrator sets the country code, SMS message sender number, and
gateway data threshold in notification settings to control data.

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Access Configuration > Gateway Configuration, and click Settings.

Step 2 Configure notification settings.
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Figure 2-532 Set Notification Configuration

● Recipient Country Code: Select the country where recipients are located.

● Country Code Prefix Type: Determine whether to add the plus sign (+)
before the notification sender number when sending an SMS notification.

● Data Limit Type: Select a notification data limit type. The options are Daily
Total Data Threshold and Daily Monomedia Data Threshold.

● Daily Total Data Threshold: Set the maximum number of notifications,
including SMS messages and emails, that all gateways can send in a day. The
value ranges from 1 to 1000000. Set this parameter when Data Limit Type is
set to Daily Total Data Threshold.

● Daily Data Threshold For SMS Messages/Daily Data Threshold For Emails:
Set the maximum number of notifications that SMS or email gateways can
send in a day. The value ranges from 1 to 1000000. Set these parameters
when Data Limit Type is set to Daily Monomedia Data Threshold.

Step 3 Click Save.

----End

2.11.4 Configuring Variables
After a tenant administrator configures variables, these variables can be used for
configuring a notification template, and can be applied when the notification
template is used to send notifications.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Workbench Configuration > Notification Variables.
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Figure 2-533 Notification Variables

Step 2 Click New.

Figure 2-534 New Notification Variables

● Name (mandatory): Enter a customized variable name. The value can contain
a maximum of 100 characters, including only letters, digits, underscores (_),
and periods (.).

● Description: Enter a variable description. The value can contain a maximum
of 200 characters.

● Type

– Template variable: If a variable is unique to a template, select this value.

– Public variable: If a variable can be used by all templates, select this
value.

● Variable Value: Enter a default value. The value can contain a maximum of
500 characters, including only letters, digits, spaces, and the following special
characters: -;@.
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Step 3 Click Save.

Step 4 Click View References corresponding to the new notification variable to view
notification templates that reference the variable.

Figure 2-535 View References

Step 5 (Optional) You can perform the following operations on the new notification
variable:

● Click Edit to modify the notification variable information. The variable name
and type cannot be modified.

● Click Delete to delete the notification variable. Variables that have been
referenced by templates cannot be deleted.

----End

2.11.5 Configuring Notification Templates as an Administrator
A tenant administrator can configure notification templates to reference when
sending common notifications.

NO TICE

Before deleting an SMS or email notification template, ensure that the template is
not used by other businesses. Otherwise, the configured businesses will become
invalid.

Determine the notification template application scenario based on the actual
business configuration. The involved scenarios are as follows:

● Agent monitoring and inspection: 4.3.1.3 Configuring Report Subscription

● Intelligent outbound call: SMS template referenced during outbound call task
creation in 2.13.2.6 Creating Outbound Call Templates and 2.13.3 Managing
Outbound Call Tasks

● Configuration center: conference link SMS template in 2.3.3.2 Configuring
Satisfaction Surveys and 2.17.3 Configuring Parameters

● Agent workbench: notification sending on the voice and video workbench
(3.7.8 Sending Notifications), conference link SMS message sending, and
notification sending on the contact details page of a contact record.

● One-click trial use on Huawei Cloud: automatic email sending and automatic
SMS message sending

● Robot management: SMS message diagram element and SMS template
referenced during outbound call risk monitoring
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Context
● Variables can be inserted into notification templates. You can configure some

variables in advance. For details about how to configure variables, see 2.11.4
Configuring Variables.

● An administrator can directly reference configured notification templates
when sending notifications.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Workbench Configuration > Notification Template.

Figure 2-536 Notification Template

Step 2 Create an SMS notification template.

1. Click New. The Creating a Notification Template page is displayed.

Figure 2-537 Creating a Notification Template - SMS

2. Configure basic information.
– Channel Type (mandatory): Select a notification sending type.
– Template Name (mandatory): Enter a customized notification template

name. The value can contain a maximum of 200 characters and cannot
contain special characters. The template name must be unique.

– Notification Type (mandatory): Select a notification template type. The
options are Internal Notification and External Notification.
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– Home Organization: Select the OU to which a notification template
belongs.

3. Configure the notification content.
– Recipient: Select recipients. The value can contain a maximum of 4000

characters.
– Template Type: Select an SMS notification template type. The options

are HUAWEI CLOUD SMS Messages and SMS Gateway.
– HUAWEI CLOUD Template ID, Signature Name, and Signature

Channel ID: Set these parameters when Template Type is set to
HUAWEI CLOUD SMS Messages. You need to enable and log in to
Huawei Cloud, enable the SMS message sending service, and obtain the
Huawei Cloud template ID, signature name, and signature channel ID.

– Number of Variables: Enter a value ranging from 1 to 10. Set this
parameter when Template Type is set to HUAWEI CLOUD SMS
Messages.

– Set Variable: Click  to add a variable and set the
following parameters:

▪ No.: Enter a variable No. The value is a positive integer.

▪ Type: Select a variable type. The options are PHONE, DATETIME,
CHARDIGIT, and MONEYTEXT.

▪ Description: Enter a variable description. The value can contain a
maximum of 50 characters.

▪ Default Value: Enter a default variable value.
○ For the PHONE type, the value is a number of 1 to 15 digits.
○ For the DATETIME type, the date format is yyyy-MM-dd, and

the time format is HH:mm:ss.
○ For the CHARDIGIT type, the value is a string of 1 to 20 digits

and letters.
○ For the MONEY type, the value is a number of 1 to 20 digits.

Only digits and decimal points that can properly express the
amount can be passed.

○ For the TEXT type, the value is a string of 1 to 20 characters and
cannot contain the following special characters: .{}

Step 3 Create an email notification template.

1. Click New. The Creating a Notification Template page is displayed.
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Figure 2-538 Creating a Notification Template - Email

2. Configure basic information.
– Channel Type (mandatory): Select a notification sending type.
– Template Name (mandatory): Enter a customized notification template

name. The value can contain a maximum of 200 characters and cannot
contain special characters. The template name must be unique.

– Notification Type (mandatory): Select a notification template type. The
value can only be Internal Notification.

– Home Organization: Select the OU to which the notification template
belongs.

3. Configure the notification content.
– Recipient, Cc, and Bcc: Select recipients, Cc recipients, and Bcc recipients.
– Title: Enter a notification template title. The value can contain a

maximum of 200 characters.

– Attachment: Click  and select a local file to add it
to the email as an attachment. The file must be a DOC, DOCX, XLS, XLSX,
TXT, PNG, JPG, XML, JSON, CSV, BMP, ZIP, PPT, or PPTX file whose size is
less than 10 MB. A maximum of 10 files can be uploaded.

– Template Content: Enter the notification content.

Step 4 Create an internal message notification template.

1. Click New. The Creating a Notification Template page is displayed.

Figure 2-539 Creating a Notification Template - Internal Message

2. Configure basic information.
– Channel Type (mandatory): Select a notification sending type.
– Template Name (mandatory): Enter a customized notification template

name. The value can contain a maximum of 200 characters. The template
name must be unique.
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– Notification Type (mandatory): Select a notification template type. The
options are Internal Notification, System Notification, and Merchant
Notification. Merchant notifications are notifications sent to merchants.

– Home Organization: Select the OU to which the notification template
belongs.

3. Configure the notification content.
– Recipient: Select recipients.
– Title: Enter a notification template title. The value can contain a

maximum of 200 characters.
– Template Content: Enter the notification content.

Step 5 Click Save.

----End

2.11.6 Configuring Message Receiving Routes
A tenant administrator can create an email receiving route to store emails in the
default inbox configured in the gateway configuration to the AICC inbox, and
create an SMS receiving route to store SMS messages in the recipient address to
the AICC inbox.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Access Configuration > Notification Route.

Figure 2-540 Notification Route

Step 2 Choose New. The New Notification Route dialog box is displayed.
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Figure 2-541 New Notification Route

● Media Type: Media type of received messages. The options are SMS and
Email.

● Recipient Address: Address for receiving messages. When Media Type is set
to SMS, enter a mobile number. You can enter multiple numbers and separate
them with commas (,). The mobile number must be unique.

● Gateway: Gateway for receiving messages. When Media Type is set to Email,
select a gateway. The options are email gateways whose Protocol Type is
POP3 or IMAP in the tenant space.

● Implementation mode: Implementation mode of a notification route. The
options are as follows:
– Inbox: Notification routing is implemented through the inbox.
– Service Invoking: Notification routing is implemented through service

invocation. The options are Satisfaction Survey and Cas service.
● Recipient: Select a business account in the tenant space.

Step 3 Click Save.

----End

2.11.7 Sending Notifications as an Administrator
A tenant administrator can send internal notifications.

Prerequisites
● To send bulletins, a bulletin type has been configured on the Configuration

Center > Workbench Configuration > Notification Type > Bulletin Type
page. If no bulletin type has been configured, configure one by referring to
2.11.1 Configuring Bulletin Types.

● To send Huawei Cloud SMS messages:
– Huawei Cloud SMS requires that the server has the permission to access

the external network.
– The Huawei Cloud SMS service has been purchased, and SMS

configuration has been completed on the Configuration Center > Access
Configuration > SMS Configuration page. If SMS configuration has not
been completed, complete it by referring to 2.11.2 Configuring SMS
Messages.

– A Huawei Cloud SMS notification template has been configured on the
Configuration Center > Workbench Configuration > Notification
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Template page. If no SMS notification template has been configured,
configure one by referring to 2.11.5 Configuring Notification Templates
as an Administrator.

● To send SMS gateway messages:
– An SMS message sender number has been configured on the

Configuration Center > Access Configuration > SMS Configuration >
SMS Number page. If no SMS message sender number has been
configured, configure one by referring to 2.11.2 Configuring SMS
Messages.

– An SMS gateway has been configured on the Configuration Center >
Access Configuration > Gateway Configuration page. If no SMS
gateway has been configured, configure one by referring to 2.11.3.1
Configuring SMS Gateways.

● To send emails, an email gateway has been configured on the Configuration
Center > Access Configuration > Gateway Configuration page. If no email
gateway has been configured, configure one by referring to 2.11.3.2
Configuring Email Gateways.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and click  in the upper right
corner of the page. The Notification Center page is displayed.

Step 2 Click . The Send a notification page is
displayed.

Step 3 Send a bulletin notification.

Figure 2-542 Sending a bulletin notification

1. Configure the bulletin notification content.
– Type: Select Bulletin.
– Recipient: Click Recipient. In the Recipient dialog box, select recipients

and click Complete.
– Recipient Group: Click Recipient Group. In the Recipient Group dialog

box, select recipient groups and click Complete.
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– Title: Enter a notification title. The value can contain a maximum of 200
characters.

– Bulletin Type: Select a bulletin type. For details about how to configure
bulletin types, see 2.11.1 Configuring Bulletin Types.

– Priority: Select a notification urgency level. The options are Low,
Medium, High, and Critical.

– release time: Set the bulletin release time.

▪ If this parameter is set to a specific time, the notification is created
and saved after you click Send, and the notification content is sent at
the specified time.

▪ If this parameter is left blank, the notification content is sent
immediately after you click Send.

– periodically send: Determine whether to send the notification
periodically.

– sending frequency: After you select periodically send, select a
notification sending frequency. The options are every day, weekly, and
per month.

– weekly or per month: Select a week or date for sending the notification.
The value ranges from Monday to Sunday or Day 1 to Day 31. This
parameter is mandatory when sending frequency is set to weekly or per
month.

– Expired On: Set the time when the notification expires. After the
notification expires, the notification will not be sent.

– Notification content: Enter the notification content.
2. (Optional) Click Save to save the notification to the draft box.
3. Click Send to send the notification content.

Step 4 Send an internal message notification.

Figure 2-543 Sending an internal message notification

1. Configure the internal message notification content.
– Type: Select Internal Message.
– Reference Template: Determine whether to reference a notification

template.
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– Select Template: After you enable Reference Template, select a
notification template whose Message Sending Mode is Internal
Message in the tenant space and click Complete to reference it.
For details about how to configure notification templates, see 2.11.5
Configuring Notification Templates as an Administrator.

– Recipient: Click Recipient. In the Recipient dialog box, select recipients
and click Complete.

– Recipient Group: Click Recipient Group. In the Recipient Group dialog
box, select recipient groups and click Complete.

– Title: Enter a notification title. The value can contain a maximum of 200
characters.

– Priority: Select a notification urgency level. The options are Low,
Medium, High, and Critical.

– Scheduled Notification: Determine whether to specify the notification
sending time.

▪ If this function is enabled, the notification is created and saved after
you click Send, and the notification content is sent at the specified
time.

▪ If this function is disabled, the notification content is sent
immediately after you click Send.

– Sending Time: After you enable Scheduled Notification, select a specific
time for sending the notification.

– Set Variable: After you enable Reference Template and select a
template, you can change the default values of variables in the template.

– Preview: Update the variables in the notification content to the default
values.

– Notification content: Enter the notification content.
2. (Optional) Click Save to save the notification to the draft box.
3. Click Send to send the notification content.

Step 5 Send an SMS notification.

Figure 2-544 Sending an SMS notification
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1. Configure the SMS notification content.
– Type: Select SMS.
– SMS: Select an SMS channel. The options are Huawei SMS and Gateway

SMS.
– Reference Template: Determine whether to reference a notification

template.
– Select Template: After you enable Reference Template, select a

notification template whose Message Sending Mode is SMS in the
tenant space and click Complete to reference it.
For details about how to configure notification templates, see 2.11.5
Configuring Notification Templates as an Administrator.

– Sender ID: Set this parameter when SMS is set to Gateway SMS. For
details about how to configure sender numbers, see Configuring SMS
Message Sender IDs.

– Recipient: Click Recipient. In the Recipient dialog box, select recipients
and click Complete.

– Scheduled Notification: Determine whether to specify the notification
sending time.

▪ If this function is enabled, the notification is created and saved after
you click Send, and the notification content is sent at the specified
time.

▪ If this function is disabled, the notification content is sent
immediately after you click Send.

– Sending Time: After you enable Scheduled Notification, select a specific
time for sending the notification.

– Set Variable: After you enable Reference Template and select a
template, you can change the default values of variables in the template.

– Preview: Update the variables in the notification content to the default
values when SMS is set to Gateway SMS.

– Notification content: Enter the notification content when SMS is set to
Gateway SMS.

2. Click Send to send the notification content.

Step 6 Send an email notification.

Figure 2-545 Sending an email notification
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1. Configure the email notification content.

– Type: Select Email.

– Reference Template: Determine whether to reference a notification
template.

– Select Template: After you enable Reference Template, select a
notification template whose Message Sending Mode is Email in the
tenant space and click Complete to reference it.

For details about how to configure notification templates, see 2.11.5
Configuring Notification Templates as an Administrator.

– Recipient, Cc, and Bcc: Click Recipient, Cc, or Bcc. In the Recipient, Cc,
or Bcc dialog box, select objects and click Complete.

NO TE

The Cc and Bcc recipients are optional. If the Cc or Bcc recipient does not exist,
the email can still be sent. However, the system displays a message indicating
that the Cc or Bcc recipient does not exist.

– Title: Enter a notification title. The value can contain a maximum of 200
characters.

– Attachment: Click  and select a local file to add
it to the email as an attachment. The file must be a DOC, DOCX, XLS,
XLSX, TXT, PNG, JPG, XML, JSON, CSV, BMP, ZIP, PPT, PPTX, or PDF file
whose size is less than 10 MB. A maximum of 10 files can be uploaded.

– Scheduled Notification: Determine whether to specify the notification
sending time.

▪ If this function is enabled, the notification is created and saved after
you click Send, and the notification content is sent at the specified
time.

▪ If this function is disabled, the notification content is sent
immediately after you click Send.

– Sending Time: After you enable Scheduled Notification, select a specific
time for sending the notification.

– Set Variable: After you enable Reference Template and select a
template, you can change the default values of variables in the template.

– Preview: Update the variables in the notification content to the default
values.

– Notification content: Enter the notification content.

2. Click Send to send the notification content.

----End

2.11.8 Viewing Notifications
A tenant administrator can view bulletins that have been sent, emails that have
been sent and received, notification sending records, and notification drafts.
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Prerequisites
● To view emails in the inbox, an email message route has been configured on

the Configuration Center > Access Configuration > Notification Route
page. If no email message route has been configured, configure one by
referring to 2.11.6 Configuring Message Receiving Routes.

● To view Huawei Cloud SMS messages or SMS gateway messages in the inbox,
an SMS message route has been configured on the Configuration Center >
Access Configuration > Notification Route page. If no SMS message route
has been configured, configure one by referring to 2.11.6 Configuring
Message Receiving Routes.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and click  in the upper right
corner of the page. The Notification Center page is displayed.

Figure 2-546 Viewing notifications

Step 2 Select a mailbox and click  to view the notification types contained in the
mailbox.
● Inbox, containing System Bulletin, Internal Bulletin, Internal Message,

Email, and SMS
● Draft, containing Bulletin and Internal Message
● Outbox, containing Bulletin, Internal Message, Email, and SMS
● Callback Record
● Sending Record

Step 3 Select a notification type and view the corresponding notification list.
● Inbox

– Enter a notification title and click  to search for notifications based on
the notification title.

– Click  to refresh notifications of the selected notification type.

– Click  and choose AII, Read, or Unread to filter notifications of the
selected notification type based on the notification status.
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– Select multiple notifications, click , and choose Mark messages as
read or Delete to operate them in batches. These operations are not
supported for emails.

– Click  and choose Delete all read messages to delete notifications in
batches. This operation is not supported for emails.

– Select multiple notifications and click  to mark them as read in
batches. This operation is supported only for emails.

● Draft Box

– Enter a notification title and click  to search for notifications based on
the notification title.

– Click  to refresh notifications of the selected notification type.

– Select multiple notifications and click  to delete them in batches.

● Outbox

– Enter a notification title and click  to search for notifications based on
the notification title.

– Click  to refresh notifications of the selected notification type.

– Click  and choose AII, Read, or Unread to filter notifications of the
selected notification type based on the notification status.

– Select multiple notifications and click  to delete them in batches.

● Callback Record

– Select a notification callback time range and click  to search for
notification callback records. The options are 1 Day, Last 3 days, Last 7
days, and Customization.

– Set Recipient, Sender, and Callback Status to further filter notification
callback records.

● Sending Record

– Select a notification sending time range and a notification sending state,

and click  to search for notification sending records. The options are
1 Day, Last 3 days, Last 7 days, and Customization.

– Set Recipient to further filter notification sending records.

Step 4 Select a notification and view its details.

● Inbox

– Click  to delete the notification.

– Click  to reply to the notification. This operation is not supported for
internal bulletins.

– Click  to maximize the notification.

● Draft Box
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– Click  to modify the notification.

– Click  to delete the notification.

– Click  to maximize the notification.
● Outbox

– Click  to delete the notification.

– Click  to maximize the notification.
– Click the name of an attachment to download the attachment and view

its content.

NO TE

The downloaded data contains personal data. Exercise caution when processing
the downloaded data to prevent personal data leakage and abuse.

----End

2.12 Managing the Customer Center
A tenant administrator or an agent can view customer information and customer
contact records, and add customer information.

Prerequisites
● The agent has the Customer Center Management menu permission. By

default, a tenant administrator has this permission.
● The Customer Center feature has been enabled for the tenant space.
● The tenant parameter Display Unified Customer Contact Information has

been set to Yes.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Customer Center >
Customer Center Management.

Step 2 Set search criteria to search for customer information based on the criteria.

Table 2-160 GUI elements on the Customer Center Management page

Element Typ
e

Description

Search for
name/
phone/
email

Tex
t
box

Enter the name, mobile number, or email address for
searching for customer information.
The value can contain 0 to 255 characters.

But
ton

Refresh the page.
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Element Typ
e

Description

But
ton

Import user information.

BatchDel
ete

But
ton

Select names and delete them.

Create But
ton

Add customer information.

Name Lab
el

Customer name.

Phone Lab
el

Customer mobile number.

Email Lab
el

Customer email address.

Remark Lab
el

Customer information description.

CreateTi
me

Lab
el

Time when customer information is created.

UpdateTi
me

Lab
el

Time when customer information is updated.

Operation But
ton
gro
up

Operations that can be performed.
● View: View customer information and customer contact

records.
● Delete

 

Step 3 Add a customer.

You can add customers one by one or import customers in batches as required.

● Adding customers one by one

a. Click Create.

b. Configure customer information.

Table 2-161 GUI elements on the Add Customer page

Element Ty
pe

Description

name Tex
t
bo
x

Customer name.
The value can contain 0 to 80 characters.
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Element Ty
pe

Description

gender Op
tio
n
bu
tto
n

Customer gender.

▪ Male

▪ female

▪ Information not available

Phone Tex
t
bo
x

Customer mobile number.

Click  on the right to add a mobile number. A
maximum of three mobile numbers can be configured.
The value can contain 0 to 20 characters.

Email Tex
t
bo
x

Customer email address.

Click  on the right to add an email address. A
maximum of two email addresses can be configured.
The value can contain 0 to 128 characters.

Compan
y

Tex
t
bo
x

Company to which a customer belongs.
The value can contain 0 to 80 characters.

Address Dr
op
-
do
wn
list

Contact address of a customer.

address
Detail

Tex
t
bo
x

Detailed contact address of a customer.
The value can contain 0 to 80 characters.
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Element Ty
pe

Description

Channel Dr
op
-
do
wn
list
+
tex
t
bo
x

Channel information.

Click  to add a channel.

▪ wechat

▪ twitter

▪ weibo

▪ facebook

▪ skype

▪ linkedin

▪ web

▪ line

▪ instagram

▪ telegram

▪ whatsapp

Enter a customer login channel account in the text
box, for example, a WeChat account.
The value can contain 0 to 255 characters.

Remark Tex
t
bo
x

Customer information description.
The value can contain 0 to 80 characters.

 
c. Click Save.

● Importing customers in batches

a. Click .
b. Click Customer Information Import Template to obtain the import

template.
c. Open the downloaded template file and configure the data to be

imported by referring to Figure 2-547.

Figure 2-547 Adding data
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▪ customerName: This field is mandatory. Other fields are optional.

▪ customerName, addtionalAddress, company, and remark: It is
recommended that the values contain a maximum of 80 characters.

▪ cellPhone: It is recommended that the value contain a maximum of
20 characters.

▪ email: It is recommended that the value contain a maximum of 128
characters.

▪ gender: The value can only be male, female, or unKnownSex.

▪ country, province, city, and area: The values are address names
preset in address data. Invalid address data is not imported.

d. Save the file.

e. Click  and select the configured .xlsx file.
f. Click Save to upload the customer information.

----End

2.13 Making Intelligent Outbound Calls
This section describes how to configure intelligent automatic outbound calls,
manage outbound call tasks by category (including automatic and manual
outbound call tasks), and properly plan outbound call tasks.

2.13.1 Overview of Outbound Call Tasks
To maintain customer relationships, improve customer satisfaction, or seek
business opportunities, enterprises often call customers for return visits, surveys,
additional information, product promotion, or other activities.

The AICC is a comprehensive outbound call management platform for enterprises.
It supports the following types of outbound call tasks.

NO TE

If the number of predicted outbound call tasks is greater than or equal to 4 and the
number of outbound call records configured for each task is greater than or equal to
100,000, performance risks may arise when all tasks are being executed and the database is
running on a server with an 8-core CPU.
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Table 2-162 Outbound call task types

Task Type Agent
Participati
on
(Yes/No)

Application
Scenario

Required
Resource

Advantage

Common
IVR
outbound
call task

No Revisit, survey,
standardized
information
collection, or
other scenarios
with standard
script
processes.

IVR
channel

● This method is
cost-effective,
because agent
participation is not
required.

● IVR flows are used
to interact with
customers by
playing voices,
collecting digits,
and routing calls.

Predicted
outbound
call task

Yes Customer care,
product
marketing, and
business
opportunity
seeking.

Skill queue ● This method is
more friendly and
flexible due to
agent participation.

● This method
ensures efficient
outbound calls,
because the AICC
dynamically
assigns calls based
on factors such as
the call completion
rate and rejection
rate.

Intelligent
robot
outbound
call task

No Revisit, survey,
standardized
information
collection, or
other scenarios
with standard
script
processes.

Enabled
intelligent
IVR
TTS and
ASR
channels

● This method is
cost-effective,
because agent
participation is not
required.

● This method
optimizes the
experience and
shortens the
operation and
service durations
due to the
semantic
recognition
technology of the
intelligent IVR flow.
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Task Type Agent
Participati
on
(Yes/No)

Application
Scenario

Required
Resource

Advantage

Manual
outbound
call task

Yes Customer care,
product
marketing, and
business
opportunity
seeking

Skill queue ● This method is
more friendly due
to agent
participation.

● Agents determine
the number of
outbound calls.

Previewed
outbound
call task

Yes Scenarios
where
customer
background
information
needs to be
obtained in
advance, for
example,
dunning tasks.

Skill queue ● This method is
more friendly due
to agent
participation.

● Agents have
enough time to
learn about the
customer's
background
information, which
provides better
experience.

Preempte
d
outbound
call task

Yes Agents are
preoccupied.
After a
customer is
connected, the
call is directly
connected to
an agent,
reducing the
customer's
waiting time.

Skill queue ● This method is
more friendly due
to agent
participation.

● This method
reduces the
probability of
hang-up due to
waiting. After a
customer accesses
the system, the
customer can be
connected to the
preoccupied agent
immediately.

Fixed
outbound
call task

Yes Customer care,
product
marketing, and
business
opportunity
seeking.

Skill queue ● This method is
more friendly due
to agent
participation.

● Outbound call
tasks can be
assigned based on
the idle agent rate.
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You can select a desired outbound call task based on the application scenarios and
advantages.

The following figure shows the task states and corresponding operations in the
AICC.

Figure 2-548 Status of the outbound call task

2.13.2 Preparations for Creating Outbound Call Tasks

2.13.2.1 Managing Special Dates

Special dates are specified in automatic outbound call tasks. For example, if a call
center expects the agents to make outbound calls on workdays at a time different
from that on weekends and public holidays, set weekends and public holidays to
special dates which can be selected when you create automatic outbound call
tasks.

Context

You can set special dates in any of the following ways:

● Specify one or more days in a week, usually weekends or workdays.

● Specify a date or time period. Generally, usually holidays or workdays
temporarily adjusted.

● Specify one or more days in a year, usually public holidays.
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Business Scenario
In a call center, Saturday and Sunday are special days, and no agent needs to be
on duty.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Call Config > Holidays.

Figure 2-549 Holidays page

Step 2 Click New to create a special date.

Figure 2-550 Create Special Date page

Step 3 Set Task Type to By Week, and select Saturday and Sunday. The following table
describes the parameters on the page.

Table 2-163 Parameters on the Create Special Date page (By Week)

Parameter Description

Special Date Name Enter a special date name.

Task Type Set this parameter to By Week.

Select Date Select dates as required, for example, select Saturday
and Sunday.
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Table 2-164 Parameters on the Create Special Date page (By Date)

Parameter Description

Special Date Name Enter a special date name.

Task Type Set this parameter to By Date.

Select Date Set Start Date and End Date.
The end date must be later than or equal to the start
date.

 

Table 2-165 Parameters on the Create Special Date page (Repeat By Year)

Parameter Description

Special Date Name Enter a special date name.

Task Type Set this parameter to Repeat By Year.

Select Date Set Start Date and End Date.
The end date must be later than or equal to the start
date.

 

Step 4 Click OK.

----End

2.13.2.2 Managing Blocklisted Outbound Numbers
You can blocklist the numbers of unfriendly customers or known numbers that
cannot be called. These blocklisted numbers will not be called during the
execution of outbound call tasks.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Call Config > Blocklist.

By default, the outbound number blocklist displays the blocklisted numbers of the
tenant space.
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Figure 2-551 Blocklist

Step 2 Create a blocklist category.

1. Click New. The Add Number to Blocklist dialog box is displayed.
2. Click Blocklist Category. The Select Blocklist Category dialog box is

displayed.
3. In the Select Blocklist Category dialog box, click New to create a blocklist

category.

Step 3 Configure outbound number blocklist data.
● Adding numbers one by one

a. Click New. The Add Number to Blocklist dialog box is displayed.

Figure 2-552 Add Number to Blocklist

Table 2-166 GUI elements on the Add Number to Blocklist page

Element/Component Description

Called Number Blocklisted number.
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Element/Component Description

Blocklist Category ▪ If no blocklist category exists, create a
blocklist category by referring to Step 2.

▪ If a blocklisted number is not bound to a
blocklist category, the number is a global
blocklisted number and takes effect for all
outbound call tasks.

▪ If a blocklisted number is bound to a
blocklist category, the number takes effect
only for outbound call tasks bound to the
blocklist category when being created.

Validity Time (Hour) Validity period of a blocklisted number, in
hours. The value ranges from 1 to 120. For
example, if you enter 1, the blocklisted
number becomes invalid 1 hour after it is
created.

Remarks Remarks of a blocklisted number.

 
b. Enter information as prompted and click OK.

● Importing numbers in batches

a. Click .
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Figure 2-553 Setting Import Method to Using file
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Figure 2-554 Setting Import Method to Using server

b. Set the file upload parameters.

Table 2-167 File upload parameters

Parameter Description

Import
Method

The options are as follows:

▪ Using file: A maximum of 50,000 data records can
be imported at a time.

▪ Using server: A maximum of 500,000 data records
can be imported at a time.

Blocklist
Category

Blocklist category.

Server Set this parameter to the IP address of the server
where the blocklist file is located. This parameter is
available when Import Method is set to Using server.
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Parameter Description

File Address Set this parameter to the relative path of the default
path on the file server where the blocklist file is
located. This parameter is available when Import
Method is set to Using server.

File Name Enter the import file name including the file name
extension. This parameter is available when Import
Method is set to Using server.

Parsing Mode The option is as follows:

▪ By template: Click

 to download
the import file template.

Select File Upload a local file. This parameter is available when
Import Method is set to Using file.

 

c. Click  to import outbound number blocklist data using scheduled
tasks. The number of scheduled tasks for importing blocklist data is
restricted by the tenant parameter Maximum number of scheduled
tasks in the outbound call blocklist. The default value is 10. To change
the value, go to the Configuration Center > System Management >
Tenant Parameter page.
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Figure 2-555 Scheduled Import

d. Click OK to import the outbound number blocklist data.
e. On the Blocklist page, click the import result icon to view the imported

data.

Step 4 On the Blocklist page, enter a blocklisted number in the called number text box
and press Enter to search for information about the blocklisted number.

----End

2.13.2.3 Defining Business Results

The business result refers to the processing result of the outbound call service.
Tenant administrators define common business result types. Agents mark the
business result based on the business execution result during the outbound call
process.

Context

For outbound calls, tenant A has the following business results:

1: success

2: failure

3: uncertain

The business result 2 (failure) has the following sub-business results:

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 952



1: The customer does not want to purchase the product.

2: The customer has purchased the product.

The business result 3 (uncertain) has the following two sub-business results:

1: The call is not answered by the customer.

2: The call is interrupted.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Call Config > Business Results.

Figure 2-556 Business Results

Step 2 Click . In the Create Business Result dialog box, enter related
information.

Figure 2-557 Create Business Result

Step 3 Click OK.

Step 4 Click Sub-business result in the Operation column corresponding to the new
business result and click New.
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Figure 2-558 Page for creating a sub-business result

Step 5 Configure the sub-business result content and click Save.

Step 6 (Optional) Click Edit to modify the name and description of the sub-business
result.

NO TE

The name of a referenced sub-business result cannot be modified.

Step 7 Enable Appointment Pop-up Screen corresponding to the business result. After
an agent selects and saves the business result on the outbound call workbench,
the reserved outbound call task dialog box is displayed.

Step 8 Enable Business Target corresponding to the business result. After an agent
selects and saves the business result on the outbound call workbench, the number
of calls that have achieved the business target is incremented by 1 on the
Outbound Call > Call Monitor page.

----End

2.13.2.4 Defining Outbound Call Data Attributes

The purpose of defining outbound call attributes is to create customized attributes
for outbound call data configuration. The attributes can be used for outbound call
filtering and sorting.

Context

A tenant can set business information about a specific enterprise, for example, the
customer name and arrears amount defined in an outbound call attribute.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Call Config > Data Attr.
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Figure 2-559 Data Attr

Step 2 Click New and configure attribute parameters.

Figure 2-560 Create Attribute
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Table 2-168 Parameters on the Create Attribute page

Parameter Description

Attribute
Name

Attribute name, which is customized. The value can contain a
maximum of 20 characters.

Attribute
Code

Attribute code, which is customized. The value can contain a
maximum of 30 characters.
Digits, letters, and hyphens (-) are allowed. When letters are used
as attribute codes, outbound call attributes can be sorted in
alphabetical order.

Marketing
Mode

● Telemarketing
● Multimedia marketing
● Public (available for both Telemarketing and Multimedia

marketing)

Attribute
Type

Attribute type. The options are as follows:
● String
● Digit
● Encryption
NOTE

For security purposes, set Attribute Type to Encryption if the attribute
contains personal data, such as the customer ID card number.

Push to
Agent

The options are as follows:

● : The attribute is displayed on the outbound call
workbench.

●

Mandatory The options are as follows:

●

●

Anonymize
d

The options are as follows:

●

●
NOTE

For security purposes, set Anonymized to Yes if the attribute contains
personal data, such as the customer ID card number.
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Parameter Description

Editable The options are as follows:

●

●

 

Step 3 Click OK. The attribute is successfully created and is in unpublished state.

Step 4 (Optional) If the created data attribute is incorrect, click Edit in the Operation
column to edit the attribute content, including Attribute Name, Push to Agent,
Mandatory, Anonymized, and Editable.

(Optional) If the data attribute is no longer needed, click Delete in the Operation
column to delete it.

Step 5 Click Publish in the Operation column corresponding to the new data attribute to
publish it.

Step 6 Select a published data attribute and click Unpublish to cancel it.

----End

2.13.2.5 Defining Outbound Call Results
Outbound call results can be defined to identify the causes of failed outbound call
tasks.

Context
For failed calls, the outbound call system records cause codes based on the failed
process nodes and communication signaling. Cause codes can be configured in
sequence based on business scenarios. Multiple cause codes can be aggregated
into one outbound call failure cause, based on which outbound call results are
pushed back.

The mappings between outbound call failure causes and cause codes are preset in
the system before delivery. You can customize the mappings as required.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Call Config > External Result.

Figure 2-561 External Result
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Step 2 Click New to create an outbound call result.

Figure 2-562 Create Outbound Call Failure Cause

Step 3 Configure the outbound call failure cause and click Add to add outbound call
results.
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Figure 2-563 Adding outbound call results

Step 4 Select one or more outbound call results and click OK.

Step 5 Click OK.

----End

2.13.2.6 Creating Outbound Call Templates

The use of outbound call templates facilitates creation of outbound call tasks.
Many outbound call tasks use similar settings, except time and names. Therefore,
using an existing outbound call template considerably shortens the time spent in
creating outbound call tasks.

Procedure

Scenario 1: Create a common IVR outbound call template.

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Call Config > Call Template.
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Figure 2-564 Call Template

Step 2 Choose New > Robot outbound call template.

Figure 2-565 Creating a robot outgoing call template

Step 3 Configure basic template information.

1. Click the Caller Number selection box. The Select Calling Number dialog
box is displayed. The default value of Priority is 3. You can select a value from
the drop-down list.
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Figure 2-566 Select Calling Number

2. Select calling numbers and click OK.
3. Select an IVR flow and click OK.
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Step 4 Configure the outbound call period.

Figure 2-567 Outbound Call Duration

● Regular Date Time Period (mandatory): Set at least one outbound call time
period.

● Special Time Period (Optional): If special dates are configured, set at least
one outbound call time period for the special dates.

● Special Date (Optional): Click , select special dates in
the add special date dialog box, and click OK. For details about how to
configure special dates, see 2.13.2.1 Managing Special Dates.
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Figure 2-568 add special date

Step 5 Click Next.

Figure 2-569 Outbound Strategy

Step 6 Click Confirm.

Step 7 On the Call Template page, click Publish corresponding to the new outbound call
template in Draft state. The template changes to the Published state.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 963



Step 8 (Optional) To modify a published outbound call template, click Suspend. After the
template changes to the Suspended state, click Edit to edit the template. After
the editing is complete, click Publish to change the template to the Published
state. (Optional) To delete an unnecessary outbound call template, click Delete.

----End

Scenario 2: Create a manual outbound call template. (This scenario is not
supported in independent deployment mode.)

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Call Config > Call Template.

Step 2 Choose New > Manual outgoing call template.

Figure 2-570 Create Manual Outbound Call Template

Step 3 Enter basic information as required and click Save.

----End

Scenario 3: Create a system automatic outbound call template.

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Call Config > Call Template.

Step 2 Choose New > System automatic outbound call template.
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Figure 2-571 Creating an Automatic Outbound Call Template

Step 3 Enter information on the Task Information and Outbound Strategy tab pages as
required and click Confirm.

Figure 2-572 Outbound Strategy

----End

2.13.2.7 Managing the Special List

Invalid numbers can be automatically filtered. The invalid numbers or system
prompt tones identified by outbound call tasks can be added to the special list.
The tenant administrator determines whether to transfer these numbers to the
blocklist or ignore them.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call >
Special List.

By default, numbers that have been added to the outbound call special list of the
tenant space are displayed.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 965



Figure 2-573 Special List page

Step 2 Perform the following operations on numbers in the special list:
● Misjudge

a. Select a misjudged number and click Misjudge.
b. In the Remarks text box, enter the reason why the number is misjudged.
c. Click Save. The outbound number is removed from the special list.

● Transfer To Blocklist

a. Select a number to be added to the blocklist and click Transfer To
Blocklist.

b. Click OK. The outbound number is added to the blocklist.

Step 3 Enter a number in the search criteria to query information about the number to
be reviewed.

----End

2.13.2.8 Configuring an Outbound Call File Server

A tenant administrator can configure a server for storing outbound call files.

Context

When configuring outbound call data in an outbound call task, you can import
data from a server. In this case, you need to configure the source SFTP server and
related file information, and select a file-data mapping rule.

You can import a blocklist from a server. Upload the blocklist template to the
corresponding path on the server, and enter the file name and path when
importing the blocklist.

You can import multimedia marketing data from a server. Upload the multimedia
marketing data template to the corresponding path on the server, and then enter
the file name and path when importing multimedia marketing data. In addition,
you can select a parsing mode for a mapping rule.
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Prerequisites
You have contacted the system administrator to add the IP address of a file server
to the trustlist.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Call Config > File Server.

Step 2 Click New to add an outbound call file server.

Set Type to SFTP or OBS as required.

Figure 2-574 Adding an SFTP file server
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Figure 2-575 Authentication mode being Public Key

● Type: Set this parameter to SFTP.
● IP Address: IP address of the file server where outbound call data is stored.

The IP address must be in the trustlist.
● Port: Port number of the server.
● Username: Username for logging in to the server. The value can contain a

maximum of 30 characters.
● Authentication Mode: Password Authentication and Public Key are

supported.
● Key Type: RSA and ECDSA are supported.
● Key Length: maximum length of the key; unit: character. If this field is

modified, the public key is automatically updated. The public key of the server
should be updated in time.

● Password and Confirm Password: Password for connecting to the server.
● Default Path: Path for storing outbound call data. The value must start

with /.
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Figure 2-576 Adding an OBS file server

● Type: Set this parameter to OBS. Object Storage Service (OBS) provides
customers with secure, highly-reliable, and low-cost data storage of massive
data without considering the capacity limit. In addition, OBS provides
customers with multiple storage types to meet their requirements in various
business scenarios. For details, see OBS.

● IP Address: IP address for storing outbound call data files.
● Bucket: Container for storing objects in OBS.
● AK and SK: Access key of the OBS server, which is used for authentication.

The AK and SK are obtained after OBS is purchased.

NO TE

OBS file servers are supported only in the SaaS environment.

Step 3 Click OK to save the outbound call file server configuration.

----End

2.13.2.9 Importing Mapping Rules

A tenant administration can specify the mapping between outbound call data
import files and data import rules.

Context

When configuring outbound call data in an outbound call task, you can import
data from a server. In this case, you need to configure the source SFTP server and
related file information, and select a file-data mapping rule.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Call Config > Mapping Rule.

Step 2 Click New to add a mapping rule between outbound call data fields and the
column numbers of the fields in the imported file.

Figure 2-577 Add Rule

Table 2-169 GUI elements on the Add Rule page

Element/
Component

Description

Basic Information: Mapping rule information.

Rule Name Customized rule name.

Marketing
Mode

● Telemarketing
● Multimedia marketing

Description Description of a mapping rule.

Number Data: Mapping rule between outbound call data fields and the column
numbers of the fields in the imported Excel file.

Customer ID Number of the column where the field is located in the
imported file.

Number
Column

Number of the column where the field is located in the
imported file.

Type Column Number of the column where the field is located in the
imported file.

Call Interval
Column

Number of the column where the field is located in the
imported file.
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Element/
Component

Description

Service Attribute: Mapping rule between outbound call data attribute fields
and the column numbers of the fields in the imported file.

Attribute
Name

Configured attribute.

Attribute
Column

Column number of an attribute in the imported file.

Operation Deletion is supported.

 

Step 3 Click OK.

Step 4 (Follow-up operation) On the Outbound Call > Call Mgmt page, click Contact
list in the Operation column corresponding to an outbound call task. Click
Import, set Parsing Mode to By rule, and select the new mapping rule.
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Figure 2-578 Using a mapping rule

----End

2.13.2.10 Managing Task Groups

Context

Different percentages (with a sum of 100%) can be set for tasks in a task group.
During data import, data is imported to specified outbound call tasks based on
the percentages.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Call Config > Task Group Management.

Step 2 Click New.
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Figure 2-579 Create task group

● Task group name: The task group name must be unique in a tenant space
and cannot contain the following special characters: `~!@#$%^&*()+=|{}'":;\
[]/?.¥...',

● describe: Enter a task group description. The description cannot exceed 255
characters.

● mission name: Only outbound call tasks in the Waiting, Completed,
Suspended, Executing, or Draft state can be selected. Outbound call tasks
that are already in other task groups cannot be selected.

● contact list: View the batch name.
● Proportion(%): Enter a positive integer ranging from 1 to 100. The sum of

percentages must be 100%. During data import, data is allocated based on
the percentage.

Step 3 Click Save.

Step 4 Click Import. In the Import dialog box, download the outbound call data
template, fill in the template, upload the file, and click OK. For details about how
to import outbound call data, see Importing Outbound Call Data.
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Figure 2-580 Import

NO TE

If the associated target task has expired or been archived, data cannot be imported again.

Step 5 Click Import Result to check the imported content.

Step 6 (Follow-up activity) After the outbound call data is successfully imported, access

the Outbound Call > Call Mgmt page, enable , and execute the
outbound call task.

----End

2.13.3 Managing Outbound Call Tasks
A tenant administrator can manage telemarketing activities for specified customer
groups by creating outbound call tasks and importing customer numbers to the
tasks.

2.13.3.1 Creating Common IVR Outbound Call Tasks or Intelligent Robot
Outbound Call Tasks

This section describes how to create common IVR outbound call tasks or
intelligent robot outbound call tasks.
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Prerequisites
● To create a common IVR outbound call task, you have configured and

published a main IVR flow. For details about how to configure a common IVR
flow, see 2.6.1 Getting Started. To create an intelligent outbound call task,
you have configured and published a main intelligent IVR flow. For details
about how to configure an intelligent IVR flow, see 2.6.2 Configuring an
Intelligent Robot.

NO TE

In independent deployment mode, you have configured the IVR flow on the web
configuration console.

● To create an outbound call task, you have completed the operations in 2.13.2
Preparations for Creating Outbound Call Tasks.

● If the tenant space is in trial commercial use, you have contacted O&M
personnel to add the numbers used for making outbound calls to the tenant
space trustlist.

● To send SMS notifications for failed outbound calls, you have configured an
internal SMS template on the Configuration Center > Workbench
Configuration > Notification Template page. For details about how to
configure an SMS notification template, see 2.11.5 Configuring Notification
Templates as an Administrator. Set Template Type to HUAWEI CLOUD
SMS Messages.

● To configure a callback URL, you have submitted an application for adding
the callback URL to the address trustlist to the system administrator, and the
system administrator has approved the application.

Context

In a common IVR outbound call task, the system makes an outbound call to a
customer and the call is transferred to a specified IVR flow after being connected.
The IVR flow then plays a voice and collects digits from the customer.

Select a configured outbound call template where certain outbound call task
parameters are preset. For details, see 2.13.2.6 Creating Outbound Call
Templates.

You can modify, start, or delete a task in draft state, and configure outbound call
data for the task.

Business Scenario

The following describes how to configure an automatic outbound call task for a
call center to notify customers of major product changes by playing voices. The
outbound call task is executed in working hours on workdays and also on
weekends. If a customer is busy, the call is made to the customer for another two
times.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > Call
Mgmt.
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Step 2 Click Create and choose Robot Outbound Call.

Figure 2-581 Page for creating a common IVR outbound call task

Step 3 Configure basic information.
● Task Name: Enter a customized task name.
● Caller Number: Select an existing calling number of the current tenant space.

A maximum of 100 calling numbers can be added.
● Task Start And End Time: The start time cannot be later than the end time.
● Task Type: Select Common IVR Outbound Call or Intelligent Robot

Outbound Call.
● Common IVR: Select an IVR flow that has been configured and published.
● Smart Robot: Only robots bound to the main flow can be selected.
● Questionnaire: An IVR survey needs to be used together with the

questionnaire diagram element in an IVR flow. A manual and IVR survey can
be used on the outbound call workbench or used together with the
questionnaire diagram element in an IVR flow.

● SMS Template for Failed Outbound Call: Select a configured internal SMS
notification template. For details about how to configure an SMS notification
template, see 2.11.5 Configuring Notification Templates as an
Administrator. Set Template Type to HUAWEI CLOUD SMS Messages.

● Priority: Select a value from 1 to 5. A smaller value indicates a higher priority.
If tasks are started at the same time, the task with a higher priority is called
preferentially.

● Transfer to Skill Queue: After a skill queue is selected, the Variable
assignment diagram element in the IVR flow is used to obtain the value of
SkillQueueName (skill queue name) in the call-associated data. The skill
queue name is used to transfer a call to a skill queue when Transfer Type is
set to Skill Queue (Name) for the Call Transfer diagram element.

a. Variable assignment
Click the Flow Attribute tab and create the FLOW.chuichui variable in
the Flow Variable area.
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Click the Node Attribute tab, click the Obtaining Associated Data tab,
and create the FLOW.chuichui=iSales.SkillQueueName variable.

b. Call Transfer
Set Transfer Type to Skill Queue (Name).
Set Route Value to FLOW.chuichui.
Set Associated Data to IVRREQUEST.transin_data.

Figure 2-582 Variable assignment

Figure 2-583 Call Transfer

● Associate Business Result: This field is displayed only after Transfer to Skill
Queue is set for an intelligent robot outbound call task. If a business result is
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associated, only the associated business result and its sub-business results can
be selected for outbound calls.

● Manual Questionnaire: This field is displayed only when Transfer to Skill
Queue is set. Only manual surveys and manual and IVR surveys are available.
If a manual survey is selected, the survey is displayed on the outbound call
workbench. A manual and IVR survey can be used on the outbound call
workbench or used together with the questionnaire diagram element in an
IVR flow.

● Blocklist Type: If a blocklist category is selected, all numbers in the blocklist
are not called within the specified period.

● Callback Address: Enter the URL for callback upon call connection or release
on the customer side.

NO TE

The callback URL is a third-party URL and can carry data. The carried parameters
include dataId, taskId, sessionId, calledNo, beginTime, vdnId, failCode, callId,
filePath, and customFiled.

In the integrated environment, the callback URL can be configured only in the
outbound call task.

Step 4 Configure the outbound call period. The parameters take effect according to the
following priority: Allocate time periods by special dates > Special Date >
Regular Date Time Period.

Figure 2-584 Outbound Call Duration

1. In Regular Date Time Period(UTC+08:00), set the start time and end time of
the working period. Examples are as follows:
9:00–11:30
14:00–18:00

2. In Special Date, click add special date to add days such as holidays and
weekends as special dates.
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3. In Special Time Period(UTC+08:00), click Add Time Period and set Start
Time and End Time to 00:00 and 23:59, respectively.

4. In Allocate time periods by special dates(UTC+08:00), set a period. If this
function is not required, disable it.

NO TE

If calls do not need to be made on some special dates, for example, weekends, you
can set Regular Date Time Period(UTC+08:00) to 00:00 - 23:59, set weekends as
special dates, and set Special Time Period(UTC+08:00) to 00:00 - 00:00, as shown in
the following figure.

Step 5 Click Next and configure the task policy.

Figure 2-585 Task Strategy

Table 2-170 Parameters in the Task Strategy area

Parameter Description

Max. Response
Duration

If the response duration exceeds this value, the
current call ends and the next call is to be made.
The value ranges from 5 to 120. The default value is
20.

Outbound Call Interval Interval for starting an outbound call.
Enter an integer ranging from 1 to 9999.
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Parameter Description

Number of Outbound
Calls at a Time

Number of outbound calls each time. The default
value is 1.
The value cannot exceed the number of purchased
IVR channels in the tenant space.
If the value of Outbound Call Interval is greater
than 3, the number of outbound calls initiated by the
system is calculated as follows: Value of Number of
Outbound Calls at a Time/Value of Outbound Call
Interval x 3.

Outbound Call Data
Attribute Filtering

You can customize data attributes on the
Configuration Center > Call Config > Data Attr
page.
Enable this parameter to customize filter criteria. The
system initiates an outbound call only when the pre-
called customer number meets the criteria. Encrypted
attributes cannot be used as filter criteria.
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NO TE

Outbound Call Interval and Number of Outbound Calls at a Time should be configured
to make a fixed number of outbound calls on average with proper intervals rather than
make all outbound calls at once.
For example, if you want to make 60 outbound calls in 1 minute, you are advised to set
both Outbound Call Interval and Number of Outbound Calls at a Time to 3 instead of
60.
For a key robot outbound call or intelligent outbound call task, the number of outbound
calls is calculated as follows: (Value of Number of Outbound Calls at a Time/Value of
Outbound Call Interval) x 3, rounded up. Outbound calls are made only when the result is
greater than 1. If the value of Outbound Call Interval is greater than 3, 3 is used for
calculation. If the value of Outbound Call Interval is less than 3, the actual value is used.
● Q1: If the value of Outbound Call Interval is greater than 3, 3 is used for calculation. If

the value of Outbound Call Interval is less than 3, the actual value is used. What is the
meaning?
A1: If the outbound call interval is set to an interval greater than 3 seconds, the OBS
still uses 3 seconds as the call interval. If the outbound call interval is set to an interval
less than 3 seconds, the configured call interval is used.

● Q2: If I set Outbound Call Interval to 10 and Number of Outbound Calls at a Time to
100, how many outbound calls are made every 10 seconds? 100 or 30?
A2: The outbound call interval configured for the outbound call task is used only to
calculate the number of calls made each time. When the value is greater than 3, it does
not indicate the actual call interval. If you set Outbound Call Interval to 10, the actual
call interval is 3 seconds. In this case, the number of calls made each time is 30 based
on the formula: (Value of Number of Outbound Calls at a Time/Value of Outbound
Call Interval) x 3. That is, 30 outbound calls are made every 3 seconds.

● Q3: If I set Outbound Call Interval to 1 and Number of Outbound Calls at a Time to
10, will 30 outbound calls be made every second?
A3: In this case, 10 outbound calls are made every second.

● Q4: What will happen if the calculated number of outbound calls is less than 1?
A4: In this case, no outbound call is made at the first interval. An outbound call is made
until the decimal part of the value of Number of Outbound Calls at a Time
accumulates to greater than 1.

Step 6 Configure the call policy.

1. In the Call Strategy area, customize the pre-called customer numbers. Set
parameters based on Table 2-171.
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Figure 2-586 Call Strategy

Table 2-171 Parameters in the Call Strategy area

Parameter Description

Call Sequence: Customize the call sequence of pre-called customer
numbers.

Unordered call -

By No -

By data attribute Click Add, select attributes, and set the sorting type.
You can adjust the attribute sequence after adding the
attributes.

Multi-number customer call rounds: Mode for calling multiple numbers
of a customer.

In sequence Call multiple numbers of a customer in sequence.

By number type You can select Existing number type or New number
type. After the configuration, the number with the
specified type placed ahead is called first.
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Parameter Description

By sequence
number

You can enter the sequence numbers of numbers. After
the configuration, the number with a smaller sequence
number is called first.

 

2. Configure Outbound Call Result Policy, which indicates the processing
method when an outbound call is not connected due to an unallocated
number, busy line, or other exceptions. Select Global policy or Contact
Policy.
– Global policy

▪ Disable Configure Policy Based On Results.
Set Max. Call Attempt Days, Maximum number of call attempts
per day, and Call-Out Interval (s).

Click  and set Add non-retry result code. When the result of
an outbound call to a customer matches a result code configured in
Add non-retry result code, the system stops retrying calling all
other numbers of the customer.

Figure 2-587 Disabling Configure Policy Based On Results

▪ Enable Configure Policy Based On Results.

In Results processing strategy, click  and set Outbound
Call Failure Cause, Retry Times and Call-Out Interval (s). Click

 for multiple times to add multiple policies one by one.
Policies with the same values of Outbound Call Failure Cause
cannot be added.
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Click  and set Add non-retry result code. When the result
of an outbound call to a customer matches a result code configured
in Add non-retry result code, the system stops retrying calling all
other numbers of the customer.

Figure 2-588 Enabling Configure Policy Based On Results

NO TE

If the outbound call interval is set to a large value, outbound call operations
indicators, such as the call connection rate, may be affected. You are advised to
use the default value.

– Contact Policy

▪ Default number type: Set Whether to configure based on the
result to configure the policy.

If it is set to No, you can set Max. Call Attempt Days and
Maximum number of call attempts per day.

Figure 2-589 Setting Whether to configure based on the result to No

If it is set to Yes, you can set Outbound Call Failure Cause, Retry

Times, and Call-Out Interval (s). Click  for multiple times
to add multiple policies one by one. Policies with the same values of
Outbound Call Failure Cause cannot be added.
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Figure 2-590 Setting Whether to configure based on the result to Yes

▪ Added number type: Click  to access the Configure Policy
Based On Results dialog box. You must set Number Type first
regardless of whether Configure Policy Based On Results is
enabled, and then set other parameters.
If Configure Policy Based On Results is disabled, set Number Type
to New number type and set Max. Call Attempt Days and
Maximum number of call attempts per day.

Figure 2-591 Disabling Configure Policy Based On Results

If Configure Policy Based On Results is enabled, set Number Type

to New number type, click , and set Outbound Call
Failure Cause, Maximum number of call attempts, and Call-Out

Interval (s). Click  for multiple times to add multiple
policies one by one. Policies with the same values of Outbound Call
Failure Cause cannot be added.
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Figure 2-592 Enabling Configure Policy Based On Results

Step 7 (Optional) Click Save as Template. In the dialog box that is displayed, enter a
template name and click confirm to save the current configuration as an
outbound call template.

Step 8 Click Save.

Step 9 Return to the Call Mgmt page, click Contact list in the Operation column
corresponding to the new outbound call task, and add outbound call data to the
outbound call task. For details, see 2.13.3.7.1 Configuring Outbound Call Data.

Step 10 Return to the Call Mgmt page and click  corresponding to the new
outbound call task.

----End

Follow-up Procedure
To modify an outbound call task, click Suspend to suspend it.

After the task is suspended, click Edit to modify the outbound call task. The
procedure for changing the calling number is as follows:

1. Click Caller Number. The page for selecting a calling number is displayed.
The selected calling number is displayed by default.
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Figure 2-593 Select Calling Number

2. Click Add and select another calling number. The selected calling number
cannot be selected again. The number of new calling numbers cannot exceed
the Maximum number of calling numbers configured by an administrator.

Figure 2-594 Adding a calling number

3. Click OK. Return to the Select Calling Number page and click OK.

To view the task result, you can click a task to access the outbound call task
details page and click the outbound call result on the outbound call task details
page to view the outbound call result for each customer.

NO TE

To enable the recording function for intelligent robot outbound call results, choose
Configuration Center > Chatbot Management > Flow Configuration > System > System
Settings, click the System Settings tab, and set FLOWRECORDFLAG (whether to enable
the recording function for intelligent IVR call flows) to Enable. In this way, Play is displayed
for intelligent robot outbound call results.
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On the task result page, you can perform the following operations:

● Click Details to view all outbound call results of all called numbers under the
customer.

● Click Business Result to remark the called outbound numbers.
● Click Export to export the task result.
● Click View Export Result to view the export result. On the displayed page,

you can download the result.

NO TE

The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

2.13.3.2 Creating Predicted Outbound Call Tasks
To ensure call efficiency and connect to as many customers as possible without
annoying them, the system dynamically adjusts the number of agent outbound
calls and automatically assigns the calls to agents according to multiple
algorithms. This task is time-effective for the agents.

Prerequisites
● The platform role of a user account is agent.
● To create an outbound call task, you have completed the operations in 2.13.2

Preparations for Creating Outbound Call Tasks.
● At least one voice skill queue exists. For details about the configuration

method, see 2.3.1.1 Maintaining a Tenant Space Skill Queue. The skill
queue has been associated with the agent who needs to make an outbound
call. For details about the association method, see 2.3.1.3 Associating an
Allocated Agent ID with a Business Account and Skill Queue.

● If the tenant space is in trial commercial use, you have contacted O&M
personnel to add the numbers used for making outbound calls to the tenant
space trustlist.

● To send SMS notifications for failed outbound calls, you have configured an
internal SMS template on the Configuration Center > Workbench
Configuration > Notification Template page. For details about how to
configure an SMS notification template, see 2.11.5 Configuring Notification
Templates as an Administrator.

● To configure a callback URL, an application has been submitted to the system
administrator and approved to add the callback URL to the address trustlist.

Context
A predicted outbound call task depends on algorithms. The system provides the
following algorithms for a call center to automatically calculate the number of
calls to be assigned to each agent:

● Algorithm for Empirical Prediction: monitors and collects statistics on
parameters such as the off-hook rate, average call duration, and number of
queuing calls in real time to control the outbound call speed to indirectly
reduce queuing calls. In this way, the agent usage is maximized under
acceptable call loss conditions.
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This algorithm applies to the scenarios with more than 15 agents, a relatively
stable call process, and all factors following the normal distribution, that is,
objective factors such as the off-hook rate, call duration, number of agents in
working state, wrap-up state duration, and queuing duration do not change
dramatically and can be collected.

● Algorithm for Agent Usage: dynamically adjusts the number of calls
assigned to each agent by controlling the agent usage and call loss rate.

● Algorithm for Outbound Call Connection Rate: dynamically adjusts the
number of calls assigned to each agent by controlling the call loss rate,
customer waiting time, and call connection rate.

● Algorithm for Offhook Rate: makes predicted outbound calls based on the
current off-hook rate. This algorithm reduces the changes in the number of
agents and call duration, and minimizes the call loss caused by the changes.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > Call
Mgmt.

Step 2 Click Create and choose System Automatic Outbound Call. On the Create
System Auto Outbound Call page, set Task Type to Predicted Outbound Call.

Figure 2-595 Page for configuring the basic information of a predicted outbound
call task

Step 3 Configure basic information.
● Task Name: Enter a customized task name.
● Caller Number: Select an existing calling number of the current tenant space.

A maximum of 100 calling numbers can be added.
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● Task Start And End Time: Select the task start time and end time.
● Task Type: Select Predicted Outbound Call. For an outbound call task

created using a template, the value of this parameter is the type configured in
the template by default and cannot be changed.

● Skill Queue: Select an existing skill queue. For details about how to configure
a skill queue, see 2.3.1.1 Maintaining a Tenant Space Skill Queue.

● Questionnaire: Only Manual Questionnaire and Manual vs. IVR
Questionnaire are supported. A manual and IVR survey can be used on the
outbound call workbench or used together with the questionnaire diagram
element in an IVR flow.

● SMS Template for Failed Outbound Call: Select a configured internal SMS
notification template. For details about how to configure an SMS notification
template, see 2.11.5 Configuring Notification Templates as an
Administrator.

● Priority: Select a value from 1 to 5. A smaller value indicates a higher priority.
If tasks are started at the same time, the task with a higher priority is called
preferentially.

● Play Voice: When an agent makes an outbound call, a recording can be
played to the customer. Voice resources are prompt tones with Status being
Approved on the Configuration Center > Resource Management > Audio
and Video page. A maximum of 10 voice resources can be selected.

Figure 2-596 Playing a recording

● Associate Business Result: After an outbound call task is associated with a
business result, only the associated business result and its sub-business results
can be selected for outbound calls in the task. If Appointment Pop-up
Screen is enabled for the business result, after the business result is selected
for an outbound call, the dialog box for creating a reserved outbound call task
is displayed.

● Callback Address: Enter the URL for callback upon call connection or release
on the customer side. An example is https://support.huaweicloud.com/
productdesc-cec/cec_01_0001.html.

NO TE

The callback URL is a third-party URL and can carry data. The carried parameters
include dataId, taskId, sessionId, calledNo, beginTime, vdnId, failCode, callId,
filePath, and customFiled.
In the integrated environment, the callback URL can be configured only in the
outbound call task.
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● Blocklist Type: If a blocklist category is selected, all numbers in the blocklist
are not called within the specified period.

Step 4 Configure the outbound call period. The parameters take effect according to the
following priority: Allocate time periods by special dates > Special Date >
Regular Date Time Period.

Figure 2-597 Outbound Call Duration

1. In Regular Date Time Period(UTC+08:00), set the start time and end time of
the working period. Examples are as follows:
9:00–11:30
14:00–18:00

2. In Special Date, click add special date to add days such as holidays and
weekends as special dates.

3. In Special Time Period(UTC+08:00), click Add Time Period and set Start
Time and End Time to 00:00 and 23:59, respectively.

4. In Allocate time periods by special dates(UTC+08:00), set a period. If this
function is not required, disable it.
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NO TE

If calls do not need to be made on some special dates, for example, weekends, you
can set Regular Date Time Period(UTC+08:00) to 00:00 - 23:59, set weekends as
special dates, and set Special Time Period(UTC+08:00) to 00:00 - 00:00, as shown in
the following figure.

Step 5 Configure the task policy by referring to Table 2-172, which describes the key
parameters for each algorithm.

NO TICE

The following parameter settings must be verified and optimized for multiple
times. If you are not sure about the initial settings, retain the recommended
settings and adjust them later based on the outbound call effect.

Figure 2-598 Task Strategy
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Table 2-172 Key parameters for each algorithm in the Task Strategy area

Algorith
m Type

Parameter Description

Algorith
m for
Empirical
Predictio
n

Outbound Call
Speed

Prediction factor of the maximum outbound call
speed, which is calculated by the system based
on the empirical model.
You are advised to set this parameter based on
the project type and dialing test result for each
average call duration. Set this parameter to 70
for projects whose average call duration is less
than 100 seconds, to 40 for projects whose
average call duration is between 100 seconds
and 140 seconds, and to 20 for projects whose
average call duration is between 140 seconds
and 180 seconds.

Algorith
m for
Agent
Usage

Min. Call Loss
Rate

The call loss rate is the ratio of calls that are
hung up during queuing to the total off-hook
calls.
Set this parameter to the minimum call loss rate.
When the call loss rate calculated by the system
exceeds the value of this parameter, the system
reduces the calls assigned to the agent to
prevent the call loss rate from increasing.

Agent Usage Agent usage threshold.
When the agent usage calculated by the system
exceeds the value of this parameter, the system
reduces the calls assigned to the agent to
prevent the call loss rate from increasing.

Method for
Calculating
Agent Usage

Whether the numerator includes the working
state duration (that is, the wrap-up state
duration).

Algorith
m for
Outboun
d Call
Connecti
on Rate

Min. Call Loss
Rate

The call loss rate is the ratio of calls that are
hung up during queuing to the total off-hook
calls.
Set this parameter to the minimum call loss rate.
When the call loss rate calculated by the system
exceeds the value of this parameter, the system
reduces the calls assigned to the agent to
prevent the call loss rate from increasing.

Outbound Call
Connection Rate

Ratio of connected calls to the total calls. Set this
parameter to the maximum connection rate.
When the call connection rate is less than the
value of this parameter, the system reduces the
calls assigned to the agent.
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Algorith
m Type

Parameter Description

Called Party's
Waiting Time

Maximum customer waiting time, in seconds. If
the waiting time exceeds the value of this
parameter, the system reduces the calls assigned
to the agent to prevent customers from waiting
for a long time.

Algorith
m for
Offhook
Rate

Calculation
Factor

Off-hook rate calculation factor. If multiple
agents meet the routing rules, the system
preferentially assigns calls to the agent with a
high off-hook rate.

 

Step 6 Configure the call policy.

1. In the Call Strategy area, customize the pre-called customer numbers. Set
parameters based on Table 2-173.

Figure 2-599 Call Strategy

Table 2-173 Parameters in the Call Strategy area

Parameter Description

Call Sequence: Customize the call sequence of pre-called customer
numbers.

Unordered call -

By No -
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Parameter Description

By data attribute Click Add, select attributes, and set the sorting type.
You can adjust the attribute sequence after adding the
attributes.

Multi-number customer call rounds: Mode for calling multiple numbers
of a customer.

In sequence Call multiple numbers of a customer in sequence.

By number type You can select Existing number type or New number
type. After the configuration, the number with the
specified type placed ahead is called first.

By sequence
number

You can enter the sequence numbers of numbers. After
the configuration, the number with a smaller sequence
number is called first.

 

2. Configure Outbound Call Result Policy, which indicates the processing
method when an outbound call is not connected due to an unallocated
number, busy line, or other exceptions. Select Global policy or Contact
Policy.
– Global policy

▪ Disable Configure Policy Based On Results.
Set Max. Call Attempt Days, Maximum number of call attempts
per day, and Call-Out Interval (s).

Click  and set Add non-retry result code. When the result of
an outbound call to a customer matches a result code configured in
Add non-retry result code, the system stops retrying calling all
other numbers of the customer.
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Figure 2-600 Disabling Configure Policy Based On Results

▪ Enable Configure Policy Based On Results.

In Results processing strategy, click  and set Outbound
Call Failure Cause, Retry Times and Call-Out Interval (s). Click

 for multiple times to add multiple policies one by one.
Policies with the same values of Outbound Call Failure Cause
cannot be added.

Click  and set Add non-retry result code. When the result
of an outbound call to a customer matches a result code configured
in Add non-retry result code, the system stops retrying calling all
other numbers of the customer.

Figure 2-601 Enabling Configure Policy Based On Results

NO TE

If the outbound call interval is set to a large value, outbound call operations
indicators, such as the call connection rate, may be affected. You are advised to
use the default value.

– Contact Policy
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▪ Default number type: Set Whether to configure based on the
result to configure the policy.
If it is set to No, you can set Max. Call Attempt Days and
Maximum number of call attempts per day.

Figure 2-602 Setting Whether to configure based on the result to No

If it is set to Yes, you can set Outbound Call Failure Cause, Retry

Times, and Call-Out Interval (s). Click  for multiple times
to add multiple policies one by one. Policies with the same values of
Outbound Call Failure Cause cannot be added.

Figure 2-603 Setting Whether to configure based on the result to Yes

▪ Added number type: Click  to access the Configure Policy
Based On Results dialog box. You must set Number Type first
regardless of whether Configure Policy Based On Results is
enabled, and then set other parameters.
If Configure Policy Based On Results is disabled, set Number Type
to New number type and set Max. Call Attempt Days and
Maximum number of call attempts per day.
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Figure 2-604 Disabling Configure Policy Based On Results

If Configure Policy Based On Results is enabled, set Number Type

to New number type, click , and set Outbound Call
Failure Cause, Maximum number of call attempts, and Call-Out

Interval (s). Click  for multiple times to add multiple
policies one by one. Policies with the same values of Outbound Call
Failure Cause cannot be added.

Figure 2-605 Enabling Configure Policy Based On Results

Step 7 (Optional) Click Save as Template. In the dialog box that is displayed, enter a
template name and click confirm to save the current configuration as an
outbound call template.

Step 8 Click Save.

Step 9 Return to the Call Mgmt page, click Contact list in the Operation column
corresponding to the new outbound call task, and add outbound call data to the
outbound call task. For details, see 2.13.3.7.1 Configuring Outbound Call Data.

Step 10 Return to the Call Mgmt page and click  corresponding to the new
outbound call task.

----End
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Follow-up Procedure

To modify an outbound call task, click Suspend to suspend it.

After the task is suspended, click Edit to modify the outbound call task. The
procedure for changing the calling number is as follows:

1. Click Caller Number. The page for selecting a calling number is displayed.
The selected calling number is displayed by default.

Figure 2-606 Select Calling Number

2. Click Add and select another calling number. The selected calling number
cannot be selected again. The number of new calling numbers cannot exceed
the Maximum number of calling numbers configured by an administrator.

Figure 2-607 Adding a calling number

3. Click OK. Return to the Select Calling Number page and click OK.
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To view the task result, you can click a task to access the outbound call task
details page and click the outbound call result on the outbound call task details
page to view the outbound call result for each customer.

NO TE

To enable the recording function for intelligent robot outbound call results, choose
Configuration Center > Chatbot Management > Flow Configuration > System > System
Settings, click the System Settings tab, and set FLOWRECORDFLAG (whether to enable
the recording function for intelligent IVR call flows) to Enable. In this way, Play is displayed
for intelligent robot outbound call results.

On the task result page, you can perform the following operations:

● Click Details to view all outbound call results of all called numbers under the
customer.

● Click Business Result to remark the called outbound numbers.
● Click Export to export the task result.
● Click View Export Result to view the export result. On the displayed page,

you can download the result.

NO TE

The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

2.13.3.3 Creating Previewed Outbound Call Tasks

In a previewed outbound call task, the system pushes a customer to an agent (not
to call the agent). After previewing the customer information, the agent manually
executes calls.

Prerequisites
● The platform role of a user account is agent.
● To create an outbound call task, you have completed the operations in 2.13.2

Preparations for Creating Outbound Call Tasks.
● At least one voice skill queue exists. For details about the configuration

method, see 2.3.1.1 Maintaining a Tenant Space Skill Queue. The skill
queue has been associated with the agent who needs to make an outbound
call. For details about the association method, see 2.3.1.3 Associating an
Allocated Agent ID with a Business Account and Skill Queue.

● If the tenant space is in trial commercial use, you have contacted O&M
personnel to add the numbers used for making outbound calls to the tenant
space trustlist.

● To send SMS notifications for failed outbound calls, you have configured an
internal SMS template on the Configuration Center > Workbench
Configuration > Notification Template page. For details about how to
configure an SMS notification template, see 2.11.5 Configuring Notification
Templates as an Administrator.

● To configure a callback URL, an application has been submitted to the system
administrator and approved to add the callback URL to the address trustlist.
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Context
In the predicted outbound call scenario, a call is made to a customer and then to
an agent. When the call reaches the agent, the customer is already online and
waiting. Therefore, the agent does not have enough time to understand the
customer's background information.

In a previewed outbound call task, the system pushes a customer to an agent (not
to call the agent). After previewing the customer information, the agent manually
makes a call.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > Call
Mgmt.

Step 2 Click Create and choose System Automatic Outbound Call. On the Create
System Auto Outbound Call page, set Task Type to Preview Outbound Call.

Figure 2-608 Page for configuring the basic information of a previewed outbound
call task

Step 3 Configure basic information.
● Task Name: Enter a customized task name.
● Caller Number: Select an existing calling number of the current tenant space.

A maximum of 100 calling numbers can be added.
● Start Time: Set this parameter to a value not earlier than the current time.
● End Time: Set this parameter to a value not earlier than the start time.
● Task Type: Select Preview Outbound Call. For an outbound call task created

using a template, the value of this parameter is the type configured in the
template by default and cannot be changed.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1001



● Skill Queue: Select an existing skill queue. For details about how to configure
a skill queue, see 2.3.1.1 Maintaining a Tenant Space Skill Queue.

● Questionnaire: Only Manual Questionnaire and Manual vs. IVR
Questionnaire are supported. A manual and IVR survey can be used on the
outbound call workbench or used together with the questionnaire diagram
element in an IVR flow.

● SMS Template for Failed Outbound Call: Select a configured internal SMS
notification template. For details about how to configure an SMS notification
template, see 2.11.5 Configuring Notification Templates as an
Administrator.

● Priority: Select a value from 1 to 5. A smaller value indicates a higher priority.
If tasks are started at the same time, the task with a higher priority is called
preferentially.

● Play Voice: When an agent makes an outbound call, a recording can be
played to the customer. Voice resources are prompt tones with Status being
Approved on the Configuration Center > Resource Management > Audio
and Video page. A maximum of 10 voice resources can be selected.

Figure 2-609 Playing a recording

● Associate Business Result: After an outbound call task is associated with a
business result, only the associated business result and its sub-business results
can be selected for outbound calls in the task. If Appointment Pop-up
Screen is enabled for the business result, after the business result is selected
for an outbound call, the dialog box for creating a reserved outbound call task
is displayed.

● Callback Address: Enter the URL for callback upon call connection or release
on the customer side.

NO TE

The callback URL is a third-party URL and can carry data. The carried parameters
include dataId, taskId, sessionId, calledNo, beginTime, vdnId, failCode, callId,
filePath, and customFiled.

In the integrated environment, the callback URL can be configured only in the
outbound call task.

● Blocklist Type: If a blocklist category is selected, all numbers in the blocklist
are not called within the specified period.

After the configuration is complete, click Next.
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Step 4 Configure the outbound call period. The parameters take effect according to the
following priority: Allocate time periods by special dates > Special Date >
Regular Date Time Period.

Figure 2-610 Outbound Call Duration

1. In Regular Date Time Period(UTC+08:00), set the start time and end time of
the working period. Examples are as follows:
9:00–11:30
14:00–18:00

2. In Special Date, click add special date to add days such as holidays and
weekends as special dates.

3. In Special Time Period(UTC+08:00), click Add Time Period and set Start
Time and End Time to 00:00 and 23:59, respectively.

4. In Allocate time periods by special dates(UTC+08:00), set a period. If this
function is not required, disable it.

NO TE

If calls do not need to be made on some special dates, for example, weekends, you
can set Regular Date Time Period(UTC+08:00) to 00:00 - 23:59, set weekends as
special dates, and set Special Time Period(UTC+08:00) to 00:00 - 00:00, as shown in
the following figure.
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Step 5 Configure the task policy. Set Preview Timeout Interval (s) and Previewed
Outbound Call Duration.

Step 6 Configure the call policy.

1. In the Call Strategy area, customize the pre-called customer numbers. Set
parameters based on Table 2-174.

Figure 2-611 Call Strategy

Table 2-174 Parameters in the Call Strategy area

Parameter Description

Call Sequence: Customize the call sequence of pre-called customer
numbers.

Unordered call -

By No -

By data attribute Click Add, select attributes, and set the sorting type.
You can adjust the attribute sequence after adding the
attributes.

Multi-number customer call rounds: Mode for calling multiple numbers
of a customer.

In sequence Call multiple numbers of a customer in sequence.
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Parameter Description

By number type You can select Existing number type or New number
type. After the configuration, the number with the
specified type placed ahead is called first.

By sequence
number

You can enter the sequence numbers of numbers. After
the configuration, the number with a smaller sequence
number is called first.

 

2. Configure Outbound Call Result Policy, which indicates the processing
method when an outbound call is not connected due to an unallocated
number, busy line, or other exceptions. Select Global policy or Contact
Policy.
– Global policy

▪ Disable Configure Policy Based On Results.
Set Max. Call Attempt Days, Maximum number of call attempts
per day, and Call-Out Interval (s).

Click  and set Add non-retry result code. When the result of
an outbound call to a customer matches a result code configured in
Add non-retry result code, the system stops retrying calling all
other numbers of the customer.

Figure 2-612 Disabling Configure Policy Based On Results
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▪ Enable Configure Policy Based On Results.

In Results processing strategy, click  and set Outbound
Call Failure Cause, Retry Times and Call-Out Interval (s). Click

 for multiple times to add multiple policies one by one.
Policies with the same values of Outbound Call Failure Cause
cannot be added.

Click  and set Add non-retry result code. When the result
of an outbound call to a customer matches a result code configured
in Add non-retry result code, the system stops retrying calling all
other numbers of the customer.

Figure 2-613 Enabling Configure Policy Based On Results

NO TE

If the outbound call interval is set to a large value, outbound call operations
indicators, such as the call connection rate, may be affected. You are advised to
use the default value.

– Contact Policy

▪ Default number type: Set Whether to configure based on the
result to configure the policy.
If it is set to No, you can set Max. Call Attempt Days and
Maximum number of call attempts per day.

Figure 2-614 Setting Whether to configure based on the result to No
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If it is set to Yes, you can set Outbound Call Failure Cause, Retry

Times, and Call-Out Interval (s). Click  for multiple times
to add multiple policies one by one. Policies with the same values of
Outbound Call Failure Cause cannot be added.

Figure 2-615 Setting Whether to configure based on the result to Yes

▪ Added number type: Click  to access the Configure Policy
Based On Results dialog box. You must set Number Type first
regardless of whether Configure Policy Based On Results is
enabled, and then set other parameters.
If Configure Policy Based On Results is disabled, set Number Type
to New number type and set Max. Call Attempt Days and
Maximum number of call attempts per day.

Figure 2-616 Disabling Configure Policy Based On Results

If Configure Policy Based On Results is enabled, set Number Type

to New number type, click , and set Outbound Call
Failure Cause, Maximum number of call attempts, and Call-Out

Interval (s). Click  for multiple times to add multiple
policies one by one. Policies with the same values of Outbound Call
Failure Cause cannot be added.
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Figure 2-617 Enabling Configure Policy Based On Results

Step 7 (Optional) Click Save as Template. In the dialog box that is displayed, enter a
template name and click confirm to save the current configuration as an
outbound call template.

Step 8 Click Save.

Step 9 Return to the Call Mgmt page, click Contact list in the Operation column
corresponding to the new outbound call task, and add outbound call data to the
outbound call task. For details, see 2.13.3.7.1 Configuring Outbound Call Data.

Step 10 Return to the Call Mgmt page and click  corresponding to the new
outbound call task.

----End

Follow-up Procedure
To modify an outbound call task, click Suspend to suspend it.

After the task is suspended, click Edit to modify the outbound call task. The
procedure for changing the calling number is as follows:

1. Click Caller Number. The page for selecting a calling number is displayed.
The selected calling number is displayed by default.
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Figure 2-618 Select Calling Number

2. Click Add and select another calling number. The selected calling number
cannot be selected again. The number of new calling numbers cannot exceed
the Maximum number of calling numbers configured by an administrator.

Figure 2-619 Adding a calling number

3. Click OK. Return to the Select Calling Number page and click OK.

To view the task result, you can click a task to access the outbound call task
details page and click the outbound call result on the outbound call task details
page to view the outbound call result for each customer.

NO TE

To enable the recording function for intelligent robot outbound call results, choose
Configuration Center > Chatbot Management > Flow Configuration > System > System
Settings, click the System Settings tab, and set FLOWRECORDFLAG (whether to enable
the recording function for intelligent IVR call flows) to Enable. In this way, Play is displayed
for intelligent robot outbound call results.
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On the task result page, you can perform the following operations:

● Click Details to view all outbound call results of all called numbers under the
customer.

● Click Business Result to remark the called outbound numbers.
● Click Export to export the task result.
● Click View Export Result to view the export result. On the displayed page,

you can download the result.

NO TE

The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

2.13.3.4 Creating Preempted Outbound Call Tasks
In a preempted outbound call, an agent is preempted. After the agent answers the
call, the agent and customer are connected.

Prerequisites
● The platform role of a user account is agent.
● To create an outbound call task, you have completed the operations in 2.13.2

Preparations for Creating Outbound Call Tasks.
● At least one voice skill queue exists. For details about the configuration

method, see 2.3.1.1 Maintaining a Tenant Space Skill Queue. The skill
queue has been associated with the agent who needs to make an outbound
call. For details about the association method, see 2.3.1.3 Associating an
Allocated Agent ID with a Business Account and Skill Queue.

● If the tenant space is in trial commercial use, you have contacted O&M
personnel to add the numbers used for making outbound calls to the tenant
space trustlist.

● To send SMS notifications for failed outbound calls, you have configured an
internal SMS template on the Configuration Center > Workbench
Configuration > Notification Template page. For details about how to
configure an SMS notification template, see 2.11.5 Configuring Notification
Templates as an Administrator.

● To configure a callback URL, an application has been submitted to the system
administrator and approved to add the callback URL to the address trustlist.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > Call
Mgmt.

Step 2 Click Create and choose System Automatic Outbound Call. On the Create
System Auto Outbound Call page, set Task Type to Preempted Outbound Call.
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Figure 2-620 Page for configuring the basic information of a preempted outbound
call task

Step 3 Configure basic information.
● Task Name: Enter a customized task name.
● Caller Number: Select an existing calling number of the current tenant space.
● Task Start And End Time: Select the task start time and end time.
● Task Type: Select Preempted Outbound Call. For an outbound call task

created using a template, the value of this parameter is the type configured in
the template by default and cannot be changed.

● Skill Queue: Select an existing skill queue. For details about how to configure
a skill queue, see 2.3.1.1 Maintaining a Tenant Space Skill Queue.

● Questionnaire: Only Manual Questionnaire and Manual vs. IVR
Questionnaire are supported. A manual and IVR survey can be used on the
outbound call workbench or used together with the questionnaire diagram
element in an IVR flow.

● SMS Template for Failed Outbound Call: Select a configured internal SMS
notification template. For details about how to configure an SMS notification
template, see 2.11.5 Configuring Notification Templates as an
Administrator.

● Priority: Select a value from 1 to 5. A smaller value indicates a higher priority.
If tasks are started at the same time, the task with a higher priority is called
preferentially.

● Play Voice: When an agent makes an outbound call, a recording can be
played to the customer. Voice resources are prompt tones with Status being
Approved on the Configuration Center > Resource Management > Audio
and Video page. A maximum of 10 voice resources can be selected.
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Figure 2-621 Playing a recording

● Associate Business Result: After an outbound call task is associated with a
business result, only the associated business result and its sub-business results
can be selected for outbound calls in the task. If Appointment Pop-up
Screen is enabled for the business result, after the business result is selected
for an outbound call, the dialog box for creating a reserved outbound call task
is displayed.

● Blocklist Type: If a blocklist category is selected, all numbers in the blocklist
are not called within the specified period.

● Callback Address: Enter the URL for callback upon call connection or release
on the customer side.

NO TE

The callback URL is a third-party URL and can carry data. The carried parameters
include dataId, taskId, sessionId, calledNo, beginTime, vdnId, failCode, callId,
filePath, and customFiled.
In the integrated environment, the callback URL can be configured only in the
outbound call task.

After the configuration is complete, click Next.

Step 4 Configure the outbound call period. The parameters take effect according to the
following priority: Allocate time periods by special dates > Special Date >
Regular Date Time Period.
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Figure 2-622 Outbound Call Duration

1. In Regular Date Time Period(UTC+08:00), set the start time and end time of
the working period. Examples are as follows:
9:00–11:30
14:00–18:00

2. In Special Date, click add special date to add days such as holidays and
weekends as special dates.

3. In Special Time Period(UTC+08:00), click Add Time Period and set Start
Time and End Time to 00:00 and 23:59, respectively.

4. In Allocate time periods by special dates(UTC+08:00), set a period. If this
function is not required, disable it.

NO TE

If calls do not need to be made on some special dates, for example, weekends, you
can set Regular Date Time Period(UTC+08:00) to 00:00 - 23:59, set weekends as
special dates, and set Special Time Period(UTC+08:00) to 00:00 - 00:00, as shown in
the following figure.

Step 5 Configure the task policy. Set Max. Response Duration, enable Outbound Call
Data Attribute Filtering, and select attributes.
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Figure 2-623 Task Strategy

Figure 2-624 Select Attribute

Step 6 Configure the call policy.

1. In the Call Strategy area, customize the pre-called customer numbers. Set
parameters based on Table 2-175.

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1014



Figure 2-625 Call Strategy

Table 2-175 Parameters in the Call Strategy area

Parameter Description

Call Sequence: Customize the call sequence of pre-called customer
numbers.

Unordered call -

By No -

By data attribute Click Add, select attributes, and set the sorting type.
You can adjust the attribute sequence after adding the
attributes.

Multi-number customer call rounds: Mode for calling multiple numbers
of a customer.

In sequence Call multiple numbers of a customer in sequence.

By number type You can select Existing number type or New number
type. After the configuration, the number with the
specified type placed ahead is called first.
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Parameter Description

By sequence
number

You can enter the sequence numbers of numbers. After
the configuration, the number with a smaller sequence
number is called first.

 

2. Configure Outbound Call Result Policy, which indicates the processing
method when an outbound call is not connected due to an unallocated
number, busy line, or other exceptions. Select Global policy or Contact
Policy.
– Global policy

▪ Disable Configure Policy Based On Results.
Set Max. Call Attempt Days, Maximum number of call attempts
per day, and Call-Out Interval (s).

Click  and set Add non-retry result code. When the result of
an outbound call to a customer matches a result code configured in
Add non-retry result code, the system stops retrying calling all
other numbers of the customer.

Figure 2-626 Disabling Configure Policy Based On Results

▪ Enable Configure Policy Based On Results.

In Results processing strategy, click  and set Outbound
Call Failure Cause, Retry Times and Call-Out Interval (s). Click

 for multiple times to add multiple policies one by one.
Policies with the same values of Outbound Call Failure Cause
cannot be added.
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Click  and set Add non-retry result code. When the result
of an outbound call to a customer matches a result code configured
in Add non-retry result code, the system stops retrying calling all
other numbers of the customer.

Figure 2-627 Enabling Configure Policy Based On Results

NO TE

If the outbound call interval is set to a large value, outbound call operations
indicators, such as the call connection rate, may be affected. You are advised to
use the default value.

– Contact Policy

▪ Default number type: Set Whether to configure based on the
result to configure the policy.

If it is set to No, you can set Max. Call Attempt Days and
Maximum number of call attempts per day.

Figure 2-628 Setting Whether to configure based on the result to No

If it is set to Yes, you can set Outbound Call Failure Cause, Retry

Times, and Call-Out Interval (s). Click  for multiple times
to add multiple policies one by one. Policies with the same values of
Outbound Call Failure Cause cannot be added.
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Figure 2-629 Setting Whether to configure based on the result to Yes

▪ Added number type: Click  to access the Configure Policy
Based On Results dialog box. You must set Number Type first
regardless of whether Configure Policy Based On Results is
enabled, and then set other parameters.
If Configure Policy Based On Results is disabled, set Number Type
to New number type and set Max. Call Attempt Days and
Maximum number of call attempts per day.

Figure 2-630 Disabling Configure Policy Based On Results

If Configure Policy Based On Results is enabled, set Number Type

to New number type, click , and set Outbound Call
Failure Cause, Maximum number of call attempts, and Call-Out

Interval (s). Click  for multiple times to add multiple
policies one by one. Policies with the same values of Outbound Call
Failure Cause cannot be added.
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Figure 2-631 Enabling Configure Policy Based On Results

Step 7 (Optional) Click Save as Template. In the dialog box that is displayed, enter a
template name and click confirm to save the current configuration as an
outbound call template.

Step 8 Click Save.

Step 9 Return to the Call Mgmt page, click Contact list in the Operation column
corresponding to the new outbound call task, and add outbound call data to the
outbound call task. For details, see 2.13.3.7.1 Configuring Outbound Call Data.

Step 10 Return to the Call Mgmt page and click  corresponding to the new
outbound call task.

----End

Follow-up Procedure
To modify an outbound call task, click Suspend to suspend it.

After the task is suspended, click Edit to modify the outbound call task. The
procedure for changing the calling number is as follows:

1. Click Caller Number. The page for selecting a calling number is displayed.
The selected calling number is displayed by default.
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Figure 2-632 Select Calling Number

2. Click Add and select another calling number. The selected calling number
cannot be selected again. The number of new calling numbers cannot exceed
the Maximum number of calling numbers configured by an administrator.

Figure 2-633 Adding a calling number

3. Click OK. Return to the Select Calling Number page and click OK.

To view the task result, you can click a task to access the outbound call task
details page and click the outbound call result on the outbound call task details
page to view the outbound call result for each customer.

NO TE

To enable the recording function for intelligent robot outbound call results, choose
Configuration Center > Chatbot Management > Flow Configuration > System > System
Settings, click the System Settings tab, and set FLOWRECORDFLAG (whether to enable
the recording function for intelligent IVR call flows) to Enable. In this way, Play is displayed
for intelligent robot outbound call results.
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On the task result page, you can perform the following operations:

● Click Details to view all outbound call results of all called numbers under the
customer.

● Click Business Result to remark the called outbound numbers.
● Click Export to export the task result.
● Click View Export Result to view the export result. On the displayed page,

you can download the result.

NO TE

The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

2.13.3.5 Creating Fixed Outbound Call Tasks

In a fixed outbound call task, outbound calls are assigned to idle agents by ratio
to improve call efficiency. The ratio can be adjusted based on the business target
and the number of idle agents. Fixed outbound call tasks can be used to quickly
contact with potential customers. When there are a large number of customer
numbers to be called, fixed outbound call tasks have significant advantages over
other types of outbound call tasks.

Prerequisites
● The platform role of a user account is agent.
● You have contacted the system administrator to enable the system parameter

Display Fixed Proportion of Outgoing Calls under System Parameter >
Intelligent Outbound Call > Managing Configurations.

● To create an outbound call task, you have completed the operations in 2.13.2
Preparations for Creating Outbound Call Tasks.

● At least one voice skill queue exists. For details about the configuration
method, see 2.3.1.1 Maintaining a Tenant Space Skill Queue. The skill
queue has been associated with the agent who needs to make an outbound
call. For details about the association method, see 2.3.1.3 Associating an
Allocated Agent ID with a Business Account and Skill Queue.

● If the tenant space is in trial commercial use, you have contacted O&M
personnel to add the numbers used for making outbound calls to the tenant
space trustlist.

● To send SMS notifications for failed outbound calls, you have configured an
internal SMS template on the Configuration Center > Workbench
Configuration > Notification Template page. For details about how to
configure an SMS notification template, see 2.11.5 Configuring Notification
Templates as an Administrator.

● To configure a callback URL, an application has been submitted to the system
administrator and approved to add the callback URL to the address trustlist.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > Call
Mgmt.
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Step 2 Click Create and choose System Automatic Outbound Call.

Figure 2-634 Page for creating a fixed outbound call task

Step 3 Configure basic information.
● Task Name: Enter a customized task name.
● Caller Number: Select an existing calling number of the current tenant space.

A maximum of 100 calling numbers can be added.
● Task Type: Select Fixed Outbound Call.
● Task Template: Select a fixed outbound call template whose Status is

Published on the Configuration Center > Call Config > Call Template page.
● Task Start And End Time: Select the task start time and end time.
● Skill Queue: Select an existing skill queue. For details about how to configure

a skill queue, see 2.3.1.1 Maintaining a Tenant Space Skill Queue.
● Smart Robot: Select an intelligent robot. During the execution of a fixed

outbound call task, the value of Call Result is Successful for a call only when
the call is routed from an intelligent robot to an agent, and a contact record
is generated for the call with the agent.

● Questionnaire: Only Manual Questionnaire and Manual vs. IVR
Questionnaire are supported. A manual and IVR survey can be used on the
outbound call workbench or used together with the questionnaire diagram
element in an IVR flow.

● Play questionnaire process: Select a survey flow. This parameter is displayed
when the selected survey is a manual and IVR survey.

● SMS Template for Failed Outbound Call: Select a configured internal SMS
notification template. For details about how to configure an SMS notification
template, see 2.11.5 Configuring Notification Templates as an
Administrator.
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● Priority: Select a value from 1 to 5. A smaller value indicates a higher priority.
If tasks are started at the same time, the task with a higher priority is called
preferentially.

● Callback Address: Enter the URL for callback upon call connection or release
on the customer side.

● Blocklist Type: If a blocklist category is selected, all numbers in the blocklist
are not called within the specified period.

● Associate Business Result: After an outbound call task is associated with a
business result, only the associated business result and its sub-business results
can be selected for outbound calls in the task. If Appointment Pop-up
Screen is enabled for the business result, after the business result is selected
for an outbound call, the dialog box for creating a reserved outbound call task
is displayed.

Step 4 Configure the outbound call period. The parameters take effect according to the
following priority: Allocate time periods by special dates > Special Date >
Regular Date Time Period.

Figure 2-635 Outbound Call Duration

1. In Regular Date Time Period(UTC+08:00), set the start time and end time of
the working period. Examples are as follows:

9:00–11:30

14:00–18:00

2. In Special Date, click add special date to add days such as holidays and
weekends as special dates.

3. In Special Time Period(UTC+08:00), click Add Time Period and set Start
Time and End Time to 00:00 and 23:59, respectively.

4. In Allocate time periods by special dates(UTC+08:00), set a period. If this
function is not required, disable it.
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NO TE

If calls do not need to be made on some special dates, for example, weekends, you
can set Regular Date Time Period(UTC+08:00) to 00:00 - 23:59, set weekends as
special dates, and set Special Time Period(UTC+08:00) to 00:00 - 00:00, as shown in
the following figure.

Step 5 Configure the task policy. Set Fixed Outbound Call to a value ranging from 1 to
20 and set Max. Response Duration.

Figure 2-636 Task Strategy
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Table 2-176 Parameters for configuring the policy of a fixed outbound call task

Parameter Value Range Description

Fixed Outbound Call The value ranges from 1
to 20. The default value
is 10.

● Fixed outbound call
ratio = Number of
outbound calls/
Number of idle
agents

● The number of
outbound calls
indicates the number
of calls obtained from
the business side
during execution of a
fixed outbound call
task.

● Number of outbound
calls = Number of idle
agents x Fixed
outbound call ratio

● The maximum
number of outbound
calls is 900.

Max. Response Duration The value ranges from 5
to 120. The default value
is 20.

If the response duration
exceeds this value, the
current call ends and the
next call is to be made.
The value ranges from 5
to 120. The default value
is 20.

 

Step 6 Configure the call policy.

1. In the Call Strategy area, customize the call policy for customer numbers to
be called. Set parameters based on Table 2-177.
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Figure 2-637 Call Strategy

Table 2-177 Parameters in the Call Strategy area

Parameter Description

Multi-number customer call rounds: Mode for calling multiple numbers
of a customer.

In sequence Call multiple numbers of a customer in sequence.

By number type You can select Existing number type or New number
type. After the configuration, the number with the
specified type placed ahead is called first.

By sequence
number

You can enter the sequence numbers of numbers. After
the configuration, the number with a smaller sequence
number is called first.

 

2. Configure Outbound Call Result Policy, which indicates the processing
method when an outbound call is not connected due to an unallocated
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number, busy line, or other exceptions. Select Global policy or Contact
Policy.
– Global policy

▪ Disable Configure Policy Based On Results.
Set Max. Call Attempt Days, Maximum number of call attempts
per day, and Call-Out Interval (s).

Click  and set Add non-retry result code. When the result of
an outbound call to a customer matches a result code configured in
Add non-retry result code, the system stops retrying calling all
other numbers of the customer.

Figure 2-638 Disabling Configure Policy Based On Results

▪ Enable Configure Policy Based On Results.

In Results processing strategy, click  and set Outbound
Call Failure Cause, Retry Times and Call-Out Interval (s). Click

 for multiple times to add multiple policies one by one.
Policies with the same values of Outbound Call Failure Cause
cannot be added.

Click  and set Add non-retry result code. When the result
of an outbound call to a customer matches a result code configured
in Add non-retry result code, the system stops retrying calling all
other numbers of the customer.
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Figure 2-639 Enabling Configure Policy Based On Results

NO TE

If the outbound call interval is set to a large value, outbound call operations
indicators, such as the call connection rate, may be affected. You are advised to
use the default value.

– Contact Policy

▪ Default number type: Set Whether to configure based on the
result to configure the policy.
If it is set to No, you can set Max. Call Attempt Days and
Maximum number of call attempts per day.

Figure 2-640 Setting Whether to configure based on the result to No

If it is set to Yes, you can set Outbound Call Failure Cause, Retry

Times, and Call-Out Interval (s). Click  for multiple times
to add multiple policies one by one. Policies with the same values of
Outbound Call Failure Cause cannot be added.
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Figure 2-641 Setting Whether to configure based on the result to Yes

▪ Added number type: Click  to access the Configure Policy
Based On Results dialog box. You must set Number Type first
regardless of whether Configure Policy Based On Results is
enabled, and then set other parameters.
If Configure Policy Based On Results is disabled, set Number Type
to New number type and set Max. Call Attempt Days and
Maximum number of call attempts per day.

Figure 2-642 Disabling Configure Policy Based On Results

If Configure Policy Based On Results is enabled, set Number Type

to New number type, click , and set Outbound Call
Failure Cause, Maximum number of call attempts, and Call-Out

Interval (s). Click  for multiple times to add multiple
policies one by one. Policies with the same values of Outbound Call
Failure Cause cannot be added.
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Figure 2-643 Enabling Configure Policy Based On Results

Step 7 (Optional) Click Save as Template. In the dialog box that is displayed, enter a
template name and click confirm to save the current configuration as an
outbound call template.

Step 8 Click Save.

Step 9 Return to the Call Mgmt page, click Contact list in the Operation column
corresponding to the new outbound call task, and add outbound call data to the
outbound call task. For details, see 2.13.3.7.1 Configuring Outbound Call Data.

Step 10 Return to the Call Mgmt page and click  corresponding to the new
outbound call task.

----End

2.13.3.6 Creating Manual Outbound Call Tasks
In a manual outbound call task, an agent in a specified skill queue manually locks
an outbound call task and executes the outbound call. This task applies to the
scenarios with flexible scripts and agent service time.

Prerequisites
● The platform role of a user account is agent.
● To create an outbound call task, you have completed the operations in 2.13.2

Preparations for Creating Outbound Call Tasks.
● At least one voice skill queue exists. For details about the configuration

method, see 2.3.1.1 Maintaining a Tenant Space Skill Queue. The skill
queue has been associated with the agent who needs to make an outbound
call. For details about the association method, see 2.3.1.3 Associating an
Allocated Agent ID with a Business Account and Skill Queue.

● If the tenant space is in trial commercial use, you have contacted O&M
personnel to add the numbers used for making outbound calls to the tenant
space trustlist.

● To send SMS notifications for failed outbound calls, you have configured an
internal SMS template on the Configuration Center > Workbench
Configuration > Notification Template page. For details about how to
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configure an SMS notification template, see 2.11.5 Configuring Notification
Templates as an Administrator.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > Call
Mgmt.

Step 2 Click Create and choose Manual Outbound Call.

Figure 2-644 Create Agent Outbound Call

NO TE

● You can select a survey based on the version number.

● For an outbound call task created using a template, the task type cannot be changed.
Determine the outbound call task template type before creating an outbound call task.

Step 3 Configure manual outbound call task information.

Table 2-178 Manual outbound call task parameters

Parameter Description

Basic Information

Task Name Task name, which is customized. This parameter is
mandatory. The value can contain a maximum of 100
characters.
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Parameter Description

Caller Number Calling number of the outbound call task. This
parameter is mandatory. Multiple calling numbers
can be selected.
The options are all access codes of the tenant space.

Call Attempts Maximum number of call attempts. This parameter is
mandatory. A failed call can be manually initiated
again. When the number of call attempts reaches the
maximum, unless the call is successful, the call
cannot be initiated again.
The value ranges from 1 to 6.

SMS Template for
Failed Outbound Call

Content of the SMS notification sent when the
outbound call task fails. This parameter is optional.

Assigning Agents
Click  to select agents in an associated voice skill
queue to execute the outbound call task.
If you select Specified Agent, you can specify one or
more agents. Otherwise, all agents in the skill queue
are selected.

Blocklist Type If a blocklist category is selected, all numbers in this
type are not called within the specified period.

Play Voice Select the corresponding voice resources to relieve the
user's waiting anxiety during a call. Play Voice: The
options are prompt tones configured on the
Configuration Center > Resource Management >
Audio and Video Resource Management page. A
maximum of 10 prompt tones can be selected.

Associate Business
Result

After you associate a task with a business result, only
the associated business result and its sub-business
results can be selected for outbound calls in the task.
If Appointment Pop-up Screen is enabled for the
business result, after the business result is selected for
an outbound call, the dialog box for creating a
reserved outbound call task is displayed.

Automatic Extraction Rule
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Parameter Description

Whether to enable the automatic extraction rule.
After the automatic extraction rule is enabled, a
specified agent can click the extraction button during
a manual outbound call. 10 outbound call records
that meet criteria are automatically extracted each
time.

Restrictions

Business Result Select a configured business result.

Result Fulfillment Number of calls marked with the selected business
result in the current task.
The value is a positive integer.

Completed Calls Number of calls that need to be made before the
outbound call task is complete.
The value ranges from 1 to 100000.

Single-time Claimed
Quantity

Number of outbound call records extracted each time
before the outbound call task is complete.
The value is a positive integer.

Data Extraction Conditions

Add Condition Select And or Or.
● And: All conditions must be met.
● Or: Any one of the conditions is met.

Add Subcondition Add a subcondition as an additional condition.

 

Step 4 (Optional) Click Save as Template. In the dialog box that is displayed, enter a
template name and click confirm to save the current configuration as an
outbound call template.

Step 5 Click Save.

Step 6 Return to the Call Mgmt page, click Contact list in the Operation column
corresponding to the new outbound call task, and add outbound call data to the
outbound call task. For details, see 2.13.3.7.1 Configuring Outbound Call Data.

Step 7 Return to the Call Mgmt page and click  corresponding to the new
outbound call task.

----End
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Follow-up Procedure
To modify an outbound call task, click Suspend to suspend it.

After the task is suspended, you can perform the following operations:

● Click Edit to modify an outbound call task.

To view the task result, you can click a task to access the outbound call task
details page and view the outbound call result of each customer.

On the task result page, you can perform the following operations:

● Click Details to view all outbound call results of all called numbers under the
customer.

● Click Play to play the recording of a completed call.

● Click  to export the task result.

NO TE

The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

● Click View Export Result to view the export result. On the displayed page,
you can download the result.

2.13.3.7 Configuring an Outbound Call Task
After an outbound call task is created, you need to configure outbound call data
for the task so that the task can be executed properly. Manual outbound call tasks
support the configuration of reserved outbound calls.

2.13.3.7.1 Configuring Outbound Call Data

Outbound call data is customer numbers to be called in outbound call tasks. You
can configure customer numbers one by one or import them in batches based on
the number of customers.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > Call
Mgmt.

Step 2 If batch information is not configured for an outbound call task, click

 to create a batch. Enter a batch name and click .

Step 3 Click Pending Calls.
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Table 2-179 Batch data parameters

Parameter Description

Customer ID Unique ID of a customer.
If multiple available numbers are configured for a
customer ID, the system considers the call complete
as long as any number is called successfully, and will
not call other numbers.

Customer Number Customer number, whose format is restricted by the
tenant parameters Minimum length of outbound
customer number, Maximum length of outbound
customer number, The begin digits of the
customer number, International Crown Code, and
International area code. These tenant parameters
are set under Configuration Center > System
Management > Tenant Parameter.

Available Calls Number of available numbers of a customer ID.

Operation Operations that can be performed.
● Edit
● Delete

 

Step 4 (Optional) Click Set Attributes and configure attributes by referring to
Configuring Outbound Call Data Attributes.

Step 5 Configure outbound call data.

Select a data configuration method and configure outbound call data as required
by referring to Adding Outbound Call Data Records One by One, Importing
Outbound Call Data, Adding Outbound Call Data Through Scheduled Import,
or Importing Outbound Call Data to Multiple Tasks Through a Task Group.

Step 6 (Optional) Click Details corresponding to the configured outbound call data
record to view details about the outbound call data. Click Modify to modify
configuration items other than Customer ID. Click Delete to delete the configured
outbound call data record. Select multiple outbound call data records and click
Delete on the top to delete them in batches.

----End

Configuring Outbound Call Data Attributes

Step 1 Choose Outbound Call > Call Mgmt.

Step 2 Click Contact list corresponding to an outbound call task in the Draft state.
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Figure 2-645 Batch management

Step 3 Click Set Attributes.

1. By default, all defined outbound call data attributes are displayed. For details
about how to configure customized attributes, see 2.13.2.4 Defining
Outbound Call Data Attributes.

2. Click  to enable Enable custom attribute.
3. Select the attributes to be configured as required.

Figure 2-646 Set Attributes

NO TE

● If Enable custom attribute is disabled, attributes do not need to be configured for the
outbound call data.

● If Enable custom attribute is enabled but no attribute is selected, attributes whose
Mandatory is Yes need to be configured for the outbound call data.

● If Enable custom attribute is enabled and attributes are selected, the selected
attributes need to be configured for the outbound call data.

● It is recommended that the value of an attribute contain only digits and letters. If other
formats need to be supported, configure the connection string by referring to
"Commissioning the Intelligent Outbound Call Business > Configuring an ApLogic Data
Source" in the commissioning guide.
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Step 4 Click OK.

NO TE

The outbound call data attributes configured here can be displayed on the outbound call
result page.

----End

NO TE

If you choose to import outbound call data by using a template, you need to disable
Enable custom attribute first. In this mode, customized attributes cannot be configured for
outbound call data.

Importing Outbound Call Data

Step 1 Choose Outbound Call > Call Mgmt.

Step 2 Click Contact list corresponding to an outbound call task in the Draft state.

Step 3 Click Import and set import parameters.

Figure 2-647 Import
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Table 2-180 Parameters for importing outbound call data

Parameter Description

Import
Method

File import mode.
The options are as follows:
● Using file: Upload an outbound call data file from the local

PC.
● Using server: Upload an outbound call data file from a

remote server.

Target
Contact List

Import batch. Data of an outbound call task may need to be
imported for multiple times. Since different batches of data have
different execution logic, batch management is required.

Import
Sequence

The options are as follows:
● Ascending Order
● Descending Order

Parsing
Mode

Data parsing mode.
The options are as follows:
● By template
● By rule

Download
Outbound
Call Data
Template

Download the template when Parsing Mode is set to By
template.
The outbound call data template varies depending on Outbound
Call Result Policy configured for the outbound call task. The
following figures show the template content.

Figure 2-648 Import template for the global policy

Figure 2-649 Import template for the contact policy

Mapping
Rule

Select a configured mapping rule when Parsing Mode is set to
By rule. For details about how to configure rules, see 2.13.2.9
Importing Mapping Rules.

Upload
Click  and select a local file. The file storage
period is seven days.

Server IP address of the server where the outbound call data file is
stored when Import Method is set to Using server. For details
about how to configure a server, see 2.13.2.8 Configuring an
Outbound Call File Server.
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Parameter Description

File Address Path of the outbound call data file on the server when Import
Method is set to Using server.

File Name Name of the outbound call data file when Import Method is set
to Using server. The file name contains the file name extension.

 

NO TE

Set the cell format of the file to be imported to text. If you import data using a file, a
maximum of 50,000 records can be imported at a time. If you import data using a server, a
maximum of 500,000 records can be imported at a time. It is recommended that a
maximum of 50,000 records be imported at a time. Otherwise, the outbound call rate may
be affected.
The format of Called Number is restricted by the tenant parameters Minimum length of
outbound customer number, Maximum length of outbound customer number, The
begin digits of the customer number, International Crown Code, and International
area code.

Step 4 In the Import dialog box, set the required parameters, select the file prepared in
the previous step, and click OK.

Step 5 Click Import Result to view the import result, that is, the number of records that
are successfully imported and that of records that fail to be imported. Click the
value in the Number of Failed Records column to download and view failed
outbound call data, and click the value in the Number of Duplicate Records
column to download and view duplicate outbound call data.

Possible causes of import failures: number of numbers exceeding the maximum,
incorrect separator, empty called number, empty interval, interval exceeding the
range, empty number type, nonexistent number type, and blocklisted number.

NO TE

When files are imported using a server, after the import is complete (successful or failed),
the original files are moved to a new directory. The directory is created by date (the date
directory is created in the default path of the outbound call file server), for example,
20230714.
Pay attention to the disk space of the server to prevent import failures caused by full disk
space.

----End

Adding Outbound Call Data Through Scheduled Import

Step 1 Choose Outbound Call > Call Mgmt and click Contact list. Click Scheduled
Import.
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Figure 2-650 Scheduled Import

Step 2 Click OK.

NO TE

When scheduled import is configured, after the import is complete (successful or failed),
the original files are moved to a new directory. The directory is created by date (the date
directory is created in the default path of the outbound call file server), for example,
20230714.
Pay attention to the disk space of the server to prevent import failures caused by full disk
space.

----End

Adding Outbound Call Data Records One by One
Step 1 Choose Outbound Call > Call Mgmt and click Contact list in the Operation

column.

Step 2 If batch information is not configured for an outbound call task, click

 to create a batch. Enter a batch name and click .
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Step 3 Click Pending Calls in the Operation column corresponding to the batch.

Step 4 On the batch data page, click New. The outbound call data configuration list is
displayed, as shown in the following figure.

Figure 2-651 Create Outbound Call Data

For details about how to configure the attribute content, see 2.13.2.4 Defining
Outbound Call Data Attributes.

Step 5 Click OK. The message "The current number sequence is the call sequence. Please
check the data again" is displayed. Click Yes.

----End

Importing Outbound Call Data to Multiple Tasks Through a Task Group

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Call Config > Task Group Management.

Step 2 Click New.
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Figure 2-652 Create task group

Step 3 Set parameters and click Save.

Step 4 Click Import. In the Import dialog box, download the outbound call data
template, fill in the template, upload the file, and click OK.

----End

(Optional) Adding Watermarks

Step 1 Choose Configuration Center > System Management > Tenant Parameter.

Step 2 Choose Tenant parameters > Unified Public Configuration.

Step 3 Set watermark parameters.
● Whether to enable page watermarking: Click Edit, set Parameter Value to

Yes, and click Save.
● Page Watermark Character: Click Edit, set Parameter Value to the

watermark to be displayed, and click Save.

Step 4 Choose Outbound Call > Call Mgmt and click Contact list corresponding to an
outbound call task to go to the outbound call data management page to view the
watermark effect.

Figure 2-653 Outbound call data

----End
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Batch Management

Step 1 Choose Outbound Call > Call Mgmt and click Contact list in the Operation
column.

Step 2 Click Create batch. In the Create batch dialog box, enter a batch name and click
Save.

Figure 2-654 Create batch

Step 3 Click Pending Calls corresponding to the new batch on the right. On the batch
data page, you can add batch data.

Figure 2-655 Batch data

Step 4 Return to the batch management page and click  to enable the batch.

Figure 2-656 Batch management

----End

2.13.3.7.2 Viewing Reservation Details of an Outbound Call Task

A tenant administrator can view the reservation status of all outbound call tasks.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > Call
Mgmt.
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Step 2 Click Reservation. View the list of reserved outbound calls associated with the
current outbound call task. The following table describes the parameters in the
list.

Table 2-181 Parameters in the reserved outbound call list

Parameter Description

Customer Number Number used for a reserved call.

Reserved Call Time Reserved call time. If a call is not processed after the
reserved time, the value of this parameter is
displayed in red. If the reservation is about to expire
in the next 5 minutes, it is displayed in yellow.

Initiated by Account of the agent who makes the reserved
outbound call.

Call Time Segment Call time segment.

Status Status of a call.
● Pending
● Executing
● Completed

Result Call result.
● Failed
● Successful
● Reject

Failure Cause Cause of a call failure.

Reservation Status ● Reserved
● Callback
● Expired
● Completed
● Ready to call back

Remarks Remarks.

Business Result Path Business result of a call.

Business Description Description of a business result.

Reserved call tуре ● Reservation for manual outbound calls
● Reserve automatic outbound calls

Created On Creation time.
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Parameter Description

Operation ● Modify
● Adjustment Record
● Play
● Business Result
● Survey Result

 

Step 3 Click Query to query desired outbound calls.

Table 2-182 Search criteria for querying reserved outbound calls

Parameter Description

Customer Number Customer number.
Fuzzy search by suffix is supported.

Call Result Call result.
● Failed
● Successful
● Reject

Start time of a reserved
call – End time of a
reserved call

Start time and end time of a reserved call.

Business Result Business result. The source is the existing business
result of the tenant.

 

Step 4 Select multiple reservation records and click Adjust in the upper right corner to
adjust agents in batches.

----End

2.13.3.7.3 Viewing Outbound Call Results

Tenant administrators can view the execution results of all outbound call tasks.

Procedure

Step 1 Choose Outbound Call > Call Mgmt, click a task, and view the outbound call
result of each customer on the outbound call task details page.
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Figure 2-657 Outbound call results

Step 2 Click Details to view the call details of a called number.

Figure 2-658 Call Result Details

Table 2-183 Parameters in the outbound call result details list

Parameter Description

Customer ID Customer ID, which is created when outbound call
data is created.

Customer number Customer number.

Status Status of a call.
● Executing
● Completed

Start Time Time when a call starts.

End Time Time when a call ends.

Call Attempts Number of times that a customer number is called.
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Parameter Description

Call Result Call result.
● Failed
● Successful
● Reject

Cause Call failure cause.

Business Result Path Business result of a call.

Business Description Business result description.

Call ring duration Ringing duration.

Manual call duration Manual call duration.

IVR call duration IVR call duration.

ACW Wrap-up duration after a call ends.

Total call duration Outbound call end time minus outbound call start
time.

Operation Operations that can be performed on an outbound
call result.
● Business Result
● Business Result Log
● Play
● Download

 

NO TE

● The outbound call data attributes configured in Configuring Outbound Call Data
Attributes are displayed next to the Operation column.

● Call ring duration, Manual call duration, IVR call duration, and ACW on the
Completed tab page depend on the CC-CMS's function of importing CDRs to the
database using the CCDIS. Therefore, you need to commission this function first.
Otherwise, the values of these parameters are 0.

Step 3 Click a task, click the Completed tab, and click  to export task results.

----End

Follow-up Procedure

Watermarks can be displayed on the outbound call task result page.

Step 1 Choose Configuration Center > System Management > Tenant Parameter.

Step 2 Choose Tenant parameters > Unified Public Configuration.
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Step 3 Set watermark parameters.
● Whether to enable page watermarking: Click Edit, set Parameter Value to

Yes, and click Save.
● Page Watermark Character: Click Edit, set Parameter Value to the

watermark to be displayed, and click Save.

Step 4 Choose Outbound Call > Call Mgmt and view the watermark effect.

----End

2.13.3.7.4 Viewing Survey Statistics

Tenant administrators can view survey answer statistics.

Prerequisites
● A survey has been configured for an outbound call task.
● An outbound call task is not in the draft state.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > Call
Mgmt.

Figure 2-659 Task management page

Step 2 Select an outbound call task that is being executed or has been completed, and
click Respondent Statistics.

----End

2.13.3.8 Managing Outbound Call Tasks in Batches

When there are a large number of outbound call tasks, a tenant administrator can
handle outbound call tasks in batches.

The following batch operations can be performed on outbound call tasks:
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● Batch Start
Only outbound call tasks in Draft or Suspended state can be started in
batches.

● Batch Suspend
Only outbound call tasks in the Executing or Completed state can be
suspended in batches.

● Batch Modify Basic Information
This operation will change the basic information of the selected tasks to the
same content. Exercise caution when performing this operation. The following
information can be modified:
– Basic information: Caller Number, Start Time, End Time, and SMS

Template for Failed Outbound Call
– Automatic extraction rule: If the selected tasks contain manual outbound

call tasks, the rule content can be modified.
– Common parameters: If the selected outbound call tasks are of different

types, only common parameters can be modified.

NO TE

The manual outbound call task and the key chatbot outbound call task cannot be
modified at the same time.

● Batch Change Outbound Call Time
This operation is not supported if the selected tasks contain manual outbound
call tasks.

● Batch Modify Outbound Call Policy
– This operation is not supported if the selected tasks contain manual

outbound call tasks.
– Only outbound call tasks of the same type can be modified in batches.

● Batch Modify Outbound Call Logic
– This operation is not supported if the selected tasks contain manual

outbound call tasks.
– Only outbound call tasks of the same type can be modified in batches.
– Business result policies cannot be configured for key chatbot outbound

call tasks and intelligent chatbot outbound call task.
– Only outbound call tasks with the same outbound call mode in CALL

POLICY can be modified in batches.
– Only outbound call tasks with the same policy type in OUTBOUND CALL

RESULT POLICY can be modified in batches.

2.13.4 Managing Multimedia Marketing
Enterprises often proactively conduct businesses, such as SMS return visits and
email push, to maintain customer relationships, improve customer satisfaction, or
seek business opportunities.

The AICC provides a multimedia marketing platform for enterprises and supports
the following marketing modes.
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Table 2-184 Multimedia marketing modes

Task Type Agent
Participation
(Yes/No)

Application
Scenario

Advantages

SMS
marketing
task

No Activities such as
SMS return visit
and marketing.

This method is cost-
effective, because agent
participation is not
required.

Email
marketing
task

No Activities such as
email promotion,
notification, and
return visit.

This method is cost-
effective, because agent
participation is not
required.

WhatsApp
marketing
task

No WhatsApp
promotional
activities and
WhatsApp channel
notifications.

This method is cost-
effective, because agent
participation is not
required.

 

You can create and manage multimedia marketing tasks for target customers.

2.13.4.1 Configuring Multimedia Marketing Tasks
Multimedia marketing tasks support SMS marketing and email marketing. Tenant
administrators can configure multimedia marketing tasks as required.

Prerequisites
● The Intelligent Outbound Call, SMS Marketing, Email Marketing,

WhatsApp Marketing, and SmartCare features have been enabled for the
tenant space.

● To use the care task function, you have contacted the system administrator to
add the SmartCare interconnection address on the Call Center > Address
Trustlist page.

Procedure

Step 1 (Optional) Sign in to the AICC as a tenant administrator, choose Configuration
Center > Expansion and Integration > SmartCare Integration, and configure
SmartCare integration information. If the care task function is not required, skip
this step.
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Figure 2-660 Configuring SmartCare integration information

1. SmartCare Interconnection Address: Contact Huawei O&M personnel to
obtain the address, and contact the system administrator to add the address
to the trustlist on the Call Center > Address Trustlist page.

2. AppId: Contact Huawei O&M personnel to obtain the value.
3. AppSecret: Contact Huawei O&M personnel to obtain the value.
4. Certificate: Contact the system administrator to upload the certificate to

Configuration Center > System Management > Certificate.

Step 2 Sign in to the AICC as a tenant administrator and choose Outbound Call >
mMarketing.

Step 3 View the created multimedia marketing tasks in the list.

Figure 2-661 mMarketing

Step 4 Click New. On the Create Multimedia Marketing Task page, configure
marketing task information.
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Figure 2-662 Basic Information

Figure 2-663 Marketing Policy

Task Type: The options are Marketing and Care. In a care task, an agent needs to
call a customer back who intends to make a complaint to pacify the customer and
improve customer satisfaction. The SmartCare feature must be enabled for care
tasks. Care task data is imported through scheduled tasks in the background. A
tenant space can publish only one voice scenario–based care task and one data
scenario–based care task.

The supported media types of multimedia tasks are as follows:

● SMS: Marketing campaigns are carried out by SMS message. The notification
template can be a Huawei Cloud SMS message template or SMS gateway
message template.
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– For details about how to configure a marketing notification template, see
2.11.5 Configuring Notification Templates as an Administrator.

– To use an SMS gateway message template, you need to configure a
gateway. For details about how to configure a gateway, see 2.11.3.1
Configuring SMS Gateways.

– By default, the country codes of China and Brazil are available. To add a
country code, configure the dictionary value.
The configuration method is as follows:
DELETE FROM SYS_DATADICT_ITEM WHERE rel_id = '88001202102081808';
INSERT INTO SYS_DATADICT_ITEM (rel_id, dict_code, item_code, item_name, be_code, order_no, 
description, oper_id, oper_time, oper_org_id, ext1, ext2, ext3, ext4, ext5, be_id) VALUES 
('88001202102081808', 'CCN.COUNTRY_CODE', '+55', 'Brazil', '101', '2', null, '101', null, '101', 
null, null, null, null, null, null)
DELETE FROM SYS_DATADICT_ITEM_LANG WHERE rel_id = '8800120210208180801';
INSERT INTO SYS_DATADICT_ITEM_LANG (rel_id, item_rel_id, locale, item_name, be_id) VALUES 
('8800120210208180801', '88001202102081808', 'en_US', 'Brazil', null);
DELETE FROM SYS_DATADICT_ITEM_LANG WHERE rel_id = '8800120210208180802';
INSERT INTO SYS_DATADICT_ITEM_LANG (rel_id, item_rel_id, locale, item_name, be_id) VALUES 
('8800120210208180802', '88001202102081808', 'en_US', 'Brazil', null);

In the preceding information, 88001202102081808 is the customized
dictionary value ID. 8800120210208180801 and 8800120210208180801
are the customized dictionary internationalization IDs. Brazil, +55, and 2
are the customized country name, country code, and sequence number,
respectively.
After the configuration, restart the SUMApp for the configuration to take
effect.

● Email: Marketing activities are carried out by email.
– For details about how to configure a marketing notification template, see

2.11.5 Configuring Notification Templates as an Administrator.
– For details about how to configure a gateway, see 2.11.3.1 Configuring

SMS Gateways.
● WhatsApp

– For details about how to configure the WhatsApp channel, see 2.5.8
Configuring the WhatsApp Channel.

– For details about how to configure a WhatsApp template message, see
2.3.2.10 Managing the Multimedia Library.

Step 5 Click Save. The multimedia marketing task is created successfully.

Step 6 Return to the mMarketing tab page and click Import Data to import data.

Step 7 Return to the mMarketing tab page and click Publish to publish the marketing
task.

Step 8 Click  to export multimedia marketing tasks. A maximum of 100,000 records
can be exported.

----End

Follow-up Procedure
To modify a multimedia marketing task, click Suspend to suspend it.

After the task is suspended, you can perform the following operations:
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● Click Edit to modify the multimedia marketing task.
● Click Delete to delete the multimedia marketing task.
● Click Import Data to import data.
● Click View Marketing Result to view the execution result of the multimedia

marketing task.

2.13.4.2 Configuring Multimedia Marketing Data

Marketing data of multimedia marketing tasks can be added one by one or
imported in batches. Data of the multimedia marketing tasks of the care type is
imported by obtaining poor-QoE users from the SmartCare system through
scheduled tasks.

Importing Marketing Data in Batches

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call >
mMarketing.

Step 2 If the marketing activity is in draft or suspended state, click Import Data. You can
import data by file or by server.

Figure 2-664 Multimedia data import page

If you select the import mode using a template, click Download Marketing Data
Template. The following figure shows the preconfigured template. Add marketing
data by row in the template.

If you select the import mode using a rule, the file is imported based on the
configured rule.

Figure 2-665 SMS import template

Figure 2-666 Email import template
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NO TE

Set the cell format of the imported file to text. If you import data using a file, a maximum
of 10,000 records can be imported at a time. If you import data using a server, a maximum
of 500,000 records can be imported at a time. It is recommended that a maximum of
50,000 records be imported at a time. Otherwise, the outbound call rate may be affected.
When the template selected for a marketing task has variables, the template to be
imported has the corresponding variables.
The format of Recipient number is restricted by the tenant parameters Minimum length
of outbound customer number, Maximum length of outbound customer number, The
begin digits of the customer number, International Crown Code, and International
area code. These parameters are set under Configuration Center > System Management
> Tenant Parameter.

Step 3 In the Import Marketing Data dialog box, set the required parameters, select the
file prepared in the previous step, and click OK.

Step 4 Click Import Result to view the import result, that is, the numbers of records that
are successfully imported and that fail to be imported. Click the value in the
Number of Failed Records column to download and view the failed outbound
call data, and click the value in the Number of Duplicate Records column to
download and view the duplicate outbound call data.

----End

Adding Marketing Data Records One by One

Step 1 Choose Outbound Call > mMarketing and click Import Data in the Operation
column.

Step 2 Click Add and enter the recipient number in the text box. Click Set Variable in the
Operation column and set the variable.

Figure 2-667 Page for adding the multimedia marketing data

Step 3 Click Save.

Step 4 (Optional) Click Edit to change the recipient number, and reconfigure the variable
for the configured multimedia marketing data.

----End

Importing Marketing Data Using Scheduled Tasks (Multimedia Marketing
Tasks of the Care Type)

Step 1 Contact the system administrator to sign in to the AICC, choose Call Center >
Tenant Management, and enable the SmartCare feature for the tenant space.

Step 2 Sign in to the AICC as a tenant administrator, choose Outbound Call >
mMarketing, and create a multimedia marketing task of the care type. For
details, see 2.13.4.1 Configuring Multimedia Marketing Tasks.
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Step 3 Click View in the Operation column of the multimedia marketing task of the care
type to view the poor-QoE data imported by scheduled tasks.

NO TE

The number of poor-QoE customers (including customers in data and voice scenarios)
obtained every day is restricted by the system parameter Maximum number of caring
users. Modification to this parameter does not take effect immediately. Wait for 1 hour.

Step 4 Select a recipient number and click Delete to delete the number. Click Edit to
modify the recipient number.

----End

2.13.4.3 Viewing Multimedia Marketing Results

An agent can view the result of a single multimedia marketing task on the iSales
task list page.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call >
mMarketing.

Step 2 Click View Marketing Result.

Figure 2-668 Multimedia marketing result page

You can perform a search as follows:

1. By sending status: Select a sending status and click Search.

2. By time: Set the start time and end time, and click Search.

3. By recipient: Enter a recipient number or email address, and press Enter.

4. Click  to export multimedia marketing results. A maximum of 100,000
records can be exported.
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NO TE

The start time cannot be later than the current time. Data created within a maximum
of three months can be queried. By default, data created within one month is queried.

----End

2.13.5 Managing Outbound Call Task Reports

2.13.5.1 Outbound Call Task Monitoring Report
The outbound call task monitoring data can be displayed in reports so that
administrators can track the execution of outbound call tasks promptly.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > Call
Monitor.

Figure 2-669 Call Monitor

Step 2 Click an outbound call task to access the Monitoring Task Indicators page.
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Figure 2-670 Monitoring Task Indicators

● In Completeness Of All Batches or Completion Of Initiated Batches, view
statistics on the completion status of the outbound call task, including the
number of completed calls, number of uncompleted calls, number of pending
calls, and number of records in the special list.

● In Today's Business Targets, view the number of calls that are completed on
the current day with their business results marked as Business Target.

● In Today's Business Targets Per Hour, view the number of today's calls that
have achieved the business target per hour, which is calculated as follows:
Number of today's calls that have achieved the business target/Number of
valid outbound call hours.

● In Today's Call Statistics, view the data of Call Completion Rate, Number
of successful calls, Number of failed calls, Outbound Call Customers Not
Completed, Average Call Duration, Abandoned Calls, Number of
unsubmitted business results, and Voicemail Percentage.

Table 2-185 Indicators in the Today's Call Statistics area

Indicator Description

Call Completion Rate The formula is as follows: Number of successful
calls/(Number of successful calls + Number of
failed calls).
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Indicator Description

Number of successful
calls

Number of completed and uncompleted calls that
are successful on the current day.

Number of failed calls Number of completed and uncompleted calls that
fail on the current day. After a reserved manual
outbound call made to a customer fails, if
another call attempt is made and fails again,
only one failure record is counted.

Outbound Call
Customers Not
Completed

Number of uncompleted calls.

Average Call Duration Average call duration.

Abandoned Calls Number of calls that customers hang up when
waiting in skill queues.

Number of
unsubmitted business
results

Number of completed outbound calls,
uncompleted outbound calls, and reserved manual
outbound calls that are successful and not marked
with business results on the current day.

Voicemail Percentage The formula is as follows: Number of outbound
calls that are transferred to the voice mailbox/
(Number of successful outbound calls + Number
of failed outbound calls).

 
● In Today's business Results Report, view the details of business results

marked for outbound calls in the outbound call task in a specified time range.
● In Today's Indicator Trend, view the trends of 15-minute indicators of the

outbound call task on the current day, including Number of completed calls,
Number of business targets, Abandoned Calls, Percentage of business
targets, and Call Success Rate.

Table 2-186 Indicators in the Today's Indicator Trend area

Indicator Description

Number of completed
calls

The formula is as follows: Number of completed
outbound calls + Number of uncompleted
outbound calls + Number of completed reserved
manual outbound calls.

Number of business
targets

Number of completed outbound calls,
uncompleted outbound calls, and reserved manual
outbound calls that are successful and whose
business results are marked as Business Target.

Abandoned Calls Number of calls that are hung up when waiting in
skill queues.
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Indicator Description

Percentage of business
targets

The formula is as follows: Number of calls that
have achieved the business target/Number of
successful outbound calls.

Call Completion Rate The formula is as follows: Number of successful
outbound calls/Number of outbound calls.

 
● On the Agent Monitoring tab page, view the current status and status

duration of all agents in the tenant space.
– An inspector can perform real-time inspection operations on a specific

agent, including Screen QC, Force Busy, Force Idle, Force Out, and Force
Release.

– When the Online Chat and Intelligent Outbound Call features are
enabled for the current tenant, a supervisor can click Chat corresponding
to an agent and send an instant message to the agent, as shown in
Figure 2-671. The agent receives a screen pop-up as shown in Figure

2-672, and can click  in the lower right corner of the page to view
the session list. To use this function, an agent needs to contact the tenant
administrator to grant the Message Sending permission. The tenant
administrator has this permission by default.

Figure 2-671 Instant message sent by a supervisor
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Figure 2-672 Screen pop-up received by an agent

– Click  to view the indicator statistics of rest reasons. You can configure
rest reasons on the Configuration Center > Workbench Configuration >
Rest Reason page.

– Click More, select Common agent, Quality checker, or Callout agent,
and search for data based on the selected platform role.

● On the Agent State Trend tab page, view today's statistics on the number of
agents in a specified state for every 5 minutes. By default, the statistics on
agents in the Online, Idle, Talking, and Busy states are displayed.

Figure 2-673 Agent State Trend

NO TE

The agent state trend chart displays the data of agent states at the data collection
time point instead of agent states in a certain time range. For example, if an agent is
in the Idle state from 19:11:00 to 19:14:00 and in the Rest state (marked with rest
reason A) at 19:15:00, which is the data collection time point, the number of rest
reason As is incremented by 1 at 19:15:00.

● On the Call Statistics tab page, view the progress of the outbound call task.
(This tab page is displayed only for predicted, previewed, and preempted
outbound call tasks.)
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Figure 2-674 Call Statistics

● On the Call Quality Statistics tab page, view the call connection rate and
abandonment rate (displayed in a line chart). You can select a date that is not
earlier than the task start date or later than the current date. (This tab page
is displayed only for predicted, previewed, and preempted outbound call
tasks.)

Figure 2-675 Call Quality Statistics

● On the Call Monitoring tab page, view the monitoring chart of the task.
(This tab page is displayed only for predicted outbound call tasks.) The bar
chart is refreshed every 15 minutes and displays the following data:
Connected Calls, Calls Answered by Agents, Queuing Calls, Abandoned
Calls, and Lost Calls.

Figure 2-676 Call Monitoring

● On the OBS Data Monitoring tab page, view OBS data monitoring
information. (This tab page is displayed only for predicted, previewed,
preempted, and fixed outbound call tasks.)

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1062



Figure 2-677 OBS Data Monitoring

Step 3 Click the Agent Monitoring tab.

Figure 2-678 Agent Monitoring

● Enter the name of an outbound call task and click  to search for the
monitoring data of the outbound call task.

● Click  to export agent monitoring data. Click  to view the export
record.

● Click  to sort the data of an indicator in ascending or descending order.

Step 4 Click the Indicator Monitoring tab.
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Figure 2-679 Indicator Monitoring

● Indicator monitoring information of 30-Minute Indicator and Indicator of
the current day are displayed.

● Enter the name of an outbound call task and click  to search for the
monitoring data of the outbound call task.

● Click  to export indicator monitoring data.

● Click  to sort the data of an indicator in ascending or descending order.

Step 5 Click the Task overview tab.

Figure 2-680 Task overview

● Enter the name of an outbound call task and click  to search for the
monitoring data of the outbound call task.

● Click  to export report data.

● Click  to sort the data of an indicator in ascending or descending order.

----End
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2.13.5.2 Viewing Business Result Reports

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call >
Service Result Report.

● Outbound Call Task: Select an outbound call task.

● Report Type: Select Daily report, Weekly report, or Monthly report.

● Report time: Set the time range for report data query.

– Daily report: The time range cannot exceed 31 days.

– Weekly report: Select the start date and end date. (The time selector
converts a date into the corresponding week.)

– Monthly report: Set the start year and month as well as the end ones.

Step 2 Select a report type and click Search.

● Daily report: Set the start date and end date. The end date cannot be earlier
than the start date. The time range cannot exceed 31 days. The end date
must be earlier than the current date.

● Weekly report: The start year and end year can be the current year or the
previous year. The time range cannot exceed 12 weeks. The maximum end
week is the week of the current date.

● Monthly report: The start year and end year can be the current year or the
previous year. The time range cannot exceed six months. The maximum end
month is the month of the current date.

Step 3 Select some business results from the Select drop-down list and a date, week, or
month to view the corresponding bar chart.

Step 4 Select some business results from the Select drop-down list to view the
corresponding trend line chart.

Step 5 View sub-business result report data.

● Click the bar of a business result in the bar chart to drill down to the sub-
business result report of the business result.

● Click the line of a business result in the line chart to drill down to the sub-
business result trend chart of the business result.

----End

2.13.5.3 Outbound Call Task Report

You can view indicators such as Number Of Called Out Customers, Number Of
Successful Outbound Customers, and Number Of Failed Outbound Customers
on the Task Report page.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > Task
Report.
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Figure 2-681 Task Report

● Report type: Select Daily report, Weekly report, or Monthly report.
● Report time: Set the time range for report data query.

– Daily report: Set the start date and end date. The end date cannot be
earlier than the start date. The time range cannot exceed 31 days. The
end date must be earlier than the current date.

– Weekly report: The start year and end year can be the current year or
the previous year. The time range cannot exceed 12 weeks. The maximum
end week is the week of the current date.

– Monthly report: The start year and end year can be the current year or
the previous year. The time range cannot exceed six months. The
maximum end month is the month of the current date.

● Outbound Call Task: Select a manual, predicted, preempted, previewed, or
fixed outbound call task that is not in the draft state.

Step 2 You can switch to the Chart page to view the monitoring indicators and trend of

outbound call tasks. Click  on the right and select indicators as required.
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Figure 2-682 Summary of outbound call tasks

----End

2.13.5.4 Viewing Intelligent Robot Outbound Call Records

Tenant administrators can view the call records of intelligent robot outbound call
tasks.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > Call
Mgmt.

Step 2 Click an outbound call task that is not in the draft state to go to the outbound call
task details page.

Step 3 On the outbound call task details page, click the Completed tab, and view the
outbound call result.

Step 4 Click a call record in the outbound call result to view the call record.

----End

2.13.5.5 Agent Work Statistics

You can view agent work statistics by outbound call task or agent.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > Agent
Work.

Figure 2-683 Agent Work page

Step 2 Select a start time, an end time, and an outbound call task or agent whose
statistics are to be collected.

NO TE

The time range is less than or equal to seven days.

Select at least one outbound call task or agent.

Step 3 If the query is successful, click . The message "The exported data contains
personal information. Exercise caution when performing this operation" is
displayed, as shown in Figure 2-684. After you click OK, the message "The export
task list has been created. Do you want to view it in the export list?" is displayed.

Figure 2-684 Exporting a data package

NO TE

The exported data contains personal data. Exercise caution when processing the exported
data to prevent personal data leakage and abuse.

Step 4 Click  to download the exported CSV file.
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Figure 2-685 Exporting a CSV file

----End

2.13.5.6 RBT Recognition

When an agent executes an outbound call task, a large amount of failed
outbound call data may be generated. The agent may be unable to record and
analyze the failure causes due to heavy workload. In this case, a tenant
administrator can use the RBT intention recognition function for intention
recognition. After outbound call failure results are automatically recognized, they
are saved to an RBT report which the tenant administrator can use for analysis.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Outbound Call > RBT
Recognize.

Figure 2-686 RBT Recognize

● Start Time: Set the recording start time for query.

● End Time: Set the recording end time for query.

● Customer number: Enter the called number of a customer.

● Status: Select To be confirmed or Confirmed.

Step 2 After the start time and end time are selected, query data. (The end date cannot
be earlier than the start date, and the date range cannot cross months.)

Step 3 Click Advanced Search. Enter the outbound call number or select a status from
the drop-down list and click Search.

Step 4 View RBT recognition results. Click Play to play the record of a CDR.
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Step 5 Click Business Result. If the business result of the current data is edited, the
updated business result is displayed in the list.

----End

2.14 Managing Surveys
A survey records the survey content in the form of questions. Administrators can
configure surveys for survey statistics collection of other businesses.

2.14.1 Configuring Surveys
Surveys include manual surveys, IVR surveys, and intelligent training surveys. After
a tenant administrator configures surveys in a unified manner, the surveys can be
used to collect statistics based on scenarios.

Survey types are described as follows:

● Lightweight surveys can be used only by IVR flows. Only single-question
surveys with a fixed number of options can be configured.

● Standard surveys can be used by intelligent outbound calls, IVR flows, and
intelligent training businesses. Diversified surveys can be configured.

Prerequisites

To use the Analyzed function in the lightweight survey management, the
commissioning in "Commissioning Guide > Commissioning Functions >
Commissioning the Function of Pushing CDR Files and Satisfaction Results to
Kafka and Elasticsearch" has been completed for the tenant space.

Configuring a Lightweight Survey

Step 1 Sign in to the AICC as a tenant administrator and choose Survey > Survey Config.

Figure 2-687 Lightweight survey management

Step 2 (Optional) Click  to switch the survey edition as required.

Step 3 Click New Survey. The Create Survey page is displayed.

● Satisfaction Survey: Only one satisfaction survey can be created and cannot
be deleted.

a. Create a satisfaction survey. Configure the survey name.
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Figure 2-688 Add Satisfaction Survey

b. Click Create to save the survey information.
c. On the survey management page, click Modify corresponding to the new

satisfaction survey, and configure the survey content.
d. Click the Satisfaction Level tab and configure satisfaction levels for the

survey.
You need to configure the voice file of the IVR flow.

Figure 2-689 Satisfaction Level

▪ Click the Voice File selection box to select an uploaded and
approved voice file.

▪ Click Add to upload a local voice file. After the system administrator
approves the file, the file can be used.

e. For details about other configurations, see 2.3.3.2 Configuring
Satisfaction Surveys.

NO TICE

▪ After the satisfaction survey is published successfully, the settings on
the Configuration Center > Workbench Configuration >
Satisfaction page cannot be modified. If the satisfaction survey is not
created or published, the settings on the Configuration Center >
Workbench Configuration > Satisfaction page are not affected.

▪ If the satisfaction survey is not published and the settings are different
from those on the Satisfaction page, the settings of the satisfaction
survey are used.

● IVR Survey

a. Configure an IVR survey. For details, see Table 2-187.
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Figure 2-690 Survey Content Configuration

Table 2-187 GUI elements on the Survey Content Configuration page

Element Description

Survey Name The value can contain a maximum of 32
characters, including only letters and digits.

Survey Question The value can contain a maximum of 256
characters.

Survey Options (A maximum of nine options can be added.)

DESCRIPTION The value can contain a maximum of 32
characters.

Operation You can perform the following operations:

▪ Add

▪ Delete

Survey voice

Voice type Voice file type. The options are as follows:

▪ Voice

▪ Text-to-Speech
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Element Description

Voice File You can select only an approved voice file
whose Usage Scenario is IVR on the
Resource Management > Audio and Video
page.

TTS You can select only an approved TTS file
whose Usage Scenario is IVR on the
Resource Management > Audio and Video
page.
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Element Description

Add After you click this button, the Audio and
Video page is displayed. For details about
how to configure voice and video resources,
see 2.6.3.2 Managing Voice and Video
Resources.

 

b. Click Save. The IVR survey is configured.

Step 4 Return to the survey management page and click Release corresponding to the
new survey. After the survey is published, the IVR flow management side
automatically creates and publishes an IVR flow with the same name as the
survey.

Step 5 (Optional) Click Change The Name corresponding to the satisfaction survey to
change the survey name.

Step 6 Click Analyzed to view the usage of the survey in the IVR, including the
respondent quantity statistics and respondent proportion statistics.

Figure 2-691 IVR survey statistics

----End

Configuring a Standard Survey

Step 1 Sign in to the AICC as a tenant administrator and choose Survey > Survey Config.

Figure 2-692 Survey Config

Step 2 (Optional) Click  to switch the survey edition as required.

Step 3 Configure a survey category.
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1. All is selected by default. Click . The Create Survey Category dialog box
is displayed.

2. Configure the survey type.

Figure 2-693 Create Survey Category

3. Click Create to save the survey category information.

Step 4 Configure a survey.

1. Select the new survey category and click Add on the right of the page. The
Create Survey page is displayed.

2. Configure the survey content.

Figure 2-694 Create Survey

– Survey Name: (Mandatory) Survey name. Enter a value that contains a
maximum of 32 characters.

– Survey Category: (Mandatory) Survey category. Select a created survey
category.

– Keywords: Survey keywords.
– Survey Type: (Mandatory) The options are Manual survey, IVR survey,

Intelligent training, and Manual and IVR survey.
3. Choose Save.

Step 5 Click Question List and configure questions.
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1. Click Add. The Create Question page is displayed.
2. Configure the question content.

Figure 2-695 Adding a question to a manual survey

Figure 2-696 Adding a question to an IVR survey

Table 2-188 Problem announcement playing mode

Element Description

Voice File You can select only an approved voice file whose
Usage Scenario is questionnaire on the
Resource Management > Audio and Video
page.
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Element Description

TTS You can select only an approved TTS file whose
Usage Scenario is questionnaire on the
Resource Management > Audio and Video
page.

 

Figure 2-697 Adding a question to an intelligent training

3. Click Save. The question list page is displayed.

Step 6 (Optional) Adjust the sequence of questions in the question list. Click Adjust
Sequence. In the Adjust Sequence dialog box, select the desired question, click
Up or Down, and click OK.
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Figure 2-698 Adjust Sequence

Step 7 Configure question execution rules.

1. Return to the question list page and click Manage Question. The Manage
Question page is displayed.

Figure 2-699 Manage Question

2. Each question has a default rule. Default rules cannot be modified or deleted.
You can click Add to customize question execution rules as required.
Customized rules cannot be modified or deleted.

3. Set Question Type to Multiple choices and edit the rule.

a. Select a question from the question list and set the redirection rule. The
default redirection rule is Jump based on option.

b. If Jump Rule is set to Fixed jump, the system directly jumps to the
specified question. If Jump Rule is set to Jump based on option, the
system jumps to the specified question only when the specified option is
met.
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4. Click OK.

Step 8 (Optional) On the survey details page, click Test Survey to test the survey before
the survey is officially published.

Figure 2-700 Survey details

Step 9 Click Release to officially publish the survey.

----End

Follow-up Procedure

You can perform the following operations on a published survey:

● Click Disable. The survey of the current version is disabled and cannot be
used by other modules.

● Click New Version to copy all content of the survey of the current version to
create a survey of a new version.

2.14.2 Querying Answers
Business scenarios associated with released surveys can be queried.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Survey > Answer Query.

Figure 2-701 Answer Query

Step 2 Click  in the Survey text box, and select a survey.

Figure 2-702 Select Survey
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NO TE

Click a survey version to query its details.

Step 3 Click Search to search for business scenarios associated with the survey.

Step 4 Click Export to export the survey.

Figure 2-703 Export Result

Step 5 Click View Export Result to view the survey export result.

Step 6 Click an answer ID to view details about the answer.

----End

2.14.3 Querying Answer Statistics
Answer statistics details of surveys can be queried. The statistics are displayed by
answer rate.

Procedure
Step 1 Sign in to the AICC as a tenant administrator and choose Questionnaire Survey >

Questionnaire Statistics.

Figure 2-704 Questionnaire Statistics
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Step 2 Click Search to query answer details based on search criteria.

Step 3 Click  to query answer details.

----End

2.15 Managing Intelligent Training
Intelligent training tasks can be used to periodically train and test agents through
released intelligent IVR flows to check the business skills of the agents.

2.15.1 Managing Training Tasks
A tenant administrator configures intelligent training tasks. Agents can choose to
participate in training tasks as required.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Business Training >
Training Task Management.

Step 2 Click New. The Creating a Training Task page is displayed.

Step 3 Configure basic information about the training task.

Figure 2-705 Basic Information

● Maximum Number of Questionnaire Answers: Enter an integer ranging
from 1 to 100. If no value is entered, the number of times for answering the
survey is not limited by default.

● Training Questionnaire: Select a published intelligent training survey.

● IVR Flow: Select a published intelligent IVR flow.

Step 4 Click Next. The Object Management page is displayed.

Figure 2-706 Object Management

Click Add, and select an agent account to participate in the training task.

Step 5 Click Next. The Outbound Call Duration page is displayed.
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Figure 2-707 Outbound Call Duration

NO TE

An outbound call time segment must be set in the Set Outbound Call Time area.

Step 6 Click Next. The Outbound Call Policy page is displayed.

Figure 2-708 Outbound Call Policy

Step 7 Click Save.

Step 8 Return to the Training Task Management page, select the configured training
task, and click Start to start the training task.

----End

Follow-up Procedure

You can perform the following operations on training tasks:

● Click Suspend to stop a training task.
● Click Edit to modify all information of a training task.
● Click Task Result to view the call result list of a task.

Figure 2-709 Task result

Click Export to create a task of exporting training task results. Click View
Export Result and click Download corresponding to the export task whose
Result is Successful to download the training task results to the local PC.

NO TE

The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

● Click Associated Questionnaire to view the survey details.
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Figure 2-710 Associated survey

● Click Result Analysis to view the answer details.

Figure 2-711 Result analysis

● Click  to modify the basic information, task object, task time, and task
policy of a training task.

2.16 Configuring the Knowledge Base
This section describes how to configure the knowledge base as a tenant
administrator for agents to reference.

2.16.1 Introduction
The knowledge base is a valuable knowledge management tool that helps
enterprises, organizations, and individuals better manage and use their knowledge
resources to enhance work efficiency, improve decision-making, promote
knowledge sharing, improve customer service, and reduce costs.

Related Concepts
● Column: A column is similar to a folder, which is used to store knowledge

files. Knowledge compilers can create columns based on the column type,
business status, and business effective time, organize columns in a tree
structure, and store knowledge in different columns to implement knowledge
classification and management.

● Knowledge: Knowledge is stored in columns. An online editor is provided to
edit knowledge content. Common knowledge and Q&A knowledge are
supported. Common knowledge can be displayed in texts, charts, audio, and
videos. Q&A knowledge can be displayed only in FAQ groups.

● Extended attribute: In addition to the content, knowledge also carries many
attribute labels. Different industries and enterprises have different label
definitions.
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● Consultation table: A consultation table stores business consultation
information. When handling businesses, an agent can look up information in
a consultation table to answer business questions.

2.16.2 Managing Knowledge in the Background
Knowledge compilers can manage knowledge columns and content in the
background and publish knowledge after professional review. Agents can search
for and browse knowledge details in the foreground.

2.16.2.1 Configuring Columns

Knowledge compilers organize columns in a tree structure by business dimension
to implement knowledge classification and management.

Prerequisites
● The Knowledge Base feature has been enabled for the tenant space, and the

operator has the Knowledge Base > Knowledge Management > Knowledge
Column menu permission.

● Extended attributes can be configured for columns. For details about how to
manage extended attributes, see 2.16.2.3 Managing Extended Attributes.

Procedure

Step 1 Sign in to the AICC as a knowledge compiler and choose Knowledge Base >
Knowledge Column.

Figure 2-712 Category Knowledge

●  indicates a column, and  indicates a knowledge item.
● You can search for existing column information based on the knowledge

column name, modifier, modification start time, modification end time, and
column type.

● Historical and valid normal columns are displayed on the left.
– For normal columns, column names are displayed.
– For historical columns, column names are in Column name(History)

format.
● Subcolumns and valid knowledge items in the selected column are displayed

on the right by default.
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– Click  to display historical subcolumns and expired knowledge items
in the selected column.

– Click  to display normal subcolumns and valid knowledge items in
the selected column.

NO TE

The preceding operations are not supported for historical columns.

Step 2 Click . The page shown in Figure 2-713 is displayed.

NO TE

Only subcolumns can be added to a root column. Subcolumns or knowledge items can be
added to a customized column.

Figure 2-713 Add Category

Table 2-189 Parameters on the Add Category page

Element/
Component

Description

Category Name Mandatory. The value can contain a maximum of 80
characters.

Category Path Path of a column to be added or modified, which cannot be
modified.

maintenance
group

Group to which personnel who can maintain the current
column belong.
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Element/
Component

Description

browse group Group to which the personnel who can browse the current
column belong.

Category Type Mandatory. The options are as follows:
● Normal category: A column of this type and its

knowledge items can be displayed on the knowledge
base home page.

● History: A column of this type and its knowledge items
cannot be displayed on the knowledge base home page.

Display on Front
Page

Mandatory when Category Type is set to Normal category.
Whether to display a column on the knowledge base home
page after the column is published. The options are as
follows:
● Yes
● No

Validity Period
Start/Validity
Period End

Mandatory when Category Type is set to Normal category.
The time zone of the validity period must be the same as
that of the browser.

Upon Expiration Mandatory when Category Type is set to Normal category.
The options are as follows:
● Mark: After a column expires, the column status is

changed to Expired. [Expired] is automatically added to
the column name.

● Delete: Move a column to the recycle bin.
(When a column and its subcolumns are deleted, only
the parent column is moved to the recycle bin.)

● Move to History: Move a column to a specified historical
column.

Move to History Mandatory when Upon Expiration is set to Move to
History.
Column to which an expired column is moved.

Summary The value can contain a maximum of 256 characters.

Review and
Publish
Knowledge in
Category

Mandatory when Category Type is set to Normal category.
The options are as follows:
● Yes: Knowledge items in the current column need to be

approved before being published.
● No: Knowledge items in the current column can be

directly published without approval.
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Element/
Component

Description

Inherit Parent
Category
Attribute

Mandatory when Category Type is set to Normal category.
The options are as follows:
● Yes: Subcolumns automatically inherit the extended

attributes of the parent column.
● No: Subcolumns do not inherit the extended attributes of

the parent column.

Extended
Attribute

Label attributes of the current column.
Click Select and select extended attributes. The options are
attributes that have been configured and enabled by
referring to 2.16.2.3 Managing Extended Attributes.

 

Step 3 Verify that the information is correct and click Submit.

Step 4 (Optional) Select a column under a knowledge column and click  to delete the
column and all its subcolumns and knowledge items.

Step 5 Select the new column, click , and create a subcolumn by referring to Step 2.

Step 6 (Optional) Select the new subcolumn on the right.
● Click Modify and modify basic column information based on Table 2-189.

Category Path and Category Type cannot be modified.
● Click Delete to move the column to the recycle bin.
● Click Unlock and unlock the locked column.

If the editing of a column is interrupted due to reasons such as sign-out and
the column is not saved, the column will be locked. In this case, the value of
Locked By is the account of the operator who locks the column.

NO TE

Only the operator who has locked the column can unlock it.

● Click Permanently Delete to delete the column directly instead of moving it
to the recycle bin.

NO TE

Before permanently deleting a column, ensure that the column is no longer needed.
Deleted data cannot be retrieved.

● Click More and choose Move. In the dialog box that is displayed, select the
target column, click Submit, and move the column to the target column.

● Click More and choose Modify Attribute. In the Batch Modify Attributes
dialog box, modify Display on Front Page, Validity Period Start, and
Validity Period End.

● Click More, choose Sort, and click Up, Down, or Pin as required. Alternatively,
click Adjust to, select the target column, and move the column before or
after the target column.

----End

CEC
User Guide 2 Tenant Administrator Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1088



2.16.2.2 Compiling Knowledge

After configuring a knowledge column, a knowledge compiler can configure the
information of a knowledge item such as the knowledge type and knowledge
content.

Prerequisites
● The Knowledge Base feature has been enabled for the tenant space, and the

operator has the Knowledge Base > Knowledge Management > Knowledge
Column menu permission.

● A column has been configured under the current tenant.

● Extended attributes can be configured for knowledge items. For details about
how to manage extended attributes, see 2.16.2.3 Managing Extended
Attributes.

Procedure

Step 1 Sign in to the AICC as a knowledge compiler and choose Knowledge Base >
Knowledge Column.

Figure 2-714 Knowledge list

●  indicates a column, and  indicates a knowledge item.

● You can search for existing knowledge information by knowledge column
name, modifier, modification start time, modification end time, column type,
knowledge type, and knowledge status.

When Category Type is set to Knowledge, you can set Knowledge Type and
Knowledge Status.

● Historical and valid normal columns are displayed on the left.

– For normal columns, column names are displayed.

– For historical columns, column names are in Column name(History)
format.

● Subcolumns and valid knowledge items in the selected column are displayed
on the right by default.
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– Click  to display historical subcolumns and expired knowledge items
in the selected column.

– Click  to display normal subcolumns and valid knowledge items in
the selected column.

NO TE

The preceding operations are not supported for historical columns.

Step 2 Select a new column and click Add Knowledge.

Step 3 Configure knowledge content.

1. Configure basic knowledge information.

Figure 2-715 Basic Information

Table 2-190 Parameters on the Basic Information tab page

Parameter Description

Knowledge Name Mandatory. The value can contain a maximum of 80
characters.

Path Path of a knowledge item to be added or modified,
which cannot be modified.

browse group Group to which the personnel who can browse the
current knowledge item belong.
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Parameter Description

Type Mandatory. The options are as follows:
– Common knowledge: You can use an editor to edit

knowledge content, such as texts, tables, images,
audio, and videos, and set their formats.

– Q&A knowledge: You need to configure at least one
question and one answer. A question can have
multiple answers.

Display on Front
Page

Mandatory. Whether to display a knowledge item on
the knowledge base home page after it is published.
The options are as follows:
– Yes
– No

Validity Period
Start/Validity
Period End

Mandatory. The time zone of the validity period must
be the same as that of the browser.

Upon Expiration Mandatory. The options are as follows:
– Mark: After a knowledge item expires, its status is

updated to Expired, and its name is displayed as
Knowledge name[expired].

– Delete: Move a knowledge item to the recycle bin.
(When a column and its subcolumns are deleted,
only the parent column is moved to the recycle bin.)

– Move to History: Move a knowledge item to a
specified historical column.

Move to History Mandatory when Upon Expiration is set to Move to
History.
You can specify the column to which a knowledge item
is moved upon expiration.

Summary The value can contain a maximum of 256 characters.

Keywords Keywords used to search for knowledge content. Use
semicolons (;) to separate multiple keywords.

Knowledge
Association

A maximum of 20 published knowledge items can be
associated.

Publish Mode Mandatory. The options are as follows:
– Publish directly: A knowledge item is directly

published to the knowledge base home page
without secondary approval.

– Review then publish: A knowledge item needs to
be approved before being published to ensure the
accuracy and security of knowledge content.
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Parameter Description

Reviewed By Mandatory when Publish Mode is set to Review then
publish.

Attachment
Click  and upload a local file.

 
2. After confirming that the information is correct, perform the following

operations as required:
– Click Close to cancel the knowledge creation.
– Click Save and NextStep and go to the Content tab page.

3. Configure knowledge content.
– Configure common knowledge content.

When Type is set to Common knowledge, configure the content based
on the following description:
You can edit common knowledge content, such as texts, tables, images,
audio, and videos, and set their formats in an editor.

Figure 2-716 Common knowledge content

▪ : Insert or edit a multimedia file. Local videos cannot be
uploaded.
○ General: Set the multimedia URL and the width and height. The

multimedia URL is the URL of a media resource that can be
downloaded.
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○ Embed: Paste the multimedia embedded code.
○ Advanced: Set the alternative multimedia URL and media poster

(image URL). The alternative multimedia URL is the URL of a
media resource that can be downloaded. The media poster is the
URL of an image that can be previewed.

▪ : Insert special characters. The following types of special
characters are provided: Currency, Text, Quotations, Mathematical,
Extended Latin, Symbols, and Arrows.

▪ : Preview the knowledge display effect during editing.

▪ : Reference a published content template.
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NO TE

○ After a content template is used, the content you are editing will be
overwritten. Exercise caution when performing this operation.

○ After a content template is used, the editing specifications related to the
content template are displayed. The Editing Specifications dialog box
can be moved and collapsed, but cannot be closed.

– Configure Q&A knowledge content.

When Type is set to Q&A knowledge, configure the content based on
the following description:

A Q&A knowledge item is displayed in the form of one question and one
answer. Only the text format is supported. A question can have one or
more answers, and a Q&A knowledge item can have one or more FAQ
groups.

Figure 2-717 Q&A knowledge content

▪ Add Question: Add FAQ groups.

▪ Delete Q&A: Delete an unnecessary FAQ group if there are multiple
FAQ groups. There must be at least one FAQ group.

▪ Up/Down: Sort FAQ groups.
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▪ Question (mandatory): The value can contain a maximum of 500
characters.

▪ Answer (mandatory): The value can contain a maximum of 500
characters.

▪ Add Answer/Delete Answer: A question can have multiple answers
and must have at least one answer.

4. After confirming that the information is correct, perform the following
operations as required:
– Click Submit. The knowledge item is compiled successfully, and the

knowledge status becomes Published.
– Click Pre Step to return to the Basic Information tab page.
– Click Save And NextStep to go to the Extended Information tab page.
– Click Close to save the current knowledge content. The knowledge status

becomes New.
5. Configure extended knowledge information.

Figure 2-718 Extended Information

– Inherit Parent Category Attribute (mandatory): Determine whether to
inherit the extended attributes of the parent column.

– Add: Click this button and select a configured extended attribute. For
details about extended attributes, see 2.16.2.3 Managing Extended
Attributes.
You can perform the following operations on configured extended
attributes:

▪ Click Delete to delete unnecessary an extended attribute.

▪ Click Up or Down to determine the display position of an attribute.

6. After confirming that the information is correct, perform the following
operations as required:
– Click Close to save the current knowledge content. The knowledge status

becomes New.
– Click Submit. The knowledge item is compiled successfully, and the

knowledge status becomes Published.

Step 4 (Optional) Select the new knowledge item.
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● Click Modify and modify basic knowledge information by referring to Table
2-190. Path and Type cannot be modified.

● Click Delete to move the knowledge item to the recycle bin.
● Click Unlock and unlock the locked knowledge item.

If a knowledge item is edited and submitted again, or the editing is
interrupted due to reasons such as sign-out and the knowledge item is not
saved, the knowledge item is locked. In this case, the value of Locked By is
the account of the operator who locks the knowledge item.

NO TE

Only the operator who has locked the knowledge item can unlock it.

● Click Permanently Delete to delete the knowledge item directly instead of
moving it to the recycle bin.

NO TE

Before permanently deleting the knowledge item, ensure that it is no longer needed.
Deleted data cannot be retrieved.

● Click More and choose Move. In the dialog box that is displayed, select the
target column and click Submit to move the knowledge item to the column.

● Click More and choose Publish to publish the new knowledge item. You can
publish knowledge items in batches.

● Click More and choose Copy. On the Knowledge Compilation page,
configure knowledge content by referring to Step 3.

● Click More and choose Modify Attribute. In the Batch Modify Attributes
dialog box, modify Display on Front Page, Validity Period Start, and
Validity Period End.

● Click More, choose Sort, and click Up, Down, or Pin as required. Alternatively,
click Adjust to, select the target knowledge item, and move the knowledge
item before or after the target knowledge item.

Step 5 (Optional) Compare knowledge items. You can compare only two common
knowledge items.

To compare knowledge items, use either of the following methods:

● Select two common knowledge items and click .

● Click . On the knowledge selection page, add common

knowledge items to the comparison list and click .
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Figure 2-719 Selecting knowledge items for comparison

----End

2.16.2.3 Managing Extended Attributes
Labels can be added to knowledge items using extended attributes so that users
can quickly locate them.

Prerequisites
The Knowledge Base feature has been enabled for the tenant space, and the
operator has the Knowledge Base > Knowledge Management > Knowl
Attribute menu permission.

Procedure

Step 1 Sign in to the AICC as a knowledge compiler and choose Configuration Center >
Knowledge base management > Knowl Attribute.

Figure 2-720 Knowl Attribute

Step 2 Click New.
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Figure 2-721 Add Extended Attribute

● Name (mandatory): The value can contain a maximum of 50 characters.
● Input Type (mandatory): Select Text input, Drop-down list, Radio box, or

Check box.

NO TE

The input mode of an extended attribute cannot be modified and updated after being
saved.

Step 3 Click OK.

Step 4 Configure extended attribute details.

When Input Type is set to Drop-down list, Radio box, or Check box, dictionary
values can be configured for the extended attribute.

1. Click Details in the Operation column corresponding to the new extended
attribute.
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Figure 2-722 Extended Attribute Details

2. Click New and add attribute dictionary values as required. The extended
attribute must have at least one dictionary value.

3. Set Dictionary Value, which is mandatory. The value can contain a maximum
of 100 characters.

4. (Optional) Click Delete to delete an unnecessary dictionary value. Click Up or
Down to sort dictionary values.

5. After the configuration is complete, click OK.

Step 5 Click Enable corresponding to the configured extended attribute. The extended
attribute status becomes Enable.

Extended attributes in the Enable state can be referenced by columns and
knowledge items.

Step 6 (Optional) Perform other operations.
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● By default, a new extended attribute is in the Draft state. Click Edit and
modify the basic information about the extended attribute. Click Delete to
delete the extended attribute.

● Click Disable corresponding to an enabled extended attribute. The extended
attribute status becomes Disable. In this case, the extended attribute cannot
be referenced by columns or knowledge items.
Enabled extended attributes cannot be modified. You can only view their
details.

● Click Enable corresponding to a disabled extended attribute. The extended
attribute status becomes Enable.

----End

2.16.2.4 Reviewing Knowledge
To ensure the correctness of knowledge content, knowledge items need to be
reviewed by reviewers before being published or updated.

Prerequisites
● The Knowledge Base feature has been enabled for the tenant space, and the

operator has the Knowledge Base > Knowledge Review > Knowledge
Review menu permission.

● The current user has tasks to be reviewed.

Procedure

Step 1 Sign in to the AICC as a reviewer and choose Knowledge Base > Knowledge
Review.

By default, all knowledge items to be reviewed are displayed. You can set search
criteria, such as Knowledge Name, Submitted By, Task Start Time, and Task
End Time, to search for knowledge items. You can also directly select a knowledge
item for review.

Figure 2-723 Reviewing knowledge items

Step 2 Click the Pending Review tab and view the list of knowledge items to be
reviewed.

Step 3 Click the name of a knowledge item.

Review the knowledge details, enter review remarks at the bottom of the page,
click Approve or Reject, and then confirm the review result.
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Figure 2-724 Reviewing a knowledge item

Step 4 (Optional) Select multiple knowledge items and click Batch Approve or Batch
Reject.

In the dialog box that is displayed, enter the review remarks and click OK.

Figure 2-725 Batch Approve

Step 5 (Optional) Click the My Application tab and view the list of knowledge items
submitted by the current account for review.
● Search for knowledge item information by knowledge item name, submitter,

task start time, task end time, and review status.
● Click the name of a knowledge item to view its knowledge details submitted

by the current account.

----End

Follow-up Procedure

Step 1 Choose Knowledge Base > Review Record and view knowledge review records.

NO TE

To use the knowledge review record query function, you must have the Knowledge Base >
Knowledge Review > Review Record menu permission.
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Figure 2-726 Review Record

You can search for data by knowledge item name, review status, task start time,
task end time, submitter, and reviewer.

Step 2 Click the name of a review record and view the knowledge details and review
process.

Figure 2-727 Review details

----End

2.16.2.5 Managing the Recycle Bin

The CC-iKBS provides the recycle bin function. When deleting columns and
knowledge items, you can move them to the recycle bin to prevent data loss
caused by misoperations.

Prerequisites
● The Knowledge Base feature has been enabled for the tenant space, and the

operator has the Knowledge Base > Knowledge Management > Recycle Bin
menu permission.

● Delete has been clicked to delete a column or knowledge item. If you click
Delete permanently, the deleted column or knowledge item is not moved to
the recycle bin.
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Procedure

Step 1 Sign in to the AICC as a knowledge compiler and choose Knowledge Base >
Recycle Bin.

Figure 2-728 Recycle Bin

You can search for deleted columns and knowledge items by knowledge column
name, knowledge column type, deletion start time, and deletion end time.

Step 2 Select multiple columns or knowledge items and click Restore to restore them to
the column management page.

Step 3 Select multiple columns or knowledge items and click Delete to delete them
permanently.

Step 4 Click Empty Recycle Bin to clear all deleted columns and knowledge items by one
click.

NO TE

After columns and knowledge items are deleted or the recycle bin is cleared, the columns
and knowledge data will be deleted permanently. Exercise caution when performing these
operations.

----End

2.16.2.6 Managing Knowledge Versions

Historical knowledge versions are used to identify knowledge maintenance
records. Knowledge compilers can manage and maintain historical knowledge
versions based on the versions recorded in the system.

Procedure

Step 1 Sign in to the AICC as a knowledge compiler and choose Knowledge Base >
Knowledge Column.
● The historical version function is not supported for columns.
● Click a value in the Source Version column to view the latest version of a

knowledge item. Target Version displays the number of historical versions of
a knowledge item.

Step 2 Click a value in the Target Version column corresponding to a published
knowledge item.
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Figure 2-729 Manage Knowledge History

Step 3 (Optional) Click a historical knowledge version name to view its details.

Step 4 Click Restore corresponding to a historical knowledge version. The page for
configuring a new knowledge version is displayed, and the current knowledge
item is automatically changed to a historical version.

Step 5 (Optional) Perform the following operations on historical knowledge versions:
● Click Delete corresponding to a historical knowledge version to delete it.
● Select different knowledge versions and click Compare to compare them.

----End

2.16.2.7 Managing Content Templates

You can use a content template when configuring common knowledge content in
the editor to quickly reference the content configured in the template, facilitating
knowledge compilation.

Prerequisites

The Knowledge Base feature has been enabled for the tenant space, and the
operator has the Knowledge Base > Template management > Content
template menu permission.

Procedure

Step 1 Sign in to the AICC as a knowledge compiler and choose Configuration Center >
Knowledge base management > Content Template.

Figure 2-730 Content template management
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You can search for content template data based on the template name, template
status, modifier, modification start time, and modification end time.

Step 2 Add a content template.

Use one of the following methods as required:

● Add a template at a time.

a. Click Add. On the page that is displayed, configure template information.

Figure 2-731 Adding a content template

▪ Template name (mandatory): Enter a value of no more than 80
characters.

▪ Template status (mandatory): Select Draft or Valid.

▪ Template description: Enter a value of no more than 400 characters.

▪ Template content: Configure the common knowledge content by
referring to 2.2-1 Configure common knowledge content.

▪ Editing Specifications: Specify the editing requirements for
referencing the common knowledge content template.

b. Click Save.
● Import templates in batches.

a. Click Import.
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Figure 2-732 Import Templates

b. Click Download Import Template to download the import template to
the local PC.

c. Edit the file content and then save the file.

d. Click  to upload the template file.
e. Set Import Method. If you select Overwrite Templates with Same

Names, the uploaded content template overwrites an existing content
template with the same name. If you select Create Directly, the
uploaded content template is directly created without overwriting an
existing content template with the same name.

f. Click OK.

Step 3 (Optional) Perform the following operations on content templates:
● Select multiple content templates and click Delete to delete them in batches.
● Select multiple content templates and click Export to export them to the local

PC.
● Click Modify corresponding to a content template to modify the template

content. Template status can be set to Invalid.
● Click Delete corresponding to a content template to deleted it.
● Click Copy corresponding to a content template. The content template

configuration page is displayed for you to add a content template with the
same content. The name of the new template is *-copy, and its status is
Draft. For details about how to configure a template copy, see 2.7-2 Add a
content template.

----End

Follow-up Procedure
Content templates can be imported and exported. A maximum of 10 templates
can be imported and exported at a time.
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Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Knowledge Base Management > Content Template.

Step 2 Click Import.

Figure 2-733 Import Template

Step 3 Select the template data file, and then click OK to upload the file.

NO TE

Before the import, you can download the import template, edit it in the specified format,
and then upload it.

----End

2.16.3 Managing Knowledge in the Foreground
The knowledge base allows agents to search for and browse knowledge based on
business requirements, improving agent service efficiency.

2.16.3.1 Knowledge Base Home Page

The knowledge base home page is provided for agents to search for knowledge by
keyword.

Prerequisites

The Knowledge Base feature has been enabled for the tenant space, and the
operator has the Knowledge Base > Knowledge Application > Knowledge
Home menu permission.
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Procedure

Step 1 Sign in to the AICC as an agent and choose Knowledge Base > Knowledge
Home.

Figure 2-734 Knowledge Home

● My History: displays all knowledge items viewed by the current account in
descending order of the time on the right of the items, which indicates the
time when they were viewed.

● Shortcuts: displays all favorite knowledge items of the current account in
ascending order of the time on the right of the items, which indicates the
time when they were added to favorites.

● Most Clicks: displays all knowledge items that have been clicked in
descending order of the number of views and the last update time on the
right of each item.

You can view the number of views on the knowledge details page.

Step 2 Search for knowledge items.

Use either of the following methods:

● Enter a keyword in the text box on the top and click  to search for required
knowledge items.

The knowledge names, content, or keywords are matched based on the
entered content. The matched keywords are displayed in red in the search
results.

● Click Advanced Search.

You can set keyword, column name, knowledge type, update start time, and
update end time, and then search for required knowledge items. The matched
keywords are displayed in red in the search results.
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Figure 2-735 Advanced Search

Step 3 Click  on the top to refresh the knowledge
base home page and return to the page shown in Figure 2-734.

Step 4 Choose a column on the left. The subcolumns and knowledge items in the column
are displayed on the right.

Figure 2-736 Knowledge columns

● Name:  indicates a column, and  indicates a knowledge item.
● If a subcolumn has knowledge items, its name is Subcolumn name(Number

of knowledge items). You can click a subcolumn name to view the columns
and knowledge items in the subcolumn.

● Click  on the right of a column name to display the subcolumns in the
column.
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Figure 2-737 Subcolumn

● Display and sorting: Click By No, By Name, Clicks, or Time and then  to
sort the columns and knowledge items in ascending or descending order.

Step 5 Click a knowledge item name to view the knowledge details.

Figure 2-738 Knowledge details

Step 6 Click  to add the current knowledge item to my
favorites.

----End

2.16.3.2 Managing Favorites
Favorites folders are used by agents to save required knowledge to quickly access
the knowledge.

Prerequisites
● The Knowledge Base feature has been enabled for the tenant space, and the

operator has the Knowledge Base > Knowledge Application > Favorites
menu permission.

Procedure
Step 1 Sign in to the AICC as an agent and choose Knowledge Base > Favorites.

Figure 2-739 Favorites
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NO TE

On the Favorites page, the favorites directory tree on the left can be expanded. A
maximum of three directory levels are supported.

Step 2 Click  to add a favorites directory.

Figure 2-740 Add Directory

Directory Name (mandatory): Enter a value of no more than 80 characters.

Step 3 Click OK.

Step 4 (Optional) Click  corresponding to the new favorites directory to delete it.

NO TE

After a favorites directory is deleted, all favourite knowledge items in the directory will be
deleted. Exercise caution when performing this operation.

Step 5 Choose a favorites directory. All knowledge items in the directory are displayed on
the right.
● Click a favourite knowledge item name to view the knowledge details.
● Click Edit and modify the knowledge item name displayed on the Favorites

page.
● Click Delete to delete a knowledge item from favorites.

----End

2.16.4 Managing Consultation Tables
A consultation table stores business consultation information. When handling
businesses, an agent can look up in a consultation table to answer business
questions.

2.16.4.1 Managing Consultation Table Templates
A consultation table template, similar to a data table, can be referenced during
consultation table data creation.

Prerequisites
● The AppCube feature has been enabled for the tenant space, and the AICC

has been connected to AppCube. The Knowledge base feature has been
enabled.
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● You have the Knowledge Base > Knowledge Management > Consult Table
Config and Channel Configuration > Call Center Configuration > Service
Guidance Configuration menu permissions.

● You have customized consultation table fields.

a. Sign in to the AICC as a tenant administrator and choose Configuration
Center > Knowledge Base Management > Consultation Table
Template.

b. Click Configure to access AppCube and configure consultation tables.

Figure 2-741 Config Center

c. Choose Processes > Model. The consultation table list page is displayed.

Figure 2-742 Model

d. Select a consultation table to which a field needs to be added and click
New to add a field. The consultation tables are preset and contain two
fields by default.

e. Select a field type and configure field details as prompted. The field name
is automatically filled in based on the label and can be modified.
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f. Click Next to save the new field.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Knowledge Base Management > Consultation Table Template.

Figure 2-743 Consultation table template list

You can click Configure to customize consultation table fields. For details, see
Prerequisites.

Step 2 Click Add. On the page that is displayed, configure a consultation table template.

Figure 2-744 Adding a consultation table template

● Template name: Name of the consultation table template. This parameter is
mandatory.

● Consult table: Select the required consultation table. This parameter is
mandatory.

● Template status: Status of the consultation table template. This parameter is
mandatory. The options are as follows:

– Draft: Multiple draft consultation table templates can be created for a
consultation table.

– Enabled: Only one enabled consultation table template can be created
for a consultation table.

● Template description: Description of the consultation table template.

● List of consultation table fields: The values are automatically generated after
the required consultation table is selected.

Step 3 Select a field and click Modify. On the page for editing extended attributes,
configure extended attributes of the consultation table field.
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Figure 2-745 Editing extended attributes

● Field: Read-only.

● Display name: Read-only.

● Displayed or Not: Whether to display the field in the consultation table field
list.

● Search Criterion or Not: Whether the field is a search criterion in the
consultation table field list.

● Anonymized or Not: Whether to anonymize the field in the consultation
table field list. Set Anonymized or Not to Yes for fields that contain personal
data and sensitive data.

Step 4 Click OK to complete the configuration of extended attributes and return to the
page for adding a template.

Step 5 (Optional) To change the display position of a consultation table field, select the
field and click Move up or Move Down.

Step 6 Click Save.

----End
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Follow-up Procedure
You can perform the following operations after you select consultation table
templates:

● Click Delete to delete the consultation table templates in batches.
● Click Modify to modify template parameters except Consult table. The

template status can be changed to Discarded.

2.16.4.2 Managing Consultation Table Data
Tenant administrators can configure consultation table data.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Knowledge Base Management > Consultation Table Management.
● Enabled consultation table templates are displayed on the left.
● The data in a consultation table is displayed on the right. By default, 100

records are displayed.

Figure 2-746 Consultation table management

Step 2 Select the consultation table template to be configured and click  on
the right. The dialog box for adding consultation table data is displayed.

Step 3 Enter the values of the fields in the consultation table and click Save.
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Figure 2-747 Adding consultation table data

----End

Follow-up Procedure
● Manage consultation table data based on conditions.

– Click  to add a search condition. A maximum of 10 search conditions
can be added.

– Click  to delete a search criteria.

– Configure search conditions and click Delete by condition to delete field
values based on specific conditions.

– Configure search conditions and click Query to query field values based
on the conditions.

– Click Reset to clear conditions by one click.

● Select data records and click  to delete them in batches.

● For configured field data records:

– Click Delete to delete a field data record.

– Click Modify to update a field data record.

2.16.4.3 Consultation Table Lookup

During business handling, an agent can look up in a consultation table to answer
business questions.
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Prerequisites

The knowledge base feature has been enabled for the tenant space, and the
operator has the permission on the Search Consultation Table menu.

Procedure

Step 1 Sign in to the AICC as an agent and choose Knowledge Base > Search
Consultation Table.

Figure 2-748 Consultation table lookup

● Enabled consultation table templates are displayed on the left.

● All data values in a consultation table template are displayed on the right.

Step 2 Select a consultation table to obtain the table data.

Step 3 Click the COMMON SEARCH tab.

Set search criteria and click Query to search for consultation table data that
meets the search criteria.

Step 4 Click the INTELLIGENT SEARCH tab.

Intelligent search supports only keyword-based search. All data values of the
string and number types in the consultation table can be queried. Fuzzy search is
supported.

----End

2.17 Configuring Public Resources

2.17.1 Modifying Policy Information
A tenant administrator can directly modify the agent call policy of the tenant
space without contacting O&M personnel. The policy information includes the call
allocation mode, rest queuing policy, whether to release calls not answered for a
long period, and whether to set agents who do not answer for a long period to
the busy state.
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Prerequisites
None

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
System Management > Tenant Information.

Step 2 In the Policy Information area, click  to enter the editing mode.

Figure 2-749 Page for modifying policy information

Step 3 Modify policy information based on Table 2-191.

Table 2-191 Policy information parameters

Parameter Description Value Range

Call Allocation Mode Call allocation mode. ● Optimal
● Average
● Agent with most

skills
Default value: Optimal
Table 2-192 describes
the parameters.
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Parameter Description Value Range

Rest Queuing Policy Rest queuing policy. ● Agent who applies
for a rest first: When
there is a rest place,
the system sets the
agent who applies for
a rest first to the rest
state.

● Agent with the least
rest on the current
day: When there is a
rest place, the system
sets the agent with
the least rest on the
current day to the rest
state.
Rest ratio of a day =
(Total rest duration
during historical sign-
in periods on the day
+ Rest duration
during the current
sign-in period)/(Total
sign-in duration
during historical sign-
in periods on the day
+ Sign-in duration
during the current
sign-in period)

Default value: Agent
who applies for a rest
first

Release Calls Not
Answered for a Long
Period

Whether to release calls
not answered for a long
period.

● : no

● : yes

Default value: 

Set Agents Who Do Not
Answer for a Long Period
to the Busy State

Whether to set agents
who do not answer for a
long period to the busy
state.

● : no

● : yes

Default value: 
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Table 2-192 Call allocation modes

Call Allocation
Mode

Description Scenario Processing

Optimal In this mode, a
call is
preferentially
allocated to the
agent who meets
the call skill
requirements and
has the fewest
skills.
When there are
multiple agents
who meet the
requirements, the
system allocates
the call to one of
the agents at
random.

A VDN has the
following idle
agents at a
certain time:
● Agent A has

skill 1 and skill
2.

● Agent B has
skill 1.

● Agent C has
skill 1, skill 2,
and skill 3.

The call that is
first selected from
skill queue 1 is
allocated to agent
B.

Average In this mode, the
system allocates
calls to agents
with the longest
idle time in turn
according to the
idle time of the
agents.

The call that is
first selected in
skill queue 1 is
allocated to the
agent with the
longest idle time.

Agent with most
skills

In this mode, a
call is
preferentially
allocated to the
agent who meets
the call skill
requirements and
has the most
skills.
When there are
multiple agents
who meet the
requirements, the
system allocates
the call to one of
the agents at
random.

The call that is
first selected from
skill queue 1 is
allocated to agent
C.

 

Step 4 Click Save.

----End
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2.17.2 Viewing Interconnection Parameters
Interconnection parameters are the AK/SK authentication information of the
current tenant space. When a tenant invokes the AICC through the API
management platform, the AK/SK can be used to obtain a token.

Prerequisites

You have obtained the parameters for interconnection from the operation
personnel.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
System Management > Tenant Information.

Step 2 In the Incterconnection parameters area, view the API Fabric ID.

Step 3 (Optional) Click download SK to download the SK to the local PC. Click reset SK
and enter the password of the current user to reset the SK.

NO TE

● The SK information can be downloaded only once. If it is downloaded more than once,
the system prompts the user to reset the SK.

● When the SK is rest, if the current user password is incorrectly entered for three times,
the user will be locked for 10 minutes. Reset the SK after 10 minutes.

● Verification Code: Verification mode used for password settings to guarantee security
of the current account. The verification code can be a mobile phone verification code or
an email verification code. The verification mode is specified by the system parameter
Two-factor Authentication Method.

Verification Code is available only when Two-factor Authentication Method is set to
SMS verification code or Email verification code. You can click Send Code to obtain a
verification code.

– A verification code is valid for 1 to 5 minutes, which is specified by the system
parameter Two-factor Authentication System-level Verification Code Validity
Period.

– The interval for obtaining a verification code is 1 minute. If you enter a verification
code correctly but password change fails, you can obtain a new verification code
immediately.

----End

Follow-up Procedure

Click download SK to download the SK to the local PC.

Click reset SK and enter the password of the current user to reset the SK.
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NO TE

● The SK information can be downloaded only once. If it is downloaded more than once,
the system prompts the user to reset the SK.

● When the SK is rest, if the current user password is incorrectly entered for three times,
the user will be locked for 10 minutes. Reset the SK after 10 minutes.

2.17.3 Configuring Parameters
A tenant administrator can configure tenant parameters to control the running
mode and function rules of the system. For details about the parameters, see the
Description column.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
System Management > Tenant Parameter.

Figure 2-750 Configuring parameters

Table 2-193 Tenant parameters

Parameter Description

Unified
Public
Configura
tion

Commo
n

Whether to enable
page
watermarking

Whether to enable the page
watermark function.

Subscriber
Number
Anonymization
Rule

User number anonymization rule.
The options are Anonymize middle
four digits and Retain only last
four digits.

Page Watermark
Character

Page watermark string.
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Parameter Description

Whether to enable
file watermarking

Whether to enable the file
watermark function.
If this function is enabled,
watermarks are displayed in the
following exported files:
● Exported outbound call result file

and call record file
● Exported contact record file
● Exported recording inspection file

File Watermark
Character

File watermark string.

Specifies whether
to set the
password of the
compressed file for
exporting data.

The options are Yes and No. The
default value is Yes.

Number of agents
that can be
queried for call
transfer

Number of agents that can be
queried in each skill queue during
call transfer.
The value ranges from 1 to 500.
The default value is 150.

Connecti
on
Manage
ment

Call
Control

Number Display
for Agent Phone

Number display policy for agent
phones. The options are Display
system calling number and Display
customer number.

Answer Inbound
Call as Inspector

Whether an inspector answers an
inbound call. The options are No
and Yes.

Integrate OpenEye
in Web System

Whether to integrate the OpenEye
softphone in the web system. The
options are No and Yes.
To implement this function, a tenant
needs to install the OpenEye locally.

Agent Answering
Mode

Agent answering mode. The options
are Custom, Automatic, and
Manual.

Call Processing
After Agent
Rejection

Call processing after an agent
manually rejects a call. The options
are Return call to original queue
and set agent to busy and Release
call and set agent to idle.
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Parameter Description

Web-integrated
OpenEye Video
Display

Video display of the OpenEye
integrated with the web system. This
parameter is valid only when
Integrate OpenEye in Web System
is enabled. For example, in the value
0,0,800,380,PiP,Fit, 0,0 indicates the
X and Y coordinates of the video
position (the upper left corner of
the screen is the coordinate origin),
800,380 indicates the width and
height of the window, PiP indicates
the layout of the video image (PiP
indicates picture-in-picture, and SbS
indicates side-by-side), and Fit
indicates the display mode of the
video image (Fit indicates that the
video is adapted according to its
original proportions, and Cut
indicates that the video is displayed
at full size according to its original
proportions and cropped if
necessary).

Video Recording
Mode

Video recording mode. The options
are Same-size image for three
parties, Maximized customer
image, Maximized agent image,
and Maximized third-party image.

Agent
Status

After-Call Agent
State

State that an agent automatically
enters after a call ends. The options
are Idle and Wrap-up.

Signed-in Agent
State

State that an agent automatically
enters after sign-in. The options are
Idle, Wrap-up, and Busy.

Forcibly End Agent
Rest After Timeout

Whether to forcibly end an agent's
rest when the rest times out. The
options are No and Yes.

Internal Message
Template for
Notifying
Supervisor of
Agent Rest
Timeout

Template for sending an internal
message to the supervisor when an
agent's rest times out. Set this
parameter to the internal message
notification template ID. If this
parameter is not set, no internal
message is sent to the supervisor
when an agent's rest times out.
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Parameter Description

Mode in Which an
Agent Signs In to a
Skill Queue

Mode in which an agent signs in to
a skill queue. The parameter
modification takes effect after the
page is refreshed.
NOTE

● If this tenant parameter is set to
Agent-defined, the value of the
agent parameter Mode in Which an
Agent Signs In to a Skill Queue is
used.

● If this tenant parameter is set to
Automatic or Specified, the value of
this parameter is used.

Log
Tracing

Agent ID Requiring
Log Generation

Agent ID for generating logs. Use
commas to separate multiple IDs,
for example, 101,102,103.

Agent Output Log
Level

Level of generated agent connection
operation logs.

Contact
Record

Time Span for
Contact Record
Query

Time span for searching for contact
records, in days. The default value is
7.

Number of days in
advance for
querying contact
records

Number of days in advance for
searching for contact records, in
days. The default value is 7.

Indicates whether
to store callData
in contact records.

Whether to store call-associated
data in contact records. If this
parameter is set to Yes, the
connected contact records
integrated by the Dynamics can
carry the call-associated data of the
last call for callback. The options are
No and Yes. The default value is No.

Validity days of
call reason
configuration

Number of days that the call reason
can be supplemented or modified
for historical contact records. The
value must be an integer. The
default value is 0. The value 0
indicates that the period is not
limited. The call reason can be
supplemented or modified for
historical contact records generated
in any period.
NOTE

The value of this parameter depends on
the time range of data obtained for call
reason analysis statistics.
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Parameter Description

Whether
encryption or
decryption is
required to
download
recordings.

The value Yes indicates that the
recording file of a contact record or
an outbound call result can be
downloaded only after a
decompression password is entered.
The value No indicates that a
recording file can be downloaded
directly.

Indicates whether
to set the call
reason for
customer contact.

Whether the call reason needs to be
set for a customer contact.
● If this parameter is set to Yes, the

Call Reason dialog box is
automatically displayed when no
call reason is not set after a
common customer session ends.
Contact records for which no call
reason is set are displayed on the
Unfinished Contact page.
When the agent sign-out
response is successful, the system
checks whether the agent has
unfinished contact at 00:00:00 on
the current day in the time zone
where the agent is located. A
dialog box is displayed if the
agent has unfinished contact on
the current day which needs to
be handled in a timely manner.
Click Go for processing to open
the Contact record page.

● If this parameter is set to No, the
Call Reason dialog box is not
automatically displayed after a
common customer session ends
and the Unfinished Contact tab
page is not displayed.

The options are as follows:
● Yes
● No
The default value is No.
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Parameter Description

Agent
Workbe
nch

Whether to send
internal messages
when the WebRTC
network is
abnormal

Whether to send an internal
message to notify the OU manager
if the network quality is poor when
an agent uses the WebRTC to make
a call. Only one internal message
can be sent within 60 minutes.
The options are as follows:
● Yes
● No
The default value is No.

WebRTC Network
Anomaly
Detection
Threshold

The format is Number 1;Number 2.
Both Number 1 and Number 2
range from 1 to 120, in seconds.
● Number 1 indicates the threshold

for the duration in which the
WebRTC network status is
abnormal, in seconds. If the
duration exceeds the threshold,
an exception is reported.

● Number 2 indicates the threshold
for the duration in which the
WebRTC network status is
normal, in seconds. If the
duration reaches the threshold,
the network is considered to be
recovered.

The default value is 6;3.

Display Associated
Data

Whether to display call-associated
data. The options are No and Yes.

Conference Link
SMS Template

SMS template used for sending
conference links. The template must
contain the Meeting_URL variable.

Display Unified
Customer Contact
Information

Whether to display unified contact
customer information. The options
are No and Yes.

Local listening
port of the agent
VRC.

Local listening port of the agent
VRC. This port is used by inspectors
to initiate screen inspection
connections.
The value ranges from 1 to 65535.
The default value is 6600.
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Parameter Description

VRC WebSocket
Port

WebSocket connection port of the
VRC. When the OpenEye is used, set
this parameter to the port
configured on the VRC.
The value ranges from 1 to 65535.
The default value is 7684.

The duration of
SmartCare
abnormal time
backtracking (s)

If the abnormal time passed to
SmartCare is the current time, the
value of the parameter
configuration is used to make
logical judgments based on the time
period before the current time, such
as on whether the user is affected
by the fault during this period.
The value ranges from 60 to 86400.
The default value is 3600.

The time (h)
pushed forward
from the current
time as start time
when SmartCare
delimits creation

If the end time passed to SmartCare
is the current time, the value of the
parameter configuration means that
a time period before the current
time is used as the start time, for
example, of fault demarcation for
the user during this period.
The value ranges from 1 to 168.
The default value is 24.

Service
Channels

Commo
n

Indicates whether
to enable the
system default
greeting (except
the email
channel).

Whether to enable the default
system greeting (except the email
channel).

Multimedia
Sessions
Concurrently
Processed by
Agent

Number of multimedia sessions that
can be handled by an agent
concurrently.
The value ranges from 1 to 60.
Default value: 5
NOTE

In the text chat scenario, if the CTI
specification is 8U32G and 60 text chats
are initiated to an agent within 6
seconds (the number of multimedia
sessions that an agent can concurrently
process is set to 60), a maximum of 10
sessions can be connected.
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Parameter Description

Third-party
interface invoking
failure rate
statistical period

Statistical period of the third-party
interface invocation failure rate, in
minutes. The value ranges from 1 to
30. The default value is 5.

Third-Party
Interface Invoking
Failure Rate Alarm
Threshold

Alarm threshold of the third-party
interface invocation failure rate, in
%. The value ranges from 1 to 100.
The default value is 20.

Validity duration
of the URL used by
a customer to
access a resource

The validity duration of the URL
used by a customer to access a
resource. The value is in minutes
and ranges from 5 to 10080 (at
most seven days). The default value
is 1440 (equals one day).

Indicates whether
to enable the new
special list for
multimedia.

Whether to use the new special list
function for multimedia channels.
The options are No and Yes.

Social Media
Approver Account

Default value: none
Social media approver account. If
this parameter is left blank, post
approval is not performed.
NOTE

The value can only be an employee
account with the Enterprise account
operation menu permission under the
current tenant.

Social Media Video
Upload Size Limit

Maximum size of an uploaded social
media video, in MB. The default
value is 200, and the maximum
value is 500.

Maximum size of
uploaded social
media images

Maximum size of uploaded social
media images, in MB. The default
value is 1, and the maximum value
is 4.

Message
allocation
threshold for
operators

Threshold for not assigning
messages to an operator. If the
number of messages unhandled by
an operator exceeds the threshold,
messages are not assigned to the
operator. The default value is 5, and
the maximum value is 20.
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Parameter Description

Number of SMs
allocated by the
operator

Number of messages that can be
assigned to an operator at a time.
The default value is 10, and the
maximum value is 20.

Number of offline
users allocated
each time

Number of offline customers
assigned each time. The value
ranges from 1 to 10. The default
value is 5.

Interval for
querying the
allocated offline
user list

Interval for querying assigned offline
customers. The value ranges from 0
to 60, in minutes. The default value
is 5.
NOTE

The value 0 indicates that offline
customers are not queried.

Number of offline
message for
warning alarm

When the number of offline
messages exceeds the value of this
parameter, a warning alarm is
generated. The value ranges from 1
to 100000. The default value is
5000.

Number of offline
message for minor
alarm

When the number of offline
messages exceeds the value of this
parameter, a minor alarm is
generated. The value ranges from 1
to 100000. The default value is
8000.

Number of offline
message for major
alarm

When the number of offline
messages exceeds the value of this
parameter, a major alarm is
generated. The value ranges from 1
to 100000. The default value is
10000.

Offline message
days for minor
alarm

When the number of days for which
an offline message is not handled
exceeds the value of this parameter,
a minor alarm is generated. The
value ranges from 1 to 15. The
default value is 3.

Offline message
days for major
alarm

When the number of days for which
an offline message is not handled
exceeds the value of this parameter,
a major alarm is generated. The
value ranges from 1 to 15. The
default value is 5.
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Parameter Description

DY contact record
reply message
switch

Whether the messages of contact
records in the Dynamics can be
replied to. The options are No and
Yes. The default value is No.

Web Map Type Used by
Location Message
Received Through
Web Channel

Type of the map used to display
location messages received from the
web channel on the web client and
agent workbench.

Email Max. Bytes in
Email Body

Maximum number of bytes in the
email body, in MB. The value ranges
from 1 to 10. The default value is 2.

Max. Email Cc
Recipients

Number of Cc recipients when a
maximum of 4096 characters are
allowed. The value ranges from 0 to
50. The default value is 20.

Max. Email Bcc
Recipients

Number of Bcc recipients when a
maximum of 4096 characters are
allowed. The value ranges from 0 to
50. The default value is 20.

Max. Email
Forwarding
Recipients

Number of email forwarding
recipients when a maximum of 4096
characters are allowed. The value
ranges from 1 to 50. The default
value is 20.

Max. Email Drafts
Added by Agent

Maximum number of email drafts
added by an agent. The value
ranges from 1 to 50. The default
value is 20.

Max. Size of
Images in Email

Maximum size of images in a reply
email edited by an email agent. The
value ranges from 0 to 1024, in KB.
The default value is 300.

Max. Images in
Email

Maximum number of images in a
reply email edited by an email
agent. The value ranges from 0 to
20. The default value is 10.

Auto Zoom Email
Channel Images

Whether to enable email channel
image auto scaling. The options are
Yes and No. The default value is No.
The value Yes indicates that images
whose size exceed the limit are
automatically zoomed in or out, and
the value No indicates that images
are not zoomed in or out.
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Parameter Description

WhatsA
pp

Map Type Used by
Location Message
Received Through
WhatsApp
Channel

Type of the map used to display
location messages received from the
WhatsApp channel on the agent
workbench.

WhatsApp
Webhook
Password
Authentication
Validity Period

Validity period of the Webhook
password used for authenticating
received requests when the
WhatsApp channel is connected to
the Infobip. The value ranges from 7
to 365. The default value is 90.

Line Map Type Used by
Location Message
Received Through
LINE Channel

Type of the map used to display
location messages received from the
LINE channel on the LINE client and
agent workbench.

Validity Period of
Access Token for
Accessing LINE

Validity period of an access token
for accessing the LINE, in days. The
value ranges from 1 to 30. The
default value is 30.

WeChat Map Type Used by
Location Message
Received Through
WeChat Channel

Type of the map used to display
location messages received from the
WeChat channel on the WeChat
client and agent workbench.

5G RCS Map Type Used by
Location Message
Received Through
5G RCS Channel

Type of the map used to display
location messages received from the
5G RCS channel on the agent
workbench.

Intelligen
t
Outboun
d Call

Commo
n

Record outbound
interface invoking
logs

Whether to record outbound call
interface invocation logs. If yes,
invocation records of one month are
stored by default. Invocation records
of a maximum of three months can
be stored.

Indicates whether
to send internal
messages when
outbound calls are
abnormal.

The default value is No, indicating
that no internal message is sent to
the manager of an employee when
an outbound call is abnormal. If this
parameter is set to Yes, an internal
message is sent to the manager of
an employee when an outbound call
is abnormal.
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Parameter Description

Threshold for
abnormal
outbound call
duration.

The unit is second. If the duration of
an outbound call is less than the
value of this parameter, the system
considers the call as an abnormal
call. If the value is 0 or empty, the
system does not determine whether
a call is an abnormal call.

Only leaf nodes
can be selected for
service results.

Only leaf nodes can be selected for
business results. The default value is
no.

Task due reminder
time

Number of days before task
expiration a reminder is sent. Unit:
day. The default value is –1,
indicating that no reminder is sent.
The value ranges from –1 to 10, that
is, a reminder can be sent at most
10 days before task expiration.

Managi
ng
Configu
rations

Destination
address of
outgoing call
result push

Address provided by the third party
for receiving outbound call results
pushed to the third party.

Maximum number
of scheduled tasks
in the outbound
call blocklist

Maximum number of scheduled
tasks in the outbound call blocklist.
The value ranges from 1 to 24, and
the default value is 10.

Call
Configu
ration

Manual outgoing
call automatic
outgoing call
switch

Whether to enable the automatic
outbound call capability for manual
outbound calls.

Time limit for
manual outgoing
calls

Time during which an agent is in
idle state before making an
automatic outbound call, in seconds.
The value ranges from 1 to 120.

Call Number Prefix
Configuration

Prefix of an outbound number. Use
commas (,) to separate multiple
prefixes.

Minimum length
of outbound
customer number

Minimum length of a customer
number, excluding the international
call prefix and international area
code.

Maximum length
of outbound
customer number

Maximum length of a customer
number, excluding the international
call prefix and international area
code.
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Parameter Description

The begin digits of
the customer
number

Start number of a customer number.
Use commas (,) to separate multiple
numbers.

CCNotific
ation

Internal
Messag
e

Notify App of
Internal Message

Whether to notify the app of an
internal message. The options are
Yes and No.

AK for Invoking
App Service for
Internal Message
Notification

AK provided by the app for invoking
the app service to send an internal
message notification.

Protocol for
Invoking App
Service for Internal
Message
Notification

Protocol type for invoking the app
service to send an internal message
notification. The options are http
and https. Use HTTPS because HTTP
is an insecure protocol.

IP Address and
Port for Invoking
App Service for
Internal Message
Notification

IP address and port number for
invoking the app service to send an
internal message notification. The
format is IP address:Port number.

URL for Invoking
App Service for
Internal Message
Notification

URL for invoking the app service to
send an internal message
notification. A reference
configuration is /app/agent/
gateway/v1/notice/
enterpriseMessage.

Cyclical Invoking
Times of App
Interface for
Internal Message
Notification

Number of times that the app
interface is cyclically invoked for
internal message notification. A
reference configuration is 3.

Email Delete Email
Received by
Tenant
Administrator and
Tenant from Email
Server

Whether to delete emails received
by tenant administrators and
tenants from the email server. The
default value is Yes, indicating that
the emails are deleted.

Max. Size of
Images in Email

By default, the maximum size of an
image is 100 KB. The value must be
greater than 0 and less than or
equal to 1024, in KB.

Teleco
m
number

International
Crown Code

International call prefix of the
tenant location. The default value is
00.
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Parameter Description

International area
code

International area code of the
tenant location. The default value is
86.

Online
Chat

Session Retention
Days

Session retention days. The value is
an integer ranging from 1 to 14, and
the default value is 7.

Number of days
for storing chat
records

Chat record retention day. The value
is an integer ranging from 1 to 93,
and the default value is 30.
The chat record retention days must
be greater than or equal to the
session retention days.

Operatio
n Risk
Control

Commo
n

Mobile number
area code

-

Schedule Commo
n

Time when the
compliance detail
view is
automatically
updated

Automatic refresh interval when
Auto Refresh on the adherence
details page is enabled, in seconds.
The value ranges from 10 to 20. The
default value is 20.

Maximum number
of rule sets in a
scheduling
scenario

Maximum number of rule sets
associated with all agents in a
schedule scenario. When this value
is exceeded, an error message is
displayed. The value ranges from 1
to 5. The default value is 5.

 

Step 2 Search for the parameter to be modified based on Parameter Name and
Description, click Edit in the Operation column, and enter the parameter value in
the Parameter Value column.

Step 3 Click Save to save the parameter configuration.

Step 4 (Optional) Click Synchronize or reset to synchronize or reset the value in the
Parameter Value column.

----End

2.17.3.1 Configuring Watermarks

A tenant administrator can configure watermarks for pages and exported files to
protect page data security in the tenant space.

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
System Management > Tenant Parameter.

Step 2 Choose Tenant parameters > Unified Public Configuration > Common.
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Figure 2-751 Watermark parameters

Step 3 Set parameters.
● Whether to enable page watermarking: Whether to display watermarks on

pages. This function is disabled by default. Enabling this function displays the
watermark string on pages after the setting is refreshed. The default
watermark string is the business account. You can modify the watermark
string using the tenant parameter Page Watermark Character.

● Page Watermark Character: Watermark string displayed on pages.
● Whether to enable file watermarking: Whether to display watermarks in

exported files. This function is disabled by default. Enabling this function
displays the watermark string in exported files after the setting is refreshed.
The default watermark string is the business account. You can modify the
watermark string using the tenant parameter File Watermark Character. If
this function is enabled, watermarks are displayed in the following exported
files:
– Exported outbound call result file and call record file
– Exported contact record file
– Exported recording inspection file

● File Watermark Character: Watermark string displayed in exported files.

Step 4 View the watermark display effect.

Figure 2-752 Page watermark display effect

----End
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2.17.4 Adding Customer Numbers to the Special List
An agent can add customers who make harassing calls to the blocklist. Calls from
blocklisted customers are not transferred to manual service and do not occupy
manual resources. The agent can add VIP customers to the redlist to receive
notifications of calls from redlisted customers.

Context

(Optional) In an old tenant, to use the new special list management function, set
the tenant parameter Indicates whether to enable the new special list for
multimedia. to Yes. The system has automatically synchronized the special list
data configured in 2.17.7 Configuring Email Special List Rules and 2.17.8
Configuring SMS Special List Rules to the new function. All special list records
except those with wildcard characters are synchronized. In addition, the old special
list management function (2.17.7 Configuring Email Special List Rules and
2.17.8 Configuring SMS Special List Rules) becomes invalid and resumes only
after you set Indicates whether to enable the new special list for multimedia.
to No. In this case, the data that has been added to the new special list needs to
be manually added to the old special list.

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Resource Management > Special List, and click the Special List tab.

Step 2 Add a special list level.

1. Click the Level Management tab.
2. Click New.
3. Set the following special list level parameters:

– Special List Type: The options are Black List and Red List.
– Level Name: The value can contain a maximum of 100 characters.
– Restriction mode: The options are Incoming Call, Outgoing Call, and

Incoming and outgoing calls.
– Restricted Duration (Hour): The value ranges from 0 to 8760, in hours.
– Status: The options are Available and Unavailable.
– Remark: The value can contain a maximum of 256 characters.

Step 3 Add a special list reminder.

1. Click the Special list reminder tab.
2. Click New.
3. Set the following special list reminder parameters:

– Special List Type: The options are Black List and Red List.
– Special list level: Select a special list level that is enabled on the Level

Management page.
– Reminder Message: The value can contain a maximum of 256

characters.
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Step 4 Add customer numbers to the special list.

You can add customer numbers one by one or import customer numbers in
batches as required.

● Add customer numbers one by one.

a. Click the Special List tab.
b. Click New.
c. Configure customer number information.

▪ Subscriber number
The value can contain a maximum of 100 characters.

○ The value can be a phone number.

○ The value can be an email address.
Example: 123@huawei.com

▪ Special List Type: The options are Black List and Red List.

▪ Special List Level: Select a special list level that is enabled on the
Level Management page.

▪ Effective Time: Time when a customer number takes effect in a
special list. The value must be later than the current time and earlier
than January 19, 2038.

▪ Expiration Time: Time when a customer number expires in the
special list. By default, this parameter is automatically set to the
value of Effective Time plus the duration specified by Restricted
Duration (Hour) on the Level Management page. You can
manually change the value. The value must be later than the current
time and earlier than January 19, 2038.

▪ Reason for Joining: Reason for adding a customer number to the
blocklist. The value can contain a maximum of 1024 characters.

d. Click Save to save the customer number.
● Import customer numbers in batches.

a. Click the Special List tab.

b. Click .
c. Select a special list to be imported.

The options are Black List and Red List.
d. Click Special List Import Template.

i. Open the downloaded template and configure the customer
numbers to be imported by referring to Figure 2-753.

Figure 2-753 Adding data
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○ Subscriber number
The value can contain a maximum of 100 characters.
○ The value can be a phone number.
○ The value can be an email address.

Example: 123@huawei.com
○ Level: Select a special list level that is enabled on the Level

Management page.
○ Effective Time: Time when a customer number takes effect in

the special list. The value must be later than the current time
and earlier than January 19, 2038.

○ Expiration Time: Time when a customer number expires in the
special list. The value must be later than the current time and
earlier than January 19, 2038.

○ Reason for Joining: Reason for adding a customer number to
the blocklist. The value can contain a maximum of 1024
characters.

ii. Save the configured template as an .xlsx file.

e. Click  and select the configured .xlsx file.
f. Click OK to upload the customer numbers.

If the customer to be imported already exists in the selected special list,
the import fails. In this case, you need to manually add the customer to
the special list on the page.

Step 5 View the new customer numbers on the Special List tab page.

NO TE

After customer numbers are added, they can be used by the Information query diagram
element in the IVR flow configuration.
Special list rules are applicable only to common IVR flows, intelligent IVR flows, and email,
SMS, and multimedia channels.
After the offline message function is enabled for the SMS and email channels, messages
that fail to be sent will be resent 5 minutes later. Therefore, after the blocklist expiration
time is reached, SMS messages and emails sent within 5 minutes before the expiration time
will be received.

----End

Follow-up Procedure
A tenant administrator can perform the following operations on customer
numbers:

NO TE

The exported data contains personal data. Exercise caution when processing the exported
data to prevent personal data leakage and abuse.

● Special List tab page
Transfer To History: Select customer numbers, and delete them from Special
List temporarily and move them to Special List History.
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Delete: Select customer numbers and delete the data.
Modify: Select customer numbers and modify Effective Time, Expiration
Time and Reason for Joining for them.
Export: Select customer numbers and export the data. If no customer number
is selected, all records that meet the search criteria are exported. A maximum
of 10,000 records can be exported at a time. If the number of records that
meet the search criteria exceeds 10,000, the export fails. In this case, you need
to set search criteria and export records again.

● Special List History tab page
Restores: Select customer numbers and add them to Special List again.
Delete: Select customer numbers and delete the data.
Export: Select customer numbers and export the data. If no customer number
is selected, all records that meet the search criteria are exported. A maximum
of 10,000 records can be exported at a time. If the number of records that
meet the search criteria exceeds 10,000, the export fails. In this case, you need
to set search criteria and export records again.

2.17.5 Configuring the Channel Special List
A tenant administrator can restrict specified or all channels by special list level.

Prerequisites
A special list level whose restriction mode is blocklist has been created based on
Step 2.

Procedure

Step 1 Choose Configuration Center > Resource Management > Channel Special List
and click Create.

Step 2 Set channel special list information.
● Special List Level: Select a special list level.

After Special List Level is set, Special List Type Name, Restriction Mode,
Restricted duration (hour), and Status are automatically filled in.

● Restricted Channel Type: Select Email or SMS.
● Application Mode: Select All of them or Designated Channel.
● Restricted Channels (mandatory when Application Mode is set to

Designated Channel): Select an existing channel.

NO TE

– Click Add. Multiple channels can be restricted.

– For the same special list level and channel type, the specified channel must be
unique.

– For the same special list level and channel type, if Application Mode is All of
them, no more channel special list records can be added.

Step 3 Click Save.

----End
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2.17.6 Managing a Certificate
A tenant administrator can import certificates for management purposes.

Prerequisites
You have obtained the certificate file and certificate information.

The obtaining methods include:

● CLI

Step 1 Run the following command on the Windows 10 or Linux host:
echo -n | openssl s_client -connect IP:PORT 2>&1 | sed -ne '/-BEGIN CERTIFICATE-/,/-END CERTIFICATE-/p' > 
yourcert.pem

For example, run the following command to generate a Huawei email server
certificate:

echo -n | openssl s_client -starttls smtp -connect smtp.huawei.com:587 2>&1| sed -ne '/-BEGIN 
CERTIFICATE-/,/-END CERTIFICATE-/p' > smtp.pem

Alternatively, run the following command:

echo -n | openssl s_client -connect popscn06.huawei.com:995 2>&1| sed -ne '/-BEGIN CERTIFICATE-/,/-END 
CERTIFICATE-/p' > pop.pem

NO TE

Certificate files in other formats (such as .jks, .cer, and .crt) can be converted.

----End

● Browser

Step 1 Enter the address in the browser address bar, click View site information in front
of the address to obtain the certificate file.

The following takes obtaining the Huawei email server certificate as an example:

1. Open a browser, enter https://dggpro-b.paas.huawei.com/cloudauth/?
redirect=https%3A%2F%2Fcn02%2Eemail%2Ehuawei%2Ecom%3A%2Fowa in
the address box, and log in to the mailbox using a domain account.

2. After login, click View site information in front of the address, and then click
Certificate (Valid).
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3. Click the Certification Path tab, select the root certificate, and click View
Certificate.
All branch sites of a website can use the root certificate in the certificate
chain for authentication. Therefore, the root certificate is recommended to
reduce the certificate maintenance workload.

4. In the dialog box that is displayed, click the Details tab, click Copy to File,
and click Next. (You can also click the Certificate Path tab to export the root
certificate or level-2 certificate. The export method is similar.)

5. Select a certificate format and click Next.
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6. Enter the name of the certificate file to be exported and click Next.

7. Click Finish to generate a certificate file. The file name is the complete path
of the certificate file.
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----End

Procedure

Step 1 Sign in to AICC as a tenant administrator and choose Configuration Center >
System Management > Certificate.

Step 2 Click New. The Adding a Certificate dialog box is displayed.
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Figure 2-754 Adding a Certificate

Table 2-194 Parameters for adding a certificate

Parame
ter

Description

Certific
ate
Name

Enter a customized certificate name.
The value can contain a maximum of 64 characters.

Certific
ate
Descript
ion

Enter a customized certificate description.
The value can contain a maximum of 256 characters.
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Parame
ter

Description

Certific
ate
Type

Select a certificate type that is supported by the system.
● JKS
● DER
● PKCS12
● PEM
NOTE

The encryption algorithm used by a certificate in PKCS12 format is insecure and
has security risks. You are advised to add a certificate in another format, such
as JKS.

Certific
ate
Passwor
d

Enter a certificate password.
The value can contain a maximum of 256 characters.

Certific
ate File

Select a local certificate file.

CRL File Select a local CRL file.

 

Step 3 Click Save. The certificate is uploaded successfully and takes effect 10 minutes
later.

----End

Follow-up Procedure
After the certificate is uploaded successfully, you can perform the following
operations:

● Click Edit in the Operation column to update the certificate.
● Click Discard in the Operation column to discard the certificate.
● Click Reuse in the Operation column to reuse a discarded certificate.

2.17.7 Configuring Email Special List Rules
A tenant administrator configures the email special list, which is the email address
blocklist, to block emails that do not need to be received. Agents cannot send
emails to blocklisted email addresses (including email addresses of recipients, Cc
recipients, and Bcc recipients).

Prerequisites
You have configured the email channel. For details, see 2.5.6 Configuring the
Email Channel.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Resource Management > Mailing Special List.

Step 2 Click Create. In the Creating a Special List Rule dialog box, set rule parameters.

Figure 2-755 Creating a Special List Rule

Table 2-195 Parameters for creating a special list rule

Parame
ter

Description

Rule
Name

Enter a customized rule name.
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Parame
ter

Description

Rule
Descript
ion

Enter a description, which is optional.

Enable Determine whether to enable the rule after the configuration is
complete.
This switch is turned on by default. Retain the default setting.

Channe
l
Selectio
n

Select the email channel to which the rule applies.
● Email channels configured for the tenant
● All channels (all email channels)

Validity
Period

Set the validity period of the rule.
● At least one of the start time and end time must be set.
● If the end time is not set, the validity period is from the start time

to the maximum expiration time, which is 2038-1-18 23:59:59.
● If the start time is not set, the validity period starts from the

current time.
● By default, the rule takes effect immediately, and the validity

period is set to the maximum value, which is from the current time
to 2038-01-18 23:59:59.

Add Add a blocklisted email address.

Email
Address

Enter a blocklisted email address.

Delete a blocklisted email address that has been added.

 

Step 3 Click Save to save the new email special list rule.

----End

2.17.8 Configuring SMS Special List Rules
A tenant administrator configures the SMS special list, that is, the mobile number
blocklist, to block SMS messages that do not need to be received. Agents cannot
send SMS messages to blocklisted mobile numbers.

Prerequisites
You have configured the SMS channel. For details, see 2.5.9 Configuring the SMS
Channel.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Resource Management > SMS Special List.
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Step 2 Click Create. In the Creating a Special List Rule dialog box, set rule parameters.

Figure 2-756 Creating a Special List Rule page

Table 2-196 Parameters for creating an SMS special list rule

Parame
ter

Description

Rule
Name

Enter a customized rule name.

Rule
Descript
ion

Enter a description, which is optional.
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Parame
ter

Description

Enable Determine whether to enable the rule after the configuration is
complete.
This switch is turned on by default. Retain the default setting.

Channe
l
Selectio
n

Select the SMS channel to which the rule applies.
● SMS channels configured for the tenant
● All channels (all SMS channels)

Validity
Period

Set the validity period of the rule.
● At least one of the start time and end time must be set.
● If the end time is not set, the validity period is from the start time

to the maximum expiration time, which is 2038-1-18 23:59:59.
● If the start time is not set, the validity period starts from the

current time.
● By default, the rule takes effect immediately, and the validity

period is set to the maximum value, which is from the current time
to 2038-01-18 23:59:59.

Add Add a blocklisted mobile number.

Mobile
Numbe
r

Enter a blocklisted mobile number.

Delete a blocklisted mobile number that has been added.

 

Step 3 Click Save to save the new SMS special list rule.

----End

2.17.9 Configuring Resource Dump Tasks
A tenant administrator creates resource dump tasks to transfer business resource
data to specified locations.

Prerequisites
● You have enabled the Resource Dump feature for the tenant.
● You have purchased Object Storage Service (OBS) at https://

www.huaweicloud.com/intl/en-us/product/obs.html.
● To use the function of querying dump resources online, you have enabled the

View dump resources online feature.
In addition, you have purchased Cloud Search Service (CSS) on Huawei Cloud
at https://www.huaweicloud.com/intl/en-us/product/css.html, obtained
the cloud search server certificate by referring to https://
support.huaweicloud.com/intl/en-us/css_faq/css_02_0106.html, and
uploaded the certificate to the system by referring to 2.17.6 Managing a
Certificate.
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● An application has been submitted to the system administrator and approved
to add the OBS address, OBS proxy address, CSS address, and CSS proxy
address to the address trustlist.

Context
● If information, such as the AK, SK, and proxy user password, is changed on

OBS, you need to modify the configuration in the AICC as follows: Choose
Configuration Center > System Management > Resource Dump and
update OBS information, such as the AK, SK, and proxy server password.

● If the user password of CSS or the CSS proxy server is changed, you need to
modify the configuration in the AICC as follows: Choose Configuration
Center > System Management > Resource Dump and update the user
password of CSS or the CSS proxy server.

● After a resource dump task or server is deleted, the corresponding dump
resources cannot be queried online. You can query the dump resources on the
purchased CSS.

Procedure

Step 1 Add a resource dump server.

1. Click the Resource Dump Server tab.
2. Click New in the upper right corner to add a resource dump server for storing

resource data, including voice files, report data, CDR data, contact records,
multimedia chat data, and AI inspection data.

NO TE

A maximum of 20 resource dump servers can be added for a tenant space.

3. Customize the server name and set Type to OBS server.
The server name must be unique.

4. Enter information about the purchased OBS, including the OBS address, data
bucket, AK, and SK.

5. (Optional) Configure the proxy. Enter the proxy server address, port,
username, and password.

NO TE

If the server can directly access the external network, you do not need to configure the
proxy.

6. Click OK.

Step 2 (Optional) Add a cloud search server.

1. Click the Cloud Search Server Configuration tab.
2. Click New in the upper right corner to add a cloud search server.

NO TE

Only one cloud search server can be added for a tenant space.

3. Customize the server name and set Type to CSS server.
The server name must be unique.
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4. Enter information about the purchased CSS, including the CSS address, CSS
port, cluster login username, and password.

5. (Optional) Configure the proxy. Enter the proxy server address, port,
username, and password.

NO TE

If the server can directly access the external network, you do not need to configure the
proxy.

6. Select the cloud search server certificate that has been uploaded.

NO TE

If certificate verification is disabled, peer identity spoofing risks occur. You are advised
to enable certificate verification.

7. Click OK.

Step 3 Click the Resource Dump Task tab to add a task for obtaining resource data.

NO TE

Only one voice file task, one report data task, one CDR data task, and one AI inspection
data task can be created for the same dump data type and dump duration.

Step 4 Add a task for obtaining voice files.

1. Customize the task name and set Dump Data Type to Voice file.
The task name must be unique.

2. Select a configured dump server and set the dump file path for storing voice
files generated by the business side, for example, /data/voicefile.

3. (Optional) Set Dump file retention period (month). The value is an integer
ranging from 1 to 60. If this parameter is left blank, data is stored
permanently.

4. (Optional) Click  to enable CSS.
The keys for storing voice files in OBS are written to CSS.

5. Click OK.

Step 5 Add a task for obtaining report data.

1. Customize the task name and set Dump Data Type to Report data.
The task name must be unique.

2. Select a configured dump server and set the dump file path for storing report
data generated by the business side, for example, /data/reportdata.

3. Set the dump duration.
– Day: Data of one day is uploaded for each task.
– Week: Data of one week from Monday to Sunday is uploaded for each

task.
– Month: Data of one month from the beginning to the end is uploaded

for each task.
4. (Optional) Set Dump file retention period (month). The value is an integer

ranging from 1 to 60. If this parameter is left blank, data is stored
permanently.
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5. Select one or more reports to be dumped. The options are as follows:
– VDN Performance Report
– VDN Performance Statistics Report by Access Code
– IVR Data Report
– IVR Data Statistics Report by Access Code
– Skill Queue Performance Report
– Skill Queue Performance Statistics Report by Access Code
– Agent Performance Summary Report
– Skill Queue Summary Report
– Agent Outbound Call Summary Report
– Agent Connection Operation Report
– Summary Report on Calls Abandoned During Ringing

6. Click OK.
7. Click Enable to enable the task.

Step 6 Add a task for obtaining CDR data.

1. Customize the task name and set Dump Data Type to CDR data.
The task name must be unique.

2. Select a configured dump server and set the dump file path for storing CDR
data generated by the business side, for example, /data/cdrdata.

3. (Optional) Set Dump file retention period (month). The value is an integer
ranging from 1 to 60. If this parameter is left blank, data is stored
permanently.

4. Click OK.
5. Click Enable to enable the task.

Step 7 Add a task for obtaining contact records. A maximum of 20 contact record tasks
can be added.

1. Customize the task name and set Dump Data Type to Contact record.
The task name must be unique.

2. Select a configured dump server and set the dump file path for storing
contact records generated by the business side, for example, /data/
contactrecord.

3. Set the dump duration.
– Day: Data of one day is uploaded for each task.
– Week: Data of one week from Monday to Sunday is uploaded for each

task.
– Month: Data of one month from the beginning to the end is uploaded

for each task.
4. Set the start day of the dump duration. When Dump Duration is set to Week

or Month, you need to set this parameter to delete contact records.
– When Dump Duration is set to Week, the value of Dump Duration

Start ranges from Monday to Sunday.
– When Dump Duration is set to Week, the value of Dump Duration

Start is a positive integer ranging from 1 to 28.
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5. (Optional) Set Dump file retention period (month). The value is an integer
ranging from 1 to 60. If this parameter is left blank, data is stored
permanently.

6. (Optional) Set filter criteria.
7. Set Export data field. The options are as follows:

– Fields in contact record list: All data fields are exported and the value
cannot be customized.

– Customized fields in contact record: All fields are exported by default
and the value can be customized.

8. Click OK.
9. Click Enable to enable the task.

Step 8 Add a task for obtaining multimedia chat data.

NO TE

For a single tenant, one channel can have only one dump task. If an omni-channel dump
task exists, other dump tasks for storing multimedia chat data are not allowed. Discarded
tasks are not counted.

1. Customize the task name and set Dump Data Type to Multimedia chat
data.
The task name must be unique.

2. Select a configured dump server and set the dump file path for storing
multimedia chat data generated by the business side. The dump file path
must start with a slash (/), for example, /data/multimedia.
After the dump file path is set, the system automatically displays the path for
storing dump files on OBS in /ccfs/Tenant space ID/Entered path format.

3. (Optional) Set Dump file retention period (month). The value is an integer
ranging from 1 to 60. If this parameter is left blank, data is stored
permanently.

4. (Optional) Click  to enable CSS.
The keys for storing chat record index files in OBS are written to CSS.

5. Set Chat Data Dump Duration (Day).
The value is an integer ranging from 2 to 180. The default value is 30.

NO TE

The current date is used as the date before which data is dumped. For example, if this
parameter is set to 3, data of the third day before is dumped, but data of the fourth
day before and earlier is not dumped.
In earlier versions, the value of Chat Data Dump Duration (Day) ranges from 1 to
180. When this parameter is set to 1, if a multimedia chat crosses days, the chat data
may be lost. In this case, you are advised to add a resource dump task again.

6. Select all channel types.
7. Click OK.

Step 9 Add a task for obtaining AI inspection data.

1. Customize the task name and set Dump Data Type to AI inspection data.
The task name must be unique.
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2. Select a configured dump server and set the dump file path for storing AI
inspection data generated by the business side. The dump file path must start
with a slash (/), for example, /data/inspectiondata.
After the dump file path is set, the system automatically displays the path for
storing dump files on OBS in /ccfs/Tenant space ID/Entered path format.

3. (Optional) Set Dump file retention period (month). The value is an integer
ranging from 1 to 60. If this parameter is left blank, data is stored
permanently.

4. Set AI Inspection Data Dump Duration (Day).
The value an integer ranging from 15 to 90. The default value is 60.

NO TE

The current date is used as the date before which data is dumped. For example, if this
parameter is set to 3, data of the third day before is dumped, but data of the fourth
day before and earlier is not dumped.

5. Click OK.

----End

Follow-up Procedure
● 5 minutes after a task is started, choose Configuration Center > System

Management > Resource Dump Task to view the task execution record.
– If a task fails to be executed, click Re-execute to execute the task again.

● After a task for which CSS is enabled is started, choose Customer Contact
History > Dump Resource to view dump resources online.

2.17.10 Managing Menus
The preset menus in the system can be searched. In addition, a tenant
administrator can create or delete customized menus.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
System Management > Menu Management.

Step 2 Click . The New Menu dialog box is displayed.
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Figure 2-757 New Menu

● Menu Name (mandatory): Enter a customized menu name. The value can
contain a maximum of 50 characters and cannot contain the following special
characters: !#$%&()+:"{},\/'[]=

● Permission Name (mandatory): Enter the name of the permission associated
with the current menu, which must be unique in the tenant space. The value
can contain a maximum of 50 characters and cannot contain the following
special characters: !#$%&()+:"{},\/'[]=

● AppCube-Integrated Page (mandatory): This parameter can be set when the
AppCube feature is enabled for the tenant space and a non-AICC application
is installed on AppCube.

● Select Application (mandatory if AppCube-Integrated Page is enabled):
Select the software installed on the Package Installation page under the
Admin menu on AppCube.

● Select Menu (mandatory if AppCube-Integrated Page is enabled): Select the
menu of the software installed on AppCube.

● Menu URL (mandatory): Enter the detailed URL of the customized menu. For
an external page, you need to contact the system administrator to add the
URL to the address trustlist.

Step 3 Click . The customized menu is created successfully.

Step 4 (Optional) Click Delete corresponding to the new customized menu to delete it.

----End
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2.17.11 Managing Email Signatures
After a tenant administrator adds an email signature, enables the email signature
switch, and selects the email signature during email channel configuration, the
configured email signature is carried when an agent replies to or forwards an
email. This section describes how to add an email signature.

NO TICE

Before deleting an email signature, ensure that the email signature is not used by
other businesses. Otherwise, the configured businesses will become invalid.
Determine the email signature application scenario based on the actual business
configuration. The involved scenario is as follows:
Channel configuration: 2.5.6 Configuring the Email Channel

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Workbench Configuration > Email Signature.

Step 2 Click New. The page for creating an email signature is displayed.

Step 3 Configure an email signature.

Figure 2-758 Create Email Signature

● Signature Name: This parameter is mandatory. The signature name must be
unique in the tenant space, and cannot contain eval, exec, or the following
special characters: <=>/\"

● Signature Content

– : Undo an operation.
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– : Redo an operation.

– : Select a font. The default value is Microsoft YaHei.

– : Select a font size. The default value is 16px.

– : Mark content in bold.

– : Mark content in italics.

– : Add an underscore (_).

– : Add a strikethrough.

– : Clear formatting.

– : Set the font color.

– : Set the background color.

– : Insert a table.

– : Insert an image.

– : Align content on the left.

– : Align content in the center.

– : Align content on the right.

– : Justify content.

– : Insert a variable. When a signature with a variable is
used, the variable in the signature is replaced with the actual user
information. The available variables are as follows:

▪ User Name: ${employee.name}

▪ User email address: ${employee.email}

▪ User Position: ${employee.title}

Step 4 After the configuration is complete, click Complete to create and save the email
signature.

Step 5 (Optional) Click Edit or Delete in the Operation column corresponding to an
email signature to edit or delete it.

(Optional) Select one or more email signatures and click Delete to delete them in
batches.

----End

2.17.12 Configuring Message Flow Control Rules
A tenant administrator can configure message flow control rules to control
WhatsApp and SMS messages.
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Prerequisites

The tenant has available WhatsApp and SMS channels.

Context

The system performs flow control on WhatsApp and SMS messages sent by users.
When the usage reaches a threshold, an alarm is triggered, and a system bulletin
is automatically sent to users.

Procedure

Step 1 Sign in to AICC as a tenant administrator and choose Configuration Center >
System Management > Message Flow Control.

Step 2 Click New to add a flow control rule.

A maximum of 20 flow control rules can be added by default. To add more rules,
contact O&M personnel.

Step 3 Set parameters based on Table 2-197.

Table 2-197 Parameter description

Parameter Description

Name Customized name. The value can contain a
maximum of 128 characters.

Description Customized description. The value can
contain a maximum of 256 characters.

Channel Type Channel type.
● WhatsApp
● SMS

FC Object Flow control object. The options are all the
following channels of the current tenant:
● WhatsApp channels
● SMS channels

Period Range Flow control period type.
● Daily
● Weekly
● Monthly
● Customization: Customize a time range.

Start time Start time. This parameter is mandatory when
Period Range is set to Weekly or Monthly.
● Weekly: 1–7
● Monthly: 1–31
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Parameter Description

Start Time Start time and end time. This parameter is
mandatory when Period Range is set to
Customization.
The maximum time span is 90 days.

End Time

Alarm Threshold (%) Customized alarm threshold.
The value ranges from 0 to 100. The default
value is 80.

Alarm Interval (min) Customized alarm interval. The value can
contain a maximum of 10 digits.

Prompt Message Customized prompt message. The value can
contain a maximum of 1024 characters.

Prompt Interval (min) Customized prompt interval.
● 1–30
● Digits

Max. Messages Customized maximum of messages.
● 1–1000000000
● Digits

 

Step 4 Click Save.

Step 5 Click  to enable the rule.

----End

2.17.13 Configuring UC Integration
A tenant administrator can configure authentication information for the AICC to
connect to Microsoft Teams and synchronize online experts of Microsoft Teams.
AICC agents can initiate call transfer, help seeking, and three-party calls to experts
of Microsoft Teams as required.

Prerequisites
● The AICC frontend has been connected to Microsoft Teams.
● The application is successfully registered with the Microsoft identity platform

according to https://docs.microsoft.com/en-us/graph/auth-register-app-v2.
The following information has been obtained:
– Directory (tenant) ID
– Application (client) ID
– Application (client) password
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Context
● Only Microsoft Teams can be connected.
● If the application (client) password is changed, you need to modify the

configuration in the AICC as follows: Choose Configuration Center >
Expansion and Integration > UC Integration and update the value of
Application (Client) Password.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Expansion and Integration > UC Integration.

Step 2 Click  to enable Microsoft Teams Integration.

Step 3 Set Directory (Tenant) ID, Application (Client) ID, and Application (Client)
Password.

Step 4 Click Save.

----End

2.17.14 Managing Emails
A tenant administrator can view and manage customer emails and forward emails
to specified employees on the Email page.

Prerequisites

You have configured an available email channel and received customer emails.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Contact History >
Email. All emails on the current day are displayed in the inbox by default.

NO TE

Click Download corresponding to an email and click Yes in the confirmation dialog box
that is displayed to download the attachment.

The downloaded data contains personal data. Exercise caution when processing the
downloaded data to prevent personal data leakage and abuse.

Step 2 Create an inbox catalog for employee A.

1. Hover the pointer over Inbox, click , and create a catalog named
Employee A.

2. Click Save.

Step 3 Move emails to the Employee A catalog.

1. Select the emails to be moved.
2. Click Batch Operation, choose Move, and select the Employee A catalog.
3. Click Confirm.
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Step 4 Assign an email to employee A.

1. Click the Employee A catalog in the inbox.
2. Select the check boxes of the emails to be assigned.
3. Click Assign. The configuration page is displayed.
4. Click the Agent tab and select employee A in a skill queue.

NO TE

If you select a skill queue on the Skill Queue tab page, the system randomly allocates
a call to an agent in the skill queue.

5. Click OK.
After the assignment is successful, employee A is the handler.

Step 5 View all email forwarding records of the tenant.

1. Click the Forwarding Record tab.
2. Click the email title to view the email details.

The value cannot be modified.

----End

2.17.15 Configuring External Numbers
A tenant administrator can configure external numbers so that agents can select
external numbers from the external number list during call transfer, consultation,
and three-party calls.

Prerequisites
(Optional) To display the calling number (number of the user talking with the
agent) on the external number side, the calling number anonymization feature
has been enabled for the tenant.

Context
● External numbers apply to the following scenarios:

– Call transfer (Calls can be transferred to external numbers only in
Success Transfer, Conversation Transfer, or Three-Party Transfer
mode.)

– Consultation or help-seeking
– Three-party calls

● A maximum of 10,000 external numbers can be added for a tenant.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Resource Management > External number.

Step 2 Click New. The configuration dialog box is displayed.
● Number: Enter an external number. The requirements are as follows:

– The value is 0 or a positive integer.
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– The value is a string of a maximum of 24 characters.

● Name: The value is a string of a maximum of 200 characters and must be
unique.

● User Number Forwarding

– : The number of the customer talking with the agent is displayed
on the external number side.

– : The default access code of the tenant is displayed on the external
number side.

● (Optional) Organization Unit: Select an OU created in 2.2.1 Configuring
OUs.

Step 3 Click Save. To add more external numbers, repeat the preceding steps.

----End

2.17.16 Querying Operation Logs
Operation logs are used for security audit of user operations. An administrator can
query operation logs to view operation records.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
System Management > Operation Log.

Figure 2-759 Operation Log

Step 2 Set data filter criteria.

● Select a time range to query operation logs. The time range can be 1 Day, 3
Days, 7 Days, or Customization.

● Click More, set Account, Operation Type, Object ID, and Object Name, and
click Search to filter detailed data. Table 2-198 describes the options of
Operation Type.
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● Click  to refresh real-time data.

Step 3 Click  to set the table header.

Figure 2-760 Column Configuration

● Click  or  to deselect a column.
● Drag a selected column to change its sequence.
● Click Reset to reset the column configuration to the state when the dialog

box is opened.

After the configuration is complete, click OK to save the new column
configuration. Data is displayed based on the new column configuration.

----End

Reference

Table 2-198 Operation types

Operation Type Definition

Activate Activate a user.

Active Activate.

actRolePerms Modify the function permissions of a role.

actRoleUsers Grant a role to users.

addContactInformation Add contact and manager information.

applyTokenBySysAdmin Provide token information as the system
administrator.

autoClearExpiredLoginLog Automatically clear expired sign-ins.
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Operation Type Definition

autoClearExpiredOperLog Automatically clear expired operations.

autoClearExpiredRoleAuthLog Automatically clear expired roles.

autoClearExpiredUserLog Automatically clear expired users.

Batchdelete Batch delete.

batchModifyEmployeeStatus Update tenant space users in batches.

Batch_delete Batch delete.

changeSelfPwd Chang your own password.

checkUserLock Check whether a user is locked.

Create Add a contact, send an internal message, or
create a deduplication rule.

createEmployee Create employee information.

createEmployeeContact Create an employee contact.

createOrg Create an OU.

createOrgContact Create an OU contact.

createPwdRuleGroup Create a password rule group.

createRentPerm Create a function permission.

createRole Create a role.

createTenantSpaceV3 Create a tenant space.

Create_Record Create a record.

Deactivate Deactivate.

Deactive Disable.

Delete Delete.

deleteContactInformation Delete contact information.

deleteEmployeeContact Delete an employee contact.

deleteEmployeeInformation Delete employee information.

deleteOrgByTenantSpaceIdAn-
dOrgId

Delete an OU based on the tenant space ID
and OU ID.

deletePermByAuthIds Delete a function permission.

deletePwdRuleGroup Delete a password rule group.

deleteRoleByRoleId Delete a role.
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Operation Type Definition

deleteUserSessionBySysAdmin Delete the user communication period as the
system administrator.

Delete_Record Delete a record.

deregisterMenusByMenus Register a menu.

kickOutUserByAccount Kick out a user based on the account.

lockUser Lock a user.

lockUsersList Lock users.

modifyEmployeeV2 Modify employee information.

Move Move.

orgRelationRole Associate a role or cancel a role association.

patchPwdRuleGroup Create or modify a password rule group.

patchPwdRuleGroupRule Create or modify a rule in a password rule
group.

patchRoleByRoleId Create or modify role information by role ID.

Publish Publish.

queryEmployeeContact Search for employee contacts.

queryOrgContact Associate a role or cancel a role association.

refreshToken Refresh a token.

registerMenu Register a menu.

resetUsersPwdV2 Reset user passwords in batches.

unlockUser Release a user.

unlockUsersList Release users.

Update Update a contact.

updateContactInformation Update contact information.

updateEmployeeContact Update an employee contact.

updateOrg Update an OU.

updateUserSessionBySysAd-
min

Update the user communication period as the
system administrator.

updateUsersOfOrgByTenant-
SpaceIdAndOrgId

Add or delete an employee.

Update_Record Update a record.
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2.17.17 Querying Sign-in Logs
Sign-in logs are used to trace agent operations, facilitating fault locating. Agent
sign-in records on a specified date can be queried.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
System Management > Sign-In Log.

Figure 2-761 Sign-In Log

Step 2 Set data filter criteria.
● Select a time range and enter a sign-in account to query sign-in logs. The

time range can be 1 Day, 3 Days, 7 Days, or Customization.
● Click More, enter an employee name, select an operation type, and click

Search to filter detailed data.

● Click  to refresh real-time data.

----End

2.18 Managing Business Fault Bypass
This section describes how to manage business fault bypass and how to handle
emergency faults to ensure normal businesses for operators.

2.18.1 Agent Bypass
In fault mode, the AICC page cannot be signed in. You need to use the
CCGatewayBar to access the AICC page. For details, see 2.18.3 CC-Gateway
Emergency Connection Bar.

2.18.2 Performing the IVR Bypass
This section describes IVR business bypass.
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Step 1 Sign in to the system as a tenant administrator and add a fault prompt tone.

1. Choose  > IVR Management > IVR Voice.

2. Upload a voice file and submit it for approval.
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Step 2 After a voice file is uploaded, contact the system administrator for approval. After
the file is approved, perform the following operations.

Step 3 Sign in to the system as a tenant administrator and set the fault prompt tone.

1. Choose  > Call Center Configuration > Basic Information.
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2. Enable Breakdown Voice and select the uploaded voice file.

----End

If a call is transferred to an agent in a flow, the system plays the fault prompt
tone and bypasses the call.
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2.18.3 CC-Gateway Emergency Connection Bar
If a fault occurs in the AICC connection bar, tenant administrators can refer to this
section to handle the fault bypass.

Procedure

Step 1 Log in to the CC-Gateway server and modify the configuration file.

The configuration file is stored in /home/elpis/tomcat/webapps/agentgateway/
WEB-INF/config/basic.properties. Change the value of
SUPPORT_AGENT_FAULT_MODE to ON in the configuration file and wait for 1
minute for the hot loading of the configuration item to take effect.

Step 2 Use the softphone number and password to log in to the OpenEye.
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Step 3 Log in to the CC-Gateway emergency connection bar.
● Open a browser, enter https://IP address:Port number/agentgateway/

resource/ccbar/index in the address box, and press Enter.
● The IP address is the IP address of the CC-Gateway service. The port number

is the HTTPS port number of the CC-Gateway service.

Step 4 Enter the agent ID, password, and softphone number, and click Log In.

Step 5 In the upper left corner of the emergency connection page, click  to update the
agent status.

An agent can choose one of the following states:
● If the agent needs to handle other businesses (for example, internal

discussion), the agent can choose Work to enter the working state.
● If the agent needs to handle other businesses (for example, providing

services), the agent can choose Busy to enter the busy state.
Table 2-199 describes the results of choosing Busy in different agent states.

Table 2-199 Results of choosing Busy

Agent State Result

Idle The Busy state is entered successfully. The agent enters
the Busy state.

Work The Busy state is applied for successfully.
The agent enters the Busy state after exiting the Work
state.

Calling The Busy state is applied for successfully.
The agent enters the Busy state after ending the call.

 
● If the agent finishes handling other businesses (for example, internal

discussion), the agent can choose Exit Work or Idle to continue to answer
calls from customers.

● If the agent needs to take a break (for example, to drink water), the agent
can choose Exit Work and does not answer calls from customers temporarily.
Table 2-200 describes the results of choosing Rest in different agent states.

Table 2-200 Results of choosing Rest

Agent State Result

Idle The Rest state is entered successfully. A dialog box is
displayed, showing the rest start time. The agent enters
the Rest state after clicking OK.

Work The Rest state is applied for successfully.
A dialog box is displayed, showing the rest start time.
The agent enters the Rest state after exiting the work
state.
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Agent State Result

Calling The Rest state is applied for successfully.
A dialog box is displayed, showing the rest start time.
The agent enters the Rest state after ending the call.

 

Step 6 In the upper left corner of the emergency connection page, click  to view
information about the current agent.

Step 7 When a call comes in, the softphone of the agent rings, and the call is
automatically connected. The agent can also click Answer before the call is
automatically connected.

Step 8 After a call is connected, the agent can perform the following operations:
● Hold or unhold a call.

To make another call (for consultation or discussion), click  to hold the
current call and stop voice transmission. The agent and customer cannot hear
each other, and the customer hears the call hold tone.

After the consultation or discussion ends, click  to unhold the call and
resume voice transmission.

● Mute or unmute a call.

Click  to mute the call so that the customer cannot hear the agent, but
the agent can hear the customer.

Click  to unmute the call so that the agent and customer can hear and
talk with each other.

● Transfer a call.

a. Click  to open the page for transferring a call.
b. Select a third party to which the current call needs to be transferred. The

third party can be a skill queue, an agent, or an IVR.
c. Click OK.

● Transfer out a call.

a. Click  to open the page for transferring a call.
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b. Select a third party to which the current call needs to be transferred, that
is, an external number, and select a transfer type.

c. Click OK. The agent can transfer the current call to a third-party expert.
● Initiate an internal help request.

a. Click  to open the page for making an internal help call.
b. Configure an internal help call.

▪ Help-seeking object: The agent can seek help from a skill queue or
an agent.

▪ Help-seeking type
○ Two-party help-seeking: The call with the customer is held, and

the current agent and requested agent are in a call. If the
requested agent releases the call, the current agent continues to
talk with the customer.

○ Three-party help-seeking: The customer, current agent, and
requested agent are in a call. If any party releases the call, the
call continues between the other two parties.
An agent can make an internal help call to a specified agent or
a skill queue. If a skill queue is requested, the system specifies
an agent.

c. Click OK. An agent can make an internal help call to another agent
during a call with a customer.

● Connect a held call.

During a voice call with a customer, click  to hold the call, call a third
party, and connect the held call to the third party.

● Make an internal call.

a. Click  to open the page for making an internal call.
b. Select an agent in idle state based on the agent ID.
c. Click OK. When agents (including inspectors) need to communicate with

each other, they can make internal calls to each other.
● Make a three-party call.

During a voice call with a customer, click  to call a third party (agent or
external expert) to join the call. In this way, a three-party call is set up and
the three parties can communicate with each other.
During a call with a customer, an agent holds the call, calls an external
phone, and clicks Third Party. In this way, the agent starts a three-party call
with the customer and external phone.

● Make an outbound call.

Click , enter an outbound number, and click . If an agent needs to
call back a customer or perform proactive marketing, the agent can specify a
customer number and manually make an outbound call.

● Set call-associated data.
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a. Click  to open the page for configuring call-associated data.
b. After call-associated data is configured, click OK. An agent can configure

call-associated data during a voice call.
● Query call information.

Click  to open the call information page. An agent can view the calling
number, called number, media type, and call-associated data of the current
call.

Step 9 After the current call ends, click  to release the call and enter the idle state.

Step 10 After finishing work, click  to sign out of the current agent account.

----End

2.19 Co-browsing

2.19.1 Creating Co-browsing Rules
A tenant administrator can configure rules. When a customer shares a page with
an agent during co-browsing, some sensitive information on the customer page is
shielded based on the configured co-browsing rules to protect customer
information.

Context
When creating co-browsing rules, you need to use the CSS selector syntax. You are
advised to familiarize yourself with the syntax in advance.

Prerequisites
The Co-browsing feature has been enabled for the tenant.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Expansion and Integration > Co-browsing.

Step 2 Click New.

Step 3 Set Rule name.

The value must:
● Contain only letters, digits, and underscores (_).
● Contain a maximum of 128 characters.

Step 4 Set Page Match Type as required.
● Generic Matching: The rule takes effect for all pages that are browsed

collaboratively under the tenant.
For example, all password text boxes and the Submit button are shielded.
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● Match by URL path: The pattern of the URL accessed by the browser can be
configured. The rule is the same as that of AntPathMatcher of Spring.
?: matches a single character.
*: matches zero or more characters.
**: matches zero or more paths (multi-level paths separated by slashes).
Example: https://localhost:63343/**

● Match by page ID: Generic Matching and Match by URL path cannot
exactly match a page. In this case, Match by page ID can be used.
The page ID matching mode requires customized development of the page
URL. The cobrowse_page_id parameter is passed in the page URL for exact
matching.

Step 5 (Optional) Set Page Match Config. This step is required when Page Match Type
is set to Match by URL path or Match by page ID.

The value can contain a maximum of 1024 characters.

Step 6 Set Page Element Selector. The selected page elements are shielded during co-
browsing.

The value must:
● Be in a format that meets the syntax requirements of the CSS selector.
● Contain a maximum of 1024 characters.

Example: #input

Step 7 Click Save.

----End

Follow-up Procedure

You can perform the following operations on the new rule:

● Edit
● Delete

2.19.2 Viewing Co-browsing Session Records
An agent can view operation records related to co-browsing, including the room
number, agent number, calling party information, start time, and end time.

Prerequisites
1. The co-browsing feature has been enabled for the tenant.
2. The agent has the permission on the Co-browsing menu.

Context

After the first subscriber joins a room, a record is generated, in which the start
time is updated. After the room is released, the end time is updated.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Contact History > Co-
browsing to view co-browsing session records.

----End

2.20 Social Media Operations
Connect to social media (publishing Facebook posts, X (Twitter) tweets, and
YouTube videos) for social media operations.

2.20.1 Operating Enterprise Accounts

2.20.1.1 Creating a YouTube Channel

Prerequisites
The connection to YouTube has been completed. If the connection has not been
completed, perform the following steps to complete the connection:

1. Apply for a developer account.

a. Access Google Cloud, register a Google account, and sign in.
b. Click Select a project, click NEW PROJECT, and create a project.

Figure 2-762 Select a project
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Figure 2-763 New Project

2. Enable YouTube.

a. In the navigation pane of Google Cloud, choose APIs & Services >
Enabled APIs & services.

Figure 2-764 Enabled APIs & services

b. Click ENABLE APIS AND SERVICES.
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Figure 2-765 ENABLE APIS AND SERVICES

c. Search for YouTube.

Figure 2-766 Searching for YouTube

d. Find and enable YouTube Data API v3.
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Figure 2-767 Enabling the API

If the following page is displayed, the API is enabled successfully.
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Figure 2-768 API enabled successfully

3. Create a credential.

a. In the navigation pane of Google Cloud, choose Credentials, and click
CREATE CREDENTIALS.

Figure 2-769 Creating a credential
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b. Create a key.

Figure 2-770 Creating a key

The value corresponds to the API key in the AICC.

4. Create an OAuth consent screen.

a. In the navigation pane of Google Cloud, choose OAuth consent screen.

b. Select External and click CREATE.

Figure 2-771 Creating an OAuth consent screen

Set all mandatory parameters and retain the default values for other
parameters until the 3 Test users page is displayed.

c. Click ADD USERS and add a test user.
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Figure 2-772 Adding a test user

d. Click SAVE AND CONTINUE to complete the configuration.
e. In the navigation pane of Google Cloud, choose Credentials, click

CREATE CREDENTIALS, and choose OAuth client ID.

Figure 2-773 Choosing OAuth client ID
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Figure 2-774 Creating an OAuth client ID

Add the redirection URI https://developers.google.com/
oauthplayground. Note that the URI cannot end with a slash (/).
After you click CREATE, obtain the values of OAuth Client ID and OAuth
Client secret that are generated automatically. The values correspond to
the values of Client ID and appKey in the AICC, respectively.

5. Access Google Developers, select all APIs under the YouTube Data API v3,
and enter the obtained OAuth client ID and secret to generate an API.
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Figure 2-775 Generating an API

Figure 2-776 Obtaining the generated access token and refresh token

6. Use the developer account to sign in to Google. Select Select all to assign all
permissions to the developer account.
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7. Create a channel on YouTube.
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Figure 2-777 Creating a channel

Go to the YouTube home page and choose Your channel. The last segment of
the URL is the channel ID, which corresponds to the channel ID in the AICC.

Context
None

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose  >
Account Post.

Step 2 Click Configure Channel and then click New.

Step 3 In the Create Channel dialog box, set parameters based on Table 2-201.

Table 2-201 Parameters for creating a channel

Parameter Description

Channel Name Enter a customized value.

Channel Configuration Select YouTube.

Channel ID ID of the channel created in Figure 2-777.

apiKey Key created in Figure 2-770.

Client ID Client ID generated in Figure 2-774.

appKey Client key generated in Figure 2-774.

accessToken Access token and refresh token generated in
Figure 2-776.

refreshToken

ApiFabricAK Contact the system administrator to obtain
the app key of the app that has subscribed to
the refreshNorth API and bound to the tenant
space for which the YouTube channel needs
to be configured on the Configuration
Center > Expansion and Integration > API
Management > APP Service > APP
Management page, and enter the app key
here.
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Parameter Description

ApiFabricSK Contact the system administrator to obtain
the app secret of the app that has subscribed
to the refreshNorth API and bound to the
tenant space for which the YouTube channel
needs to be configured on the Configuration
Center > Expansion and Integration > API
Management > APP Service > APP
Management page, and enter the app secret
here.

 

Step 4 Click Save.

----End

2.20.1.2 Creating a Facebook Channel

Prerequisites

The connection to Facebook has been completed. If the connection has not been
completed, perform the following steps to complete the connection:

1. Visit https://developers.facebook.com/apps and use a Meta for Developers
account to log in.
If no Meta for Developers account is available, create one.

2. Create an app.

a. Click Other, select the Business type, customize the app name, and
retain other default settings.

b. Click Set up corresponding to the Messenger product to add it to the
app.

3. Create a public home page.
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4. Bind the new public home page.

5. Refresh the application page to obtain the bound home page ID and
password.

– The number in the red box is the ID of the public home page, which
corresponds to the value of Channel ID in the AICC.

– The tokens correspond to the values of accessToken and refreshToken in
the AICC.

6. Obtain the ID and secret of the created app.

– The value of App ID corresponds to the value of Client ID in the AICC.
– The value of App secret corresponds to the value of appKey in the AICC.

7. Set access permissions.

a. Access https://developers.facebook.com/tools/explorer/.
b. Set the parameter on the top of the page to me?fields=id,name.
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c. Set Meta App to the app created in 2.
d. Add the following permissions under Permission:

▪ pages_show_list

▪ pages_messaging

▪ pages_read_engagement

▪ pages_manage_metadata

▪ pages_read_user_content

▪ pages_manage_posts

▪ pages_manage_engagement

e. Set User or Page.

i. Click  and choose Get Page Access Token. The public home page
is displayed.

ii. Click Continue as XXX, and select the public home page created in 3.
iii. Click Continue.
iv. Click Save.

v. Click  again and select the new public home page.
f. Click Submit. The permissions are added successfully.

8. Set the validity period of the access token to three months.

a. Access https://developers.facebook.com/tools/debug/accesstoken.
b. Enter the access token obtained in 4 and click Debug.

If the debugging is successful, the following information is displayed:

▪ The value of Type is Page, not User.

▪ The value of Expires is Never.

▪ The value of Data Access Expires is about three months later.

▪ The permissions under Granular Scopes contain at least the
permissions added in 6.
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Context

None

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose  >
Account Post.

Step 2 Click Configure Channel and then click New.

Step 3 In the Create Channel dialog box, set parameters based on Table 2-201.

Table 2-202 Parameters for creating a channel

Parameter Description

Channel Name Enter a customized value.

Channel Configuration Select Facebook.

Channel ID Public home page ID obtained in 5.

Client ID App ID generated in 6.

appKey App key generated in 6.

accessToken Tokens generated in 5.

refreshToken
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Parameter Description

ApiFabricAK Contact the system administrator to obtain
the app secret of the app that has subscribed
to the facebookNorth, facebookRefresh-
Noth, and facebookReplyNorth APIs and
bound to the tenant space for which the
Facebook channel needs to be configured on
the Configuration Center > Expansion and
Integration > API Management > APP
Service > APP Management page, and enter
the app ID here.

ApiFabricSK Contact the system administrator to obtain
the app secret of the app that has subscribed
to the facebookNorth, facebookRefresh-
Noth, and facebookReplyNorth APIs and
bound to the tenant space for which the
Facebook channel needs to be configured on
the Configuration Center > Expansion and
Integration > API Management > APP
Service > APP Management page, and enter
the app secret here.

Operation personnel Assign employees of the tenant to maintain
the publish channel.
A maximum of 10 operations personnel can
be assigned to a channel.

 

Step 4 Click Save.

----End

2.20.1.3 Publishing a YouTube Post

Prerequisites

A YouTube channel has been created. For details, see 2.20.1.1 Creating a YouTube
Channel.

Context
● By default, approval is not required for publishing a YouTube post or deleting

a published YouTube post. If the tenant parameter Social Media Approver
Account is set, posts can be published or deleted only after being approved
by the approver.

● When you publish a YouTube post, the maximum size of a video that can be
uploaded is specified by the tenant parameter Social Media Video Upload
Size Limit. The parameter unit is MB. The default value is 200, and the
maximum value is 500.

● Only videos can be uploaded through the YouTube channel.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose  >
Account Post.

Step 2 Click Post.

Step 3 Configure basic information based on Table 2-203.

Table 2-203 Parameters for configuring basic information

Parameter Description

Theme Enter a customized value. The value can
contain a maximum of 100 characters.

Contents Enter a customized value. The value can
contain a maximum of 5000 characters.

Image Currently, this function is not supported.

(Mandatory) Video Upload a local video. The video size cannot
exceed the value of the tenant parameter
Social Media Video Upload Size Limit.
The video must be in MP4 format.

Release Channel Select YouTube.

Channel Information - YouTube

(Mandatory) Audience Set these parameters as required.

(Optional) Label

(Mandatory) License

(Mandatory) Category

(Mandatory) Public Scope

 

Step 4 Click Next.

Step 5 Configure publishment information based on Table 2-204.

Table 2-204 Parameters for configuring publishment information

Parameter Description

Release a channel/Page Select the YouTube channel created in
2.20.1.1 Creating a YouTube Channel.

Publication Type The options are as follows:
● Real-Time Release
● Scheduled Release
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Parameter Description

Estimated Release Time This parameter is mandatory when
Publication Type is set to Scheduled
Release.
Set a future time.

Approver An approver is automatically displayed. This
parameter is displayed only when the tenant
parameter Social Media Approver Account is
set.

Remarks Enter remarks. The value can contain a
maximum of 500 characters.

 

To publish the post through multiple channels, click Create to add multiple
channels.

Step 6 Click Submit.

After you click Submit, the post is automatically published by default. If the
tenant parameter Social Media Approver Account is set, the post can be
published only after the approver approves the post.

----End

Follow-up Procedure

After a YouTube video post is published, choose  and click the
Enterprise Account Message Processing tab to view the post publishment
details. For details, see 2.20.3 Handling Enterprise Account Messages.

2.20.1.4 Publishing a Facebook Post

Prerequisites
A Facebook channel has been created. For details, see 2.20.1.2 Creating a
Facebook Channel.

Context
● By default, approval is not required for publishing a Facebook post or deleting

a published Facebook post. If the tenant parameter Social Media Approver
Account is set, posts can be published or deleted only after being approved
by the approver.

● When you publish a Facebook post, the maximum size of a video that can be
uploaded is specified by the tenant parameter Social Media Video Upload
Size Limit. The parameter unit is MB. The default value is 200, and the
maximum value is 500.

● When you publish a Facebook post, the maximum size of an image that can
be uploaded is specified by the tenant parameter Maximum size of uploaded
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social media images. The parameter unit is MB. The default value is 1, and
the maximum value is 4.

● The validity duration of the URL used by a customer to access a resource is
controlled by the tenant parameter Validity duration of the URL used by a
customer to access a resource. The value is in minutes and ranges from 5 to
10080 (at most seven days). The default value is 1440 (equals one day).

● Blank posts cannot be published through the Facebook channel. You need to
set at least one of Contents, Image, and Video.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose  >
Account Post.

Step 2 Click Post.

Step 3 Configure basic information based on Table 2-203.

Table 2-205 Parameters for configuring basic information

Parameter Description

Theme Enter a customized value. The value can
contain a maximum of 100 characters.

Contents Enter a customized value. The value can
contain a maximum of 5000 characters.

Image Upload a local image. A maximum of nine
images can be uploaded. The size of an
image cannot exceed the value of the tenant
parameter Maximum size of uploaded
social media images.
The image must be in either of the following
formats:
● PNG
● JPG
● GIF
● BMP
● TIFF

Video Upload a local video. Only one video can be
uploaded. The video size cannot exceed the
value of the tenant parameter Social Media
Video Upload Size Limit.
The video must be in MP4 format.

Release Channel Select Facebook.

Channel Information - Facebook
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Parameter Description

Allow embedding The check box is selected by default. Select or
deselect the check box based on site
requirements.

 

Step 4 Click Next.

Step 5 Configure publishment information based on Table 2-204.

Table 2-206 Parameters for configuring publishment information

Parameter Description

Release a channel/Page Select the Facebook channel created in
2.20.1.2 Creating a Facebook Channel.

Publication Type The options are as follows:
● Real-Time Release
● Scheduled Release

Estimated Release Time This parameter is mandatory when
Publication Type is set to Scheduled
Release.
Set a future time.

Approver An approver is automatically displayed. This
parameter is displayed only when the tenant
parameter Social Media Approver Account is
set.

Remarks Enter remarks. The value can contain a
maximum of 500 characters.

 

To publish the post through multiple channels, click Create to add multiple
channels.

Step 6 Click Submit.

After you click Submit, the post is automatically published by default. If the
tenant parameter Social Media Approver Account is set, the post can be
published only after the approver approves the post.

----End

2.20.1.5 Approving a Post

Prerequisites
● The tenant parameter Social Media Approver Account has been set.
● The approver account has the Enterprise account operation menu

permission.
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Context
None

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose  >
Account Post.

Step 2 Click the to be approved tab and click Approval in the Operation column
corresponding to a post in the to be approved state.

Step 3 After reading the post, click Passed or Reject.

----End

Follow-up Procedure

Choose  > Account Post and click the Approval History tab
to view the approval history.

2.20.2 Handling Multimedia Messages
When a publish channel managed by an operator is mentioned (@) by others,
operations personnel can receive notifications and make responses.

Prerequisites
1. A poster has mentioned the public home page, and the publish channel has

been assigned to operations personnel.
2. The operations personnel must be employees of the current tenant and have

the Social Media Operations and Offline Message Processing menu
permissions.

Context
● Currently, only Facebook messages can be handled.
● A message is considered handled when it is opened. On the page, an operator

can only click the link of a post to go to the post. After the list is refreshed,
the handled message is no longer displayed.

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose , and click
the Multimedia message processing tab.

Posts that mention the operations personnel are displayed in the list. All posters
are displayed as Anonymous User.

Step 2 In the list, click a post to view the post content.
● Click Visit the original text to go to the social media platform and read the

original text.
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● The  function is not supported currently.

● Click  to end the message.

----End

2.20.3 Handling Enterprise Account Messages
Operations personnel can maintain published posts, including viewing the number
of likes and comments on a post and replying to comments.

Prerequisites
● The tenant administrator has published YouTube videos and Facebook posts

on the  > Account Post page.
● The operations personnel must be employees of the current tenant and have

the Social Media Operations and Enterprise account operation menu
permissions.

Context

Data on the page is automatically refreshed every 30 minutes. Posts that are just
published can be displayed in the list only after being manually queried.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose  >
Enterprise Account Message Processing.

Step 2 In the list, click a published post to view the post details.

Manage posts by referring to Table 2-207.

Table 2-207 Post operation buttons

Button Description

Batch Reply Click this button to reply to posts of a poster
in batches. Click it again to cancel the batch
reply.

Comment on Comment on a post.

All Reply This button is displayed when the total
number of comments under a commenter is
greater than 1. Click this button to display all
comments. Click it again to hide the
comments.

Reply Reply to a single post.
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NO TE

● Video posts can be played.

● Currently, only texts and emojis are supported.

----End

2.21 Performance Management

2.21.1 Performance Configuration

2.21.1.1 Performance Algorithm

Before creating a performance plan, the tenant administrator need to configure
the corresponding performance algorithm.

Prerequisites
● The performance management feature has been enabled for the tenant

space.

a. Sign in to the AICC as the system administrator.
b. Choose Call Center > Tenant Management.
c. Click Edit in the row containing the current tenant.
d. Click the Virtual Call Center tab. In the Feature Selection area, enable

the Performance Management feature.

Figure 2-778 Enabling the performance management feature

The performance management feature depends on the AppCube feature.
Before enabling the performance management feature, enable the
AppCube feature.

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Performance management > Performance configuration, and choose
Performance Algorithm.

Figure 2-779 Performance algorithm page
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Step 2 Click Create and create a performance algorithm.

Figure 2-780 Creating a performance algorithm

1. Algorithm Name: Customize a value with a maximum of 100 characters.
2. Algorithmic Equation: Insert variables to create an algorithm equation. The

algorithm equation supports the following symbols: +–%*/[](). Example:
[Satisfaction score]*0.2+[Working hour fulfillment rate]*0.2+[Call success
rate]*0.2+[Call completion rate]*0.2 Variables that can be inserted into the
algorithm equation are as follows:
– Satisfaction score
– Manual inspection score
– Intelligent quality inspection score
– Working hours
– Average Processing Duration
– Total number of calls
– Number of calls for which the call reason is recorded
– Intelligent Training Score

3. Decimal Place: Enter the number of decimal places to be retained in the final
performance score. The default value is 1.
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4. Equation Check: Set a simulated test based on the algorithm equation. Click
Start verification. The calculation is performed based on the selected
indicators.

Step 3 After all the preceding information is configured, click Save.

Step 4 In the Operation column, click Edit, Delete, or Reference List for the current
performance algorithm as required. If a performance algorithm is referenced by a
performance plan, the performance algorithm cannot be deleted but can be
modified.

----End

2.21.1.2 Performance Plan

The tenant administrator can configure a performance plan for performance
management and employee training guide.

Prerequisites
● The performance management feature has been enabled for the tenant

space.

a. Sign in to the AICC as the system administrator.
b. Choose Call Center > Tenant Management.
c. Click Edit in the row containing the current tenant.
d. Click the Virtual Call Center tab. In the Feature Selection area, enable

the Performance Management feature.

Figure 2-781 Enabling the performance management feature

The performance management feature depends on the AppCube feature.
Before enabling the performance management feature, enable the
AppCube feature.

● The performance algorithm has been configured.

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Configuration Center >
Performance management > Performance configuration, and choose
Performance Plan.

Figure 2-782 Performance plan page
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Step 2 Click Create and create a performance plan. Configure Program Information first.

Figure 2-783 Creating a performance plan - Program Information page

1. Performance PlanName: Customize a value with a maximum of 100
characters.

2. Assessment Cycle Type: Select an appraisal period type.
– Monthly
– Quarter
– Semiannual
– Year
– Customize: If you select Customize, the time span cannot exceed 366

days but can cross years.
3. Assessment Cycle: Select an appraisal period based on the appraisal period

type.
4. Assessment Data Period: Set a specific appraisal time period.
5. Performance Algorithm: Select an existing performance algorithm. If no

algorithm is available, click  to create an algorithm for the current
performance plan.

Step 3 Click Next step, select applicable members for the performance plan.
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Figure 2-784 Creating a performance plan - Applicable Members page

Step 4 After all the preceding information is configured, click Confirm.

Step 5 In the Operation column, click Edit or Delete for the current performance plan as
required. A performance period that has been carried forward (that is, the
appraisal is completed) cannot be edited.

----End

2.21.2 Performance Scoring
Performance score details of the current agent can be viewed or deleted based on
the specified performance plan.

Prerequisites
● The performance management feature has been enabled for the tenant

space.
a. Sign in to the AICC as the system administrator.
b. Choose Call Center > Tenant Management.
c. Click Edit in the row containing the current tenant.
d. Click the Virtual Call Center tab. In the Feature Selection area, enable

the Performance Management feature.

Figure 2-785 Enabling the performance management feature
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The performance management feature depends on the AppCube feature.
Before enabling the performance management feature, enable the
AppCube feature.

● The performance algorithm and performance plan have been configured.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Performance >
Performance Scoring.

Figure 2-786 Performance Scoring page

Step 2 Click  and enter a performance plan name to view the
corresponding performance score.

This field is mandatory. If no performance plan is selected, no content is displayed
in the list by default. After a performance plan is selected, the system dynamically
determines the involved performance indicators based on the performance
algorithm corresponding to the plan and displays the indicators in the list.

Step 3 Check the queried performance indicators based on the following table.

Table 2-208 Performance indicators

Indicator Description

Performance Plan Status Performance plan status. The value can be Under
appraisal or Completed.

Satisfaction Score Average satisfaction score calculated based on the
appraisal period.

Manual Inspection Score Average score of manual inspection calculated
based on the appraisal period.

Intelligent Quality
Inspection Score

Average score of intelligent inspection calculated
based on the appraisal period.

Working Hours Sum of working duration based on the appraisal
period, in seconds.

Average Processing
Duration

Average processing duration calculated based on
the appraisal period, in seconds.

Total Number Of Calls Total number of calls calculated based on the
appraisal period.
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Indicator Description

Number of calls for which
the call reason is recorded

Number of calls for which the call reason is
recorded based on the appraisal period.

Intelligent Training Score Average intelligent training score calculated based
on the appraisal period.

Performance Score Performance score calculated based on the
performance algorithm.

Performance Score
Update Time

Time when a performance score is updated.

 

Step 4 In the Operation column, click View or Delete for the current performance score
as required.

----End
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3 Agent Guide(AICC)

This document provides guidance for agents to perform operations so that agents
can use the AICC business platform.

3.1 Introducing Agent Workbenches
The AICC provides a workbench page where basic agent operations are integrated
so that agents can perform operations without switching the menus. Workbenches
are classified into the audio and video workbench and online chat workbench.

3.2 Switching the Agent Status
An agent can switch the agent status using the connection bar on the top of the
page for the system to better assign businesses.

3.3 Allowing Browser Pop-up Notifications

3.4 Handling Voice Businesses
This section describes how to handle voice businesses as an agent.

3.5 Handling Video Businesses
This section describes how to handle video businesses as an agent.

3.6 Handling Multimedia Chat Businesses
This section describes how to handle multimedia businesses as an agent.

3.7 Performing Other Agent Operations
This section describes other operations performed by an agent.

3.8 Managing Inspection Results
This section describes inspection management. An agent can manage inspection
results.

3.9 Typical Scenarios
This section describes some typical scenarios of operations performed by an agent.

3.10 Viewing Training Tasks
Intelligent training tasks can be used to periodically train and test agents through
IVR flows to check the business skills of the agents.

3.11 Intelligent Outbound Call Tasks
Based on the assigned outbound call tasks, agents make outbound calls and
configure outbound call results.

3.12 OpenEye Help Document
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3.13 Implementing Intelligent Case Filling

3.1 Introducing Agent Workbenches
The AICC provides a workbench page where basic agent operations are integrated
so that agents can perform operations without switching the menus. Workbenches
are classified into the audio and video workbench and online chat workbench.

3.1.1 Voice and Video Workbench
An agent uses the voice and video workbench to handle customer businesses
through inbound and outbound voice calls.

An agent can open the voice and video workbench in either of the following ways:

● Choose Call.
● After an agent signs in, the voice and video workbench is automatically

opened. Alternatively, you can make an inbound or outbound call through the
connection bar. After the call is connected, the voice and video workbench is
automatically opened.

3.1.1 Voice and Video Workbench shows the voice and video workbench GUI.

Figure 3-1 Voice and video workbench

Table 3-1 describes the GUI.
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Table 3-1 Voice and video workbench

Content Description

Help an agent handle businesses during
a call.
This button is displayed only when the
Agent Business Process Visualization
feature is enabled and the Service
Guidance menu permission is assigned
to an agent.
For details about how to configure a
visualized service guidance flow, see
2.3.3.14 Configuring Service
Guidance.

Create cases in one-click mode. For
details, see 3.7.20 Creating a Case by
One Click.

Perform intelligent case filling and
create a SmartCare in-depth
demarcation task. For details, see
3.7.19 Intelligent Case Filling and
3.7.18 SmartCare Fault Demarcation.

Create a harassment record for a
customer during a two-party call with
the customer.
For details about how to create a
harassment record, see 3.7.14 Creating
Harassment Records.

Identify and display the call reason of a
customer. You can add call remarks as
required. A remark can contain a
maximum of 300 characters. For
details, see 3.7.5 Setting Call Reasons.
For details about how to configure a
call reason, see 2.3.2.1 Configuring
Call Reasons.
After the Automatic Conversation
Summary feature has been enabled for

the tenant and an agent, the  icon
is displayed when the agent configures
the call reason on the workbench.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1208



Content Description

Third-party page provided by the
customer

Display the multimedia inbound call
screen pop-up that has been enabled in
the system. Configure the tab page
name based on site requirements.
For details about how to configure a
screen pop-up, see 2.3.2.6 Configuring
Screen Pop-ups.

Send an email notification to a
customer during a call with the
customer.
For details about how to send a
notification, see 3.7.8 Sending
Notifications.

Send a WhatsApp notification to a
customer during a call with the
customer.
For details about how to send a
notification, see 3.7.8 Sending
Notifications.

Send an SMS notification to a customer
during a call with the customer.
For details about how to send a
notification, see 3.7.8 Sending
Notifications.

Authenticate the customer identity
during a call with a customer.
For details about how to perform
identity authentication, see 3.7.11
Performing Identity Authentication.

This button is displayed only when the
Customer Center feature is disabled.
When the call between an agent and a
customer is abnormally disconnected,
the agent can proactively initiate a
callback by clicking Callback to
improve customer experience.
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Content Description

Call Message This area is displayed only when the
Customer Center feature is disabled.
Display session information, including
the calling and called numbers of an
inbound call, handled number, skill
queue, and smart voice recording
information.

Click  to set a handled number of up
to 24 characters to identify the service
object.
If no handled number is set, the
handled number is the same as the
customer number.
Click the link next to Business Request
to view the visualized flow.

Customer Information This area is displayed only when the
Customer Center feature is disabled.
Display information about the
customer who makes the inbound call.
Configure the style of each field in this
area to display different field values in
different styles.

To view the Agent Assistant tab on the
voice and video workbench, you need
to enable the intelligent recognition
function.
Display script recommendations, FAQ
recommendations, and forbidden word
prompts for agents.

Real-time transcription.
Display the converted conversations
between customers and agents in real
time in text format. When Only
Customer is selected, only converted
speeches of the customer are displayed.
After the large model engine feature is
enabled, the system can display
customers' emotions and intents to
agents based on large models.
To view the Real-time transfer tab
page, you need to enable the
intelligent recognition function. For
details, see "Manual Service FAQs >
How Do I Enable Real-Time ASR?" in
AICC Operation Guide - FAQs.
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Content Description

History contacts This area is displayed only when the
Customer Center feature is disabled.
Display the latest three contact records.
Contact records can only be displayed
by time.

● Click  to go to the
Contact Details page. On the
Message Sending Record tab page,
click Send to send a multimedia
message (SMS message, email, or
WhatsApp message) to a customer.
NOTE

The agent is in a conversation with the
handled number.

● Click More to go to the History
contacts page, showing the contact
records generated for the current
handled number within the number
of days specified by the tenant
parameter Time Span for Contact
Record Query. Click a call SN and
play the voice or video of a contact
record. On the Message Sending
Record tab page, click Send to send
a multimedia message (SMS
message, email, or WhatsApp
message) to a customer.
NOTE

The agent is in a conversation with the
handled number.
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Content Description

Contact Records This area is displayed only when the
Customer Center feature is enabled
and the tenant parameter Display
Unified Customer Contact
Information is set to Yes.
Display the latest five contact records.
Contact records can only be displayed
by time.
Click More to go to the History
contacts page, showing the contact
records generated for the current
handled number within the number of
days specified by the tenant parameter
Time Span for Contact Record Query.
Click a call SN and play the voice or
video of a contact record. On the
Message Sending Record tab page,
click Send to send a multimedia
message (SMS message, email, or
WhatsApp message) to a customer.
NOTE

The agent is in a conversation with the
handled number.

Basic Information This area is displayed only when the
Customer Center feature is enabled
and the tenant parameter Display
Unified Customer Contact
Information is set to Yes.
● If information about the customer

exists on the Customer Center >
Customer Center Management
page, the customer information is
displayed.

● If information about the customer
does not exist on the Customer
Center > Customer Center
Management page, an agent can
click  to edit customer
information. For details, see 3.7.15
Editing Customer Information.

Call Information This area is displayed only when the
Customer Center feature is enabled
and the tenant parameter Display
Unified Customer Contact
Information is set to Yes.
The information includes the calling
number, called number, and skill queue.
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Content Description

SmartCare fault demarcation.
The SmartCare tab is displayed on the
audio and video workbench only when
the SmartCare feature is enabled for
the tenant and the language for the
tenant is within the value range of the
system parameter Languages
supported by the SmartCare.
For details, see 3.7.18 SmartCare Fault
Demarcation.

 

3.1.2 Online Chat Workbench
An agent can use the online chat workbench to handle customer businesses
through multimedia channels.

An agent can open the online chat workbench in either of the following ways:

● Choose Online Chat Workbench.
● After an agent signs in to a multimedia skill queue, the online chat

workbench is automatically opened.

Figure 3-2 shows the online chat workbench GUI.

Figure 3-2 Online chat workbench
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NO TE

During a web chat on the online chat workbench, if the customer sends an attachment, the
agent can click Receive to download the attachment.

During an email chat on the online chat workbench, select an email, click Download, and
then click YES in the confirmation dialog box to download the email attachment.

Downloaded data contains personal data. Exercise caution when handling the downloaded
data to prevent personal data leakage and abuse.

● During an SMS or email chat with a customer, click  to create a harassment record.

● In the SMS or email session history on the online chat workbench, click  to create a
harassment record.

● Click  to access a visualized service guidance flow when the Agent Business Process
Visualization feature is enabled and the Service Guidance menu permission is assigned
to the agent.

● Click the link next to Business Request to view the visualized flow.

● The Incoming Call Message area displays information such as the customer name,
customer number, client software environment, customer access channel, waiting time,
and handled number. You can set a handled number to identify the service object. The
handled number can contain a maximum of 50 characters.

The SmartCare tab is displayed on the workbench only when the SmartCare feature is
enabled for the tenant and the language for the tenant is within the value range of the
system parameter Languages supported by the SmartCare. For details, see 3.7.18
SmartCare Fault Demarcation.

The Call Information area is displayed only when the Customer Center feature is enabled
and the tenant parameter Display Unified Customer Contact Information is set to Yes.
For a current session, the information includes the channel, user ID, and skill queue. For a
historical session, the information includes the channel and user ID.

During a chat with a customer, an agent can click  on the workbench to create
intelligent case filling and SmartCare in-depth demarcation tasks. For details, see 3.7.19
Intelligent Case Filling and 3.7.18 SmartCare Fault Demarcation.

During a chat with a customer, an agent can click  on the workbench to create a case.
For details, see 3.7.20 Creating a Case by One Click.

During a chat with a customer, an agent can click  to configure the call reason. If the
Automatic Conversation Summary feature has been enabled for the tenant and an agent,

the  icon is displayed when the agent configures the call reason on the workbench. For
details, see 3.7.5 Setting Call Reasons

3.2 Switching the Agent Status
An agent can switch the agent status using the connection bar on the top of the
page for the system to better assign businesses.

Context

An agent can control the connection status by using the connection bar provided
by the connection framework.
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The connection status refers to the status of a signed-in agent, which can be Idle,
Talking, Wrap-up, Busy, or Rest, as described in Table 3-2. The system
determines whether to assign an inbound call to an agent based on the agent
status.

Table 3-2 Connection status description

Agent Status Description

Idle An agent waits for the system to assign an inbound call.

Talking An agent is processing a voice or video call.

Occupied An agent is processing a multimedia inbound call, an agent
does not answer a voice or video call, or a customer does not
answer a voice or video call.

Wrap-up An agent handles a call-related business (for example, filling in
the customer inbound call information) after the customer
hangs up.

Busy An agent is busy.

Rest An agent takes a rest.
● The countdown time is displayed when an agent is in the

Rest state.
● If the remaining rest time is 5 minutes and the tenant

parameter Forcibly End Agent Rest After Timeout is set to
Yes, the "You will be working in XX minutes. Please reserve
time in advance!" message is displayed in the lower right
corner of the page every minute.

● If the rest ends and the tenant parameter Forcibly End
Agent Rest After Timeout is set to No, the time elapsed
after the rest is displayed in red on the connection bar. The
message "The rest has expired for XX minutes. Please work as
soon as possible." is displayed in the lower right corner every
minute.

 

An agent performs connection operations, such as answering calls, taking a rest,
and showing busy, to switch the connection status. Figure 3-3 shows the
connection status switchover relationships.

A dialog box is displayed in the lower right corner of the browser, indicating the
corresponding call connection event.
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Figure 3-3 Connection status switchover

Procedure

Step 1 Sign in to the AICC as an agent.

Step 2 Click  on the top to sign in to the platform.

● The system parameter Agent status after sign-in specifies the agent status
after sign-in. The agent states after sign-in are as follows:

– Idle

– Wrap-up

– Busy
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● The tenant parameter Mode in Which an Agent Signs In to a Skill Queue
and agent parameter with the same name specify the mode in which an
agent signs in to a skill queue.
– The options of the tenant parameter Mode in Which an Agent Signs In

to a Skill Queue are as follows:

▪ Agent-defined

▪ Automatic: When an agent signs in, the agent automatically signs in
to all skill queues bound to the agent.

▪ Specified: When an agent signs in, the agent can specify skill queues
bound to the agent to sign in. The capabilities of an agent depend
on the skill queues that the agent has signed in to. Select a skill
queue to sign in as required.

Figure 3-4 Specifying skill queues

The default value is Agent-defined. The parameter modification takes
effect after the page is refreshed.

– The options of the agent parameter Mode in Which an Agent Signs In
to a Skill Queue are as follows:

▪ Automatic: When an agent signs in, the agent automatically signs in
to all skill queues bound to the agent.

▪ Specified: When an agent signs in, the agent can specify skill queues
bound to the agent to sign in. The capabilities of an agent depend
on the skill queues that the agent has signed in to. Select a skill
queue to sign in as required.
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Figure 3-5 Specifying skill queues

The default value is Automatic. The parameter modification takes effect
after the page is refreshed.

If the tenant parameter is set to Agent-defined, the value of the agent
parameter Mode in Which an Agent Signs In to a Skill Queue is used.
If the tenant parameter is set to Automatic or Specified, its value is used.

Step 3 Click  on the top and select a state as required.

Figure 3-6 Switching the agent status

----End

Follow-up Procedure
After signing in, an agent can click  in the upper right corner and choose Reset
Skills to reselect the skill queue to which the agent needs to sign in. The
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capabilities of the agent change with the skill queue to which the agent signs in.
For example, if a versatile agent has signed in to a voice or video skill queue and a
multimedia skill queue, after the agent clicks Reset Skills, selects only the voice or
video skill queue, and saves the configuration, the agent can handle only voice or
video calls but cannot handle multimedia chats.

Figure 3-7 Expanding the shortcut menu

Figure 3-8 Reset Skill Queue

NO TE

The agent must have the Reset Skills operation permission.

Common agents in a new tenant space have the permission by default.

Common agents in an old tenant do not have the permission by default. To add the
permission, contact the tenant administrator.

3.3 Allowing Browser Pop-up Notifications

Prerequisites

The tenant administrator has enabled Pop-up dialog box reminder on the Page
Message Notification Configuration tab page of the Prompt Tone page.
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Context
Voice, video, and multimedia inbound call notifications support only manual call
answering.

Procedure

Step 1 Sign in an agent. The browser displays a dialog box asking whether to allow
notifications.

Step 2 Click Allow.

----End

3.4 Handling Voice Businesses
This section describes how to handle voice businesses as an agent.

3.4.1 Answering Inbound Calls Automatically
An agent can automatically answer an inbound call from a customer.

Context
An agent can answer an allocated inbound call. After the call is answered
successfully, the agent can start talking with the customer.

Prerequisites
● The agent has signed in and is in idle state.
● Automatic call answering has been configured in either of the following

methods:
– A tenant administrator chooses Configuration Center > System

Management > Tenant Parameter > Tenant parameters > Connection
Management > Call Control and sets Agent Answering Mode to
Automatic.

– A tenant administrator chooses Configuration Center > System
Management > Tenant Parameter > Tenant parameters > Connection
Management > Call Control and sets Agent Answering Mode to

Custom. An agent clicks , chooses Personal Center,
clicks the Agent parameters tab, and sets Agent answer mode to
Automatic answer.

Procedure
When a new inbound call arrives, the softphone on the agent side rings and the
call will be automatically connected. The agent can also click Answer before the
call is automatically connected. The process is described as follows:

Step 1 After a new inbound call arrives, the softphone of the agent rings.
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Step 2 The agent clicks Answer or waits for the call to be automatically connected. The
agent enters the Talking state, and the softphone shows that the agent is
answering a call.

----End
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3.4.2 Answering Inbound Calls Manually
An agent can manually answer an inbound call from a customer.

Context
An agent can manually answer an allocated inbound call. After the call is
answered successfully, the agent can start talking with the customer.

Prerequisites
● The agent has signed in.
● The agent is in idle state.
● Manual call answering has been configured in either of the following

methods:
– A tenant administrator chooses Configuration Center > System

Management > Tenant Parameter > Tenant parameters > Connection
Management > Call Control and sets Agent Answering Mode to
Manual.

– A tenant administrator chooses Configuration Center > System
Management > Tenant Parameter > Tenant parameters > Connection
Management > Call Control and sets Agent Answering Mode to

Custom. An agent clicks , chooses Personal Center,
clicks the Agent parameters tab, and sets Agent answer mode to
Manual response.

Procedure
When a new inbound call arrives, the softphone of the agent rings. The agent can
click Answer to answer the call.

Step 1 After a new inbound call arrives, the softphone of the agent rings. Click Answer.

At this time, the call is still not connected and the agent is in the Occupied state.

Step 2 After clicking , the agent enters the Talking state, and the softphone shows
that the agent is answering a call.
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----End

3.4.3 Transferring Calls
An agent can transfer a call to another skill queue, a third-party system, another
agent, or an IVR to handle customer businesses.

Context
A call can be transferred to an external number, another agent, a skill queue, or
an IVR. After an inbound call is transferred, the call-related information is also
transferred.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1223



Following describes the transfer types for transferring a call to a skill queue or
another agent.

Table 3-3 Call transfer types

Transfer Type Description

Success Transfer After an agent transfers a call, the agent releases the
call only after the transferred-to agent answers the call.
Otherwise, the system displays a message indicating
that the transfer fails and the agent continues to talk
with the customer.

Release Transfer After an agent transfers a call, the agent releases the
call immediately, regardless of whether the transferred-
to agent answers the call. However, if an agent transfers
the call to a skill queue, the agent releases the call only
after the transfer is successful.

Conversation
Transfer

This mode can be selected only when a call is
transferred to an external number.
After an agent transfers a call, the system monitors the
call transfer process. After the called party answers the
call and talks with the customer, the agent can release
the call.

Hang-up Transfer After an agent transfers a call to an automatic flow, the
agent is in waiting state. After handling the call, the
flow transfers the call back to the agent.
A transfer diagram element cannot be configured in the
IVR flow to further transfer the call to another device.

 

Prerequisites
The agent is in talking state.

Procedure
After answering an inbound call, the agent finds that the call needs to be
transferred.

Step 1 Click  on the connection bar.

Step 2 Click the tab corresponding to the transferred-to object.
● Transfer to a skill queue
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● Transfer to an agent

: The agent is idle.

: The agent is busy.
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: The agent is taking a rest.

: The agent is in a voice or video call.

: The agent is in an online chat.
● Transfer to an external number

NO TE

– An agent can directly select an external number configured on the Configuration
Center > Resource Management > External number page.

– When User Number Forwarding is set to Yes for the selected external number,
only Success Transfer and Conversation Transfer are supported.

– When User Number Forwarding is set to No for the selected external number,
Release Transfer is supported for an inbound call and is not supported for the
agent's outbound call.

– If the agent enters an external number, Release Transfer is supported for an
inbound call and is not supported for the agent's outbound call.

– During a call between an agent and customer 1, if the agent transfers the call to
customer 2 in Conversation Transfer mode and then customer 1 hangs up, the
agent cannot further transfer the call to an external number.

– During a call between an agent and customer 1, if the agent transfers the call to
customer 2 in Conversation Transfer mode and then customer 2 hangs up, the
agent can further transfer the call to an external number.
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● Transfer to an IVR

When the Redis is faulty and the Redis emergency mode is enabled, the
function of transferring calls to the IVR is unavailable.

Step 3 Select an idle agent, a skill queue, or an IVR or enter an external number, and
then click OK.

----End

After the transfer, the current agent enters the Idle state.

3.4.4 Making Outbound Calls
An agent can initiate a call to a customer for business operations.
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Context
An outbound call refers to a call initiated by an agent after the agent enters the
phone number of a customer.

An agent needs to make an outbound call to talk with a colleague outside the
customer service center or a customer.

Prerequisites
● The agent has set the answering mode to manual answering in the agent

parameters.
● The agent has signed in.
● The agent is not in talking state.

Procedure
An agent can make outbound calls in all connection states except the wrap-up,
rest, and talking states.

An agent clicks , enters the called number in the keyboard area, and clicks

.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1228



3.4.5 Making Three-Party Calls
An agent can connect to a third party to jointly handle the business during a call
with a customer.

Context

An agent can initiate a three-party call during a call with a customer for help-
seeking. In this scenario, a three-party call is set up among the customer, agent
who initiates the help-seeking request, and agent who accepts the help-seeking
request. If one party hangs up, the other two parties can still talk with each other.

A three-party call supports three help-seeking modes: help-seeking from a skill
queue, help-seeking from an agent, and help-seeking from an external number.

● If an agent does not know where to seek help, the agent can select a skill
queue for the system to specify an agent in the skill queue as the requested
agent.

● If an agent knows to whom a help-seeking request can be sent, the agent can
directly enter the agent ID of the requested agent to seek help.
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Prerequisites
● The agent has signed in.
● The agent is in a two-party conversation.

Procedure
A three-party call supports three help-seeking modes: help-seeking from a skill
queue, help-seeking from an agent, and help-seeking from an external number.

When an agent clicks Three-Party during a call:

● If an agent does not know where to seek help, the agent can select a skill
queue for the system to specify an agent in the skill queue as the requested
agent.

● If an agent needs to seek help from another agent, the agent can select the
agent for the system to specify the agent as the requested agent.

● If an agent knows to whom a help-seeking request can be sent, the agent can

click  to select or enter an external number.

3.4.6 Holding Calls
An agent can hold a call with a customer and continue to talk with the customer
after handling other businesses.

Context
The call holding service enables an agent to hold an ongoing call. When the call is
held, the customer can hear a prompt tone indicating that the call is held. After an
agent completes other tasks, the agent can cancel the call holding to continue to
talk with the customer. When the call is held, the agent can perform other
operations but cannot answer a new inbound call.

Procedure
After answering a call, an agent needs to suspend the current call to complete
other operations.

Click  on the connection bar to hold a call or click  to unhold a call.

A held call cannot be released by the agent. The agent cannot sign out if the call
is held. In this case, the agent can unhold the call.

NO TE

Differences between call holding and muting are as follows:
When a call is held, the customer can hear the call holding background music played by the
system. When a call is muted, the customer hears no tone from the receiver.
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3.4.7 Consulting
An agent can initiate a consultation request during a call with a customer. During
consultation, the call channel of the customer is held, and the agent who initiates
the consultation request talks with the agent who accepts the consultation
request.

Context
During consultation, the call between the agent and customer is held, and the
agent talks with another agent or an external party who accepts the consultation
request. After the consultation call ends, the current agent can continue to talk
with the customer.

During consultation, if the consulted agent does not answer the call for a long
time, the agent who initiates the consultation request can cancel the consultation.

Procedure

An agent in talking state clicks  on the connection bar to open the
consultation page.

Consultation supports three modes: skill queue, agent, and external number.

● Consultation with a skill queue
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● Consultation with an agent
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: The agent is idle.

: The agent is busy.

: The agent is taking a rest.

: The agent is in a voice or video call.

: The agent is in an online chat.
● Consultation with an external number
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If the outbound call object is a third-party IVR flow and the keys pressed by
the customer or agent need to be transferred to the IVR flow in a three-party
call later, select Indicates whether the process is a self-service process.
This check box is controlled by the tenant parameter Three-party Conference
Number Transfer. The default value is not supported, indicating that this
check box is not displayed. This check box is displayed only when the tenant
administrator sets the parameter to supported.
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3.4.8 Making Internal Calls
An agent can also call other agents.

Context
Internal calls refer to the calls between agents in the AICC. For example, when no
inbound call is available, frontend agents can make internal calls to relevant
personnel for consultation.

Procedure

Step 1 An agent in idle, busy, or wrap-up state clicks  on the connection bar and then

clicks  to open the internal call page.

Step 2 Select another agent in idle or wrap-up state.
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: The agent is idle.

: The agent is busy.

: The agent is taking a rest.

: The agent is in a voice or video call.

: The agent is in an online chat.

----End

3.4.9 Releasing Calls
An agent can release a call after the call ends.

Context
After an agent finishes a service, the agent can proactively end the call if the
customer does not proactively hang up first. After the call ends, the agent
switches to the Idle state on the connection bar.

Procedure

An agent clicks  to end a call.
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3.4.10 Configuring the Agent Assistant
An agent can use the agent assistant to better communicate with customers.

Context
On the voice and video workbench, the system converts the interaction records
between agents and customers into text in quasi real time. The text content is
matched with sensitive words and keywords through the OIAP intelligent services,
and the system can send scripts to agents, improving the service quality of agents.

Procedure
When Only Customer is selected, the system can display only converted speeches
of the customer.

FAQ details are displayed based on keywords in the conversation, providing
knowledge support for agents. You can click the URL in the script guidance page
to go to the corresponding page.

Associated intentions and scripts are displayed based on keywords in the
conversation, providing script guidance for agents.

The number of matched sensitive words is displayed and such words are
highlighted in the real-time transcription window to remind agents to correct it in
a timely manner.

A visualized service guidance flow can be displayed based on keywords in the
conversation.
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3.4.11 Initiating Callbacks
An agent can proactively initiate a callback to a customer for completing a
business which is interrupted abnormally.

Context
When a call between an agent and a customer is interrupted unexpectedly, the
agent can proactively initiate a callback to improve customer experience.

● An agent can initiate a callback only when the agent is in idle or busy state.
● A callback can be initiated only when the call type is calling party or called

party.
● Anonymous calls do not support callback.
● Multimedia agents cannot initiate a callback.

Procedure
If the call between an agent and a customer is interrupted unexpectedly, the
agent can call back the customer by one click and continue to talk with the
customer.
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3.5 Handling Video Businesses
This section describes how to handle video businesses as an agent.

3.5.1 Answering Inbound Calls Automatically
An agent can automatically answer an inbound call from a customer.

Context

An agent can answer an allocated inbound call. After the call is answered
successfully, the agent can start talking with the customer.

Prerequisites
● The agent has signed in and is in idle state.
● Automatic call answering has been configured in either of the following

methods:
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– A tenant administrator chooses Configuration Center > System
Management > Tenant Parameter > Tenant parameters > Connection
Management > Call Control and sets Agent Answering Mode to
Automatic.

– A tenant administrator chooses Configuration Center > System
Management > Tenant Parameter > Tenant parameters > Connection
Management > Call Control and sets Agent Answering Mode to

Custom. An agent clicks , chooses Personal Center,
clicks the Agent parameters tab, and sets Agent answer mode to
Automatic answer.

Procedure
When a new inbound call arrives, the softphone on the agent side rings and the
call will be automatically connected. The agent can also click Answer before the
call is automatically connected. The process is described as follows:

1. After a new inbound call arrives, the softphone of the agent rings.

2. The agent clicks Answer or waits for the call to be automatically connected.
The agent enters the Talking state, and the softphone shows that the agent
is answering a call.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1240



3.5.2 Answering Inbound Calls Manually
An agent can manually answer an inbound call from a customer.

Context
An agent can manually answer an allocated inbound call. After the call is
answered successfully, the agent can start talking with the customer.

Prerequisites
● The agent has signed in.
● The agent is in idle state.
● Manual call answering has been configured in either of the following

methods:
– A tenant administrator chooses Configuration Center > System

Management > Tenant Parameter > Tenant parameters > Connection
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Management > Call Control and sets Agent Answering Mode to
Manual.

– A tenant administrator chooses Configuration Center > System
Management > Tenant Parameter > Tenant parameters > Connection
Management > Call Control and sets Agent Answering Mode to

Custom. An agent clicks , chooses Personal Center,
clicks the Agent parameters tab, and sets Agent answer mode to
Manual response.

Procedure
When a new inbound call arrives, the softphone of the agent rings. The agent can
click Answer to answer the call.

1. After a new inbound call arrives, the softphone of the agent rings. Click
Answer.

2. At this time, the call is still not connected and the agent is in the Occupied
state.

3. After clicking , the agent enters the Talking state, and the softphone
shows that the agent is answering a call.
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3.5.3 Transferring Calls
An agent can transfer a call to another skill queue, a third-party system, another
agent, or an IVR to handle customer businesses.

Context
A call can be transferred to an external number, another agent, a skill queue, or
an IVR. After an inbound call is transferred, the call-related information is also
transferred.

The following table describes the transfer types for transferring a call to a skill
queue or another agent.
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Table 3-4 Call transfer types

Transfer Type Description

Success Transfer After an agent transfers a call, the agent releases the
call only after the transferred-to agent answers the call.
Otherwise, the system displays a message indicating
that the transfer fails and the agent continues to talk
with the customer.

Release Transfer After an agent transfers a call, the agent releases the
call immediately, regardless of whether the transferred-
to agent answers the call. However, if an agent transfers
the call to a skill queue, the agent releases the call only
after the transfer is successful.

Conversation
Transfer

After an agent transfers a call and the transferred-to
agent answers the call, the agent proactively releases
the call.

Hang-up Transfer After an agent transfers a call to an automatic flow, the
agent is in waiting state. After handling the call, the
automatic flow transfers the call back to the agent.
A transfer diagram element cannot be configured in the
IVR flow to further transfer the call to another device.

 

Procedure
After answering an inbound call, the agent finds that the call needs to be
transferred.

1. Click  on the connection bar.

2. Click the tab corresponding to the transferred-to object.
– Transfer to a skill queue

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1244



– Transfer to an agent
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– Transfer to an external number
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NO TE

● An agent can directly select an external number configured on the
Configuration Center > Resource Management > External number page.

● When User Number Forwarding is set to Yes for the selected external
number, only Success Transfer and Conversation Transfer are supported.

● When User Number Forwarding is set to No for the selected external
number, Release Transfer is supported for an inbound call and is not
supported for the agent's outbound call.

● If the agent enters an external number, Release Transfer is supported for an
inbound call and is not supported for the agent's outbound call.

● During a call between an agent and customer 1, if the agent transfers the call
to customer 2 in Conversation Transfer mode and then customer 1 hangs up,
the agent cannot further transfer the call to an external number.

● During a call between an agent and customer 1, if the agent transfers the call
to customer 2 in Conversation Transfer mode and then customer 2 hangs up,
the agent can further transfer the call to an external number.

– Transfer to an IVR

3. Select an idle agent, a skill queue, or an IVR or enter an external number, and
then click OK.

After the transfer, the current agent enters the Idle state.

3.5.4 Making Outbound Calls
An agent can initiate a call to a customer for business operations.
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Context
An outbound call refers to a call initiated by an agent after the agent enters the
phone number of a customer.

An agent needs to make an outbound call to talk with a colleague outside the
customer service center or a customer.

Procedure
An agent can make outbound calls in all connection states except the wrap-up,
rest, and talking states.

An agent clicks , enters the called number in the keyboard area, and clicks

 to initiate a call.

3.5.5 Making Three-Party Calls
An agent can connect to a third party to jointly handle the business during a call
with a customer.
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Context
An agent can initiate a three-party call during a call with a customer for help-
seeking. In this scenario, a three-party call is set up among the customer, agent
who initiates the help-seeking request, and agent who accepts the help-seeking
request. If one party hangs up, the other two parties can still talk with each other.

NO TICE

If the video application mode is SFU video, three-party calls are not supported.
If the video application mode is MCU video, three-party calls are supported.

Procedure
A three-party call supports three help-seeking modes: help-seeking from a skill
queue, help-seeking from an agent, and help-seeking from an external number.

When an agent clicks Three-Party during a call:

● If an agent does not know where to seek help, the agent can select a skill
queue for the system to specify an agent in the skill queue as the requested
agent.

● If an agent needs to seek help from another agent, the agent can select the
agent for the system to specify the agent as the requested agent.

● If an agent knows to whom a help-seeking request can be sent, the agent can

click  to select or enter an external number.

During a three-party call, you can manually maximize the displayed image.

During a three-party call, you cannot share the desktop or adjust the video
window size if not all of the three parties enable the video function.

The following modes are supported.

● The following figure shows the images of three parties of an equal size.
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● The following figure shows a maximized user image.
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● The following figure shows a maximized agent image.

● The following figure shows a maximized third party image.
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3.5.6 Holding Calls
An agent can hold a call with a customer and continue to talk with the customer
after handling other operations.

Context
The call holding service enables an agent to hold an ongoing call. When the call is
held, the customer can hear a prompt tone indicating that the call is held. After an
agent finishes tasks such as help-seeking, the agent can cancel the call holding to
continue to talk with the customer. When the call is held, the agent can perform
other operations but cannot answer a new inbound call. During consultation, if
the consulted agent does not answer the call for a long time, the agent who
initiates the consultation request can cancel the consultation.

Procedure
After answering a call, an agent needs to suspend the current call to complete

other operations. Click  on the connection bar to hold a call or click  to
unhold a call.

A held call cannot be released by the agent. The agent cannot sign out if the call
is held. The agent can perform operations such as making an outbound call or
canceling the call holding.
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NO TE

Differences between call holding and muting are as follows:
When a call is held, the customer can hear the call holding background music played by the
system. When a call is muted, the customer hears no tone from the receiver.

3.5.7 Consulting
An agent can initiate a consultation request during a call with a customer. During
consultation, the call channel of the customer is held, and the agent who initiates
the consultation request talks with the agent who accepts the consultation
request.

Context
During consultation, the call between the agent and customer is held, and the
agent talks with another agent or an external party who accepts the consultation
request. After the consultation call ends, the current agent can continue to talk
with the customer.

Procedure

An agent in talking state clicks  on the connection bar to open the
consultation page.

Consultation supports three modes: skill queue, agent, and external number.

● Consultation with a skill queue
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● Consultation with an agent
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● Consultation with an external number
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3.5.8 Releasing Calls
An agent can release a call after the call ends.

Context
After an agent finishes a service, the agent can proactively end the call if the
customer does not proactively hang up first. After the call ends, the agent
switches to the Idle state on the connection bar.
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Procedure

An agent clicks  to end a call.

3.5.9 Switching Between Voice and Video Calls
An agent can switch the call type during a video call with a customer.

Context

NO TICE

Switching between voice and video calls is available only for video agents.

Currently, switching between voice and video calls is supported in the following
scenarios:

● An agent initiates a voice call or a customer dials a called route to connect to
an agent. After the voice call is connected, the agent can click the switching
button to switch the voice call to a video call.

● A call is held, unheld, muted, or unmuted.

● A call is transferred to an agent or a skill queue.

Procedure

An agent clicks  to switch between voice and video calls.

When the WebRTC feature is enabled for a video agent and the video application
mode is SFU video, the following scenarios are supported:

● When a voice call is initiated, an agent switches it to a video call. After the
user accepts to switch the call mode, the two parties have a video call.

● When a video call is initiated, an agent switches it to a voice call. The two
parties have a voice call.

● When a voice call is initiated, an agent switches it to a video call, but the user
denies switching the call mode. The user is still in the voice call. The agent
can invite the user to have a video call again.

● When a video call is initiated, a user switches it to a voice call and answers
the call. The user is in the voice call. The agent can invite the user to have a
video call.

● An agent can switch between voice and video calls for multiple times.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1258



NO TE

Contact records can be recorded. Both SFU and MCU videos can be downloaded, but SFU
videos rather than MCU videos can be played online.

3.5.10 Sharing the Desktop
An agent can share the desktop during a video call with a customer.

Prerequisites
● The WebRTC feature has been enabled for agents.
● The agent is not bound to a mobile number or fixed-line phone number.
● To use the OpenEye softphone, the OpenEye has been configured as follows:

a. Click  before logging in to the OpenEye.
b. Configure general settings.

i. Choose General.
ii. Enable or disable Conference Sharing.

○ Disable Conference Sharing when the UAP of the V1R5 version
is used.

○ Enable Conference Sharing when the UAP of the V3R1 version
is used.

c. Configure media settings.

i. Choose Media.
ii. Enable Virtual Camera.
iii. Set Share Screen.

○ If Video application mode is set to MCU video when the tenant
is created, set Share Screen to MCU mode.

○ If Video application mode is set to MCU+SFU video when the
tenant is created, set Share Screen to SFU mode.

Context
An agent can use the WebRTC or OpenEye softphone to sign in as an agent and
share the desktop during a video call with a customer.

CA UTION

Pay attention to personal privacy protection during desktop sharing.

Procedure

If the WebRTC softphone is used, click  to share the desktop.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1259



If an integrated OpenEye softphone is used, click  to share the desktop.

If an independent OpenEye softphone is used, share the desktop on the OpenEye.

The following contents can be shared:

● Entire screen
● Application window
● Browser tab page

3.6 Handling Multimedia Chat Businesses
This section describes how to handle multimedia businesses as an agent.

3.6.1 Answering Calls
An agent can use the online chat workbench to handle customer businesses
through multimedia channels.

Context

The workbench can be opened using the menu or automatically opened when the
agents associated with multimedia skill queues sign in.

After the workbench is opened, the number of calls made on the current day and
average call duration (in seconds) are displayed.

When an agent processes a multimedia message, the connection bar is in the
Occupied state. In this state, the agent can make outbound calls at the same
time. When a voice call is released, the multimedia call cannot be released at the
same time.

Current is displayed on the left. The chat area, third-party page provided by the
customer, and input area of the current conversation are displayed in the middle.
Incoming Call Message, Call Reason, History contacts, and multimedia are
displayed on the right.

The third-party page provided by the customer is configured based on the call
launch page. In addition, the call launch page path carries the employee ID and
information about the calling and called parties.

If multiple tab pages are opened and the current online chat workbench is not
activated, when a new message is received, the tab page blinks and an
announcement is played, indicating that a new message is received.

Prerequisites

When the Refine response feature is enabled for a tenant, the agent bound to the
tenant administrator is a versatile agent, and the Intelligent Recognition and
Reply polishing switches are turned on, the AI polishing function can be used.
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Procedure

A customer communicates with agent A through the web channel to query the
call fee balance, and then rates the service after the conversation ends.

Step 1 Sign in to system on the connection bar and set the agent to the idle state.

Step 2 Initiate a call as a customer. The agent workbench automatically connects to the
multimedia session. After the agent double-clicks the session, the information is
displayed on the right.

NO TE

● Before sending a message, click  to check spelling to avoid spelling mistakes.

All channels support spelling check. For the email channel, the forwarding, reply, and
email draft viewing pages are involved.

Only the spelling of text is checked. Misspelled words are marked in red.

Currently, only Chinese, English, and Portuguese spelling checks are supported. If a
tenant uses a language other than Chinese, English, or Portuguese, Language is set to
English by default.

● In the Current area, the chat content between the customer and agent is displayed. If
the customer has historical conversations with an agent, the historical conversation
records of the customer can be displayed in Current.

● When the content entered by an agent is used in a historical conversation, the system
automatically associates and displays related historical content for the agent to select,
improving the business handling efficiency.

● After a customer reads a message sent by an agent, the message status is displayed as
Read on the online chat workbench. The customer is unaware of the message status.

----End

Troubleshooting

If the email content cannot be displayed and is empty, click Refresh to check the
OBS status. If a message is displayed, including that the refresh fails, contact O&M
personnel.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1261



3.6.2 Sending an Electronic Document Link

Context
During the chat with a customer, you can send an electronic document link to the
customer for signing.

In the OP integration deployment environment, electronic document links cannot
be sent.

Prerequisites
● The Contract Digital Signature feature has been enabled for the tenant. If

the feature is not enabled, contact operations personnel to enable it.
● The tenant has an available WhatsApp channel.
● In the electronic document, the customer signature location has been marked

with an arrow, and the electronic document must be in PDF format.
For details, see 3.6.2.1 FAQ: How Do I Insert an Arrow to an Electronic
Document?

● The agent is chatting with the customer.

Procedure
Step 1 Contact operations personnel to determine the size and location of the arrow and

the timeout period for a single signature.
● The arrow size is specified by the system parameter Signature location

picture size. The default value is 18*22, indicating the width x height of the
signature location image.

● The arrow location is specified by the system parameter Signature image
size and offset. The default value is 100*50*2*0, indicating the width x height
x x-axis offset x y-axis offset of the image.

● The timeout period for a single signature is specified by the system parameter
Single signature timeout (seconds). The default value is 600.

Step 2 Establish a session with the customer.

Step 3 Select the prepared electronic document.

1. Click  above the input area. The Send Document page is displayed.

Figure 3-9 Send Document page
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2. Click  and select the prepared electronic document.

Only PDF files are supported.

3. Click Statistic to display the number of signatures to be signed.

If there are multiple signatures, you can select mandatory signatures.

Figure 3-10 Selecting mandatory signatures

4. Click Finish. The document link is automatically saved in the text box.

A record is automatically added on the Contact History > Document
Management page, and the document status is Unsigned. For details about
other operations, see 3.7.13 Managing Documents.

If the name of the document to be uploaded is the same as that of an
existing document and the existing document is valid, the document cannot
be uploaded.

Step 4 Click Send and wait for the customer to sign.

If the document does not expire or become invalid within the session period, the
customer can sign the document. The timeout period for a document is the
number of signatures in the document multiplied by the timeout period for a
single signature.

During the signing process, the agent can prompt the customer to confirm the
document content, sign the document, and submit the document. A document
link can be submitted for signing only once.

After the customer submits the document, the document status changes to
Signed on the Contact History > Document Management page. Within 1
minute, the document preview page is automatically displayed on the agent side.

----End
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Follow-up Procedure
In the History contacts area, click the generated data to view the document
status, preview, and download the document in the contact records.

3.6.2.1 FAQ: How Do I Insert an Arrow to an Electronic Document?

Prerequisites
You have prepared an electronic document in PDF format.

Context
Use a PDF editor to insert an arrow to the location for a signature in an electronic
document.

PDF editor: prepared by yourself

Arrow icon:

Procedure

Step 1 Download the package from Context and extract the arrow icon
icon_Arrow18x22.png.

Step 2 Run the PDF editor and open the electronic document in PDF format.

Step 3 Insert the arrow icon.

The method of inserting a local image varies according to the PDF editor that you
use.

Figure 3-11 Selecting the icon

NO TE

Do not change the size of the arrow.
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Step 4 Check that the arrow is in the body of the electronic document.

Step 5 Drag the arrow to the location for a signature.

When you drag the arrow, retain its original size. Copy and paste operations are
supported.

Step 6 Save the electronic document with the arrow inserted.

----End

3.6.3 Initiating a Voice or Video Call
During a text chat with a customer through the WhatsApp channel, an agent can
initiate a voice or video call.

Prerequisites
● The browser used by the customer supports WebRTC.

● The customer has audio input and output devices or video input and output
devices (for video calls).

● The WebRTC feature has been enabled and the anonymous call server has
been configured for the tenant space.

● A web channel for which the click-to-dial called route is configured is
available.

Context

If call collaboration is required, that is, a customer can have a text chat and a
voice or video call with the same agent, the agent scopes of the click-to-dial skill
queue and multimedia skill queue must be the same in the web channel
configuration.

A voice or video call cannot be initiated during a chat between a robot and a
customer.

Procedure

Step 1 Click  as an agent. The system automatically generates a voice or video call
link in the text box.

Step 2 Click Send. The customer receives the voice or video call link. After the customer
clicks the link, the two parties can talk with each other.

----End

3.6.4 Transferring Sessions

Context

A session needs to be transferred to another agent.
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Procedure

Click  to transfer an ongoing session to another agent. A session can be
transferred by skill queue (multimedia type) or by agent (multimedia agent). The
transfer modes are release-after-transfer and blind transfer. During session
transfer, agent states and accounts can be viewed.

Release-after-transfer: After an agent transfers a session, the agent releases the
session only after the transferred-to agent answers the session. Otherwise, the
system displays a message indicating that the transfer fails.

Blind transfer: After an agent transfers a session, the agent releases the session
immediately, regardless of whether the transfer is successful.

Figure 3-12 Transferring a session to a skill queue
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Figure 3-13 Transferring a session to an agent

: The agent is in a voice or video call.

: The agent is in an online chat.

3.6.5 Initiating Sessions
An agent can search for a user not contacted in historical sessions, and set up a
connection through the email, WhatsApp, 5G RCS, or SMS channel.

Prerequisites

Channels such as email, WhatsApp, 5G RCS, and SMS message are available, and
the offline message function has been enabled for the channels.

Context

Users not contacted refer to users who have never been contacted and users who
have not been contacted for more than seven days.
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Procedure
Assume that an email agent initiates a session.

Step 1 Click Sign In on the connection bar and set the agent status to busy.

Step 2 Choose Online Chat and click .

Step 3 Enter a user ID, select a channel type, select an OU, and select a channel
configured for the selected OU.

Figure 3-14 Offline call (when Channel Type is set to Email)

Step 4 Click Save. A session is initiated, and the agent status changes from idle to
occupied and then to idle.

----End

3.6.6 Initiating Co-browsing
An agent can initiate co-browsing after a customer is connected to the agent.

Prerequisites
● The agent and customer are in a session.
● The OU that the agent can access has available co-browsing URLs.
● The Co-Browse plugin must be installed for the Chrome browser used by the

customer. The agent obtains the plugin package from AICC Developer Forum
and sends it to the customer. The agent instructs the customer to install the
Co-Browse plugin by referring to the following steps, or the agent can refer to
the usage guide attachment in the plugin package for more details.

a. Decompress cobrowse-plugin.rar.
b. Change the value of aiccDomain in the content_script.js file to the

domain name or IP address and port number of AICC.
  let aiccDomain = 'https://aiccclond.com';
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c. Open the Chrome browser, click  in the upper right corner, and choose
Extensions > Manage Extensions.

d. Select Developer mode, click Load unpacked, and choose the
decompressed plugin file cobrowse-plugin whose configuration has been
modified.

e. If the following information is displayed, the plugin is installed
successfully:

Context
Only the web channel supports this function.

Procedure

Step 1 Click  on the right and select an OU that you can access.

Step 2 Click More and choose Co-browsing.
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Figure 3-15 Choose Co-browsing

Step 3 Select a co-browsing URL and click  to send a co-browsing request.

Figure 3-16 Sending a co-browsing URL

Step 4 After the co-browsing request is successfully sent, wait for the customer to accept
the request.

A blank Co-browsing tab page and a browser trust request are displayed on the
agent side. You need to access and trust a website in the browser as prompted. If
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no content is displayed on the Co-browsing tab page after the website is trusted,
initiate co-browsing again.

Figure 3-17 Waiting page

Figure 3-18 Browser trust request

The preceding figures are only examples.

Step 5 After the customer accepts the request, co-browse the page with the customer.

A new page is displayed on the customer side. The page content of the co-
browsing URL is displayed on both the new page on the customer side and the
Co-browsing tab page on the agent side.

Note: When the customer page is displayed on the Co-browsing tab page on the
agent side, some sensitive information on the customer page is shielded based on
the co-browsing rules configured by a tenant administrator.

Table 3-5 GUI elements on the Co-browsing page (agent side)

Element/Component Type Description

Button The agent requests or stops the customer
page control permission.
After the agent initiates a request, the
following options are displayed on the
customer side:

● : Accept the request.

● : Reject the request.
NOTE

Accepting the request will share your page, which
may contain your personal data. Exercise caution
when performing this operation.
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Element/Component Type Description

Button The agent exits the co-browsing room.

Button Eraser.

Button Highlighter.

Button Brush.

Button Hide the toolbar.

 

Figure 3-19 Co-browsing page (customer side)
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Table 3-6 GUI elements on the Co-browsing page (customer side)

Element/
Compone
nt

Ty
pe

Description Value
Range

Triggeri
ng
Event

Remarks

But
ton

Draw. - Click -

But
ton

The customer
revokes or grants
the page control
permission to the
agent.

- Click -

But
ton

Highlight key
areas.

- Click -

But
ton

Erase a drawn
mark.

- Click -

But
ton

The customer exits
the co-browsing
room.

- Click -

But
ton

Hide the toolbar. - Click -

 

NO TE

The agent is advised to view the customer's presentation in the normal browser window
instead of the zoomed-out browser window.

----End

Follow-up Procedure
After the co-browsing ends, the agent can choose Contact History > Co-browsing
to view the co-browsing session record, including Room Number, Agent Number,
Caller, Starting Time, and End Time.

3.6.6.1 FAQ: How Does a Customer Initiate Co-browsing?
After a customer is connected to an agent, the customer can initiate co-browsing.
The following describes how a customer initiates co-browsing using the Try
function in the AICC.

Prerequisites
The agent and customer are in a session.

Context
Only the web channel supports this function.
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Procedure

Step 1 The customer clicks  and then clicks Selecting a sensitive area to block
some sensitive information on the page. The selected area is displayed as
pixelation on the agent side. If no information needs to be blocked, skip this step.

Figure 3-20 Customer's view

Step 2 The customer clicks Direct sharing to initiate co-browsing. A message is
displayed, indicating that the browser page will be shared, and the customer clicks
Confirm to share the page.
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Step 3 A dialog box is displayed on the agent side, asking the agent whether to accept
the co-browsing invitation. The agent clicks OK to accept it.

Figure 3-21 Co-browsing invitation dialog box on the agent side

Step 4 The Co-browsing tab page is displayed on the agent side to display the page
shared by the customer. The agent can also apply for the operation permission.

Note: When the customer page is displayed on the Co-browsing tab page on the
agent side, some sensitive information on the customer page is shielded based on
the sensitive area selected by the customer or on the co-browsing rules configured
by a tenant administrator.

Figure 3-22 Agent's view

----End

3.6.7 Releasing Calls
An agent can release a call after the call ends.

Context
After an agent finishes a service, the agent can proactively end the call if the
customer does not proactively hang up first. After the call ends, the agent
switches to the idle state on the connection bar.

Procedure

An agent clicks  to end a call.
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3.6.8 Querying Historical Contacts
An agent can view the latest three contact records.

Context
The latest three contact records are displayed by time. Contact records can only be
displayed by time.

You can view multimedia messages, such as emojis, images, videos, and addresses,
in historical contact records.

Procedure

● Click  to go to the Contact Details page.

NO TE

The agent is in a conversation with the handled number.

● Click More to view the contact records generated for the current handled
number in the last seven days.
Click a call SN to view the session content.

NO TE

The agent is in a conversation with the handled number.

Figure 3-23 Historical contacts page

3.6.9 Withdrawing Agent Messages
An agent can withdraw messages.

Context
When an agent has an online chat with a customer, the agent can recall the
message that has been sent.

NO TE

Only the web channel supports message recall.
Only messages within 2 minutes can be recalled.
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Procedure
On the agent side, right-click a message and choose Retract from the shortcut
menu.

Figure 3-24 Withdrawing a message

After a message is recalled, the following information is displayed.

Figure 3-25 Agent page

3.6.10 Applying for a Multimedia Silent Agent
A chatbot can apply for a multimedia agent for assistance during the conversation
with a user.

Context
A silent agent can be in one of the following states: common, monitoring,
insertion, and transfer.

Common: When a silent agent switches to this state, the agent proactively
releases the call with the chatbot. The user directly communicates with the
chatbot.

Monitoring: When a silent agent switches to this state, the agent can view the
conversation between the user and chatbot. When the chatbot fails to reply to a
user's question for three consecutive times, the chatbot sends a help signal to the
silent agent. The silent agent can send a reply or switch the state for assistance.

Insertion: When a silent agent switches to this state, the silent agent directly
communicates with the user in the name of the chatbot. When the user sends a
message, the chatbot sends a help request to the silent agent. The silent agent
can reply to the user only when the chatbot asks for help.

Transfer: When a silent agent switches to this state, the agent can transfer the call
to the agent service.
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NO TE

● Silent agents are available only in channels that support chatbot and silent agent skill
queue configurations.

● Silent agents are available only for flows whose Work Mode is set to Monitor or Insert
during publishment on the Flow Orchestration page in the intelligent IVR.

● Silent agents do not support the manual answering mode.

Procedure

When a user has a chat with the chatbot and the chatbot cannot identify the
user's intent, the chatbot asks for help from a silent agent.

Figure 3-26 Multimedia silent agent page

3.6.11 Callback
During or after a text chat with a WhatsApp customer, an agent can initiate a
voice session to contact the customer.

Prerequisites
● The agent is chatting with the customer through the WhatsApp channel.
● The History tab page contains WhatsApp customers with whom the agent

has chatted.
● The agent is in one of the following states:

– Idle
– Busy
– Wrap-up

● You have contacted the tenant administrator to configure the international
crown code of the mobile number of the WhatsApp customer to be contacted
to the AICC system.
Path: Configuration Center > System Management > Tenant Parameter >
CCNotification > Telecom number.
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Procedure

Step 1 During a text chat with a customer:

1. Return to the online chat workbench.

2. Click  in the upper part of the call message.

Step 2 After a text chat with a customer:

1. Open the online chat workbench.
2. Click History in the upper left corner.
3. Find the session record of the customer to be contacted.

4. Click  in the upper part of the call message.

----End

3.7 Performing Other Agent Operations
This section describes other operations performed by an agent.

3.7.1 Configuring the Personal Center
Agents can query their own agent and employee information in the personal
center, configure personalized nicknames and greetings for themselves, and set
personalized agent parameters.

Procedure

Step 1 Sign in to the AICC as an agent, click the business account in the upper right
corner, and select Personal Center from the drop-down list.
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Figure 3-27 Personal center

Step 2 View employee information.

On the left, basic information about the agent is displayed, including the business
account, username, phone number, email address, position, and manager.

Step 3 View agent information.

1. Click the Agent Info tab to view the agent information.

2. View the agent ID, agent type, role, softphone number, registration server
address, and skill queue on the Agent Info tab page.

3. Click  to download the VRC client to the local PC.

NO TE

If the screen recording and screen inspection features are not enabled and the system
parameter VRC download address is not set, the Download VRC button is not
displayed.

4. Click  to download the softphone client to the
local PC.

NO TE

If the WebRTC feature is enabled for an agent, the Download OpenEye button is not
displayed.

5. Click Reset Softphone Password to reset the current softphone login
password.
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Figure 3-28 Resetting the softphone password

Verification Code is available only when Two-factor Authentication
Method is set to SMS verification code or Email verification code. You can
click Send Code to obtain a verification code.

6. In softphone number status, check the sign-in status of the softphone. You
can also click Unregister to sign out of the softphone.

7. Click Modify to update Fixed-Line/Mobile Number.

Step 4 Set personalized configuration.

1. Click the Personalized Settings tab.
2. Click Edit and configure personalized settings.

Figure 3-29 Personalized Settings

– Conversion Head Portrait: Click Change Avatar to customize an avatar
for an agent during a session. Currently, eight avatars are provided.

– Session Nickname: Agent nickname for a customized session. The value
contains a maximum of 20 characters and cannot contain the following
special characters: +~!@#$%&*()/=+{};:'",<.>?
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– Number of clients served by a session at the same time: Number of
multimedia customers concurrently served by an agent based on the
following priority: agent level > organization level > tenant level. If the
value is 0, the configuration at this level does not take effect and the
configuration at other levels is used. If the agent is not bound to a
business account, Maximum concurrent service customers is not
displayed. The value ranges from 0 to 60. The default value is 0.

– Personalized Greetings:

▪ Click . You can add a maximum of four greetings in different time
segments.

▪ Time range: Select the time range for using the greeting. The start
time ranges from 00:00 to 23:00, and the end time ranges from 01:00
to 00:00.

▪ Greetings: Content of a customized greeting. The value contains a
maximum of 20 characters and cannot contain the following special
characters: <>'"/\

▪ Click  to delete unnecessary greetings.

3. Click Save.

Step 5 Set agent parameters.

1. Click the Agent parameters tab.

Figure 3-30 Agent parameters

Table 3-7 Agent parameters

Parameter
Name

Parameter Value Description

Callout
Caller

Default value: -
(customized by the
agent)

Calling number used by an agent to
make an outbound call.
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Parameter
Name

Parameter Value Description

Agent
answer
mode

– Automatic
answer

– Manual
response

Default value:
Automatic answer

Agent answering mode. The options
are Automatic answer and Manual
response. The default value is empty,
which is consistent with the tenant
configuration. If the tenant-level
configuration is configured by the
agent, the default value is Automatic
answer.

Whether to
integrate
the
OpenEye on
the web
page

– No
– Yes
– Consistent with

the tenant level
Default value:
Consistent with
the tenant level

Whether to integrate the OpenEye
softphone in the web system. The
options are No, Yes, and Consistent
with the tenant level.
To implement this function, the
OpenEye must be installed on the
local PC of the agent.

Web-
integrated
OpenEye
Video
Display

Default value: -
(customized by the
agent)

Video display of the OpenEye
integrated with the web system. This
parameter is valid only when Whether
to integrate the OpenEye on the
web page is enabled. For example, in
the value 0,0,800,380,PiP,Fit, 0,0
indicates the X and Y coordinates of
the video position (the upper left
corner of the screen is the coordinate
origin), 800,380 indicates the width
and height of the window, PiP
indicates the layout of the video image
(PiP indicates picture-in-picture, and
SbS indicates side-by-side), and Fit
indicates the display mode of the
video image (Fit indicates that the
video is adapted according to its
original proportions, and Cut indicates
that the video is displayed at full size
according to its original proportions
and cropped if necessary).

WebRTC
auto-
registration
with sign-in

– Yes
– No
Default value: Yes

Indicates whether the WebRTC is
automatically registered when an
agent signs in.
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Parameter
Name

Parameter Value Description

Mode in
Which an
Agent Signs
In to a Skill
Queue

The options are as
follows:
– Automatic
– Specified
Default value:
Specified

Mode in which an agent signs in to a
skill queue. The options are
Automatic (automatically sign in to
the skill queue configured for the
agent) and Specified (sign in to a
specified skill queue).
The parameter modification takes
effect after the page is refreshed.

 
2. Select an agent parameter, click Edit, and change the value of Parameter

Value.
3. Click Save.
4. (Optional) Click Reset to restore agent parameter values to the default

values.
5. Click Sync to synchronize the modified agent parameters to the cache.
6. After configurations are modified successfully, sign in again for the

modification to take effect.
7. (Optional) Select agent parameters in batches and click Batch Reset to

restore agent parameter values to default values in batches. Click Batch Sync
to synchronize the modified agent parameter values to the cache in batches.

----End

3.7.2 Querying Historical Contacts
An agent can query historical contact records.

Context

Historical contact records can only be displayed by time.

Procedure

● Click  to go to the Contact Details page.
On the Message Sending Record tab page, click Send to send a multimedia
message (SMS message, email, or WhatsApp message) to a customer.

NO TE

The agent is in a conversation with the customer.

● Click More to go to the History contacts page, showing the contact records
generated for the current handled number within the number of days
specified by the tenant parameter Time Span for Contact Record Query.
Click a call SN and play the voice or video of a contact record. On the
Message Sending Record tab page, click Send to send a multimedia message
(SMS message, email, or WhatsApp message) to a customer.
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NO TE

The agent is in a conversation with the customer.

3.7.3 Viewing Inbound Call Information
An agent can view inbound call information.

Context
The Call Message area displays inbound call information, including the calling
number, called number, handled number, skill queue, and smart voice recording
information.

Procedure
Smart Voice Recording is displayed when a call is transferred from a chatbot to
an agent. The chat content between the chatbot and the user can be viewed by
clicking Details on the Smart Voice Recording page.

Figure 3-31 Call Message

You can set a handled number to identify the service object. The handled number
can contain a maximum of 24 characters.

If no handled number is set, the handled number is the same as the customer
number.
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Figure 3-32 Smart Voice Recording

3.7.4 Setting the Handled Number
During a call, an agent can set the handled number to identify the service object.

Context

If no handled number is set, the handled number is the same as the customer
number.

Procedure

Click  to set the handled number in the dialog box that is displayed. The
handled number can contain a maximum of 50 characters.

Figure 3-33 Setting the handled number
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3.7.5 Setting Call Reasons
An agent can set call reasons to identify the customer.

Context
The call reason of the customer is identified and displayed.

Procedure

Click  and select a call reason in the dialog box that is displayed. You can add
call remarks of up to 2000 characters as required.

If any item under Relate Cases is selected, the Create Case page is displayed after
you click Save. The Relate Cases area is displayed only when the Case 2.0 feature
is enabled.

After the Automatic Conversation Summary feature has been enabled for the

tenant and an agent, the  icon is displayed when the agent configures the call
reason on the workbench. This feature analyzes conversations between agents and
customers based on LLMs and generates session summaries, including whether
problems are solved and customer satisfaction, for the agents to view.
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3.7.6 Setting the Online Chat Service Time
An agent can set working hours to maximize agent utilization.

Context

This section describes how to configure non-working days for agents to manage
working hours on working days and non-working days.

Procedure

Choose Configuration Center > Workbench Configuration > Online Chat
Service Hours.

● Set the non-working days of each week.
Select non-working days of each week from the selection box, which is valid
every week.

● Set specified dates to non-working days.
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Add a rule to specified dates and set extra non-working days. For example, set
October 1 to October 7 as non-working days.

● Set exceptional working days.

Add a rule to set a day in a cycle or consecutive non-working days as a
working day.

3.7.7 Configuring Personalized Common Phrases
Agents can configure personalized common phrases in advance to improve work
efficiency.

Prerequisites

None

Procedure

Step 1 Choose Configuration Center > Workbench Configuration > Common Phrase.

Step 2 Click . In the dialog box that is displayed, enter a category name and click Save.

After the category name is created, you can perform the following operations:

● Click  to update the category name.

● Click  to delete the category name.

Step 3 Select a common phrase category, click Create in the upper right corner, enter a
common phrase, select a shortcut (optional), and click Save.

Figure 3-34 Create Common Phrases

Step 4 Click Save.

----End

Follow-up Procedure

View the configured personalized common phrase and its shortcut in Multimedia
on the right of the online chat workbench.
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3.7.8 Sending Notifications
Agents can send internal messages and send multimedia messages (SMS
messages, WhatsApp messages, or emails) during calls with customers.

Prerequisites
● To send Huawei Cloud SMS messages, contact the tenant administrator to

purchase the Huawei Cloud SMS service and complete SMS configuration on
the Configuration Center > Access Configuration > SMS Configuration >
HUAWEI CLOUD SMS page by referring to 2.11.2 Configuring SMS
Messages. Huawei Cloud SMS requires that the server has the permission to
access the external network.

● To send SMS gateway messages, contact the tenant administrator to
configure SMS message sender numbers on the Configuration Center >
Access Configuration > SMS Configuration > SMS Number page.

● To send conference link SMS messages:
– Contact the tenant administrator to configure SMS message sender

numbers on the Configuration Center > Access Configuration > SMS
Configuration > SMS Number page.

– Contact the tenant administrator to configure the Meeting_URL variable
on the Configuration Center > Workbench Configuration >
Notification Variables page.

– Contact the tenant administrator to create an SMS gateway message
template whose Notification Type is External Notification on the
Configuration Center > Workbench Configuration > Notification
Template page. The SMS gateway message template must contain the
Meeting_URL variable.

– Contact the tenant administrator to configure the tenant parameter
Conference Link SMS Template.

● To send SMS gateway messages and emails, contact the tenant administrator
to configure the SMS and email gateways on the Configuration Center >
Access Configuration > Gateway Configuration page.

● To send WhatsApp messages, contact the tenant administrator to configure
the WhatsApp channel on the Configuration Center > Access Configuration
> Channel Configuration page.

● You have been granted the Channel Configuration > Notification Center >
Agent Send Notification menu permission.
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Procedure

Step 1 Sign in to the AICC as an agent.

Step 2 Send an SMS message.

1. Click  on the Call page when answering a call or making an outbound
call.

2. Select Huawei SMS to send a Huawei Cloud SMS message.

a. Click Reference Template. In the template list that is displayed, select a
configured Huawei Cloud SMS template whose Notification Type is
External Notification and click Complete.

b. Confirm the information and click OK.

3. Select Gateway SMS to send an SMS gateway message.

a. Click Sender ID, select a sender ID, and click Confirm.

The sender IDs are added on the Configuration Center > Access
Configuration > SMS Configuration > SMS sender ID configuration
page.

b. (Optional) Click  next to Reference Template. In the template list
that is displayed, select a configured SMS gateway template whose
Notification Type is External Notification and click Complete.

NO TE

After a template is referenced, you can modify the sender number, recipient, and
variable value, but cannot modify the content.

c. Enter the SMS message content.

d. Confirm the information and click OK.

4. Send a conference link SMS message.

a. Click Sender Number, select a sender number, and click OK.

The sender number is added on the Configuration Center > Access
Configuration > SMS Configuration > SMS Number page.

b. Enter a recipient number.

c. Click OK.

After the SMS message is sent successfully, the recipient can view the
conference link in the SMS inbox and click the conference link to join the
conference.

The conference link can be used only once. If the recipient exits the
conference, a new conference link SMS message needs to be sent.

Step 3 Send an email.

1. Click  on the Call page when answering a call or making an outbound call.

2. (Optional) Click  next to Reference Template. In the template list that
is displayed, select a configured email template and click Complete.
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NO TE

After a template is referenced, you can modify the outbox, recipient, and variable
value, but cannot modify the content.

3. Set Outbox to the default email address configured on the Gateway
Configuration page.

4. In the Recipient text box, enter the recipient email address.
5. In the Title text box, enter a title.

6. (Optional) Click , select a local file as the email attachment, and click
Upload.
The supported file formats are DOC, DOCX, XLS, XLSX, TXT, PNG, JPG, XML,
JSON, CSV, BMP, ZIP, PPT, PPTX, and PDF.
The file size cannot exceed 10 MB. A maximum of 10 files can be uploaded.

7. Enter the email content.
8. Confirm the information and click Send.

Step 4 Send a WhatsApp message.

1. Click  on the Call page when answering a call or making an outbound
call.

2. Set WhatsApp Channel to a WhatsApp channel.
3. Click WhatsApp Message Template, select a WhatsApp template message

created on the Configuration Center > Resource Management >
Multimedia Library > Card Template > WhatsApp Template Message page,
and click Complete.
Before creating a WhatsApp template message, create a WhatsApp template
on the Configuration Center > Resource Management > WhatsApp
Template page.

4. Confirm the information and click Send.

Step 5 Send an internal message.

1. Click . On the Notification Center page, click

.
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Figure 3-35 Send a notification

2. Configure the notification content.

– Type: Select Internal Message.

– Recipient: Click Recipient. In the Recipient dialog box, select recipients
and click Complete.

NO TE

Assign the Query User and Save Employee permissions under Menu
permissions > User Management > User Management > Employee to the
agent who needs to send internal messages. Otherwise, the agent cannot select
recipients.

– Recipient Group: Click Recipient Group. In the Recipient Group dialog
box, select recipient groups and click Complete.

– Title: Enter a notification title. The value can contain a maximum of 200
characters.

– Priority: Select a notification urgency level. The options are Low,
Medium, High, and Critical.

– Notification content: Enter the notification content.

3. Click Send to send an internal message.

4. (Optional) Click Save to save the internal message as a draft.

----End

3.7.9 Viewing Skill Queue Adjustment Records
An agent or a tenant administrator can query skill queue adjustment details.

Prerequisites
● The agent has the Reset Skill Record menu permission.

● The agent's skill queue has been adjusted by referring to Follow-up
Procedure.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1293



Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Work Log > Adjustment
Log.

Step 2 Set search criteria to search for skill queue adjustment records based on the
criteria.

Figure 3-36 Adjustment Log page

Table 3-8 GUI elements on the Adjustment Log page

Element Typ
e

Description

Time Dro
p-
do
wn
list

The options are as follows:
● 1 Day
● 3 Days
● 7 Days
● Customization

Adjust
Service
Account

Tex
t
box

Search criterion.
● Business account of the agent who adjusts a skill queue.
● Business account of an inspector.

Adjust
Agent
WorkNo

Tex
t
box

Search criterion.
● ID of the agent who adjusts a skill queue.
● Agent ID of an inspector.

Adjusted
Service
Account

Tex
t
box

Search criterion.
● Business account of the agent whose skill queue is

adjusted.
● Business account of the agent whose skill queue is

adjusted by an inspector.

Adjusted
Agent
WorkNo

Tex
t
box

Search criterion.
● ID of the agent whose skill queue is adjusted.
● ID of the agent whose skill queue is adjusted by an

inspector.

Reset But
ton

Reset search criteria.

Search But
ton

Search for skill queue adjustment records.
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Element Typ
e

Description

But
ton

Search for data based on search criteria again and refresh
data on the page.

Adjust
Service
Account

Lab
el

● Business account of the agent who adjusts a skill queue.
● Business account of an inspector.

Adjust
Agent
WorkNo

Lab
el

● ID of the agent who adjusts a skill queue.
● Agent ID of an inspector.

Adjusted
Service
Account

Lab
el

● Business account of the agent whose skill queue is
adjusted.

● Business account of the agent whose skill queue is
adjusted by an inspector.

Adjusted
Agent
WorkNo

Lab
el

● ID of the agent whose skill queue is adjusted.
● ID of the agent whose skill queue is adjusted by an

inspector.

Adjust
Time

Lab
el

Time when a skill queue is adjusted.

Skill
Queue
Before
Adjustme
nt

Lab
el

Skill queue to which an agent has signed in before skill queue
adjustment.

Skill
Queue
After
Adjustme
nt

Lab
el

Skill queue to which an agent signs in after skill queue
adjustment.

 

----End

3.7.10 Viewing Identity Authentication Records
An agent or a tenant administrator can query identity authentication details.

Prerequisites
The agent has the Identity Authentication Record menu permission.

Procedure
Step 1 Sign in to the AICC as a tenant administrator and choose Work Log > Auth Log.

Step 2 Set search criteria to search for identity authentication records based on the
criteria.
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Figure 3-37 Auth Log page

Table 3-9 GUI elements on the Auth Log page

Element Typ
e

Description

Time Dro
p-
do
wn
list

The options are as follows:
● 1 Day
● 3 Days
● 7 Days
● Customization

Account Tex
t
box

Business account of the agent who performs identity
authentication. Advanced search criterion.
Whether this parameter is displayed is determined by the
Querying All Authentication Records permission. Agents
without this permission cannot view this parameter. By
default, a tenant administrator has this permission.

Employee
ID

Tex
t
box

ID of the agent who performs identity authentication.
Advanced search criterion.
Whether this parameter is displayed is determined by the
Querying All Authentication Records permission. Agents
without this permission cannot view this parameter. By
default, a tenant administrator has this permission.

Call S/N Tex
t
box

Call SN. Advanced search criterion.

Customer
Number

Tex
t
box

Customer number. Advanced search criterion.

Authentic
ation
Result

Dro
p-
do
wn
list

Search criterion.
● Not returned
● Pass
● Fail
● Error

Reset But
ton

Reset search criteria.

Search But
ton

Search for identity authentication records.
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Element Typ
e

Description

But
ton

Search for data based on search criteria again and refresh
data on the page.

Account Lab
el

Business account of the agent who performs identity
authentication.

Employee
ID

Lab
el

ID of the agent who performs identity authentication.

Call S/N Lab
el

Call SN.

Customer
Number

Lab
el

Customer number.

Authentic
ation
Time

Lab
el

Time when identity authentication is performed.

Authentic
ation
Mode

Lab
el

Identity authentication mode.

Authentic
ation
Result

Lab
el

Identity authentication result.
● Not returned
● Pass
● Fail
● Error

 

----End

3.7.11 Performing Identity Authentication
During a call with the customer, an agent can initiate an authentication process to
authenticate the customer identity.

Prerequisites

To send identity authentication requests, the tenant administrator has configured
and enabled identity authentication modes on the Configuration Center >
Expansion and Integration > Authenticate page.

Procedure

Step 1 Sign in to the AICC as an agent.

Step 2 Click  on the Call page when answering a call or making an outbound call.
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The identity authentication record can be queried on the Work Log > Auth Log
page.

----End

3.7.12 Viewing Customer Information
An agent can view customer information on the audio and video workbench.

Context
The contact customer information area on the agent workbench displays
information about the customer who makes the inbound call. The data sources of
this area are as follows:

● Call-associated data
● Information dataset (data of the connected outbound call API)
● Local data (customized data table)

Procedure
After a customer makes an inbound call, the audio and video workbench displays
the customer information.

Figure 3-38 Customer Information

3.7.13 Managing Documents
An agent can search for documents of the current tenant space by page based on
criteria, or invalidate, preview, or download documents.

Prerequisites
● The agent must have the Document Management menu permission and the

Download Document, Preview Document, and Operation All Documents
operation permissions.

● Operations in 3.6.2 Sending an Electronic Document Link have been
completed.

Procedure

Step 1 Sign in to the AICC as an agent and choose Contact History > Document
Management.

Step 2 Set search criteria to search for documents based on the criteria.
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Figure 3-39 Document Management page

Table 3-10 GUI elements on the Document Management page

Element Typ
e

Description

Searching
for
Documen
t Names

Tex
t
box

Document name.

Caller
Number

Tex
t
box

Search criterion.
● When an agent initiates a call, the calling number is an

access code.
● When a customer initiates a call, the calling number is a

customer number.

Called
Number

Tex
t
box

Search criterion.
● When an agent initiates a call, the called number is a

customer number.
● When a customer initiates a call, the called number is an

access code.

Documen
t Status

Dro
p-
do
wn
list

Document status. Advanced search criterion.
● Unsigned
● Signed
● Expired

Signature
Date

Dro
p-
do
wn
list

Signature date. Advanced search criterion.

Reset But
ton

Reset search criteria.

Search But
ton

Search for document management records.

But
ton

Search for data based on search criteria again and refresh
data on the page.
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Element Typ
e

Description

Caller
Number

Lab
el

● When an agent initiates a call, the calling number is an
access code.

● When a customer initiates a call, the calling number is a
customer number.

The calling number can be displayed anonymously. If the
User numbers are displayed in plaintext permission is
available, the number is displayed in plaintext. Otherwise, the
number is displayed anonymously. By default, a tenant
administrator has the User numbers are displayed in
plaintext permission. If anonymous display is required, you
are advised to create a tenant administrator role, deselect the
User numbers are displayed in plaintext permission for the
role, and assign it to the tenant administrator.

Called
Number

Lab
el

● When an agent initiates a call, the called number is a
customer number.

● When a customer initiates a call, the called number is an
access code.

The called number can be displayed anonymously. If the User
numbers are displayed in plaintext permission is available,
the number is displayed in plaintext. Otherwise, the number
is displayed anonymously. By default, a tenant administrator
has the User numbers are displayed in plaintext
permission. If anonymous display is required, you are advised
to create a tenant administrator role, deselect the User
numbers are displayed in plaintext permission for the role,
and assign it to the tenant administrator.

Documen
t Status

Lab
el

Document status.
● Unsigned
● Signed
● Expired

Documen
t Name

Lab
el

Document name.

Signature
Date

Lab
el

Date when a document is signed.

Update
Date

Lab
el

Date when a document is re-signed.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1300



Element Typ
e

Description

Operation Lab
el

● Invalidation
Select the document to be invalidated and click
Invalidation.

● Download
Select the document to be downloaded and click
Download.
NOTE

The downloaded documents contain personal data. Exercise
caution when handling the downloaded documents to prevent
personal data leakage and abuse.

● Preview
Select the document to be previewed and click Preview.

 

----End

3.7.14 Creating Harassment Records

Context

In the following scenarios, an agent can create a harassment record for a
customer and submit the record to the tenant administrator or other personnel
with the permission for review. After the record is approved, the customer is added
to the special list.

● An agent is in a two-party voice or video call with a customer.
● An agent is in an SMS or email chat with a customer.
● An agent views the SMS or email session history on the online chat

workbench.

Procedure

Step 1 Sign in to the AICC as an agent.

Step 2 Click  on the workbench page during a conversation with a customer.
● Special List Type: The options are Black List and Red List.
● Reason for Joining: The value can contain a maximum of 1024 characters.

NO TE

– Customers who behave uncivilly can be added to the blacklist.

– VIP customers can be added to the redlist.

Step 3 Click Save.

To query harassment records, choose Configuration Center > Resource
Management > Harassment Record.

----End
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3.7.15 Editing Customer Information
An agent can edit customer information on the voice and video workbench and
online chat workbench during or after a session with a customer.

Prerequisites
● The Customer Center feature has been enabled for the tenant space.
● This area is displayed only when the Customer Center feature is enabled and

the tenant parameter Display Unified Customer Contact Information is set
to Yes.

Procedure

Step 1 View basic information on the workbench during a session between an agent and
a customer.

Step 2 Click  to configure basic information.

Table 3-11 GUI elements on the page for configuring basic information

Element Type Description

Name Text box Customer name.
The value is a string of 0 to 80 characters.

gender Option
button

Customer gender.
● Male
● female
● Information not available

Phone Text box Customer mobile number.

Click  on the right to add a mobile
number. A maximum of three mobile
numbers can be configured.
The value is a string of 0 to 20 characters.

Email Text box Customer email address.

Click  on the right to add an email
address. A maximum of two email
addresses can be configured.
The value is a string of 0 to 128 characters.

Company Text box Company to which a customer belongs.
The value is a string of 0 to 80 characters.

Address Drop-
down
list

Contact address of a customer.
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Element Type Description

AddressDetail Text box Detailed contact address of a customer.
The value is a string of 0 to 80 characters.

Remark Text box Customer information description.
The value is a string of 0 to 80 characters.

 

Step 3 Click Create.

After the customer information is created, you can query it on the Customer
Center > Customer Center Management page.

----End

3.7.16 Querying Sign-In Records
An agent or tenant administrator can query and export agent sign-in and sign-out
logs.

Prerequisites
The agent has the permission to export sign-in logs.

Procedure

Step 1 Sign in to the AICC as an agent or a tenant administrator and choose Work Log >
Sign-In Log.

Step 2 Set search criteria to search for sign-in logs based on the criteria.

Figure 3-40 Sign-In Log page
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Table 3-12 GUI elements on the Sign-In Log page

Element Typ
e

Description

Time Dro
p-
do
wn
list

The options are as follows:
● 1 Day
● 3 Days
● 7 Days
● Customization

But
ton

Search for data based on search criteria again and refresh
data on the page.

But
ton

Add a sign-in log export task.

But
ton

View sign-in log export tasks.

Account Lab
el

Business account.

Employee
ID

Lab
el

Agent ID.

Operation
Type

Lab
el

Operation type.
● Sign Out
● Forcible Sign In
● Forcible Sign Out
● Sign In

Operation
Time

Lab
el

Operation time.

Result Lab
el

Operation result.
● Successful
● Failed

Sign-In IP
Address

Lab
el

IP address of the PC for signing in to the Customer Service
Cloud.

Failure
Reason
Code

Lab
el

Failure cause code.

 

Step 3 Export sign-in logs.

1. Click . The New export task dialog box is displayed.

2. Enter a customized compression password.
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The compression password must contain letters, digits, and the following
special characters: @#$%^&*+|=~!?,.:;-_'"(){}[]/><
The compression password is a string of 8 to 12 characters.
If the tenant parameter Whether to set a password for compressing exported
data is set to No, an export task can be created without entering the
compression password.

3. Click OK.

Step 4 View export tasks.

1. Click . The Export task view dialog box is displayed.
2. Download the sign-in logs of a task whose Task Status is Success.
3. After the download is successful, open the exported file and enter the

compression password to view the exported sign-in logs.
If the tenant parameter Whether to set a password for compressing exported
data is set to No, you can directly open the file without entering the
compression password.

----End

3.7.17 Performing Screen Recording for Agents
After an agent installs the VRC client on the local PC, the AICC automatically
starts the screen recording task when the agent status changes from the idle state
to the state processing voice and video calls. After the call is released, the system
automatically stops the screen recording.

Prerequisites
The screen resolution must meet the following requirements:

The resolution is within the range from 1024 pixels x 768 pixels to 1920 pixels x
1080 pixels based on the actual aspect ratio of the screen. The width resolution
must be a multiple of 4, and the height resolution must be a multiple of 2.
Otherwise, screens cannot be recorded.

It is recommended that the resolution be 1920 pixels x 1080 pixels to ensure
screen recording clarity.

Procedure

Step 1 Install the VRC client.

1. Sign in to the AICC as an agent.
2. Click the business account in the upper right corner of the page and choose

Personal Center.
3. On the Agent Info tab page, click Download VRC to obtain the VRC

installation package.
4. Decompress the VRC installation package VRC.zip on the local PC.

It is recommended that the Client_update_pack directory be a level-2
directory. The path cannot be too long and cannot contain Chinese characters.
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5. Right-click VRCService\Client_update_pack\client_update_script.bat and
choose Run as administrator.

6. Create a shortcut for the VRC application.

a. Go to the VRCService folder, for example, D:\VRCService.
b. Right-click the vrc_service_tray.exe file and choose Create shortcut. The

vrc_service_tray.exe - Shortcut file is generated.
7. Configure the VRC to automatically start upon system startup.

a. Open the system startup directory. Windows is used as an example:

i. Press Win+R to open the Run window.
ii. Enter shell:startup and click OK.

b. Copy the vrc_service_tray.exe -Shortcut file generated in Step 1.6 to the
startup directory.

8. Change the local port number of the VRC.

a. Edit the D:\VRCService\Client_update_pack\package\vrc.ini file.
b. Add ListenPort=8024 under [common].

The port number must be available. Run the netstat -ano | findstr :8024
command in the CLI on Windows to check whether the port number is
occupied.
The port number must be the same as the value of the tenant parameter
VRC WebSocket Port.

9. Right-click on the taskbar of the desktop and choose Task Manager to open
the task manager and click the Startup menu. If vrc_service_tray is displayed,
the VRC is successfully configured to automatically start upon system startup.

10. During the first startup, run vrc_service_tray as an administrator and view the
vrc.log file. The information shown in Figure 3-41 is displayed.

Figure 3-41 Successful startup

Step 2 Log in to the AICC as an agent and click .

After the sign-in is successful, the following dialog box is displayed.

----End

Follow-up Procedure

Step 1 Initiate a voice call and a video call.

Step 2 Choose Contact History > Contact in the AICC.

Step 3 Find the contact records of the voice and video calls.
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Step 4 After you click Play in the Recording File column corresponding to the contact
record of the voice call, the agent's screen operation video is displayed.

Step 5 After you click Play in the Recording File column corresponding to the contact
record of the video call, the Recording File Details dialog box is displayed. Then,
after you click Play corresponding to the record whose Media Type is VRC, the
agent's screen operation video is displayed.

----End

3.7.18 SmartCare Fault Demarcation

Context
● If the inbound customer on the audio and video workbench is a customer

with common issues, a SmartCare quick fault demarcation task is
automatically created. The agent can also manually create a SmartCare quick
fault demarcation task on the audio and video workbench and online chat
workbench.

● If the problem of the customer is not solved through quick demarcation, the
agent can create an in-depth demarcation task on the audio and video
workbench and online chat workbench.

Prerequisites
● The SmartCare feature has been enabled for the tenant.
● The language for the tenant is within the value range of the system

parameter Languages supported by the SmartCare.
● The system has been interconnected with SmartCare. For details, see 2.3.3.15

Configuring SmartCare Integration Information.
● The Case 2.0 feature has been enabled for the tenant before an in-depth

demarcation task is created.

Procedure

Step 1 Sign in to the AICC as an agent.

Step 2 Create a SmartCare quick fault demarcation task.

1. Click  on the right of the workbench. The SmartCare Fault Boundary
page is displayed.

2. Click Modify to create a quick fault demarcation task.
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Figure 3-42 Quick fault demarcation task creation page

Table 3-13 GUI elements on the quick fault demarcation task creation page

Element Ty
pe

Description

Fault
number

Tex
t
box

Customer mobile number.
The value consists of 1 to 64 characters.

Fault
tracing
duration

Tex
t
box

The demarcation start time equals this period earlier than
the current system time.
Value range: 1 to 168 hours
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Element Ty
pe

Description

Longitud
e

Tex
t
box

Longitude where a fault occurs.
Value range: [-180, 180]. A maximum of six decimal
places are allowed.

Latitude Tex
t
box

Latitude where a fault occurs.
Value range: [–90, 90]. A maximum of six decimal places
are allowed.

Radius Tex
t
box

Radius of the longitude and latitude where the fault
occurs.
The unit of this parameter is meter and the value of this
parameter is a non-negative integer. The maximum value
of this parameter is controlled and verified by SmartCare.

 
3. Click Confirm.

After the task is successfully created, Figure 3-43 is displayed.

Figure 3-43 Quick fault demarcation

The quick fault demarcation result is queried through invocation every 5
seconds using a timer. When the result is queried, the timer stops. A
maximum of 20 automatic queries can be performed. The agent can also click
retry to query the quick fault demarcation result immediately. Figure 3-44
shows a quick fault demarcation result.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1309



Figure 3-44 SmartCare quick fault demarcation result
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Step 3 Create a SmartCare in-depth fault demarcation task.

1. Click  or  on the workbench.

 is available only when the Intelligent order filling feature is enabled.
2. Select a case type based on service requirements on the Select Work Order

Type page that is displayed.
3. Click Yes when "Are you creating a ticket that needs to initiate a fault deep

boundary task to aid in ticket processing?" is displayed.
4. Set the in-depth fault demarcation task parameters by referring to Table

3-13.
5. Click Confirm, and the Case Information page containing the

SmartCareTaskID parameter and its value is displayed on the right.

----End

3.7.19 Intelligent Case Filling
When an agent creates a case on the workbench, the system automatically
extracts the information contained in the text of the conversation between the
customer and agent and fills the information in the corresponding case form to
complete the case filling task, reducing manual case filling workload of the agent.

Prerequisites
● The Intelligent order filling, Case 2.0, AppCube, Customer Center, and

Intelligent Agent (the number of intelligent agents is greater than 0)
features have been enabled for the tenant space.

● The tenant administrator has enabled the Intelligent order filling feature for
agents on the Agent Management page.

● The tenant space administrator has set Enabling the Intelligent TT Filling
Feature to Yes on the Configuration Center > System Management >
Tenant Parameter page.

● The tenant administrator has completed 2.6.6.1 Building the Intelligent
Case Filling Service Based on a Small Language Model.

● 2.11.3.1 Configuring SMS Gateways and 2.11.3.2 Configuring Email
Gateways have been completed.

Procedure

Step 1 Click  on the workbench as an agent.

Step 2 Select a case type based on service requirements on the Select Work Order Type
pop-up window that is displayed.

The system automatically extracts information contained in the text of the
conversation between the customer and the agent and provides top 3 case types
for the agent to select from.

Step 3 Select a case type, the Case Information page is displayed on the right of the
workbench.
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Step 4 Configure the case content.

Table 3-14 GUI elements on the Case Information page

Element Typ
e

Description

Automati
c
extraction

But
ton

After this switch is turned on, the Case Type, Case Title, and
Case Description fields can be automatically configured.

Case Type Dro
p-
do
wn
list

Case type associated with a case.
The options are all case types configured on the
Configuration Center > Case Configuration 2.0 > Case
Configuration > Case Type page of the tenant space.

Case Title Tex
t
box

Short description of a case.
This parameter can contain a maximum of 128 characters.
The system automatically extracts information contained in
the text of the conversation between the customer and the
agent and sets this parameter.

Case
Descriptio
n

Tex
t
box

Case details.
This parameter can contain a maximum of 20,000 characters.
The system automatically extracts information contained in
the text of the conversation between the customer and the
agent and sets this parameter.

Deadline Tim
e
sele
ctio
n
con
trol

End time of a case.

Priority Dro
p-
do
wn
list

Priority of a case.
The options are as follows:
● Low
● Medium
● High
● Critical

Source Dro
p-
do
wn
list

Source of a case.
The options are as follows:
● Voice
● Whatsapp
● Web
● Email
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Element Typ
e

Description

Associate
d
Customer

Dro
p-
do
wn
list

Customer associated with a case.
The options are customers configured on the Customer
Center > Customer Center Management page.

Assignme
nt Mode

Opt
ion
but
ton

Assignment mode.
The options are as follows:
● Manually
● Auto

Automatic assignment is performed based on the case
assignment rule on the Configuration Center > Case
Configuration 2.0 > Case Configuration > Case
Assignment Rule page.

Owner
Type

Opt
ion
but
ton

Owner type.
The options are as follows:
● Case Queue: Assign the case to a group.
● Agent: Assign the case to an agent.
This parameter can be configured only when Assignment
Mode is set to Manually.

Owner Dro
p-
do
wn
list

Case owner.
● When Owner Type is set to Case Queue, select the case

queue configured on the Configuration Center > Case
Configuration 2.0 > Case Configuration > Case Queue
page.

● When Owner Type is set to Agent, select an employee in
the tenant space.
If Claim is selected, the owner is the creator of the current
case by default.

This parameter can be configured only when Assignment
Mode is set to Manually.

Attachme
nt

But
ton

Uploading an attachment.
The attachment supports the following formats: JPG, PNG,
PDF, JPEG, GIF, DOC, and DOCX. A maximum of five
attachments can be uploaded, and the size of an attachment
cannot exceed 5 MB.

Refill But
ton

Invoking an LLM to extract the information contained in the
text of the conversation between the customer and the
agent.
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Element Typ
e

Description

Customer
Notificati
on

Che
ck
box

Whether to notify associated customers and the notification
mode.
The options are as follows:
● Customer Notification--Email
● Customer Notification--SMS
The corresponding email address or mobile number of the
customer to be notified need to be configured on the
Customer Center > Customer Center Management page.

 

Step 5 Click Save.

----End

3.7.20 Creating a Case by One Click
An agent can click Create Case on the workbench to create a case.

Prerequisites

The Case 2.0 feature has been enabled for the tenant space.

Procedure

Step 1 Click  on the workbench as an agent.

Step 2 Select a case type based on service requirements on the Select Work Order Type
pop-up window that is displayed.

The system automatically extracts information contained in the text of the
conversation between the customer and the agent and provides top 3 case types
for the agent to select from.

Step 3 Select a case type, the Case Information page is displayed on the right of the
workbench.

Step 4 Configure the case content.

Table 3-15 GUI elements on the Case Information page

Element Typ
e

Description

Case Type Dro
p-
do
wn
list

Case type associated with a case.
The options are all case types configured on the
Configuration Center > Case Configuration 2.0 > Case
Configuration > Case Type page of the tenant space.
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Element Typ
e

Description

Case Title Tex
t
box

Short description of a case.
This parameter can contain a maximum of 128 characters.
The system automatically extracts information contained in
the text of the conversation between the customer and the
agent and sets this parameter.

Case
Descriptio
n

Tex
t
box

Case details.
This parameter can contain a maximum of 20,000 characters.
The system automatically extracts information contained in
the text of the conversation between the customer and the
agent and sets this parameter.

Deadline Tim
e
sele
ctio
n
con
trol

End time of a case.

Priority Dro
p-
do
wn
list

Priority of a case.
The options are as follows:
● Low
● Medium
● High
● Critical

Source Dro
p-
do
wn
list

Source of a case.
The options are as follows:
● Voice
● Whatsapp
● Web
● Email

Associate
d
Customer

Dro
p-
do
wn
list

Customer associated with a case.
The options are customers configured on the Customer
Center > Customer Center Management page.
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Element Typ
e

Description

Assignme
nt Mode

Opt
ion
but
ton

Assignment mode.
The options are as follows:
● Manually
● Auto

Automatic assignment is performed based on the case
assignment rule on the Configuration Center > Case
Configuration 2.0 > Case Configuration > Case
Assignment Rule page.

Owner
Type

Opt
ion
but
ton

Owner type.
The options are as follows:
● Case Queue: Assign the case to a group.
● Agent: Assign the case to an agent.
This parameter can be configured only when Assignment
Mode is set to Manually.

Owner Dro
p-
do
wn
list

Case owner.
● When Owner Type is set to Case Queue, select the case

queue configured on the Configuration Center > Case
Configuration 2.0 > Case Configuration > Case Queue
page.

● When Owner Type is set to Agent, the options are all
employees in the tenant space.
If Claim is selected, the owner is the creator of the current
case by default.

This parameter can be configured only when Assignment
Mode is set to Manually.

Attachme
nt

But
ton

Uploading an attachment.
The attachment supports the following formats: JPG, PNG,
PDF, JPEG, GIF, DOC, and DOCX. A maximum of five
attachments can be uploaded, and the size of an attachment
cannot exceed 5 MB.

Customer
Notificati
on

Che
ck
box

Whether to notify the associated customer and the
notification mode.
The options are as follows:
● Customer Notification--Email
● Customer Notification--SMS
The corresponding email address or mobile number of the
customer to be notified needs to be configured on the
Customer Center > Customer Center Management page.

 

Step 5 Click Save.

----End
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3.7.21 Searching for Satisfaction Statistics
An agent can search for agent satisfaction statistics.

Prerequisites

The agent has the Satisfaction Statistics operation permission.

Procedure

Step 1 Sign in to the AICC as an agent and choose Contact History > Satisfaction
Statistics.

Step 2 Set search criteria to search for agent satisfaction statistics based on the criteria.

Figure 3-45 Satisfaction Statistics page (Daily report)

Figure 3-46 Satisfaction Statistics page (Weekly report)

Figure 3-47 Satisfaction Statistics page (Monthly report)

Table 3-16 GUI elements on the Satisfaction Statistics page

Element Typ
e

Description

Dro
p-
do
wn
list

Satisfaction statistics report type.
The options are as follows:
● Daily report
● Weekly report
● Monthly report

Cal
end
ar
co
mp
one
nt

Time range. Search criterion.
● When Daily report is selected, the maximum time range

for the search is 31 days.
● When Weekly report is selected, the maximum time

range for the search is 12 weeks.
● When Monthly report is selected, the maximum time

range for the search is 12 months.
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Element Typ
e

Description

Employee
ID

Tex
t
box

Agent ID. Search criterion.

Skill
Queue

Dro
p-
do
wn
list

Skill queue. Search criterion.
This parameter is displayed only when Skill Queue Summary
is selected.

Media
Type

Dro
p-
do
wn
list

Media type. Search criterion.
The options are as follows:
● Voice
● Video
● Multimedia
This parameter is displayed only when Skill Queue Summary
is selected.

Multimed
ia Type

Dro
p-
do
wn
list

Multimedia type. Search criterion.
The options are as follows:
● Web
● WeChat
● Facebook
● X(Twitter)
● 5G
● Email
● Line
● Whatsapp
● TELEGRAM
● INSTAGRAM
● SMS
This parameter is displayed only when Media Type is set to
Multimedia.

But
ton

Search for data based on search criteria again and refresh
data on the page.

But
ton

Create an export task.

But
ton

View export tasks.
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Element Typ
e

Description

Date Lab
el

Date of a record in the daily satisfaction statistics report.
This parameter is displayed only when Daily report is
selected.

Week Lab
el

Week of a record in the weekly satisfaction statistics report.
This parameter is displayed only when Weekly report is
selected.

Month Lab
el

Month of a record in the monthly satisfaction statistics
report.
This parameter is displayed only when Monthly report is
selected.

Employee
ID

Lab
el

Agent ID.

Agent
Name

Lab
el

Agent name.

Account Lab
el

Business account bound to a skill queue.

Skill
Queue ID

Lab
el

Skill queue ID.
This parameter is displayed only when Skill Queue Summary
is selected.

Skill
Queue
Name

Lab
el

Skill queue name.
This parameter is displayed only when Skill Queue Summary
is selected.

Score 1
Qty

Lab
el

Number of times that the satisfaction evaluation result
scored 1 in a skill queue.

Score 2
Qty

Lab
el

Number of times that the satisfaction evaluation result
scored 2 in a skill queue.

Score 3
Qty

Lab
el

Number of times that the satisfaction evaluation result
scored 3 in a skill queue.

Score 4
Qty

Lab
el

Number of times that the satisfaction evaluation result
scored 4 in a skill queue.

Score 5
Qty

Lab
el

Number of times that the satisfaction evaluation result
scored 5 in a skill queue.

Average
Score

Lab
el

Average score of satisfaction evaluation results in a skill
queue.

 

Step 3 Export satisfaction evaluation statistics to the local server in batches.
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1. Click  and enter a compression password.

NO TE

– For details about the complexity requirements of the compression password, see
the prompt on the page. The compression password is used to open the
downloaded package.

– The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

2. Click  to view the export tasks in the last seven days. To open a file, you
need to enter the compression password set during export task creation.

----End

3.8 Managing Inspection Results
This section describes inspection management. An agent can manage inspection
results.

3.8.1 Viewing Manual Inspection Results and Applying for
Inspection Reviews

An agent can view the inspection result and apply to an inspector for a review if
the agent has any doubts about the rating items.

Applying for Manual Inspection Reviews

Step 1 Choose Inspection > Task Result.

Step 2 Set search criteria and click Search to obtain the search result. Click Reset to clear
the existing search criteria.

Step 3 Click Details corresponding to a record. On the Manual Inspection tab page,
obtain the rating details.
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Step 4 Click Request For Review, set the application reason, and submit the application.

Figure 3-48 Review application page

Step 5 You can also click the Review task tab on the My To Do page, and click a task
name to quickly access the review task page.

Figure 3-49 Quick entry

Figure 3-50 Review task page

----End
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Follow-up Procedure
After an agent submits a review application, an inspector reviews the rating items
again based on the agent's requirements. After the inspector reports the review
result, the agent can view the review result on the same page.

No matter whether the review application is approved, the agent cannot submit it
again.

3.8.2 Appealing Against AI Inspection Results
An agent can view AI inspection results and provide materials to initiate appeals if
the agent has any doubts.

Procedure

Step 1 Sign in to the CEC as an agent and choose Inspection > Call List. The brief search
criteria and inspected call list are displayed.

Step 2 Click View in the Operation column to view the inspection details.

Step 3 Click Initiate Appeal. The dialog box for initiating an appeal is displayed.

Figure 3-51 Initiate Appeal
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Select the rules to appeal against and the appeal supervisor, and click Submit. A
message is displayed, indicating that the appeal is successfully submitted and that
you need to wait for the manual review result.

----End

Follow-up Procedure
● After an agent submits an appeal, an inspector reviews the rating items again

based on the agent's requirements. After the inspector submits a review
result, the agent can view the result on the same page.

● After the appeal process ends, a common agent can submit an appeal again
no matter whether the appeal is approved or not.

3.8.3 Requesting the Review of an Inspection Result
An agent can request the review of an inspection result.

Procedure

Step 1 Sign in to the CEC as an inspected agent and choose Inspection > Task Result.

Step 2 Click Details corresponding to an inspection result. The inspection result details
page is displayed.

Step 3 Click Request For Review, enter a review reason, and submit the request. An
inspector will receive your review request.

Figure 3-52 Request for Review

Step 4 (Follow-up operation) Sign in to the CEC as an inspector, choose Inspection >
Review Mgmt, and click Details corresponding to a review request. On the page
that is displayed, reject or approve the review request. You can also view review
requests in the My To Do area on the home page.
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Figure 3-53 Review task

----End

3.8.4 Handling AI Inspection Appeals
After inspectors perform AI inspections, they can review the AI inspection appeals
submitted by agents and update inspection results.

Scenario
Inspectors can view the inspected call list, click View to view the inspected call
details, or modify the inspection result and view the inspection process by title on
the Appeal Details page.

Procedure
Step 1 Sign in to the CEC as an inspector using an allocated business account.

Choose Inspection > Appeal List. The Appeal List page is displayed.
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Step 2 In the inspected call list opened in Step 1, click View. The appeal details page is
displayed. (Closed appeals can only be viewed but cannot be handled.)

Step 3 In the Inspection Rule area, modify the inspection result of a pending appeal.

Step 4 Click Modify. The dialog box for modifying the inspection result is displayed. You
can select Compliance or Violation to modify the result. The Remarks field is
mandatory. Click OK to submit the operation, or click Cancel to cancel the
operation.
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Step 5 View the appeal handling process which varies according to the operator's title.

The following figure shows the appeal handling process.

Figure 3-54 Appeal handling process

----End

3.9 Typical Scenarios
This section describes some typical scenarios of operations performed by an agent.

3.9.1 Customer and Agent Chatting Through the Web Channel

Scenario
A customer communicates with agent A through the web channel to query the
call fee balance, and then rates the service after the conversation ends.
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Procedure
A customer communicates with agent A through the web channel.

Step 1 Sign in to system on the connection bar and set the agent to the idle state.

Step 2 Open the customer conversation window.

1. Choose Configuration Center > Access Configuration > Channel
Configuration, click Edit corresponding to the new web channel, save the
modification, and click Try on the Channel Integration tab page.

2. On the page that is displayed, click  in the lower right corner.
3. In the Customer Service dialog box, enter the chat content, click Send, and

check the reply of the agent.
If the chat content entered by the customer contains keywords configured for
agents, the agent identifies the keyword and replies to it. If the key word
cannot be identified, the agent replies, for example, "Sorry, I cannot
understand."

NO TE

– If the message of a customer fails to be sent, the  icon is displayed before the
message. You can click the icon to re-send the message.

– When having a conversation with an agent, the customer can use the emoji
emoticons provided by the system.

The conversation window of the customer is as follows.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1327



The online chat workbench of agent A is as follows.
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NO TE

– In the Current area, the chat content between the customer and agent is
displayed. If the customer has historical conversations with an agent, the historical
conversation records of the customer can be displayed in Current.

– When the content entered by an agent is used in a historical conversation, the
system automatically associates and displays related historical content for the
agent to select, improving the business handling efficiency.

4. Click  in the online chat dialog box that is displayed, click Evaluate to
rate the service of the current agent, including satisfaction score and content
evaluation, and then click Submit.
The customer can only evaluate the services of agents who have at least one
dialog with the customer in the web channel. During and after a dialog, the
customer can evaluate the services at any time. The last evaluation is used.

----End

3.9.2 Making Calls Using the WebRTC Phone

Context
The web real-time communication (WebRTC) uses a web browser to transmit
texts, files, videos, and voices in real time.

Currently, the WebRTC feature supports voice and video calls.

Prerequisites
● The tenant status is normal, and the WebRTC feature is not enabled.
● You have allowed the browser to obtain the microphone permission by

performing the following steps:

a. Choose Start > Settings > Privacy > Microphone.
b. In Allow access to the microphone on this device, click Change and

enable Microphone access for this device.
c. Enable Allow apps to access your microphone.

● (Optional) You have allowed the browser to obtain the camera permission. If
video calls are required, perform the following operations:
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a. Choose Start > Settings > Privacy > Camera.
b. In Allow access to the camera on this device, click Change and enable

Camera access for this device.
c. Enable Allow apps to access your camera.

Procedure

Step 1 Sign in to the AICC as the system administrator.

Step 2 Enable the intelligent agent function for a tenant administrator.

1. Choose Call Center > Tenant Management.
2. Select a tenant for whom the WebRTC function is to be enabled and click

Edit.
3. Click the Virtual Call Center tab and enable WebRTC in the Feature

Selection area.
4. In the Allocate Resource area, set Agent registration server type to

webRTC and set Agent registration server.
5. After the configuration, click Save.

----End

NO TE

The WebRTC is supported for the CTI pool mode. If the selected call center is in pool mode,
you need to add more than one WebRTC gateway for provisioning agents. In addition, more
than one WebRTC gateway needs to be configured for agents.

Verification

Step 1 Sign in to the AICC as an agent for whom the WebRTC feature is enabled.

NO TE

The agent must meet the following requirements:
● The agent has not been bound to a fixed-line phone or mobile phone.
● The agent has been bound to voice-related skill queues (including voice, video, voice

click-to-dial, and video click-to-dial skill queues).

Step 2 On the connection bar, click  and click Register.  is displayed after the
softphone is manually registered.
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NO TE

● When you sign out, the two phones sign out at the same time.
● After you sign out, the softphone status changes to unregistered.
● If the softphone number unified authentication feature is enabled for the tenant and

Authentication Mode is set to Unified authentication for the agent, the agent cannot

click  to perform registration. If Authentication Mode is set to UAP Authentication

for the agent, the agent can click  to perform registration.
● After you click Sign In, the softphone is automatically registered.
● In pool mode, there are two phones that share the same password. If the registration is

successful, the status of the two phones is registered. If either of them fails, you can
click the phone to register again.

●  is displayed if the WebRTC phone fails to be registered, or the WebRTC phone is
registered successfully and then deregistered.

Step 3 Initiate a voice call.

1. Click , enter a softphone number, and make a call. The call can be a voice
call.

NO TE

– A WebRTC phone can make outbound calls only when it is registered and the
agent has signed in.

– When you dial the number for the first time, the message "xxx.xxx.xxx.xxx wants to
use your microphone" is displayed. Click Allow.

2. Click Answer to answer a ringing call as an agent. The customer's phone then
rings and waits for the customer to answer the call.
The WebRTC phone is in talking state and displayed in green, and the agent is
in occupied state.

Step 4 Initiate a video call.

1. Click , enter a softphone number, and make a call. The call can be a video
call.

NO TE

– A WebRTC phone can make outbound calls only when it is registered and the
agent has signed in.

– When you dial the number for the first time, the message "xxx.xxx.xxx.xxx wants to
use your microphone" is displayed. Click Allow.

2. Click Answer to answer a ringing call as an agent. The customer's phone then
rings and waits for the customer to answer the call.
The WebRTC phone is in talking state and displayed in green, and the agent is
in occupied state. The following figure shows a video call.
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Only the local video window is displayed.

Click  on the connection bar to share a specified area, which can be:
– Entire screen
– Application window
– Browser tab page

NO TE

– In pool mode, either of the two phones is used randomly.

– Pay attention to personal privacy protection during desktop sharing.

3. (Optional) After the video call is connected, check whether the following page
is displayed.

: Disable the camera.

: Zoom in the window.

: Hide the video window and display the call duration ( ).

: Display the fullscreen video window.

: Switch to a voice call or resume a video call. Click the button for
switching between voice and video calls on the connection bar and select a
video call.

: Mute yourself and click again to unmute yourself.
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: Hang up the current call.

Step 5 Answer a call from a user.

1. When a user dials the access code of a skill queue, the agent waits for about
two seconds and automatically answers the call.

2. When a user dials the access code of an IVR device and the call is transferred
to an agent, the agent automatically answers the call 2 seconds after the user
hears the announcement.

NO TE

In pool mode, an agent talks with a phone randomly. The agent enters the busy state
and does not answer other calls.
If a user directly makes a call to an idle phone, the call is directly disconnected.

----End

Follow-up Procedure

Click  to monitor the call quality.

For details about the call quality, see Table 3-17 and Table 3-18.

Table 3-17 Network level description

Network
Level

Ico
n

Packet Loss Rate Jitter One-way
Delay

Good < 0.1% < 10 < 40 ms

Medium < 1% < 20 < 100 ms

Poor < 5% < 60 < 400 ms

 

NO TE

The lowest network level determined based on the packet loss rate, jitter, and one-way
delay is used as the network level.
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Table 3-18 Data source description

Data Type Calculation Method Description

Packet loss rate Number of packets received by
the local end in 1s = Total
number of packets received by
the local end – Total number of
packets received by the local end
1s ago
Number of packets sent by the
remote end in 1s = Total number
of packets sent by the remote
end – Total number of packets
sent by the remote end 1s ago
Packet loss rate = (Number of
packets sent by the remote end
in 1s – Number of packets
received by the local end in 1s)/
Number of packets sent by the
remote end in 1s

The agent
acts as the
recipient.

Jitter Jitter = Receive jitter of the local
end

One-way delay One-way delay = Round-trip
time/2

 

If the tenant parameter Whether to send internal messages when the WebRTC
network is abnormal is set to Yes, an internal message is sent to notify the OU
manager when the network quality is poor. Only one internal message can be sent
within 60 minutes.

3.10 Viewing Training Tasks
Intelligent training tasks can be used to periodically train and test agents through
IVR flows to check the business skills of the agents.

3.10.1 My Training Tasks
Agents can view training tasks that have been started and participate in tasks as
required.

Procedure

Step 1 Sign in to the AICC as an agent and click Sign In. The agent enters the sign-in
state.

Step 2 Choose Business Training > My Tasks.
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Step 3 Select a training task and click the task name to view the task details.

Step 4 Click Start Training to participate in the training task and wait for the system to
make a training outbound call.

----End

Follow-up Procedure
Click Answer Records to view the answer details of the training task.

3.11 Intelligent Outbound Call Tasks
Based on the assigned outbound call tasks, agents make outbound calls and
configure outbound call results.

3.11.1 Agent Outbound Call Task
A tenant administrator executes the outbound call task through the agent
outbound call task and views the outbound call result.

3.11.1.1 Introduction to the Outbound Call Task of an Agent
An outbound call agent performs outbound call–related operations in the
outbound call task of the agent.

The agent outbound call task supports the following outbound call-related
operations:

● 3.11.1.2 Manually Making an Outbound Call
– Retrieving/Releasing a number
– Viewing the number list
– Calling the current number

● 3.11.1.3 Viewing and Executing a Previewed Outbound Call
● 3.11.1.4 Viewing a Predicted Outbound Call
● 3.11.1.5 Viewing a Preempted Outbound Call
● 3.11.1.6 Creating a Reserved Outbound Call Task
● 3.11.1.7 Adding a Customer Number to the Blocklist
● 3.11.1.8 Changing an Outbound Number
● 3.11.1.9 Viewing Outbound Call Results: This function is supported for

manual, previewed, predicted, and preempted outbound calls.
● Viewing a reserved outbound call

Prerequisites
If your tenant space is in trial commercial use, outbound calls can only be made to
five numbers. Therefore, you need to ask the system operation personnel to add
the numbers to be called to the trustlist. Only in this way can you make outbound
calls.
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3.11.1.2 Manually Making an Outbound Call

After an administrator creates a manual outbound call task, an agent can refer to
this section to perform operations related to manual outbound calls in the
outbound call task.

Prerequisites

The administrator has created a manual outbound call task for a specified agent
and started the task.

Procedure

Step 1 Sign in to the AICC as an outbound call agent.

Step 2 Choose Outbound Call > Agent Call.

Figure 3-55 Agent outbound call task

Step 3 Click a task to view its details.

Step 4 Click Extract. The outbound call data can be extracted only when the outbound
call data is not extracted by other agents and the outbound call task is being
executed.

Step 5 Click Number List to view the outbound number list as described in the following
table.

Table 3-19 Elements in the outbound number list

Element/Component Description

Called Number Outbound number, which is anonymized.

Operation Currently, the Call button is available.

 

Step 6 Click Call to send a dial-up request to the customer number.
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NO TE

An outbound call can be made only when the following conditions are met: The outbound
call data is not complete and has been locked, the agent has signed in and is in idle state,
and the outbound call task is being executed. If a call fails, it is initiated again until it
succeeds or the maximum number of call attempts is reached.

Step 7 After the call ends, view the outbound call result. For details, see 3.11.1.9 Viewing
Outbound Call Results.

----End

3.11.1.3 Viewing and Executing a Previewed Outbound Call

After an administrator creates a previewed outbound call task, an agent can refer
to this section to perform operations related to previewed outbound calls in the
outbound call task.

Prerequisites
● The administrator has created a previewed outbound call task for a specified

agent and started the task.
● The agent is in the idle state. The previewed outbound call task is configured

with outbound call data and has been started.

Procedure

Step 1 Sign in to the AICC as an outbound call agent.

Step 2 Choose Outbound Call > Agent Call.

Figure 3-56 Agent Call

Step 3 In the Executing a Preview Outbound Call dialog box, click Call to make an
outbound call.
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Figure 3-57 Executing a Preview Outbound Call

Table 3-20 GUI elements on the Executing a Preview Outbound Call page

Element/Component Description

Task Name Outbound call task name.

Customer ID Customer ID of the current previewed outbound
call.

Called Number Outbound number.

Operation Operations that can be performed.

 

Step 4 After the call ends, view the outbound call result. For details, see 3.11.1.9 Viewing
Outbound Call Results.

----End

3.11.1.4 Viewing a Predicted Outbound Call

After an administrator creates a predicted outbound call task, an agent can refer
to this section to perform operations related to predicted outbound calls in the
outbound call task.

Prerequisites
● The administrator has created a predicted outbound call task for a specified

agent and started the task.
● The agent is in the idle state. The predicted outbound call task is configured

with outbound call data and has been started.

Procedure

Step 1 Sign in to the AICC as an outbound call agent.

Step 2 Choose Outbound Call > Agent Call.
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Figure 3-58 Outbound call task page

Step 3 View the outbound call result. For details, see 3.11.1.9 Viewing Outbound Call
Results.

Table 3-21 GUI elements on the predicted outbound call result page

Element
/
Compon
ent

Ty
pe

Description Value
Range

Triggere
d Event

Remarks

Custome
r ID

La
bel

Unique ID of a
customer.

- Read-
only

-

Outboun
d Call
Status

La
bel

Outbound call
status.

● To Be
Execute
d

● Executi
ng

● Comple
ted

Read-
only

-

Start
Time

La
bel

Call start time. - Read-
only

-

End
Time

La
bel

Call end time. - Read-
only

-

Call
Result

La
bel

Call result. ● Failed
● Success

ful
● Reject

Read-
only

-

Cause La
bel

Call failure cause. - Read-
only

-
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Element
/
Compon
ent

Ty
pe

Description Value
Range

Triggere
d Event

Remarks

Business
Result

La
bel

Result of the
outbound call
business selected
by an agent.

● Success
ful

● Uncert
ain

● Failed

Read-
only

If this parameter
is empty, no
agent is set.

Sub-
status

La
bel

Sub-status of the
outbound call
business result.

- Read-
only

-

Business
Descripti
on

La
bel

Description of the
outbound call
business entered
by an agent.

- Read-
only

Business
description is
provided only for
manual,
predicted,
previewed, and
preempted
outbound calls.

Operatio
n

But
ton

Details of an
outbound call
result.

Details Click -

 

----End

3.11.1.5 Viewing a Preempted Outbound Call
After an administrator creates a preempted outbound call task, an agent can refer
to this section to perform operations related to preempted outbound calls in the
outbound call task.

Prerequisites
● The administrator has created a preempted outbound call task for a specified

agent and started the task.
● The agent is in the idle state. The preempted outbound call task is configured

with outbound call data and has been started.

Procedure

Step 1 Sign in to the AICC as an outbound call agent.

Step 2 Choose Outbound Call > Agent Call.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1340



Figure 3-59 Agent outbound call task

Step 3 Click the outbound call result in the row where the task is located. For details, see
3.11.1.9 Viewing Outbound Call Results.

----End

3.11.1.6 Creating a Reserved Outbound Call Task
This section describes how to create a reserved outbound call task.

Prerequisites
● The agent is speaking.
● The customer number is not in the blocklist.

Scenario Description
When an agent is executing an outbound call task, if the customer is busy and
wants to communicate with the agent at another time, the agent can create an
outbound call task and call the customer again at the time specified by the
customer.

Procedure

Step 1 Sign in to the AICC as an outbound call agent.

Step 2 Choose Outbound Call > Agent Call.
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Figure 3-60 Outbound call execution

Step 3 Click Reserved Outbound Call. The Create Reserved Outbound Call page is
displayed, as described in the following table.

Table 3-22 GUI elements on the Create Reserved Outbound Call page

Element/Component Description

Customer Number Number for which a call needs to be reserved.

Reserved Call Time Reserved call time.

Remarks Remarks of a reserved call.

 

Step 4 Enter the mandatory information and click Save. The reserved outbound call task
is added successfully.

----End

3.11.1.7 Adding a Customer Number to the Blocklist

Agents can add a customer or the current number of a customer to the blocklist in
an agent outbound call task.

Scenario Description

When an agent executes an outbound call task, if a customer does not want to be
called anymore, the agent can add the customer to the blocklist.

Procedure

Step 1 Sign in to the AICC as an outbound call agent.

Step 2 Choose Outbound Call > Agent Call.
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Figure 3-61 Outbound call execution

Step 3 Click . The dialog box for adding a number to the blocklist is displayed. The
following table describes the GUI elements in the dialog box.

Table 3-23 GUI elements on the page for adding a number to the blocklist

Element/Component Description

Add blockList type The options are as follows:
● Number Type: A customer has multiple

numbers. Only the number is in the blocklist.
Other numbers can still be called.

● Customer Type: All customer numbers are
blocklisted.

Called Number Blocklisted number. This element is available only
when Add blockList type is Number Type.

Validity Time (Hour) Validity period of the blocklist, in hours. The value
ranges from 1 to 120. For example, if you enter 1,
the blocklist becomes invalid one hour after it is
created.

Remarks Blocklist remarks.
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Figure 3-62 Adding a number to the blocklist

Step 4 Set mandatory parameters and click Save. The number is added to the blocklist
successfully.

----End

3.11.1.8 Changing an Outbound Number
Agents can change the outbound call number of a customer in the outbound call
task.

Scenario Description
When an agent executes an outbound call task, if a customer wants the agent to
call another number, the agent can change the outbound number.

Procedure

Step 1 Sign in to the AICC as an outbound call agent.

Step 2 Choose Outbound Call > Agent Call.
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Figure 3-63 Outbound call execution

Step 3 Click . The window for changing the reserved outbound call number is
displayed. The GUI elements are as follows.

Table 3-24 GUI elements on the Changing Outbound Number page

Element/Component Description

Customer Number Customer number to be changed.

Remarks Remarks of a reserved call.

 

Figure 3-64 Changing Outbound Numbers

Step 4 Enter the mandatory information and click Save. The outbound number is
changed successfully.

----End
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3.11.1.9 Viewing Outbound Call Results

Agents can view the results of outbound call tasks that have been executed and
supplement or modify the business results.

Prerequisites

An outbound call task is executed, such as an agent outbound call task, a preview
outbound call task, or a predicted outbound call task.

Procedure

Step 1 Sign in to the AICC as an agent.

Step 2 Choose Outbound Call > Agent Call.

Step 3 Click the row where the task is located to view the outbound call result details.

Step 4 On the Outbound Call Result page, click Details.

Step 5 On the outbound call result details page, click Business Result to supplement or
modify the business result.

Table 3-25 GUI elements on the business result filling page

Eleme
nt/
Comp
onent

Description

Task
Name

Name of the manual or predicted outbound call for which the business
result is entered.

Result This parameter is controlled by the tenant parameter Only leaf nodes
can be selected for service results. If the parameter is set to Yes, only
leaf nodes can be selected.

Descri
ption

Business result description.

 

----End

3.11.2 Reserved Manual or Automatic Outbound Call
When a customer wants to be called at another time during an outbound call, an
agent can reserve a manual or automatic outbound call at the expected time so
that the agent can continue the talk with the customer at the expected time.

3.11.2.1 Viewing a Reserved Outbound Call

On the Reserved Call page, an agent can view the reserved manual and
automatic outbound calls associated with the agent.
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Prerequisites
The agent has the reserved outbound call task permission.

Procedure

Step 1 Sign in to the AICC as an agent. Choose Outbound Call > Reserved Call.

Step 2 View the reserved outbound calls of the current agent by reserved time in
ascending order.

Table 3-26 Parameters in the reserved outbound call list

Parameter Description

Customer Number Customer number to which a reserved call needs to
be made.

Reserved Call Time Reserved call time.

Associate Outbound
Call Task

Associated outbound call task.

Result Call result.
● Failed
● Successful
● Reject

Failure Cause Failure cause.

Reservation Status ● Reserved
● Prepare for callback (within 5 minutes before the

reserved time)
● Callback
● Completed
● Expired

Start Time Call start time.

End Time Call end time.

Remarks Remarks.

Business Result Path Business result of a call.

Business Description Description of a business result.

Reserved call tуре ● Reservation for manual outbound calls
● Reserve automatic outbound calls

Creator Creator.

Created On Time when a reserved outbound call is created.
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Parameter Description

Operation Operations that can be performed on the current call.
The options are as follows:
● Call
● Modify
● Delete
● Adjustment Record
● Business Result
● Survey Result (This button is available when the

outbound call task is associated with a survey.)

 

Step 3 Set search criteria based on Table 3-27, and click Search to search for reserved
outbound calls that meet the search criteria.

Table 3-27 Search criteria for searching for reserved outbound calls

Parameter Description

Customer Number Customer number.
Fuzzy search by suffix is supported.

Task Name Task name.

Start time of a reserved
call – End time of a
reserved call

Start time and end time of a reserved call.

Reset Reset the search criteria and refresh the list.

Search Search for reserved outbound calls.

 

Step 4 Click Modify, set Remarks, and click Save.

Step 5 Click Delete to delete a reserved outbound call record. Only numbers that have
not been used to make calls can be deleted.

----End

3.11.2.2 Adding a Reserved Outbound Call
An agent can reserve an outbound call so that the agent can perform the
outbound call task again at another time.

Prerequisites
● The reserved time must not be earlier than the current time.
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Procedure

Step 1 Sign in to the AICC as an agent and choose Outbound Call > Reserved Call.

Step 2 Click New.

Figure 3-65 Creating a reserved manual outbound call

Figure 3-66 Creating a reserved automatic outbound call

Step 3 Set mandatory parameters and click Save.

----End

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1349



3.11.2.3 Executing a Reserved Outbound Call
An agent can go to the Reserved Call page and execute a reserved outbound call
task during the reserved outbound call time. If the reserved outbound call task has
expired, the system reminds the agent to handle the task when the agent enters
the Agent Call page.

Context
The total number of reserved outbound call tasks that have expired and that of
reserved outbound call tasks that are about to expire within 5 minutes are
displayed and refreshed every minute on the Agent Call page to remind an agent
to handle the reserved outbound call tasks on the Reserved Call page promptly.

Procedure
Step 1 Sign in to the AICC as an agent. Choose Outbound Call > Reserved Call.

Step 2 Click Call corresponding to the reserved manual outbound call to be executed.

Figure 3-67 Reserved manual outbound call workbench

NO TE

The Call button is available only when a reserved outbound call has not been executed, and
the agent has signed in and is in idle state.

----End

3.12 OpenEye Help Document

3.12.1 OpenEye Help Guide
The OpenEye Desktop help guide provides description about login, system
settings, software functions, and personal data in the OpenEye Desktop.
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● Obtaining Help Information
● Installation Description
● Login and Logout
● Introduction to System Settings
● Introduction to Software Functions
● Description of Personal Data
● Uninstallation Description

3.12.2 Change History
Release Date Issue Description

2019-12-30 V1.0 This issue is the first official release.

2021-03-08 V1.1 This issue is the second official release.

2022-03-03 V2.0 This issue is the third official release.

2022-10-30 V2.0 This issue is the fourth official release.

2023-07-31 V2.0 This issue is the fifth official release.

2024-09-30 V2.0 This issue is the sixth official release.

 

3.12.3 Installation Description
● The requirements of installation scenarios are as follows:

a. Install the OpenEye directly. In this scenario, the OpenEye is not installed
before.

b. Upgrade the OpenEye. You need to uninstall the OpenEye of the original
version and install the new version.

● The requirements of installation environments are as follows:

a. Windows 10 or Windows 11 environment: 2-core, 2.6 GHz or higher CPU
and 4 GB memory or higher; .NET Framework 4.5.2 or later; and Visual C
++ runtime environment.
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If the .NET Framework 4.5.2 and Visual C++ plug-ins are not installed in the
installation environment, download the installation packages from the following
websites, double-click the installation packages, and install the plug-ins following
the installation steps.

● .NET Framework 4.5.2: https://dotnet.microsoft.com/en-us/download/dotnet-
framework/net452

Click the Runtime installation package in Offline installer for installation.

● Visual C++: https://learn.microsoft.com/en-us/cpp/windows/latest-supported-
vc-redist?view=msvc-170#visual-studio-2015-2017-2019-and-2022

Select the Visual Studio 2015 and Visual Studio 2010 installation packages
for installation.

b. China-made environment: Phytium Arm chip (D2000) + UOS V20 1050;
Zhaoxin x86 chip (4-core) + UOS V20 1050; or Phytium Arm chip (D2000)
+ Kylin V10 SP1.

c. Device requirements:

▪ CPU frequency: 2.3 GHz or above.

▪ Remaining memory: 4 GB or more memory and 1 GB or more free
memory.

▪ Available disk space: 1 GB or more free space in the /opt/apps
directory. If logs are continuously captured, it is recommended that
the space be 5 GB or above.

▪ Other devices: camera of 720p at 30 Hz, PC with built-in audio card,
and NIC of 100 Mbit/s or higher (1000 Mbit/s recommended).

● To obtain the OpenEye installation package, go to the AICC software
download page on the support website, click a desired AICC version, obtain
the OpenEye installation package based on the operating system version in
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the software list, decompress the OpenEye installation package, and obtain
the installation program.
– The installation package for the Windows operating system is

OpenEye_xx.c.zip, for example, OpenEye_V2.0.zip.
– The installation package for the UnionTech operating system is

openeye_x.x_amd64_uos.zip or openeye_x.x_arm64_uos.zip, for
example, openeye_2.0_amd64_uos.zip.

– The installation package for the Kylin operating system is
openeye_linux.zip or openeye_linux_x86.zip.

After obtaining the software package, you must verify the integrity of the
package. For details, see 3.12.3.3 Verifying Software Package Integrity. Only
verified software packages can be deployed.

NO TE

In the current version, the Authenticate Administrator function is supported in the general
settings of the OpenEye. If authentication is enabled, install the OpenEye as an
administrator.

3.12.3.1 Installation

3.12.3.1.1 Common Installation

Procedure

Step 1 Double-click OpenEyeSetup.exe to install the program. Select a language. You
can change the language later under Settings > General. Click OK.

Figure 3-68 Installation language

Step 2 Perform the installation according to the installation wizard. Click Next.
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Figure 3-69 Installation wizard

Step 3 Read the license agreements and click I Accept. If you do not accept the
agreements, click Cancel to end the installation.

Figure 3-70 License Agreement window

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1354



Step 4 The OpenEye provides a default installation path. Click Browse to change the
installation path.

Figure 3-71 Installation path

Step 5 Click Install. The program will be installed automatically. After the installation is
complete, you can modify some program settings.
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Figure 3-72 Installing the OpenEye

NO TE

Auto startup: Whether the OpenEye is automatically started upon system startup.

Service mode (without UI): If this option is selected, after the OpenEye is started, the
OpenEye window is hidden and the OpenEye icon appears in the task bar.

Enable answering mode change authentication: This option is selected by default. When
this option is selected, only the administrator can change Answering Mode in general
settings and select Ring for 0 Seconds Before Auto-answer. If this option is not selected,
common operators can also change Answering Mode.

Preset files: The version for Windows supports the preset files replacing configurations and
inbound call prompt tones during installation. The configured config.xml file is placed in
the directory where the installation program is located, and is automatically imported for
configuration when the installation is complete. The audio files are renamed (as In.wav for
the inbound call prompt tone and ring.wav for the RBT), placed in the \ring folder in the
directory where the installation program is located, and automatically replace the default
prompt tones when the installation is complete. Currently, WAV files are supported, in
PCMA, PCMU, or G.729 format or containing PCM data with the sampling precision of 8 or
16 bits and sampling rate of 8 kHz to 48 kHz. Dual channels are supported.

----End

3.12.3.1.2 Silent Installation

Procedure

Step 1 Optional: Open the CLI as an administrator and run the following commands to
go to the folder where the OpenEyeSetup.exe installation program is located.
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Figure 3-73 Commands for opening the installation program directory

NO TICE

The name of the path for storing the OpenEye installation package cannot contain
Chinese characters or special characters. Otherwise, the installation fails.

Step 2 Perform the installation.

● OpenEyeSetup.exe /S: silent installation in the default path

Figure 3-74 Command for installation in the default path

● OpenEyeSetup.exe /S /D=D:\xxxx\xxxx: silent installation in a specified
installation path

Figure 3-75 Command for installation in a specified path

● OpenEyeSetup.exe /S /A=1: silent installation in the default path, with the
answering mode change authentication enabled

Figure 3-76 Command for setting parameters for installation

● OpenEyeSetup.exe /S /A=1 /D=D:\xxxx\xxxx: silent installation in a specified
installation path, with the answering mode change authentication enabled

Figure 3-77 Command for setting parameters and specifying the installation
path

● OpenEyeSetup.exe /S /L=2052 /D=D:\xxxx\xxxx: silent installation in a
specified installation path, with the language set to English
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Figure 3-78 Command for setting the language and specifying the
installation path

● OpenEyeSetup.exe /S /A=1 /T=0 /D=D:\xxxx\xxxx: silent installation in a
specified installation path, with the answering mode change authentication
enabled and answering mode interval set

Figure 3-79 Command for enabling the answering mode change
authentication, setting the answering interval, and specifying the installation
path

● OpenEyeSetup.exe /S /WebMode=1 /AutoBoot=0: web integration mode set
to the service mode, with the auto startup upon system startup disabled

Figure 3-80 Command for setting the web integration mode to the service
mode and disabling the auto startup upon system startup

NO TE

● /S indicates silent installation.
● /A=1 indicates that answering mode change authentication is enabled.
● /D=Installation path indicates the specified installation path.
● /L=2052 indicates the language setting. 2052 indicates Chinese, 1033 indicates English,

1034 indicates Spanish, and 1054 indicates Thai. If this parameter is not set, the default
language of the operating system is used.

● /T=0 indicates that the answering interval is 0. If this parameter is not set, the default
interval (0) is used.

● /T takes effect on the OpenEye only when /A is set to 1.
● /WebMode=1 indicates that the web integration mode is set to the service mode. The

value 0 indicates the common mode where the program window is displayed after the
program is started. The value 1 indicates the service mode where the program window
is hidden and the program icon appears in the task bar after the program is started.

● /AutoBoot=0 indicates that the OpenEye is not started upon system startup. By default,
the OpenEye is started upon system startup. You can use /AutoBoot=0 to disable the
function.

Use spaces to separate parameters. /S is mandatory for silent installation. If you want to
specify an installation path, place /D as the last parameter in the installation command.
Otherwise, the parameters following /D are regarded as a part of the path.

----End

3.12.3.1.3 Chinese Version Installation

Step 1 Double-click the installation package to run the installation program
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Step 2 Click Install. (You may need to enter the computer user password for
authorization.)

Step 3 Complete the installation.
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----End

NO TE

● After the installation is complete, you can run DefaultWebMode.sh in the installation
directory to switch the program to the service mode (where the program window is
hidden and the program icon appears in the task bar after the program is started).

● If you run the sudo dpkg -i com.huawei.openeye*.deb command to install the
software, when the message "launch mode without UI: yes/no ?" is displayed, you can
enter yes to select the service mode.

3.12.3.2 Version Upgrade

3.12.3.2.1 Windows Version Upgrade

Overview

Version upgrade requires uninstalling the original version and installing the new
version.

You can perform the upgrade in either of the following ways:

● Overwrite upgrade: Overwrite the original OpenEye client, which retains the
original configuration.

● Upgrade after uninstallation: Manually uninstall the original client and install
the new version. You can choose whether to retain the original client
configuration.
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Overwrite Upgrade

Step 1 Double-click OpenEyeSetup.exe to install the program. An uninstallation prompt
is displayed. Click OK to uninstall the OpenEye of the original version.

Figure 3-81 Uninstallation prompt

Step 2 Wait until the uninstallation is complete. After the uninstallation is complete,
install the new version. For details, see Procedure.

----End

Upgrade After Uninstallation

Step 1 Manually uninstall the OpenEye program of the original version.

You can choose either of the following ways as required:

● Click the Start button, go to Settings > Apps, find the OpenEye application in
the installed application list, and click Uninstall to manually uninstall it.

● Go to the OpenEye installation directory, for example, C:\Huawei\OpenEye.

Double-click the uninstallation program  to manually uninstall it.

Step 2 Confirm the uninstallation and click OK.

Figure 3-82 Information confirmation

Step 3 When the uninstallation is complete, select Do you want to delete all user data?
and click Finish.
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Figure 3-83 Uninstalling the program

Step 4 Double-click OpenEyeSetup.exe to run the installation program. For details, see
Common Installation.

----End

3.12.3.2.2 Upgrade for Chinese Version

Overwrite Upgrade

Step 1 Double-click the com.huawei.openeye_2.0.0-1_arm64.deb installation program.
A message is displayed, indicating that the same version has been installed. Click
Reinstall.
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Step 2 In the displayed dialog box, enter the password and click Confirm.
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Step 3 Complete the installation.

----End
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3.12.3.3 Verifying Software Package Integrity

To prevent software packages from being tampered with or damaged during
transmission, which may threaten the carrier network security, you need to verify
the integrity of the software packages after obtaining them. Software packages
can be deployed only after they pass the verification.

Context

Each software package and its signature file are stored in the same directory. Each
software package corresponds to a verification file, which is used to verify the
integrity of the software package. To download the digital signature file of a
software package, click pgp or cms corresponding to the software package on the
support website.

● You can click pgp to download a signature file in .asc format for manually
verifying the integrity of a software package. To use a software package
independently, you need to manually verify the integrity of the software
package. For details, see Procedure.

NO TE

This method can be used to verify the integrity of all software packages.

● You can click cms to download a signature file in .p7s format for
automatically verifying the integrity of a software package. You need to
import a software package together with its CMS signature for the NMS or
deployment tool to verify the digital signature.

Procedure

Step 1 Visit https://support.huawei.com/carrierindex/en/hwe/index.html.

Step 2 Download OpenPGP Signature Verification Guide.

The download URL is https://support.huawei.com/carrier/docview!docview?
nid=PK100000008.

Step 3 Verify software package integrity by referring to OpenPGP Signature Verification
Guide.

----End

Troubleshooting

If a software package fails the verification, do not use the software package, and
contact Huawei technical support.

3.12.4 Help Information Obtaining

3.12.4.1 Obtaining Help Information

To obtain the help document, select the OpenEye client software and press F1.
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3.12.5 Login and Logout
The login module of the OpenEye client software provides the functions of login,
logout, password remembering, and automatic login.

NO TE

The login module does not provide the password change function. The UAP server does not
provide the API function interface for changing user passwords. Therefore, the client based
on the API function interface of the UAP server cannot implement this function. From the
perspective of customer requirements, no agent can proactively change phone account
passwords of a carrier's businesses. Phone accounts are created by an administrator in a
unified manner, and passwords are set and changed by the administrator.

3.12.5.1 Login

Prerequisites
You have completed the configurations in Settings > Server Settings.

Procedure

Step 1 Double-click the OpenEye and enter the softphone number and password on the
login page. You can select Remember Password or Auto Login as required. Click
Log In.
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Figure 3-84 Login page

Before logging in to the Chinese version and making anonymous calls, select
Agree Huawei Privacy Policy.
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Figure 3-85 Login Page - Chinese Version

Step 2 Log in to the OpenEye workspace page. If the login fails, a dialog box is displayed,
prompting you to change the account or password.
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Figure 3-86 OpenEye workspace

----End

3.12.5.2 Remember Password
The Remember Password function is supported on the login page. You can select
Remember Password to save the password so that you do not need to enter the
password in the next login.
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Figure 3-87 Remember Password

3.12.5.3 Auto Login
The Auto Login function is supported on the login page, which takes effect after
the login is successful. The login information used for the successful login are
automatically used for the next login to the OpenEye.
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Figure 3-88 Auto Login

NO TE

You can select both Remember Password and Auto Login or only one of them.

3.12.5.4 Login Status
NO TE

After login, a dot is added to the logo on the home page. The login status is displayed in
green, red, or gray respectively. Move the pointer to the logo on the home page. A dialog
box is displayed, indicating IP address:Port number of a server. The registration status (dot
in different colors) is displayed. The server registration status is displayed in green or gray.
In pool networking, the registration status of all servers is displayed. In non-pool
networking, only the status of the server registered successfully is displayed.
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Logo displayed (green, red, and gray) after successful login is as follows.

Figure 3-89 Logo on the home page

Login status is as follows.

Figure 3-90 All servers are registered and logged in

Figure 3-91 Red: some servers failed to be registered or logged in

Figure 3-92 All servers are offline

Elements in the server status dialog box:

IP address:Port number

Figure 3-93 Green: registration successful; gray: registration failed

All servers are offline, the login status turns gray, and a dialog box is displayed,
indicating that the servers are offline.
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After the login, when you move the cursor over the OpenEye icon in the task bar,
an infotip is displayed, showing the server registration status. Reg indicates that
the registration is successful while UnReg indicates that the registration fails.
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3.12.5.5 Logout

After login, you can click  on the workspace to log out of the system and
return to the login page.

Figure 3-94 Logout

3.12.6 Introduction to System Settings
The OpenEye client allows customers to customize some system parameters to

meet personalized requirements. You can click  to go to the setting page and
set parameters.
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3.12.6.1 Server Settings
Server settings support the pool networking mode and common server setting
mode.

Figure 3-95 Settings page

● Common networking: single-server configuration. The configuration
information is as follows:
– Server: Select a server from the drop-down list. A maximum of five

servers can be configured.
– Name: server name
– IP: IP address of the server
– Port: port number of the server
– Backup IP: IP address of the backup server
– Backup Port: port number of the backup server
– Registration Heartbeat Interval: The default value is 150. The minimum

value is 30, which is half of the login expiration time.
– Transport Mode: UDP and TLS modes are supported.
In TLS transmission mode, you can choose whether to enable Enable Chinese
cryptographic algorithm and Media Encryption.
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To use the TLS transmission mode, you need to configure the certificates and
keys in the config.xml file in the program installation directory.

● Pool networking: One account can be used to log in to multiple servers at the
same time. Currently, a maximum of four servers are supported. In this mode,
the login account can answer inbound calls from any server in the pool. When
an outbound call is made, the first server set in the pool is used as the
primary server. That is, only the account on the first server set in the pool can
be used to make outbound calls.

Figure 3-96 Configuring the pool networking
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NO TE

● The minimum heartbeat interval that can take effect is determined by the
minimum login expiration time configured on the connected server.

● Server setting operations are not allowed during a call. To set server information,
log out of the OpenEye.

● After the registration is successful, the OpenEye sends Option messages every 30
seconds to keep the UDP port alive. Maintenance personnel can modify Option
message sending configuration in the config.xml file as follows: Add
<optionInterval value="30" /> under the configuration/settings node.
optionInterval value indicates the interval. If it is set to 0 or a value greater than
or equal to the registration heartbeat interval, Option messages are not sent. The
minimum interval is 10 seconds. If optionInterval value is set to a value less than
10, Option messages are sent every 10 seconds.

3.12.6.2 General Settings
General settings of the OpenEye allow you to set the language, answering mode,
shortcut key for screenshots, path for saving screenshots, and screenshot format.

Figure 3-97 General settings 1 (administrator)
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Figure 3-98 General settings 2
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Figure 3-99 General settings 3
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Figure 3-100 General settings 4
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Figure 3-101 General settings 5

● Auto startup
Set whether the OpenEye starts with the Windows OS. This function is
disabled by default.

NO TE

You can enable the OpenEye auto startup function for the China-made environment
on the Settings page.

● Language Setting
Simplified Chinese and English are supported. The setting takes effect after
restart. The default language is simplified Chinese.

● Answering Mode
– If the answering mode change authentication is enabled:

When an administrator logs in to the OpenEye, the Authenticate
Administrator switch is displayed and Answering Mode can be changed.
Figure 3-97 shows the details.
A common operator cannot change the answering mode.
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– If the answering mode change authentication is disabled:
Both the administrator and common operators can change Answering
Mode and Authenticate Administrator is not displayed.

a. Ring for N Seconds Before Auto-hangup
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The system automatically releases an inbound call after the preset
waiting time. N is the waiting time configured by users, in seconds. The
default value is 120. The recommended value ranges from 1 to 120.

b. Ring for N Seconds Before Auto-answer
The system automatically answers an inbound call after the preset
waiting time. N is the waiting time configured by users, in seconds. The
default value is 3. The recommended value ranges from 1 to 120.

NO TE

If this parameter is set to 0, the call is automatically answered and no message is
displayed.

c. Do Not Disturb
The system will not notify you of calls from any contact or unknown
person and will automatically reject the calls.

● Reject Button in Inbound Call Notification
This function is enabled by default. If this function is disabled, the Reject
button in the lower right corner of the Inbound Call Notification window is
hidden.

Figure 3-102 Inbound Call Notification - the Reject button displayed

Figure 3-103 Inbound Call Notification - the Reject button hidden

● Pin to Top of Main Window
After this function is enabled, the main window can be displayed on the top
and is not covered by other windows. This function is disabled by default.

● Allow Empty Password
When this function is disabled, if the password text box is empty, the login
request is rejected and no login request is sent to the server. After this

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1383



function is enabled, the system does not check whether the password text box
is empty. Instead, the system sends a login request to the server for password
verification. This function is disabled by default.

NO TE

● By default, the Allow Empty Password function is disabled. If this function is
enabled, security risks exist. Exercise caution when enabling this function.

● Auto Audio-Video Switch
When the voice call mode is changed by the agent, the OpenEye does not
display a confirmation dialog box and automatically switches the call mode.
This function is disabled by default.

● Conference Sharing
The UAP's screen sharing function for self-developed video conferences is
supported. By default, this option is not selected and cannot be modified after
login.
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After this option is selected, if the UAP provides the self-developed conference
function, a user dials the access number to connect to an agent. The agent shares the
screen and the image is displayed on the customer video call page.

If the UAP does not provide the self-developed conference function, the customer
cannot view the screen being shared, and the call is not affected.

● Call Ended Hint

This function is disabled by default. After this function is enabled, a prompt
tone is played when the called party ends the call.

● Audio device detection prompt

This function is enabled by default. If this function is disabled, no dialog box is
displayed when no audio device is detected.

● Video device detection prompt
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This function is enabled by default. If this function is disabled, no dialog box is
displayed when no video device is detected.

● Minimize to System Tray

NO TE

This function is disabled by default. If you have enabled this function, click  in
the main window, the main window is minimized and the taskbar icon is not
displayed.

Selecting Minimize window in the When closing the main window area has the
same effect.

● When closing the main window
When the main window is closed, the program supports the following status:
– Close program
– Minimize window
– No prompt next time

● Log setting
– Log path: The value is the Documents directory of the user.
– Log collect: After you click this button, the OpenEye logs are

automatically collected and saved to the path specified by Log path.
● Auto Clear

Expired logs are deleted every 24 hours or when the OpenEye is started. By
default, this function is enabled and logs generated 15 days ago are deleted.

● Screenshot Shortcut Key
The shortcut keys can be customized. The default shortcut key is LeftCtrl+Q.
– Reset: Restore shortcut key settings to default.

● Screenshot Saving Path
The saving path can be customized. Click Modify to configure the saving path
or click Open to open the folder for storing screenshots.

● Screenshot Saving Format
The OpenEye screenshots can be in JPG or PNG format. The default format is
JPG.

● Disable camera in video call
During a video call, images can be used to replace the actual scenario. By
default, the local camera is enabled.

● Pic path when disable camera
When the Disable camera in video call function is disabled, this function is
disabled by default. When the Disable camera in video call function is
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enabled, the image configured in this function is used by default. Click Set to
update the image path.

NO TE

1. After the display language is changed, you must restart the system for the setting to
take effect. You are advised not to change the language during business handling.

2. Shortcut key settings may conflict with that of the operating system or other software.
In this case, shortcut keys will fail to be set. You need to set shortcut keys again until
they are set successfully.

3.12.6.3 Media Settings
Media settings allow you to set the audio devices, video devices, video quality,
video resolution, and virtual camera.

NO TE

The client of the Chinese version does not support the following functions:
● Virtual Camera
● Replace Background
● Beautification

Figure 3-104 Media setting 1
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Figure 3-105 Media setting 2
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Figure 3-106 Media setting 3
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● Audio Input
After deselecting Use the default device, you can manually select an audio
input device.
When the volume of the system microphone is lower than the threshold or
the device is muted, the OpenEye displays a corresponding message. The
mute switch can be used to mute the system microphone.

NO TE

1. If the audio input volume is configured, the system automatically decreases the
volume to an appropriate level when the volume of the collected audio input of the
microphone is too high.
2. Click the microphone icon before the volume slider to mute or unmute the
microphone during a call (only for calls, not for devices).
3. The mute setting function is not implemented in the Chinese version.

● Audio Output
After deselecting Use the default device, you can manually select an audio
output device.

● Ringing volume and Call volume
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NO TE

1. Set the ringing volume and call volume separately.
2. When there is an inbound or outbound call, the speaker volume is the preset
ringing volume. If the call is not connected, the speaker volume is restored to the call
volume after the ringing.
3. Click the speaker icon before the slider which adjusts the ringing volume to mute or
unmute the ringtone for inbound calls.
4. Click the speaker icon before the slider which adjusts the call volume to mute or
unmute the speaker during a call (only for calls, not for devices).
5. The mute setting function is not implemented in the Chinese version.

You can adjust the volume of the system device. Click the speaker icon on the
left of the volume bar to mute the system speaker.
When the volume of the system speaker is lower than the volume alarm
threshold or the device is muted, the OpenEye displays a corresponding
message.

● Input Gain, Output Gain
The decibel values of the input and output audio are increased.

● Codec param
Audio data codec format supported by the local end during a call. If this
option is deselected, the local media capability does not support the
corresponding codec during signaling negotiation.

● Audio VAD
After this function is enabled, data packets are sent only when human voices
are detected during audio calls using the G.711 encoding format. This reduces
bandwidth usage.

● Video Device

Multiple types of video devices are supported. Click  to preview the
image quality of the video device.

● Video policy
The Quality and Smoothness policies are supported.
If you select Quality, the system ensures image quality first during video
communication. If you select Smoothness, the system ensures image
smoothness first during video communication.

● Resolution
Customers can select a proper resolution based on the network condition.
1080p, 720p, and 360p are supported. 1080p is used by default.

● Virtual Camera
After this function is enabled, screen sharing (mainstream transmission),
video background replacement, and beautification are supported in SFU
mode.

NO TE

When the CPU has fewer than four cores or multiple instances are started, the
function is not displayed.
The graphics card driver must support OpenGL 4.5.
This function is not supported in the Chinese version.
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● Share Screen
– MCU mode: Data is shared through substream transmission.
– SFU mode: Data is shared through mainstream transmission.

● Replace Background
After this function is enabled, the background image of the local video will be
replaced with the preset image during a video call.

● Beautification
Whitening and Skin Smoothing are supported. The beautification degree can
be adjusted as required.

3.12.6.4 Introduction to Permission Settings
The OpenEye supports the creation of management accounts to control some
operation permissions. (If a management account is created for multiple times,
only the latest one takes effect.)

The password contains 8 to 16 characters and must contain at least two types of
the following characters: lowercase letters, uppercase letters, digits, and special
characters. The password cannot be the same as the account.

3.12.6.4.1 Permission Settings - Windows Version

Create a management account:

Open the cmd window as an administrator, switch to the OpenEye installation
directory, and run the KmcToolkit.exe addAdmin command.

Enter the username, password, and confirm password as prompted.

Permission settings:

After a management account is added, the Permission Settings page is displayed
when the system administrator starts the OpenEye.
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The Authenticate Administrator option is selected by default. If this option is
selected, authentication is required for opening the Settings window and exiting
the program.

The Login control option is deselected by default. If this option is selected,
authorization is required for modifying the login account and setting automatic
login.

The password can be changed if the Change Administrator Password option is
selected.
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3.12.6.4.2 Permission Settings - Chinese Version

Create a management account:

Run the ./AddAdmin.sh command in the OpenEye installation directory.

Enter the username and password and confirm the password as prompted. Set
parameters in the configuration information as follows:

Permission settings:

After a management account is added, the Permission page is displayed when the
system administrator starts the OpenEye.

Permissions can be set after the management account is authorized.
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The Permission control option is selected by default. If this option is deselected,
all operations do not need to be authorized.

The Setting option is deselected by default. Enter settingctrl=y to enable this
function when adding a management account. If this option is selected,
authentication is required for opening the Settings window.

The Logout option is deselected by default. Enter logoutctrl=y to enable this
function when adding a management account. If this option is selected,
authentication is required for logout.

The Exit option is deselected by default. Enter exitctrl=y to enable this function
when adding a management account. If this option is selected, authentication is
required for exiting the program.

The Login option is deselected by default. Enter loginctrl=y to enable this
function when adding a management account. If this option is selected,
authentication is required for modifying the login account and setting automatic
login.

Separate multiple configuration parameters with spaces.

The authorization is valid until the program is restarted and the authorization can
be canceled.

The password of the management account can be changed.
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3.12.6.5 About
You can query the OpenEye version information, including the version ownership
and legal liability.

Figure 3-107 About
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3.12.7 Introduction to Software Functions
The OpenEye supports voice communication, video communication, and call
record functions.

● Voice communication provides functions of initiating calls, answering calls,
hanging up calls, adjusting call volume, and holding calls.

● Video communication makes communication between customers and agents
more entertaining.

● Call records store detailed call information. Other operations can also be
performed in call records, such as initiating a call.

3.12.7.1 Voice Communication
The OpenEye supports functions of initiating calls, answering calls, rejecting calls,
hanging up calls, and adjusting call volume.

3.12.7.1.1 Initiating a Call

A voice call can be initiated by dialing a number or from call records. For details
about how to initiate a call from call records, see 3.12.7.3.3 Initiating a Call.

Procedure

Step 1 Start the OpenEye client and enter the account and password to log in to the
OpenEye workspace.

Step 2 On the Workspace tab and enter the called number as required.
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Figure 3-108 OpenEye workspace

Step 3 Click  to make a voice call.

Step 4 After the customer answers the call, the agent can talk with the customer.

----End

NO TE

When entering a called number, you can click  to delete a character each time or
press the Delete or Backspace key to delete one or more characters.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1398



3.12.7.1.2 Answering a Call

An inbound call can be answered. The inbound call can be displayed on the home
screen or as an inbound call notification. A voice call can be answered in either of
the two methods.

● Home page: Click  to answer the call.

Figure 3-109 Call page

● Inbound Call Notification: Click  to answer the call.
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Figure 3-110 Inbound Call Notification

3.12.7.1.3 Rejecting a Call

An inbound call can be rejected. The inbound call can be displayed on the home
screen or as an inbound call notification. A voice call can be rejected in either of
the two methods.

● Home page: Click  to reject the call.
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Figure 3-111 Call page

● Inbound Call Notification: Click  to reject the call.

Figure 3-112 Inbound Call Notification
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3.12.7.1.4 Hanging Up a Call

During a voice call, you can click  to end the call.

Figure 3-113 Voice call window

3.12.7.1.5 Adjusting Volume

After an inbound call is answered, the volume of the microphone and speaker can
be adjusted to ensure that the call is smooth.
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Procedure

Step 1 During a voice call, click  to access the function area and adjust the
volume.

Step 2 Click  and drag the dot in the volume slider to adjust the microphone
volume.

Figure 3-114 Adjusting the microphone volume

Step 3 Click  and drag the dot in the volume slider to adjust the speaker
volume.

Figure 3-115 Adjusting the speaker volume

Step 4 (Optional) Click  to mute the microphone. In this case, the other party

cannot hear your voice. Click  to unmute the local microphone for
talking with each other.

----End
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3.12.7.1.6 Initiating an Anonymous Call

The local number can be hidden using the anonymous call function.

NO TE

● To enable the anonymous call function, set isvalid to true in the /configuration/
settings/anonymousSetting/setting section in the userconfig.xml file in the program
installation directory.

Procedure

Step 1 On the login page of the OpenEye client, click Anonymous Call in the lower left
corner.

Figure 3-116 Initiating an anonymous call

Step 2 On the Anonymous call configuration panel, set the IP address and port number
of the SBC, and set the account to the anonymous card character string
configured on the UAP.
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Figure 3-117 Anonymous call configuration

Step 3 Click Log In and initiate a call on the workbench.

----End

3.12.7.2 Video Communication
The OpenEye supports video communication functions, including voice calls, video
calls, video window setting, screenshot, screen sharing, label, and virtual camera.

3.12.7.2.1 Initiating a Call

A video call can be initiated by dialing a number or from call records. For details
about how to initiate a call from call records, see 3.12.7.3.3 Initiating a Call.

Procedure

Step 1 Start the OpenEye client and enter the account and password to log in to the
OpenEye workspace.

Step 2 Click the Workspace tab and enter the called number as required.
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Figure 3-118 OpenEye workspace

Step 3 Click  to make a video call.
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Step 4 After the customer answers the call, the agent can talk with the customer through
the video call.

----End

NO TE

When entering a called number, you can click  to delete a character each time or
press the Delete or Backspace key to delete one or more characters.

3.12.7.2.2 Answering a Call

An inbound call can be answered. The inbound call can be displayed on the home
screen or as an inbound call notification. A video call can be answered in either of
the two methods.

● Home page: Click  to answer the call.

● Inbound Call Notification: Click  to answer the call.

3.12.7.2.3 Rejecting a Call

Video calls can be rejected. For details, see 3.12.7.1.3 Rejecting a Call.

3.12.7.2.4 Hanging Up a Call

During a video call, you can click  to end the video call.
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Figure 3-119 Video call window

3.12.7.2.5 Adjusting Volume

The procedure for adjusting the video volume is the same as that for adjusting the
voice volume. For details, see Adjusting Volume.

3.12.7.2.6 Enabling/Disabling a Camera

Local and peer cameras can be configured during a video call.
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Procedure

Step 1 During a video call, click  to access the function area and configure the
camera function.

Figure 3-120 Video call function area

Step 2 Set the peer camera.

● You can click  to disable the peer camera.
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● You can click  to enable the peer camera.

Step 3 Set the local camera.

● Click  to disable the local camera. The preset image for the
camera image is displayed on the peer client.

● Click  to enable the local camera.

----End

3.12.7.2.7 Window Mode Switching

The video call window supports the PiP and Align mode. The PiP mode is used by
default.

Procedure

Step 1 After the video call starts, click  to access the function area to switch the
window mode.

Step 2 In PiP mode, click  to switch to the Align mode.
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Figure 3-121 Align window

Step 3 In Align mode, click  to switch to the PiP mode.
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Figure 3-122 Pip window

----End

3.12.7.2.8 Window Size Switching

The video call window can be switched between the large and small windows to
optimize the video display.

Procedure

Step 1 During a video call, click  to access the function area and switch the
video window.
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Figure 3-123 Function area

Step 2 Click . The video page is displayed in a new window.

CEC
User Guide 3 Agent Guide(AICC)

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1413



Figure 3-124 Opening a new window

NO TE

After the window is switched, the video page is displayed on the OpenEye main page, and
the function area is moved to the new window.

Step 3 The video display supports the 16:9 and 4:3 ratios. You can click  to change
the mode.
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Figure 3-125 16:9 mode

Figure 3-126 4:3 mode

Step 4 Access the function area and click . The initial video page is displayed.

----End
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NO TE

Click the close button in the upper right corner to end the full-screen display and the
current video call. The workspace on the home page is displayed. Exercise caution when
performing this operation.

3.12.7.2.9 Full Screen

A video call can be displayed in full screen mode, and the OpenEye menu bar is
retained. The GUI can be displayed as required.

Procedure

Step 1 During a video call, click  to access the function area and choose the
full screen function.

Step 2 Click  to display the page in full screen mode.

Figure 3-127 Full Screen

Step 3 In full screen mode, you can exit from this mode in either of the following
methods.

● Return to the OpenEye home page.

In the function area, click  to access the home page of the OpenEye
and continue the video call.

● Switch to a new window.
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In the function area, click . A new window is displayed for the video.
For details about the new window, see 3.12.7.2.8 Window Size Switching.

● End the call.

----End

NO TE

Click the close button in the upper right corner to end the full-screen display and the
current video call. The workspace on the home page is displayed. Exercise caution when
performing this operation.

3.12.7.2.10 Screenshot

During a video call, a screenshot can be captured by clicking a button or pressing
shortcut keys. After the operation, the screenshot is automatically saved to the
specified path.

Procedure

Step 1 During a video call, click  to access the function area and choose the
screenshot function.

Step 2 Click  to capture a screenshot for the current window.
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Figure 3-128 Screenshot

Step 3 (Optional) You can also press the shortcut keys to capture a screenshot.

----End

NO TE

For details about how to set the path for storing screenshots, see Screenshot Saving Path.

For details about how to set the screenshot format, see Screenshot Saving Format.

For details about how to set shortcut keys for screenshots, see Screenshot Shortcut Key.

3.12.7.2.11 Screen Recording

A video call supports the synchronous screen recording function. During screen
recording, only the peer video window is displayed.
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Procedure

Step 1 During a video call, click  to access the function area and choose the
screen recording function.

Step 2 Click  to start the screen recording in the current video window.

Figure 3-129 Screen recording
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Step 3 Click  to stop screen recording.

----End

3.12.7.2.12 Screen Sharing

Screen sharing scope includes desktop, specified area, and specified application.
The sharing scope can be customized as required.

Procedure

Step 1 During a video call, click  to access the function area and choose the
screen sharing function.
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Figure 3-130 Screen sharing

Step 2 Click  and select an application to be shared.
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Figure 3-131 Selecting an application to be shared

Step 3 Share the screen.
● Desktop: The sharing scope is the entire local desktop.
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Figure 3-132 Sharing the desktop

● ShareRect: The sharing scope is the content covered by the green box. You
can drag the box to change the sharing scope as required.

Figure 3-133 Sharing a specified area

● Specified application: The sharing scope is the content in the selected
application window.
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Figure 3-134 Sharing a specified application

NO TE

An application that has been opened in the taskbar can be shared.
The Chinese version does not support sharing of specified areas.

Step 4 View the sharing duration, perform the labeling, stop sharing, and enable the
sound on the sharing menu bar that is displayed in the middle of the top of the
computer screen.

Step 5 Click  to stop the sharing.

Figure 3-135 Menu bar

----End

Follow-up Operations
During screen sharing, the peer client can switch to the full screen mode, and
minimize and maximize the screen.
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NO TE

During screen sharing, the peer end can only end the call to stop screen sharing.

3.12.7.2.13 Label Sharing

During screen sharing, you can customize labels as required.

Procedure

Step 1 Enable the sharing function during a video call by referring to 3.12.7.2.12 Screen
Sharing.

Step 2 On the sharing menu bar of a shared area, click .

Figure 3-136 Sharing labels on the desktop
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Figure 3-137 Sharing labels in a specified application

Figure 3 Sharing labels in a specified area

Step 3 Verify that label sharing supports the following functions:
● Whiteboard: Switch the background between the Whiteboard and Desktop

during labeling. After the background is switched, the previous labels are
cleared.

● Line: Select a line tool, such as a brush, straight line, arrow, dotted line, circle,
or rectangle, for labeling.

● Word: Insert text and adjust the size of the inserted text.
● Color: Select the color of lines and texts.
● Cancel: Cancel the last step.
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● Save: Save the current label screenshot. The save path is the same as that of
the video image screenshot. You can choose Settings > General > Screenshot
Saving Path to set the save path.

● Exit: Manually exit the labeling page.

----End

3.12.7.2.14 Replacing the Background

A video call supports background replacement. For privacy purposes, the video
background image can be replaced as required.

NO TE

The client of the Chinese version does not support the background replacement function.

Procedure

Step 1 After a video call starts, click  to access the function area and choose the
background replacement function.

Step 2 Click . The background image is replaced with the selected image
during a video call.

Step 3 Click  to return to the actual video background.

----End

NO TICE

For details about how to replace the background image, see Modify background.
If the background replacement image is not set, the background replacement
function does not take effect.

3.12.7.2.15 Beautification

A video call supports facial beautification for the local video. The beautification
settings include skin whitening and smooth. The beautification degree can be
adjusted as required.

NO TE

The client of the Chinese version does not support the beautification function.
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Procedure

Step 1 After the video call starts, click  to access the function area and choose
the beautification function.

Step 2 Click  to enable the beautification function.

Step 3 Click  to disable the beautification function.

----End

3.12.7.2.16 Initiating an Anonymous Call

You can initiate an anonymous voice call by referring to 3.12.7.1.6 Initiating an
Anonymous Call.

3.12.7.3 Call Records
Call records store detailed call information of a user. A user can also perform
related operations in call records, for example, initiating calls.

3.12.7.3.1 Viewing Call Records

Context
Call records are classified into the following types:

● Missed calls: calls that are not answered, marked with .

● Answered calls: calls that have been answered, marked with .

● Dialed calls: calls that have been dialed, marked with .

Procedure

Step 1 Start the OpenEye client and enter the account and password to log in to the
OpenEye workspace.

Step 2 Click the Call Records tab to view the call details.
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Figure 3-138 Call Records page

Step 3 View the call details.

● : View all calls.

● : View missed calls.

● : View outbound calls.

● : View inbound calls.

● : View the call quality analysis.
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Step 4 Click . The call quality analysis page is displayed, showing the quality of each
call.

Figure 3-139 Call Quality Analysis

----End

NO TE

A maximum of 200 call records can be stored on the local PC. If the number of call records
exceeds 200, the earliest call records are automatically deleted.
A maximum of 50 latest calls can be displayed in the Windows version, and a maximum of
20 latest calls can be displayed in the Chinese version.

3.12.7.3.2 Deleting or Clearing Call Records

You can clear call records in one-click mode, or delete a call record as required.
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Procedure

Step 1 Start the OpenEye client and enter the account and password to log in to the
OpenEye workspace.

Step 2 Choose Call Records to view the call details.

Step 3 Click  to delete all call records.

Step 4 Select a call record you want to delete and click  on the right to delete it. You
can delete unnecessary call records one by one.

Figure 3-140 Deleting a call record

----End

3.12.7.3.3 Initiating a Call

Voice calls and video calls can be initiated from call records.

Procedure

Step 1 Start the OpenEye client and enter the account and password to log in to the
OpenEye workspace.

Step 2 Click the Call Records tab to view the call details.

Step 3 Select a call record and click  to initiate a voice call. Click  to initiate a
video call.
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Figure 3-141 Initiating a call

----End

3.12.8 Description of Personal Data
During business operation or fault locating, the OpenEye Desktop platform
obtains or uses users' personal data listed in the following table. You are obligated
to formulate necessary user privacy policies and take sufficient measures based on
the laws of concerned countries to ensure that users' personal data is fully
protected.
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anonym
ized.
When a
user
does
not
select
Remem
ber
Passwo
rd, the
encrypt
ed
passwo
rd is
deleted.

Account
s and
passwo
rds in
operati
on logs
are
anonym
ized.
Operati
on logs
can be
directly
copied
from
the
installat
ion
path.
Encrypt
ed
passwo
rds
cannot
be
exporte
d.

Account
s and
passwo
rds in
operati
on logs
are
anonym
ized.
Operati
on logs
can be
directly
copied
from
the
installat
ion
path.
Encrypt
ed
passwo
rds
cannot
be
exporte
d.
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Usage
Scenari
o

Person
al Data
Collect
ed

Data
Collecti
on
Source
and
Metho
d

Purpos
e and
Securit
y
Protect
ion
Measur
e

Data
Storage
Period
and
Strateg
y

Data
Destruc
tion
Metho
d

Export
Metho
d (Such
as APIs
and
Comma
nds)
and
Export
Implem
entatio
n
Schem
e
(Anony
mity or
Pseudo
nym)

Export
Guide

ber
Passwo
rd and
Auto
Login
check
boxes.

Call
records

Call
duratio
n,
calling
number,
called
number,
and call
type

Call
records
of users
are
collecte
d and
stored
in the
databas
e.

Call
records
are
used for
user
service
apprais
al or
audit.
Call
records
are
encrypt
ed and
saved
in the
databas
e
provide
d by
the
softwar
e.

The
latest
200 call
records
are
recorde
d. The
OpenEy
e
Deskto
p
provide
s the
Clear
button
to clear
call
records.

The
OpenEy
e
Deskto
p
provide
s the
Clear
button
to clear
call
records.

Call
records
cannot
be
exporte
d.

Call
records
cannot
be
exporte
d.
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Usage
Scenari
o

Person
al Data
Collect
ed

Data
Collecti
on
Source
and
Metho
d

Purpos
e and
Securit
y
Protect
ion
Measur
e

Data
Storage
Period
and
Strateg
y

Data
Destruc
tion
Metho
d

Export
Metho
d (Such
as APIs
and
Comma
nds)
and
Export
Implem
entatio
n
Schem
e
(Anony
mity or
Pseudo
nym)

Export
Guide

Machin
e code
generat
ion

MAC
address
and
CPU
informa
tion of
a
machin
e where
the
OpenEy
e
Deskto
p is
installe
d

Informa
tion is
collecte
d from
the
machin
e where
the
OpenEy
e
Deskto
p is
installe
d by
invokin
g
functio
ns.

Informa
tion
such as
the
MAC
address
and
CPU of
a
machin
e where
the
OpenEy
e
Deskto
p is
installe
d is
used to
generat
e the
machin
e code.
The
informa
tion is
not
stored.

The
MAC
address
and
CPU
informa
tion of
a
machin
e is not
stored.

N/A N/A N/A
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Usage
Scenari
o

Person
al Data
Collect
ed

Data
Collecti
on
Source
and
Metho
d

Purpos
e and
Securit
y
Protect
ion
Measur
e

Data
Storage
Period
and
Strateg
y

Data
Destruc
tion
Metho
d

Export
Metho
d (Such
as APIs
and
Comma
nds)
and
Export
Implem
entatio
n
Schem
e
(Anony
mity or
Pseudo
nym)

Export
Guide

Video
call
screens
hot and
screen
recordin
g

Images
in a
video
call

A user
uses
the
screen
capture
or
screen
recordin
g
functio
n
during
a video
call.

A
functio
n entry
is
provide
d to
meet
user
require
ments,
which
generat
es
images
or video
files
from
video
calls,
and
saves
the
images
or video
files to
a
specifie
d
director
y.

Files
are
saved
to a
specifie
d
director
y and
manag
ed by
users.

Data
can be
deleted
by the
user.

N/A Generat
ed
images
or video
files
can be
directly
copied.
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3.12.9 Uninstallation Description
The OpenEye can be uninstalled manually.

Procedure

Step 1 Choose Start > Control Panel > Programs and Features. The Uninstall or
change a program window is displayed.

Step 2 Click the OpenEye and right-click Change/Uninstall Program. A confirmation
dialog box is displayed.

Step 3 Click Yes to uninstall the OpenEye. The background automatically performs the
uninstallation.

Step 4 When the uninstallation is complete, select Do you want to delete all user data?
and click Finish.
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----End

3.13 Implementing Intelligent Case Filling
When a user communicates with an agent through voice or multimedia, the agent
may need to create a case. In this case, the agent can click the one-click case
creation button.

Procedure

Step 1 Choose Audio and Video Workbench to open the audio and video workbench,
and click Sign In on the navigation bar.

Step 2 Click  in the upper part of the page to call another agent.

Step 3 Click  above the session to create a case after the call ends. In the Select a
case type dialog box that is displayed, select a case type based on business
requirements.

Step 4 After a case type is selected, the Create Case page is displayed, and the case type
is automatically filled in.

Step 5 The address information during the call is automatically filled in oifde. The oifde
field is customized.
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Figure 3-142 Intelligent case filling

----End
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4 Inspector Guide

To guide and evaluate the service of agents, an enterprise can assign inspectors to
monitor the conversation between agents and customers in real time.

The inspection mode varies depending on the inspection content. An inspector can
select an inspection mode to perform inspections.

4.1 Processing Manual Post-Event Inspections
After an agent completes a call, an inspector can check the call content, inspect
the agent, and process violations.

4.2 AI Inspection
The AICC automatically queries agents' service content based on the rules set by
inspectors, reducing inspector operations.

4.3 Performing Agent Monitoring and Inspections
Quality checkers can monitor VDNs, IVRs, skill queues, and agents, and inspect
agents.

4.1 Processing Manual Post-Event Inspections
After an agent completes a call, an inspector can check the call content, inspect
the agent, and process violations.

4.1.1 Executing Inspection Tasks
An inspector can access an inspection task and inspect the calls of agents.

Step 1 Use an allocated business account to sign in to the CEC.

Step 2 Choose Inspection > Task Query.

Step 3 By default, the inspection task list displays the tasks that an inspector is involved
in.
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Figure 4-1 Task Query

Step 4 Click Task next to a desired inspection task. The list of pending records for an
inspector is displayed.

Step 5 If the list of pending records is empty, click Obtain To-Be-Inspected Record to
obtain the pending records.

NO TE

Before obtaining inspection records, ensure that the inspected agent has made calls during
the inspection period.
If the task type is automatic post-event inspection, contact records are automatically
extracted from the system.
When the task type is manual post-event inspection, you need to manually select contact
records.

Figure 4-2 To-Be-Inspected Record Query
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Figure 4-3 Select Contact Record

Step 6 Select an inspection record and click Start Inspection to access the manual
inspection stage. The Session Content and Contact Information tab pages are
displayed on the left, and the rating template of the inspection task is displayed
on the right. The inspector can perform an inspection based on the rating items
and click Submit to complete the inspection. The inspector can then view the
inspection result. For details, see 4.1.2 Viewing Inspection Results.

Figure 4-4 Manual inspection page

----End

4.1.2 Viewing Inspection Results
An inspector can view inspection results.
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Step 1 Choose Inspection > Task Result.

Step 2 Set search criteria and click Search to obtain the search result. Click Reset to clear
the existing search criteria.

Figure 4-5 Task Result

Step 3 Click Adding An Export Task to export the inspection result.

Step 4 Click Details. On the Manual Inspection page, view the score details and
summary for the current inspection record.

----End

4.1.3 Handling Review Applications
If an agent disagrees with an inspection result, the agent can apply for a review.
An inspector with the permission can handle the review application.

Step 1 Choose Quality Inspection > Reconsideration Management.

Step 2 Set the search criteria and click Search to obtain the search result. Click Reset to
clear the existing search criteria.

Figure 4-6 Reconsideration Management page

Step 3 Click Details in the Operation column to view the inspection details. If an
inspection record is in Approved or Failed state, you can only view the result. If it
is in Pending state, you can click Details to handle the review application.
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Figure 4-7 Handling a review application

Step 4 Click Reject. In the dialog box that is displayed, enter the comments. The manual
inspection result remains unchanged. If you modify the score or summary of an
inspection item, click Submit, and then enter the comments, the manual
inspection result of the record is updated.

Figure 4-8 Entering review comments

----End

4.2 AI Inspection
The AICC automatically queries agents' service content based on the rules set by
inspectors, reducing inspector operations.

4.2.1 Viewing To-Do Inspection Tasks
An inspector can quickly view and handle to-do inspection tasks, improving
inspection efficiency.
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Prerequisites
The inspected agent has contact records.

Procedure

Step 1 Sign in to the CEC as a tenant administrator and view to-do inspection tasks in the
My To Do area on the home page.

Figure 4-9 Home page

Step 2 Click the name of an inspection task. The To-Be-Inspected Record Query page is
displayed.

Figure 4-10 To-Be-Inspected Record Query

Step 3 Click Obtain To-Be-Inspected Record and select contact records.

CEC
User Guide 4 Inspector Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1445



Figure 4-11 Select Contact Record

Step 4 Click OK to obtain to-be-inspected records.

Step 5 Click Start Inspection to inspect a record.

----End

4.2.2 Executing Manual Sample Inspection Tasks
After an inspection supervisor creates a manual sample inspection task and
assigns it to an inspector, the inspector can view it in My Inspection Task and
review the AI inspection result.

Procedure
Step 1 Use the allocated business account to sign in to the CEC.

Step 2 Choose Quality Inspection > My Inspection Task.

Step 3 View the inspection task list. By default, the list displays the tasks that an
inspector is involved in.

Figure 4-12 Inspection task list

Step 4 Click View corresponding to an inspection task. The Basic Task Details list is
displayed.

Step 5 In the Basic Task Details list, click View corresponding to a record. The Call
Inspection Details page is displayed.
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Figure 4-13 Call Inspection Details page

Step 6 On the Call Inspection Details page, click View to view the rule, or click Modify
to modify the inspection result.

Figure 4-14 Silence Rule Details page
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Figure 4-15 Modify Inspection Result page

Step 7 On the Call Inspection Details page, click Complete Sample Inspection and
Complete Re-Inspection to complete the sample inspection.

----End

4.3 Performing Agent Monitoring and Inspections
Quality checkers can monitor VDNs, IVRs, skill queues, and agents, and inspect
agents.

4.3.1 Monitoring Configuration
A system administrator can configure inspection relationships, full screen
monitoring, and report subscription tasks.

4.3.1.1 Configuring Monitoring and Inspection Relationships
When inspectors need to perform agent monitoring and recording inspection, a
tenant administrator can configure the monitoring and inspection relationships
between inspectors and agents.

Prerequisites
Inspectors and agents have been configured for the tenant.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Monitor Relationship.

Step 2 Configure an agent group.

1. Click the Traffic Group tab.

Figure 4-16 Traffic Group

2. Click  to create an agent group.

Figure 4-17 Creating an agent group

– User Group Name: The value cannot contain special characters and must
be unique.

Click Save.
3. Select the new agent group, click Add in the Configure Role Info area on the

right, and add agents to the agent group.
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Figure 4-18 Adding agents to an agent group

Agents of all roles can be selected.

Click OK.

4. (Optional) You can perform the following operations on an agent group and
its members.

– Hover the pointer over the agent group and click  to delete the agent
group and its members.

– Click  to edit basic information about the agent group.

– Search for configured agents in the agent group based on the agent ID,
name, and business account.

– Click Delete corresponding to a configured agent to delete the agent
from the agent group.

– Select multiple configured agents and click Delete to delete the agents in
batches.

Step 3 Configure an inspector group.

1. Click the Quality Inspection Group tab.

Figure 4-19 Quality Inspection Group

2. Click  to create an inspector group.
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Figure 4-20 Creating an inspector group

– User Group Name: The value cannot contain special characters and must
be unique.

Click Save.
3. Select the new inspector group, click Add in the Configure Role Info area,

and add agents to the inspector group.

Figure 4-21 Adding agents to an inspector group

Only agents of the Quality checker role can be selected.

CEC
User Guide 4 Inspector Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1451



Click OK.

4. Click the Inspection Relationships tab, click Add, and configure monitoring
and inspection relationships.

Figure 4-22 Adding agent groups to be inspected

Click OK.

5. (Optional) You can perform the following operations on an inspector group,
its members, and inspection relationships.

– Hover the pointer over the inspector group and click  to delete the
inspector group, its members, and inspection relationships configured for
the group.

– Click  to edit basic information about the inspector group.

– Search for configured agents in the inspector group based on the agent
ID, name, and business account.
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– Click Delete corresponding to a configured agent to delete the agent
from the inspector group.

– Select multiple configured agents and click Delete to delete the agents in
batches.

– Search for configured inspection relationships by agent group name.

– Click Delete corresponding to a configured inspection relationship to
delete it.

– Select multiple configured inspection relationships and click Delete to
delete the inspection relationships in batches.

Step 4 Search for inspection relationships.

1. Click the Query Inspection Relationships tab.

2. Enter an inspector group or inspected group and click  to search for
configured inspection relationships.

Figure 4-23 Query Inspection Relationships

3. Click More and set more search criteria, including Inspector Name, Inspector
ID, Inspected Party Name, and Inspected Party ID, to search for inspection
relationships.

----End

4.3.1.2 Configuring Fullscreen Monitoring

A tenant administrator performs this operation when a fullscreen is required to
view real-time monitoring data, today's indicator statistics, historical indicator
monitoring data, and the trend chart of the number of calls, call rate, duration,
and number of agents under the tenant space, or display the monitoring data.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Fullscreen Monitor.
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Figure 4-24 Fullscreen Monitor

Step 2 Click  to add a theme.

Figure 4-25 Create Subject

● Subject Name: Enter a name that contains a maximum of 32 characters. The
name must be unique and cannot contain special characters.

● Theme Type: Select Public Themes or Private Themes.

Employees who have the following permissions share screen data of public
themes:

– Menu permissions Call Center Monitor, Monitor Configuration, and
Full Screen Monitoring Configuration
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– Operation permissions Large-screen monitoring management, Viewing
Public Large-Screen Monitoring, and Edit Public Large-Screen
Monitoring

● Style: Select Light or Dark.
● Resolution: Select 720P (1280*720), 1080P (1920*1080), 4K (4096*2160),

or Customization (the resolution ranges from 720P to 8K).

Step 3 Click Save.

Step 4 (Optional) You can perform the following operations on the new theme:

● Click  or  to change the sequence of the theme in the list.

● Click  to display the theme in fullscreen mode.

● Click  to modify the theme information.

● Click  to delete the theme.

Step 5 Select the new theme and create a chart.

1. On the chart information pane on the right, click  to create a chart.
2. Configure chart information.

Figure 4-26 Create Chart

– Name: Enter a customized name that contains a maximum of 32
characters. The name must be unique and cannot contain special
characters.

– Monitored Object: Select an object to be monitored on a fullscreen. The
options are Skill Queue, VDN, IVR, Access Code, and Agent. When
Monitored Object is set to Access Code, only the indicator Number of
outgoing calls can be monitored.

– Skill Queue/Access Code/Organization Unit/Select Agent: Set this
parameter based on the monitored object.

– Monitoring Mode: Select a fullscreen monitoring mode. The options are
Today's Indicator Statistics, Today's Trend, Real-time Monitoring
During Running, and Real-time Monitoring During Running.

▪ When Monitored Object is set to Skill Queue, VDN or IVR, you can
select any of all the monitoring modes.
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▪ When Monitored Object is set to Access Code, you can only select
Today's Trend.

▪ When Monitored Object is set to Agent, you can select Today's
Indicator Statistics, Real-time Monitoring During Running, or
Today's Trend.

– Media Type/Multimedia Type: Select a call media type.
– Statistical Period: Select a period for collecting statistics on report

indicators.

▪ When Monitoring Mode is set to Today's Trend, this parameter is
mandatory.

▪ When Monitored Object is set to Access Code, you can only select 1
hour.

– Refresh Period: Select an interval for automatically refreshing report
data. This parameter is mandatory when Monitoring Mode is set to
Today's Indicator Statistics, Real-time Monitoring During Running, or
Today's Trend.

– Report Type/Collection Period: Select a report type or the time when
historical indicator report statistics are collected. This parameter is
mandatory when Monitoring Mode is set to Historical Indicator
Statistics

▪ When Report Type is set to Daily Report (Relative Time), you can
select a day earlier than the current time. The value ranges from 1 to
31 days earlier than the current time.

▪ When Report Type is set to Daily Report (Fixed Time), you can
select a fixed date.

– Chart Type: Select a display type. The options are Bar Chart, Pie Chart,
Line Chart, Table, and Rich Text.

▪ When Monitoring Mode is set to Today's Indicator Statistics or
Real-time Monitoring During Running, you can select Bar Chart,
Pie Chart, Table, or Rich Text.

▪ When Monitoring Mode is set to Today's Trend, you can select only
Line Chart.

▪ When Monitoring Mode is set to Historical Indicator Statistics, you
can select Bar Chart or Table.

– Indicator type: Select a report indicator type. The options are Number of
Calls, Call Rate, Duration, and Number of Agents.

▪ When Monitoring Mode is set to Today's Indicator Statistics or
Today's Trend, you can select Number of Calls, Call Rate, or
Duration.

▪ When Monitoring Mode is set to Real-time Monitoring During
Running:
○ If Monitored Object is set to Skill Queue or VDN, you can

select Number of Calls or Number of Agents.

CEC
User Guide 4 Inspector Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1456



○ If Monitored Object is set to IVR, you can only select Number
of Calls.

○ If Monitored Object is set to Agent, you can select Number of
Calls or Duration.

▪ When Monitored Object is set to Access Code, you can only select
Number of Calls.

– Set Indicator Thresholds: Determine whether to enable the function of
configuring indicator thresholds. This parameter is not displayed when
Chart Type is set to Pie Chart.

– Min Threshold/Max Threshold: Enter a customized value. The threshold
can be empty. The minimum threshold must be less than the maximum
threshold.

▪ For indicators of the Number of Calls and Number of Agents types,
the value is an integer ranging from 0 to 99999999.

▪ For indicators of the Call Rate type, the value is an integer ranging
from 0 to 100, in percentage.

▪ For indicators of the Duration type, the value is an integer ranging
from 0 to 86,400, in seconds.

3. Click Save.
4. (Optional) Repeat the preceding steps to create multiple charts for the theme.

Step 6 (Optional) You can perform the following operations on the new chart:

● Click  to modify the chart information.

● Click  to delete the chart.

● Click  to modify the chart of the rich text type.
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Figure 4-27 Modify Rich Text

● Drag the chart to change its display position.

Step 7 Click  to save the layout.

Step 8 (Optional) Click  on the chart information page to preview the theme layout.

Step 9 (Optional) Click  on the theme information page to play the theme layout.

----End

4.3.1.3 Configuring Report Subscription
A tenant administrator can configure report subscription to periodically send
report data via email. This function can be used only in the integration
environment.

NO TE

The report data to be sent contains personal data. Exercise caution when processing the
received report data to prevent personal data leakage and abuse.

Prerequisites
● You have configured an email gateway. For details, see 2.11.3.2 Configuring

Email Gateways.
● You have configured an email notification template. For details, see 2.11.5

Configuring Notification Templates as an Administrator.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Configuration Center >
Quality Management > Report Subscription.

Figure 4-28 Report Subscription

Step 2 Click New.

Figure 4-29 New Report Subscription

● Subscribe Name: Enter a customized subscription name, which can contain a
maximum of 50 characters and must be unique.

● Email Template Name: Select the notification template configured in 2.11.5
Configuring Notification Templates as an Administrator. One email
template corresponds to only one subscription data record.

● Sent Period: Set the period for subscribing to reports. The options are
Monday to Sunday.

● Sending time: Select the time for sending subscribed reports. The value
ranges from 00:00 to 23:45 with a step of 15 minutes.

Step 3 Click  and select reports to be subscribed to.
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Figure 4-30 Adding a Report

● Report name: Select the report to be subscribed to. For details about the
report data, see 4.3.3 Report Query.

● Report type: Select the type of the report to be subscribed to. The options are
Daily report, Weekly report, and Monthly report.

Select indicators of the report to be subscribed to as required and click OK.

Step 4 Click Save.

Step 5 The new report subscription information is enabled by default. You can click

 to disable the report subscription.

Step 6 (Optional) You can perform the following operations on the configured report
subscription information:

● Click Edit to update the basic information about the report and sending
scope.

● Click Delete to delete disabled report subscription information.

Step 7 (Optional) Create a perspective view based on the downloaded Excel report data.

1. Select the data area to be used for creation.

2. Click Insert, and then click PivotChart.

3. Access the PivotChart, and click Field List and Field Button.

4. Drag the filter criteria (agent ID, agent name, and date) to the axis (type)
area and drag various indicators to the value area.

5. Filter data by date and agent ID.
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6. By default, the chart is a bar chart. To generate a line chart, right-click the
chart area, choose Change Chart Type from the shortcut menu, and then
select the line chart.

----End

4.3.2 Monitoring Management
A tenant administrator can manage the monitoring content after the monitoring
content configuration.

4.3.2.1 Monitoring Offline Messages
The customer service representative can view the number of offline customers and
offline messages in each channel to understand the business handling pressure,
adjust agents, and improve service quality.

Prerequisites
The current tenant has available WhatsApp, 5G RCS, web, email, SMS, Instagram,
and Telegram channels.

Procedure

Step 1 Sign in to the AICC as an agent and choose Monitoring > Offline Message.

Step 2 View the number and trend of offline customers and offline messages in channels.

By default, a tenant administrator has the permission on the Offline Message
Monitoring menu. If the agent has no such permission, contact the tenant
administrator to add the permission.

● Click  to refresh the data in the list.
● Select a channel from the Access channel drop-down list to view the data of

offline customers and offline messages in the channel.

----End

4.3.2.2 Monitoring Agents
An inspector can monitor agents and dynamically adjust agent resources based on
business requirements. A tenant administrator can monitor agent status but
cannot perform inspection operations, such as skill queue adjustment, on agents.

Prerequisites
Prerequisites for an inspector:

● Monitoring and inspection relationships have been configured for the
inspector.

● The Agent Monitor menu permission has been assigned to the inspector.
● To allow the inspector to monitor multimedia sessions, the inspector has been

bound to a multimedia agent and has the following operation permissions:
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Multimedia Session Monitoring, Multimedia Session Insertion, and
Multimedia Session Interception.
By default, a tenant administrator has the preceding operation permissions
and other roles do not have them. You need to contact a tenant administrator
to assign the operation permissions to the inspector.

● To allow the inspector to monitor screens, the Screen Monitoring role
permission has been assigned to the inspector, the Screen recording and
screen inspection feature has been enabled during tenant provisioning, the
VRC has been started locally, and the inspector and agent have signed in.
To install the VRC locally, perform the following steps:

a. Sign in to the AICC using an agent business account.
b. Click the business account in the upper right corner of the page and

choose Personal Center.
c. On the Agent Info tab page, click Download VRC to obtain the VRC

installation package.
d. Decompress the VRC installation package VRC.zip on the local PC.

It is recommended that the Client_update_pack directory be a level-2
directory. The path cannot be too long and cannot contain Chinese
characters.

e. Right-click VRCService\Client_update_pack\client_update_script.bat
and choose Run as administrator.

f. Create a shortcut for the VRC application.

i. Go to the VRCService folder, for example, D:\VRCService.
ii. Right-click the vrc_service_tray.exe file and choose Create shortcut.

The vrc_service_tray.exe - Shortcut file is generated.
g. Configure the VRC to automatically start upon system startup.

i. Open the system startup directory. The following uses Windows as
an example:

1) Press Win+R to open the Run window.
2) Enter shell:startup and click OK. The system startup directory is

displayed.
ii. Copy the vrc_service_tray.exe -Shortcut file generated in f.ii to the

startup directory.
h. Change the local port number of the VRC.

i. Edit the D:\VRCService\Client_update_pack\package\vrc.ini file.
ii. Add ListenPort=8024 under [common].

The port number must be available. Run the netstat -ano |
findstr :8024 command in the CLI on Windows to check whether the
port number is occupied.
The port number must be the same as the value of the tenant
parameter VRC WebSocket Port.

i. Right-click on the taskbar of the desktop and choose Task Manager to
open the task manager and click the Startup menu. If vrc_service_tray is
displayed, the VRC is successfully configured to automatically start upon
system startup.
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j. During the first startup, run vrc_service_tray as an administrator and
view the vrc.log file. The information shown in Figure 4-31 is displayed.

Figure 4-31 Successful startup

Procedure

Step 1 Sign in to the AICC as an inspector and choose Monitoring > Agent Monitor.

Figure 4-32 Agent Monitor (in list mode)

● Agent statistics: Statistics on the total number of agents for whom monitoring
and inspection relationships with the current inspector have been configured,
including the agent status and alarm information, are displayed.

● Data updated: The time when agent monitoring information is last updated
is displayed. Automatic refresh can be enabled.

● Current Status Of The Agent: The current agent status can be Offline, Idle,
preoccupied, Occupied, Answering, Talking, Wrap-up, Busy, Rest, Learning,
or Adjusting.

● Current Status Reason: When the value of Current Status Of The Agent is
Rest for an agent, the value is the rest reason selected by the agent. For
details about how to configure rest reasons, see 2.3.2.2 Configuring Rest
Reasons.

● Alarm: This function is available only in the integration environment. If an
agent says sensitive words when answering a call, an alarm is generated. The
alarm validity period is 12 hours. After the validity period ends, the alarm is
no longer displayed on the page.

● Current State Duration Of An Agent: Click  to manually refresh data.
Alternatively, enable Auto Refresh to automatically refresh data every 10
seconds.

● Agent Group: Agent group to which an agent belongs. If an agent does not
belong to any agent group, a hyphen (-) is displayed.
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Step 2 Set data filter criteria.

● Click Agent Name. In the Select Agent dialog box, select agents and click 
to search for information about the agents.

Figure 4-33 Select Agent

● Click More, set Agent Status, >= Status Duration (Minute), Inspection
Status, Alarm Status, Sign-in Queue, and Agent Group, and click Search to
filter detailed data.
The options of Agent Group are as follows:
– For a tenant administrator, the options are all agent groups.
– For an inspector, the options are agent groups for which inspection

relationships have been configured.

● Click  to refresh real-time data.

Step 3 Click  to set the table header.
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Figure 4-34 Column Configuration

● Click  or  to deselect a column.
● Drag a selected column to change its sequence.
● Click Reset to reset the column configuration to the state when the dialog

box is opened.

After the configuration is complete, click OK to save the new column
configuration. Data is displayed based on the new column configuration.

Step 4 Click Detail corresponding to an agent for whom an alarm is generated. The
alarm details dialog box is displayed, showing the following information: Call ID,
Agent ID, Time, Dialog Content, Sensitive Word, and Emotional Type.

Figure 4-35 Inspection Alarm Details

Step 5 Click  to switch the Agent Monitor page between the list mode and
card mode.
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Figure 4-36 Agent Monitor (in card mode)

NO TE

● In card mode, hover the pointer over  in the upper right corner of the card of an
agent to be inspected to view inspection operations that can be performed.

● In list mode, view common inspection operations that can be performed in the
Operation column of the list and view other inspection operations that can be
performed on the button bar in the upper right corner of the list.

Step 6 Perform inspection operations.

NO TE

In the independent deployment environment, when an inspector clicks any inspection
operation for the first time, a dialog box is displayed, asking the inspector to change the
password. Set the password to the one used by the inspector to log in to the web
configuration console.
When an inspector has not logged in to the OpenEye or an inspected agent is not in talking
state, you are advised to avoid frequently switching the inspection type. Otherwise, an
operation exception message will be displayed by the platform.

● Adjust Queues: Select one or more signed-in agents and click Adjust Queues
to adjust their skill queues.
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Figure 4-37 Adjust Queues

NO TE

– After an agent whose skill queue is adjusted signs out and then signs in again, the
skill queue configuration of the agent is restored to that before the skill queue
adjustment.

– If a tenant requires cross-channel agent support, the multi-channel support feature
needs to be enabled when the tenant is created. In addition, the Agent multi-
channel support operation permission needs to be assigned to the inspector and
the agent whose skill queue needs to be adjusted.

● Send Notes: Select one or more signed-in agents and click Send Notes to
send notes to the agents.
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Figure 4-38 Send Notes

NO TE

In the integration environment, after an inspector sends a note to an agent, the agent

can choose  > Inbox > Internal Message to view the received note whose subject
is inspection note.

● Force Busy: Select an agent in Idle state and click Force Busy to change the
status to Busy.

● Force Idle: Select an agent in Busy state and click Force Idle to change the
status to Idle.

● Force Release: Select an agent in Talking state and click Force Release to
forcibly release the ongoing call. The agent receives a notification indicating
the inspector's operation.

Figure 4-39 Notification

● Force Out: Select a signed-in agent and click Force Out to forcibly sign out
the agent.
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● Listen: Click Listen in the Operation column corresponding to an agent to
listen to the agent.

● Insert: Click Insert in the Operation column corresponding to an agent to
insert into the call of the agent.

● switch: Click switch in the Operation column corresponding to an agent who
is being inspected (listening or insertion) by the inspector to switch the
inspection mode (from Listen to Insert or from Insert to Listen).

● intercept: Click intercept in the Operation column corresponding to an
agent who is being inspected (listening, insertion, or whispering) by the
inspector to kick out the agent and talk with the customer. The agent receives
a notification indicating the inspector's operation.

● Whisper: Click Whisper in the Operation column corresponding to an agent
to whisper to the agent. (The customer is unaware of the talk between the
inspector and the agent.)

● Send Message: Send text messages to an agent. You can send messages to a
signed-in agent in real time, or send messages to an offline agent who can
view the messages after sign-in.
Select an agent and click Send Message.

After a session is created, click  in the lower right corner of the
browser to expand or collapse the session list.
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Figure 4-40 Sending messages

● Multimedia Session Monitoring: Click Multimedia Session Monitoring in
the Operation column corresponding to a multimedia agent in Idle state to
monitor the agent in real time. The inspector can view the customer access
channel, chat records of the inspected agent and customer, and contact
history. The customer is unaware of the operations.

Figure 4-41 Multimedia session monitoring
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Click  to directly participate in the conversation between the agent and
customer.

Click  to directly chat with the customer.

NO TE

This function is not supported for the full containerized installation scenario.

Click  to have a point-to-point chat with the agent.
● Monitor Screen: Click Monitor Screen in the Operation column

corresponding to an agent to view the agent's screen.

NO TE

In list mode, a maximum of three buttons are displayed in the Operation column

corresponding to an agent. If there are more than three buttons, two buttons and  are

displayed. Click  to view other buttons.

Step 7 In card mode, perform different inspection operations based on agent states.
● Agent in Idle state

● Agent in Busy state
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● Agent in Rest state

● Agent in Wrap-up state
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● Agent in Talking state

● Agent in a multimedia chat
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Step 8 View details about an agent.
● In list mode, click an agent and view the agent details on the page that is

displayed.

Figure 4-42 Agent details (in list mode)

● In card mode, click an agent and view the agent sign-in details on the right of
the page. Click View Details to view the agent details on the page shown in
Figure 4-42.

CEC
User Guide 4 Inspector Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1474



Figure 4-43 Agent details (in card mode)

----End

4.3.2.3 Playing Recordings

Inspectors can play and download call recording and video files.

Prerequisites
● Monitoring and inspection relationships have been configured for the

inspector.

● The permission on the Recording menu has been assigned to the inspector.

Procedure

Step 1 Sign in to the AICC as an inspector and choose Monitoring > Recording.
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Figure 4-44 Recording

Step 2 Set data filter criteria.

● Click the time widget, set the start time and end time, and click OK to filter
data.

● Click Advanced Search, set Caller Number, Called Number, Recording SN,
and Agent, and click Search to filter detailed data.

● Click  to refresh real-time data.

The indicator color in the Recording Duration (s) column is red and cannot be
configured. The color becomes darker for each additional minute, with the darkest
shade representing 10 minutes or more.

The following fields are displayed in the list:

● Recording SN

● Call Type

● Skill Queue

● Business Type

● Agent

● Caller Number

● Called Number

● Recording Start Time

● Recording End Time

● Recording Duration (s)

Step 3 Click Play in the Operation column to play a recording or video online. You can
set the playback rate of the recording or video.

Step 4 Click Download in the Operation column to download a recording or video file to
the local PC.
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NO TE

The downloaded data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

Step 5 (Optional) Export recording playback data (excluding recording or video files) to
the local PC.

1. Click  and enter a compression password to create an export task.

NO TE

– For details about the requirements of the compression password, see the prompt
on the page. The compression password is used to open the downloaded package.
The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

– In the independent deployment environment, click  to export recording
playback data without entering a compression password.

2. Click  to view the export tasks in the last seven days.
3. Click download in the Operation column corresponding to the created export

task to download the exported data to the local PC. When opening the file,
you need to enter the compression password set when you create the export
task.

----End

4.3.2.4 Monitoring Indicators
A tenant administrator can view data about the real-time overview, VDNs, voice
and video IVR, skill queues, agents, multimedia IVR, and cases in the tenant space.

Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Monitoring > Index
Monitor.

Step 2 View the real-time overview.
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Figure 4-45 RealTime Overview

● Indicator statistics: The indicators include the number of inbound calls,
number of outbound calls, inbound call connection rate, and outbound call
connection rate. The statistics are displayed in the following dimensions: data
summary, day-over-day (DoD) rate (compared with the indicator value
collected from the same time segment on the previous day), and data
statistics by channel (covering only the channels preconfigured in the baseline
version).
– DoD rate: The comparison result between the indicator value until the

current time on the current day and the indicator value of the same time
segment on the previous day is displayed.

▪ : No data is displayed because the value on the previous day is 0.

▪ : The value increases compared with the previous day.

▪ : The value decreases compared with the previous day.

– Click  to view submedia call statistics.
● Call Trends: The number of inbound calls, number of outbound calls, number

of connected inbound calls, and number of connected outbound calls of the
tenant space on the current day are displayed in a line chart.

● Agent Status: The real-time agent status distribution of the tenant space on
the current day is displayed in a pie chart.

● Skill Queue Service Level Overview: Statistics on skill queue service level
fulfillment are collected in real time by channel type.
– By default, the skill queue service level data of the voice channel is

displayed. Click a channel type tab to view the corresponding service level
data.
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– By default, five channel types are displayed. For the Multimedia type,
statistics can be queried by submedia type.

– By default, data of a maximum of 10 skill queues can be displayed. Scroll
the content vertically to view the extra data.

– The expected skill queue service level is that the number of calls
connected within 20 seconds reaches 80%, which can be configured using
a parameter.
The integrated deployment environment supports the configuration and
modification of tenant parameters. You can configure the tenant
parameter Expected service level of the skill queue under
Configuration Center > System Management > Tenant Parameter >
Call center monitoring > Index Monitor. The default value is 0.8,
indicating 80%. The value ranges from 0 to 1.
The independent deployment environment supports only the
configuration of system parameters. You can configure the system
parameter Expected service level of the skill queue under
Configuration Center > System Management > Parameter Settings >
Call Center Monitoring > Index Monitor. The default value is 0.8,
indicating 80%. The value ranges from 0 to 1.

● Click  to refresh real-time data. The indicator statistics as well as the
Call Trends, Agent Status, and Skill Queue Service Level Overview areas
are refreshed.

Step 3 View VDN monitoring information.

Figure 4-46 VDN Monitor

1. Click the VDN Monitor tab and select a media type to query today's VDN
monitoring information.
– When Media Type is set to Multimedia, select a submedia type to query

today's VDN monitoring information.
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– Click  to refresh real-time data.

– Click  to set indicators related to the real-time number of calls,
today's number of calls, call rate, and duration.

The real-time number of calls and today's number of calls are both
displayed in the statistics under Number of Calls.

2. Click Number of Calls, Call Rate, or Duration to view the corresponding
monitoring indicator information in a trend chart.

3. Click  to set the indicators for querying today's trend statistics and
refresh the statistics.

4. Drag the trend chart to view the information of a desired time segment.

Step 4 View voice and video IVR monitoring information.

Figure 4-47 Audio&Video IVR Monitor

1. Click the Audio&Video IVR Monitor tab and select a media type to query
today's voice and video IVR monitoring information.

– Click  to refresh real-time data.

– Click  to set indicators. You can select three to five indicators.

2. View the DoD rate of each IVR indicator. The comparison result between the
indicator value until the current time on the current day and the indicator
value of the same time segment on the previous day is displayed.

For each indicator, a small chart of today's trend statistics is displayed.

3. Click Number of Calls, Call Rate, or Duration to view the corresponding
monitoring indicator information in a trend chart.
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4. Click  to set the indicators for querying today's trend statistics and
refresh the statistics.

5. Drag the trend chart to view the information of a desired time segment.

Step 5 View skill queue monitoring information.

Figure 4-48 Skill Queue Monitor

1. Click the Skill Queue Monitor tab page and select a skill queue and a media
type to query today's skill queue monitoring information.

– You can select a maximum of 10 skill queues.

– When Media Type is set to Multimedia, select a submedia type to query
today's skill queue monitoring information.

– Click  to refresh real-time data.

2. Click Number of Calls, Call Rate, Duration, or Number of Agents to view
the corresponding monitoring indicator data.

3. Click  to set the table header.

4. Click  to set the indicators for querying today's trend statistics and
refresh the statistics.

– In the case of only one skill queue, you can select 1 to 10 indicators.

– In the case of multiple skill queues, you can select only one indicator.

5. Drag the trend chart to view the information of a desired time segment.

Step 6 View agent indicator monitoring information.

CEC
User Guide 4 Inspector Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1481



Figure 4-49 Agent Indicator Monitoring

1. Click the Agent Indicator Monitoring tab and select an OU, an agent, and a
media type to query today's agent indicator monitoring information.
– You can select a maximum of five agents.
– When Media Type is set to Multimedia, select a submedia type to query

today's agent indicator monitoring information.

– Click  to refresh real-time data.
2. Click Number of Calls, Call Rate, or Duration to view the corresponding

monitoring indicator data.

3. Click  to set the table header.

4. Click  to set the indicators for querying today's trend statistics and
refresh the statistics.
– In the case of only one agent, you can select 1 to 10 indicators.
– In the case of multiple agents, you can select only one indicator.

5. Drag the trend chart to view the information of a desired time segment.

Step 7 View multimedia IVR monitoring information.
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Figure 4-50 Multimedia IVR Monitor

1. Click the Multimedia IVR Monitor tab and select a multimedia type to query
today's multimedia IVR monitoring information.
– Select a channel from the drop-down list to view the corresponding

statistics.

– Click  to refresh real-time data.

– Click  to set indicators. You can select three to five indicators.
2. View the DoD rate of each IVR indicator. The comparison result between the

indicator value until the current time on the current day and the indicator
value of the same time segment on the previous day is displayed.
For each indicator, a small chart of today's trend statistics is displayed.

3. Click Number of Calls, Call Rate, or Duration to view the corresponding
monitoring indicator information in a trend chart.

4. Click  to set the indicators for querying today's trend statistics and
refresh the statistics.

5. Drag the trend chart to view the information of a desired time segment.

----End

4.3.2.5 Monitoring Inbound Call Records

A tenant administrator can view information about abandoned customer calls,
calls requiring callback, and inbound calls.

Procedure

Step 1 Sign in to the AICC as a tenant administrator. Choose Monitoring > Incoming Call
Record.

Step 2 Query information about abandoned calls.
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1. Click the Queuing Abandon Query tab to view information about abandoned
customer calls in the tenant space. Only data generated within seven days
before the current time can be queried, and the query time range cannot span
days.

Figure 4-51 Queuing Abandon Query

– You can query abandoned calls in the tenant space based on the start
time, end time, customer number, access code, and skill queue name.

– By default, the list displays information about abandoned customer calls
in the tenant space on the current day, including the call SN, customer
number, access code, skill queue name, and waiting duration.

2. Set data filter criteria.
– Click Advanced Search, enter a customer number and an access code,

select a skill queue, and click Search to filter detailed data.

– Click  to refresh real-time data.

3. Click  to set the table header.
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Figure 4-52 Queuing Abandon Query - Column Configuration

– Click  or  to deselect a column.
– Drag a selected column to change its sequence.
– Click Reset to reset the column configuration to the state when the

dialog box is opened.
After the configuration is complete, click OK to save the new column
configuration. Data is displayed based on the new column configuration.

Step 3 Query information about calls requiring callback.

1. Click the Callback Record Query tab to view information about calls
requiring callback in the tenant space. Only data generated within seven days
before the current time can be queried, and the query time range cannot span
days.

Figure 4-53 Callback Record Query

– You can query calls requiring callback in the tenant space based on the
start time and end time.

– By default, the list displays information about calls requiring callback in
the tenant space on the current day, including the call SN, customer
number, access code, skill queue name, and waiting duration.

2. Click  to refresh real-time data.

3. Click  to set the table header.
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– Click  or  to deselect a column.
– Drag a selected column to change its sequence.
– Click Reset to reset the column configuration to the state when the

dialog box is opened.
After the configuration is complete, click OK to save the new column
configuration. Data is displayed based on the new column configuration.

Step 4 Query information about inbound calls.

1. Click the Incoming Call Record Query tab to view information about
inbound calls in the tenant space. Only data generated within seven days
before the current time can be queried, and the query time range cannot span
days.

Figure 4-54 Incoming Call Record Query

– You can query inbound calls in the tenant space based on the start time,
end time, call release cause, whether manual service is requested, and
whether the call is answered.

– By default, the list displays information about inbound calls in the tenant
space on the current day.
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2. Set data filter criteria.
– Click Advanced Search, enter a call release cause, set whether manual

service is requested, and set whether the call is answered, and click
Search to filter detailed data.

– Click  to refresh real-time data.

3. Click  to set the table header.

Figure 4-55 Incoming Call Record Query - Column Configuration

– Click  or  to deselect a column.
– Drag a selected column to change its sequence.
– Click Reset to reset the column configuration to the state when the

dialog box is opened.
After the configuration is complete, click OK to save the new column
configuration. Data is displayed based on the new column configuration.

Step 5 (Optional) On the Callback Record Query or Incoming Call Record Query page,
export the queried data to the local PC.

1. Click  and enter a compression password based on the password
requirements. Click OK. An export task is created.
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Figure 4-56 Export

2. Click , select the export task whose Status is Success based on the
export time, and click download to download the exported data.

Figure 4-57 Export task view

NO TICE

Data files can be exported only in the integration environment.

----End

4.3.2.6 Monitoring Call Links
A tenant administrator can view call link information.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator and choose Monitoring > Call Link.
Inbound call details are displayed.

Figure 4-58 Call Link

Step 2 Set data filter criteria.
● Click the time widget, set the start time and end time, and click OK to filter

data.

NO TE

The earliest start time is 00:00:00 on the previous day, and the latest end time is
23:59:59 on the current day.

● Click Advanced Search, enter a calling number and a called number, and click
Search to filter detailed data.

● Click  to refresh real-time data.

Step 3 Click a call ID to view the call track of a specific call.

Figure 4-59 Call Track

Step 4 Click  to set the table header.
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Figure 4-60 Column Configuration

● Click  or  to deselect a column.

● Drag a selected column to change its sequence.

● Click Reset to reset the column configuration to the state when the dialog
box is opened.

After the configuration is complete, click OK to save the new column
configuration. Data is displayed based on the new column configuration.

----End

4.3.2.7 Querying Bidirectional Call Details

Step 1 Sign in to the AICC as a tenant administrator and choose Monitoring >
Bidirectional Call to query bidirectional call details.

Figure 4-61 Bidirectional Call
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Step 2 Set data filter criteria.
● Please Input Calling Or Called No.: Enter a calling or called number.
● Click Advanced Search and set the following search criteria:

– Connect State: The options are Connected and Unconnected.
– Hang Up Method: The options are Caller Hang Up, Called Hang Up,

and Exception Hang Up.
– Start time and end time: Click the time widget and set the time range of

the call start time.

NO TE

The call start time and call end time must be both set or left blank. The time
range cannot exceed seven days.

After the filter criteria are set, click Search to filter detailed data.

● Click  to refresh real-time data.

Step 3 Click  to set the table header.

1. Click Set Table Header. The Filter Table Header page is displayed.

Figure 4-62 Column Configuration

– For some columns, you cannot deselect them or change their sequence.

– Click  or  to deselect a column.
– Drag a selected column to change its sequence.

– Hover the pointer over  to view the detailed description of a column.
– Click Reset to reset the column configuration to the state when the

dialog box is opened.
After the configuration is complete, click OK to save the new column
configuration. Data is displayed based on the new column configuration.
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Table 4-1 Column description

Column Description

Calling Number Calling number of a bidirectional call.

Called Number Called number of a bidirectional call.

Connect State Connection status.

Hang Up Method Release mode.

Access Code Access code.

Call Start Time Call start time.

Call End Time Call end time.

Call Alerting Time Called party ringing time.

Call Talking Time Talking start time.

Talking Duration(s) Talking duration (s).

Caller Release Time Talking end time.

Caller Alerting Time Calling party ringing time.

Caller Talking Time Calling party talking time.

Caller Talking Duration(s) Agent talking duration (s).

Create Time Call creation time.

Call Type Call type.

Caller Alerting Duration(s) Calling party ringing duration (s).

Called Alerting Duration(s) Called party ringing duration (s).

 

Step 4 Export data.

1. Click  and enter a compression password to create an export task.

NO TE

For details about the requirements of the compression password, see the prompt on
the page. The compression password is used to open the downloaded package.
The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

2. Click  to view the export tasks in the last seven days.
3. Click download in the Operation column corresponding to the created export

task to download the exported data to the local PC. When opening the file,
you need to enter the compression password set when you create the export
task.

----End
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4.3.2.8 Viewing Agent Monitoring Operation Details
A tenant administrator can view the connection operation details of agents in a
tenant space.

Procedure

Step 1 Sign in to the AICC as a tenant administrator, choose Monitoring > Agent
Operation Details, and view the connection operation details of agents in the
current tenant space.

Figure 4-63 Agent Operation Details

Step 2 Set data filter criteria.
● Select the operation time. You can select 1 Day, 3 Days, 7 Days, or

Customization and search for agent operation details in the last day, last
three days, last seven days, or customized time period.

CA UTION

The customized time period must be equal to or less than seven days. A
maximum of the last 60 days are displayed in the start time selector.

● Select the OU to which agents belongs.
● Click the Select Agent selection box and select agents in the specified OU.
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Figure 4-64 Select Agent

– Search for an agent by agent name or business account.

– Click  to set the table header.

Figure 4-65 Column Configuration
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▪ For some columns, you cannot deselect them or change their
sequence.

▪ Click  or  to deselect a column.

▪ Drag a selected column to change its sequence.

▪ Click Reset to reset the column configuration to the state when the
dialog box is opened.

After the configuration is complete, click OK to save the new column
configuration. Data is displayed based on the new column configuration.

● Select an operation type and search for agent operation details based on the
selected agent operation type.
When an agent selects the default rest reason, the value of Operation Type is
Rest. When an agent selects a customized rest reason, the value of Operation
Type is the corresponding rest reason description. For details about how to
configure rest reasons, see 2.3.2.2 Configuring Rest Reasons.

● Click  to refresh real-time data.

----End

4.3.2.9 Monitoring Call Details
A tenant administrator can view call details.

Procedure
Step 1 Sign in to the AICC as a tenant administrator and choose Monitoring > Call

Detail to view call details of the tenant space.

Figure 4-66 Call Detail

Step 2 Set data filter criteria.
● Click the time widget, set the start time and end time, and click OK to filter

data.
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NO TE

In the integrated deployment environment, the maximum time span between the start
time and end time is five days.
In the independent deployment environment, the maximum time span between the
start time and end time is one day.

● Click More, set Caller Number, Called Number, Call Sequence Number, and
Device No, and click Search to filter detailed data.

● Click  to refresh real-time data.

Step 3 Click  to set the table header.

Figure 4-67 Column Configuration

● For some columns, you cannot deselect them or change their sequence.

● Click  or  to deselect a column.
● Drag a selected column to change its sequence.

● Hover the pointer over  to view the detailed description of a column.
● Click Reset to reset the column configuration to the state when the dialog

box is opened.

After the configuration is complete, click OK to save the new column
configuration. Data is displayed based on the new column configuration.

Step 4 (Optional) Export details to the local PC.

1. Click  and enter a compression password to create an export task.
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NO TE

– For details about the requirements of the compression password, see the prompt
on the page. The compression password is used to open the downloaded package.

The exported data contains personal data. Exercise caution when processing the
exported data to prevent personal data leakage and abuse.

– In the independent deployment environment, you can click  to export call
details without entering a compression password.

2. Click  to view the export tasks in the last seven days.
3. Click download in the Operation column corresponding to the created export

task to download the exported details to the local PC. When opening the file,
you need to enter the compression password set when you create the export
task.

----End

4.3.3 Report Query
The AICC provides 14 reports. The first 13 reports include daily, weekly, and
monthly reports. A tenant administrator can view various indicators in the reports
and export the reports to the local PC.

NO TE

The exported data contains personal data. Exercise caution when processing the exported
data to prevent personal data leakage and abuse.

4.3.3.1 VDN Traffic Report

The VDN traffic report collects statistics on the inbound call traffic of the call
center in a specified period, and provides indicators including the total number of
inbound calls, number of calls answered by IVRs, and number of calls answered by
agents.

Procedure

Step 1 Sign in to the AICC as a tenant administrator or an inspector and choose Report >
VDN Traffic Report to query VDN traffic report data.

Figure 4-68 VDN Traffic Report
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● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.
– Daily report: The time range cannot exceed 31 days.
– Weekly report: Set the start year and week as well as the end ones.
– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down list boxes
support search and filtering.

● User Level: The options are existing customer levels of the VDN on the web
configuration console.

● Media Type: The options are Voice, Multimedia, Video, Voice Click to Dial,
and Video Click to Dial.

● Submedia Type: This parameter needs to be set when Media Type is set to
Multimedia. The options are Web, WhatsApp, LINE, WeChat, Facebook, X
(Twitter), 5G RCS, Email, and SMS.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.

Figure 4-69 Filter Indicator dialog box

Table 4-2 Indicators in the Filter Indicator dialog box

Indicator Description

Total system
inbound calls

Total number of system inbound calls (excluding internal
inbound calls).
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Indicator Description

Successful
system
inbound calls

Number of successful system inbound calls, including the
calls during IVR voice playback, queuing, ringing at agent
voice terminals, and agent answering (excluding internal
inbound calls).

System
inbound call
success rate
(%)

Percentage of successful system inbound calls to total
system inbound calls.

Failed
system
inbound calls

Number of failed system inbound calls = Total number of
system inbound calls – Number of successful system
inbound calls

IVR inbound
calls

Total number of inbound calls connected to the IVR.

Connected
IVR inbound
calls

Number of IVR inbound calls whose call duration is greater
than 0.

IVR inbound
call
connection
rate (%)

Percentage of connected IVR inbound calls in IVR inbound
call requests.

Pure-IVR
inbound calls

Number of inbound calls that are processed only by the IVR
and do not request manual service.

Successful
pure-IVR
inbound calls

Number of successful inbound calls processed only by the
IVR, that is, number of successful inbound calls that are not
processed by any agent.

Pure-IVR
inbound call
success rate
(%)

Percentage of calls processed only by the IVR to total
inbound calls.
Pure-IVR inbound call success rate = Successful pure-IVR
inbound calls/(Successful pure-IVR inbound calls + Number
of agent answered calls) x 100

Manual
inbound calls

Total number of inbound calls requesting agent services.

Manual
request rate
(%)

Percentage of inbound calls requesting manual service to
total inbound calls.
Manual request rate = Number of manual inbound calls/
(Number of manual inbound calls + Number of pure-IVR
inbound calls) x 100

Agent
answered
calls

Number of calls successfully answered by agents.
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Indicator Description

Manual
inbound call
success rate
(%)

Percentage of agent answered calls to manual inbound
calls.

Manual
success rate
in total
inbound calls
(%)

Percentage of agent answered calls to total inbound calls.
Manual success rate in total inbound calls = Number of
agent answered calls/(Number of successful IVR inbound
calls + Number of agent answered calls) x 100

Called
agents

Number of agents who receive inbound calls.

Agent calls Number of incoming calls assigned to each agent during
the selected time period.

 
2. Select the report indicators to be displayed and click OK to save the

configuration.

Step 3 Switch the data display mode.
● Click Switch To Chart to switch the data display mode from table to line

chart and bar chart.
In chart mode, you can set search criteria and click Search to filter specific
data based on the search criteria.

● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.
2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.
– Compressed password: The value is a string of 8 to 12 characters and

must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

▪ The compression password is used to open the downloaded package.

▪ You do not need to configure the compression password in the independent
deployment environment.

– Click OK to create an export task.
3. Click Export task view to view the export tasks in the last seven days.
4. Select the created export task based on Export Start Time and Status, and

click download to export the report file to the local PC. To open the report
file on the local PC, you need to enter the compression password set when
you create the export task.

----End
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4.3.3.2 VDN Traffic Report by Access Code

The VDN traffic report by access code collects statistics on the inbound call traffic
of the call center by access code in a specified period, and provides indicators
including the total number of inbound calls, number of calls answered by IVRs,
and number of calls answered by agents.

Procedure

Step 1 Sign in to the AICC as a tenant administrator or an inspector and choose Report >
VDN Traffic Report by AccessCode to query VDN traffic report data by access
code.

Figure 4-70 VDN Traffic Report by AccessCode

● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.
– Daily report: The time range cannot exceed 31 days.
– Weekly report: Set the start year and week as well as the end ones.
– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down list boxes
support search and filtering.

● Access Code: Fuzzy search is supported. The value is a number of at least
three digits. In chart mode, the value can contain fewer than three digits.

● User Level: The options are existing customer levels of the VDN on the web
configuration console.

● Media Type: The options are Voice, Multimedia, Video, Voice Click to Dial,
and Video Click to Dial.

● Submedia Type: This parameter needs to be set when Media Type is set to
Multimedia. The options are Web, WhatsApp, LINE, WeChat, Facebook, X
(Twitter), 5G RCS, Email, and SMS.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.
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Figure 4-71 Filter Indicator dialog box

Table 4-3 Indicators in the Filter Indicator dialog box

Indicator Description

Total system
inbound calls

Total number of system inbound calls (excluding internal
inbound calls).

Successful
system
inbound calls

Number of successful system inbound calls, including the
calls during IVR voice playback, queuing, ringing at agent
voice terminals, and agent answering (excluding internal
inbound calls).

System
inbound call
success rate
(%)

Percentage of successful system inbound calls to total
system inbound calls.

Failed
system
inbound calls

Number of failed system inbound calls = Total number of
system inbound calls – Number of successful system
inbound calls

IVR inbound
calls

Total number of inbound calls connected to the IVR.

Connected
IVR inbound
calls

Number of IVR inbound calls whose call duration is greater
than 0.

IVR inbound
call
connection
rate (%)

Percentage of connected IVR inbound calls to IVR inbound
call requests.

Pure-IVR
inbound calls

Number of inbound calls that are processed only by the IVR
and do not request manual service.
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Indicator Description

Successful
pure-IVR
inbound calls

Number of successful inbound calls processed only by the
IVR, that is, number of successful inbound calls that are not
processed by any agent.

Pure-IVR
inbound call
success rate
(%)

Percentage of calls processed only by the IVR to total
inbound calls.
Pure-IVR inbound call success rate = Successful pure-IVR
inbound calls/(Successful pure-IVR inbound calls + Number
of agent answered calls) x 100

Manual
inbound calls

Total number of inbound calls requesting agent services.

Manual
request rate
(%)

Percentage of inbound calls requesting manual service to
total inbound calls.
Manual request rate = Number of manual inbound calls/
(Number of manual inbound calls + Number of pure-IVR
inbound calls) x 100

Agent
answered
calls

Number of calls successfully answered by agents.

Manual
inbound call
success rate
(%)

Percentage of agent answered calls to manual inbound
calls.

Manual
success rate
in total
inbound calls
(%)

Percentage of agent answered calls to total inbound calls.
Manual success rate in total inbound calls = Number of
agent answered calls/(Number of successful IVR inbound
calls + Number of agent answered calls) x 100

Called
agents

Number of agents who receive inbound calls.

Agent calls Number of incoming calls assigned to each agent during
the selected time period.

 
2. Select the report indicators to be displayed and click OK to save the

configuration.

Step 3 Switch the data display mode.
● Click Switch To Chart to switch the data display mode from table to line

chart and bar chart.
In chart mode, you can set search criteria and click Search to filter specific
data based on the search criteria.

● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.
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Step 4 Export report data.

1. Click New export task. The export task page is displayed.
2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.
– Compressed password: The value is a string of 8 to 12 characters and

must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

▪ The compression password is used to open the downloaded package.

▪ You do not need to configure the compression password in the independent
deployment environment.

– Click OK to create an export task.
3. Click Export task view to view the export tasks in the last seven days.
4. Select the created export task based on Export Start Time and Status, and

click download to export the report file to the local PC. To open the report
file on the local PC, you need to enter the compression password set when
you create the export task.

----End

4.3.3.3 IVR Traffic Report
The IVR traffic report collects statistics on the inbound call traffic of IVRs in a
specified period, and provides indicators including the number of inbound calls
and number of successful inbound calls.

Procedure

Step 1 Sign in to the AICC as a tenant administrator or an inspector and choose Report >
IVR Traffic Report to query IVR traffic report data.

Figure 4-72 IVR Traffic Report

● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.
– Daily report: The time range cannot exceed 31 days.
– Weekly report: Set the start year and week as well as the end ones.
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– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down list boxes
support search and filtering.

● User Level: The options are existing customer levels of the VDN on the web
configuration console.

● Media Type: The options are Voice, Multimedia, Video, Voice Click to Dial,
and Video Click to Dial.

● Submedia Type: This parameter needs to be set when Media Type is set to
Multimedia. The options are Web, WhatsApp, LINE, WeChat, Facebook, X
(Twitter), 5G RCS, Email, and SMS.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.

Figure 4-73 Filter Indicator dialog box

Table 4-4 Indicators in the Filter Indicator dialog box

Indicator Description

IVR inbound
calls

Total number of inbound calls made using the IVR.

Connected
IVR inbound
calls

Number of IVR inbound calls whose call duration is greater
than 0.

IVR inbound
call
connection
rate (%)

Percentage of the number of connected IVR inbound calls in
the number of IVR inbound call requests.
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Indicator Description

Successful
pure-IVR
inbound calls

Number of successful inbound calls processed only by the
IVR, that is, number of successful inbound calls that are not
processed by any agent.

Pure-IVR
inbound call
success rate
(%)

Percentage of the number of calls processed only by the IVR
in the total number of inbound calls. Pure-IVR inbound call
success rate = Successful pure-IVR inbound calls/(Successful
pure-IVR inbound calls + Number of agent answered calls) x
100

IVR Short
Calls
Num(Within
3s)

Number of calls whose IVR duration is greater than 0 and
less than or equal to 3 seconds.

Total IVR
Service
Time(S)

Total IVR call duration. If a call is connected to the IVR for
multiple times, the IVR service duration is the total IVR call
duration.

Average IVR
Inbound Call
Duration(S)

Average IVR inbound call duration = IVR inbound call
duration/Number of connected IVR inbound calls

 
2. Select the report indicators to be displayed and click OK to save the

configuration.

Step 3 Switch the data display mode.
● Click Switch To Chart to switch the data display mode from table to line

chart and bar chart.
In chart mode, you can set search criteria and click Search to filter specific
data based on the search criteria.

● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.
2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.
– Compressed password: The value is a string of 8 to 12 characters and

must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

▪ The compression password is used to open the downloaded package.

▪ You do not need to configure the compression password in the independent
deployment environment.

– Click OK to create an export task.
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3. Click Export task view to view the export tasks in the last seven days.
4. Select the created export task based on Export Start Time and Status, and

click download to export the report file to the local PC. To open the report
file on the local PC, you need to enter the compression password set when
you create the export task.

----End

4.3.3.4 IVR Traffic Report by Access Code
The IVR traffic report by access code collects statistics on the inbound call traffic
of IVRs by access code in a specified period, and provides indicators including the
number of inbound calls and number of successful inbound calls.

Procedure

Step 1 Sign in to the AICC as a tenant administrator or an inspector and choose Report >
IVR Traffic Report by AccessCode to query IVR traffic report data by access code.

Figure 4-74 IVR Traffic Report by AccessCode

● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.
– Daily report: The time range cannot exceed 31 days.
– Weekly report: Set the start year and week as well as the end ones.
– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down list boxes
support search and filtering.

● Access Code: Fuzzy search is supported. The value is a number of at least
three digits. In chart mode, the value can contain fewer than three digits.

● User Level: The options are existing customer levels of the VDN on the web
configuration console.

● Media Type: The options are Voice, Multimedia, Video, Voice Click to Dial,
and Video Click to Dial.

● Submedia Type: This parameter needs to be set when Media Type is set to
Multimedia. The options are Web, WhatsApp, LINE, WeChat, Facebook, X
(Twitter), 5G RCS, Email, and SMS.
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Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.

Figure 4-75 Filter Indicator dialog box

Table 4-5 Indicators in the Filter Indicator dialog box

Indicator Description

IVR inbound
calls

Total number of inbound calls made using the IVR.

Connected
IVR inbound
calls

Number of IVR inbound calls whose call duration is greater
than 0.

IVR inbound
call
connection
rate (%)

Percentage of the number of connected IVR inbound calls in
the number of IVR inbound call requests.

Successful
pure-IVR
inbound calls

Number of successful inbound calls processed only by the
IVR, that is, number of successful inbound calls that are not
processed by any agent.

Pure-IVR
inbound call
success rate
(%)

Percentage of the number of calls processed only by the IVR
in the total number of inbound calls. Pure-IVR inbound call
success rate = Successful pure-IVR inbound calls/(Successful
pure-IVR inbound calls + Number of agent answered calls) x
100

IVR Short
Calls
Num(Within
3s)

Number of calls whose IVR duration is greater than 0 and
less than or equal to 3 seconds.

CEC
User Guide 4 Inspector Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1508



Indicator Description

Total IVR
Service
Time(S)

Total IVR call duration. If a call is connected to the IVR for
multiple times, the IVR service duration is the total IVR call
duration.

Average IVR
Inbound Call
Duration(S)

Average IVR inbound call duration = IVR inbound call
duration/Number of connected IVR inbound calls

 
2. Select the report indicators to be displayed and click OK to save the

configuration.

Step 3 Switch the data display mode.
● Click Switch To Chart to switch the data display mode from table to line

chart and bar chart.
In chart mode, you can set search criteria and click Search to filter specific
data based on the search criteria.

● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.
2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.
– Compressed password: The value is a string of 8 to 12 characters and

must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

▪ The compression password is used to open the downloaded package.

▪ You do not need to configure the compression password in the independent
deployment environment.

– Click OK to create an export task.
3. Click Export task view to view the export tasks in the last seven days.
4. Select the created export task based on Export Start Time and Status, and

click download to export the report file to the local PC. To open the report
file on the local PC, you need to enter the compression password set when
you create the export task.

----End

4.3.3.5 Skill Queue Traffic Report

The skill queue traffic report collects statistics on the inbound call traffic of skill
queues in a specified period, and provides indicators including the number of
inbound calls, call duration, and number of abandoned calls.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator or an inspector and choose Report >
Skill Queue Traffic Report to query skill queue traffic report data.

Figure 4-76 Skill Queue Traffic Report

● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.
– Daily report: The time range cannot exceed 31 days.
– Weekly report: Set the start year and week as well as the end ones.
– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down list boxes
support search and filtering.

● Skill Queue: Select a skill queue that has been configured in the call center
configuration.

● User Level: The options are existing customer levels of the VDN on the web
configuration console.

● Media Type: The options are Voice, Multimedia, Video, Voice Click to Dial,
and Video Click to Dial.

● Submedia Type: This parameter needs to be set when Media Type is set to
Multimedia. The options are Web, WhatsApp, LINE, WeChat, Facebook, X
(Twitter), 5G RCS, Email, and SMS.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.
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Figure 4-77 Filter Indicator dialog box

Table 4-6 Indicators in the Filter Indicator dialog box

Indicator Description

Service
requests

Number of inbound calls requesting manual service.

Number of
connected
manual calls

Number of inbound calls connected by agents.

Request
connection
rate (%)

Percentage of connected manual inbound call requests to
manual inbound calls requesting services.

Lost call
requests

Number of lost call requests = Number of service requests
– Number of connected call requests

Manual
Inbound Call
Connection
Number in
15s

Number of call requests connected to agents within 15
seconds.

Manual
inbound call
connection
rate in 15s
(%)

Percentage of call requests connected to agents within 15
seconds to total calls requesting manual service.

Manual
Inbound Call
Connection
Number in
20s

Number of call requests connected to agents within 20
seconds.
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Indicator Description

Manual
inbound call
connection
rate in 20s
(%)

Percentage of call requests connected to agents within 20
seconds to total calls requesting manual service.

Manual
Inbound Call
Connection
Number in
30s

Number of call requests connected to agents within 30
seconds.

Manual
inbound call
connection
rate in 30s
(%)

Percentage of call requests connected to agents within 30
seconds to total calls requesting manual service.

Average
waiting
duration (s)

Average waiting duration of all connected calls in a queue.

Average ring
duration of
lost calls (s)

Average ring duration of all unanswered calls.

Average call
duration (s)

Average call duration.
Average duration of connected manual inbound calls =
Duration of connected manual inbound calls/Number of
connected manual inbound calls

Average ring
duration of
manual
inbound calls
(s)

Average ring duration of an agent's terminal.
Average ring duration of manual inbound calls = Total ring
duration of manual inbound calls/Number of answering
times

Abandoned
queuing calls

Number of calls proactively abandoned by customers
during queuing.

Unanswered
calls

Number of unanswered calls after being assigned to
agents.

 
2. Select the report indicators to be displayed and click OK to save the

configuration.

Step 3 Switch the data display mode.
● Click Switch To Chart to switch the data display mode from table to line

chart and bar chart.
In chart mode, you can set search criteria and click Search to filter specific
data based on the search criteria.
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● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.
2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.
– Compressed password: The value is a string of 8 to 12 characters and

must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

▪ The compression password is used to open the downloaded package.

▪ You do not need to configure the compression password in the independent
deployment environment.

– Click OK to create an export task.
3. Click Export task view to view the export tasks in the last seven days.
4. Select the created export task based on Export Start Time and Status, and

click download to export the report file to the local PC. To open the report
file on the local PC, you need to enter the compression password set when
you create the export task.

----End

4.3.3.6 Skill Queue Traffic Report by Access Code
The skill queue traffic report by access code collects statistics on the inbound call
traffic of skill queues by access code in a specified period, and provides indicators
including the number of inbound calls, call duration, and number of abandoned
calls.

Procedure

Step 1 Sign in to the AICC as a tenant administrator or an inspector and choose Report >
Skill Queue Traffic Report by AccessCode to query skill queue traffic report data
by access code.
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Figure 4-78 Skill Queue Traffic Report by AccessCode

● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.
– Daily report: The time range cannot exceed 31 days.
– Weekly report: Set the start year and week as well as the end ones.
– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down list boxes
support search and filtering.

● Skill Queue: Select a skill queue that has been configured in the call center
configuration.

● Access Code: Fuzzy search is supported. The value is a number of at least
three digits. In chart mode, the value can contain fewer than three digits.

● User Level: The options are existing customer levels of the VDN on the web
configuration console.

● Media Type: The options are Voice, Multimedia, Video, Voice Click to Dial,
and Video Click to Dial.

● Submedia Type: This parameter needs to be set when Media Type is set to
Multimedia. The options are Web, WhatsApp, LINE, WeChat, Facebook, X
(Twitter), 5G RCS, Email, and SMS.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.
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Figure 4-79 Filter Indicator dialog box

Table 4-7 Indicators in the Filter Indicator dialog box

Indicator Description

Service
requests

Number of inbound calls requesting manual service.

Number of
connected
manual calls

Number of inbound calls connected by agents.

Request
connection
rate (%)

Percentage of connected manual inbound call requests to
manual inbound calls requesting services.

Lost call
requests

Number of lost call requests = Number of service requests
– Number of connected call requests

Manual
Inbound Call
Connection
Number in
15s

Number of call requests connected to agents within 15
seconds.

Manual
inbound call
connection
rate in 15s
(%)

Percentage of call requests connected to agents within 15
seconds to total calls requesting manual service.

Manual
Inbound Call
Connection
Number in
20s

Number of call requests connected to agents within 20
seconds.
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Indicator Description

Manual
inbound call
connection
rate in 20s
(%)

Percentage of call requests connected to agents within 20
seconds to total calls requesting manual service.

Manual
Inbound Call
Connection
Number in
30s

Number of call requests connected to agents within 30
seconds.

Manual
inbound call
connection
rate in 30s
(%)

Percentage of call requests connected to agents within 30
seconds to total calls requesting manual service.

Average
waiting
duration (s)

Average waiting duration of all connected calls in a queue.

Average ring
duration of
lost calls (s)

Average ring duration of all unanswered calls.

Average call
duration (s)

Average call duration.
Average duration of connected manual inbound calls =
Duration of connected manual inbound calls/Number of
connected manual inbound calls

Average ring
duration of
manual
inbound calls
(s)

Average ring duration of an agent's terminal.
Average ring duration of manual inbound calls = Total ring
duration of manual inbound calls/Number of answering
times

Abandoned
queuing calls

Number of calls proactively abandoned by customers
during queuing.

Unanswered
calls

Number of unanswered calls after being assigned to
agents.

 
2. Select the report indicators to be displayed and click OK to save the

configuration.

Step 3 Switch the data display mode.
● Click Switch To Chart to switch the data display mode from table to line

chart and bar chart.
In chart mode, you can set search criteria and click Search to filter specific
data based on the search criteria.
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● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.
2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.
– Compressed password: The value is a string of 8 to 12 characters and

must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

▪ The compression password is used to open the downloaded package.

▪ You do not need to configure the compression password in the independent
deployment environment.

– Click OK to create an export task.
3. Click Export task view to view the export tasks in the last seven days.
4. Select the created export task based on Export Start Time and Status, and

click download to export the report file to the local PC. To open the report
file on the local PC, you need to enter the compression password set when
you create the export task.

----End

4.3.3.7 Traffic Summary Report
The traffic summary report collects statistics on the call traffic in a specified
period, and provides indicators including the number of manual inbound calls,
number of manual outbound calls, call duration, wrap-up duration, idle duration,
and busy duration.

Procedure

Step 1 Sign in to the AICC as a tenant administrator or an inspector and choose Report >
Traffic Summary Report to query traffic summary report data.

Figure 4-80 Traffic Summary Report

● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.
– Daily report: The time range cannot exceed 31 days.
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– Weekly report: Set the start year and week as well as the end ones.

– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down list boxes
support search and filtering.

● User Level: The options are existing customer levels of the VDN on the web
configuration console.

● Media Type: The options are Voice, Multimedia, Video, Voice Click to Dial,
and Video Click to Dial.

● Submedia Type: This parameter needs to be set when Media Type is set to
Multimedia. The options are Web, WhatsApp, LINE, WeChat, Facebook, X
(Twitter), 5G RCS, Email, and SMS.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.

Figure 4-81 Filter Indicator dialog box

Table 4-8 Indicators in the Filter Indicator dialog box

Indicator Description

Service
requests

Number of inbound calls requesting manual services.

Number of
connected
manual calls

Number of inbound calls connected by agents.

Request
connection
rate (%)

Percentage of the number of connected manual inbound
call requests in the number of manual inbound calls
requesting services.
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Indicator Description

Average
queuing
duration of
connected
calls (s)

Average queueing duration of all connected calls in a
queue.

Manual call
connection
rate in 20s
(%)

Percentage of the number of calls manually connected in
20s in the total number of manually connected calls.

Average call
duration (s)

Average call duration. Average duration of connected
manual inbound calls = Duration of connected manual
inbound calls/Number of connected manual inbound calls

Average
inbound call
duration of
terminals (s)

Average inbound call duration through agent terminals.

Lost call
requests

Number of lost call requests = Number of service requests
– Number of connected call requests

Request loss
rate (%)

Request loss rate (%) = 100 (%) – Call connection rate (%)

Average ring
duration of
lost calls (s)

Average ring duration of all unanswered calls.

Max. waiting
duration (s)

Maximum waiting duration (queuing and ring duration) of
all calls.

Outbound
calls

Number of calls made by an agent to customers.

Connected
manual
outbound
calls

Number of connected manual outbound calls.

Outbound
call
connection
rate (%)

Percentage of the number of connected outbound calls in
the number of outbound calls.

Total failed
outbound
calls

Total number of failed outbound calls.
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Indicator Description

Average
Manual
Outbound
Call Duration
(s)

Average outbound call duration between an agent and
customers.

Average ring
duration of
outbound
calls (s)

Average ring duration of outbound calls = Total ring
duration of outbound calls/Number of answering times

Total
connected
calls

Number of connected inbound and outbound calls.

Average
successful
calls per hour

Average number of successful calls per hour in the selected
working time segment.

Called agents Number of agents who receive inbound calls.

Agent calls Number of incoming calls assigned to each agent during
the selected time period.

Work
duration rate
(%)

Work duration rate = (Total work duration – Rest
duration)/Total work duration x 100

Online rate
(%)

Online rate = (Manual call duration + Total wrap-up
duration + Total duration of other states)/(Total work
duration – Rest duration) x 100

Total work
duration (s)

Total duration from the time when an agent signs in to the
time when the agent signs out. Total work duration =
Manual call duration + Total wrap-up duration + Total busy
duration + Total rest duration + Total duration of other
states + Idle duration

Manual call
duration (s)

Total call duration of an agent, excluding the text chat
duration.

Manual call
duration rate
(%)

Manual call duration rate = Manual call duration/Total
work duration x 100

Average
manual call
duration (s)

Average call duration of an agent. Average manual call
duration = Manual call duration/Number of successful
manual calls

Total wrap-up
duration (s)

Total duration when an agent is in wrap-up state.
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Indicator Description

Wrap-up
duration rate
(%)

Wrap-up duration rate = (Total wrap-up duration/Total
work duration) x 100

Average
wrap-up
duration (s)

Average duration when an agent is in wrap-up state.
Average wrap-up duration = Total wrap-up duration/
Number of wrap-up times

Average
processing
duration (s)

Average processing duration = (Manual call duration +
Total wrap-up duration)/Number of successful manual calls

Total rest
duration (s)

Total leave duration of an agent or duration when the
agent is in rest state.

Rest duration
rate (%)

Rest duration rate = (Total rest duration/Total work
duration) x 100

Total busy
duration (s)

Total duration when an agent is in busy state.

Busy duration
rate (%)

Busy duration rate = (Total busy duration/Total work
duration) x 100

Total duration
of other
states (s)

Total duration when an agent is in another state, or call
duration of other skills when multiple skills exist.

Other
duration rate
(%)

Other duration rate = (Total duration of other states/Total
work duration) x 100

Total ring
duration (s)

Total ringing duration of an agent, excluding the call
duration.

Idle duration
(s)

Total duration when an agent is in idle state.

Idle Rate (%) Percentage of an agent's total idle duration in the total
work duration.

Hold duration
(s)

Total duration when an agent is in call hold state. The call
duration of an agent includes the call hold time.

Average hold
duration (s)

Average call hold duration. Average hold duration = Hold
duration/Number of hold times

 
2. Select the report indicators to be displayed and click OK to save the

configuration.

Step 3 Switch the data display mode.
● Click Switch To Chart to switch the data display mode from table to line

chart and bar chart.
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In chart mode, you can set search criteria and click Search to filter specific
data based on the search criteria.

● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.
2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.
– Compressed password: The value is a string of 8 to 12 characters and

must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

▪ The compression password is used to open the downloaded package.

▪ You do not need to configure the compression password in the independent
deployment environment.

– Click OK to create an export task.
3. Click Export task view to view the export tasks in the last seven days.
4. Select the created export task based on Export Start Time and Status, and

click download to export the report file to the local PC. To open the report
file on the local PC, you need to enter the compression password set when
you create the export task.

----End

4.3.3.8 Agent Traffic Report
The agent traffic report collects statistics on the activities of each agent in a
specified OU, and provides indicators including the number of inbound calls,
number of outbound calls, call duration, and connection operation duration of the
agents.

Procedure

Step 1 Sign in to the AICC as a tenant administrator or an inspector and choose Report >
Agent Traffic Report to query agent traffic report data.
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Figure 4-82 Agent Traffic Report

● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.
– Daily report: The time range cannot exceed 31 days.
– Weekly report: Set the start year and week as well as the end ones.
– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down lists support
search and filtering.

● Select OU

a. Click , select an OU in the Select OU dialog box, and click OK to save
the configuration. After the saving, the Start Agent ID and End Agent ID
text boxes are hidden, and the Select Agent selection box is displayed.

b. Click  to delete the selected OU. After the deletion, the Start Agent
ID and End Agent ID text boxes are displayed, and the Select Agent
selection box is hidden.
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NO TE

When you have the permission to view report OUs:

– The options are all OUs.

– If no OU is selected, the Start Agent ID and End Agent ID text boxes are
displayed.

– After an OU is selected, the options of the Select Agent selection box are agents
of the selected OU.

When you do not have the permission to view report OUs:

– The options are only the current OU and its lower-level OUs.

– If no OU is selected, the current agent ID is displayed in the Select Agent
selection box.

– After an OU is selected, if you are the manager of the OU, the options of the
Select Agent selection box are agents of the selected OU. If you are a common
agent of the OU, the current agent ID is displayed in the Select Agent selection
box.

● Select Agent: Click  to select an agent account.
● Start Agent ID: The value can contain a maximum of five characters. If no

value is entered, the search result contains the agent performance report data
of all agent IDs in the current tenant space.

● End Agent ID: The value can contain a maximum of five characters. The end
agent ID must be greater than or equal to the start agent ID.

● Media Type: The options are Voice, Multimedia, Video, Voice Click to Dial,
and Video Click to Dial.

● Submedia Type: This parameter needs to be set when Media Type is set to
Multimedia. The options are Web, WhatsApp, LINE, WeChat, Facebook, X
(Twitter), 5G RCS, Email, and SMS.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.

Figure 4-83 Filter Indicator dialog box

CEC
User Guide 4 Inspector Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1524



Table 4-9 Indicators in the Filter Indicator dialog box

Indicator Description

Manual
Incoming
Calls

Number of incoming call requests for manual service.

Number of
connected
manual calls

Number of inbound calls connected by an agent.

Inbound call
connection
rate (%)

Percentage of the number of connected manual incoming
calls to the number of manual incoming calls.

Number of
lost manual
incoming
calls

Number of lost manual incoming calls = Number of
manual incoming calls – Number of connected manual
incoming calls

Average ring
duration of
manual
inbound calls
(s)

Average ringing duration of an agent's terminal. Average
ringing duration of manual inbound calls = Total ringing
duration of manual inbound calls/Number of ringing calls

Average call
duration (s)

Average call duration. Average duration of connected
manual inbound calls = Duration of connected manual
inbound calls/Number of connected manual inbound calls

Manual
outbound
calls

Number of manual outbound calls, including the outbound
calls initiated by agents and those transferred from the IVR
to manual services.

Connected
manual
outbound
calls

Number of connected manual outbound calls.

Outbound
call
connection
rate (%)

Percentage of the number of connected outbound calls to
the number of outbound calls.

Average Ring
Duration of
Manual
Outbound
Calls (s)

Average time for an agent to wait for customers to answer
outbound calls.

Average
Manual
Outbound
Call Duration
(s)

Average outbound call duration between an agent and
customers.
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Indicator Description

Total
connected
calls

Number of connected inbound and outbound calls.

Average
manual
inbound calls
per hour

Average number of calls answered by an agent per hour in
the selected working time segment.

Work
duration rate
(%)

Work duration rate = (Total work duration – Rest
duration)/Total work duration x 100

Work state
duration rate
(%)

Work state duration rate = (Total call duration + Total
wrap-up duration)/(Total work duration – Rest duration) x
100

Total work
duration (s)

Total duration from the time when an agent signs in to the
time when the agent signs out. Total work duration =
Manual call duration + Total wrap-up duration + Total busy
duration + Total rest duration + Total duration of other
states + Idle duration

Manual call
duration (s)

Total call duration of an agent, excluding the text chat
duration.

Total talk
duration (s)

Total duration when an agent is in talking state.

Average
manual call
duration (s)

Average call duration of an agent. Average manual call
duration = Manual call duration/Number of successful
manual calls

Total wrap-up
duration (s)

Total duration when an agent is in wrap-up state.

Wrap-up
duration rate
(%)

Wrap-up duration rate = (Total wrap-up duration/Total
work duration) x 100

Average
wrap-up
duration (s)

Average duration when an agent is in wrap-up state.
Average wrap-up duration = Total wrap-up duration/
Number of wrap-up times

Average
processing
duration (s)

Average processing duration = (Manual call duration +
Total wrap-up duration)/Number of successful manual calls

Total rest
duration (s)

Total leave duration of an agent or duration when the
agent is in rest state.

Rest duration
rate (%)

Rest duration rate = (Total rest duration/Total work
duration) x 100
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Indicator Description

Total busy
duration (s)

Total duration when an agent is in busy state.

Busy duration
rate (%)

Busy duration rate = (Total busy duration/Total work
duration) x 100

Total ring
duration (s)

Total ringing duration of an agent, excluding the call
duration.

Idle duration
(s)

Total duration when an agent is in idle state.

Idle Rate (%) Percentage of an agent's total idle duration to the total
work duration.

Hold duration
(s)

Total duration when an agent is in call hold state. The call
duration of an agent includes the call hold time.

Average hold
duration (s)

Average call hold duration. Average hold duration = Hold
duration/Number of hold times

Percentage of
Call Duration
(%)

(Total talk duration/Total work duration) x 100

 
2. Select the report indicators to be displayed and click OK to save the

configuration.

Step 3 Switch the data display mode.
● Click Switch To Chart to switch the data display mode from table to line

chart and bar chart.

● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.
2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.
– Compressed password: The value is a string of 8 to 12 characters and

must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

▪ The compression password is used to open the downloaded package.

▪ You do not need to configure the compression password in the independent
deployment environment.

– Click OK to create an export task.
3. Click Export task view to view the export tasks in the last seven days.
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4. Select the created export task based on Export Start Time and Status, and
click download to export the report file to the local PC. To open the report
file on the local PC, you need to enter the compression password set when
you create the export task.

----End

4.3.3.9 Agent Outbound Call Report

The agent outbound call report collects statistics on the outbound call traffic of
each agent in a specified OU, and provides indicators including the number of
successful outbound calls, number of failed outbound calls, and outbound call
duration.

Procedure

Step 1 Sign in to the AICC as a tenant administrator or an inspector and choose Report >
Agent Outbound Call Report to query agent outbound call report data.

Figure 4-84 Agent Outbound Call Report

● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.
– Daily report: The time range cannot exceed 31 days.
– Weekly report: Set the start year and week as well as the end ones.
– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down lists support
search and filtering.

● Select OU

a. Click , select an OU in the Select OU dialog box, and click OK to save
the configuration. After the saving, the Start Agent ID and End Agent ID
text boxes are hidden, and the Select Agent selection box is displayed.
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b. Click  to delete the selected OU. After the deletion, the Start Agent
ID and End Agent ID text boxes are displayed, and the Select Agent
selection box is hidden.

NO TE

When you have the permission to view report OUs:
– The options are all OUs.
– If no OU is selected, the Start Agent ID and End Agent ID text boxes are

displayed.
– After an OU is selected, the options of the Select Agent selection box are agents

of the selected OU.
When you do not have the permission to view report OUs:
– The options are only the current OU and its lower-level OUs.
– If no OU is selected, the current agent ID is displayed in the Select Agent

selection box.
– After an OU is selected, if you are the manager of the OU, the options of the

Select Agent selection box are agents of the selected OU. If you are a common
agent of the OU, the current agent ID is displayed in the Select Agent selection
box.

● Select Agent: Click  to select an agent account.
● Start Agent ID: The value can contain a maximum of five characters. If no

value is entered, the search result contains the agent outbound call report
data of all agent IDs in the current tenant space.

● End Agent ID: The value can contain a maximum of five characters. The end
agent ID must be greater than or equal to the start agent ID.

● Media Type: The options are Voice, Multimedia, Video, Voice Click to Dial,
and Video Click to Dial.

● Submedia Type: This parameter needs to be set when Media Type is set to
Multimedia. The options are Web, WhatsApp, LINE, WeChat, Facebook, X
(Twitter), 5G RCS, Email, and SMS.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.
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Figure 4-85 Filter Indicator dialog box

Table 4-10 Indicators in the Filter Indicator dialog box

Indicator Description

Outbound
calls

Number of calls made by an agent to customers.

Connected
manual
outbound
calls

Number of connected manual outbound calls.

Outbound
call
connection
rate (%)

Percentage of the number of connected outbound calls to
the number of outbound calls.

Unanswered
outbound
calls

Number of outbound calls that are rejected by customers
or are not answered after ringing.

Invalid
outbound
calls

Number of outbound calls that cannot reach customers
due to invalid numbers or power-off.

Total failed
outbound
calls

Total number of failed outbound calls.

Total
outbound call
duration (s)

Total outbound call duration between an agent and
customers.
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Indicator Description

Average
Manual
Outbound
Call Duration
(s)

Average outbound call duration between an agent and
customers.

Total ring
duration of
outbound
calls (s)

Total ringing duration of outbound calls.

Average ring
duration of
outbound
calls (s)

Average ringing duration of outbound calls = Total ringing
duration of outbound calls/Number of ringing calls

 
2. Select the report indicators to be displayed and click OK to save the

configuration.

Step 3 Switch the data display mode.
● Click Switch To Chart to switch the data display mode from table to line

chart and bar chart.
In chart mode, you can set search criteria and click Search to filter specific
data based on the search criteria.

● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.
2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.
– Compressed password: The value is a string of 8 to 12 characters and

must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

▪ The compression password is used to open the downloaded package.

▪ You do not need to configure the compression password in the independent
deployment environment.

– Click OK to create an export task.
3. Click Export task view to view the export tasks in the last seven days.
4. Select the created export task based on Export Start Time and Status, and

click download to export the report file to the local PC. To open the report
file on the local PC, you need to enter the compression password set when
you create the export task.

----End
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4.3.3.10 Agent Operation Report

The agent operation report collects statistics on the connection operations and
duration of each agent in a specified OU, and provides indicators including the
number of sign-in times, number of sign-out times, connection status duration,
number of call transfers, and number of call hang-ups.

Procedure

Step 1 Sign in to the AICC as a tenant administrator or an inspector and choose Report >
Agent Operation Report to query agent connection report data.

Figure 4-86 Agent Operation Report

● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.

– Daily report: The time range cannot exceed 31 days.

– Weekly report: Set the start year and week as well as the end ones.

– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down lists support
search and filtering.

● Select OU

a. Click , select an OU in the Select OU dialog box, and click OK to save
the configuration. After the saving, the Start Agent ID and End Agent ID
text boxes are hidden, and the Select Agent selection box is displayed.

b. Click  to delete the selected OU. After the deletion, the Start Agent
ID and End Agent ID text boxes are displayed, and the Select Agent
selection box is hidden.
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NO TE

When you have the permission to view report OUs:

– The options are all OUs.

– If no OU is selected, the Start Agent ID and End Agent ID text boxes are
displayed.

– After an OU is selected, the options of the Select Agent selection box are agents
of the selected OU.

When you do not have the permission to view report OUs:

– The options are only the current OU and its lower-level OUs.

– If no OU is selected, the current agent ID is displayed in the Select Agent
selection box.

– After an OU is selected, if you are the manager of the OU, the options of the
Select Agent selection box are agents of the selected OU. If you are a common
agent of the OU, the current agent ID is displayed in the Select Agent selection
box.

● Select Agent: Click  to select an agent account.
● Start Agent ID: The value can contain a maximum of five characters. If no

value is entered, the search result contains the agent connection operation
report data of all agent IDs in the current tenant space.

● End Agent ID: The value can contain a maximum of five characters. The end
agent ID must be greater than or equal to the start agent ID.

● Media Type: The options are Voice, Multimedia, Video, Voice Click to Dial,
and Video Click to Dial.

● Submedia Type: This parameter needs to be set when Media Type is set to
Multimedia. The options are Web, WhatsApp, LINE, WeChat, Facebook, X
(Twitter), 5G RCS, Email, and SMS.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.

Figure 4-87 Filter Indicator dialog box
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Table 4-11 Indicators in the Filter Indicator dialog box

Indicator Description

Total work
duration (s)

Total duration from the time when an agent signs in to the
time when the agent signs out. Total work duration =
Manual call duration + Total wrap-up duration + Total busy
duration + Total rest duration + Total duration of other
states + Idle duration

Wrap-up
times

Number of times that an agent enters the wrap-up state.

Total wrap-up
duration (s)

Total duration when an agent is in wrap-up state.

Outbound
call wrap-up
times

Number of times that an agent enters the wrap-up state
after outbound calls end.

Outbound
call wrap-up
duration (s)

Wrap-up duration after outbound calls end.

Inbound call
wrap-up
times

Number of times that an agent enters the wrap-up state
after inbound calls end.

Inbound call
wrap-up
duration (s)

Wrap-up duration after inbound calls end.

Rest times Number of times an agent enters the rest state.

Total rest
duration (s)

Total leave duration of an agent or duration when the
agent is in rest state.

Hold times Number of hold times.

Hold duration
(s)

Total duration when an agent is in call hold state. The call
duration of an agent includes the call hold time.

Silence times Number of silence times.

Total silence
duration (s)

Silence duration.

Internal help
requests

Number of internal help requests.

Internal help
request
duration (s)

Duration of internal help requests.

Busy times Number of times an agent enters the busy state.

Total busy
duration (s)

Total duration when an agent is in busy state.
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Indicator Description

Voice playing
times

Number of voice playing times.

Voice playing
duration (s)

Voice playing duration.

Total duration
of other
states (s)

Total duration when an agent is in another state, or call
duration of other skills when multiple skills exist.

Sign-in times Number of sign-in times.

Sign-out
times

Number of sign-out times.

Three-party
calls

Number of three-party calls.

Internal
transfers

Number of internal transfer times.

Manual
transfer-out
times

Number of manual transfer-out times.

Manual-to-
IVR transfer
times

Number of manual-to-IVR transfer times.

Internal calls Number of internal calls.

Internal call
duration (s)

Internal call duration.

Manual-to-
skill queue
transfers

Number of manual-to-skill queue transfers.

Agent hang-
ups

Number of agent hang-ups.

Customer
hang-ups

Number of customer hang-ups.

System hang-
ups

Number of system hang-ups.

Number of
times that an
agent is
suspended to
transfer to
the IVR

Number of times that the agent suspends the call and
transfers the call to the IVR after the call is connected.
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Indicator Description

Number of
manual
transfers to
IVR and re-
transfers out

Number of times that the agent transfers to the IVR and
then transfers out.

 
2. Select the report indicators to be displayed and click OK to save the

configuration.

Step 3 Switch the data display mode.
● Click Switch To Chart to switch the data display mode from table to line

chart and bar chart.
In chart mode, you can set search criteria and click Search to filter specific
data based on the search criteria.

● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.
2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.
– Compressed password: The value is a string of 8 to 12 characters and

must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

▪ The compression password is used to open the downloaded package.

▪ You do not need to configure the compression password in the independent
deployment environment.

– Click OK to create an export task.
3. Click Export task view to view the export tasks in the last seven days.
4. Select the created export task based on Export Start Time and Status, and

click download to export the report file to the local PC. To open the report
file on the local PC, you need to enter the compression password set when
you create the export task.

----End

4.3.3.11 Abandoned Call in Ringing Report
The abandoned call in ringing report collects statistics on the number of calls
abandoned by customers before agents answer the calls.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator or an inspector and choose Report >
Abandoned Call in Ringing Report to query abandoned call in ringing report
data.

Figure 4-88 Abandoned Call in Ringing Report

● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.
– Daily report: The time range cannot exceed 31 days.
– Weekly report: Set the start year and week as well as the end ones.
– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down lists support
search and filtering.

● Select OU

a. Click , select an OU in the Select OU dialog box, and click OK to save
the configuration. After the saving, the Start Agent ID and End Agent ID
text boxes are hidden, and the Select Agent selection box is displayed.

b. Click  to delete the selected OU. After the deletion, the Start Agent
ID and End Agent ID text boxes are displayed, and the Select Agent
selection box is hidden.
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NO TE

When you have the permission to view report OUs:

– The options are all OUs.

– If no OU is selected, the Start Agent ID and End Agent ID text boxes are
displayed.

– After an OU is selected, the options of the Select Agent selection box are agents
of the selected OU.

When you do not have the permission to view report OUs:

– The options are only the current OU and its lower-level OUs.

– If no OU is selected, the current agent ID is displayed in the Select Agent
selection box.

– After an OU is selected, if you are the manager of the OU, the options of the
Select Agent selection box are agents of the selected OU. If you are a common
agent of the OU, the current agent ID is displayed in the Select Agent selection
box.

● Select Agent: Click  to select an agent account.
● Start Agent ID: The value can contain a maximum of five characters. If no

value is entered, the search result contains the abandoned calls (during
ringing) summary report data of all agent IDs in the current tenant space.

● End Agent ID: The value can contain a maximum of five characters. The end
agent ID must be greater than or equal to the start agent ID.

● Media Type: The options are Voice, Multimedia, Video, Voice Click to Dial,
and Video Click to Dial.

● Submedia Type: This parameter needs to be set when Media Type is set to
Multimedia. The options are Web, WhatsApp, LINE, WeChat, Facebook, X
(Twitter), 5G RCS, Email, and SMS.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.

Figure 4-89 Filter Indicator dialog box
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Table 4-12 Indicators in the Filter Indicator dialog box

Indicator Description

Calls
Abandoned in
Ring

Number of calls abandoned by the caller while ringing
without being answered.

 

2. Select the report indicators to be displayed and click OK to save the
configuration.

Step 3 Switch the data display mode.

● Click Switch To Chart to switch the data display mode from table to line
chart and bar chart.

In chart mode, you can set search criteria and click Search to filter specific
data based on the search criteria.

● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.

2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.

– Compressed password: The value is a string of 8 to 12 characters and
must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

▪ The compression password is used to open the downloaded package.

▪ You do not need to configure the compression password in the independent
deployment environment.

– Click OK to create an export task.

3. Click Export task view to view the export tasks in the last seven days.

4. Select the created export task based on Export Start Time and Status, and
click download to export the report file to the local PC. To open the report
file on the local PC, you need to enter the compression password set when
you create the export task.

----End

4.3.3.12 Interval-based VDN Traffic Report

The interval-based VDN traffic report collects statistics on the inbound call traffic
of the call center at a specified interval in a specified period, and provides
indicators including the total number of inbound calls, number of calls answered
by IVRs, and number of calls answered by agents.
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Procedure

Step 1 Sign in to the AICC as a tenant administrator or an inspector and choose Report >
Interval-Based VDN Traffic Report to query interval-based VDN traffic report
data.

Figure 4-90 Interval-Based VDN Traffic Report

● Statistical Step: The options are 15 minutes, 30 minutes, and 1 hour. The
default value is 15 minutes.

● Start Time: Only data of the last seven days can be queried. The time range
cannot exceed one day.

● End Time: Only data of the last seven days can be queried. The time range
cannot exceed one day.

● User Level: The options are existing customer levels of the VDN on the web
configuration console.

● Media Type: The options are Voice, Multimedia, Video, Voice Click to Dial,
and Video Click to Dial.

● Submedia Type: This parameter needs to be set when Media Type is set to
Multimedia. The options are Web, WhatsApp, LINE, WeChat, Facebook, X
(Twitter), 5G RCS, Email, and SMS.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.

Figure 4-91 Filter Indicator dialog box
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Table 4-13 Indicators in the Filter Indicator dialog box

Indicator Description

Inbound calls Total number of inbound calls in the VDN. The value is the
sum of manual inbound calls and inbound calls
automatically made using the IVR.

Connected
inbound calls

Number of connected inbound calls. The value is the sum
of connected manual inbound calls and inbound calls
automatically connected using the IVR.

IVR inbound
calls

Total number of calls connected to the IVR.

Connected
IVR inbound
calls

Number of IVR inbound calls whose call duration is greater
than 0.

Manual
inbound calls

Number of inbound calls assigned to skill queues or agents.

Connected
manual
inbound calls

Number of manual inbound calls connected to agents,
which is the number of manual inbound calls whose call
duration is greater than 0.

Outbound
calls

Number of manual and automatic outbound calls in the
VDN. The value is the sum of manual outbound calls and
outbound calls automatically made using the IVR.

Connected
outbound
calls

Number of automatic and manual outbound calls that are
answered by called parties. The value is the sum of
connected manual outbound calls and outbound calls
automatically connected using the IVR.

Pure-IVR
outbound
calls

Number of outbound calls made only by the IVR.

Connected
pure-IVR
outbound
calls

Number of connected pure-IVR outbound calls whose IVR
device occupation duration is greater than 0.

Manual
outbound
calls

Number of manual outbound calls made by agents.

Connected
manual
outbound
calls

Number of manual outbound calls connected to users,
which is the number of manual outbound calls whose call
duration is greater than 0.

Inbound call
connection
rate (%)

Percentage of connected inbound calls to total inbound
calls.
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Indicator Description

IVR inbound
call
connection
rate (%)

Percentage of connected IVR inbound calls to total IVR
inbound calls.

Manual
inbound call
connection
rate (%)

Percentage of connected manual inbound calls to total
manual inbound calls.

Outbound
call
connection
rate (%)

Percentage of connected outbound calls to total outbound
calls.

Pure-IVR
outbound call
connection
rate (%)

Percentage of connected pure-IVR outbound calls to total
pure-IVR outbound calls.

Manual
outbound call
connection
rate (%)

Percentage of connected manual outbound calls to total
manual outbound calls.

Average
inbound call
duration in
VDN (s)

Average inbound call duration in the VDN. The value is the
total inbound call duration divided by the number of
inbound calls.

Average
outbound call
duration in
VDN (s)

Average outbound call duration in the VDN. The value is
the total outbound call duration divided by the number of
outbound calls.

 
2. Select the report indicators to be displayed and click OK to save the

configuration.

Step 3 Switch the data display mode.
● Click Switch To Chart to switch the data display mode from table to line

chart and bar chart.
In chart mode, you can set search criteria and click Search to filter specific
data based on the search criteria.

● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.
2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.
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– Compressed password: The value is a string of 8 to 12 characters and
must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

▪ The compression password is used to open the downloaded package.

▪ You do not need to configure the compression password in the independent
deployment environment.

– Click OK to create an export task.
3. Click Export task view to view the export tasks in the last seven days.
4. Select the created export task based on Export Start Time and Status, and

click download to export the report file to the local PC. To open the report
file on the local PC, you need to enter the compression password set when
you create the export task.

----End

4.3.3.13 IVR Outbound Call Report
The IVR outbound call report collects statistics on the outbound call traffic of IVRs
in a specified period, and provides indicators including the number of outbound
calls and number of lost calls.

Procedure

Step 1 Sign in to the AICC as a tenant administrator or inspector and choose Report >
IVR Outbound Call Report to query IVR outbound call report data.

Figure 4-92 IVR Outbound Call Report

● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.
– Daily report: The time range cannot exceed 31 days.
– Weekly report: Set the start year and week as well as the end ones.
– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down list boxes
support search and filtering.
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● Voice Call Type: The options are One-click bidirectional call, Voice
notification, and Intelligent outgoing call.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.

Figure 4-93 Filter Indicator dialog box

Table 4-14 Indicators on the Filter Indicator page

Indicator Description

IVR outbound
calls

Total number of IVR outbound calls.

CEC
User Guide 4 Inspector Guide

Issue 01 (2025-01-21) Copyright © Huawei Technologies Co., Ltd. 1544



Indicator Description

Connected
IVR outbound
calls

Number of IVR outbound calls whose call duration is
greater than 0.

IVR outbound
call
connection
rate (%)

Percentage of connected IVR outbound calls to total IVR
outbound call requests.

Lost calls due
to busy lines

Number of calls that are not answered due to busy lines.

Lost calls due
to call
rejection

Number of calls that are not answered due to call rejection.

Lost calls due
to ringing
timeout

Number of calls that are not answered due to ringing
timeout.

Other lost
calls

Number of calls that are not answered due to reasons
other than busy lines, call rejection, and ringing timeout.

 
2. Select the report indicators to be displayed and click OK to save the

configuration.

Step 3 Switch the data display mode.
● Click Switch To Chart to switch the data display mode from table to line

chart and bar chart.
In chart mode, you can set search criteria and click Search to filter specific
data based on the search criteria.

● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.
2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.
– Compressed password: The value is a string of 8 to 12 characters and

must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

The compression password is used to open the downloaded package.

– Click OK to create an export task.
3. Click Export task view to view the export tasks in the last seven days.
4. Select the created export task based on Export Start Time and Status, and

click download to export the report file to the local PC. To open the report
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file on the local PC, you need to enter the compression password set when
you create the export task.

----End

4.3.3.14 System Performance Report
The system performance report collects statistics on the number of concurrent
calls of IVRs, agents, and skill queues, and provides indicators including the
maximum number of concurrent calls, minimum number of concurrent calls, and
average number of concurrent calls.

Procedure

Step 1 Sign in to the AICC as a tenant administrator or inspector and choose Report >
System Performance Report to query system performance report data.

Figure 4-94 System Performance Report

● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.
– Daily report: The time range cannot exceed 31 days.
– Weekly report: Set the start year and week as well as the end ones.
– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down list boxes
support search and filtering.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.
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Figure 4-95 Filter Indicator dialog box

Table 4-15 Indicators on the Filter Indicator page

Indicator Description

Min.
concurrent
agent
inbound calls

Minimum number of concurrent inbound calls whose
service device type is agent.

Max.
concurrent
agent
inbound calls

Maximum number of concurrent inbound calls whose
service device type is agent.

Avg.
concurrent
agent
inbound calls

Average number of concurrent inbound calls whose service
device type is agent.

Min.
concurrent
agent
outbound
calls

Minimum number of concurrent outbound calls whose
service device type is agent.

Max.
concurrent
agent
outbound
calls

Maximum number of concurrent outbound calls whose
service device type is agent.

Avg.
concurrent
agent
outbound
calls

Average number of concurrent outbound calls whose
service device type is agent.
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Indicator Description

Min.
concurrent
agent calls

Minimum number of concurrent calls whose service device
type is agent.

Max.
concurrent
agent calls

Maximum number of concurrent calls whose service device
type is agent.

Avg.
concurrent
agent calls

Average number of concurrent calls whose service device
type is agent.

Min.
concurrent
IVR inbound
calls

Minimum number of concurrent inbound calls whose
service device type is IVR.

Max.
concurrent
IVR inbound
calls

Maximum number of concurrent inbound calls whose
service device type is IVR.

Avg.
concurrent
IVR inbound
calls

Average number of concurrent inbound calls whose service
device type is IVR.

Min.
concurrent
IVR outbound
calls

Minimum number of concurrent outbound calls whose
service device type is IVR.

Max.
concurrent
IVR outbound
calls

Maximum number of concurrent outbound calls whose
service device type is IVR.

Avg.
concurrent
IVR outbound
calls

Average number of concurrent outbound calls whose
service device type is IVR.

Min.
concurrent
IVR calls

Minimum number of concurrent calls whose service device
type is IVR.

Max.
concurrent
IVR calls

Maximum number of concurrent calls whose service device
type is IVR.

Avg.
concurrent
IVR calls

Average number of concurrent calls whose service device
type is IVR.
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Indicator Description

Min.
concurrent
skill queue
inbound calls

Minimum number of concurrent inbound calls whose
service device type is skill queue.

Max.
concurrent
skill queue
inbound calls

Maximum number of concurrent inbound calls whose
service device type is skill queue.

Avg.
concurrent
skill queue
inbound calls

Average number of concurrent inbound calls whose service
device type is skill queue.

Min.
concurrent
skill queue
outbound
calls

Minimum number of concurrent outbound calls whose
service device type is skill queue.

Max.
concurrent
skill queue
outbound
calls

Maximum number of concurrent outbound calls whose
service device type is skill queue.

Avg.
concurrent
skill queue
outbound
calls

Average number of concurrent outbound calls whose
service device type is skill queue.

Min.
concurrent
skill queue
calls

Minimum number of concurrent calls whose service device
type is skill queue.

Max.
concurrent
skill queue
calls

Maximum number of concurrent calls whose service device
type is skill queue.

Avg.
concurrent
skill queue
calls

Average number of concurrent calls whose service device
type is skill queue.
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NO TE

All minimum numbers of concurrent calls are 0 only when the values of all related
indicators of the day are 0. Otherwise, the value is the minimum indicator value after
related indicators of the day whose values are 0 are excluded.

2. Select the report indicators to be displayed and click OK to save the
configuration.

Step 3 Switch the data display mode.
● Click Switch To Chart to switch the data display mode from table to line

chart and bar chart.
In chart mode, you can set search criteria and click Search to filter specific
data based on the search criteria.

● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.
2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.
– Compressed password: The value is a string of 8 to 12 characters and

must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

The compression password is used to open the downloaded package.

– Click OK to create an export task.
3. Click Export task view to view the export tasks in the last seven days.
4. Select the created export task based on Export Start Time and Status, and

click download to export the report file to the local PC. To open the report
file on the local PC, you need to enter the compression password set when
you create the export task.

----End

4.3.3.15 Agent Timesheet Report
The agent timesheet report collects statistics on the working status of agents in a
specified period, and provides indicators such as the connection operation duration
and number of connection operations.

Procedure

Step 1 Sign in to the AICC as a tenant administrator or an inspector and choose Report >
Agent Timesheet Report to query agent timesheet report data.
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Figure 4-96 Agent Timesheet Report

● Report Type: The options are Daily report, Weekly report, and Monthly
report.

● Report time: Set the time range for report data query.

– Daily report: The time range cannot exceed 31 days.

– Weekly report: Set the start year and week as well as the end ones.

– Monthly report: Set the start year and month as well as the end ones.

NO TE

The Start Week/End Week and Start Month/End Month drop-down list boxes
support search and filtering.

● Start Agent ID: The value can contain a maximum of five characters. If no
value is entered, the search result contains the agent timesheet report data of
all agent IDs in the current tenant space.

● End Agent ID: The value can contain a maximum of five characters. The end
agent ID must be greater than or equal to the start agent ID.

Step 2 Filter indicators.

1. Click Set Table Header. The Filter Indicator dialog box is displayed.

Figure 4-97 Filter Indicator dialog box
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Table 4-16 Indicators in the Filter Indicator dialog box

Indicator Description

work duration
(s)

Total duration from the time when an agent signs in to the
time when the agent signs out.

Manual call
duration (s)

Total call duration of an agent, excluding the text chat
duration.

Total
multimedia
processing
duration (s)

Total multimedia session duration.

Total ring
duration (s)

Total ring duration of an agent, excluding the call duration.

Wrap-up
duration (s)

Total duration when an agent is in wrap-up state.

Idle duration
(s)

Total duration when an agent is in idle state.

Busy duration
(s)

Total duration when an agent is in busy state.

Rest duration
(s)

Total leave duration of an agent or duration when the
agent is in rest state.

Other time(s) Other time = Total signed-in duration – Total net work
duration – Total idle duration – Total busy duration – Total
wrap-up duration – Total ring duration – Total rest duration
NOTE

The total net work duration indicates the duration when an agent
is in talking state. If the agent is in both a multimedia call and a
voice call for a period of time, the period is counted only once.

Total
Incoming
Voice Calls

Total number of voice inbound calls.

Total Number
of Outgoing
Voice Calls

Total number of voice outbound calls.

Total
Incoming
Multimedia
Calls

Total number of multimedia inbound calls.

Total number
of
multimedia
outgoing calls

Total number of multimedia outbound calls.

Rest times Number of times that an agent enters the rest state.
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Indicator Description

Busy times Number of times an agent enters the busy state.

Wrap-up
times

Number of times that an agent enters the wrap-up state.

Voice Call
Ratio (%)

Percentage of voice call duration to total work duration.

Idle Rate (%) Percentage of an agent's total idle duration to total work
duration.

Busy duration
rate (%)

Busy duration rate = (Total busy duration/Total work
duration) x 100

Rest duration
rate (%)

Rest duration rate = (Total rest duration/Total work
duration) x 100

Wrap-up
duration rate
(%)

Wrap-up duration rate = (Total wrap-up duration/Total
work duration) x 100

 

2. Select the report indicators to be displayed and click OK to save the
configuration.

Step 3 Switch the data display mode.

● Click Switch To Chart to switch the data display mode from table to line
chart and bar chart.

● Click Switch To Table to switch the data display mode from line chart and
bar chart to table.

Step 4 Export report data.

1. Click New export task. The export task page is displayed.

2. Configure an export task.

– Export File Format: The exported file can be in CSV or PDF format.

– Compressed password: The value is a string of 8 to 12 characters and
must contain letters, digits, and special characters (excluding |;&$-<>/\`!
#(){}, spaces, newline characters, and tabs).

NO TE

▪ The compression password is used to open the downloaded package.

▪ You do not need to configure the compression password in the independent
deployment environment.

– Click OK to create an export task.

3. Click Export task view to view the export tasks in the last seven days.

4. Select the created export task based on Export Start Time and Status, and
click download to export the report file to the local PC. To open the report
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file on the local PC, you need to enter the compression password set when
you create the export task.

----End
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