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Troubleshooting Cases

Updated on 2025-01-17 GMT+08:00

Context

You may encounter an Agent installation failure or exception after the Agent is installed. This section describes some common troubleshooting cases to help you quickly locate the problem.

Abnormal Agent Status

Symptom:

After the Agent has been installed, the Agent status was displayed as Abnormal in the client list.

Possible cause:

The Agent status is abnormal.

Solution:

  1. Check whether the Agent process is running properly. If the process has exited, start the process again.

    In Windows, double-click the agent_start.bat file. In Linux, run the service cbragent start command.

  2. Re-install the Agent.
  3. Check the time zone and date on the backup client. If the time difference between the client and server is greater than 15 minutes, adjust your local time based on the UTC time. If the Agent status remains abnormal after the client time is adjusted, wait for about half an hour until the system updates the latest Agent status.

Agent Installation Failed with Message "BackupService.7403, Invalid Agent" Returned

Symptom:

The Agent installation failed, and the message "BackupService.7403, Invalid Client" was returned.

Possible cause:

No hybrid cloud backup vault is available before you install the Agent.

Solution:

  1. Purchase a hybrid cloud backup vault on the CBR console.
  2. Re-install the Agent.

Agent Installation Failed with Message "Could not resolve host" Returned

Symptom:

The Agent installation failed, and the message "Could not resolve host" was returned.

Figure 1 "Could not resolve host" message

Possible cause:

The local DNS server cannot resolve the public domain name of Huawei Cloud.

Solution:

  1. Edit the resolv.conf file on the local host and check whether the DNS server is configured. If you access Huawei Cloud over the Internet, set the DNS server to 8.8.8.8.
  2. Re-install the Agent.

Agent Installation Failed with Message "Incorrect IAM authentication information" Returned

Symptom:

The Agent installation failed, and the message "Incorrect IAM authentication information" was returned.

Figure 2 "Incorrect IAM authentication information" message

Possible cause:

Wrong AK and SK were entered during installation.

Solution:

  1. Obtain the correct AK and SK and enter them again.
  2. Re-install the Agent.

Agent Installation in Windows Failed with "OpenSCManager failed" Recorded in the Log

Symptom:

The Agent installation in Windows failed, and "OpenSCManager failed" was recorded in the log.

Possible cause:

The installation script is not run as administrator.

Solution:

Run the installation script as administrator to re-install the Agent.

Backup Failed After the Agent of a Windows Client Was Re-installed, and the Agent Status Was Displayed as Abnormal on the Console

Symptom:

After the Agent of a Windows backup client was uninstalled and then re-installed, backups failed and the Agent status was displayed as Abnormal on the console.

Possible causes:

  • The Agent fails to send heartbeat messages, or the domain name is incorrect.
  • Writes to the Agent's configuration file fail or encounter an error.

Solution:

Uninstall the Agent and then re-install it.

Windows Client Was Offline and Failed to Be Restarted

Symptom:

The Agent installation in Windows failed, and "OpenSCManager failed" was recorded in the log.

Possible cause:

There are a large number of .tmp files (generated due to log compression exceptions) in the log directory.

Solution:

1. Delete all log files in the log directory and uninstall the Agent.

2. Re-install the Agent.

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