Help Center/ Virtual Private Network/ Troubleshooting/ Successful Client Connection but Unavailable Services/ Client Traffic Is Interrupted, and an Error Message Is Displayed During Connection Establishment
Updated on 2025-05-26 GMT+08:00

Client Traffic Is Interrupted, and an Error Message Is Displayed During Connection Establishment

Applicable Client

OpenVPN GUI

Symptom

The client is successfully connected, but cannot ping the IP address of an ECS. When the OpenVPN GUI client is restarted, the following message is displayed: "OPENVPNServiceInteractive" is not started. The log contains the following error information:

ERROR: route addition failed using CreateIpForwardEntry: access denied

Possible Causes

The OpenVPN client software is not running properly.

Procedure

  1. Enter Task Manager in the taskbar search box, and click Task Manager to open it.
  2. Click the Services tab, find the OPENVPNServiceInteractive service, and check its running status, as shown in Figure 1.
    Figure 1 Task Manager
    • If the service is running properly, go to step 3.
    • If the service is stopped, perform the following operations to change the startup type of the service:
      1. Right-click the service and choose Start to start the service.
      2. Click Open Services in the lower part of the Task Manager, as shown in Figure 2.
        Figure 2 Open Services
      3. Find the OpenVPN Interactive Service, right-click it, and choose Properties from the shortcut menu.
      4. Change the Startup type value of the service to Automatic, as shown in Figure 3.
        Figure 3 Changing the startup type
      5. Click OK.
  3. Disconnect the OpenVPN GUI client and reconnect it.