Help Center> Relational Database Service> Troubleshooting> RDS for MySQL> Connection Issues> Error 1251 Reported During Login to a DB Instance on the Navicat Client After the Database Version Is Upgraded
Updated on 2023-11-03 GMT+08:00

Error 1251 Reported During Login to a DB Instance on the Navicat Client After the Database Version Is Upgraded

Scenario

The following error is reported when a regular user logs in to a DB instance through the Navicat client after the database version is upgraded: 1251 - Client does not support authentication protocol requested by server;consider upgrading MySQL client.

Possible Causes

The identity authentication plugin of the username is caching_sha2_password. The database proxy does not support the caching_sha2_password plugin of RDS for MySQL 8.0, so an error is reported during the login.

Solution

  • Update the Navicat driver.
  • Change the encryption rule for user login to mysql_native_password for RDS for MySQL 8.0 DB instances.

    Run the select plugin from mysql.user where user="user_name"; statement on the DAS console to change the identity authentication plugin.