Error Message "Connection permission denied (publickey)" Is Displayed
Symptom
Error message "Connection permission denied (publickey)" is displayed when VS Code is connecting to a development environment. Please make sure the key file is correctly selected and the file permission is correct. You can view the instance keypair information on ModelArts console."
Possible Causes
The permission on the key file or the folder where the key is stored is incorrect, or the key is incorrect.
Solution
- Change the permission for the /home/ma-user directory. You are advised to set the permission to 755 or 750 to ensure user isolation and security.
chomd 755 /home/ma-user
chomd 750 /home/ma-user
- Check whether the key is the same as that bound to the instance.
- Stop the instance and go to the instance details page.
- Update the key. Click the Edit icon next to Authentication, and then click Create to create a key and then select it.
- Use VS Code to connect to the instance again and select the new key.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot