Help Center> ModelArts> Troubleshooting> Inference Deployment> AI Application Management> Insufficient Disk Space Is Displayed When a Service Is Deployed After an AI Application Is Imported
Updated on 2023-09-08 GMT+08:00

Insufficient Disk Space Is Displayed When a Service Is Deployed After an AI Application Is Imported

Symptom

After an AI application is imported, message "No space left on device" is displayed during service deployment.

Possible Causes

ModelArts uses containers to deploy services. There are size limitations for containers to run. If the size of your model file, custom file, or system file exceeds the Docker size, a message will be displayed, indicating that the image space is insufficient.

Solution

The maximum Docker size for a container in a public resource pool is 10 GB, and that for a container in a dedicated resource pool is 30 GB.

If the AI application is imported from OBS or a training job, the total size of the base image, model files, code, data files, and software packages cannot exceed the limit.

If the AI application is imported from a custom image, the total size of the decompressed image and image dependencies cannot exceed the limit.