Help Center/ Elastic Cloud Server/ Troubleshooting/ Remote Login/ Remote Login Errors on Windows/ What Should I Do If I'm Locked Out of My Account After Too Many Login or Password Change Attempts When Connecting to a Windows ECS?
Updated on 2025-12-16 GMT+08:00

What Should I Do If I'm Locked Out of My Account After Too Many Login or Password Change Attempts When Connecting to a Windows ECS?

Symptom

When you attempt to remotely log in to a Windows ECS, an error message is displayed indicating that your account has been locked out due to too many login or password change attempts.

Possible Causes

  • An account lockout policy has been configured in the Windows system's group policy. If there are too many failed password attempts, the account will be locked, preventing remote desktop login.
  • The Windows public image version is Windows 2022 . Account lockout policies are enabled by default.

Solution

You can change the account lockout threshold to 0 for the Windows group policy.

  1. Connect to the Windows ECS using VNC.

    For details, see Logging In to a Windows ECS Using VNC.

  2. In the lower left corner of Windows, right-click Start and click Run.
  3. Enter gpedit.msc in the displayed dialog box and click OK. The Local Group Policy Editor window is displayed.

  4. In the Local Group Policy Editor window, choose Computer Configuration > Windows Settings > Security Settings > Account Policies > Account Lockout Policy.

    Operations to disable the account lockout policy vary depending on Windows operating system versions. The following example is just for your reference.

    • Double-click Allow Administrator account lockout, select Disabled, and click OK.

    • Double-click Account lockout threshold, set the account lockout threshold to 0, and click OK.

  5. Connect to the Windows ECS using remote desktop.