Help Center> Data Replication Service> Troubleshooting> Failure Cases> Real-Time Migration and Synchronization from MySQL to MySQL> Full or Incremental Phase Error: service *** failed, cause by: Unable to connect to DBMS: ***
Updated on 2023-01-17 GMT+08:00

Full or Incremental Phase Error: service *** failed, cause by: Unable to connect to DBMS: ***

Scenarios

During a full or incremental migration or synchronization, an error is reported, and the log information is as follows: service *** failed, cause by: Unable to connect to DBMS: ***

Possible Causes

The connection to the source or destination database fails to be established.

Solution

  1. Check whether the source or destination database is running properly.
  2. Check whether the network connection between the DRS instance and the source or destination database is normal.
  3. Check whether the IP address of the DRS instance is allowed to access the source or destination database.