Help Center> Data Replication Service> Troubleshooting> Failure Cases> Real-Time Synchronization from PostgreSQL to PostgreSQL> Full Synchronization Error: Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections
Updated on 2023-01-17 GMT+08:00

Full Synchronization Error: Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections

Scenarios

During full synchronization, an error is reported, and the log information is as follows: service DATAMOVE failed, cause by: source engine postgresql client initialize failed, detail: Unable to connect to DBMS: url= %s/position3.0?client_encoding=UTF-8&ssl=false&sslmode=prefer user= %s, Caused by: Connection to %s refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.

Possible Causes

The connection to the source or destination database fails to be established.

Solution

Perform the following operations:

  1. Check whether the source or destination database is running properly.
  2. Check whether the DRS instance IP address is allowed by the listening port of the source or destination database.
    • For DRS tasks performed over a public network, the source database must allow access from the DRS instance EIP, and the destination database must allow access from the private IP address of the DRS instance.
    • For DRS tasks performed in a VPC, VPN, or Direct Connect network, both the source and destination databases must allow access from the private IP addresses of DRS instance.