Updated on 2023-01-17 GMT+08:00

Full Phase Error: Table *** already exists

Scenarios

During a full migration or synchronization, an error is reported, and the log information is as follows: service DATAMOVE failed, cause by: apply event=[type=table_rename_or_copy, index=null, schema_name= %s, object_name= %s] occur error, msg=rename table %s. %s error: Table '%s ' already exists.

Possible Causes

The table without a primary key already exists in the destination database.

Solution

  1. Contact the O&M engineers to delete the tables that do not have primary keys from the destination database.
  2. In the task list, locate the target task and click Resume in the Operation column to resume the task.