Updated on 2023-02-15 GMT+08:00

Full Phase Error: The table *** is full

Scenarios

During a full migration or synchronization, an error is reported, and the log information is as follows: service DATAMOVE failed, cause by: apply event=[type=table_data, batch_index_in_shard=1, table_schema=%s, table_name=%s, record_num=%s,] occur error, msg=apply data of table=`%s`.`%s` failed: The table *** is full.

Possible Causes

The destination database storage space is insufficient. As a result, data fails to be written to the destination database.

Solution

  1. Adjust the storage space of the destination database.

    • If RDS for MySQL is used, see RDS for MySQL Performance Tuning or contact RDS customer service to adjust the destination database storage space.
    • If an on-premises MySQL database or a MySQL database built on another cloud is used, contact database O&M engineers to check and adjust the destination database storage space.

  2. After the adjustment is complete, click Resume in the Operation column to resume the task.