Help Center> Cloud Search Service> Troubleshooting> Clusters> Why Do I Fail to Access CSS Using TransportClient?
Updated on 2023-10-10 GMT+08:00

Why Do I Fail to Access CSS Using TransportClient?

Symptom

CSS cannot be accessed using the Spring Data Elasticsearch method, and the error message "None of the configured nodes are available" is displayed.

Possible Causes

Generally, cluster.name needs to be configured when you access a cluster using TransportClient. The possible cause of access failure is that the Settings.EMPTY option is used or the setting is incorrect.

Procedure

For details about how to connect a client to a cluster, see Accessing the Cluster Through the Transport Client.