ALM-43850 KMS Service Unavailable
Alarm Description
The system checks the KMS service status every 60 seconds. This alarm is generated when the KMS service is unavailable.
This alarm is cleared when the KMS service recovers.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
43850 |
Critical |
Quality of service |
KMS |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
KMS cannot provide the encryption key management service. If you cannot obtain the key, data cannot be encrypted or decrypted, and services encrypted or decrypted using KMS fail.
Possible Causes
- The ZooKeeper service is abnormal.
- The KMSWebServer instance is abnormal.
Handling Procedure
Check the KMSWebServer status.
- On FusionInsight Manager, choose Cluster > Name of the desired cluster > Services > ZooKeeper, and check whether the service running status is normal.
- Rectify the fault by following the instructions in the help information of "ALM-13000 ZooKeeper Service Unavailable" and check whether the ZooKeeper running status is normal.
- On FusionInsight Manager, choose Cluster > Name of the desired cluster > Services> KMS. On theDashboard tab, check whether there is a node configured with the KMSWebServer role in the normal running status.
- choose O&M > Alarm > Alarms, check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 5.
Collect fault information.
- On FusionInsight Manager, choose O&M > Log > Download.
- In the Service area, select the following services of the desired cluster.
- ZooKeeper
- KrbServer
- Click OK.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M engineers and send the collected logs.
Alarm Clearance
After the fault is rectified, the system automatically clears this alarm. You do not need to manually clear it.
Related Information
None.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot