ALM-24006 Heap Memory Usage of Flume Server Exceeds the Threshold
Alarm Description
The system checks the heap memory usage of the Flume service every 60 seconds. This alarm is generated when the heap memory usage of the Flume instance exceeds the threshold for 10 consecutive times. This alarm is cleared when the heap memory usage is less than the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
24006 |
Critical (default threshold: 95%) Major (default threshold: 90%) |
Quality of service |
Flume |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
|
Additional Information |
Trigger Condition |
Specifies the alarm triggering condition. |
Impact on the System
If the heap memory overflows, the service may break down and the Flume instance may be unavailable.
Possible Causes
The heap memory of the Flume instance is overused or the heap memory is inappropriately allocated.
Handling Procedure
Check the heap memory usage.
- Log in to FusionInsight Manager and choose O&M. In the navigation pane on the left, choose Alarm > Alarms. On the page that is displayed, locate the row containing Flume Heap Memory Usage Exceeds the Threshold, and view the Location information. Check the name of the host for which the alarm is generated.
- On FusionInsight Manager, choose Cluster > Name of the target cluster > Services > Flume. On the page that is displayed, click the Instance tab. On the displayed tab page, select the role corresponding to the host name for which the alarm is generated and select Customize from the drop-down list in the upper right corner of the chart area. Choose Agent and select Flume Heap Memory Resource Percentage. Then, click OK.
- Check whether the heap memory used by Flume reaches the threshold (95% of the maximum heap memory by default).
- On FusionInsight Manager, choose Cluster > Name of the desired cluster > Service > Flume > Configuration. On the page that is displayed, click All Configurations and choose Flume > System. Set -Xmx in the GC_OPTS parameter to a larger value based on site requirements and save the configuration.
If this alarm is generated, the heap memory configured for Flume is insufficient for data transmission. You are advised to change the heap memory to: Channel capacity x Maximum size of a single data record x Number of channels. Note that the value of xmx cannot exceed the remaining memory of the node.
- Restart the affected services or instances and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 6.
Collect the fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select Flume for the target cluster.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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