ALM-24000 Flume Service Unavailable
Alarm Description
The alarm module checks the Flume service status every 180 seconds. This alarm is generated if the Flume service is abnormal.
This alarm is automatically cleared after the Flume service recovers.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
24000 |
Critical |
Error handling |
Flume |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
Flume cannot work and data transmission is interrupted.
Possible Causes
All Flume instances are faulty.
Handling Procedure
- Log in to a Flume node as user omm and run the ps -ef|grep "flume.role=server" command to check whether the Flume process exists on the node.
- In the alarm list, check whether alarm "Flume Service Unavailable" is cleared.
- If yes, no further action is required.
- If no, go to 3.
Collect the fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select Flume for the target cluster.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot