Help Center/ Migration Center/ Tool Guide/ FAQs/ How Do I Fix the Error "The collector is not installed" When a Discovery Task Fails?
Updated on 2024-09-05 GMT+08:00

How Do I Fix the Error "The collector is not installed" When a Discovery Task Fails?

Symptom

After the Edge device and resource credential were associated, the deep collection failed, and the failure cause was "The collector is not installed".

Possible Causes

Possible causes are:

  • The Edge device' specifications are insufficient for the collector to run properly. The recommended specifications are 4 vCPUs and 8 GB of memory.
  • The collector was offline. The Edge device's specifications are sufficient but the collector did not run.

Solutions

  • The Edge device's specifications are insufficient.

    Upgrade the Edge device's specifications or install Edge on a server with higher specifications. Then perform a deep collection again.

  • The collector was offline.

    The following table lists the collectors integrated in Edge. The server collector is used as an example to explain the method, which applies to other collectors as well.

    Collector

    Collected Resource

    Process

    Installation Directory

    rda-collector-platform

    VMware-based private cloud platforms

    rda-collector-platform.exe

    <Installation path>\Edge\tools\plugins\collectors

    rda-collector-server

    Server

    rda-collector-server.exe

    rda-collector-kubernetes

    Container

    rda-collector-kubernetes.exe

    1. Go to the bin directory in the collector installation directory on the Edge device, for example, C:\Edge\tools\plugins\collectors\rda-collector-server\bin.
    2. Double-click start.bat to start the server collector.

    3. Open Task Manager. On the details page, check the status of rda-collector-server.exe. If the status is Running, the collector is started.

    4. Return to the MgC console and click Collect in the Status column to collect the resource information again.