Help Center> Migration Center> Tool Guide> FAQs> How Do I Fix the Error "The collector is not installed" When a Discovery Task Fails?
Updated on 2024-01-17 GMT+08:00

How Do I Fix the Error "The collector is not installed" When a Discovery Task Fails?

Symptom

After the Edge device and resource credential are associated, the deeper discovery fails, and the failure cause is "The collector is not installed".

Possible Causes

The required collector on the Edge device became offline.

Solution

The solution described here is true for all collectors. The following table lists the collectors integrated in Edge.

Collector

Collected Resource

Process

Installation Directory

rda-collector-platform

Private cloud: Only VMware is supported.

rda-collector-platform.exe

<Installation path>\Edge\tools\plugins\collectors

rda-collector-server

Server

rda-collector-server.exe

rda-collector-kubernetes

Container

rda-collector-kubernetes.exe

  1. Go to the bin directory in the collector installation directory on the Edge device, for example, C:\Edge\tools\plugins\collectors\rda-collector-server\bin.
  2. Double-click start.bat to start the server collector.

  3. Open the task manager. On the details page, check the running status of the host collector rda-collector-server.exe. If the status is Running, the collector is started.

  4. Return to the MgC console and click Rediscover in the Status column to collect the resource again.