Help Center/ Server Migration Service/ FAQs/ Known Errors and Solutions/ SMS.9007 Migration task paused. Rate limit not applied. Rate exceeded limit multiple times.
Updated on 2024-10-15 GMT+08:00

SMS.9007 Migration task paused. Rate limit not applied. Rate exceeded limit multiple times.

Symptom

During the migration of a Linux server, the message "SMS.9007 Migration task paused. Rate limit not applied. Rate exceeded limit multiple times." was displayed.

Possible Causes

The configured rate limit was not applied due to the following reasons:

  • There were traffic limiting rules on the NIC of the source server.
  • Traffic Control (TC) was missing or abnormal on the source server.
  • Class Based Queuing (CBQ) was missing on the source server.
  • The source server did not have the route command.

Solutions

  • Check whether the source server has rate limiting rules (including but not limited to those for NICs) and evaluate whether deleting the existing rules will affect services. To view the NIC rate limiting rule, perform the following steps:

    Log in to the source server as the root user and run the following command to display the configurations of all NICs:

    ifconfig
    Run the following command to display the traffic control rules of a specific NIC. eth0 is used in the following example.
    tc qdisc show dev eth0
    • If deleting existing rules affects services, go to the SMS console, delete the migration rate limit you configured and start the migration task. For details, see Setting a Migration Rate.
    • If deleting existing rules does not affect services, run the following command to delete the rules. eth0 is used in the following example. Then click Start on the SMS console to continue the migration.
      tc qdisc del dev eth0 root
  • Run the following commands on the source server to check whether the required commands and modules are available:
    tc -V                Check whether TC is available.
    route                Check whether the route command is available.
    Run the lsmod | grep sch_cbq  Check whether CBQ is available.
    If any command or module is missing, rectify the fault and run the following command to delete related log files. Then click Start on the SMS console to continue the migration.
    rm -f /SMS-Agent/agent/Logs/handleRecord.log