Help Center> Server Migration Service> FAQs> Known Errors and Solutions> SMS.0410 Failed to Obtain NIC Information
Updated on 2024-03-29 GMT+08:00

SMS.0410 Failed to Obtain NIC Information

Symptom

When you started the Agent on a Linux server, one of the following messages was displayed:

  • SMS.0410: Failed to obtain NicName information of source server.

  • SMS.0410: Failed to obtain IPAddress information of source server.

Possible Causes

If the source server has multiple NICs, the Agent may fail to obtain the default gateway information of the source server. As a result, the correct NIC name, MAC address, and IP address cannot be obtained.

Solutions

  • Solution for error "SMS.0410: Failed to obtain NicName information of source server"
    1. View the routing table.
      #route -n

      The following table describes the parameters.

      Parameter

      Description

      Destination

      The destination IP address. The gateway corresponding to 0.0.0.0 is the default gateway.

      Gateway

      The gateway IP address.

      Iface

      The network interface.

      As shown in the preceding figure, if the source server has multiple default gateways, the Agent may fail to obtain the default gateway information. In this case, proceed with the subsequent steps.

    2. Check the network configuration.
      #ifconfig -a

      • The leftmost column lists NICs, such as ethx, ensx, and enp0sx.
      • inet is the IP address of a NIC.
      • ether is the MAC address of a NIC.
    3. Modify network.dev in the .../SMS-Agent/agent/config/g-property.cfg configuration file.

      You need to check which NIC of the source server is used for migration. Then set network.dev to the name of the NIC used for migration.

      Assume the NICs queried in step 2 include eth0, eth1, and eth2, and the NIC used for migration is eth0. network.dev must set to be eth0.

    4. After the configuration is complete, restart the Agent.
  • Solution for error "SMS.0410: Failed to obtain IPAddress information of source server"
    1. Check whether the network.dev parameter in the .../SMS-Agent/agent/config/g-property.cfg file has been configured.
      • If it has, go to step 2.
      • If it has not, go to step 3.
    2. Check whether the NIC specified by network.dev is correct by referring to Solution for error 1.
      • If the configuration is incorrect, modify it and restart the Agent. If the problem persists, go to step 3.
      • If the configuration is correct, go to step 3.
    3. Modify network.macaddr and network.ipaddr in the .../SMS-Agent/agent/config/g-property.cfg configuration file.

      Set network.macaddr and network.ipaddr to the values of inet (IP address) and ether (MAC address) corresponding to the correct NIC queried in step 2 in handling error 1.

      network.macaddr = xx-xx-xx-xx-xx-xx (MAC address)

      network.ipaddr = xxx.xxx.xxx.xxx (IP address)

      Both the MAC address and IP address need to be configured. The six groups of characters in the MAC address must be separated by hyphens (-).

    4. After the configuration is complete, restart the Agent.

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