SMS.0410 Failed to Obtain NIC Information
Symptom
When you started the Agent on a Linux server, one of the following messages was displayed:
Possible Causes
If the source server has multiple NICs, the Agent may fail to obtain the default gateway information of the source server. As a result, the correct NIC name, MAC address, and IP address cannot be obtained.
Solutions
- Solution for error "SMS.0410: Failed to obtain NicName information of source server"
- View the routing table.
#route -n
The following table describes the parameters.
Parameter
Description
Destination
The destination IP address. The gateway corresponding to 0.0.0.0 is the default gateway.
Gateway
The gateway IP address.
Iface
The network interface.
As shown in the preceding figure, if the source server has multiple default gateways, the Agent may fail to obtain the default gateway information. In this case, proceed with the subsequent steps.
- Check the network configuration.
#ifconfig -a
- The leftmost column lists NICs, such as ethx, ensx, and enp0sx.
- inet is the IP address of a NIC.
- ether is the MAC address of a NIC.
- Modify network.dev in the .../SMS-Agent/agent/config/g-property.cfg configuration file.
You need to check which NIC of the source server is used for migration. Then set network.dev to the name of the NIC used for migration.
Assume the NICs queried in step 2 include eth0, eth1, and eth2, and the NIC used for migration is eth0. network.dev must set to be eth0.
- After the configuration is complete, restart the Agent.
- View the routing table.
- Solution for error "SMS.0410: Failed to obtain IPAddress information of source server"
- Check whether the network.dev parameter in the .../SMS-Agent/agent/config/g-property.cfg file has been configured.
- Check whether the NIC specified by network.dev is correct by referring to Solution for error 1.
- Modify network.macaddr and network.ipaddr in the .../SMS-Agent/agent/config/g-property.cfg configuration file.
Set network.macaddr and network.ipaddr to the values of inet (IP address) and ether (MAC address) corresponding to the correct NIC queried in step 2 in handling error 1.
network.macaddr = xx-xx-xx-xx-xx-xx (MAC address)
network.ipaddr = xxx.xxx.xxx.xxx (IP address)
Both the MAC address and IP address need to be configured. The six groups of characters in the MAC address must be separated by hyphens (-).
- After the configuration is complete, restart the Agent.
Known Errors and Solutions FAQs
- SMS.0202 AK/SK Authentication Failed. Ensure that the AK and SK Are Correct
- SMS.0203 Connection from Source Server to API Gateway Timed Out
- SMS.0204 Insufficient Permissions. Obtain the Required Fine-Grained Permissions
- SMS.0205 Incorrect System Time or Time Zone On Source Server
- SMS.0206 Only x86 Servers Can Be Migrated
- SMS.0210 Failed to Create File on Target Server
- SMS.0303 Unable to Access Domain Name
- SMS.0410 Failed to Obtain NIC Information
- SMS.0412 Target Server Does Not Exist
- SMS.0515 Migration Failed. Source Disk Information Has Changed. Delete Target Server Configuration and Restart the Agent
- SMS.0609 An Older Version of Agent Is Detected. Please Exit The Current Program, Uninstall the Old Agent Completely, and Install the Newest One
- SMS.0805 Failed to Migrate Partition to Target Server
- SMS.0806 Failed to Synchronize Partition to Target Server
- SMS.1105 Disk Creation Failed
- SMS.1106 Failed to Delete Disk XXX
- SMS.1204 Failed to Create File on Source Server
- SMS.1205 Failed to Load WMI
- SMS.1351: Mount Point /xxx Detected on the Source Server, Which Has No Free Space. Ensure that There Is at Least 1 MB of Space
- SMS.1352: Unknown Physical Volumes Detected on the Source Server
- SMS.1353: Bind Mount or Repeated Mount Detected on /xxx of the Source Server
- SMS.1402 SSH Client Not Installed
- SMS.1414 The Migration Module Stopped Abnormally and Cannot Synchronize Data
- SMS.1807 Failed to Connect to the Target Server. Check Whether Its IP Address Is Reachable and Confirm that Port 8900 Is Enabled
- SMS.1901 Agent Could Not Read Disk Information
- SMS.1902 Failed to Start the I/O Monitoring Module
- SMS.1904 Failed to Create a Snapshot for the Windows Server
- SMS.2802 Failed to Connect to the Target Server. Check Whether Its IP Address Is Reachable and Port 8899 Is Enabled
- SMS.3205 Failed to Mount Partition XXX to Directory XXX
- SMS.3802 Failed to Establish an SSH Connection with the Target Server
- SMS.5102 Agent Startup Failed Because the noexec Permission Is Unavailable on /tmp in Linux
- SMS.5105 Agent Startup Failed. Insufficient Permissions to Add Files to or Delete Files from xxx
- SMS.5108 Failed to Execute df -TH
- SMS.6303 The Installed Agent Is of an Earlier Version. Download the Latest Version
- SMS.6509 Incompatible File System of the Source Server
- SMS.6511 The Source Server Lacks Driver Files
- SMS.6517 rsync Not Installed on the Source Server
- SMS.6528 Complete Real-name Authentication to Invoke SMS APIs
- SMS.6533 VSS Not Installed on the Source Server
- SMS.6537 SMS Cannot Migrate System Disks Larger Than 1 TB
- SMS.6562: Component i386-pc Not Found on Source Server For solution, see SMS API Reference
- SMS.6563: File initrd or initramfs of the xxxx version Not Found Under /boot Directory For solution, see SMS API Reference
- SMS.6616 The Current OS Does Not Support Block-level Migration/SMS.6617 The Current Kernel Version Does Not Support Block-level Migration
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