SMS.0303 Unable to Access Domain Name
Symptom
When you started the migration, the error message "SMS.0303 Unable to access domain name XXX" was displayed on the SMS console.
Possible Causes
For a successful migration, the source server must access all required domain names. If any domain name fails to be connected, this error message is displayed.
The possible causes are as follows:
- The network is abnormal, for example, the connection times out or the network is disconnected or inaccessible.
- The access is blocked by the firewall.
- Security alarms are generated on the source server, or the source server EIP is unbound or frozen.
- The access is blocked by the security group of the source server.
Solutions
- Ping another domain name.
- If the ping operation succeeds, the network is normal.
- If the ping operation fails, the network is abnormal. Check the local network.
- Check the firewall settings of the source server.
If the access is blocked, allow the access and continue the migration.
- Check whether security alarms are generated on the source server, or the source server EIP is unbound or frozen.
- If the EIP is unbound, you can bind it back or use a private network for migration.
- If the EIP is frozen, contact ECS or EIP technical support.
- Check whether the required outbound ports are allowed in the security group of the source server.
- If there are no outbound rules for the protocols and ports shown in Figure 1, add rules for them.
- If there are outbound rules for the ports but Action is set to Deny, change the actions to Allow.
- If there are outbound rules for allowing the ports but the destination IP addresses are not 0.0.0.0/0, change them to 0.0.0.0/0.
Known Errors and Solutions FAQs
- SMS.0202 AK/SK Authentication Failed. Ensure that the AK and SK Are Correct
- SMS.0203 Connection from Source Server to API Gateway Timed Out
- SMS.0204 Insufficient Permissions. Obtain the Required Fine-Grained Permissions
- SMS.0205 Incorrect System Time or Time Zone On Source Server
- SMS.0206 Only x86 Servers Can Be Migrated
- SMS.0210 Failed to Create File on Target Server
- SMS.0303 Unable to Access Domain Name
- SMS.0410 Failed to Obtain NIC Information
- SMS.0412 Target Server Does Not Exist
- SMS.0515 Migration Failed. Source Disk Information Has Changed. Delete Target Server Configuration and Restart the Agent
- SMS.0609 An Older Version of Agent Is Detected. Please Exit The Current Program, Uninstall the Old Agent Completely, and Install the Newest One
- SMS.0805 Failed to Migrate Partition to Target Server
- SMS.0806 Failed to Synchronize Partition to Target Server
- SMS.1105 Disk Creation Failed
- SMS.1106 Failed to Delete Disk XXX
- SMS.1204 Failed to Create File on Source Server
- SMS.1205 Failed to Load WMI
- SMS.1351: Mount Point /xxx Detected on the Source Server, Which Has No Free Space. Ensure that There Is at Least 1 MB of Space
- SMS.1352: Unknown Physical Volumes Detected on the Source Server
- SMS.1353: Bind Mount or Repeated Mount Detected on /xxx of the Source Server
- SMS.1402 SSH Client Not Installed
- SMS.1414 The Migration Module Stopped Abnormally and Cannot Synchronize Data
- SMS.1807 Failed to Connect to the Target Server. Check Whether Its IP Address Is Reachable and Confirm that Port 8900 Is Enabled
- SMS.1901 Agent Could Not Read Disk Information
- SMS.1902 Failed to Start the I/O Monitoring Module
- SMS.1904 Failed to Create a Snapshot for the Windows Server
- SMS.2802 Failed to Connect to the Target Server. Check Whether Its IP Address Is Reachable and Port 8899 Is Enabled
- SMS.3205 Failed to Mount Partition XXX to Directory XXX
- SMS.3802 Failed to Establish an SSH Connection with the Target Server
- SMS.5102 Agent Startup Failed Because the noexec Permission Is Unavailable on /tmp in Linux
- SMS.5105 Agent Startup Failed. Insufficient Permissions to Add Files to or Delete Files from xxx
- SMS.5108 Failed to Execute df -TH
- SMS.6303 The Installed Agent Is of an Earlier Version. Download the Latest Version
- SMS.6509 Incompatible File System of the Source Server
- SMS.6511 The Source Server Lacks Driver Files
- SMS.6517 rsync Not Installed on the Source Server
- SMS.6528 Complete Real-name Authentication to Invoke SMS APIs
- SMS.6533 VSS Not Installed on the Source Server
- SMS.6537 SMS Cannot Migrate System Disks Larger Than 1 TB
- SMS.6562: Component i386-pc Not Found on Source Server For solution, see SMS API Reference
- SMS.6563: File initrd or initramfs of the xxxx version Not Found Under /boot Directory For solution, see SMS API Reference
- SMS.6616 The Current OS Does Not Support Block-level Migration/SMS.6617 The Current Kernel Version Does Not Support Block-level Migration
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