Updated on 2024-08-01 GMT+08:00

SMS.1104 Failed to Detach disk xx

Symptom

A migration task failed, and the error message "SMS.1104 Failed to detach disk xxx. Failure cause: xxx" was displayed.

Possible Causes

During the migration, operations such as detaching disks, creating temporary disks, and attaching disks are performed on the target server. Detaching a disk from the target server may fail if:

  • The target server was locked or does not support disk detachment.

    Disks cannot be detached from a locked ECS, a spot ECS, a FlexusL instance (original HECS L), or a server created from an ISO image.

  • The purchase order was not completed.

    A disk cannot be detached if the server or disk purchase order is not completed.

Solutions

  • The target server was locked or does not support disk detachment.
    • If the target server was a spot ECS or a locked ECS, delete the current migration task, create a migration task again, and select another cloud server that supports disk detachment.
    • If the target server was a FlexusL instance (original HECS L), delete the current migration task, use the latest Agent, and create a migration task again.
    • If the target server was created from an ISO image, delete the current migration task. Then, use an ISO image to create a temporary ECS, use the temporary ECS to create a system disk image, use the system disk image to create an ECS, generate a new ECS, and use the new ECS to create a migration task.
  • The purchase order was not completed.

    If the target server was billed based on a yearly/monthly basis, check whether the server and disk purchase orders have been completed. If they are not, wait for the orders to complete or complete the orders and try the migration again.