Help Center> Server Migration Service> FAQs> Migration or Synchronization Failures> What Do I Do If the SMS-Agent Exits Suddenly and Disconnects a Windows Source Server from the SMS Console During a Migration?
Updated on 2023-11-29 GMT+08:00

What Do I Do If the SMS-Agent Exits Suddenly and Disconnects a Windows Source Server from the SMS Console During a Migration?

Symptom

During the migration of a Windows server, the source server was suddenly disconnected from the SMS console. It was found that the SMS-Agent program exited from the source server.

Possible Causes

The SMS-Agent program may exit if the Customer Experience Improvement Program is turned on on the source server.

  1. Check the disconnection time in the SMS-Agent migration logs stored in C:\SMS-Agent-Py3\SmsAgent_Info.log.

  2. On the source server, open Event Viewer > Windows Logs > System.

  3. In the system logs, check the log generated at the SMS-Agent disconnection time. The log says that the source server was automatically restarted due to a user logout notification for the customer experience improvement program.

Solution

Turn off the customer experience improvement program.

  1. On the source server, open the Run window, enter gpedit.msc, and click OK.
  2. In the navigation tree, choose Computer Configuration > Administrative Templates > System > Internet Communication Management > Internet Communication settings, and locate Turn off Windows Customer Experience Improvement Program.

  3. Double-click Turn off Windows Customer Experience Improvement Program. In the displayed window, select Enabled and click OK.

  4. Open Computer Management. Choose System Tools > Task Scheduler Library >Microsoft > Windows > Customer Experience Improvement Program, and disable all tasks.

  5. Choose System Tools > Task Scheduler Library > Microsoft > Windows > Application Experience, and disable all tasks.

  6. Delete the migration task on the SMS console, create a task for the source server again, and start the migration task.

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