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Why Can't I See Data Disks on a Windows Target Server After Migration?
Updated on 2023-12-20 GMT+08:00
Why Can't I See Data Disks on a Windows Target Server After Migration?
Possible Causes
The SAN policy for the source server OS is Offline Shared. This means the data disks will be offline after migration.
Solutions
- If you do not need to perform a synchronization, you can fix this issue by modifying the target server. For more information, see Solution 1 or Solution 2.
- If you need to perform a synchronization, you can fix this issue by modifying the source server. For more information, see Solution 3. Then perform a synchronization.
Solution 1
- Choose Start > Run.
- Enter diskmgmt.msc and press Enter to open the Disk Management window.
In the following figure, disk 1 is offline.
Figure 1 Offline
- Right-click the offline data disk and select online from the pop-up menu.
Figure 2 Bringing the disk online
Solution 2
- Right-click the Start menu.
- Click Run and enter cmd.
- Run diskpart to start the disk management tool.
- Run list disk to list all disks on the current server. In the following figure, disk 0 is online and disk 1 is offline.
- Run select disk 1.
- Run online disk to change the disk status from offline to online.
- If the disk is read only after it goes online, run the attribute disk clear readonly command to remove the write protection on the disk.
Solution 3
- On the source server, right-click the Start menu.
- Click Run and enter cmd.
- Run diskpart to start the disk management tool.
- Run the san command to query the current disk policy. If SAN Policy: Offline Shared is returned, the disks will be offline by default.
- Run the san policy=onlineAll command to bring disks online by default.
- After the modification, click Sync on the SMS console. After the synchronization is complete, the disks on the target server will be online automatically.
- After the modification is complete on the source server, you do not need to restart the source server.
- The modified disk policy will be synchronized to the target server, and disks on the target server will be brought online automatically. SMS has no requirements on disk policies. You need to determine whether to restore the disk policy of the source server.
Parent topic: Target Server Configuration and Launch
Target Server Configuration and Launch FAQs
- What Are the Differences Between Target and Source Servers After the Migration?
- How Will the Authentication of a Target Server Change?
- How Do I Optimize a Windows Target Server After the Migration Is Complete?
- How Do I Fix the Error "SMS.1113 Failed to reconfigure partition details on the target server" When I Launch the Target Server?
- After a Windows Server Was Migrated, Why Is the Used Space of C: Drive Increased?
- How Do I Uninstall the SMS-Agent from the Source and Target Servers After the Migration Is Complete?
- How Do I Configure the Yum Repository for the Target Server After the Migration Is Complete?
- Why Is the File System Size Inconsistent Before and After the Migration?
- Why Can't I See Data Disks on a Windows Target Server After Migration?
- Why Can't a Windows Target Server Access the Internet After the Migration?
- Why Is the System Recovery Options Window Displayed When the Target Server Is Started?
- How Do I Fix a GRUB Error Because an XFS Volume Is Mounted to the /boot Partition?
- What Do I Do If a Target Server Fails to Be Created?
- How Do I Troubleshoot a MySQL Startup Failure on the Target Server After the Migration?
- How Do I Resolve Error "SELinux targeted" When I Start a Linux Target Server After the Migration Is Complete?
- Why Do the Agent Plug-ins from the Source Cloud Service Provider Exist on the Target Server After the Migration Is Complete?
- Why Is the Usable Memory (RAM) Less Than the Total Installed Memory on a Target Server Running 64-bit Windows?
- After the Migration Is Complete, Will Deleting the Target Server Configuration or Server Record Affect the Source or Target Server?
- How Do I Fix BSOD Errors When I Start a Windows Target Server After the Migration?
- How Do I Fix Startup Failures of a Windows Target Server After the Migration?
- If I Change the Password of the Source Server and Perform an Incremental Replication After the Full Migration Is Complete, Will the New Password Be Synchronized to the Target Server?
- What ECS Types Are Supported by SMS?
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