Help Center> Server Migration Service> FAQs> Known Errors and Solutions> SMS.0202 AK/SK Authentication Failed. Ensure that the AK and SK Are Correct
Updated on 2024-04-24 GMT+08:00

SMS.0202 AK/SK Authentication Failed. Ensure that the AK and SK Are Correct

Symptom

When you started the Agent, the error "SMS.0202 AK/SK authentication failed. Ensure that the AK and SK are correct" was reported.

Possible Causes

Possible causes are:

  • The entered AK or SK is incorrect.
  • The AK/SK pair has been deleted or disabled.
  • The programmatic access method is not enabled for the Huawei Cloud account you used for migration.

Handling Methods

  • The entered AK or SK is incorrect.

    Check whether the entered AK/SK pair of the Huawei Cloud account is correct, especially whether any spaces or characters are missed during the copy. Enter the AK/SK pair for authentication again.

  • The AK/SK pair has been deleted or disabled.
    Choose My Credentials > Access Keys to check whether the AK is in the list.
    • If it is not, use an AK/SK pair in the list for authentication or create an AK/SK pair.
    • If it is, check whether it is disabled. If the AK/SK pair is disabled, enable it.
  • The programmatic access method is not enabled for the Huawei Cloud account you used for migration.
    1. Log in to the management console.
    2. Click the username in the upper right corner and choose Identity and Access Management.
    3. In the navigation pane on the left, choose Users and click the username you used for migration.
    4. In the basic information area, check whether Programmatic access is selected for Access Type.

    5. If it is not, click , select Programmatic access, and click Yes.

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