Why Is Subscription Displayed as "Unsubscribed" Despite Having Already Subscribed to a Service?
Symptom
When I logged in to the OCR console, I noticed that the subscription status for the General Table OCR service, which I had subscribed to for an IAM user, was displaying as Unsubscribed.
Possible Causes
The above operation was performed by the master account or an IAM user (user 1) with full OCR permissions (OCR FullAccess), to individually subscribe to the General Table OCR service for a specific IAM user (user 2), and not for the current account. Therefore, the subscription status on the current page will not change.
Solution
Log in to the OCR account as user 2. You will find the subscription status is Subscribed.
If a master account or an IAM user with full OCR permissions (OCR FullAccess) needs to subscribe to an OCR service for themselves, they do so by accessing the subscription management dialog box and subscribing to the service for their own account or an account marked as Everyone. Subscribing to a service for Everyone will subscribe to the service for all IAM users under this account, including any future IAM users who may be added.
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